Guest

Cisco IOS Software Releases 12.4 Special and Early Deployments

1-, 2-, and 4-Port T1/E1 HWICs and 8-Port T1/E1 Network Module

  • Viewing Options

  • PDF (270.6 KB)
  • Feedback
1-, 2-, and 4-Port T1/E1 HWICs and 8-Port T1/E1 Network Module

Table Of Contents

1-, 2-, and 4-Port T1/E1 HWICs and 8-Port T1/E1 Network Module

Contents

Restrictions for T1/E1 HWICs and Network Module

Information About T1/E1 HWICs and Network Module

Interface Numbering on Cisco 2800 and Cisco 3800 Series Routers

How to Configure T1/E1 HWICs and Network Module

Configuring Card Type

Changing Card Type

Configuring the T1/E1 HWICs or Network Module

Configuration Examples for T1/E1 HWICs and Network Module

4-Port T1 HWIC: Example

4-Port E1 HWIC: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

controller

Feature Information for T1/E1 HWICs and Network Modules


1-, 2-, and 4-Port T1/E1 HWICs and 8-Port T1/E1 Network Module


First Published: November 22, 2007
Last Updated: July 11, 2008

This document describes the following Cisco products:

Cisco 1-Port and 2-Port Channelized T1/E1 and ISDN PRI High Speed WAN Interface Cards (HWICs)

1-port part number: HWIC-1CE1T1-PRI

2-port part number: HWIC-2CE1T1-PRI

Provides channelized T1 or E1 connections or ISDN PRI connections

Supported on Cisco 2821, and 2851 routers, and on Cisco 3800 series routers

Cisco 4-Port T1/E1 HWIC

Part number: HWIC-4T1/E1

Provides clear channel T1 or E1 connections

Supported on 2821, and 2851 routers, and on Cisco 3800 series routers

Cisco 8-Port Channelized T1/E1 and ISDN PRI High Speed WAN Network Module

Part number: NM-8CE1T1-PRI

Provides channelized T1 or E1 connections or ISDN PRI connections

Supported on Cisco 3800 series routers

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for T1/E1 HWICs and Network Modules" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Restrictions for T1/E1 HWICs and Network Module

Information About T1/E1 HWICs and Network Module

How to Configure T1/E1 HWICs and Network Module

Configuration Examples for T1/E1 HWICs and Network Module

Additional References

Command Reference

Feature Information for T1/E1 HWICs and Network Modules

Restrictions for T1/E1 HWICs and Network Module

The Cisco 2811 does not support the HWIC-4T1/E1 module.

Voice features are not supported on the HWICs or the network module.

Wetting current is not supported on the HWICs or the network module.

V54 loop up/down code recognition is not supported on the HWICs or the network module.

The 1-port and 2-port HWICs support up to 32 channels per port (up to 64 channels total on the 2-port HWIC).

The 4-port clear channel HWIC supports 1 channel per port, or 4 channels total for the HWIC.

The 8-port network module is supported only on Cisco 3800 series routers (the Cisco 3825 and Cisco 3845 routers).

The 8-port network module supports a maximum of 128 channels.

Bit Error Rate Tester (BERT) runs on the entire controller and not on specific channel groups. Because of this, only a limited number of patterns are supported. See the "Configuring the T1/E1 HWICs or Network Module" section for more details.

Information About T1/E1 HWICs and Network Module

To configure the T1/E1 HWICs and network module, you should understand the following:

Interface Numbering on Cisco 2800 and Cisco 3800 Series Routers

Interface Numbering on Cisco 2800 and Cisco 3800 Series Routers

Table 1 summarizes the interface numbering on Cisco 2811, 2821, and 2851 routers and on Cisco 3800 series routers. Table 2 gives the port numbering for the T1/E1 HWICs and network module.

Table 1 Interface Numbering on Cisco 2800 and Cisco 3800 Series Routers

Router
HWIC Interfaces
Network Module Interfaces

2811, 2821, and 2851

0/HWIC slot/port1

No support for the 8-port T1/E1 network module.

3825

0/HWIC slot/port1

Network module slot/port2

3845

0/HWIC slot/port1

Network module slot/port3

1 Interface numbering for HWIC interfaces on all routers begins with 0. Then, each router has four HWIC slots that are numbered from 0 to 3.

2 The 3825 router has two network module slots, numbered 1 to 2.

3 The 3845 router has four network module slots, numbered 1 to 4.


For illustrations of HWIC slots in the Cisco 2811, 2821, and 2851 routers, see Overview of Cisco 2800 Series Routers.

For illustrations of HWIC and network module slots in the Cisco 3825 and 3845 routers, see Overview of Cisco 3800 Series Routers.

Table 2 Port Numbering on T1/E1 HWICs and Network Module

Interface
Port Numbering

1-port T1/E1 HWIC

0

2-port T1/E1 HWIC

0 to 1

4-port T1/E1 HWIC

0 to 3

8-port T1/E1 network module

0 to 7


Some examples are as follows:

Port 0 of an HWIC in HWIC slot 0: 0/0/0

Port 1 of a 2- or 4-port HWIC in HWIC slot 1: 0/1/1

Port 3 of the 4-port HWIC in HWIC slot 2: 0/2/3

Port 6 of the 8-port network module in network module slot 2: 2/6

How to Configure T1/E1 HWICs and Network Module

Configuring Card Type

Changing Card Type

Configuring the T1/E1 HWICs or Network Module

Configuring Card Type

To configure the T1/E1 HWICs and network module for T1 or E1 operation, perform the following tasks.


Note The T1/E1 HWICs or network module will not be operational until a card type is configured.


SUMMARY STEPS

1. enable

2. configure terminal

3. card type {t1 | e1} slot subslot

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

card type {t1 | e1} slot subslot

Example:

Router(config)# card type t1 0 2

Specifies T1 or E1 connectivity. slot refers to the network module slot on the 2800 series and 3800 series platform. subslot refers to the HWIC slot on the platform. See the "Interface Numbering on Cisco 2800 and Cisco 3800 Series Routers" section.

Changing Card Type

To change a card type from T1 to E1, or from E1 to T1, perform the following tasks:

SUMMARY STEPS

1. enable

2. configure terminal

3. no card type {t1 | e1} slot subslot

4. card type {t1 | e1} slot subslot

5. write

6. reload

7. boot

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

no card type {t1 | e1} slot subslot

Example:

Router(config)# no card type t1 0 2

Optional. Removes the previously configured card type for the HWIC or network module.

Step 4 

card type {t1 | e1} slot subslot

Example:

Router(config)# card type e1 0 2

Specifies T1 or E1 connectivity for the HWIC or network module.

Step 5 

write

Example:

Router(config)# write

Rebuilds the router configuration.

Step 6 

reload

Example:

Router(config)# reload

Reloads router so that changes can take affect.

After this command executes, the router will go to ROM monitor (rommon) mode.

Step 7 

boot

Example:

Router(rommon)# boot

Boots the router for the configuration with the newly selected card type.

Configuring the T1/E1 HWICs or Network Module

To configure the T1/E1 HWICs or network module, perform the following tasks:

SUMMARY STEPS

1. enable

2. configure terminal

3. network-clock-participate [slot slot-number | wic wic-slot]

4. controller {t1 | e1} slot/subslot/port

5. framing {sf | esf}

or

framing {crc4 | no-crc4}

6. linecode {ami | b8zs}

or

linecode {ami | hdb3}

7. fdl {att | ansi | both}

8. clock source {line | internal}

9. line-termination {75-ohm | 120-ohm}

10. loopback {diagnostic | local {payload | line} | remote {iboc | esf {payload | line}}}

11. cablelength long db-loss-value

or

cablelength short length

12. channel group channel-group-number {timeslots range [speed kbps] | unframed}

or

pri-group timeslots timeslot-range [nfas_d | service]

or

tdm-group tdm-group-no timeslots timeslot-range

13. national reserve N sa4 sa5 sa6 sa7 sa8

14. crc-threshold value

15. yellow {generation | detection}

16. bert pattern pattern interval time

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

network-clock-participate [slot slot-number | wic wic-slot]

Example:

Router(config)# network-clock-participate wic 0

TDM group configuration only. Allows the ports on a specified network module or interface card to use the network clock for timing.

Step 4 

controller {t1 | e1} slot/subslot/port

Example:

Router(config)# controller t1 1/0

Enters controller configuration mode. For interface numbering conventions on the Cisco 2800 and 3800 series routers, see the "Interface Numbering on Cisco 2800 and Cisco 3800 Series Routers" section.

Step 5 

framing {sf | esf}


or

framing {crc4 | no-crc4}

Example:

Router(config-controller)# framing esf

In T1 configurations, specifies super frame (sf) or extended super frame (esf) as the frame type for data lines. Default is esf.

In E1 configurations, specifies cyclic. redundancy check 4 (crc4) or no-crc4 as the frame type for data lines. Default is crc4.

Step 6 

linecode {ami | b8zs}


or

linecode {ami | hdb3}

Example:

Router(config-controller)# linecode b8zs

In T1 configurations, specifies alternate mark inversion (AMI) or b8zs as the linecode. Default is b8zs.

In E1 configurations, specifies AMI or high-density bipolar 3 (hdb3) as the linecode. Default is hdb3.

Note When using linecode AMI, the user is advised to select 56 kbps as the speed or make sure that the channel groups created do not contain all the timeslots. See Step 12. This is to avoid exceeding the "15 zeroes" threshhold specified by standards.

Step 7 

fdl {att | ansi | both}

Example:

Router(config-controller)# fdl both

T1 only. Sets the facility data link (fdl) exchange standard for T1 interfaces using esf framing. Can select the ATT standard (ATT TR54016), the ANSI standard (ANSI T1.403), or both standards. Default is ansi. To disable fdl, enter the command no fdl.

Step 8 

clock source {line [independent] | internal}

Example:

Router(config-controller)# clock source line

line specifies that the clocking on this controller is derived from an external source, generally the telephone central office. line independent configures the port to be independent in the TDM docmain, which is when network-clock-participate is configured on the card.

internal specifies that the clock is generated by internal controller circuitry.

Default is line.

Step 9 

line-termination {75-ohm | 120-ohm}

Example:

Router(config-controller)# line-termination 75-ohm

E1 only. Sets the line termination on an E1 controller.

75-ohm specifies the 75 ohm unbalanced termination.

120-ohm specifies the 120 ohm balanced termination.

Default is 120-ohm.

Note On the 4-port HWIC and 8-port network module, line impedance will be set to the same value for each port in a two-port slice automatically. That is, on the 4-port HWIC, ports 0 and 1 will be set to the same value, and ports 2 and 3 will be set to the same value. On the 8-port network module, ports 0 and 1 will be set to the same value, as will ports 2 and 3, ports 4 and 5, and ports 6 and 7. In these cases, a message will be displayed. The example here shows the message displayed when the line termination on port 0 is changed:
Router(config)# controller e1 0/1/0
Router(config-controller)#line-termination 75-ohm
Changing the line termination for ports 0 and 1 to 75

Step 10 

loopback {diagnostic | local {payload | line} | remote {iboc | esf {payload | line}}}

Example:

Router(config-controller)# loopback remote esf line

Sets the loopback method for testing the interface. Options are:

diagnostic loops transmit signal back to receive

local puts the interface into local loopback mode at the payload or line level

remote puts the interface into remote loopback mode through an inband bit oriented code (iboc) or, for T1 only, remote esf, which uses fdl codes to set payload or line levels.

Step 11 

cablelength long db-loss-value


or

cablelength short length

Example:

Router(config-controller)# cablelength short 133

T1 only. cablelength long attenuates the pulse from the transmitter using pulse equalization and line build-out. This command applies to cables longer than 660 feet. Loss values are:

0db

-7.5db

-15db

-22.5db

Default attenuation is 0db.

cablelength short sets transmission attenuation for cable lengths of 660 feet or less. Cable lengths can be specified as follows:

110 for cable lengths from 0 to 110 feet

220 for cable lengths from 110 to 220 feet

330 for cable lengths from 220 to 330 feet

440 for cable lengths from 330 to 440 feet

550 for cable lengths from 440 to 550 feet

660 for cable lengths from 550 to 660 feet

There is no default cable length.

Step 12 

channel group channel-group-number {timeslots range [speed kbps] | unframed}


or

pri-group timeslots timeslot-range



or

tdm-group tdm-group-no timeslots timeslot-range

Example:

Router(config-controller)# channel group 1 timeslots 1-4

Note This step does not apply to the clear channel 4-port T1/E1 HWIC.

Configures the serial WAN on a T1 or E1 interface by specifying channels and their timeslots.

For T1, values are as follows:

channel-group-number is from 0 to 23

timeslots range is from 1 to 24

Default value of speed in T1 is 64 kbps. Configuration of speed is optional.

For E1, values are as follows:

channel-group-number is from 0 to 30

timeslots range is from 1 to 31

Default value of speed in E1 is 64 kbps. Configuration of speed is optional.

unframed (E1 only) specifies that all 32 timeslots are to be used for data, and that none are to be used for framing signals.

or

Configures specified timeslots on T1 or E1 interfaces for PRI for transporting ISDN data.

or

Configures specified timeslots on T1 or E1 interfaces to create clear chanel groups for time division multiplexing.

For the tdm-group configuration to work, it is necessary to configure network-clock-participate for the interface in global configuration mode.

Step 13 

national reserve N sa4 sa5 sa6 sa7 sa8

Example:

Router(config-controller)# national reserve 0 1 1 1 1 0

E1 only. Sets the 6 required national bits in E1 in the G.751 frame. Default is 1 1 1 1 1 1.

Step 14 

crc-threshold value

Example:

Router(config-controller)# crc-threshold 500

T1 only. Defines a severely errored second by specifying the number of crc errors that must occur in one second to reach the severely errored state. Default is 320.

Step 15 

yellow {generation | detection}

Example:

Router(config-controller)# no yellow detection

Enables generation and detection of yellow alarms. Default condition is that generation and detection of yellow alarms are enabled.

Use the no form of the command to disable yellow alarm detection.

Step 16 

bert pattern pattern interval time



Example:

Router(config-controller)# bert 2^11 interval 1440

Optional. Activates the Bit Error Rate Tester (bert) with the chosen test pattern for a specified duration.

Configure bert patterns on T1/E1 HWICs or network module as follows:

When the linecode is AMI, use patterns 2^11, 2^15, or 2^20-QRSS.

When the linecode is b8zs or hdb3, use patterns 2^11, 2^15, 2^20-QRSS, or 2^20-O.153.

Note If any other bert pattern is chosen, an error message will appear that lists the supported patterns for the configured linecode. A complete listing of bert patterns is in the Cisco IOS Master Commands List, Release 12.4.

interval time is from 1 to 14,400 minutes.

Configuration Examples for T1/E1 HWICs and Network Module

This section shows configuration examples for the 4-port HWIC in both T1 and E1 configurations.

4-Port T1 HWIC: Example

4-Port E1 HWIC: Example

4-Port T1 HWIC: Example

In this example, the 4-port HWIC is set to card type T1, and is configured with default settings. Channel groups are defined on ports 0, 1, and 2.

router#show running-config
Building configuration...

Current configuration : 1454 bytes
!
! Last configuration change at 09:49:03 UTC Tue Sep 19 2006
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname router
!
boot-start-marker
boot-end-marker
!
card type t1 0 2
!
no aaa new-model
!
resource policy
!
no network-clock-participate wic 2
!
ip cef
!
!
!
voice-card 0
 no dspfarm
!
!
!
controller T1 0/2/0
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 1 timeslots 5
!
controller T1 0/2/1
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 2 timeslots 10
!
controller T1 0/2/2
 framing esf
 linecode b8zs
 cablelength long 0db
 channel-group 3 timeslots 15
!
controller T1 0/2/3
 framing esf
 linecode b8zs
 cablelength long 0db
!
!
!
interface GigabitEthernet0/0
 ip address 1.7.7.12 255.255.0.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 ip address 20.20.20.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface Serial0/2/0:1
 no ip address
!
interface Serial0/2/1:2
 no ip address
!
interface Serial0/2/2:3
 no ip address
!
ip default-gateway 1.7.0.1
ip route 223.255.254.0 255.255.255.0 GigabitEthernet0/0
!
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

router#

The command show controllers t1 gives the following output.

router# show controllers t1
T1 0/2/0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (889 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     1 Line Code Violations, 2 Path Code Violations,
     0 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
     1 Errored Secs, 0 Bursty Err Secs, 1 Severely Err Secs, 0 Unavail Secs
T1 0/2/1 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (892 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
T1 0/2/2 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (893 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
T1 0/2/3 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  No alarms detected.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (896 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
router#

4-Port E1 HWIC: Example

In this example, the 4-port HWIC is set to card type E1, and is configured with default settings. A channel group is defined on port 0. The command show running-config gives the following output.

router# show running-config
Building configuration...

Current configuration : 1192 bytes
!
! Last configuration change at 01:18:52 UTC Wed Sep 20 2006
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname router
!
boot-start-marker
boot-end-marker
!
card type e1 0 2
!
no aaa new-model
!
resource policy
!
no network-clock-participate wic 2
!
ip cef
!
!
!
voice-card 0
 no dspfarm
!
!
!
controller E1 0/2/0
channel-group 1 timeslots 5
national reserve 0 1 1 1 1 0
!
controller E1 0/2/1
!
controller E1 0/2/2
!
controller E1 0/2/3
!
!
!
interface GigabitEthernet0/0
 ip address 1.7.7.12 255.255.0.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 ip address 20.20.20.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface Serial0/2/0:1
 no ip address
!
ip default-gateway 1.7.0.1
ip route 223.255.254.0 255.255.255.0 GigabitEthernet0/0
!
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end
router#

The command show controllers e1 gives the following output.

router#show controllers e1
E1 0/2/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  International Bit: 0, National Bits: 11110
  Data in current interval (621 seconds elapsed):
     5 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 2 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
E1 0/2/1 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (630 seconds elapsed):
     5 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
E1 0/2/2 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (648 seconds elapsed):
     4 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
E1 0/2/3 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info FPGA Rev: 06080409, FPGA Type: PRK4
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (660 seconds elapsed):
     56 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
router

Additional References

The following sections provide references related to the T1/E1 HWICs and Network Module feature.

Related Documents

Related Topic
Document Title

Hardware installation of network modules

Cisco Network Modules Hardware Installation Guide

CLI Commands Reference

Cisco IOS Master Commands List, Release 12.4


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards have not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs have not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs have not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Command Reference

This section documents only commands that are modified.

controller

controller

To configure a T1, E1, or J1 controller and enter controller configuration mode, use the controller command in global configuration mode.

Cisco 2600 and 3600 Series Routers

controller {t1 | e1 | j1} slot/port

Cisco 7200 Series and Cisco 7500 Series Routers

controller {t1 | e1} slot/port

Cisco AS5300 Access Servers

controller {t1 | e1} number

Cisco AS5800 Access Servers

controller t1 dial-shelf/slot/t3-port:t1-num

Cisco 2800 and 3800 Series Routers

controller {t1 | e1} slot/subslot/port

Syntax Description

t1

T1 controller.

e1

E1 controller.

j1

J1 controller.

slot/port

Backplane slot number and port number on the interface. Refer to your hardware installation manual for the specific values and slot numbers.

slot/subslot/port

Backplane slot number, subslot number, and port number on the interface. Refer to your hardware installation guide for the specific values, and slot and subslot numbers.

number

Network processor module (NPM) number, in the range 0 through 2.

dial-shelf

Dial shelf chassis in the Cisco AS5800 access server that contains the interface card.

/t3-port

T3 port number. The only valid value is 0.

:t1-num

T1 timeslot in the T3 line. The value can be from 1 to 28.


Defaults

No T1, E1, or J1 controller is configured.

Command Modes

Global configuration

Command History

Release
Modification

10.0

This command was introduced.

10.3

The e1 keyword was added.

12.0(3)T

Support was added for dial shelves on Cisco AS5800 access servers.

12.2(7)XO

The j1 keyword was added for the Cisco 2600 and Cisco 3600 series.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.4(11)XW

The subslot argument was added for the Cisco 2800 and Cisco 3800 series.


Usage Guidelines

T1 or E1 Fractional Data Lines

This command is used in configurations where the router or access server is intended to communicate with a T1 or E1 fractional data line. Additional parameters for the T1 or E1 line must be configured for the controller before the T1 or E1 circuits can be configured by means of the interface global configuration command.

To view the status of the controllers use the show controllers command.

Examples

Cisco 7500 Series Router As a T1 Controller

The following example configures the MIP in slot 4, port 0 of a Cisco 7500 series router as a T1 controller:

Router(config)# controller t1 4/0
Router(config-controller)#

Cisco AS5800 Access Server with Dial Shelf

The following example configures the T1 controller in shelf 1, slot 0, port 0:

Router(config)# controller t1 1/0/0:1
Router(config-controller)#

Cisco 3660 As a J1 Controller

The following example configures the Cisco IOS interface card in slot 3, port 0 of a Cisco 3660 as a J1 controller:

Router(config)# controller j1 3/0
Router(config-controller)#

Related Commands

Command
Description

bert abort

Resets the T1 or E1 controller.

interface serial

Specifies a serial interface created on a channelized E1 or channelized T1 controller (for ISDN PRI, CAS, or robbed-bit signaling).

show controllers content-engine

Displays information about the E1 links supported by the NPM
(Cisco 4000) or MIP (Cisco 7500 series).

show controllers j1

Displays information about the J1 link.

show controllers t1

Displays the total number of calls and call durations on a T1 controller.


Feature Information for T1/E1 HWICs and Network Modules

Table 3 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 3 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 3 Feature Information for T1/E1 HWICs and Network Module 

Feature Name
Releases
Feature Information

T1/E1 HWICs and 8-Port T1/E1 Network Module

12.4(11)XW5 12.4(20)T

T1/E1 HWICs are available as follows:

Channelized 1-port T1/E1 HWIC

Channelized 2-port T1/E1 HWIC

Clear channel 4-port T1/E1 HWIC

The T1/E1 network module is available as an 8-port channelized T1/E1 network module.

T1/E1 HWICs are supported on Cisco 2811, 2821, and 2851 routers, and on Cisco 3800 series routers.

The T1/E1 network module is supported on Cisco 3800 series routers.