Guest

Cisco IOS Software Releases 12.2 SB

Multi-VRF Support (VRF Lite)

  • Viewing Options

  • PDF (342.5 KB)
  • Feedback
Configuring MPLS Multi-VRF (VRF-lite)

Table Of Contents

Configuring MPLS Multi-VRF
(VRF-lite)

Contents

Prerequisites for MPLS Multi-VRF

Restrictions with MPLS Multi-VRF

Understanding MPLS Multi-VRF

Overview of MPLS Multi-VRF Configuration

How to Configure MPLS Multi-VRF

Configuring VRFs

Default VRF Configuration

Restrictions

What to Do Next

Configuring a VPN Routing Session

Prerequisites

Restrictions

What to Do Next

Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is not the routing protocol)

What to Do Next

Configuring BGP PE-to-CE Routing Sessions

What to Do Next

Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is the routing protocol)

Prerequisites

What to Do Next

Displaying MPLS Multi-VRF Status

Configuration Example of MPLS Multi-VRF

On the PE Router

On the CE Router

Additional References

Related Documents

Technical Assistance

Command Reference


Configuring MPLS Multi-VRF
(VRF-lite)


MPLS Multi-VRF provides the ability to configure and maintain more than one instance of a routing and forwarding table within the same CE router.

History of the MPLS Multi-VRF feature

Release
Modification

Release12.1(11)EA1

The Multi-VRF feature was introduced.

Release12.1(20)EW

The feature was integrated into the 12.1(20)EW release.

Release12.2(4)T

The feature was integrated into the T train.

Release12.2(8)YN

The feature was integrated into the Y train.

Release12.2(18)SXD

The feature was integrated into the S train.

Release 12.2(25)EWA

The feature was integrated into the 12.2(25)EWA release.

Release 12.2(28)SB

MPLS support was added.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for MPLS Multi-VRF

Restrictions with MPLS Multi-VRF

Understanding MPLS Multi-VRF

How to Configure MPLS Multi-VRF

Displaying MPLS Multi-VRF Status

Configuration Example of MPLS Multi-VRF

Prerequisites for MPLS Multi-VRF

The network's core and provider edge routers must be properly configured for MPLS VPN operation.

Restrictions with MPLS Multi-VRF

MPLS Multi-VRF can be configured only on Layer 3 interfaces.

MPLS Multi-VRF is not supported by IGRP nor ISIS.

Label distribution for a given VRF on a given router can be handled by either BGP or LDP, but not by both protocols.

Multicast cannot operate on a Layer 3 interface already configured with MPLS Multi-VRF.

Understanding MPLS Multi-VRF

Multi-VRF is a feature that enables a service provider to support two or more VPNs, where IP addresses can be overlapped among the VPNs. Multi-VRF uses input interfaces to distinguish routes for different VPNs, and forms virtual packet-forwarding tables by associating one or more Layer 3 interfaces with each VRF. Interfaces in a VRF can be either physical, such as Ethernet ports, or logical, such as VLAN SVIs (Switched Virtual Interfaces), but a Layer 3 interface cannot belong to more than one VRF at any one time. The Multi-VRF feature thus allows an operator to support two or more routing domains on a CE router, with each routing domain having its own set of interfaces and its own set of routing and forwarding tables. MPLS Multi-VRF makes it possible to extend the Label Switched Paths (LSPs) to the CE and into each routing domain that the CE supports.

MPLS Multi-VRF occurs through the activity of routers fulfilling the following roles:

Each customer edge (CE) router advertises its site's local routes to a provider edge (PE) router, and learns the remote VPN routes from that PE router.

PE routers exchange routing information with CE routers by using static routing or a routing protocol such as BGP, RIPv1, or RIPv2.

PE routers exchange MPLS label information with CE routers through LDP or BGP.

The PE needs to maintain VPN routes only for those VPNs to which it is directly attached, eliminating the requirement that the PE maintain all of the service provider's VPN routes. Each PE router maintains a VRF for each of its directly-connected sites. Two or more interfaces on a PE router can be associated with a single VRF if all the sites participate in the same VPN. Each VPN is mapped to a specified VRF. After learning local VPN routes from CEs, the PE router exchanges VPN routing information with other PE routers through internal BGP (IBPG).

With Multi-VRF, two or more customers can share one CE, and only one physical link is used between the CE and the PE. The shared CE maintains separate VRF tables for each customer, and routes packets for each customer based on that customer's own routing table. Multi-VRF thereby extends limited PE functionality to a CE device, giving it the ability, through the maintenance of separate VRF tables, to extend the privacy and security of a VPN to the branch office.

Figure 1 shows a configuration where each CE acts virtually as if it were two CEs. Because MPLS Multi-VRF is a Layer 3 feature, each interface associated with a VRF must be a Layer 3 interface.

Figure 1 Each CE router acting as several virtual CEs

Following is the packet-forwarding process in an MPLS Multi-VRF CE-enabled network, as illustrated in Figure 1:

When the CE receives a packet from a VPN, it looks up the routing table based on the input interface. When a route is found, the CE imposes the MPLS label it received from the PE for that route and forwards the packet to the PE.

When the ingress PE receives a packet from the CE, it swaps the incoming label with the corresponding label stack and sends it to the MPLS network.

When an egress PE receives a packet from the network, it swaps the VPN label with the label it earlier had received for the route from the CE, and forwards it to the CE.

When a CE receives a packet from an egress PE, it uses the incoming label on the packet to forward the packet to the correct VPN.

Overview of MPLS Multi-VRF Configuration

To configure Multi-VRF, you create a VRF table and then specify the Layer 3 interface associated with that VRF. Next, you configure the routing protocols within the VPN, and between the CE and the PE. BGP is the preferred routing protocol for distributing VPN routing information across the provider's backbone, for reasons that will be detailed in the section, How to Configure MPLS Multi-VRF.

The Multi-VRF network has three major components:

VPN route target communities: These are lists of all other members of a VPN community. You need to configure VPN route targets for each VPN community member.

Multiprotocol BGP peering of VPN community PE routers: This propagates VRF reachability information to all members of a VPN community. You need to configure BGP peering in all PE routers within a VPN community.

VPN forwarding: This transports all traffic between VPN community members across a VPN service-provider network.

How to Configure MPLS Multi-VRF

Consider these points when configuring MPLS Multi-VRF in your network:

A router with Multi-VRF is shared by several customers, and each customer has their own routing table(s).

Because each customer uses a different VRF table, the same IP addresses can be reused. Overlapped IP addresses are allowed in different VPNs.

MPLS Multi-VRF lets several customers share the same physical link between the PE and the CE. Trunk ports with several VLANs separate packets among the customers. Each customer has their own VLAN.

For the PE router, there is no difference between using MPLS Multi-VRF or using several CEs. In Figure 2 for example, four virtual Layer 3 interfaces are connected to the MPLS Multi-VRF CE.

MPLS Multi-VRF does not affect the packet switching rate.

Most routing protocols can be used between the CE and the PE: BGP, OSPF, EIGRP, RIP, and static routing. However, we recommend using external BGP (eBGP) because:

BGP does not require more than one algorithm to communicate with a multitude of CEs.

BGP is designed to pass routing information between systems run by different administrations.

BGP makes it easy to pass attributes of the routes to the CE.

Furthermore, when BGP is used as the routing protocol, it can also be used to handle the MPLS label exchange between the PE and CE. By contrast, if OSPF, EIGRP, RIP or static routing is used, LDP must be used to signal labels.

If you choose to use OSPF as the routing protocol between the PE and the CE, you should employ the capability vrf-lite subcommand under router ospf. How to do so is explained further in OSPF Support for Multi-VRF in CE Routers, Release 12.2(14)S.

The following sections present the sequence of commands required to configure Multi-VRF:

First, set up each customer's VRFs on the CE and on the PE, as explained in the "Configuring VRFs" section.

Then configure the routing protocol within the VPNs on the CE: Configuring a VPN Routing Session.

Next, configure the routing protocol between the CE and PE. BGP is recommended, so its case is given in the "Configuring BGP PE-to-CE Routing Sessions" section. But other protocols, such as OSPF, RIP or EIGRP, and static routing could be used.

Finally, establish the correct MPLS label exchange, (which differs according to the routing protocol you used in the previous sections); either:

Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is the routing protocol)

or

Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is not the routing protocol)

Configuring VRFs

VRFs must be configured on both the PE and the CE routers.

Default VRF Configuration

If no commands have yet been entered to specify a VRF, the system's default configuration is as detailed in Table 1.

Table 1 Default VRF Configuration

Feature
Default Setting

VRF

Disabled. No VRFs are defined.

Maps

No import maps, export maps, or route maps are defined.

VRF maximum routes

None.

Forwarding table

The default for an interface is the global routing table.


Restrictions

Multicast cannot be configured at the same time on the same Layer 3 interface as MPLS Multi-VRF.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip routing

4. ip vrf vrf-name

5. rd route-distinguisher

6. route-target {export | import | both} route-target-ext-community

7. import map route-map

8. exit

9. interface interface-id

10. ip vrf forwarding vrf-name

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Opens global configuration mode.

Step 3 

ip routing

Example:

Router(config)# ip routing

Enables IP routing.

Step 4 

ip vrf vrf-name

Example:

Router(config)# ip vrf v1

Names the VRF, and opens VRF configuration mode.

Step 5 

rd route-distinguisher

Example:

Router(config-vrf)# rd 100:1

Creates a VRF table by specifying a route distinguisher. Enter either an AS number and an arbitrary number (xxx:y), or an IP address and an arbitrary number (A.B.C.D:y).

Step 6 

route-target { export | import | both } route-target-ext-community

Example:

Router(config-vrf)# route-target export 100:1

Router(config-vrf)# route-target import 100:1

Creates a list of import, export, or import and export route target communities for the specified VRF.
Enter either an AS system number and an arbitrary number (xxx:y), or an IP address and an arbitrary number (A.B.C.D:y).

Note: This command is effective only if BGP is running.

Step 7 

import map route-map

Example:

Router(config-vrf)# import map blue_import_map

(Optional) Associates a route map with the VRF.

Step 8 

exit

Example:

Router(config-vrf)# exit

Returns to global configuration mode.

Step 9 

interface interface-id

Example:

Router(config)# interface fastethernet3/0.10

Specifies the Layer 3 interface to be associated with the VRF and opens interface configuration mode. The interface can be a routed port or an SVI.

Step 10 

ip vrf forwarding vrf-name

Example:

Router(config-if)# ip vrf forwarding v1

Associates the VRF with the Layer 3 interface.

What to Do Next

To confirm that the VRF has been configured correctly, use the EXEC mode show ip vrf [brief | detail | interfaces] [vrf-name] command.

If the output display of that show command reveals everything to be alright, you can then choose to save the configuration by entering the copy running-config startup-config command.

Configuring a VPN Routing Session

Routing within the VPN can be configured on the CE router with any supported routing protocol (RIP, OSPF, or BGP), or with static routing. The configuration shown here is for OSPF, but the process is the same with other protocols.

Prerequisites

The VRF referred to in Step 3 of this section must have been configured correctly, as shown in the previous section, Configuring VRFs.

Restrictions

MPLS Multi-VRF is not supported by IGRP nor ISIS.

Multicast cannot be configured on the same Layer 3 interface as MPLS Multi-VRF.

SUMMARY STEPS

1. enable

2. configure terminal

3. router ospf process-id [vrf vrf-name]

4. log-adjacency-changes

5. redistribute bgp autonomous-system-number subnets

6. network network-number area area-id

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router ospf process-id [vrf vpn-name]

Example:

Router(config)# router ospf 100 vrf v1

Enables OSPF routing, specifies a VRF table, and enters router configuration mode.

[Sometimes you may see the final term in this command spelled as vpn-name . It takes the same value as vrf-name].

Step 4 

log-adjacency-changes

Example:

Router(config-router)# log-adjacency-changes

(Optional) Logs changes in the adjacency state. This is the default state.

Step 5 

redistribute bgp autonomous-system-number subnets

Example:

Router(config-router)# redistribute bgp 800 subnets

Sets the router to redistribute information from the BGP network to the OSPF network.

Step 6 

network network-number area area-id

Example:

Router(config-router)# network 208.0.0.0 255.255.255.0 area 0

Indicates the network address and mask on which OSPF runs, and the area ID of that network address.

What to Do Next

To confirm that the VPN routing has been configured correctly, use the EXEC mode show ip ospf process-id command.

If the output display of that show command reveals everything to be alright, you can then choose to save the configuration by entering the copy running-config startup-config command.

If you need to disassociate the VPN forwarding table from the OSPF routing process, use the no router ospf process-id vrf vpn-name global configuration command.

To complete your configuration of MPLS Multi-VRF in situations where you are not using BGP, continue on to the next section, Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is not the routing protocol). If, however, you will be using BGP, skip to the section called Configuring BGP PE-to-CE Routing Sessions.

Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is not the routing protocol)

If any protocol other than BGP is used for routing between the PE and the CE, LDP should be used to signal the labels on the PE and CE VRF interfaces, as shown here next.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface-id

4. mpls ip

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Opens global configuration mode.

Step 3 

interface interface-id

Example:

Router(config)# interface fastethernet3/0.10

Opens interface configuration mode for the interface associated with the VRF. The interface can be a routed port or an SVI.

Step 4 

mpls ip

Example:

Router(config-if)# mpls ip

Enables MPLS forwarding of IPv4 packets along normally routed paths for this interface.

What to Do Next

If you are not using BGP, you have completed your MPLS Multi-VRF configuration. To see all the steps in context, go to the "Configuration Example of MPLS Multi-VRF" section.

Configuring BGP PE-to-CE Routing Sessions

To configure a BGP PE-to-CE routing session, perform the task presented next on the CE and on the PE.

PSUMMARY STEPS

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. network network-number mask network-mask

5. redistribute ospf process-id match internal

6. network network-number area area-id

7. address-family ipv4 vrf vrf-name

8. neighbor {ip-address | peer-group-name} remote-as as-number

9. neighbor address activate

DETAILED STEPS

 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:
Router# configure terminal

Enters global configuration mode.

Step 3 

router bgp autonomous-system-number

Example:

Router(config)# router bgp 100

Configures the BGP routing process with the AS number passed to other BGP routers, and opens router configuration mode.

Step 4 

network network-number mask 
network-mask
Example:
Router(config-router)# network 
208.0.0.0 mask 255.255.255.0

Specifies a network and mask to announce using BGP.

Step 5 

redistribute ospf process-id match internal

Example:

Router(config-router)# redistribute ospf 2 match internal

Sets the router to redistribute OSPF internal routes.

Step 6 

network network-number area area-id 
Example:
Router(config-router)# network 
208.0.0.0 255.255.255.0 area 0

Identifies the network address and mask on which OSPF is running, and the area ID of that network address.

Step 7 

address-family ipv4 vrf vrf-name
Example:

Router(config-router)# address-family ipv4 vrf v12

Identifies the name of the VRF instance that will be associated with the next two commands, and opens VRF address-family mode.

Step 8 

neighbor {ip-address | peer-group-name} 
remote-as as-number
Example:

Router(config-router-af)# neighbor 83.0.0.3 remote-as 100

Informs this router's BGP neighbor table of the neighbor's address (or peer group name) and the neighbor's autonomous system number.

Step 9 

neighbor address activate

Example:

Router(config-router-af)# neighbor 83.0.0.3 activate

Activates the advertisement of the IPv4 address-family neighbors.

What to Do Next

To confirm that BGP has been correctly configured, use the EXEC mode show ip bgp vpnv4 vrf-name neighbors command.

If the output display of that show command reveals everything to be alright, you can then choose to save the configuration by entering the copy running-config startup-config command.

Because you are using BGP, continue on with the next section's procedure. (Had you used another routing protocol, you would not need to implement the next section— nor of course the current section either.)

Configuring PE-to-CE MPLS Forwarding and Signalling (when BGP is the routing protocol)

If BGP is used for routing anywhere between the PE and the CE, BGP should also be used to signal the labels on the VRF interfaces of both the CE and the PE routers. Doing so consists of two operations:

At the router-configuration level: enabling MPLS label signalling via BGP (which is accomplished with the neighbor address send-label command);

At the interface level: enabling MPLS forwarding on the interface used for the PE-CE eBGP session (which is done with the mpls bgp forwarding command).

Prerequisites

The PE-CE BGP neighbor must be correctly configured for IP.

The PE-CE interface must be correctly configured for IP forwarding.

SUMMARY STEPS

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. address-family ipv4 vrf vrf-name

5. neighbor address send-label

6. end

7. configure terminal

8. interface interface-id

9. mpls bgp forwarding

DETAILED STEPS

 
Command
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router bgp autonomous-system-number

Example:

Router(config)# router bgp 100

Configures the BGP routing process with the AS number passed to other BGP routers, and opens router configuration mode.

Step 4 

address-family ipv4 vrf vrf-name
Example:

Router(config-router)# address-family ipv4 vrf v12

Identifies the name of the VRF instance that will be associated with the next two commands, and opens VRF address-family mode.

Step 5 

neighbor address send-label
Example:

Router(config-router-af)# neighbor 83.0.0.3 remote-as 100

Enables the router to use BGP to distribute MPLS labels along with the IPv4 routes to the peer router(s).

[If a BGP session is running when you issue this command, the command does not take effect until the BGP session is restarted.]

Step 6 

neighbor address activate
Example:

Router(config-router-af)# neighbor 83.0.0.3 activate

Activates the advertisement of the IPv4 address-family neighbors.

Step 7 

end

Example:

Router(config-router-af)# end

Returns to privileged EXEC mode.

Step 8 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 9 

interface interface-id

Example:

Router(config)# interface fastethernet3/0.10

Opens interface configuration mode for the interface to be used for the BGP session. The interface can be a routed port or an SVI.

Step 10 

mpls bgp forwarding

Example:

Router(config-if)# mpls bgp forwarding

Enables MPLS forwarding on the interface.

What to Do Next

You can save the configuration by entering the copy running-config startup-config command.

If you need to delete the BGP routing process, use the no router bgp autonomous-system-number global configuration command. However, if you want to delete only particular routing characteristics, enter the router bgp global configuration command, followed by the no form of the particular router configuration command which governs that characteristic.

Displaying MPLS Multi-VRF Status

To display information about MPLS Multi-VRF configuration and status, use any of the following commands:

show ip bgp vpnv4 vrf labels, to display the BGP labels for the specified VRF.

show ip protocols vrf, to display routing protocol information associated with the specified VRF.

show ip route vrf, to display the IP routing table information associated with the specified VRF.

show ip vrf, to display the set of VRFs and their associated interfaces.

show mpls forwarding-table vrf, to display the MPLS forwarding entries associated with the specified VRF.

show mpls ldp bindings vrf, to display LDP's label information base for the specified VRF.

Detailed information about each of these commands is given in the Cisco IOS MultiProtocol Label Switching Command Reference.

Configuration Example of MPLS Multi-VRF

The following example details the configuration on the CE, and on the PE-to-CE connections only, not on the PE-to-core connections because these latter are no different in Multi-VRF cases than in other cases.

Figure 2

MPLS Multi-VRF Configuration Example

On the PE Router

VRF Configuration

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip vrf v1
Router(config-vrf)# rd 100:1
Router(config-vrf)# route-target export 100:1
Router(config-vrf)# route-target import 100:1
Router(config-vrf)# exit
Router(config)# ip vrf v2
Router(config-vrf)# rd 100:2
Router(config-vrf)# route-target export 100:2
Router(config-vrf)# route-target import 100:2
Router(config-vrf)# exit

Configuring PE-CE connections using BGP for both routing and label exchange

Router(config)# router bgp 100
Router(config-router)# address-family ipv4 vrf v2
Router(config-router-af)# neighbor 83.0.0.8 remote-as 800
Router(config-router-af)# neighbor 83.0.0.8 activate
Router(config-router-af)# neighbor 83.0.0.8 send-label
Router(config-router-af)# exit
Router(config-router)# address-family ipv4 vrf vl
Router(config-router-af)# neighbor 38.0.0.8 remote-as 800
Router(config-router-af)# neighbor 38.0.0.8 activate
Router(config-router-af)# neighbor 38.0.0.8 send-label
Router(config-router-af)# end

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet3/0.10
Router(config-if)# ip vrf forwarding v1
Router(config-if)# ip address 38.0.0.3 255.255.255.0
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit
Router(config)# interface fastethernet3/0.20
Router(config-if)# ip vrf forwarding v2
Router(config-if)# ip address 83.0.0.3 255.255.255.0
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit

Configuring PE-CE connections using OSPF for routing, and LDP for label exchange

Router(config)# router ospf 100 vrf v1
Router(config-router)# network 38.0.0.0 255.255.255.0 area 0
Router(config-router)# exit

Router(config)# router ospf 101 vrf v2
Router(config-router)# network 83.0.0.0 255.255.255.0 area 0
Router(config-router)# exit

Router(config)# interface fastethernet3/0.10
Router(config-if)# ip vrf forwarding v1
Router(config-if)# ip address 38.0.0.3 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# exit

Router(config)# interface fastethernet3/0.20
Router(config-if)# ip vrf forwarding v2
Router(config-if)# ip address 83.0.0.3 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# exit

On the CE Router

VRF Configuration

Router# configure terminal
	Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip routing
Router(config)# ip vrf v11
Router(config-vrf)# rd 800:1
Router(config-vrf)# route-target export 800:1
Router(config-vrf)# route-target import 800:1
Router(config-vrf)# exit
Router(config)# ip vrf v12
Router(config-vrf)# rd 800:2
Router(config-vrf)# route-target export 800:2
Router(config-vrf)# route-target import 800:2
Router(config-vrf)# exit

Configuring CE VPN connections

Router(config)# interface fastethernet3/8
Router(config-if)# ip vrf forwarding v11
Router(config-if)# ip address 208.0.0.8 255.255.255.0
Router(config-if)# exit
Router(config)# interface fastethernet3/7
Router(config-if)# ip vrf forwarding v11
Router(config-if)# ip address 108.0.0.8 255.255.255.0
Router(config-if)# exit
Router(config)# interface fastethernet3/11
Router(config-if)# ip vrf forwarding v12
Router(config-if)# ip address 118.0.0.8 255.255.255.0
Router(config-if)# exit
Router(config)# interface fastethernet3/3
Router(config-if)# ip vrf forwarding v12
Router(config-if)# ip address 168.0.0.8 255.255.255.0
Router(config-if)# exit


Router(config)# router ospf 1 vrf v11
Router(config-router)# network 208.0.0.0 255.255.255.0 area 0
Router(config-router)# network 108.0.0.0 255.255.255.0 area 0
Router(config-router)# exit
Router(config)# router ospf 2 vrf v12
Router(config-router)# network 118.0.0.0 255.255.255.0 area 0
Router(config-router)# network 1688.0.0.0 255.255.255.0 area 0
Router(config-router)# exit

Note: If BGP is being used for routing between the PE and CE, the BGP-learned routes from the PE can be redistributed into OSPF using the following commands:

Router(config)# router ospf 1 vrf v11
Router(config-router)# redistribute bgp 800 subnets
Router(config-router)# exit
Router(config)# router ospf 2 vrf v12
Router(config-router)# redistribute bgp 800 subnets
Router(config-router)# exit

Configuring PE-CE connections using BGP for both routing and label exchange

Router(config)# router bgp 800
Router(config-router)# address-family ipv4 vrf v12
Router(config-router-af)# neighbor 83.0.0.3 remote-as 100
Router(config-router-af)# neighbor 83.0.0.3 activate
Router(config-router-af)# neighbor 83.0.0.3 send-label
Router(config-router-af)# redistribute ospf 2 match internal
Router(config-router-af)# exit
Router(config-router)# address-family ipv4 vrf vl1
Router(config-router-af)# neighbor 38.0.0.3 remote-as 100
Router(config-router-af)# neighbor 38.0.0.3 activate
Router(config-router-af)# neighbor 38.0.0.3 send-label
Router(config-router-af)# redistribute ospf 1 match internal
Router(config-router-af)# end

Router(config)# interface fastethernet3/0.10
Router(config-if)# ip vrf forwarding v11
Router(config-if)# ip address 38.0.0.8 255.255.255.0
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit
Router(config)# interface fastethernet3/0.20
Router(config-if)# ip vrf forwarding v12
Router(config-if)# ip address 83.0.0.8 255.255.255.0
Router(config-if)# mpls bgp forwarding
Router(config-if)# exit

Configuring PE-CE connections using OSPF for routing, and LDP for label exchange

Router(config)# router ospf 1 vrf v11
Router(config-router)# network 38.0.0.0 255.255.255.0 area 0
Router(config-router)# exit
Router(config)# router ospf 2 vrf v12
Router(config-router)# network 83.0.0.0 255.255.255.0 area 0
Router(config-router)# exit

Router(config)# interface fastethernet3/0.10
Router(config-if)# ip vrf forwarding v11
Router(config-if)# ip address 38.0.0.3 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# exit
Router(config)# interface fastethernet3/0.20
Router(config-if)# ip vrf forwarding v12
Router(config-if)# ip address 83.0.0.3 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# exit

Additional References

The following sections provide references related to MPLS Multi-VRF.

Related Documents


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This feature uses no new or modified commands.