Guest

Cisco IOS Software Releases 12.2 SB

MPLS VPN—Show Running VRF

  • Viewing Options

  • PDF (260.0 KB)
  • Feedback
MPLS VPN—Show Running VRF

Table Of Contents

MPLS VPN—Show Running VRF

Contents

Prerequisites for MPLS VPN—Show Running VRF

Restrictions for MPLS VPN—Show Running VRF

Information About MPLS VPN—Show Running VRF

Configuration Elements Displayed for the MPLS VPN—Show Running VRF Feature

Display of VRF Routing Protocol Configuration

Display of Configuration Not Directly Linked to a VRF

How to Configure MPLS VPN—Show Running VRF

Configuration Examples for MPLS VPN—Show Running VRF

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

show running-config vrf

show policy-map interface brief

Feature Information for MPLS VPN—Show Running VRF

Glossary


MPLS VPN—Show Running VRF


First Published: March 16, 2006
Last Updated: August 6, 2007

The MPLS VPN—Show Running VRF feature provides a Cisco IOS command-line interface (CLI) option to display a subset of the running configuration on a router that is linked to a Virtual Private Network (VPN) routing and forwarding (VRF) instance. You can display the configuration of a specific VRF or of all VRFs configured on a router.

On heavily loaded routers, the display of the configuration file might require several pages or screens. As the configuration increases in size and complexity, the possibility of misconfiguration also increases. You might find it difficult to trace a problem on a router where you have several VRFs configured. A command that displays all the elements of the configuration linked to a VRF allows for easier troubleshooting on a per-VRF basis and facilitates comparisons among configurations of different VRFs on the same router.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for MPLS VPN—Show Running VRF" section.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for MPLS VPN—Show Running VRF

Restrictions for MPLS VPN—Show Running VRF

Information About MPLS VPN—Show Running VRF

How to Configure MPLS VPN—Show Running VRF

Configuration Examples for MPLS VPN—Show Running VRF

Additional References

Command Reference

Feature Information for MPLS VPN—Show Running VRF

Glossary

Prerequisites for MPLS VPN—Show Running VRF

A Cisco IOS image that supports VRFs installed on the router

At least one VRF configured on the router

Cisco Express Forwarding is required for MPLS VPN routing and forwarding.

Restrictions for MPLS VPN—Show Running VRF

Any element of the running configuration of the router that is not linked directly to a VRF is not displayed. For example, a route map associated with a Border Gateway Protocol (BGP) neighbor in a VRF address-family configuration is not displayed. The VRF address-family configuration under BGP is displayed, but the route-map configuration is not. An exception to this general rule is the display of a controller configuration (for more information, see the "Display of Configuration Not Directly Linked to a VRF" section).

Information About MPLS VPN—Show Running VRF

Before using the MPLS VPN—Show Running VRF feature, you should understand the following information:

Configuration Elements Displayed for the MPLS VPN—Show Running VRF Feature

Display of VRF Routing Protocol Configuration

Display of Configuration Not Directly Linked to a VRF

Configuration Elements Displayed for the MPLS VPN—Show Running VRF Feature

You can display the running configuration associated with a specific VRF or all VRFs on the router by entering the show running-config vrf command. To display the running configuration of a specific VRF, enter the name of the VRF as an argument to the show running-config vrf command. For example, for a VRF named vpn3, you enter:

Router# show running-config vrf vpn3

The show running-config vrf command displays the following elements of the running configuration on a router:

The VRF configuration

This includes any configuration that is applied in the VRF submode.

The configuration of each interface in the VRF

Entering a show run vrf vpn-name command is the same as executing a show running-config interface type number for each interface that you display by use of the show ip vrf vpn-name command. The interfaces display in the same sorted order that you would expect from the show ip interface command.

For a channelized interface, the configuration of the controller is displayed (as shown by the show run controller controller-name command).

For a subinterface, the configuration of the main interface is displayed.

The configuration of routing-protocol address-families or processes that are linked with the VRF, including static routing configuration (see the "Display of VRF Routing Protocol Configuration" section.

Display of VRF Routing Protocol Configuration

Open Shortest Path First (OSPF), Routing Information Protocol (RIP), Border Gateway Protocol (BGP), Enhanced Interior Gateway Routing Protocol (EIGRP), and static routing are routing protocols that support VRF configuration.

OSPF has one process per VRF. The show running-config vrf command display includes the complete configuration of any OSPF process associated with the VRF. For example, the following shows the sample display for OSPF process 101, which is associated with the VRF named vpn3:

router ospf 101 vrf vpn3
 log-adjacency-changes
 area 1 sham-link 10.43.43.43 10.23.23.23 cost 10
 network 172.17.0.0 0.255.255.255 area 1

RIP, BGP, and EIGRP support VRF address-family configuration. If a VRF address family for the VRF exists for any of these routing protocols, a configuration in the following format is displayed:

router protocol {AS | PID}
!
address-family ipv4 vrf vrf-name
.
.
.

Where the protocol argument is one of the following: rip, bgp or eigrp; the AS argument is an autonomous system number; the PID argument is a process identifier; and the vrf-name argument is the name of the associated VRF.

The following shows a sample display for a BGP with autonomous system number 100 associated with a VRF named vpn3:

!
router bgp 100
!
address-family ipv4 vrf vpn3
 redistribute connected
 redistribute ospf 101 match external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family
 !

The show running-config vrf command also includes the configuration of any static routes configured in the VRF. For example:

ip route vrf vpn1 10.1.1.0 255.255.255.0 10.30.1.1 global 
ip route vrf vpn1 10.1.2.0 255.255.255.0 10.125.1.2 

Display of Configuration Not Directly Linked to a VRF

Any element of the configuration that is not linked directly to a VRF is not displayed. In some instances, the display of the configuration of an element that is not directly linked to a VRF is required.

For example, the show running-config vrf command displays the configuration of an E1 controller whose serial subinterfaces are in a VRF. The command displays the controller configuration and the subinterface configuration.

How to Configure MPLS VPN—Show Running VRF

There are no tasks for the MPLS VPN—Show Running VRF feature.

See the "Related Documents" section for links to configuration information for MPLS VPNs.

Configuration Examples for MPLS VPN—Show Running VRF

There are no configuration examples for the MPLS VPN—Show Running VRF feature.

See the "Related Documents" section for links to configuration information for MPLS VPNs.

Additional References

The following sections provide references related to the MPLS VPN—Show Running VRF feature.

Related Documents

Related Topic
Document Title

Configuration tasks for MPLS VPNs

"MPLS Virtual Private Networks" chapter, Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 12.4

Configuration tasks for MPLS and MPLS applications

"Configuring MPLS" chapter, Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 12.4


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Command Reference

This section documents only commands that are new or modified.

show running-config vrf

show policy-map interface brief

show running-config vrf

To display the subset of the running configuration of a router that is linked to a specific Virtual Private Network (VPN) routing and forwarding (VRF) instance or to all VRFs configured on the router, use the show running-config vrf command in user EXEC or privileged EXEC configuration mode.

show running-config vrf [vrf-name]

Syntax Description

vrf-name

(Optional) Name of the VRF of which you want to display the configuration.


Command Default

If you do not specify a vrf-name argument, the running configurations of all VRFs on the router are displayed.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.2(28)SB

This command was introduced.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

Use the show running-config vrf command to display a specific VRF configuration or to display all VRF configurations on the router. To display the configuration of a specific VRF, enter the name of the VRF as an argument to the command.

This command displays the following elements of the VRF configuration:

The VRF submode configuration

The routing protocol and static routing configurations associated with the VRF

The configuration of the interfaces in the VRF, which includes the configuration of any owning controller and physical interface for a subinterface

Examples

The following is sample output from the show running-config vrf command. It includes a base VRF configuration for VRF vpn3 and Border Gateway Protocol (BGP) and Open Shortest Path First (OSPF) configurations associated with VRF vpn3.

Router# show running-config vrf vpn3

Building configuration...

Current configuration : 604 bytes
ip vrf vpn3
 rd 100:3
 route-target export 100:3
 route-target import 100:3
!
!
interface Loopback1
 ip vrf forwarding vpn3
 ip address 10.43.43.43 255.255.255.255
!
interface Ethernet6/0
 ip vrf forwarding vpn3
 ip address 172.17.0.1 255.0.0.0
 no ip redirects
 duplex half
!
router bgp 100
!
address-family ipv4 vrf vpn3
 redistribute connected
 redistribute ospf 101 match external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family
 !
router ospf 101 vrf vpn3
 log-adjacency-changes
 area 1 sham-link 10.43.43.43 10.23.23.23 cost 10
 network 172.17.0.0 0.255.255.255 area 1
!
end

Table 1 describes the significant fields shown in the display.

Table 1 show running-config vrf Field Descriptions 

Field
Description

Current configuration: 604 bytes

Number of bytes (604) in the VRF vpn3 configuration.

ip vrf vpn3

Name of the VRF (vpn3) for which the configuration is displayed.

rd 100:3

Identifies the route distinguisher (100:3) for VRF vpn3.

route-target export 100:3
route-target import 100:3

Specifies the route-target extended community for VRF vpn3.

Routes tagged with route-target export 100:3 are exported from VRF vpn3.

Routes tagged with the route-target import 100:3 are imported into VRF vpn3.

interface loopback1

Virtual interface associated with VRF vpn3.

ip vrf forwarding vpn3

Associates VRF vpn3 with the named interface.

ip address 10.43.43.43 255.255.255.255

IP address of the loopback interface.

interface Ethernet6/0

Interface associated with VRF vpn3.

ip address 172.17.0.1 255.0.0.0

IP address of the Ethernet interface.

router bgp 100

Sets up a BGP routing process for the router with autonomous system number 100.

address-family ipv4 vrf vpn3

Sets up a routing session for VRF vpn3 using standard IP Version 4 address prefixes.

redistribute connected

Redistributes routes automatically established by IP on an interface into the BGP routing domain.

redistribute ospf 101 match external 1 external 2

Redistribute routes from the OSPF 101 routing domain into the BGP routing domain.

router ospf 101 vrf vpn3

Set up an OSPF routing process and associates VRF vpn3 with OSPF VRF processes.

area 1 sham-link 10.43.43.43 10.23.23.23 cost 10

Configure a sham-link interface on a provider edge (PE) router in a Multiprotocol Label Switching (MPLS) VPN backbone.

1 is the ID number of the OSPF area assigned to the sham-link.

10.43.43.43 is the IP address of the source PE router.

10.23.23.23 is the IP address of the destination PE router.

10 is the OSPF cost to send IP packets over the sham-link interface.

network 172.17.0.0 0.255.255.255 area 1

Defines the interfaces on which OSPF runs and defines the area ID for those interfaces.


Related Commands

Command
Description

ip vrf

Configures a VRF routing table.

show ip vrf

Displays the set of defined VRFs and associated interfaces.

show ip interface

Displays the usability status of interfaces configured for IP.

show running-config interface

Displays the configuration for a specific interface.


show policy-map interface brief

To display information about only the active policy maps attached to an interface, use the show policy-map interface brief command in privileged EXEC mode.

show policy-map interface [input | output] brief [policy-map-name] [vrf [vrf-id]] [timestamp]

Syntax Description

input

(Optional) Indicates that only the information about the active input policy maps will be displayed.

output

(Optional) Indicates that only the information about the active output policy maps will be displayed.

brief

Indicates that the name of all the active policy maps (both input and output policy maps) and the interfaces to which the policy maps are attached will be displayed. The active input policy maps will be displayed first, followed by the output policy maps.

policy-map-name

(Optional) Name of an active policy map to be displayed.

vrf

(Optional) Indicates that the active policy maps for Virtual Private Network (VPN) routing and forwarding (VRF) instances will be displayed.

vrf-id

(Optional) A specific VRF identifier.

timestamp

(Optional) Indicates that the date and time when the policy map was attached will be displayed, along with the ID of the user who attached the policy map.


Command Default

If no optional keywords or arguments are specified, all policy maps (even those that are not active) are displayed.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.2(28)SB

This command was introduced.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

The show policy-map interface brief command displays the name of the active policy maps and the interfaces to which those policy maps are attached. An active policy map is one that is attached to an interface.

The optional keywords and arguments allow you to tailor the information displayed about VPNs, time stamps, and user IDs.

If you do not specify any optional keywords or arguments, all policy maps (even those that are not active) are displayed.

VPN Information Reported

The show policy-map interface brief command can be used for VRF interfaces in applications that use VPNs. To specify VRF interfaces, use the vrf keyword with the vrf-id argument.

Time-stamp and User ID Information Reported

If the optional timestamp keyword is used with the show policy-map interface brief command, the time and date when a policy map was attached to an interface appear in the display. In addition to the time and date information, the name (that is, the user ID) of the person who attached the policy map to the interface will also be displayed.


Note If the network software is reloaded (reinstalled), the time-stamp information (the time and date information) obtained will not be retained for any of the policy maps attached to interfaces on the network. Instead, the time and date information displayed will be the time and date when the software was reloaded.


Method for Obtaining User Information

The user information included in the display is obtained from the information that you enter when you log in to the router. For example, if you are using the SSH Secure Shell utility to log in to a router, you would typically enter your username and password. However, it is not always possible to obtain the user information. Instances where user information cannot be obtained include the following:

Not all routers require user information when you log in. Therefore, you may not be prompted to enter your username when you log in to a router.

If you are connecting to a console port using the Telnet utility in a DOS environment, you do not need to enter user information.

The user information cannot be retrieved because of system constraints or other factors.

If the user information cannot be obtained, the words "by unknown" will be displayed.

Hierarchical Policy Map Information

For a hierarchical policy map structure, only the information about the parent policy maps is displayed. Information about child policy maps is not displayed.

ATM PVCs

For ATM permanent virtual circuits (PVCs), policy maps do not remain associated with the interface if the ATM PVC is not working properly (that is, the ATM PVC is "down"). Therefore, if an ATM PVC is down, and a policy map is attached to an interface, the show policy-map interface brief command does not include information about the policy maps in the command output.

Examples

The information that is displayed by the show policy-map interface brief command varies according to the optional keywords and arguments that you specify.

The following sections list the significant keyword and argument combinations used with the command and describe the corresponding information displayed.

show policy-map interface brief Command Example

The show policy-map interface brief command displays all the attached policy maps (both input policy maps and output policy maps) along with the information about the interfaces to which the policy maps are attached. The input policy maps are displayed first, followed by the output policy maps.

Service-policy input: policyname1
interface s2/0/1 
interface s6/0/0 

Service-policy output: policyname1interface s2/0/1 interface s6/0/0

show policy-map interface brief timestamp Command Example

The show policy-map interface brief timestamp command displays all the attached policy maps (both input policy maps and output policy maps) along with the information about the interfaces to which the policy maps are attached. The input policy maps are displayed first, followed by the output policy maps.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

Service-policy input: parentpolicy1 
Service-policy input: childpolicy1
interface s2/0/1 - applied 20:43:04 on 25/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

Service-policy output: policyname2
interface s2/0/2 - applied 21:47:04 on 24/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

show policy-map interface brief policy-map-name Command Example

The show policy-map interface brief policy-map-name command displays the policy map attached as either an input policy map or an output policy map, along with the information about the interface to which the policy map is attached. Only the policy map specified by the policy-map-name argument is displayed.

For example, the display for the show policy-map interface brief policyname1 command is as follows:

Service-policy input: policyname1
interface s2/0/1
interface s6/0/0

Service-policy output: policyname1
interface s1/0/2
interface s3/0/0

show policy-map interface brief policy-map-name timestamp Command Example

The show policy-map interface brief policy-map-name timestamp command displays the policy map attached as either an input policy map or an output policy map, along with the information about the interface to which it is attached. Only the policy map specified by the policy-map-name argument is displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for the show policy-map interface brief policyname2 timestamp command is as follows:

Service-policy input: policyname2
interface s2/0/2 - applied 21:47:04 on 24/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

Service-policy output: policyname2
interface s4/0/2 - applied 12:47:04 on 24/12/01 by user1
interface s7/0/1 - applied 14:43:04 on 25/12/01 by user1

show policy-map interface output brief Command Example

The show policy-map interface output brief command displays the attached output policy maps, along with the information about the interfaces to which they are attached.

Service-policy output: policyname1

show policy-map interface output brief timestamp Command Example

The show policy-map interface output brief timestamp command displays the attached output policy maps, along with the information about the interfaces to which they are attached.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

Service-policy output: policyname2
interface s2/0/2 - applied 21:47:04 on 24/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

show policy-map interface input brief Command Example

The show policy-map interface input brief command displays the attached input policy maps, along with the information about the interfaces to which they are attached.

Service-policy input: policyname2
interface s2/0/2 
interface s6/0/1 

show policy-map interface input brief timestamp Command Example

The show policy-map interface input brief timestamp command displays the attached input policy maps, along with the information about the interfaces to which they are attached.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

Service-policy input: policyname2
interface s2/0/2 - applied 21:47:04 on 24/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

show policy-map interface output brief policy-map-name Command Example

The show policy-map interface output brief policy-map-name command displays the attached output policy map, along with the information about the interface to which it is attached. Only the policy map specified by the policy-map-name argument is displayed.

For example, the display for the show policy-map interface output brief policyname1command is as follows:

Service-policy output: policyname1
interface s2/0/1
interface s6/0/0

show policy-map interface output brief policy-map-name timestamp Command Example

The show policy-map interface output brief policy-map-name timestamp command displays the attached output policy map, along with the information about the interface to which it is attached. Only the policy map specified by the policy-map-name argument is displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for the show policy-map interface output brief policyname2 timestamp command is as follows:

Service-policy output: policyname2
interface s2/0/2 - applied 21:47:04 on 24/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

show policy-map interface input brief policy-map-name Command Example

The show policy-map interface input brief policy-map-name command displays the attached input policy map, along with the information about the interface to which it is attached. Only the policy map specified by the policy-map-name argument is displayed.

For example, the display for the show policy-map interface input brief policyname1 command is as follows:

Service-policy input: policyname1
interface s2/0/1
interface s6/0/0

show policy-map interface input brief policy-map-name timestamp Command Example

The show policy-map interface input brief policy-map-name timestamp command displays the attached input policy map, along with the information about the interface to which it is attached. Only the policy map specified by the policy-map-name argument is displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for the show policy-map interface input brief policyname2 timestamp command is as follows:

Service-policy input: policyname2
interface s2/0/2 - applied 21:47:04 on 24/12/01 by user1
interface s6/0/1 - applied 19:43:04 on 25/12/01 by user1

show policy-map interface brief vrf Command Example

The show policy-map interface brief vrf command displays all the policy maps (both input policy maps and output policy maps), along with information about the interfaces and the VRFs to which the policy maps are attached.

Service-policy input: policyname1
VRFA   interface s2/0/1 
VRFB   interface s6/0/0 

Service-policy output: policyname2
VRFC   interface s2/0/2 
VRFB   interface s6/0/1 

show policy-map interface brief vrf timestamp Command Example

The show policy-map interface brief vrf timestamp command displays all the policy maps (both input policy maps and output policy maps), along with information about the interfaces and the VRFs to which the policy maps are attached.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

Service-policy input: policyname1
VRFA   interface s2/0/1 - applied 21:47:04 on 23/12/01 by user1
VRFB   interface s6/0/0 - applied 21:47:04 on 23/12/01 by user1

Service-policy output: policyname2
VRFC   interface s2/0/3 - applied 20:47:04 on 23/12/01 by user1
VRFD   interface s6/0/2 - applied 20:49:04 on 21/12/01 by user1

In some network configurations, the policy map may be attached to the interface initially, and then at a later time, the interface can be configured to act as a VRF interface. In this kind of network configuration, the time-stamp information displays the time when the policy map was attached to the interface. The display does not include the time when the interface was configured to act as a VRF interface. Displaying only the time when the policy map is attached to the interface also applies to the scenarios that are described in the following paragraph for other network configurations.

In other network configurations, a VRF may be attached to multiple interfaces as described in the following scenarios:

The policy map is also attached to both the interfaces and the VRFs. In this network configuration, all the interfaces should be shown in the display for the VRF, under the policy map name, as follows:

Service-policy input: policyname1
VRF1 interface s2/0/1 - applied 21:47:37 on 23/12/01 by user1
     interface atm0/0 - applied 11:37:57 on 21/11/01 by user1

The policy map is not attached to all interfaces to which the specific VRF is attached. In this network configuration, only the VRF interfaces that have that policy map configured are displayed.

show policy-map interface brief policy-map-name vrf timestamp Command Example

The show policy-map interface brief policy-map-name vrf timestamp command displays the policy maps attached as either an input policy map or an output policy map, along with information about the interface and VRF to which the policy map is attached. Only the policy map specified by the policy-map-name argument is displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for the show policy-map interface brief policyname1 vrf timestamp command is as follows:

Service-policy input: policyname1
VRF1   interface s2/0/1 - applied 21:47:04 on 23/12/01 by user1

Service-policy output: policyname1
VRF2   interface s6/0/1 - applied 21:47:04 on 23/12/01 by user1

show policy-map interface brief policy-map-name vrf vrf-id timestamp Command Example

The show policy-map interface brief policy-map-name vrf vrf-id timestamp command displays all the policy maps (both the input policy maps and the output policy maps), along with information about the interface and VRF to which the policy maps are attached. Only the policy map and VRF specified by the policy-map-name argument and the vrf-id argument are displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for show policy-map interface brief policyname1 vrf VRFA timestamp command is as follows:

Service-policy input: policyname1
VRFA   interface s2/0/1 - applied 21:47:04 on 23/12/01 by user1

Service-policy output: policyname1
VRFA   interface s6/0/1 - applied 21:47:04 on 23/12/01 by user1

show policy-map interface output brief vrf Command Example

The show policy-map interface output brief vrf command displays the attached output policy maps, along with information about the interface and VRF to which the policy maps are attached.

Service-policy output: policyname2
VRFC   interface s2/0/2
VRFA   interface s6/0/1 

show policy-map interface output brief vrf timestamp Command Example

The show policy-map interface output brief vrf timestamp command displays the attached output policy maps, along with information about the interface and VRF to which the policy maps are attached.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

Service-policy output: policyname2
VRFC   interface s2/0/2 - applied 21:47:04 on 23/12/01 by user1
VRFA   interface s6/0/1 - applied 21:47:04 on 23/12/01 by user1

show policy-map interface input brief vrf Command Example

The show policy-map interface input brief vrf command displays the attached input policy maps, along with information about the interface and VRF to which the policy maps are attached.

Service-policy input: policyname1
VRFA   interface s2/0/1 
VRFB   interface s6/0/0 

Service-policy input: policyname2
VRFC   interface s2/0/2 
VRFB   interface s6/0/1 

show policy-map interface input brief vrf timestamp Command Example

The show policy-map interface input brief vrf timestamp command displays the attached input policy maps, along with information about the interface and VRF to which the policy maps are attached.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

Service-policy input: policyname1
VRFA   interface s2/0/1 - applied 21:47:04 on 23/12/01 by user1
VRFB   interface s6/0/0 - applied 21:47:04 on 23/12/01 by user1

Service-policy input: policyname2
VRFC   interface s2/0/3 - applied 20:47:04 on 23/12/01 by user1
VRFD   interface s6/0/2 - applied 20:49:04 on 21/12/01 by user1

show policy-map interface input brief vrf vrf-id Command Example

The show policy-map interface input brief vrf vrf-id command displays the attached input policy maps, along with information about the interface and VRF to which the policy maps are attached. Only the policy maps attached to the VRF specified by the vrf-id argument are displayed.

For example, the display for the show policy-map interface input brief vrf VRFA command is as follows:

Service-policy input: policyname1
VRFA   interface s2/0/1 

Service-policy input: policyname2
VRFA   interface s6/0/1 

show policy-map interface output brief vrf vrf-id Command Example

The show policy-map interface output brief vrf vrf-id command displays the attached output policy maps, along with information about the interface and VRF to which the policy maps are attached. Only the policy maps attached to the VRF specified by the vrf-id argument are displayed.

For example, the display for the show policy-map interface output brief vrf VRFB command is as follows:

Service-policy output: policyname1
VRFB   interface s2/0/1 

Service-policy output: policyname2
VRFB   interface s6/0/1 

show policy-map interface input brief vrf vrf-id timestamp Command Example

The show policy-map interface input brief vrf vrf-id timestamp command displays the attached input policy maps, along with information about the interface and VRF to which the policy maps are attached. Only the policy maps attached to the VRF specified by the vrf-id argument are displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for the show policy-map interface input brief vrf VRFA timestamp command is as follows:

Service-policy input: policyname1
VRFA   interface s2/0/1 - applied 21:47:04 on 23/12/01 by user1

Service-policy input: policyname2
VRFA   interface s6/0/1 - applied 21:47:04 on 23/12/01 by user1

show policy-map interface output brief vrf vrf-id timestamp Command Example

The show policy-map interface output brief vrf vrf-id timestamp command displays the attached output policy maps, along with information about the interface and VRF to which the policy maps are attached. Only the policy maps attached to the VRF specified by the vrf-id argument are displayed.

The timestamp keyword displays the time and date when the policy map was attached to the specific interface, along with the user ID of the person who attached the policy map to the interface.

For example, the display for the show policy-map interface output brief vrf VRFB timestamp command is as follows:

Service-policy output: policyname1
VRFB   interface s2/0/1 - applied 21:47:04 on 23/12/01 by user1

Service-policy output: policyname2
VRFB   interface s6/0/1 - applied 21:47:04 on 23/12/01 by user1

Table 2 describes the significant fields shown in the various displays.

Table 2 show policy-map interface brief Field Descriptions 

Field
Description

Service-policy output: policyname2

Output policy map name.

Service-policy input: policyname2

Input policy map name.

interface s2/0/1

Interface to which the policy map is attached.

VRFA

VRF to which the policy map is attached.

applied 21:47:04 on 23/12/01

Time and date when the policy map was attached to the interface or VRF.

by user1

User ID of the person who attached the policy map to the interface or VRF.


Related Commands

Command
Description

show policy-map interface

Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface.


Feature Information for MPLS VPN—Show Running VRF

Table 3 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 3 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 3 Feature Information for MPLS VPN—Show Running VRF 

Feature Name
Releases
Feature Information

MPLS VPN—Show Running VRF

12.2(28)SB
12.0(32)SY
12.2(33)SRB
12.2(33)SXH

The MPLS VPN—Show Running VRF feature provides a CLI option to display a subset of the running configuration on a router that is linked to a VRF. You can display the configuration of a specific VRF or of all VRFs configured on a router. A command that displays all the elements of the configuration linked to a VRF allows for easier troubleshooting on a per-VRF basis and facilitates comparisons among configurations of different VRFs on the same router.

In 12.2(28)SB, this feature was introduced.

In 12.0(32)SY, support was added for a Cisco IOS 12.0SY release.

In 12.2(33)SRB, support was added for a Cisco IOS 12.2SR release.

In 122(33)SXH, support was added for a Cisco IOS 12.2SX release.

The following sections provide information about this feature:

Configuration Elements Displayed for the MPLS VPN—Show Running VRF Feature

Display of VRF Routing Protocol Configuration

Display of Configuration Not Directly Linked to a VRF

The following commands were modified by this feature: show running-config vrf and show policy-map interface brief.


Glossary

BGP—Border Gateway Protocol. An interdomain routing protocol that replaces External Gateway Protocol (EGP). BGP systems exchange reachability information with other BGP systems. BGP is defined by RFC 1163.

EGP—External Gateway Protocol. An internet protocol for exchanging routing information between autonomous systems. EGP is documented in RFC 904. Not to be confused with the general term exterior gateway protocol. EGP is an obsolete protocol that was replaced by Border Gateway Protocol (BGP).

EIGRP—Enhanced Interior Gateway Routing Protocol. Advanced version of Interior Gateway Routing Protocol (IGRP) developed by Cisco. Provides superior convergence properties and operating efficiency, and combines the advantages of link state protocols with those of distance vector protocols.

IGP—Interior Gateway Protocol. An internet protocol used to exchange routing information within an autonomous system. Examples of common Internet IGPs include Interior Gateway Routing Protocol (IGRP), Open Shortest Path First (OSPF), and Routing Information Protocol (RIP).

IGRP—Interior Gateway Routing Protocol. An Interior Gateway Protocol (IGP) developed by Cisco to address the issues associated with routing in large, heterogeneous networks.

MPLS—Multiprotocol Label Switching. A switching method that forwards IP traffic through the use of a label. This label instructs the routers and the switches in the network where to forward each packet based on preestablished IP routing information.

OSPF—Open Shortest Path First. A link-state, hierarchical, Interior Gateway Protocol (IGP) routing algorithm and routing protocol proposed as a successor to Routing Information Protocol (RIP) in the Internet community. OSPF features include least-cost routing, multipath routing, and load balancing. OSPF was derived from an early version of the Intermediate System-to-Intermediate System (IS-IS) protocol.

RIP—Routing Information Protocol. Internal Gateway Protocol (IGP) supplied with UNIX Berkeley Software Distribution (BSD) systems. RIP is the most common IGP in the Internet. It uses hop count as a routing metric.

VPN—Virtual Private Network. The result of a router configuration that enables IP traffic to use tunneling to travel securely over a public TCP/IP network.

VRF—A Virtual Private Network (VPN) routing and forwarding instance. A VRF consists of an IP routing table, a derived forwarding table, a set of interfaces that use the forwarding table, and a set of rules and routing protocols that determine what goes into the forwarding table. In general, a VRF includes the routing information that defines a customer VPN site that is attached to a provider edge (PE) router.


Note Refer to the Cisco Dictionary of Internetworking Terms and Acronyms for terms not included in this glossary.