Guest

Cisco IOS Software Releases 12.2 SB

NAS-Port-ID Format C Enhancement

  • Viewing Options

  • PDF (246.4 KB)
  • Feedback
NAS-Port-ID Format C Enhancement

Table Of Contents

NAS-Port-ID Format C Enhancement

Contents

Restrictions for NAS-Port-ID Format C Enhancement

Information About NAS-Port-ID Format C Enhancement

Coding Format for NAS-Port-ID Format C

How to Configure the NAS-Port-ID Format C Enhancement Feature

Configuring the NAS-Port-ID Format C Enhancement Feature

Configuration Examples for NAS-Port-ID Format C Enhancement

Configuring PPPoE over Ethernet for the Access Concentrator Side and Client Side: Example

Configuring PPPoE over ATM/AAL5 SNAP for the Access Concentrator Side and Client Side: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

nas-port-id format c

Feature Information for NAS-Port-ID Format C Enhancement

Glossary


NAS-Port-ID Format C Enhancement


First Published: December 5, 2006
Last Updated: December 5, 2006

The NAS-Port-ID Format C Enhancement feature introduces the nas-port-id format c command for Broadband Access Group (BBA group) configuration. This command defines a specific broadband subscriber access line identification (NAS-Port-ID) coding format. When this command is configured, the original value of the NAS-Port-ID tag is overwritten. If no valid string is available for the Remote-ID or the Circuit-ID tag as part of Dynamic Host Configuration Protocol (DHCP) option 82, a default string of 0/0/0/0/0/0 is appended to the NAS-Port-ID tag.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for NAS-Port-ID Format C Enhancement" section.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Restrictions for NAS-Port-ID Format C Enhancement

Information About NAS-Port-ID Format C Enhancement

How to Configure the NAS-Port-ID Format C Enhancement Feature

Configuration Examples for NAS-Port-ID Format C Enhancement

Additional References

Command Reference

Feature Information for NAS-Port-ID Format C Enhancement

Glossary

Restrictions for NAS-Port-ID Format C Enhancement

This functionality is available only in Cisco IOS Release 12.2(31)SB2.

The NAS-Port-ID Format C Enhancement feature is supported on the Cisco 10000 series platform where PPP over Ethernet (PPPoE) server functionality is supported.

This feature is not supported on PPP over ATM.

Information About NAS-Port-ID Format C Enhancement

To configure and apply this feature, you should understand the following concept:

Coding Format for NAS-Port-ID Format C

Coding Format for NAS-Port-ID Format C

The NAS-Port-ID Format C Enhancement feature provides the following broadband subscriber access line identification (NAS-Port-ID) coding format:

{atm/eth/trunk} NAS_slot/NAS_subslot/NAS_port:XPI:XCI {Circuit-ID/Remote-ID/default string}

For ATM, XPI is the virtual path identifier (VPI) and XCI is the virtual circuit identifier (VCI).

For Ethernet, XPI is outer vlan-tag, XCI is inner vlan-tag.

Requirements for XPI:XCI for Ethernet are as follows:

For 802.1Q tunneling (QinQ), the format should be outer vlan-tag:inner vlan-tag. (Prior to Release 12.2(31)SB2, Cisco IOS software supports inner vlan-tag:outer vlan-tag).

For single tag VLAN, XPI should be 4096.

The Circuit-ID tag (if present) must be appended to this string when the nas-port-id format c command is used. The format for the Circuit-ID or Remote-ID tag is as follows:

AccessNodeIdentifier/ANI_rack/ANI_frame/ANI_slot/ANI_subslot/ANI_port[:ANI_XPI.ANI_XCI]

The digital subscriber line access multiplexer (DSLAM) should append this information to the broadband remote access server (BRAS), and the BRAS transparently delivers it. If the Circuit-ID or Remote-ID tag is not present in DHCP option 82, a string of 0/0/0/0/0/0 should be appended to the NAS-Port-ID tag.

The following examples illustrate this format:

NAS-Port-ID = atm 31/31/7:255.65535 guangzhou001/0/31/63/31/127

In this example, the subscriber interface type of the BRAS equipment is an ATM interface, the BRAS slot number is 31, the BRAS subslot number is 31, the BRAS port number is 7, the VPI is 255, and the VCI is 65535. The string guangzhou001/0/31/63/31/127 is the Circuit-ID or Remote-ID tag.

NAS-Port-ID = eth 31/31/7:1234.2345 0/0/0/0/0/0

In this example, the subscriber interface type of the BRAS equipment is an Ethernet interface, the BRAS slot number is 31, the BRAS subslot number is 31, the BRAS port number is 7, the outer vlan-tag is 1234, and the inner vlan-tag is 2345. The string 0/0/0/0/0/0 is the default.

NAS-Port-ID = eth 31/31/7:4096.2345 0/0/0/0/0/0

In this example, the subscriber interface type of the BRAS equipment is an Ethernet interface, the BRAS slot number is 31, the BRAS subslot number is 31, the BRAS port number is 7, and the VLAN ID is 2345. The string 0/0/0/0/0/0 is the default.

How to Configure the NAS-Port-ID Format C Enhancement Feature

This section contains the following procedure:

Configuring the NAS-Port-ID Format C Enhancement Feature

Configuring the NAS-Port-ID Format C Enhancement Feature

To overwrite the original value of the NAS-Port-ID tag and define the specific broadband subscriber access line identification (NAS-Port-ID) coding format that complies with that described in the "Coding Format for NAS-Port-ID Format C" section, perform the following task.

SUMMARY STEPS

1. enable

2. configure terminal

3. bba-group pppoe group-name

4. virtual-template template-number

5. nas-port-id format c

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

bba-group pppoe group-name

Example:

Router(config)# bba-group pppoe pppoe-group

Enters BBA group configuration mode and defines a PPPoE profile.

Step 4 

virtual-template template-number

Example:

Router(config-bba-group)# virtual template 1

Configures a PPPoE profile with a virtual template to be used for cloning virtual access interfaces.

The template-number argument is an identifying number of the virtual template that will be used to clone virtual access interfaces.

Step 5 

nas-port-id format c

Example:

Router(config-bba-group)# nas-port-id format c

Specifies a format for broadband subscriber access line identification coding.

Note The designation of format c is specifically designed as follows:

NAS_PORT_ID=atm 31/31/7:255.65535 guangzhou001/0/31/63/31/127

Configuration Examples for NAS-Port-ID Format C Enhancement

To enable the NAS-Port-ID Format C Enhancement feature, you must configure the access concentrator side and the client side in your network. This section provides the following sample configurations:

Configuring PPPoE over Ethernet for the Access Concentrator Side and Client Side: Example

Configuring PPPoE over ATM/AAL5 SNAP for the Access Concentrator Side and Client Side: Example

Configuring PPPoE over Ethernet for the Access Concentrator Side and Client Side: Example

The following is a sample configuration for the access concentrator side of a PPPoE over Ethernet configuration:

bba-group pppoe bba-pppoeoe
 virtual-template 1
 nas-port-id format c
!
interface Loopback0
 ip address 10.7.7.100 255.255.255.255
!
interface Virtual-Template1
 ip unnumbered Loopback0
no peer default ip address
 ppp authentication chap
!
interface FastEthernet0/0
 description PPPoEoE
 pppoe enable group bba-pppoeoe
!

The following is a sample configuration for the client side:

bba-group pppoe bbag-pppoeoe
 virtual-template 1
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp chap hostname xyz
 ppp chap password 0 lab
!
interface Loopback0
 ip address 10.7.7.1 255.255.255.255
!
interface FastEthernet1/1
 no ip address
 pppoe enable group bbag-pppoeoe
!

Configuring PPPoE over ATM/AAL5 SNAP for the Access Concentrator Side and Client Side: Example

The following is a sample configuration for the access concentrator side of a PPPoE over an ATM/AAL5 Subnetwork Access Protocol (SNAP) configuration:

bba-group pppoe bba-pppoeoa
 virtual-template 2
 nas-port-id format c
!
interface Loopback1
 ip address 10.5.5.100 255.255.255.255
!
interface Virtual-Template2
 ip unnumbered Loopback1
no peer default ip address
 ppp authentication chap
!
interface ATM2/0.1 multipoint
 description PPPoEoA
 pvc 1/100
  encapsulation aal5snap
  protocol pppoe group bba-pppoeoa
 !

The following is a sample configuration for the client side:

bba-group pppoe bbag-pppoeoa
 virtual-template 2
!
interface Virtual-Template2
 ip unnumbered Loopback1
 ppp chap hostname abc
 ppp chap password 0 lab
!
interface Loopback1
 ip address 10.5.5.1 255.255.255.255
!
interface ATM6/0.1 multipoint
 pvc 1/100
 encapsulation aal5snap
 protocol pppoe group bbag-pppoeoa
 !

Additional References

The following sections provide references related to the NAS-Port-ID Format C Enhancement feature.

Related Documents

Related Topic
Document Title

Command reference documentation for commands used in this document

Cisco IOS Broadband and DSL Commands


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents the following new command.

nas-port-id format c

nas-port-id format c

To specify a format for broadband subscriber access line identification coding that complies with a specific set of defined requirements, use the nas-port-id format c command in BBA group configuration mode. To disable this format implementation, use the no form of this command.

nas-port-id format c

no nas-port-id format c

Syntax Description

This command has no arguments or keywords.

Command Default

If this command is not configured, the default strings for NAS-Port-ID are used.

Command Modes

BBA group configuration

Command History

Release
Modification

12.2(31)SB2

This command was introduced.


Usage Guidelines

The nas-port-id format c command defines the following broadband subscriber access line identification (NAS-Port-ID) coding format:

{atm/eth/trunk} NAS_slot/NAS_subslot/NAS_port:XPI:XCI {Circuit-ID/Remote-ID/default string}

For ATM, XPI is the virtual path identifier (VPI) and XCI is the virtual circuit identifier (VCI).

For Ethernet, XPI is outer vlan-tag, XCI is inner vlan-tag.

Requirements for XPI:XCI for Ethernet are as follows:

For 802.1Q tunneling (QinQ), the format should be outer vlan-tag:inner vlan-tag. (Prior to Release 12.2(31)SB2, Cisco IOS software supports inner vlan-tag:outer vlan-tag).

For single tag VLAN, XPI should be 4096.

The Circuit-ID tag (if present) must be appended to this string when the nas-port-id format c command is used. The format for the Circuit-ID or Remote-ID tag is as follows:

AccessNodeIdentifier/ANI_rack/ANI_frame/ANI_slot/ANI_subslot/ANI_port[:ANI_XPI.ANI_XCI]

The digital subscriber line access multiplexer (DSLAM) should append this information to the broadband remote access server (BRAS), and the BRAS transparently delivers it. If the Circuit-ID or Remote-ID tag is not present in DHCP option 82, a string of 0/0/0/0/0/0 should be appended to the NAS-Port-ID tag.

The following examples illustrate this format:

NAS-Port-ID = atm 31/31/7:255.65535 guangzhou001/0/31/63/31/127

In this example, the subscriber interface type of the BRAS equipment is an ATM interface, the BRAS slot number is 31, the BRAS subslot number is 31, the BRAS port number is 7, the VPI is 255, and the VCI is 65535. The string guangzhou001/0/31/63/31/127 is the Circuit-ID or Remote-ID tag.

NAS-Port-ID = eth 31/31/7:1234.2345 0/0/0/0/0/0

In this example, the subscriber interface type of the BRAS equipment is an Ethernet interface, the BRAS slot number is 31, the BRAS subslot number is 31, the BRAS port number is 7, the outer vlan-tag is 1234, and the inner vlan-tag is 2345. The string 0/0/0/0/0/0 is the default.

NAS-Port-ID = eth 31/31/7:4096.2345 0/0/0/0/0/0

In this example, the subscriber interface type of the BRAS equipment is an Ethernet interface, the BRAS slot number is 31, the BRAS subslot number is 31, the BRAS port number is 7, and the VLAN ID is 2345. The string 0/0/0/0/0/0 is the default.

Examples

The following example lists the commands for entering BBA group configuration mode and identifying a profile, configuring a virtual template, and specifying format c for the NAS-Port-ID tag:

bba-group pppoe bba-pppoeoe
 virtual-template 1
 nas-port-id format c
!

Related Commands

Command
Description

bba-group pppoe

Enters BBA group configuration mode and defines a PPPoE profile.

virtual-template

Configures a PPPoE profile with a virtual template to be used for cloning virtual access interfaces.


Feature Information for NAS-Port-ID Format C Enhancement

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for the NAS-Port-ID Format C Enhancement Feature

Feature Name
Releases
Feature Information

NAS-Port-ID Format C Enhancement

12.2(31)SB2

The NAS-Port-ID Format C Enhancement feature introduces the nas-port-id format c command for Broadband Access Group (BBA group) configuration. This command defines a specific broadband subscriber access line identification (NAS-Port-ID) coding format. When this command is configured, the original value of the NAS-Port-ID tag is overwritten. If no valid string is available for the Remote-ID or Circuit-ID tag as part of Dynamic Host Configuration Protocol (DHCP) option 82, a default string of 0/0/0/0/0/0 is appended to the NAS-Port-ID tag.

In Cisco IOS Release 12.2(31)SB2, support is provided for the Cisco 10000 series platform.


Glossary

AAA—authentication, authorization, and accounting.

ATM—Asynchronous Transfer Mode.

BRAS—broadband remote access server.

CLI—command-line interface.

DHCP—Dynamic Host Configuration Protocol.

DSLAM—digital subscriber line access multiplexer.

HA—high availability.

NAS—network access server.

PPPoA—Point-to-Point Protocol over ATM.

PPPoE—Point-to-Point Protocol over Ethernet.

QinQ—IEEE 802.1Q tunneling.

RADIUS—Remote Authentication Dial-In User Service (RFC 2865).

SNAP—Subnetwork Access Protocol.

VCI—virtual circuit identifier.

VLAN—virtual local-area network.

VPI—virtual path identifier.


Note See Internetworking Terms and Acronyms for terms not included in this glossary.