Guest

Cisco IOS Software Releases 12.2 SB

Distribution of Remaining Bandwidth Using Ratio

  • Viewing Options

  • PDF (400.1 KB)
  • Feedback
Distribution of Remaining Bandwidth Using Ratio

Table Of Contents

Distribution of Remaining Bandwidth Using Ratio

Contents

Prerequisites for Distribution of Remaining Bandwidth Using Ratio

Restrictions for Distribution of Remaining Bandwidth Using Ratio

Information About Distribution of Remaining Bandwidth Using Ratio

Bandwidth-Remaining Ratio

How to Configure Distribution of Remaining Bandwidth Using Ratio Feature

Configuring and Applying Bandwidth-Remaining Ratios to Subinterfaces

Configuring and Applying Bandwidth-Remaining Ratios to Class Queues

Configuration Examples for Distribution of Remaining Bandwidth Using Ratio

Configuring Bandwidth-Remaining Ratios on Ethernet Subinterfaces: Example

Configuring Bandwidth-Remaining Ratios on ATM Subinterfaces: Example

Configuring Bandwidth-Remaining Ratios on Class Queues: Example

Verifying Bandwidth Remaining Ratios: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

bandwidth remaining ratio

show policy-map

show policy-map interface


Distribution of Remaining Bandwidth Using Ratio


First Published: November, 2006

The Distribution of Remaining Bandwidth Using Ratio feature allows service providers to configure a bandwidth-remaining ratio on subinterfaces and class queues. This ratio specifies the relative weight of this subinterface or queue with respect to other subinterfaces or queues. During congestion, the router uses this bandwidth-remaining ratio to determine the amount of excess bandwidth (unused by priority traffic) to allocate to a class of non-priority traffic. The router allocates excess bandwidth relative to the other subinterface-level queues and class queues configured on the physical interface. By administering a bandwidth-remaining ratio, traffic priority is not based solely upon speed. Instead, the service provider can base priority on alternative factors such as service product, subscription rate, and so on.

History for the Distribution of Remaining Bandwidth Using Ratio Feature

Release

Modification

12.2(31)SB2

This feature was introduced and implemented on the Cisco 10000 series router for the PRE3.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for Distribution of Remaining Bandwidth Using Ratio

Restrictions for Distribution of Remaining Bandwidth Using Ratio

Information About Distribution of Remaining Bandwidth Using Ratio

How to Configure Distribution of Remaining Bandwidth Using Ratio Feature

Configuration Examples for Distribution of Remaining Bandwidth Using Ratio

Additional References

Command Reference

Prerequisites for Distribution of Remaining Bandwidth Using Ratio

You must configure traffic classes using the class-map command.

Restrictions for Distribution of Remaining Bandwidth Using Ratio

Bandwidth-remaining ratios are only available on outbound interfaces.

The bandwidth remaining ratio command cannot coexist with another bandwidth command in different traffic classes of the same policy map. For example, the following configuration is not valid and causes an error message to display:

policy-map Prec1
class precedence_0
bandwidth remaining ratio 10
class precedence_2
bandwidth 1000

The bandwidth remaining ratio command cannot coexist with another bandwidth command in the same class. For example, the following configuration is not valid and causes an error message to display:

policy-map Prec1
class precedence_0
bandwidth 1000
bandwidth remaining ratio 10

In a hierarchical policy map in which the parent policy has only the class-default class defined with a child queuing policy applied, the router accepts only the bandwidth remaining ratio form of the bandwidth command in the class-default class of the parent policy.

The bandwidth remaining ratio command cannot coexist with the priority command in the same class. For example, the following configuration is not valid and causes an error message to display:

policy-map Prec1
class precedence_1
priority percent 10
bandwidth remaining ratio 10

Information About Distribution of Remaining Bandwidth Using Ratio

The Distribution of Remaining Bandwidth Using Ratio feature allows service providers to prioritize subscriber traffic during periods of congestion. A bandwidth-remaining ratio is used to influence how the router allocates excess bandwidth (unused by priority traffic) to a class of non-priority traffic. Instead of using only bandwidth rate, the router considers configured minimum bandwidth rates, maximum bandwidth rates, and bandwidth-remaining ratios when determining excess bandwidth allocation. A bandwidth-remaining ratio adds more flexibility in prioritizing traffic and enables you to influence excess bandwidth allocation by basing the bandwidth-remaining ratio on factors other than speed.

When bandwidth-remaining ratios are not specified, the Hierarchical Queuing Framework (HQF) scheduler on the PRE3 does the following:

Computes a default bandwidth-remaining ratio based on the subinterface speed—ATM interfaces

Uses the minimum bandwidth-remaining ratio allowed (currently 1 on the PRE3)—Other interfaces such as VLANs and Frame Relay DLCIs

With bandwidth-remaining ratios, service providers have more flexibility in assigning priority to subinterfaces and queues during congestion. In addition to speed, you can base the bandwidth-remaining ratio on alternative factors, such as a service product or subscription rate. In this way, for example, you can give higher weight to subinterfaces carrying business services and lower weight to subinterfaces carrying residential services. The bandwidth-remaining ratio enables the HQF scheduler to service a subinterface with a low SCR but a high bandwidth-remaining ratio more frequently than servicing a subinterface with a high SCR but a low bandwidth-remaining ratio.

The Distribution of Remaining Bandwidth Using Ratio feature is available on outbound interfaces only.

Bandwidth-Remaining Ratio

A bandwidth-remaining ratio is a value from 1 to 1000 that is used to determine the amount of unused (excess) bandwidth to allocate to a class queue or subinterface-level queue during congestion. The router allocates excess bandwidth relative to the other class queues and subinterface-level queues configured on the physical interface. The bandwidth-remaining ratio value does not indicate a percentage. For example, a subinterface with a bandwidth-remaining ratio of 100 receives 10 times the unused (excess) bandwidth during congestion than a subinterface with a bandwidth-remaining ratio of 10.

Without bandwidth-remaining ratios, the router allocates excess bandwidth based on the following:

Speed of the subinterface (for example, the configured SCR)—ATM subinterfaces

Minimum bandwidth-remaining ratio allowed (currently 1 on the PRE3)—Interface types such as VLANs and Frame Relay DLCIs

With bandwidth-remaining ratios, excess bandwidth allocation can be based on factors other than the bandwidth rate (for example, service product or subscription rate).

How to Configure Distribution of Remaining Bandwidth Using Ratio Feature

You can apply bandwidth-remaining ratios to different subinterfaces and to different traffic queues within a single outbound interface or subinterface.

Use the following procedures to configure the Distribution of Remaining Bandwidth Using Ratio feature:

Configuring and Applying Bandwidth-Remaining Ratios to Subinterfaces

Configuring and Applying Bandwidth-Remaining Ratios to Class Queues

Configuring and Applying Bandwidth-Remaining Ratios to Subinterfaces

Use the following procedure to configure and apply bandwidth-remaining ratios to subinterfaces.


Note You can apply bandwidth-remaining ratios to outbound subinterfaces only.


SUMMARY STEPS

1. enable

2. configure terminal

3. policy-map child-policy-name

4. class class-map-name

5. bandwidth bandwidth-kbps

6. exit

7. exit

8. policy-map parent-policy-name

9. class class-default

10. bandwidth remaining ratio ratio

11. shape {average | peak} cir [bc] [be]

12. service-policy child-policy-name

13. exit

14. exit

15. interface type slot/module/port.subinterface {point-to-point | multipoint}

16. service-policy {input | output} parent-policy-name

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

policy-map child-policy-name

Example:

Router(config)# policy-map Child

Creates or modifies a child policy map. Enters policy-map configuration mode.

child-policy-name is the name of the child policy map.

Step 4 

class class-map-name

Example:

Router(config-pmap)# class precedence_0

Configures the class map that you specify. Enters policy-map class configuration mode.

class-map-name is the name of a previously created class map.

Step 5 

bandwidth bandwidth-kbps

Example:

Router(config-pmap-c)# bandwidth 10000

Specifies the bandwidth, in kbps, to be allocated to this traffic class.

bandwidth-kbps is the bandwidth in kilobits per second (kbps).

Note Repeat Steps 4 and 5 to configure additional traffic classes.

Step 6 

exit

Exits policy-map class configuration mode.

Step 7 

exit

Exits policy-map configuration mode.

Step 8 

policy-map parent-policy-name

Example:

Router(config)# policy-map Parent

Creates or modifies a parent policy map. Enters policy-map configuration mode.

parent-policy-name is the name of the parent policy map.

Step 9 

class class-default

Example:

Router(config-pmap)# class class-default

Configures the class-default class. Enters policy-map class configuration mode.

Note The router interprets any features configured under the class-default class as aggregate features on the subinterface.

Step 10 

bandwidth remaining ratio ratio

Example:

Router(config-pmap-c)# bandwidth remaining ratio 10

Specifies the bandwidth-remaining ratio for the subinterface.

ratio is the value used to determine the amount of unused bandwidth to allocate to each queue on the subinterface during periods of congestion. The scheduler allocates the excess bandwidth relative to other subinterfaces. Valid values are 1 to 1000. The default value is platform-dependent.

The router distinguishes between interface types at the subinterface level when using default bandwidth-remaining ratios. On the Cisco 10000 series router the default ratio value is 1 for VLAN subinterfaces and Frame Relay DLCIs. For ATM subinterfaces, the router computes the default based on the subinterface speed.

Step 11 

shape {average | peak} cir [bc] [be]

Example:

Router(config-pmap-c)# shape average 100000000

(Optional) Shapes the average or peak rate to the rate you specify.

average specifies average rate shaping.

peak specifies peak rate shaping.

cir specifies the committed information rate (CIR), in bits per second (bps).

(Optional) bc specifies the committed burst size, in bits.

(Optional) be specifies the excess burst size, in bits.

Step 12 

service-policy child-policy-name

Example:

Router(config-pmap-c)# service-policy Child

Applies the child policy map you specify to the traffic class. The router applies the QoS actions specified in the child policy to the traffic class.

child-policy-name is the name of the child policy.

Note The service-policy command typically requires that you specify the direction of the traffic using the input or output keywords. However, when applying a child policy to a parent policy, do not specify traffic direction.

Step 13 

exit

Example:

Router(config-pmap-c)# exit

Exits policy-map class configuration mode.

Step 14 

exit

Example:

Router(config-pmap)# exit

Exits policy-map configuration mode.

Step 15 

interface type slot/module/port.subinterface [point-to-point | multipoint]

Example:

Router(config)# interface GigabitEthernet 1/0/0.1

Creates or modifies the interface you specify. Enters subinterface configuration mode.

type is the interface type (for example, Gigabit Ethernet).

slot/module/port.subinterface is the number of the subinterface that identifies the subinterface (for example, 1/0/0.1).

(Optional) point-to-point indicates that the subinterface is a point-to-point subinterface.

(Optional) multipoint indicates that the subinterface is a point-to-multipoint subinterface.

Step 16 

service-policy {input | output} parent-policy-name

Example:

Router(config-subif)# service-policy output Parent

Applies the parent policy to the subinterface.

input indicates to apply the service policy to inbound traffic.

output indicates to apply the service policy to outbound traffic.

parent-policy-name is the name of the parent policy map.

The router shapes the subinterface traffic to the shaping rate specified in the parent class-default class and applies the QoS actions specified in the child policy to traffic matching the traffic classes.

During periods of congestion, the router uses the bandwidth-remaining ratio specified in the parent policy map to allocate unused bandwidth on this subinterface relative to other subinterfaces.

Configuring and Applying Bandwidth-Remaining Ratios to Class Queues

Use the following procedure to configure and apply bandwidth-remaining ratios to class queues.

SUMMARY STEPS

1. enable

2. configure terminal

3. policy-map child-policy-name

4. class class-map-name

5. shape {average | peak} cir [bc] [be]

6. bandwidth remaining ratio ratio

7. exit

8. exit

9. policy-map parent-policy-name

10. class class-default

11. shape {average | peak} cir [bc] [be]

12. bandwidth remaining ratio ratio

13. service-policy child-policy-name

14. exit

15. exit

16. interface type slot/module/port.subinterface {point-to-point | multipoint}

17. service-policy {input | output} parent-policy-name

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

policy-map child-policy-name

Example:

Router(config)# policy-map Child

Creates or modifies a child policy map. Enters policy-map configuration mode.

child-policy-name is the name of the child policy map.

Step 4 

class class-map-name

Example:

Router(config-pmap)# class precedence_0

Configures the class map that you specify. Enters policy-map class configuration mode.

class-map-name is the name of a previously created class map.

Step 5 

shape {average | peak} cir [bc] [be]

Example:

Router(config-pmap-c)# shape average 100000000

(Optional) Shapes the average or peak rate to the rate you specify.

average specifies average rate shaping.

peak specifies peak rate shaping.

cir specifies the committed information rate (CIR), in bits per second (bps).

(Optional) bc specifies the committed burst size, in bits.

(Optional) be specifies the excess burst size, in bits.

Step 6 

bandwidth remaining ratio ratio

Example:

Router(config-pmap-c)# bandwidth remaining ratio 10

(Optional) Specifies the bandwidth-remaining ratio for the traffic class.

ratio is the value used to determine the amount of unused bandwidth to allocate to each queue on the subinterface during periods of congestion. The scheduler allocates the excess bandwidth relative to other subinterfaces. Valid values are 1 to 1000. The default value is platform-dependent.

The router makes no distinction between interface types at the class level when using the default bandwidth-remaining ratio. On the Cisco 10000 series router the default bandwidth-remaining ratio value is 1.

Note Repeat Steps 5 and 6 for each class queue you want to define.

Step 7 

exit

Exits policy-map class configuration mode.

Step 8 

exit

Exits policy-map configuration mode.

Step 9 

policy-map parent-policy-name

Example:

Router(config)# policy-map Parent

Creates or modifies a parent policy map. Enters policy-map configuration mode.

parent-policy-name is the name of the parent policy map.

Step 10 

class class-default

Example:

Router(config-pmap)# class class-default

Configures the class-default class. Enters policy-map class configuration mode.

Note The router interprets any features configured under the class-default class as aggregate features on the subinterface.

Step 11 

shape {average | peak} cir [bc] [be]

Example:

Router(config-pmap-c)# shape average 100000000

Shapes the average or peak rate to the rate you specify.

average specifies average rate shaping.

peak specifies peak rate shaping.

cir specifies the committed information rate (CIR), in bits per second (bps).

(Optional) bc specifies the committed burst size, in bits.

(Optional) be specifies the excess burst size, in bits.

Step 12 

bandwidth remaining ratio ratio

Example:

Router(config-pmap-c)# bandwidth remaining ratio 10

(Optional) Specifies the bandwidth-remaining ratio for the subinterface.

ratio is the value used to determine the amount of unused bandwidth to allocate to each queue on the subinterface during periods of congestion. The scheduler allocates the excess bandwidth relative to other subinterfaces. Valid values are 1 to 1000. The default value is platform-dependent.

The router distinguishes between interface types at the subinterface level when using default bandwidth-remaining ratios. On the Cisco 10000 series router the default ratio value is 1 for VLAN subinterfaces and Frame Relay DLCIs. For ATM subinterfaces, the router computes the default based on the subinterface speed.

Step 13 

service-policy child-policy-name

Example:

Router(config-pmap-c)# service-policy Child

Applies the child policy map you specify to the traffic class. The router applies the QoS actions specified in the child policy to the traffic class.

child-policy-name is the name of the child policy.

Note The service-policy command typically requires that you specify the direction of the traffic using the input or output keywords. However, when applying a child policy to a parent policy, do not specify traffic direction.

Step 14 

exit

Example:

Router(config-pmap-c)# exit

Exits policy-map class configuration mode.

Step 15 

exit

Example:

Router(config-pmap)# exit

Exits policy-map configuration mode.

Step 16 

interface type slot/module/port.subinterface [point-to-point | multipoint]

Example:

Router(config)# interface GigabitEthernet 1/0/0.1

Creates or modifies the interface you specify. Enters subinterface configuration mode.

type is the interface type (for example, Gigabit Ethernet).

slot/module/port.subinterface is the number of the subinterface that identifies the subinterface (for example, 1/0/0.1).

(Optional) point-to-point indicates that the subinterface is a point-to-point subinterface.

(Optional) multipoint indicates that the subinterface is a point-to-multipoint subinterface.

Step 17 

service-policy {input | output} parent-policy-name

Example:

Router(config-subif)# service-policy output Parent

Applies the parent policy to the subinterface.

input indicates to apply the service policy to inbound traffic.

output indicates to apply the service policy to outbound traffic.

parent-policy-name is the name of the parent policy map.

Note When congestion occurs, the class queues receive bandwidth according to the specified class-level bandwidth-remaining ratios.

Configuration Examples for Distribution of Remaining Bandwidth Using Ratio

This section provides the following configuration examples:

Configuring Bandwidth-Remaining Ratios on Ethernet Subinterfaces: Example

Configuring Bandwidth-Remaining Ratios on ATM Subinterfaces: Example

Configuring Bandwidth-Remaining Ratios on Class Queues: Example

Verifying Bandwidth Remaining Ratios: Example

Configuring Bandwidth-Remaining Ratios on Ethernet Subinterfaces: Example

The following example shows how to configure bandwidth-remaining ratios on an Ethernet subinterface using a hierarchical policy. In the example, Gigabit Ethernet subinterface 1/0/0.1 is shaped to 100 Mbps. During congestion, the router uses the bandwidth-remaining ratio of 10 to determine the amount of excess bandwidth (unused by priority traffic) to allocate to the non-priority traffic on subinterface 1/0/0.1, relative to the other subinterface-level and class-level queues on the interface.

policy-map Child
class precedence_0
bandwidth 10000
class precedence_1
shape average 100000
bandwidth 100
!
policy-map Parent
class class-default
bandwidth remaining ratio 10
shape average 100000000
service-policy Child
!
interface GigabitEthernet1/0/0.1
encapsulation dot1Q 100
ip address 10.1.0.1 255.255.255.0
service-policy output Parent

Configuring Bandwidth-Remaining Ratios on ATM Subinterfaces: Example

The following example shows how to differentiate one ATM PVC from another during congestion by using bandwidth-remaining ratios. In the example, during periods of congestion in which the traffic on all PVCs on the interface exceeds the interface speed, the router uses the configured bandwidth-remaining ratio of 10 to determine the amount of excess (unused by priority traffic) bandwidth to allocate to non-priority traffic on PVC 0/200, relative to the other ATM PVCs configured on the interface.

policy-map Child
class precedence_0
bandwidth 100
class precedence_1
bandwidth 10000
!
policy-map Parent
class class-default
bandwidth remaining ratio 10
service-policy Child
!
interface ATM2/0/3.200 point-to-point
ip address 10.20.1.1 255.255.255.0
pvc 0/200
protocol ip 10.20.1.2
vbr-nrt 50000
encapsulation aal5snap
service-policy output Parent

Note If PVC 98/204 is configured on the same interface as PVC 0/200 and with a bandwidth-remaining ratio of 1, during times of congestion PVC 0/200 would have 10 times more bandwidth available to it for non-priority traffic than PVC 98/204 would have.


Configuring Bandwidth-Remaining Ratios on Class Queues: Example

In the following sample configuration, the vlan10_policy is applied on the subinterface Gigabit Ethernet 1/0/0.10 and the vlan20_policy is applied on the subinterface Gigabit Ethernet 1/0/0.20. During congestion on the interface, subinterface GE 1/0/0.20 has 10 times more available bandwidth than subinterface GE1/0/0.10 because the bandwidth-remaining ratio for subinterface GE 1/0/0.20 is 10 times more than the bandwidth-remaining ratio for subinterface 1/0/0.10: 100 on subinterface 1/0/0.20 and 10 on subinterface 1/0/0.10.

When congestion occurs within a subinterface level, the class queues receive bandwidth according to the class-level bandwidth-remaining ratios. In the example, the bandwidth for classes precedence_0, precedence_1, and precedence_2 is allocated based on the bandwidth-remaining ratios of the classes: 20, 40, and 60, respectively.

policy-map child-policy
class precedence_0
shape average 500000
bandwidth remaining ratio 20 <---- Class-level ratio
class precedence_1
shape average 500000
bandwidth remaining ratio 40 <---- Class-level ratio
class precedence_2
shape average 500000
bandwidth remaining ratio 60 <---- Class-level ratio
!
policy-map vlan10_policy
class class-default
shape average 1000000
bandwidth remaining ratio 10 <---- Subinterface-level ratio
service-policy child-policy
!
policy-map vlan20_policy
class class-default
shape average 1000000
bandwidth remaining ratio 100 <---- Subinterface-level ratio
service-policy child_policy
!
!
interface GigabitEthernet 1/0/0.10
encapsulation dot1q 10
service-policy output vlan10_policy
!
interface GigabitEthernet 1/0/0.20
encapsulation dot1q 20
service-policy output vlan20_policy

Verifying Bandwidth Remaining Ratios: Example

The following sample output from the show policy-map interface command indicates that bandwidth-remaining ratios are configured on class-level queues in the policy maps named vlan10_policy and child_policy, which are attached to the Gigabit Ethernet subinterface 1/0/0.10.

Router# show policy-map interface GigabitEthernet1/0/0.10 

  Service-policy output: vlan10_policy

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        30 second rate 0 bps
      Queueing
      queue limit 250 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      shape (average) cir 1000000, bc 4000, be 4000
      target shape rate 1000000
      bandwidth remaining ratio 10

      Service-policy : child_policy

        Class-map: precedence_0 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 0
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 20

        Class-map: precedence_1 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 1
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 40

        Class-map: precedence_2 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 2
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 60

        Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any
            0 packets, 0 bytes
            30 second rate 0 bps
         
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0 

The following sample output from the show policy-map interface command indicates that bandwidth-remaining ratios are configured on class-level queues in the policy maps named vlan20_policy and child_policy, which are attached to the Gigabit Ethernet subinterface 1/0/0.20.

Router# show policy-map interface GigabitEthernet1/0/0.20

  Service-policy output: vlan20_policy

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        30 second rate 0 bps
      Queueing
      queue limit 250 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      shape (average) cir 1000000, bc 4000, be 4000
      target shape rate 1000000
      bandwidth remaining ratio 100

      Service-policy : child_policy

        Class-map: precedence_0 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 0
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 20

        Class-map: precedence_1 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 1
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 40

        Class-map: precedence_2 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 2
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 60

        Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any
            0 packets, 0 bytes
            30 second rate 0 bps
         
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0 

The following sample output from the show policy-map command indicates that a bandwidth-remaining ratio of 10 is configured on the parent class-default class of the policy map named vlan10_policy.

Router# show policy-map vlan10_policy                   
  Policy Map vlan10_policy
    Class class-default
      Average Rate Traffic Shaping
      cir 1000000 (bps)
      bandwidth remaining ratio 10
      service-policy child_policy

The following sample output from the show policy-map command indicates that a bandwidth-remaining ratio of 100 is configured on the parent class-default class of the policy map named vlan20_policy. During congestion, the scheduler allocates the subinterface Gigabit Ethernet 1/0/0.20 10 times the bandwidth that it allocates subinterface Gigabit Ethernet 1/0/0.10.

Router# show policy-map vlan20_policy
  Policy Map vlan20_policy
    Class class-default
      Average Rate Traffic Shaping
      cir 1000000 (bps)
      bandwidth remaining ratio 100
      service-policy child_policy

The following sample output from the show policy-map command indicates that a bandwidth-remaining ratio of 20, 40, and 60 is configured on the class queues precedence_0, precedence_1, and precedence_2, respectively.


Router# show policy-map child_policy
  Policy Map child_policy
    Class precedence_0
      Average Rate Traffic Shaping
      cir 500000 (bps)
      bandwidth remaining ratio 20
    Class precedence_1
      Average Rate Traffic Shaping
      cir 500000 (bps)
      bandwidth remaining ratio 40
    Class precedence_2
      Average Rate Traffic Shaping
      cir 500000 (bps)
      bandwidth remaining ratio 60

Additional References

The following sections provide references related to Distribution of Remaining Bandwidth Using Ratio.

Related Documents


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents new and modified commands only.

bandwidth remaining ratio

show policy-map

show policy-map interface

bandwidth remaining ratio

To specify a bandwidth-remaining ratio for class-level or subinterface-level queues to be used during congestion to determine the amount of excess bandwidth (unused by priority traffic) to allocate to non-priority queues, use the bandwidth remaining ratio command in policy-map class configuration mode. To remove the bandwidth-remaining ratio, use the no form of this command.

bandwidth remaining ratio ratio

no bandwidth remaining ratio ratio

Syntax Description

ratio

Specifies the relative weight of this subinterface or queue with respect to other subinterfaces or queues. Valid values are from 1 to 1000. The default value is platform dependent.


Command Default

Cisco 10000 Series Router

When using default bandwidth-remaining ratios at the subinterface level, the Cisco 10000 series router distinguishes between interface types. At the subinterface level, the default bandwidth-remaining ratio is 1 for VLAN subinterfaces and Frame Relay DLCIs. For ATM subinterfaces, the router computes the default bandwidth-remaining ratio based on the subinterface speed.

When using default bandwidth-remaining ratios at the class level, the Cisco 10000 series router makes no distinction between interface types. At the class level, the default bandwidth-remaining ratio is 1.

Command Modes

Policy-map class

Command History

Release
Modification

12.2(31)SB

This command was introduced and implemented on the Cisco 10000 series router for the PRE3.


Usage Guidelines

Cisco 10000 Series Router

The scheduler uses the ratio specified in the bandwidth remaining ratio command to determine the amount of excess bandwidth (unused by priority traffic) to allocate to a class-level queue or a subinterface-level queue during periods of congestion. The scheduler allocates the unused bandwidth relative to other queues or subinterfaces.

The bandwidth remaining ratio command cannot coexist with another bandwidth command in different traffic classes of the same policy map. For example, the following configuration is not valid and causes an error message to display:

policy-map Prec1
class precedence_0
bandwidth remaining ratio 10
class precedence_2
bandwidth 1000

For the PRE2, the bandwidth remaining ratio command can coexist with another bandwidth command in the same class of a policy map. On the PRE3, the bandwidth remaining ratio command cannot coexist with another bandwidth command in the same class. For example, the following configuration is not valid on the PRE3 and causes an error message to display:

policy-map Prec1
class precedence_0
bandwidth 1000
bandwidth remaining ratio 10

In a hierarchical policy map in which the parent policy has only the class-default class defined with a child queuing policy applied, the router accepts only the bandwidth remaining ratio form of the bandwidth command in the class-default class.

The bandwidth remaining ratio command cannot coexist with the priority command in the same class. For example, the following configuration is not valid and causes an error message to display:

policy-map Prec1
class precedence_1
priority
police percent 30
bandwidth remaining ratio 10

All of the queues for which the bandwidth remaining ratio command is not specified receive the platform-specified minimum bandwidth-remaining ratio. The router determines the minimum committed information rate (CIR) based on the configuration.

Examples

The following example shows how to configure a bandwidth-remaining ratio on an ATM subinterface. In the example, the router guarantees a peak cell rate of 50 Mbps for the variable bit rate-non-real time (VBR-nrt) PVC 0/200. During periods of congestion, the subinterface receives a share of excess bandwidth (unused by priority traffic) based on the bandwidth-remaining ratio of 10, relative to the other subinterfaces configured on the physical interface.

policy-map Child
class precedence_0
bandwidth 10000
class precedence_1
shape average 100000
bandwidth 100
!
policy-map Parent
class class-default
bandwidth remaining ratio 10
shape average 20000000
service-policy Child
!
interface ATM2/0/3.200 point-to-point
ip address 10.20.1.1 255.255.255.0
pvc 0/200
protocol ip 10.20.1.2
vbr-nrt 50000
encapsulation aal5snap
service-policy output Parent

The following example shows how to configure bandwidth remaining ratios for individual class queues. Some of the classes configured have bandwidth guarantees and a bandwidth-remaining ratio explicitly specified. When congestion occurs within a subinterface level, the class queues receive excess bandwidth (unused by priority traffic) based on their class-level bandwidth-remaining ratios: 20, 30, 120, and 100, respectively for the precedence_0, precedence_1, precedence_2, and precedence_5 classes. Normally, the precedence_3 class (without a defined ratio) would receive bandwidth based on the bandwidth-remaining ratio of the class-default class defined in the Child policy. However, in the example, the Child policy does not define a class-default bandwidth remaining ratio, therefore, the router uses a ratio of 1 to allocate excess bandwidth to precedence_3 traffic.

policy-map Child
class precedence_0
shape average 100000
bandwidth remaining ratio 20
class precedence_1
shape 10000
bandwidth remaining ratio 30
class precedence_2
shape average 200000
bandwidth remaining ratio 120
class precedence_3
set ip precedence 3
class precedence_5
set ip precedence 5
bandwidth remaining ratio 100
policy-map Parent
class class-default
bandwidth remaining ratio 10
service-policy Child
!
interface GigabitEthernet 2/0/1.10
encapsulation dot1q 10
service-policy output Parent

Related Commands

Command
Description

show policy-map

Displays the configuration of all classes for a specified service policy map or all classes for all existing policy maps. If configured, the command output includes information about ATM overhead accounting and bandwidth-remaining ratios, used to determine a queue's fair share of excess bandwidth during congestion.

show policy-map interface

Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface. If configured, the command output includes information about bandwidth-remaining ratios, used to determine a queue's fair share of excess bandwidth during congestion.


show policy-map

To display the configuration of all classes for a specified service policy map or all classes for all existing policy maps, use the show policy-map command in EXEC mode.

show policy-map [policy-map]

Syntax Description

policy-map

(Optional) Name of the service policy map whose complete configuration is to be displayed.


Command Default

All existing policy map configurations are displayed.

Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(5)XE

This command was integrated into Cisco IOS Release 12.0(5)XE.

12.0(7)S

This command was integrated into Cisco IOS Release 12.0(7)S.

12.1(1)E

This command was integrated into Cisco IOS Release 12.1(1)E.

12.2(13)T

The output of this command was modified for the Percentage-Based Policing and Shaping feature and includes the bandwidth percentage used when calculating traffic policing and shaping.

12.0(28)S

The output of this command was modified for the QoS: Percentage-Based Policing feature to display the committed (conform) burst (Bc) and excess (peak) burst (Be) sizes in milliseconds (ms).

12.2(14)SX

Support for this command was introduced on the Supervisor Engine 720.

12.2(17d)SXB

Support for this command on the Supervisor Engine 2 was extended to Cisco IOS Release 12.2 SX.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(31)SB2

This command was enhanced to display bandwidth-remaining ratios configured on traffic classes and ATM overhead accounting, and was implemented on the Cisco 10000 series router for the PRE3.


Usage Guidelines

The show policy-map command displays the configuration of a service policy map created using the policy-map command. You can use the show policy-map command to display all class configurations comprising any existing service policy map, whether or not that service policy map has been attached to an interface. The command output includes bandwidth-remaining ratio configuration and statistical information, if configured and used to determine the amount of unused (excess) bandwidth to allocate to a class queue during periods of congestion.

Examples

The following is sample output from the show policy-map command. This sample output displays the contents of a policy map called "policy1." In policy 1, traffic policing on the basis of a committed information rate (CIR) of 20 percent has been configured, and the bc and be have been specified in milliseconds. As part of the traffic policing configuration, optional conform, exceed, and violate actions have been specified.

Router# show policy-map policy1

  Policy Map policy1
    Class class1
     police cir percent 20 bc 300 ms pir percent 40 be 400 ms
       conform-action transmit 
       exceed-action drop 
       violate-action drop 

Table 1 describes the significant fields shown in the display.

Table 1 show policy-map Field Descriptions 

Field
Description

Policy Map

Name of policy map displayed.

Class

Name of the class configured in the policy map displayed.

police

Indicates that traffic policing on the basis of specified percentage of bandwidth has been enabled. The committed burst (Bc) and excess burst (Be) sizes have been specified in milliseconds (ms), and optional conform, exceed, and violate actions have been specified.


Bandwidth-Remaining Ratio Example

The following sample output for the show policy-map command indicates that the class-default class of the policy map named vlan10_policy has a bandwidth-remaining ratio of 10. When congestion occurs, the scheduler allocates class-default traffic 10 times the unused bandwidth allocated in relation to other subinterfaces.

Router# show policy-map vlan10_policy                   
  Policy Map vlan10_policy
    Class class-default
      Average Rate Traffic Shaping
      cir 1000000 (bps)
      bandwidth remaining ratio 10
      service-policy child_policy

ATM Overhead Accounting Example

The following sample output for the show policy-map command indicates that ATM overhead accounting is enabled for the class-default class. The BRAS-DSLAM encapsulation is dot1q and the subscriber encapsulation is snap-rbe for the AAL5 service.

Policy Map unit-test
Class class-default
Average Rate Traffic Shaping
cir 10% account dot1q aal5 snap-rbe

Table 2 describes the significant fields shown in the display.

Table 2 show policy-map Field Descriptions for ATM Overhead Accounting 

Field
Description

Average Rate

Committed burst (Bc) is the maximum number of bits sent out in each interval.

cir 10%

Committed information rate (CIR) is 10 percent of the available interface bandwidth.

dot1q

BRAS-DSLAM encapsulation is 802.1Q VLAN.

aal5

DSLAM-CPE encapsulation type is based on the ATM Adaptation Layer 5 service. AAL5 supports connection-oriented variable bit rate (VBR) services.

snap-rbe

Subscriber encapsulation type.


Related Commands

Command
Description

bandwidth

Specifies or modifies the bandwidth allocated for a class belonging to a policy map, and enables ATM overhead accounting.

bandwidth remaining ratio

Specifies a bandwidth-remaining ratio for class queues and subinterface-level queues to determine the amount of unused (excess) bandwidth to allocate to the queue during congestion.

class (policy map)

Specifies the name of the class whose policy you want to create or change, and the default class (commonly known as the class-default class) before you configure its policy.

class-map

Creates a class map to be used for matching packets to a specified class.

policy-map

Creates or modifies a policy map that can be attached to one or more interfaces to specify a service policy.

shape

Shapes traffic to the indicated bit rate according to the algorithm specified, and enables ATM overhead accounting.

show policy-map interface

Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface. If configured, the command output includes information about bandwidth-remaining ratios, used to determine a queue's fair share of excess bandwidth during congestion.

show running-config

Displays the current configuration of the router. If configured, the command output includes information about ATM overhead accounting.


show policy-map interface

To display the packet statistics of all classes and all priority levels configured for all service policies either on the specified interface or subinterface or on a specific permanent virtual circuit (PVC) on the interface, use the show policy-map interface command in privileged EXEC mode.

show policy-map interface [type access-control] interface-name [vc [vpi/] vci] [dlci dlci]
[
input | output]

ATM Shared Port Adapter

show policy-map interface atm slot/subslot/port[.subinterface]

Syntax Description

type access-control

(Optional) Displays class maps configured to determine the exact pattern to look for in the protocol stack of interest.

interface-name

Name of the interface or subinterface whose policy configuration is to be displayed.

vc

(Optional) For ATM interfaces only, shows the policy configuration for a specified PVC. The name can be up to 16 characters long.

vpi/

(Optional) ATM network virtual path identifier (VPI) for this PVC. On the Cisco 7200 and 7500 series routers, this value ranges from 0 to 255.

The vpi and vci arguments cannot both be set to 0; if one is 0, the other cannot be 0.

vci

(Optional) ATM network virtual channel identifier (VCI) for this PVC. This value ranges from 0 to 1 less than the maximum value set for this interface by the atm vc-per-vp command. Typically, the lower values 0 to 31 are reserved for specific traffic (F4 Operation, Administration, and Maintenance (OAM), switched virtual circuit (SVC) signaling, Integrated Local Management Interface (ILMI), and so on) and should not be used.

The VCI is a 16-bit field in the header of the ATM cell. The VCI value is unique only on a single link, not throughout the ATM network, because it has local significance only.

The vpi and vci arguments cannot both be set to 0; if one is 0, the other cannot be 0.

dlci

(Optional) Indicates that a specific PVC for which policy configuration will be displayed.

dlci

(Optional) A specific data-link connection identifier (DLCI) number used on the interface. Policy configuration for the corresponding PVC will be displayed when a DLCI is specified.

input

(Optional) Indicates that the statistics for the attached input policy will be displayed.

output

(Optional) Indicates that the statistics for the attached output policy will be displayed.

slot

(ATM Shared Port Adapter only) Chassis slot number. Refer to the appropriate hardware manual for slot information. For SIPs, refer to the platform-specific SPA hardware installation guide or the corresponding "Identifying Slots and Subslots for SIPs, SSCs, and SPAs" topic in the platform-specific SPA software configuration guide.

/subslot

(ATM Shared Port Adapter only) Secondary slot number on a SPA interface processor (SIP) where a SPA is installed. Refer to the platform-specific SPA hardware installation guide and the corresponding "Specifying the Interface Address on a SPA" topics in the platform-specific SPA software configuration guide for subslot information.

/port

(ATM Shared Port Adapter only) Port or interface number. Refer to the appropriate hardware manual for port information. For SPAs, refer to the corresponding "Specifying the Interface Address on a SPA" topics in the platform-specific SPA software configuration guide.

.subinterface

(ATM Shared Port Adapter onlyOptional) Subinterface number. The number that precedes the period must match the number to which this subinterface belongs. The range is 1 to 4,294,967,293.


Defaults

The absence of both the forward slash (/) and a vpi value defaults the vpi value to 0. If this value is omitted, information for all virtual circuits (VCs) on the specified ATM interface or subinterface is displayed.

ATM Shared Port Adapter

When used with the ATM shared port adapter, this command has no default behavior or values.

Command Modes

Privileged EXEC

ATM Shared Port Adapter

When used with the ATM shared port adapter, EXEC or privileged EXEC.

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(5)XE

This command was integrated into Cisco IOS Release 12.0(5)XE.

12.0(7)S

This command was integrated into Cisco IOS Release 12.0(7)S.

12.1(1)E

This command was integrated into Cisco IOS Release 12.1(1)E.

12.1(2)T

This command was modified to display information about the policy for all Frame Relay PVCs on the interface, or, if a DLCI is specified, the policy for that specific PVC. This command was also modified to display the total number of packets marked by the quality of service (QoS) set action.

12.1(3)T

This command was modified to display per-class accounting statistics.

12.2(4)T

This command was modified for two-rate traffic policing. It now can display burst parameters and associated actions.

12.2(8)T

The command was modified for the Policer Enhancement—Multiple Actions feature and the WRED—Explicit Congestion Notification (ECN) feature.

For the Policer Enhancement—Multiple Actions feature, the command was modified to display the multiple actions configured for packets conforming to, exceeding, or violating a specific rate.

For the WRED—Explicit Congestion Notification (ECN) feature, the command displays ECN marking information

12.2(13)T

The following modifications were made:

This command was modified for the Percentage-Based Policing and Shaping feature.

This command was modified for the Class-Based RTP and TCP Header Compression feature.

This command was modified as part of the Modular QoS CLI (MQC) Unconditional Packet Discard feature. Traffic classes in policy maps can now be configured to discard packets belonging to a specified class.

This command was modified to display the Frame Relay DLCI number as a criterion for matching traffic inside a class map.

This command was modified to display Layer 3 packet length as a criterion for matching traffic inside a class map.

This command was modified for the Enhanced Packet Marking feature. A mapping table (table map) can now be used to convert and propagate packet-marking values.

12.2(15)T

This command was modified to display Frame Relay voice-adaptive traffic-shaping information.

12.0(28)S

This command was modified for the QoS: Percentage-Based Policing feature to include milliseconds when calculating the committed (conform) burst (bc) and excess (peak) burst (be) sizes.

12.3(14)T

This command was modified to display bandwidth estimation parameters.

12.2(18)SXE

This command was integrated into Cisco IOS Release 12.2(18)SXE. This command was modified to display aggregate WRED statistics for the ATM shared port adapter. Note that changes were made to the syntax, defaults, and command modes. These changes are labelled "ATM Shared Port Adapter" in this document.

12.4(4)T

The type access-control keywords were added to support flexible packet matching.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and its output was modified to display either legacy (nondistributed processing) QoS or hierarchical queueing framework (HQF) parameters on Frame Relay interfaces or PVCs.

12.2(31)SB2

This command was enhanced to display statistical information for each level of priority service configured and information about bandwidth-remaining ratios, and was implemented on the Cisco 10000 series router for the PRE3.


Usage Guidelines

The show policy-map interface command displays the packet statistics for classes and priority levels on the specified interface or the specified PVC only if a service policy has been attached to the interface or the PVC. The command output includes bandwidth-remaining ratios configured on traffic classes.

You can use the interface-name argument to display output for a PVC only for enhanced ATM port adapters (for example, the PA-A3) that support per-VC queueing.

The counters displayed after the show policy-map interface command is entered are updated only if congestion is present on the interface.

The show policy-map interface command displays policy information about Frame Relay PVCs only if Frame Relay Traffic Shaping (FRTS) is enabled on the interface.

The show policy-map interface command displays ECN marking information only if ECN is enabled on the interface.

To determine if shaping is active with the hierarchical queuing framework (HQF), check the queue depth field of the "(queue depth/total drops/no-buffer drops)" line in the show policy-map interface command output.

Examples

Example of Multiple Priority Queues on Serial Interface

The following sample output from the show policy-map interface command shows the types of statistical information that displays when multiple priority queues are configured. Depending upon the interface in use and the options enabled, the output you see may vary slightly from the output shown below.

Router# show policy-map interface

Serial2/1/0
Service-policy output: P1
Queue statistics for all priority classes:
.
.
.
Class-map: Gold (match-all)
0 packets, 0 bytes			/*Updated for each priority level configured.*/
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip precedence 2
Priority: 0 kbps, burst bytes 1500, b/w exceed drops: 0
Priority Level 4:
0 packets, 0 bytes

Example of Bandwidth-Remaining Ratios

The following sample output from the show policy-map interface command indicates that bandwidth-remaining ratios are configured for class queues. As shown in the example, the classes precedence_0, precedence_1, and precedence_2 have bandwidth-remaining ratios of 20, 40, and 60, respectively.

Router# show policy-map interface GigabitEthernet1/0/0.10

  Service-policy output: vlan10_policy

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
        30 second rate 0 bps
      Queueing
      queue limit 250 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      shape (average) cir 1000000, bc 4000, be 4000
      target shape rate 1000000
      bandwidth remaining ratio 10

      Service-policy : child_policy

        Class-map: precedence_0 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 0
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 20

        Class-map: precedence_1 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 1
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 40

        Class-map: precedence_2 (match-all)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 2
          Queueing
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 500000, bc 2000, be 2000
          target shape rate 500000
          bandwidth remaining ratio 60

        Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any
            0 packets, 0 bytes
            30 second rate 0 bps
         
          queue limit 62 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0 

Related Commands

Command
Description

bandwidth remaining ratio

Specifies a bandwidth-remaining ratio for class queues and subinterface-level queues to determine the amount of unused (excess) bandwidth to allocate to the queue during congestion.

priority

Specifies that low-latency behavior must be given to a traffic class and configures multiple priority queues.

police

Configures traffic policing.

police (percent)

Configures traffic policing on the basis of a percentage of bandwidth available on an interface.

police (two rates)

Configures traffic policing using two rates, the committed information rate (CIR) and the peak information rate (PIR).

policy-map

Creates or modifies a policy map that can be attached to one or more interfaces to specify a service policy.

show interfaces

Displays statistics for all interfaces configured on a router or access server.

show policy-map

Displays the configuration of all classes for a specified service policy map or all classes for all existing policy maps. If configured, the command output includes information about ATM overhead accounting and bandwidth-remaining ratios, used to determine a queue's fair share of excess bandwidth during congestion.

show policy-map class

Displays the configuration for the specified class of the specified policy map.