Guest

Cisco IOS Software Releases 12.2 S

NSF/SSO: Any Transport over MPLS and Graceful Restart

  • Viewing Options

  • PDF (259.3 KB)
  • Feedback
NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

Table Of Contents

NSF/SSO—Any Transport over MPLS and AToM Graceful Restart

Contents

Prerequisites for AToM NSF

Supported Hardware

Supported Port Adapters

Supported RSPs

Supported VIPs

Neighbor Routers in the MPLS HA Environment

Stateful Switchover

Nonstop Forwarding for Routing Protocols

Restrictions for AToM NSF

Information About AToM NSF

How AToM NSF Works

Checkpointing AToM Information

Checkpointing Troubleshooting Tips

How to Configure AToM NSF

Configuring AToM

Configuring SSO on the Route Processors

Configuring Nonstop Forwarding on the Routers

Configuring MPLS LDP Graceful Restart

Verifying the Configuration

Configuration Examples for AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for AToM NSF


NSF/SSO—Any Transport over MPLS and AToM Graceful Restart


First Published: August 11, 2004
Last Updated: June 8, 2010

Cisco nonstop forwarding (NSF) with stateful switchover (SSO) is effective at increasing availability of network services. Cisco NSF with SSO provides continuous packet forwarding, even during a network processor hardware or software failure. In a redundant system, the secondary processor recovers control plane service during a critical failure in the primary processor. SSO synchronizes the network state information between the primary and the secondary processor.

Any Transport over MPLS (AToM) uses NSF, SSO, and Graceful Restart to allow a Route Processor (RP) to recover from a disruption in control plane service without losing its MPLS forwarding state.


Note In this document, the NSF/SSO—Any Transport over MPLS and AToM Graceful Restart feature is referred to as AToM NSF for brevity.


Finding Feature Information in This Module

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for AToM NSF" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for AToM NSF

Restrictions for AToM NSF

Information About AToM NSF

How to Configure AToM NSF

Configuration Examples for AToM NSF

Additional References

Command Reference, page 10

Feature Information for AToM NSF

Prerequisites for AToM NSF

This section lists the following prerequisites:

Supported Hardware

Neighbor Routers in the MPLS HA Environment

Stateful Switchover

Nonstop Forwarding for Routing Protocols

Supported Hardware

The AToM NSF feature is supported on the Cisco 7500 series routers, with the port adapters, versatile interface processors (VIPs), and route switch processors (RSPs) listed in the following sections.

Supported Port Adapters

GEIP+

PA-2FE-TX, PA-2FE-FX

PA-2H, PA-H

PA-4E, PA-8E

PA-4T+ and/or PA-8T-232, PA-8T-V35, PA-8T-X21

PA-A3-OC3-MM, PA-A3-OC3-SMI, PA-A3-OC3-SML

PA-FE-TX, PA-FE-FX

PA-MC_8E1/120, MC-4E1, MC-2E1, MC-8T1, MC-4T1, MC-2T1

PA-MC-8E1IMA

PA-MC-8TE1+

PA-MC-E3

PA-MC-STM1-MM, PA-MC-STM1-SMI

PA-MC-T3, PA-MC-2T3+

PA-POS-OC3-MM, PA-POS-OC3-SMI, PA-POS-OC3-SML

Supported RSPs

RSP4

RSP4+

RSP8

RSP16

Supported VIPs

VIP2-50

VIP4-50

VIP4-80

VIP6-80

Neighbor Routers in the MPLS HA Environment

AToM NSF requires that neighbor networking devices be able to perform AToM GR. The Cisco 7200 and Cisco 7500 routers are capable of supporting AToM GR and can be used as neighbor networking devices.

Stateful Switchover

To perform AToM NSF, Route Processors must be configured for SSO and Graceful Restart. See the Stateful Switchover feature module for more information.

Nonstop Forwarding for Routing Protocols

You must enable NSF on the routing protocols running between the provider (P) routers, provider edge (PE) routers, and customer edge (CE) routers. The routing protocols are the following:

Border Gateway Protocol (BGP)

Open Shortest Path First (OSPF)

Intermediate System-to-Intermediate System (IS-IS)

See the Cisco Nonstop Forwarding feature module for more information.

Restrictions for AToM NSF

AToM NSF includes the following restrictions:

Tag Distribution Protocol (TDP) sessions are not supported. Only Label Distribution Protocol (LDP) sessions are supported.

AToM NSF cannot be configured on label-controlled ATM (LC-ATM) interfaces.

AToM NSF supports AToM L2VPN Interworking. However, Layer 2 Tunnel Protocol Version 3 (L2TPv3) Interworking is not supported.

AToM NSF interoperates with Layer 2 Local Switching. However, AToM NSF has no effect on interfaces configured for local switching.

Disable fair queueing on serial interfaces or distributed Cisco Express Forwarding will not work on the interfaces.

On the Cisco 7500 series routers, distributed Cisco Express Forwarding is needed to support AToM NSF.

Information About AToM NSF

How AToM NSF Works

Checkpointing AToM Information

How AToM NSF Works

AToM NSF improves the availability of a service provider's network that uses AToM to provide Layer 2 VPN services to its customers. HA provides the ability to detect failures and handle them with minimal disruption to the service being provided. AToM NSF is achieved by SSO and NSF mechanisms. A standby RP provides control-plane redundancy. The control plane state and data plane provisioning information for the attachment circuits (ACs) and AToM pseudowires (PWs) are checkpointed to the standby RP to provide NSF for AToM L2VPNs.

Checkpointing AToM Information

Checkpointing is a function that copies state information from the active RP to the backup RP, thereby ensuring that the backup RP has the latest information. If the active RP fails, the backup RP can take over.

For the AToM NSF feature, the checkpointing function copies the active RP's information bindings to the backup RP. The active RP sends updates to the backup RP when information is modified.

To display checkpointing data, issue the show acircuit checkpoint command on the active and backup RPs. The active and backup RPs have identical copies of the information.

Checkpointing Troubleshooting Tips

To help troubleshoot checkpointing errors, use the following commands:

Use the debug acircuit checkpoint command to enable checkpointing debug messages for ACs.

Use the debug mpls l2transport checkpoint command to enable checkpointing debug messages for AToM.

Use the show acircuit checkpoint command to display the AC checkpoint information.

Use the show mpls l2transport checkpoint command to display whether checkpointing is allowed, how many AToM VCs were bulk-synced (on the active RP), and how many AToM VCs have checkpoint data (on the standby RP).

Use the show mpls l2transport vc detail command to display details of VC checkpointed information.

How to Configure AToM NSF

Configuring AToM (required)

Configuring SSO on the Route Processors (required)

Configuring Nonstop Forwarding on the Routers (required)

Configuring MPLS LDP Graceful Restart (required)

Verifying the Configuration (optional)

Configuring AToM

AToM virtual circuits (VCs) must be configured on the router. See the Any Transport over MPLS feature module for information on configuring AToM. For configuring L2VPN Interworking, see the L2VPN Interworking feature module.

Configuring SSO on the Route Processors

Route processors must be configured for SSO. See the Stateful Switchover feature module for configuration information.

Configuring Nonstop Forwarding on the Routers

You must enable Nonstop Forwarding on the routing protocols running between the P routers, PE routers, and CE routers. The routing protocols include OSPF, IS-IS, and BGP. See the Cisco Nonstop Forwarding feature module for configuration information.

Configuring MPLS LDP Graceful Restart

MPLS LDP Graceful Restart (GR) is enabled globally. When you enable LDP GR, it has no effect on existing LDP sessions. LDP GR is enabled for new sessions that are established after the feature has been globally enabled.

Perform this task to configure MPLS LDP GR.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef [distributed]

4. mpls ldp graceful-restart

5. interface type slot/port

6. mpls ip

7. mpls label protocol {ldp | tdp | both}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef [distributed]

Example:

Router(config)# ip cef distributed

Enables Cisco Express Forwarding.

Step 4 

mpls ldp graceful-restart
Example:
Router (config)# mpls ldp graceful-restart

Enables the router to protect the LDP bindings and MPLS forwarding state during a disruption in service.

Step 5 

interface type slot/port
Example:
Router(config)# interface pos 3/0 

Specifies an interface and enters interface configuration mode.

Step 6 

mpls ip

Example:

Router(config-if)# mpls ip

Configures MPLS hop-by-hop forwarding for an interface.

Step 7 

mpls label protocol {ldp | tdp | both}

Example:

Router(config-if)# mpls label protocol ldp

Configures the use of LDP for an interface.

You must use LDP, because TDP sessions are not supported.

You can also issue the mpls label protocol ldp command in global configuration mode, which enables LDP on all interfaces configured for MPLS.


Verifying the Configuration

The following commands help verify that AToM NSF has been configured correctly:

show mpls ldp neighbor with the graceful-restart keyword

Displays the Graceful Restart information for LDP sessions.

show mpls ldp graceful-restart

Displays Graceful Restart sessions and session parameters.


Configuration Examples for AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

Example: Ethernet to VLAN Interworking with AToM NSF

The following example shows how to configure AToM NSF on two PE routers.

PE1
PE2
ip cef distributed
!
redundancy
mode sso
!
hw-module slot 2 image slot1:rsp-pv-mz
hw-module slot 3 image slot1:rsp-pv-mz
!
mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-tags
!
pseudowire-class atom-eth
 encapsulation mpls
 interworking ethernet
!
interface Loopback0
 ip address 10.8.8.8 255.255.255.255
!
interface FastEthernet1/1/0
 xconnect 10.9.9.9 123 encap mpls pw-class atom_eth

interface POS6/1/0
 ip address 10.1.1.1 255.255.255.0
 mpls ip
 mpls label protocol ldp
 clock source internal
 crc 32
!
interface Loopback0
 ip address 10.8.8.8 255.255.255.255
 no shutdown
!
router ospf 10
 nsf
 network 10.8.8.8 0.0.0.0 area 0
 network 19.1.1.1 0.0.0.0 area 0

ip cef distributed
!
redundancy
mode sso
!
hw-module slot 2 image slot1:rsp-pv-mz
hw-module slot 3 image slot1:rsp-pv-mz

mpls ldp graceful-restart
mpls ip
mpls label protocol ldp
mpls ldp router-id Loopback0 force
mpls ldp advertise-tags
!
pseudowire-class atom-eth
 encapsulation mpls
 interworking eth
!
interface Loopback0
 ip address 10.9.9.9 255.255.255.255
!
interface FastEthernet3/0/0
 ip route-cache cef
!
interface FastEthernet3/0/0.3
 encapsulation dot1Q 10
 xconnect 10.8.8.8 123 encap mpls pw-class atom_eth

interface POS1/0/0
 ip address 10.1.1.2 255.255.255.0
 mpls ip
 mpls label protocol ldp
 clock source internal
 crc 32
!
interface Loopback0
 ip address 10.9.9.9 255.255.255.255
!
router ospf 10
 nsf
 network 10.9.9.9 0.0.0.0 area 0
 network 10.1.1.2 0.0.0.0 area 0

Additional References

Related Documents

Related Topic
Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Cisco IOS IP SLAs commands

Cisco IOS IP SLAs Command Reference

Any Transport over MPLS

Any Transport over MPLS

Cisco nonstop forwarding

Cisco Nonstop Forwarding

L2VPN Interworking

L2VPN Interworking

Stateful switchover

Stateful Switchover


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

MPLS Label Distribution Protocol MIB Version 8 Upgrade

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 3036

LDP Specification

RFC 3478

Graceful Restart Mechanism for Label Distribution


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html


Feature Information for AToM NSF

Table 1 lists the features in this module and provides links to specific configuration information.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/fn. An account on Cisco.com is not required.


Note Table 1 lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.


Table 1 Feature Information for AToM NSF 

Feature Name
Releases
Feature Information

AToM NSF

12.2(25)S
12.2(28)SB

This feature uses NSF, SSO, and Graceful Restart to allow a route processor to recover from a disruption in control plane service without losing its MPLS forwarding state.

In 12.2(25)S, this feature was introduced on the Cisco 7500 series router.

In 12.2(28)SB, this feature was integrated into the release.

The following sections provide information about this feature:

Information About AToM NSF

How to Configure AToM NSF