Guest

Cisco IOS Software Releases 12.2 S

OSPF Shortest Path First Throttling

  • Viewing Options

  • PDF (227.9 KB)
  • Feedback
OSPF Shortest Path First Throttling

Table Of Contents

OSPF Shortest Path First Throttling

Contents

Information About OSPF SPF Throttling

Shortest Path First Calculations

How to Configure OSPF SPF Throttling

Configuring OSPF SPF Throttling

Verifying SPF Throttle Values

Configuration Examples for OSPF SPF Throttling

Throttle Timers Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

Obsolete and Replaced Commands

timers throttle spf

timer spf-interval


OSPF Shortest Path First Throttling


The OSPF Shortest Path First Throttling feature makes it possible to configure SPF scheduling in millisecond intervals and to potentially delay shortest path first (SPF) calculations during network instability. SPF is scheduled to calculate the Shortest Path Tree (SPT) when there is a change in topology. One SPF run may include multiple topology change events.

The interval at which the SPF calculations occur is chosen dynamically and is based on the frequency of topology changes in the network. The chosen interval is within the boundary of the user-specified value ranges. If network topology is unstable, SPF throttling calculates SPF scheduling intervals to be longer until topology becomes stable.

Feature Specifications for OSPF Shortest Path First Throttling

Feature History
 
Release
Modification

12.2(14)S

This feature was introduced.

12.0(23)S

This feature was integrated into Cisco Release 12.0(23)S.

12.2(15)T

This feature was integrated into Cisco IOS Release 12.2(15)T.

Supported Platforms

For information about platforms supported, refer to Cisco Feature Navigator.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Information About OSPF SPF Throttling

How to Configure OSPF SPF Throttling

Configuration Examples for OSPF SPF Throttling

Additional References

Command Reference

Information About OSPF SPF Throttling

To use SPF throttling, you should understand the following concepts:

Shortest Path First Calculations

Shortest Path First Calculations

SPF calculations occur at the interval set by the timers throttle spf command. The wait interval indicates the amount of time to wait until the next SPF calculation occurs. Each wait interval after that calculation is twice as long as the previous one until the wait interval reaches the maximum wait time specified.

The SPF timing can be better explained using an example. In this example the start interval is set at 5 milliseconds (ms), the wait interval at 1000 milliseconds, and the maximum wait time is set at 90,000 milliseconds.

timers throttle spf 5 1000 90000

Figure 1 shows the intervals at which the SPF calculations occur so long as at least one topology change event is received in a given wait interval.

Figure 1 SPF Calculation Intervals Set by the timers throttle spf Command

Notice that the wait interval between SPF calculations doubles when at least one topology change event is received during the previous wait interval. Once the maximum wait time is reached, the wait interval remains the same until the topology stablizes and no event is received in that interval.

If the first topology change event is received after the current wait interval, the SPF calculation is delayed by the amount of time specified as the start interval. The subsequent wait intervals continue to follow the dynamic pattern.

If the first topology change event occurs after the maximum wait interval begins, the SPF calculation is again scheduled at the start interval and subsequent wait intervals are reset according the parameters specified in the timers throttle spf command. Notice in Figure 2 that a topology change event was received after the start of the maximum wait time interval and that the SPF intervals have been reset.

Figure 2 Timer Intervals Reset after Topology Change Event

How to Configure OSPF SPF Throttling

Perform the following tasks to configure OSPF SPF throttling:

Configuring OSPF SPF Throttling (required)

Verifying SPF Throttle Values (optional)

Configuring OSPF SPF Throttling

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type slot/port

4. ip address ip-address mask [secondary]

5. exit

6. router ospf process-id

7. network network-number [mask | prefix-length]

8. timers throttle spf spf-start spf-hold spf-max-wait

9. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type slot/port

Example:

Router(config)# interface ethernet 1/1/1

Enters interface configuration mode for the interface specified.

Step 4 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 192.168.0.2 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 5 

exit

Example:

router# exit

Exits interface configuration mode.

Step 6 

router ospf process-id

Example:

Router(config)# router ospf 1

Configures an OSPF routing process.

Step 7 

network network-number [mask | prefix-length]

Example:

Router(config-router)# network 192.168.0.0 0.0.255.255 area 0

Configures the subnet number and mask for a Dynamic Host Configuration Protocol (DHCP) address pool on a Cisco IOS DHCP Server.

Step 8 

timers throttle spf spf-start spf-hold spf-max-wait

Example:

Router(config-router)# timers throttle spf 10 4800 90000

Sets OSPF throttling timers.

Step 9 

end

Example:

Router(config-router)# end

Exits configuration mode.


Verifying SPF Throttle Values

To verify SPF throttle timer values, use the show ip ospf command. The values are displayed in the lines that begin, "Initial SPF schedule delay...," "Minimum hold time between two consecutive SPFs...," and "Maximum wait time between two consecutive SPFs...."

Router# show ip ospf

 Routing Process "ospf 1" with ID 10.10.10.2 and Domain ID 0.0.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an autonomous system boundary router
 Redistributing External Routes from,
    static, includes subnets in redistribution
Initial SPF schedule delay 5 msecs 
 Minimum hold time between two consecutive SPFs 1000 msecs 
 Maximum wait time between two consecutive SPFs 90000 msecs 
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 4. Checksum Sum 0x17445 
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm last executed 19:11:15.140 ago 
        SPF algorithm executed 28 times
        Area ranges are
        Number of LSA 4. Checksum Sum 0x2C1D4 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Table 1 describes the show ip ospf display fields and their descriptions.

Table 1 show ip ospf Field Descriptions 

Field
Description

Routing process "ospf 201" with ID 192.42.110.200

Process ID and OSPF router ID.

Supports ...

Number of types of service supported (Type 0 only).

It is ...

Possible types are internal, area border, or autonomous system boundary.

Summary Link update interval

Specifies summary update interval in hours:minutes:seconds, and time until next update.

External Link update interval

Specifies external update interval in hours:minutes:seconds, and time until next update.

Redistributing External Routes from

Lists of redistributed routes, by protocol.

SPF calculations

Lists start, hold, and maximum wait interval values in milliseconds.

Number of areas

Number of areas in router, area addresses, and so on.

SPF algorithm last executed

Shows the last time an SPF calculation was performed in response to topology change event records.

Link State Update Interval

Specifies router and network link-state update interval in hours:minutes:seconds, and time until next update.

Link State Age Interval

Specifies max-aged update deletion interval, and time until next database cleanup, in hours:minutes:seconds.


Configuration Examples for OSPF SPF Throttling

This section contains the following examples:

Throttle Timers Example

Throttle Timers Example

This example shows a router configured with the start, hold, and maximum interval values for the timers throttle spf command set at 5, 1,000, and 90,000 milliseconds, respectively.

router ospf 1
 router-id 10.10.10.2
 log-adjacency-changes
 timers throttle spf 5 1000 90000 
 redistribute static subnets
 network 21.21.21.0 0.0.0.255 area 0
 network 22.22.22.0 0.0.0.255 area 00

Additional References

For additional information related to OSPF, refer to the following references:

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Related Documents

Related Topic
Document Title

OSPF commands

"OSPF Commands" chapter in the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2

OSPF configuration tasks

"Configuring OSPF " chapter in the Cisco IOS IP Configuration Guide, Release 12.2


Standards

Standards
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

 

MIBs

MIBs
MIBs Link

None

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


RFCs

RFCs
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

 

Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, tools, and lots more. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

This section documents the new timers throttle spf command. All other commands used with this feature are documented in the Cisco IOS Release 12.2T command reference publications.

Obsolete and Replaced Commands

Table 2 lists commands that have been replaced since Cisco IOS Release 12.2.

Table 2 Replaced OSPF Commands

Command in Cisco IOS Release 12.2
Replacement Command in Cisco IOS Release 12.2(11)S

timer spf-interval

timers throttle spf


timers throttle spf

To turn on OSPF SPF throttling, use the timers throttle spf command in router configuration mode. To turn off SPF throttling, use the no form of this command.

timers throttle spf spf-start spf-hold spf-max-wait

no timers throttle spf spf-start spf-hold spf-max-wait

Syntax Description

spf-start

Indicates the initial SPF schedule delay in milliseconds. Value range is 1 to 600,000 milliseconds.

spf-hold

Indicates the minimum hold time between two consecutive SPF calculations. Value range is 1 to 600,000 milliseconds.

spf-maximum

Indicates the maximum wait time between two consecutive SPF calculations. Value range is 1 to 600,000 milliseconds.


Defaults

SPF throttling is not set.

Command Modes

Router configuration

Command History

Release
Modification

12.2(14)S

This command was introduced.


Usage Guidelines

The timers throttle spf command replaces the timers spf-interval command.

The first wait interval between SPF calculations is the amount of time in milliseconds specified by the spf-start argument. Each consecutive wait interval is two times the current hold level in milliseconds until the wait time reaches the maximum time in milliseconds as specified by the spf-maximum argument. Subsequent wait times remain at the maximum until the values are reset or an LSA is received between SPF calculations.

Examples

The following example shows a router configured with the start, hold, and maximum interval values for the timers throttle spf command set at 5, 1,000, and 90,000 milliseconds, respectively.

router ospf 1
 router-id 10.10.10.2
 log-adjacency-changes
 timers throttle spf 5 1000 90000 
 redistribute static subnets
 network 21.21.21.0 0.0.0.255 area 0
 network 22.22.22.0 0.0.0.255 area 00

timer spf-interval

This command is replace by the timers throttle spf command. Refer to the timers throttle spf command reference page for instructions on using the new command.