Guest

Cisco IOS Software Releases 12.2 S

BGP Hybrid CLI

  • Viewing Options

  • PDF (225.0 KB)
  • Feedback
BGP Hybrid CLI

Table Of Contents

BGP Hybrid CLI

Feature Overview

Differences in Configuration Modes

NLRI CLI Examples

AFI CLI Examples

Upgrading the CLI From the NLRI Format to the AFI Format

BGP Hybrid CLI Example

Benefits

Restrictions

Related Features and Technologies

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Upgrading From the NLRI Format to the AFI Format

Verifying the Upgrade to the AFI Format

Configuration Examples

Command Reference

bgp upgrade-cli


BGP Hybrid CLI


Feature History

Release
Modification

12.0(22)S

This feature was introduced.

12.2(14)S

This feature was integrated into 12.2(14)S.


This document describes the BGP Hybrid CLI feature and includes the following sections:

Feature Overview

Benefits

Related Features and Technologies, page 7

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuration Examples

Command Reference

Feature Overview

The BGP Hybrid CLI feature simplifies the migration of Border Gateway Protocol (BGP) networks and existing configurations from the Network Layer Reachability Information (NLRI) format to the address-family identifier (AFI) format. This new functionality allows the network operator to configure commands in the AFI format and save these command configurations to existing NLRI formatted configurations. The feature provides the network operator with the capability to take advantage of new features and provides support for migration from the NLRI format to the AFI format. The BGP Hybrid CLI feature is present in Cisco IOS Release 12.0(22)S and later software releases and does not require the network operator to perform any specific configuration tasks.

The BGP Hybrid CLI feature does not add support for complete AFI and NLRI integration because of the limitations of the NLRI format. For complete support of AFI commands and features, the network operator must upgrade existing NLRI configurations with the bgp upgrade-cli command, which is used to convert existing NLRI configurations to the AFI format. This document also describes how to use the bgp upgrade-cli command to perform this upgrade.

The AFI format was introduced with multiprotocol BGP (mBGP) in Cisco IOS Release 12.0(2)S and Cisco IOS Release 11.1(20)CC and integrated into Cisco IOS Release 12.0(7)T. The AFI format is designed to be modular, scalable, and support multiple AFI and subsequent address-family identifier (SAFI) configurations. MBGP is an enhanced version of BGP that carries routing information for multiple network layer protocols and IP multicast routes. This routing information is carried in the AFI format as appended attributes (multiprotocol extensions). The AFI format was created because of scalability limitations of the NLRI format. A router that is configured in NLRI format can exchange only IPv4 unicast and multicast capabilities. Networks that are configured in the NLRI format have the following limitations:

No support for Address Family Identifier (AFI) and Subsequent Address Family Identifier (SAFI) information. Many new features are supported only in AFI and SAFI configuration modes and cannot be configured in NLRI configuration modes.

No support for IP version 6 (IPv6). A router that is configured in the NLRI format cannot establish peering with an IPv6 neighbor.

Limited support for multicast interdomain routing and incongruent multicast and unicast topologies. In the NLRI format, not all configuration options are available, and these configuration are more complex. If the routers in the infrastructure do not have multicast capabilities, or if policies differ as to where multicast traffic is configured to flow, multicast routing cannot be supported.

The AFI format in multiprotocol BGP supports multiple AFIs and SAFIs, all NLRI-based commands and policy configurations, and is backwards compatible with routers that support only the NLRI format. A router that is configured in the AFI format can support the following:

AFI and SAFI information and configurations are supported. A router that is configured in the AFI format can carry routing information for multiple network layer protocol address families (for example, IPv4, VPNv4, and IPv6).

All BGP routing policy capabilities and commands are supported.

Congruent unicast and multicast topologies that have different policies (BGP filtering configurations) are supported, as well as incongruent multicast and unicast topologies.

Connectionless Network Services (CLNS) are supported.

Interoperation between routers that support only the NLRI format (AFI-based networks are backward compatible) is supported. This includes both IPv4 unicast and multicast NLRI peers.

Virtual Private Networks (VPNs) and VPN routing and forwarding instances (VRFs) is supported.

Differences in Configuration Modes

The following sections provide examples that detail the differences between the NLRI, AFI, and hybrid command line interface (CLI). This section also provides examples of the NLRI CLI prior to upgrading with the bgp upgrade-cli command and the AFI CLI afterwards.

NLRI CLI Examples

A router that is configured in the NLRI format supports only IPv4 unicast and multicast configurations. The following NLRI CLI example is not modular, and it does not support AFI and SAFI configurations and AFI-based features. The following router CLI is seen in the NLRI format:

NLRI CLI Example

Router-NLRI(config)# router bgp 101
Router-NLRI(config-router)# neighbor 10.1.1.1 remote-as 505 nlri unicast multicast
Router-NLRI(config-router)# network 10.0.0.0 nlri unicast multicast

The following NLRI CLI example shows the configuration of redistribution and the application of separate route maps for multicast and unicast on a router that is running the NLRI format. See the second example in the "AFI Configurations" section (Redistribution Into AFI Multicast and Unicast CLI Example) for an AFI formatted version of the CLI in this example.

Redistribution Into NLRI Multicast and Unicast CLI Example

Router-NLRI(config)# router bgp 101
Router-NLRI(config-router)# neighbor 10.1.1.1 remote-as 505 nlri unicast multicast
Router-NLRI(config-router)# redistribute route-map REDISTRIBUTE-MULTICAST 
Router-NLRI(config-router)# exit
Router-NLRI(config-router)# !
Router-NLRI(config)# route-map REDISTRIBUTE-MULTICAST 10
Router-NLRI(config-route-map)# match ip address prefix-list MULTICAST-PREFIXES
Router-NLRI(config-route-map)# set nlri multicast
Router-NLRI(config-route-map)# exit
Router-NLRI(config-route-map)# !
Router-NLRI(config)# route-map REDISTRIBUTE-UNICAST 20
Router-NLRI(config-route-map)# match ip address prefix-list UNICAST-PREFIXES
Router-NLRI(config-route-map)# set nlri unicast
Router-NLRI(config-route-map)# exit
Router-NLRI(config)# !

AFI CLI Examples

Configurations in the AFI format are modular and scalable. The following AFI CLI example shows the configuration of IPv4 unicast, IPv4 multicast, VPNv4, and IPv6 within the same configuration. The following router CLI is seen in the AFI format:

AFI CLI Example

Router-AFI(config)# router bgp 202
Router-AFI(config-router)# remote-as 505
Router-AFI(config-router)# address-family ipv4 unicast 
Router-AFI(config-router-af)# neighbor 10.1.1.1 activate 
Router-AFI(config-router-af)# no auto-summary
Router-AFI(config-router-af)# no synchronization
Router-AFI(config-router-af)# exit-address-family
Router-AFI(config-router)# !
Router-AFI(config-router-af)# address-family ipv4 vrf CE1
Router-AFI(config-router-af)# neighbor 10.10.10.2 remote-as 45
Router-AFI(config-router-af)# neighbor 10.10.10.2 activate
Router-AFI(config-router-af)# no auto-summary
Router-AFI(config-router-af)# no synchronization
Router-AFI(config-router-af)# exit-address-family
Router-AFI(config-router-af)# !
Router-AFI(config-router)# address-family ipv4 multicast
Router-AFI(config-router-af)# neighbor 10.2.2.2 activate
Router-AFI(config-router-af)# no auto-summary
Router-AFI(config-router-af)# exit-address-family
Router-AFI(config-router)# !
Router-AFI(config-router)# address-family vpnv4 
Router-AFI(config-router-af)# neighbor 10.3.3.3 activate 
Router-AFI(config-router-af)# neighbor 10.3.3.3 send-community extended
Router-AFI(config-router-af)# no auto-summary 
Router-AFI(config-router-af)# exit-address-family
Router-AFI(config-router)# exit
Router-AFI(config)# !
Router-AFI(config)# router bgp 262
Router-AFI(config-router)# neighbor fe80::201:96ff:fe3b:1ff0 remote-as 150
Router-AFI(config-router)# neighbor fe80::201:96ff:fe3b:1ff0 update-source Ethernet4/1
Router-AFI(config-router)# neighbor fe80::290:92ff:fe65:681d remote-as 170
Router-AFI(config-router)# address-family ipv6
Router-AFI(config-router-af)# neighbor fe80::290:92ff:fe65:681d activate
Router-AFI(config-router-af)# neighbor fe80::290:92ff:fe65:681d route-map nh6 out
Router-AFI(config-router-af)# neighbor fe80::290:92ff:fe3b:1ff0 activate
Router-AFI(config-router-af)# exit-address-family
Router-AFI(config-router)# !

The following AFI CLI example shows the configuration of redistribution and the application of separate route maps for multicast and unicast on a router that is running the AFI format:

Redistribution Into AFI Multicast and Unicast CLI Example

Router-AFI(config)# router bgp 202
Router-AFI(config)# neighbor 10.1.1.1 remote-as
Router-AFI(config-router)# address-family ipv4 unicast 
Router-AFI(config-router-af)# neighbor 10.1.1.1 activate
Router-AFI(config-router-af)# redistribute route-map REDISTRIBUTE-UNICAST 10
Router-AFI(config-router-af)# exit
Router-AFI(config-router)# !
Router-AFI(config-router)# address-family ipv4 multicast
Router-AFI(config-router-af)# neighbor 10.1.1.1 activate
Router-AFI(config-router-af)# redistribute route-map REDISTRIBUTE-MULTICAST 20
Router-AFI(config-router-af)# exit
Router-AFI(config-router)# exit
Router-AFI(config)# !
Router-AFI(config)# route-map REDISTRIBUTE-UNICAST 10
Router-AFI(config-route-map)# match ip address prefix-list UNICAST-PREFIXES
Router-AFI(config-route-map)# exit
Router-AFI(config)# !
Router-AFI(config)# route-map REDISTRIBUTE-MULTICAST 20
Router-AFI(config-route-map)# match ip address prefix-list MULTICAST-PREFIX
Router-AFI(config-route-map)# exit
Router-AFI(config)# !

Upgrading the CLI From the NLRI Format to the AFI Format

The bgp upgrade-cli command is used to upgrade a router that is running the NLRI format to the AFI format. The bgp upgrade-cli command converts all existing NLRI formatted configurations to the AFI format. The upgrade is automatic and does not require any further configuration by the network operator, and no configuration information will be lost. The following CLI example is seen in the NLRI format prior to the upgrade:

CLI Example in NLRI Format Prior to Upgrading

Router-NLRI(config)# router bgp 303
Router-NLRI(config-router)# neighbor 10.1.1.1 remote-as 505 nlri unicast multicast

Router-NLRI(config-router)# network 10.0.0.0 nlri unicast multicast

The following CLI example shows the NLRI configuration in the AFI format after the router configuration file has been upgraded with the bgp  upgrade-cli command:

CLI Example After Upgrading to AFI Format

Router-Upgrade-CLI(config)#router bgp 303
Router-Upgrade-CLI(config-router)# remote-as 505
Router-Upgrade-CLI(config-router)#address-family ipv4 unicast 
Router-Upgrade-CLI(config-router-af)# neighbor 10.1.1.1 activate
Router-Upgrade-CLI(config-router-af)# network 10.0.0.0
Router-Upgrade-CLI(config-router-af)# exit-address-family
Router-Upgrade-CLI(config-router)# !
Router-Upgrade-CLI(config-router)# address-family ipv4 multicast
Router-Upgrade-CLI(config-router-af)# neighbor 10.2.2.2 activate
Router-Upgrade-CLI(config-router-af)# neighbor 10.0.0.0 
Router-Upgrade-CLI(config-router-af)# exit-address-family

Router-Upgrade-CLI(config-router)# !


Note After a router has been upgraded from the AFI format to the NLRI format with the bgp upgrade-cli command, NLRI commands will no longer be accessible or configurable.


BGP Hybrid CLI Example

The BGP Hybrid CLI feature is backwards compatible. A router that is running in the hybrid CLI format can interoperate with BGP peers that are configured to use only the NLRI or AFI format because multiprotocol extensions for BGP version 4 are backwards compatible with routers that support only the NLRI format. When this feature is enabled, NLRI commands that are accessed or configured are displayed in the NLRI format, and AFI commands that are accessed or configured are displayed in the AFI format. Both formats are saved in the same router configuration file. This feature allows the network operator to configure, for example, Multiprotocol Label Switching (MPLS) or VRF neighbors without requiring the network operator to immediately upgrade to the AFI format.

The following BGP Hybrid CLI example shows a CLI configuration with both AFI and NLRI commands in the IPv4 unicast, multicast, VPNv4, and IPv6 formats:

BGP Hybrid CLI Example

Router-Hybrid-CLI(config)# router bgp 404 
Router-Hybrid-CLI(config-router)#  neighbor 10.1.1.1 remote-as 505 nlri unicast multicast 
Router-Hybrid-CLI(config-router)# network 10.0.0.0 nlri unicast multicast
Router-Hybrid-CLI(config-router)# !
Router-Hybrid-CLI(config-router)# neighbor 10.3.3.3 remote-as 505
Router-Hybrid-CLI(config-router)# address-family vpnv4 
Router-Hybrid-CLI(config-router-af)# neighbor 10.3.3.3 activate
Router-Hybrid-CLI(config-router-af)# neighbor 10.3.3.3 send-community extended
Router-Hybrid-CLI(config-router-af)# exit-address-family
Router-Hybrid-CLI(config-router)# exit
Router-Hybrid-CLI(config)# !
Router-Hybrid-CLI(config)# router bgp 262
Router-Hybrid-CLI(config-router)# neighbor fe80::201:96ff:fe3b:1ff0 remote-as 150
Router-Hybrid-CLI(config-router)# neighbor fe80::201:96ff:fe3b:1ff0 update-source E 4/1
Router-Hybrid-CLI(config-router)# neighbor fe80::290:92ff:fe65:681d remote-as 170
Router-Hybrid-CLI(config-router)# address-family ipv6
Router-Hybrid-CLI(config-router-af)# neighbor fe80::290:92ff:fe65:681d activate
Router-Hybrid-CLI(config-router-af)# neighbor fe80::290:92ff:fe65:681d route-map nh6 out
Router-Hybrid-CLI(config-router-af)# neighbor fe80::290:92ff:fe3b:1ff0 activate
Router-Hybrid-CLI(config-router-af)# exit-address-family
Router-Hybrid-CLI(config-router)# !

Benefits

Simplified NLRI to AFI Migration

This feature provides the network operator with the capability to take advantage of new features and provides support for a migration from the NLRI format to the AFI format. The network operator can retain existing NLRI formatted configurations and add configurations in the AFI format without converting to the NLRI format right away.

Backwards-Compatibility with NLRI and AFI

The BGP Hybrid CLI feature allows both NLRI and AFI commands to be configured within the same session and saved to the same configuration. For mixed IPv4 multicast and unicast configurations, see the Limited Support for AFI and NLRI Integration section under the "Restrictions" heading of this document.

Reachability information can be exchanged with peers that support BGP version 4 even if the peer supports only NLRI or AFI commands and configurations.

Upgrading the software on a router that supports only NLRI mode to software that supports the BGP Hybrid CLI will allow the router to retain the preexisting NLRI configuration.

Improved AFI Support

Prefixes can be independently sourced within any individual address family. For example, a router that is running BGP can be configured as a route reflector on a per-address-family basis where the router is configured as a route reflector for only one address family and no others.

Session-related commands are common for all address families and need to be configured only once to identify a neighbor.

Reachability information can be exchanged with more than one AFI or SAFI.

Restrictions

Not Supported by IPv6

A router that is configured to run only IPv6 cannot exchange reachability information with a router that is running IPv4. For an IPv6 router to exchange reachability information with a router that is running IPv4, an IPv4 address must also be configured on the router that is running IPv6.

Limited Support for AFI and NLRI Integration

The BGP Hybrid CLI feature provides support to help the network operator migrate from the NLRI format to the AFI format. It does not add support for complete AFI and NLRI integration because of the limitations of the NLRI format. IPv4 unicast or IPv4 multicast configurations must be configured in either the AFI format or the NLRI format. This restriction does not affect VPNv4 or IPv6 AFI formatted configurations. For complete support of AFI commands and features, the network operator must upgrade existing NLRI configurations with the bgp upgrade-cli command.

AFI Upgrade Cannot be Reversed

After a router has been upgraded from the AFI format to the NLRI format with the bgp upgrade-cli command, the configuration cannot be reversed. NLRI commands will no longer be accessible or configurable.

Related Features and Technologies

The BGP Hybrid CLI feature is an extension of the BGP routing protocol. For more information about configuring BGP, refer to the "Configuring BGP" chapter of the Release 12.2 Cisco IOS IP Configuration Guide and Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols.

AFI commands, such as those used in IP version 6 (IPv6), Virtual Private Network version 4 (VPNv4), Connectionless Network Services (CLNS), and IP Multicast are based on RFC 2283, Multiprotocol Extensions for BGP-4.

Related Documents

Cisco Documentation

Cisco IOS IP Configuration Guide, Release 12.2

Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2

Supported Platforms

The BGP Hybrid CLI feature is supported by the following platforms in Cisco IOS Release 12.2(14)S:

Cisco 7200 series

Cisco 7400 series

Cisco 7500 series

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that are supported by specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

RFC 1700, Assigned Numbers.

RFC 2283, Multiprotocol Extensions for BGP-4

Configuration Tasks

See the following sections for configuration tasks for the BGP Hybrid CLI feature. Each task in the list is identified as either required or optional.

Upgrading From the NLRI Format to the AFI Format (optional)

Verifying the Upgrade to the AFI Format (optional)

Upgrading From the NLRI Format to the AFI Format

To upgrade a router that is running BGP in the NLRI format and NLRI formatted configuration to use the AFI format, use the following commands beginning in router configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Creates a BGP routing process and enters router configuration mode.

Step 2 

Router(config-router)# bgp upgrade-cli

Upgrades an existing router configuration file in the NLRI format to the AFI format and set the router CLI to use only commands in the AFI format.


Note After using the bgp upgrade-cli command to upgrade a router from the NLRI format to the AFI format, BGP commands will no longer be configurable in the NLRI format.


Verifying the Upgrade to the AFI Format

The show running-config command can be used in privileged EXEC mode to verify that an existing router configuration file has been upgraded from the NLRI format to the AFI format. This section provides sample output from a router configuration file in the NLRI format, and the same router configuration file after it has been upgraded to the AFI format with the bgp upgrade-cli command in router configuration mode.

Router Configuration File in NLRI Format Prior to Upgrading

Router Configuration File in AFI Format After Upgrading

Router Configuration File in NLRI Format Prior to Upgrading

The following sample output is from the show running-config command in privileged EXEC mode. The sample output shows a router configuration file, in the NLRI format, prior to upgrading to the AFI format with the bgp upgrade-cli command. The sample output is filtered to show only the affected portion of the router configuration.

Router# show running-config | begin bgp
router bgp 101
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.1.1 remote-as 505 nlri unicast multicast
 no auto-summary
!
ip default-gateway 10.4.9.1
ip classless
!
!
route-map REDISTRIBUTE-MULTICAST permit 10
 match ip address prefix-list MULTICAST-PREFIXES
 set nlri multicast
!
route-map MULTICAST-PREFIXES permit 10
!
route-map REDISTRIBUTE-UNICAST permit 20
 match ip address prefix-list UNICAST-PREFIXES
 set nlri unicast 
!
!
!
line con 0
line aux 0
line vty 0 4
 password PASSWORD
 login
!
end

Router Configuration File in AFI Format After Upgrading

The following sample output shows the router configuration file after it has been upgraded to the AFI format. The sample output is filtered to show only the affected portion of the router configuration file.

Router# show running-config | begin bgp
router bgp 101
 bgp log-neighbor-changes
 neighbor 10.1.1.1 remote-as 505
 no auto-summary
 !
 address-family ipv4 multicast
 neighbor 10.1.1.1 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4
 neighbor 10.1.1.1 activate
 no auto-summary
 no synchronization
 exit-address-family
!
ip default-gateway 10.4.9.1
ip classless
!
!
route-map REDISTRIBUTE-MULTICAST_mcast permit 10
 match ip address prefix-list MULTICAST-PREFIXES
!
route-map REDISTRIBUTE-MULTICAST permit 10
 match ip address prefix-list MULTICAST-PREFIXES
!
route-map MULTICAST-PREFIXES permit 10
!
route-map REDISTRIBUTE-UNICAST permit 20
 match ip address prefix-list UNICAST-PREFIXES
!
!
!
line con 0
line aux 0
line vty 0 4
 password PASSWORD
 login
!
end 

Configuration Examples

The following example upgrades an existing router configuration file in the NLRI format to the AFI format and set the router CLI to use only commands in the AFI format:

Router(config)# router bgp 5

Router(config-router)# bgp upgrade-cli

Command Reference

This section documents the bgp upgrade-cli command. The BGP Hybrid CLI feature does not require any configuration by the network operator. However, this section provides information about the bgp upgrade-cli command that allows the network operator to upgrade existing NLRI configurations to the AFI format. All other commands used with this feature are documented in the Cisco IOS Release 12.2 command reference publications.

bgp upgrade-cli

To upgrade an existing router configuration file in the NLRI format to the AFI format and set the router CLI to use only address-family identifier (AFI) commands, use the bgp upgrade-cli command in router configuration mode:

bgp upgrade-cli

Syntax Description

This command has no keywords or arguments.

Defaults

Address family commands are enabled. NLRI commands are no longer valid.

Command Modes

Router configuration

Command History

Release
Modification

12.0(14)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.

12.2(14)S

This command was integrated into Cisco IOS Release 12.2(14)S.


Usage Guidelines

The bgp upgrade-cli command is used to upgrade a router that is running in the NLRI format to the AFI format. The bgp upgrade-cli command upgrades all existing NLRI formatted configurations to the AFI format. The upgrade is automatic and does not require any further configuration by the network operator, and no configuration information will be lost. Several NLRI-based commands do not exist under the AFI format but have equivalent commands under the AFI format. See Table 1 for NLRI to AFI command mapping.

Table 1 Mapping NLRI Commands with Address Family Commands

NLRI Commands
Address Family Command

distance mbgp

distance bgp

match nlri

address-family ipv4

set nlri

address-family ipv4

show ip mbgp

show ip bgp ipv4 multicast

show ip mbgp summary

show ip bgp ipv4 multicast summary


Examples

The following example upgrades an existing router configuration file in the NLRI format to the AFI format and set the router CLI to use only commands in the AFI format:

Router(config)# router bgp 5

Router(config-router)# bgp upgrade-cli