Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2
Configuring Voice over ATM
Downloads: This chapterpdf (PDF - 418.0KB) The complete bookPDF (PDF - 9.14MB) | Feedback

Configuring Voice over ATM

Table Of Contents

Configuring Voice over ATM

VoATM Overview

AAL Technology

Variable Bit Rate Real-Time Options for Traffic Shaping

Cisco Trunk Calls on Cisco MC3810 Multiservice Concentrators

VoATM Dial Peers

VoATM Restrictions

VoATM Prerequisite Tasks

VoATM Configuration Task List

Configuring ATM Interfaces for Voice Traffic Using AAL5

Verifying the ATM PVC Configuration

Configuring AAL2 Encapsulation for VoATM

Configuring T1/E1 Trunks

Configuring Call Admission Control

Configuring Subcell Multiplexing

Configuring VoATM Dial Peers

Configuring VoATM Dial Peers to Support AAL2

Configuring VoATM Dial Peers for Cisco Trunk Calls

Configuring Dial-Peer Hunting

Configuring Cisco Trunk Permanent Calls

Verifying the Voice Connection

Troubleshooting Tips

Verifying the ATM Interface Configuration

Verifying the VoATM Connection

Troubleshooting Tips

VoATM Configuration Examples

Back-to-Back VoATM PVCs Example

Voice and Data Traffic over ATM PVCs Example

VoATM for Cisco 3600 Series Routers Configuration Example

VoATM for the Cisco MC3810 Multiservice Concentrator Configuration Example


Configuring Voice over ATM


This chapter describes Voice over ATM (VoATM) and contains the following sections:

VoATM Overview

VoATM Prerequisite Tasks

VoATM Configuration Task List

VoATM Configuration Examples

For a description of the VoATM commands, see the Cisco IOS Voice, Video, and Fax Applications Command Reference. For information about software configuration requirements for the Digital T1 Packet Voice trunk network modules on the Cisco 2600 and Cisco 3600, see the "Configuring Voice Ports" chapter. For more information about configuring ATM for data transmission, see the Cisco IOS Wide-Area Networking Configuration Guide and Command Reference.

To identify the hardware platform or software image information associated with a feature in this chapter, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

VoATM Overview

VoATM enables a router to carry voice traffic (for example, telephone calls and faxes) over an ATM network. An ATM network is a cell-switching and multiplexing technology designed to combine the benefits of circuit switching (constant transmission delay and guaranteed capacity) and packet switching (flexibility and efficiency for intermittent traffic).

All traffic to or from an ATM network is prefaced with a virtual path identifier (VPI) and virtual channel identifier (VCI). A VPI-VCI pair is considered a single virtual circuit. Each virtual circuit is a private connection to another node on the ATM network. Each virtual circuit is treated as a point-to-point mechanism to another router or host and is capable of supporting bidirectional traffic.

Each ATM node establishes a separate connection to every other node in the ATM network with which it must communicate. All such connections are established by means of a permanent virtual circuit (PVC) or a switched virtual circuit (SVC) with an ATM signaling mechanism. This signaling is based on the ATM Forum User-Network Interface (UNI) Specification V3.0.

Each virtual circuit is considered a complete and separate link to a destination node. Data can be encapsulated as needed across the connection, and the ATM network disregards the contents of the data. The only requirement is that data be sent to the ATM processor card of the router in a manner that follows the specific ATM adaptation layer (AAL) format.

An ATM connection transfers raw bits of information to a destination router or host. The ATM router takes the common part convergence sublayer (CPCS) frame, carves it up into 53-byte cells, and sends the cells to the destination router or host for reassembly. In AAL5 format, 48 bytes of each cell are used for the CPCS data and the remaining 5 bytes are used for cell routing. The 5-byte cell header contains the destination VPI-VCI pair, payload type, cell loss priority (CLP), and header error control (HEC) information.

AAL Technology

AAL defines the conversion of user information into the ATM cells. AAL protocols perform a convergence function; that is, they take whatever traffic is to be sent across the ATM network, establish the appropriate connections, and then package the traffic received from the higher layers into the 48-byte information payload that is passed down to the ATM layer for transmission. At the receiving level, the AAL layer must receive the information payloads passed up from the ATM layer and put the payloads into the form expected by the higher layer.

The AAL layers provide a service to the higher layers that corresponds to the four classes of traffic. AAL1 and AAL2 handle isochronous traffic, such as voice and video, but are not relevant to the router. AAL3/4 and AAL5 support data communications by segmenting and reassembling packets.

AAL2 is a bandwidth-efficient, standards-based trunking method for transporting compressed voice, voice-band data, circuit-mode data, and frame-mode data. VoATM with AAL2 trunking provides the following functionality:

Increased quality of service (QoS) capabilities

Robust architecture

Signalling transparency

CAS and CCS support

AAL5 is designed to support only message-mode, nonassured operation. AAL5 packets contain 48 bytes of data and a 5-byte header.

Variable Bit Rate Real-Time Options for Traffic Shaping

Variable bit rate (VBR) is a QoS class defined by the ATM Forum for ATM networks. VBR is subdivided into a real-time (RT) class and nonreal time (NRT) class. RT VBR is used for connections in which there is a fixed timing relationship between samples, as in the case of traffic shaping. NRT VBR is used for connections in which there is no fixed timing relationship between samples, but which still need a guaranteed QoS.

Traffic shaping prevents a carrier from discarding incoming calls from a Cisco router. Traffic shaping is performed by configuring the peak, average, and burst options for voice traffic. Burst is required if the PVC is carrying bursty traffic. Peak, average, and burst are required so the PVC can effectively handle the bandwidth for the number of voice calls.

Cisco Trunk Calls on Cisco MC3810 Multiservice Concentrators

Cisco trunk (private-line) calls are basically dynamic switched calls of indefinite duration that use a fixed destination telephone number and include optional transparent end-to-end signaling. The telephone number of the destination endpoint is permanently configured into the router so that it always selects a fixed destination. After the call is established, either at boot-up or when configured, the call stays up until one of the voice ports or network ports is shut down or a network disruption occurs.

The Cisco trunk call functionality provides the following benefits:

True permanent, private-line connections.

Comprehensive busyout support for trunk connections. For more information, see to the "Configuring Trunk Connections and Conditioning Features" chapter.

Transparent CAS protocol transport to enable the trunk to carry arbitrary ABCD signaling protocols.

Conversion from North American signaling protocols to CEPT (Conférence Européenne des Postes et des Télécommunications) signaling protocols used for European voice networks.

Remote analog-to-digital channel-bank operation for converting from digital voice multiplexer (DVM) to ATM voice multiplexer (AVM) configurations on the Cisco MC3810 multiservice concentrator.

VoATM Dial Peers

Establishing two-way communications using VoATM requires a specific voice connection between two defined endpoints. As shown in Figure 85, the plain old telephone service (POTS) dial peer establishes the source (the originating telephone number and voice port) of the call, and the VoATM dial peer establishes the destination by associating the destination phone number with a specific ATM virtual circuit.

Figure 85 Calls from the Perspective of Router 1

In Figure 85 the destination string, 14085554000, coming from the source, maps to U.S. phone number 555-4000, with the digit "1" plus the area code "408" preceding the number. When configuring the destination pattern, set the dial string to match the local dial conventions.

When both POTS dial peers are connected to the same router and share the same destination IP address, the VoATM dial peer does not need to be configured (see Figure 86).

Figure 86 Communication Between Dial Peers Sharing the Same Router

When configuring VoATM dial peers, an understanding of the relationship between the destination pattern and the session target is critical. The destination pattern represents the pattern for the device at the voice connection endpoint, such as a telephone or a PBX. The session target represents the serial port on the peer router at the other end of the ATM connection. Figure 87 and Figure 88 show the relationship between the destination pattern and the session target, as seen from the perspective of both routers in a VoATM configuration.

Figure 87 Relationship Between the Destination Pattern and Session Target from the Perspective of Router 1

Figure 88 Relationship Between the Destination Pattern and Session Target from the Perspective of Router 2

For more information regarding dial peers, see the "Configuring Dial Plans, Dial Peers, and Digit Manipulation" chapter.

VoATM Restrictions

The following are restrictions regarding V0ATM:

VoATM is supported only on the Cisco MC3810 multiservice concentrators ATM port 0 (compressed VoATM). When VoATM is enabled, the channel group, time-division multiplexing (TDM) group, and channel associated signaling (CAS) functionality are not available on the multiflex trunk (MFT) because ATM uses all T1/E1 time slots.

VoATM on the Cisco 3600 series router requires the installation of one of the following modules:

Multiport T1/E1 ATM network module with inverse multiplexing over ATM (IMA). The multiport T1/E1 ATM network module with IMA supports up to eight T1/E1 lines. For more information, see the Cisco IOS Release 12.0(5)T online document Configuring Multiport T1/E1 ATM Network Modules with Inverse Multiplexing over ATM on Cisco 2600 and 3600 Series Routers.

OC3 ATM network module. The OC3 ATM network module supports one OC3 line. For more information about the Digital T1 packet voice trunk network modules, see the Cisco IOS Release 12.0(3)T online document ATM OC-3 Network Module for the Cisco 3600 Series Routers.

The following AAL2 capabilities are not supported:

Data services over AAL2 (Nx64K circuit mode and N>=1)

Fax/modem relay (fax demodulation and remodulation)

Idle code detection or idle channel suppression

Cisco-switched AAL2 trunking

Only AAL5 is supported on the Cisco 3600 series routers. AAL2 is not supported.

VoATM SVCs are not supported since Cisco IOS Release12.0(7)XK. The ATM SVCs for data are still supported.

VoATM Prerequisite Tasks

Before configuring VoATM, perform the following tasks:

Install the required network modules into the Cisco 3600 series router. For more information, see the "VoATM Restrictions" section.

Establish a working ATM network. For more information, refer to the Cisco IOS Wide-Area Networking Configuration Guide.

Configure Local Management Interface (LMI) support if the carrier is using LMI because ATM defaults to Integrated Local Management Interface (ILMI).

Configure the clock source for the Cisco MC3810 multiservice concentrator interfaces. For more information, see the "Configuring Synchronous Clocking on the Cisco MC3810 Multiservice Concentrators" appendix.

Complete your company dial plan and establish a working telephony network based on the plan and:

Integrate the dial plan and telephony network into the existing ATM network topology. Make routing and dialing transparent to the user; for example, avoid secondary dial tones from secondary switches where possible.

Contact the PBX vendor for instructions about how to reconfigure the appropriate PBX interfaces.

Ensure that the voice ports and dial peers are configured. For more information, see the "Configuring Voice Ports" and "Configuring Voice Dial Peers, Dial Plans, and Digit Manipulation" chapters.

VoATM Configuration Task List

To configure VoATM, perform the following tasks:

Configuring ATM Interfaces for Voice Traffic Using AAL5

Configuring AAL2 Encapsulation for VoATM

Configuring VoATM Dial Peers

Configuring Dial-Peer Hunting

Configuring Cisco Trunk Permanent Calls

Configuring Cisco Trunk Permanent Calls

Configuring ATM Interfaces for Voice Traffic Using AAL5

ATM interfaces must be configured for voice traffic using AAL5 and the VoATM configuration must be performed on both sides of the voice connection. The only commands in ATM virtual circuit configuration mode that are used for ATM voice PVCs are encapsulation aal5mux voice, vbr-rt, and ilmi. For more information on the encapsulation command, see the Cisco IOS Wide-Area Networking Command Reference.

To calculate the minimum peak, average, and burst values for the number of voice calls, perform the following calculations:

Peak value: (2 x the maximum number of calls) x 16 Kb

Average value: (1 x the maximum number of calls) x 16 Kb

The average value correlates to the carrier sustainable cell rate (SCR).

Burst value: 4 x the maximum number of calls

The burst value is the burst size in cells.

To configure ATM interfaces to support voice traffic, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface ATM slot/number

Enters ATM interface configuration mode.

Step 2 

Router(config-if)# pvc [name] vpi/vci [ilmi | qsaal | 
smds]

Creates an ATM PVC for voice traffic and enters virtual circuit configuration mode. The keywords and arguments are as follows:

name—(Optional) Supports up to 16 characters.

vpi/—Valid range is from 0 to 255.

vci—Valid range is from 0 to 1 less than the maximum value set for the interface by the atm vc-per-vp command. Lower values 0 to 31 are reserved for specific traffic (for example, F4 OAM, ILMI, etc.) and should not be used.

VCI is a 16-bit field in the header of the ATM cell. The value is unique only on a single link. not throughout the ATM network, because it has local significance only.

Note The vpi and vci arguments cannot both be set to 0.

ilmi—(Optional) Sets up communication with the ILMI. The vpi and vci values are 0 and 16, respectively.

qsaal—(Optional) Signaling-type PVC used for setting up or tearing down data SVCs. The associated vpi and vci values are 0 and 5, respectively.

The default is that the PVC is not defined. When the PVC is defined, the global default of the encapsulation command applies (aal-encap = aal5snap).

Step 3 

Router(config-if-atm-pvc)# encapsulation aal5mux 
voice

Sets the encapsulation of the PVC to support AAL5 voice.

Step 4 

Router(config-if-atm-pvc)# vbr-rt peak-rate 
average-rate [burst]

Configures the peak and average rates and burst cell size to perform traffic shaping between voice and data PVCs for real-time voice networks. The arguments are as follows:

peak rate—Sets to the line rate if it does not exceed the carrier allowable rate (for example, 1536 kbps for T1-ATM).

average rate—Calculates according to the maximum number of PVC calls times the bandwidth per call. The following formulas calculate the average rate in kbps:

G.711 with 40- or 80-byte sample size: maximum calls x 85

G.726 with 40- or 80-byte sample size: maximum calls x 43

G.729 with 30-byte sample size: maximum calls x 15

G.729 with 20-byte sample size: maximum calls x 22

G.729 with 10-byte sample size: maximum calls x 43

If VAD is enabled, the bandwidth usage is reduced by as much as 12 percent with the maximum number of calls in progress. With fewer calls in progress, bandwidth is less.

burst (Optional)—Sets the burst size as large as possible and never less than the minimum burst size. Guidelines are as follows:

Minimum: number of voice calls x 4.

Maximum: maximum allowed by the carrier.

Step 5 

Router(config-if-atm-pvc)# exit

Exits ATM virtual circuit configuration mode.

Step 6 

Router(config-if)# pvc [name] vpi/vci

Creates an ATM PVC for data traffic and enters virtual circuit configuration mode.

Step 7 

Router(config-if-atm-pvc)# encapsulation aal5snap

Sets the encapsulation of the PVC to support ATM data traffic. In ATM PVC configuration mode, configure the ubr, ubr+ or the vbr-nrt traffic shaping commands for the data PVC as appropriate.

Note Calculate the overhead as voice rate x 1.13. See the Cisco IOS Wide-Area Network Configuration Guide for more information.

Step 8 

Router(config-if-atm-pvc)# exit

Exits ATM virtual circuit configuration mode. Repeat Steps 6 and 7 for each data PVC configured.

Verifying the ATM PVC Configuration

Verify the ATM PVC configuration by using the show atm vc command. To verify connectivity, do not use the ping command over a voice PVC because the command applies to data only. Use the ping command over the data PVC to verify that the data and voice PVCs are set to the same destination.

Configuring AAL2 Encapsulation for VoATM

AAL2 encapsulation for VoATM must be configured and the VoATM configuration must be performed on the Cisco MC3810 multiservice concentrators at both ends of the ATM link. AAL2 is not supported on the Cisco 3600 series routers.


Note If any DS0 groups (CAS groups), channel groups, or clear channels are configured on T1/E1 controller 0, remove them before configuring VoATM. Because ATM uses all the DS0 timeslots on the controller, the ATM configuration cannot take place if any DS0s on controller 0 are used by other applications.


To configure AAL2 encapsulation for VoATM, perform the following tasks:

Configuring T1/E1 Trunks

Configuring Call Admission Control

Configuring Subcell Multiplexing

Configuring T1/E1 Trunks

To configure the T1/E1 trunk, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller {t1 | e1} 0

Selects the T1 or E1 controller 0.

Note On the Cisco MC3810 multiservice concentrator, ATM is supported only on controller 0.

Step 2 

Router(config-controller)# mode atm

Specifies controller support for ATM encapsulation and creates ATM interface 0. When the controller is set to ATM mode, the following takes place:

Controller framing is automatically set to Extended SuperFrame (ESF) on T1 and to CRC4 on E1.

The linecode is automatically set to B8ZS on T1 and to HDB3 on E1.

Step 3 

Router(config-controller)# no shutdown

Ensures that the controller is activated.

Step 4 

Router(config)# interface atm0 
[subinterface-number [multipoint | 
point-to-point]]

Enters interface configuration mode to configure ATM interface 0 or an ATM subinterface. The keywords and arguments are as follows:

subinterface-numberConfigures the subinterface. Valid range is from 1 to 4294967293.

multipoint (Optional)—Assumes that is a fully meshed network. This is the default setting.

point-to-point (Optional)—Specifies the VoATM connection over point-to-point network.

Step 5 

Router(config-if)# pvc [name] {vpi/vci | vci}

Creates an ATM PVC for voice traffic and enters ATM virtual circuit configuration mode.

Note The ilmi and qsaal options are not supported for AAL2.

Step 6 

Router(config-if-atm-pvc)# encapsulation aal2

Sets the PVC encapsulation to support AAL2 voice traffic. This automatically creates channel identifiers (CIDs) 1 through 255.

 

or

 
 

Router(config-if-atm-pvc)# ip address ip-address mask

Assigns the IP address and subnet mask to the interface on the Cisco MC3810 multiservice concentrator.

 

and

 
 
Router(config-if-atm-pvc)# encapsulation 
aal5mux

Sets the encapsulation of the PVC to support voice traffic on the Cisco MC3810 multiservice concentrator.

Step 7 

Router(config-if-atm-pvc)# vbr-rt peak-rate 
average-rate [burst]

Configures the VBR for real-time voice traffic.

Step 8 

Router(config-if-atm-pvc)# oam-pvc [manage] 
[frequency]

(Optional) Configures transmission of end-to-end F5 operation, administration, and maintenance (OAM) loopback cells on a PVC; specifies the number of seconds between loopback cells; and enables OAM management of the connection. The keyword and argument are as follows:

manage(Optional) Enables OAM management.

frequency (Optional)—Valid range is 0 to 600. The default is 10.

Note The oam-pvc command does not apply to AAL2.

Step 9 

Router(config-if-atm-pvc)# oam retry up-count 
down-count retry-frequency

(Optional) Specifies OAM management parameters for verifying connectivity of a PVC connection. This command is supported only if OAM management is enabled. The arguments are as follows:

up-count—Number of OAM loopback cell responses received to change the PVC connection to up. The range is from 1 to 600; the default is 3.

down-count—Number of OAM loopback cell responses not received to change the PVC connection to down. The range is from 1 to 600; the default is 5.

retry-frequency—Number of seconds between loopback cells sent to verify the down state of a PVC. The range is from 1 to 1000; the default is 1.

Note Enter the oam retry command only once with all of the arguments in the order shown. The first number always specifies up-count; the second, down-count; and the third, retry-frequency.

Note The oam retry command does not apply to AAL2.

Configuring Call Admission Control

Configuring the call admission control (CAC) is optional for the Cisco MC3810 multiservice concentrator because the MC3810 multiservice concentrator can be configured as master or slave. By default, a Cisco MC3810 multiservice concentrator is a CAC slave.

Typically the ATM trunk is configured with the CAC master at one end (performing CAC during fax/modem up speed) and slave at the opposite end. When the Cisco MC3810 multiservice concentrator is configured as a slave, it sends a request for CAC to the CAC master.

To configure a Cisco MC3810 multiservice concentrator as a CAC master, usethe following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice service voatm

Enters voice-service configuration mode.

Step 2 

Router(config-voice-service)# session protocol aal2

Enters voice-service-session configuration mode and specifies AAL2 trunking.

Step 3 

Router(config-voice-service-session)# cac master

Configures the Cisco MC3810 multiservice concentrator as a CAC master. Default is that the concentrator acts as a CAC slave.

Step 4 

Router(config-voice-service-session)# exit

Exits voice-service session configuration mode. To return to global configuration mode, enter the exit command again.

To return a Cisco MC3810 multiservice concentrator to its default operation as a CAC slave, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice service voatm

Enters voice-service configuration mode.

Step 2 

Router(config-voice-service)# session protocol aal2

Enters voice-service-session configuration mode and specifies AAL2 trunking.

Step 3 

Router(config-voice-service-session)# no cac master

Configures this Cisco MC3810 multiservice concentrator as a CAC slave.

Step 4 

Router(config-voice-service-session)# exit

Exits voice-service session configuration mode. To return to global configuration mode, enter the exit command again.

Configuring Subcell Multiplexing

This section describes the configuration tasks necessary to enable AAL2 common part sublayer (CPS) subcell multiplexing when the Cisco MC3810 multiservice concentrator interoperates with a voice interface service module (VISM) in an MGX switch. The commands and procedures in this section are specific to the Cisco MC3810 multiservice concentrator.

To configure the Cisco MC3810 multiservice concentrator to perform subcell multiplexing, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice service voatm

Enters voice-service configuration mode.

Step 2 

Router(config-voice-service)# session protocol aal2

Enters voice-service-session configuration mode and specifies AAL2 trunking.

Step 3 

Router(config-voice-service-session)# subcell-mux

Enables subcell multiplexing. By default, subcell multiplexing is not enabled.

Step 4 

Router(config-voice-service-session)# exit

Exits voice-service session configuration mode. To return to global configuration mode, enter the exit command again.

Configuring VoATM Dial Peers

Configuring dial peers to support VoATM should be performed in a back-to-back configuration before separating them across the ATM network. The back-to-back configuration enables the testing of a voice connection. If a voice connection cannot be made after both peers are placed in the network, then you have a network problem. For information about configuring POTS dial peers, see the "Configuring Dial Plans, Dial Peers, and Digit Manipulation" chapter.

To configure VoATM dial peers, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice number voatm

Defines a VoATM dial peer and enters dial-peer configuration mode. The number argument identifies the dial peer. Do not duplicate a specific number.

Step 2 

Router(config-dial-peer)# destination-pattern string

Configures the destination pattern. The special characters are as follows: The string values are as follows:

Asterisk (*) and pound sign (#) that appear on standard touch-tone dial pads.

Comma (,) can be used only in prefixes and inserts a one-second pause.

Period (.) can be entered as a wildcard digit. Network dial peers typically use wildcards to represent a range of destination telephone numbers (for example, 1408555... for all numbers in area code 408 with a 555 prefix).

Timer (T) can be used to configure variable-length dial plans.

Step 3 

Router(config-dial-peer)# session target ATM x/y pvc 
{name | vpi/vci | vci}

Configures the ATM session target. On the Cisco 3600, if a vpi/vci combination is specified, the valid values depend on the network module installed, as follows:

For multiport T1/E1 ATM with IMA, the valid ranges are:

vpi is from 0 to 15

vci is from 1 to 255

For OC3 ATM, the valid ranges are:

vpi is from 0 to 15

vci is from 1 to 1023

Step 4 

Router(config-dial-peer)# preference value

(Optional) Configures a preference. The value argument has a valid range is from 0 to 10 (the lower the number, the higher the preference).

Step 5 

Router(config-dial-peer)# codec type [bytes 
payload_size]

Specifies the rate of speech and payload size. The default codec is g729r8. The keyword and arguments are as follows:

type—Assigns codec values to the voice port for regular switched voice calls.

bytes—(Optional) Specifies the payload size. Each codec type defaults to a different payload size if one is not specified.

payload_size—(Optional) Specifies the payload size by entering the bytes. Each codec type defaults to a different payload size if a value is not specified.

Note To obtain a list of the default payload sizes, enter the codec command and the bytes option followed by a question mark (?).

Step 6 

Router(config-dial-peer)# dtmf-relay

(Optional) Specifies support for dual tone multifrequency (DTMF) relay. If the codec type is a low bit-rate codec such as g729 or g723, the end-to-end transport of DTMF tones is improved. DTMF tones do not always propagate reliably with low bit-rate codecs. DTMF relay is disabled by default.

Step 7 

Router(config-dial-peer)# signal-type {cas | cept | 
ext-signal | transparent}

(Optional) Defines the ABCD signaling packets that are generated by the voice port and sent to the data network. The signal type must be configured to the same setting at both ends of the permanent voice call. The keywords are as follows:

cas—Support for CAS.

cept—Support for the European CEPT standard (related to Mercury Exchange Limited (MEL) CAS).

ext-signalIndicates that ABCD signaling packets should not be sent for configurations in which the line signaling information is carried externally to the voice port.

transparent(for digital T1/E1 interfaces) Reads the ABCD signaling bits directly from the T1/E1 interface without interpretation and transparently passes them to the data network. Also known as transparent FRF.11 signaling.

Step 8 

Router(config-dial-peer)# no vad

(Optional) Disables voice activity detection (VAD). This command is enabled by default.

Step 9 

Router(config-dial-peer)# sequence-numbers

(Optional) Enables the voice sequence number if required. This command is disabled by default.

Step 10 

Router(config-dial-peer)# preference value

(Optional) Configures a preference for the VoATM dial peer. The value argument has valid ranges from 0 to 10 (the lower the number, the higher the preference in hunt groups).

Step 11 

Router(config-dial-peer)# session protocol 
cisco-switched

(Optional) Configures the session protocol to support Cisco-trunk permanent trunk calls. The cisco-switched keyword is the default setting and is not required.

Note Use the no session protocol cisco-switched command if the dial peer does not support Cisco trunk calls.

Step 12 

Router(config-dial-peer)# exit

Exits dial-peer configuration mode. Repeat the steps to configure each dial peer.

Configuring VoATM Dial Peers to Support AAL2

To configure the voice network dial peers to support AAL2 on a Cisco MC3810 multiservice concentrator, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice number voatm

Defines the dial peer and enters dial-peer configuration mode.

Step 2 

Router(config-dial-peer)# destination-pattern string

Configures the destination pattern.

Step 3 

Router(config-dial-peer)# session protocol aal2-trunk

Configures the session protocol to support AAL2-trunk permanent trunk calls.

Step 4 

Router(config-dial-peer)# session target atm 0 pvc 
{name | vpi/vci | vci}

Configures the ATM session target for the dial peer. Be sure to specify atm 0 as the interface for the PVC.

Step 5 

Router(config-dial-peer)# codec aal2 profile {itut | 
custom} profile-number codec

Specifies a codec profile for the DSP. Use this command instead of the codec (dial-peer) command for AAL2 trunk applications. The keywords and arguments are as follows:

itut—Specifies the profile-number as an ITU-T type:

1: G.711ulaw

2: G.711ulaw with silence insertion descriptor (SID)

7: G.711ulaw and G.729ar8

custom—Specifies the profile-number as a custom type:

100: G.711ulaw and G.726r32

110: G.711ulaw, G.726r32, and G.729ar8

profile-number—The available profile-number selections depend on the profile type.

codec—Enter one codec for the domain specific part (DSP). The possible codec entries depend on the profile-number. The valid entries are as follows:

For ITU 1: g711ulaw

For ITU 2: g711ulaw

For ITU 7: g711ulaw or g729ar8

For custom 100: g711ulaw or g726r32

For custom 110: g711ulaw or g726r32 or g729ar8

See the Cisco IOS Voice, Video, and Fax Command Reference for the codec options available for each AAL2 profile.

Step 6 

Router(config-dial-peer)# dtmf-relay

(Optional) Specifies support for DTMF relay to improve end-to-end transport of DTMF tones if the codec type is a low bit-rate codec such as g729 or g723. DTMF tones do not always propagate reliably with low bit-rate codecs. DTMF relay is disabled by default.

Step 7 

Router(config-dial-peer)# signal-type {ext-signal | 
transparent}

(Optional) Defines the type of ABCD signaling packets that are generated by the voice port and sent over the ATM network. The signal type must be configured to the same setting at both ends of the PVC. The keywords are as follows:

ext-signalIdentifies common-channel signaling (CCS). ABCD signaling packets are not sent.

transparent—Identifies nonswitched trunks using channel associated signaling (CAS). ABCD signaling bits are passed transparently to the ATM network.

Step 8 

Router(config-dial-peer)# no vad

(Optional) Disables VAD on the dial peer. VAD is enabled by default.

Step 9 

Router(config-dial-peer)# exit

Exits dial-peer configuration mode. Repeat the steps to configure each dial peer.

Configuring VoATM Dial Peers for Cisco Trunk Calls

If Cisco trunk calls are transmitted over ATM, the dial peers must be configured to specifically support the calls. Cisco trunk calls are permanent calls.


Note A voice class to configure trunk conditioning values for the idle and out-of-service (OOS) states can be configured with the voice class assigned to the VoATM dial peer. For more information, see the "Configuring Trunk Management Features" chapter.


To configure a VoATM dial peer to support Cisco trunk calls, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice number voatm

Defines a VoATM dial peer and enters dial-peer configuration mode.

Note The VoATM dial peers must already be configured.

Step 2 

Router(config-dial-peer)# session protocol cisco-switched

Configures the session protocol to support Cisco trunk calls.

Configuring Dial-Peer Hunting

To configure dial-peer hunting, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer hunt hunt-order-number

Specifies the hunt selection order for dial peers. The hunt-order-number has valid ranges from 0 to 7 as follows:

0: Longest match in phone number, explicit preference, random selection. This is the default hunt order number.

1: Longest match in phone number, explicit preference, least recent use.

2: Explicit preference, longest match in phone number, random selection.

3: Explicit preference, longest match in phone number, least recent use.

4: Least recent use, longest match in phone number, explicit preference.

5: Least recent use, explicit preference, longest match in phone number.

6: Random selection.

7: Least recent use.

The default is the longest match in a phone number, explicit preference, and random selection (hunt order number 0).

Step 2 

Router(config)# dial-peer terminator character

(Optional) Designates a special character for variable length dialed numbers. The character argument has valid numbers and characters that are as follows:

Pound sign (#)

Asterisk (*)

Numbers from zero to nine

Letters from a to d

The default is #.

To disable dial-peer hunting, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice number {pots | 
voatm}

Enters dial-peer configuration mode for the specified dial peer.

Step 2 

Router(config-dial-peer)# huntstop

Disables dial-peer hunting on the dial peer. No further hunting is enabled if a call fails on the specified dial peer.

Note To reenable dial-peer hunting on a dial peer, enter the no huntstop command.

Configuring Cisco Trunk Permanent Calls

The Cisco trunk call functionality provides true permanent, private-line connections; comprehensive busyout support for trunk connection; and transparent CAS protocol transport to allow the trunk to carry arbitrary ABCD signaling protocols. Conversion from North American signaling protocols to CEPT (Conférence Européenne des Postes et des Télécommunications) signaling protocols used for European voice networks and remote analog to digital channel-bank operation for converting from DVM to AVM configurations is also provided.

To configure Cisco-trunk permanent calls, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice-port

Enters voice-port configuration mode.

Note The voice-port command is hardware specific. Refer to the Cisco IOS Voice, Video, and Fax Command Reference for more information.

Step 2 

Router(config-voiceport)# connection trunk destination-string [answer-mode]

Configures the trunk connection, specifying the telephone number in the destination-string argument. The answer-mode keyword specifies that the voice port should operate in slave mode. The default is master mode.

Step 3 

Router(config-voiceport)# shutdown

Shuts down the voice port.

Step 4 

Router(config-voiceport)# no shutdown

Reactivates the voice port to enable the trunk connection to take effect.


Note When the connection trunk or no connection trunk command is entered, the voice port must be toggled by entering shutdown, and then no shutdown before the changes take effect.


Verifying the Voice Connection

To verify that the voice connection is working, perform the following steps:


Step 1 Pick up the telephone handset and verify that a dial tone is present.

Step 2 Make a call from the local telephone to a configured dial peer and verify that the call attempt is successful.

Step 3 Use the show dial-peer voice command to verify that the configured data is correct.

Step 4 Use the show voice port command to show the status of the voice ports.

Step 5 Use the show voice call command to show the call status for all voice ports.

Step 6 Use the show voice dsp command to show the current status of all DSP voice channels.


Troubleshooting Tips

To resolve suspected problems, perform the following tasks:


Step 1 Use the show dial-peer voice command on the local and remote concentrators to verify that the data is configured correctly on both.

Step 2 Use the show interface command to verify that the ATM interface is up.

Step 3 Ensure that the voice port, serial port, and controller T1 0 is set to no shutdown.



Note ATM defaults to Interim Local Management Interface (ILMI). If the carrier is using LMI, be sure to configure LMI support on the router.


Verifying the ATM Interface Configuration

To verify the ATM interface configuration, perform the following tasks:

Enter the privileged EXEC show atm vc command to view the SVCs (data only) and PVCs set. The following is a sample output:

Router# show atm vc

VCD /                                      Peak  Avg/Min Burst
Interface   Name       VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts
0          1            0     5   PVC    SAAL     UBR       0                UP
0          2            0    16   PVC    ILMI     UBR       0                UP
0          379          0    60   SVC    SNAP     UBR       0                UP
0          986          0    84   SVC    SNAP     UBR       0                UP
0          14           0   133   SVC    VOICE    VBR      64     16   10    UP
0          15           0   134   SVC    VOICE    VBR      64     16   10    UP
0          16           0   135   SVC    VOICE    VBR      64     16   10    UP
0          17           0   136   SVC    VOICE    VBR      64     16   10    UP
0          18           0   137   SVC    VOICE    VBR      64     16   10    UP
0          19           0   138   SVC    VOICE    VBR      64     16   10    UP
0          20           0   139   SVC    VOICE    VBR      64     16   10    UP
0          21           0   140   SVC    VOICE    VBR      64     16   10    UP
0          22           0   141   SVC    VOICE    VBR      64     16   10    UP
0          23           0   142   SVC    VOICE    VBR      64     16   10    UP
0          24           0   143   SVC    VOICE    VBR      64     16   10    UP
0          25           0   144   SVC    VOICE    VBR      64     16   10    UP
0          26           0   145   SVC    VOICE    VBR      64     16   10    UP
0          27           0   146   SVC    VOICE    VBR      64     16   10    UP
0          28           0   147   SVC    VOICE    VBR      64     16   10    UP


Note VoATM SVCs are not supported since Cisco IOS Release12.0(7)XK. The ATM SVCs for data are still supported.


Enter the show atm pvc command with the VPI/VCI specified to view the PVCs that are set up for ILMI management and Q.SAAL signaling. The following is a sample output:

Router# show atm pvc 0/5

ATM0: VCD: 2, VPI: 0, VCI: 5, Connection Name: SAAL
UBR, PeakRate: 56
AAL5-SAAL, etype:0x4, Flags: 0x26, VCmode: 0x0
OAM frequency: 0 second(s), OAM retry frequency: 1 second(s), OAM retry frequenc
y: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM Loopback status: OAM Disabled
OAM VC state: Not Managed
ILMI VC state: Not Managed
InARP DISABLED
InPkts: 2044, OutPkts: 2064, InBytes: 20412, OutBytes: 20580
InPRoc: 2044, OutPRoc: 2064, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Compress: Disabled
Status: INACTIVE, State: NOT_IN_SERVICE
!
Router# show atm pvc 0/16

ATM0: VCD: 1, VPI: 0, VCI: 16, Connection Name: ILMI
UBR, PeakRate: 56
AAL5-ILMI, etype:0x0, Flags: 0x27, VCmode: 0x0
OAM frequency: 0 second(s), OAM retry frequency: 1 second(s), OAM retry frequenc
y: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM Loopback status: OAM Disabled
OAM VC state: Not Managed
ILMI VC state: Not Managed
InARP DISABLED
InPkts: 398, OutPkts: 421, InBytes: 30493, OutBytes: 27227
InPRoc: 398, OutPRoc: 421, Broadcasts: 0
InFast: 0, OutFast: 0, InAS: 0, OutAS: 0
OAM cells received: 0
F5 InEndloop: 0, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 0
F5 OutEndloop: 0, F5 OutSegloop: 0, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Compress: Disabled
Status: INACTIVE, State: NOT_IN_SERVICE

Enter the show atm interface command in privileged EXEC mode and specify ATM 0 to display the ATM interface. The following is a sample output:

Router# show interface atm 0

ATM0 is up, line protocol is up
  Hardware is PQUICC Atom1
  Internet address is 9.1.1.6/8
  MTU 1500 bytes, sub MTU 1500, BW 1536 Kbit, DLY 20000 usec,
     reliability 255/255, txload 22/255, rxload 11/255
  NSAP address: 47.0091810000000002F26D4901.000011116666.06
  Encapsulation ATM
  292553397 packets input, -386762809 bytes
  164906758 packets output, 1937663833 bytes
  0 OAM cells input, 0 OAM cells output, loopback not set
  Keepalive not supported
  Encapsulation(s):, PVC mode
  1024 maximum active VCs, 28 current VCCs
  VC idle disconnect time: 300 seconds
  Signalling vc = 1, vpi = 0, vci = 5
  UNI Version = 4.0, Link Side = user
  Last input 00:00:00, output 2d05h, output hang never
  Last clearing of "show interface" counters never
  Input queue: -1902/75/0 (size/max/drops); Total output drops: 205
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 67000 bits/sec, 273 packets/sec
  5 minute output rate 136000 bits/sec, 548 packets/sec
     76766014 packets input, 936995443 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     367264676 packets output, 3261882795 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out

Enter the show atm video-voice address privileged EXEC command to display the ATM interface address and confirm the ILMI status (ILMI PVC is set up to enable SVC management). The ATM interface is assigned automatically with the atm voice aesa command. The following is a sample output:

Router# show atm video-voice address

nsap address                                  type         ilmi status
47.0091810000000002F26D4901.00107B4832E1.FE   VOICE_AAL5   Confirmed
47.0091810000000002F26D4901.00107B4832E1.C8   VIDEO_AAL1   Confirmed

Verifying the VoATM Connection

Verify that the voice connection is working by performing the following steps:


Step 1 Pick up the handset on a telephone connected to the configuration and verify that there is dial tone.

Step 2 Make a call from the local telephone to a configured dial peer to verify the connection.

Step 3 Check the validity of the dial-peer and voice-port configuration by performing the following tasks:

If there are relatively few dial peers configured, use the show dial-peer voice command to verify that the data configured is correct.

To show the status of the voice ports, use the show voice port command.

To show the call status for all voice ports, use the show voice call command.

To show the current status of all DSP voice channels, use the show voice dsp command.

Troubleshooting Tips

If a call does not connect, resolve the problem by performing the following tasks:

Verify dial peer configuration by using the show dial-peer voice command on the local and remote concentrators.

Verify that ATM interface 0 is up by using the show interface command.

Ensure that the voice port, serial port, and controller T1 0 are set to no shutdown.

VoATM Configuration Examples

Configuration examples for VoATM are shown in the following sections:

Back-to-Back VoATM PVCs Example

Voice and Data Traffic over ATM PVCs Example

VoATM for Cisco 3600 Series Routers Configuration Example

VoATM for the Cisco MC3810 Multiservice Concentrator Configuration Example

Back-to-Back VoATM PVCs Example

Figure 89 shows a configuration example for two Cisco MC3810 multiservice concentrators configured back-to-back, with VoATM configured for both concentrators. This setup is a useful for testing the VoATM configuration locally to ensure that voice connections can be made before configuring VoATM across a larger network. Following the figure are the commands required for configuring the Cisco MC3810 multiservice concentrators in this example.

Figure 89 Back-to-Back VoATM PVCs Configuration

Cisco MC3810 Multiservice Concentrator 1
Cisco MC3810 Multiservice Concentrator 2
hostname location1
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.10.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
!
hostname location2
no ip domain-lookup
!
interface Ethernet0
 ip address 10.1.20.1 255.255.255.0
 no ip mroute-cache
 no ip route-cache
!
controller T1 0
 clock source internal
 mode atm
!
interface atm0 point-to-point
ip address 10.1.1.1 255.255.255.0
 no ip mroute-cache
!
controller T1 0
 clock source line
 mode atm
!
interface atm0 point-to-point
ip address 10.1.1.2 255.255.255.0
 no ip mroute-cache
!
pvc 1 1 100
 encapsulation aal5mux voice
 vbr-rt 384 192 48
!
pvc 1 1 100
 encapsulation aal5mux voice
 vbr-rt 384 192 48
!
pvc 2 1 200
 encapsulation aal5snap
 map-group atm1
!
router rip
 redistribute connected
 network 10.0.0.0
!
no ip classless
!
pvc 2 1 200
 encapsulation aal5snap
 map-group atm1
!
router rip
redistribute connected
network 10.0.0.0
!
no ip classless
!
map-list atm1
 ip 10.1.1.2 atm pvc 2 broadcast
!
dial-peer voice 1 pots
 destination-pattern 10
 port 1/1
!
dial-peer voice 202 voatm
 destination-pattern 2.
 session target ATM0 1
!
end
map-list atm1
 ip 10.1.1.1 atm pvc 2 broadcast
!
dial-peer voice 1 pots
 destination-pattern 20
 port 1/1
!
dial-peer voice 202 voatm
 destination-pattern 1.
 session target ATM0 1
!
end

Voice and Data Traffic over ATM PVCs Example

Figure 90 shows an example for both voice and data traffic over ATM between two Cisco MC3810 multiservice concentrators, including configuration for voice ports and dial peers. Following the figure are the commands required for configuring the Cisco MC3810 multiservice concentrators in this example.

Figure 90 Voice and Data Traffic over ATM PVCs Configuration

Cisco MC3810 Multiservice Concentrator 1
Cisco MC3810 Multiservice Concentrator 2
interface Ethernet0
 ip address 172.22.124.239 255.255.0.0
!
controller T1 0
 mode ATM
!
interface atm0 point-to-point
 ip address 223.223.224.229 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 map-group atm1
!
interface Ethernet0
 ip address 172.22.124.247 255.255.0.0
!
controller T1 0
 mode ATM
!
interface atm0 point-to-point
 ip address 223.223.224.228 255.255.255.0
 no ip mroute-cache
 no ip route-cache
 map-group atm1
!
pvc 26 26 200
 encapsulation aal5snap
!
pvc 27 27 270
 encapsulation aal5mux voice
 vbr-rt 384 192 48
!
no ip classless
!
pvc 26 26 200
 encapsulation aal5snap
!
pvc 27 27 270
 encapsulation aal5mux voice
 vbr-rt 384 192 48
!
no ip classless
!
map-list atm1
 ip 223.223.224.228 atm pvc 26 broadcast
!
voice-port 1/1
!
voice-port 1/2
!
voice-port 1/3
!
voice-port 1/4
!
map-list atm1
 ip 223.223.224.229 atm pvc 26 broadcast
!
login
line vty 1 4
 login
!
voice-port 1/1
!
voice-port 1/2
!
voice-port 1/3
!
voice-port 1/4
!
dial-peer voice 1 pots
 destination-pattern 3488801
 port 1/1
!
dial-peer voice 2 pots
 destination-pattern 3488802
 port 1/2
!
end
dial-peer voice 1 pots
 destination-pattern 3388801
 port 1/1
!
dial-peer voice 2 pots
 destination-pattern 3388802
 port 1/2
!
dial-peer voice 1001 voatm
 destination-pattern 348....
 session target ATM0 27 
!
end

VoATM for Cisco 3600 Series Routers Configuration Example

The following is a sample configuration for VoATM on a Cisco 3600 series router:

version 12.2
!
hostname c3640_1
!
no ip subnet-zero
no ip routing
ip wccp version 2
!
dial-control-mib max-size 500
!
process-max-time 200
!
interface Ethernet0/0
 ip address 172.28.129.54 255.255.255.192
 ip helper-address 171.71.20.62
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 no fair-queue
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 1/100
  vbr-rt 1000 500
  encapsulation aal5mux voice
 !
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 2/100
  vbr-rt 1000 500
  encapsulation aal5mux voice
 !
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/1.1 point-to-point
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 pvc 3/200
  vbr-rt 64 64 4
  encapsulation aal5mux voice
!
interface ATM1/2
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/3
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/4
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/5
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/6
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM1/7
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
 impedance 120-ohm
 no fair-queue
!
interface ATM3/0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 map-group atm1
 atm clock INTERNAL
 pvc 2/200
  encapsulation aal5snap
 no atm auto-configuration
 no atm ilmi-keepalive
 no atm address-registration
 no atm ilmi-enable
 pvc voice 1/100
  vbr-rt 5000 2500
  encapsulation aal5mux voice
!
ip default-gateway 172.28.129.1
ip classless
ip route 171.70.20.62 255.255.255.255 172.28.129.1
no ip http server
!
map-list atm1
 ip 4.4.4.2 atm-vc 2 broadcast
!
map-class frame-relay fr1
!
map-class frame-relay voice
 no frame-relay adaptive-shaping
 frame-relay cir 128000
 frame-relay bc 128000
snmp-server engineID local 00000009020000107BC778C0
snmp-server community public RO
snmp-server community SNMPv2c view v2default RO
snmp-server community v2 view v1default RO
snmp-server community config view v1default RO
snmp-server community voice view v1default RO
snmp-server packetsize 4096
snmp-server enable traps snmp
snmp-server enable traps casa
snmp-server enable traps config
snmp-server enable traps voice poor-qov
snmp-server host 171.71.128.229 version 2c SNMPv2c  config voice snmp
snmp-server host 171.71.128.242 version 2c public config voice snmp
snmp-server host 171.71.129.16 version 2c public tty frame-relay isdn hsrp
config entity envmon bgp rsvp rtr syslog stun sdllc dspu rsrb dlsw sdlc snmp
snmp-server host 171.71.129.164 version 2c public  config voice snmp
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 session-timeout 10
 password apple
 login
!
voice-port 2/0/0
 input gain 5
 output attenuation 5
!
voice-port 2/0/1
 input gain 5
 output attenuation 5
!
voice-port 2/1/0
 input gain 5
 output attenuation 5
!
voice-port 2/1/1
 input gain 5
 output attenuation 5
!
dial-peer voice 2 pots
 destination-pattern 4001
!
dial-peer voice 8000 pots
 destination-pattern 84000
!
dial-peer voice 9000 pots
 destination-pattern 94000
!
dial-peer voice 9001 pots
 destination-pattern 94001
!
dial-peer voice 348 voatm
 destination-pattern 348....
 signal-type ext-signal
 session target ATM3/0 pvc 1/100
!
dial-peer voice 338 voatm
 destination-pattern 338....
 signal-type ext-signal
 session target ATM1/0 pvc 1/100
!
dial-peer voice 2222 voatm
 preference 1
 session target ATM1/0 pvc 1/100
!
dial-peer voice 9500 voatm
 destination-pattern 95...
 session target ATM3/0 pvc 1/100
!
dial-peer voice 8400 pots
 destination-pattern 84000
!
dial-peer voice 50000 voatm
 destination-pattern 5264000
 session target ATM3/0 pvc 1/100
!
dial-peer voice 10000 pots
 destination-pattern 5254000
 port 2/0/0
!
dial-peer voice 10001 pots
 destination-pattern 4000789
 port 2/1/0
!
num-exp 1 1234
num-exp 2 2234
num-exp 12 34567890
num-exp 55 66666
end

VoATM for the Cisco MC3810 Multiservice Concentrator Configuration Example

The following is a sample configuration for VoATM on Cisco MC3810 multiservice concentrators at opposite ends of an AAL2 trunk:

End A

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname aal2-faxtest1
!
network-clock base-rate 64k
ip subnet-zero
!
isdn voice-call-failure 0
!
voice-card 0
!
controller T1 0
 mode atm
 framing esf
 linecode b8zs
!
controller T1 1
 mode cas
 framing esf
 linecode b8zs
interface Ethernet0
 ip address 1.7.78.1 255.255.0.0
!
interface Serial0
 no ip address
!
interface Serial1
 no ip address
 shutdown
interface ATM0
 no ip address
 ip mroute-cache
 no atm ilmi-keepalive
 pvc 99/99 
  vbr-rt 1536 1536 1000
  encapsulation aal2
!
voice-port 1:1
 no echo-cancel enable
timeouts wait-release 3
 connection trunk 1001
!
dial-peer voice 1001 voatm
 destination-pattern 1001
 called-number 2001
session protocol aal2-trunk
 session target ATM0 pvc 99/99 21
 dtmf-relay
 signal-type transparent
 codec aal2-profile custom 100 g711ulaw
 no vad
!
dial-peer voice 201 pots
 destination-pattern 2001
port 1:1
end

End B

Current configuration:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname aal2-faxtest2
!
network-clock base-rate 64k
ip subnet-zero
!
isdn voice-call-failure 0
!
voice-card 0
!
controller T1 0
 mode atm
 framing esf
 clock source internal
 linecode b8zs
!
controller T1 1
 mode cas
 framing esf
 linecode b8zs
 ds0-group 1 timeslots 1 type e&m-immediate-start
!
interface Ethernet0
 ip address 1.7.78.4 255.255.0.0
!
interface Serial0
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface ATM0
 ip address 223.223.226.3 255.255.255.0
 ip mroute-cache
 no atm ilmi-keepalive
 pvc 99/99 
  vbr-rt 1536 1536 1000
  encapsulation aal2
!
voice-port 1:1
timeouts wait-release 3
 connection trunk 2001 
!
dial-peer voice 201 pots
 destination-pattern 1001
port 1:1
!
dial-peer voice 1001 voatm
 destination-pattern 2001
 called-number 1001
 session protocol aal2-trunk
 session target ATM0 pvc 99/99 21
 dtmf-relay
 signal-type transparent
 codec aal2-profile custom 100 g711ulaw
 no vad
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line 2 3
line vty 0 4
 login
!
end