Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2
Configuring Trunk Connections and Conditioning Features
Downloads: This chapterpdf (PDF - 520.0KB) The complete bookPDF (PDF - 9.14MB) | Feedback

Configuring Trunk Connections and Conditioning Features

Table Of Contents

Configuring Trunk Connections and Conditioning Features

Trunking Overview

Simulated Lines and Trunks

Trunk Conditioning Signaling Attributes

Congestion Monitoring and Management Features

T1/E1 Alarm Conditioning

PSTN Fallback

Calculated Impairment Planning Factor

Service Assurance Agent

Busyout

Local Voice Busyout

Advanced Voice Busyout

Busyout Monitor

Trunk Management Prerequisite Tasks

Configuring Trunk-Conditioning Signaling Attributes

Assigning Trunk-Conditioning Attributes to Network Dial Peers

Assigning Voice Classes to Voice Ports

Verifying the Signaling Attributes and Trunk Conditioning

Configuring Trunk Connections

Configuring PLAR (Switched) Connections

Configuring Trunk/Tie-Line Connections

Configuring PLAR-OPX Connections

Configuring T1/E1 Alarm Generation Parameters

Verifying Alarm-Generation Parameters

Configuring PSTN Fallback

Configuring Fallback to Alternate Dial Peers

Configuring Destination Monitoring without Fallback to Alternate Dial Peers

Configuring Call Fallback Cache Parameters

Configuring Call Fallback Jitter-Probe Parameters

Configuring Call Fallback Probe-Timeout and Weight Parameters

Configuring Call Fallback Threshold Parameters

Configuring Call Fallback Map Parameters

Verifying PSTN Fallback Configuration

Troubleshooting Tips

Monitoring and Maintaining PSTN Fallback

Configuring Local Voice Busyout

Configuring the Busyout Trigger Event

Configuring Busyout of Voice Ports

Configuring a Voice Port to Monitor the Link to a Remote Interface

Configuring a Busyout Monitoring Voice Class

Trunk Connections and Conditioning Configuration Examples

Trunk Conditioning Configuration Example

Voice Class for VoFR and VoATM Dial Peers Configuration Example

Voice Class for Voice Ports Configuration Example

Voice Class for Default Signaling Patterns Configuration Example

Voice Class for Specified Signaling Patterns Configuration Example

PLAR (Switched Calls) Configuration Example

Permanent Trunks Configuration Example

Congestion Monitoring and Management Configuration Examples

Configuring PSTN Fallback for VoIP over Frame Relay Example

Configuring PSTN Fallback for VoIP over MLP Example

Local Voice Busyout Configuration Examples

Alarm Trigger for Busyout of Voice Ports Configuration Example


Configuring Trunk Connections and Conditioning Features


This chapter describes trunk connections and conditioning features for the Cisco 2600 and 3600 series routers and MC3810 multiservice concentrators. The features include trunk conditioning, tie-line simulation, T1/E1 alarms, Public Switched Telephone Network (PSTN) fallback, and busyout. This chapter contains:

Trunking Overview

Trunk Conditioning Signaling Attributes

Congestion Monitoring and Management Features

Trunk Management Prerequisite Tasks

Trunk Management Configuration Tasks List

Configuring T1/E1 Alarm Generation Parameters

Trunk Connections and Conditioning Configuration Examples

Congestion Monitoring and Management Configuration Examples

For a complete description of the commands in this chapter, refer to the Cisco IOS Voice, Video, and Fax Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

To identify the hardware platform or software image information associated with a feature in this chapter, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

Trunking Overview

A trunk is a communication line between two switching systems—the switching equipment in a central office (CO) and PBX. It is a physical and logical point-to-point connection with a permanent wire over which network traffic travels. A backbone is composed of a number of trunks.

Voice over IP (VoIP) simulates trunk connections. The simulated connections occur between PBXs that are connected to Cisco routers or access servers on each side of the network

In Figure 103, two PBXs are connected to a router using a simulated trunk and a recEive and transMit (E&M) voice port. In this case, a permanent, non-switched connection transparently connects the two PBXs.

Figure 103 Simulated Trunk Connection

Simulated Lines and Trunks

Simulated lines and trunks enable a telephone user at one location to dial an access code to access a PBX at another location. A second dial tone can be heard coming from the remote PBX. There are two types of simulated connections—switched and permanent—that can be configured for both analog and digital systems. The connections are created with the Cisco connection command.

The connection trunk command creates a permanent call that is connected as soon as the routers on each end are booted (see Figure 104). Permanent calls pass limited telephony signaling and operate without collecting digits or requiring changes to the overall dial plan.

Figure 104 Connection Trunk Configuration

The calls simulate a permanent tie-line between two PBXs. Both ends must be configured and have compatible voice-port signaling that is:

E&M to E&M

Foreign Exchange Office (FXO) to Foreign Exchange Station (FXS)

The signaling cannot be FXO to ground start.

When a switched call is configured (see Figure 105), the user can make a call without dialing any digits. The telephony signaling, such as hookflash, is not passed. The call will not roll over to voice mail if the remote telephone does not answer and digits from an attached telephony device are not collected.

Figure 105 Connection Private-Line Auto Ringback (PLAR) Configuration

The switched call configuration works with any type of voice port (E&M, FXO, or FXS) and can be used without any effect on an existing dial plan. It is commonly used to connect PBXs in which the remote devices appear to be physical extensions. The PBX provides dial tone to the extensions, not the router.

The connection tie-line command creates a switched call between two stations or PBXs that bypasses the switch. The connection plar-opx command creates a call that is similar to a switched call. The connection does not take place between the PBX and the local router until the far-end FXS device answers. This enables the PBX to provide centralized voice mail or attendant services when the remote device does not answer.

Trunk Conditioning Signaling Attributes

Trunk conditioning signaling attributes apply to permanent point-to-point voice connections (private lines and tie-lines) created using the connection trunk command. This feature provides the following capabilities:

Creation of voice classes.

Specific signaling attributes in each voice class.

Signaling attributes in the voice class for Voice over Frame Relay (VoFR) and Voice over Asynchronous Transfer Mode (VoATM) dial peers.

Trunk conditioning enables greater control over Cisco private-line calls that are sent over Frame Relay or ATM networks. When private-line or tie-line calls are sent between two PBXs, fault indications are sent to the sending PBX. If the call fails, the PBX is able to select an alternate path to route the calls. Selecting an alternate path applies to analog connections or digital T1/E1 using channel-associated signaling (CAS)/robbed-bit ABCD signaling. It does not cover common channel signaling (CCS).

When T1/E1 CAS is carried in transparent pass-through mode for arbitrary, unknown, or unsupported CAS protocols, it is necessary to define on-hook/idle patterns so that the domain specific part (DSP)/signaling code can sense the idle call state and shut off the flow of voice packets when no active call is in progress. This mode provides an additional idle bandwidth-saving mechanism for those cases when Voice Activity Detection (VAD) is not desired.


Note Cisco MC3810 series concentrators support additional trunk-conditioning features that specify timing, signaling, and transmission options. The features provide enhanced control over call rerouting in cases of trunk failure and increased bandwidth availability due to suppression of voice packets on Out-of-Service (OOS) trunks.


Congestion Monitoring and Management Features

Congestion monitoring of permanent and switched calls is performed with these features: T1/E1 alarm conditioning, PSTN fallback, and busyout functionality including busyout monitoring. These features provides the following capabilities:

Signaling and suppression of voice traffic for idle or OOS network trunks.

Busyout of the ports interfacing with a local PBX.

An OOS condition can be signalled using an ABCD bit pattern that is different from the busy or seized state. The difference enables the PBX to differentiate between OOS and congestion.

T1/E1 Alarm Conditioning

Alarm conditioning provides status monitoring on T1/E1 PBX voice interfaces for simulated lines and trunks created using the connection command. It supports operation with CAS, but does not support CCS.

A T1/E1 alarm can be triggered by events detected through the monitoring of a specified set of voice ports within a T1/E1 trunk. A monitored set includes a defined voice port that has a specified DS0 group or groups and configured for one of the following:

End-to-end connection of permanent virtual circuits (PVCs)

Busyout of switched virtual circuits (SVCs), where the busyout state is initiated using the busyout monitor command.

When all the monitored voice ports on a T1/E1 trunk are OOS (PVCs are OOS and SVCs are busied out), a T1/E1 Alarm Indication Signal (AIS) is generated on the T1/E1 trunk connected to the PBX or PSTN.


Note Voice ports busied out by the busyout forced command do not trigger a T1/E1 alarm.


PSTN Fallback

PSTN fallback monitors congestion in the IP network and redirects calls to the PSTN or reject calls based on the network congestion. PSTN fallback is supported on Cisco 2600 and 3600 series routers and Cisco MC3810 multiservice concentrators. For information concerning Voice over IP (VoIP), Voice over ATM (ATM), Calculated Impairment Planning Factor (ICPIF), and Service Assurance Agent (SAA), see the following:

Cisco IOS Multiservice Applications Configuration Guide

Cisco IOS Multiservice Applications Command Reference

Configuring Voice over ATM for the Cisco MC3810

Voice over ATM on Cisco 3600 Series Routers

Managing Voice Quality with Cisco Voice Manager (CVM) and Telemate

Monitoring the Router and Network

PSTN fallback can re-routed calls to an alternate IP destination or to the PSTN if the IP network is found unsuitable for voice traffic at that time. The user defines the congestion thresholds based on the configured network. This functionality enables the service provider to give a reasonable guarantee about the quality of the conversation to their VoIP users at the time of call admission.


Note PSTN fallback does not ensure that a VoIP call is protected from the effects of congestion. This is the function of the other Quality of Service (QoS) mechanisms such as IP Real-Time Transport Protocol (RTP) priority or low latency queueing (LLQ).


PSTN fallback includes the following features:

Offers flexibility to define the congestion thresholds based on the network by:

Defining a threshold based on ICPIF, which is derived as part of International Telecommunication Union (ITU) G.113.

Defining a threshold based solely on packet delay and loss measurements.

Uses SAA probes to provide packet delay, jitter, and loss information for the relevant IP addresses. Based on the packet loss, delay, and jitter encountered by these probes, an ICPIF or delay/loss value is calculated. See "Service Assurance Agent" section.

Supports calls of any codec. Only G.729 and G.711 have accurately simulated probes. Calls of all other codecs are emulated by a G.711 probe.

The fallback subsystem has a network traffic cache that maintains the ICPIF or delay/loss values for various destinations. The subsystem helps performance, because new calls to a well-known destination do not have to wait on a probe. The value is usually cached from a previous call.

Once the ICPIF or delay/loss values are calculated and stored, the values remain until the cache ages out or overflows. Until an entry ages out, probes are sent periodically for that destination. The time interval is user configurable. In the following example, it is assumed that call fallback active is enabled and an ICPIF threshold is defined. The call control would be similar if loss and delay thresholds were defined.


Step 1 A call comes into the router. The IP address of the destination is checked against the configured maps to see if it should be sent to another router, such as a backhaul router, or to an alternate dial peer. If it should be sent to another router, the IP address for the fallback subsystem is replaced with the target router. If it should be sent to an alternate dial peer, the router matches that dial peer and obtains the destination information (codec, IP address, and so on).


Note The change is made in the destination address of the probing address. The destination for the actual call is not changed.


Step 2 The router calls the fallback subsystem to look up the specified destination in its network traffic cache. If the ICPIF value exists and is current, then the router uses that value to decide whether to permit the call into the VoIP network. If the router determines that the network congestion is below the configured threshold (by looking at the value from the probe or a cached value), then the call is connected. Otherwise, the router checks the next dial-peer match again in the same way. Eventually, if all the VoIP dial peers are deemed unsuitable, then the call is hairpinned to the PSTN by virtue of a configured POTS dial peer (for analog or digital interfaces). If no PSTN dial peer is present, a fast-busy is sent to the PBX (in case of digital interfaces).


Note It is not possible to signal a fast-busy to some interfaces.


Step 3 The fallback subsystem continues probing in the background periodically (period time is configured by the call fallback probe-timeout command), so that the network congestion information is available when there is a call request. The first call for a particular dial peer may be delayed while the router calculates the congestion information for that destination.

If the timeout threshold is set and the router has not received calls for a particular destination after the threshold expires, then the router removes that destination's traffic information from the cache.


Calculated Impairment Planning Factor

ICPIF calculates an impairment factor for every piece of equipment along the voice path and adds the values to get the total impairment. The ITU assigns the different types of impairments, such as noise, delay, and echo.

The ICPIF handling has been introduced for compatibility with Cisco H.323. Part of ICPIF includes a concept of Total Impairment Value that is a function of loss of packets, delay of packets, and codecs used based on the round-trip reports from SAA. For this feature, all codecs are classified as 729 class codecs or 711 class codecs.

Service Assurance Agent

SAA is a network congestion analysis mechanism. SAA provides delay, jitter, and packet loss information for the configured IP addresses. SAA is based on a client-server protocol defined on UDP. It has an Message Digest 5 (MD5), which is a message authentication algorithm in SNMP v.2. MD5 verifies the integrity of the communication, authenticates the origin, and checks for timeliness.

SAA uses UDP port (port 1976) for sending the SAA control message to the terminating gateway. The SAA probe packets go out on randomly selected ports from the top end of the audio UDP port range (16384 - 32767).

The port pair (RTP & Real-Time Transport Control Protocol [RTCP] port) is selected, and by default SAA for call fallback uses the RTCP port (odd number) to avoid going into the priority queue, if enabled. If fallback is configured to use the priority queue, the RTP port (even number) is selected. The audio UDP port range must be included in the priority queue for fallback priority queueing to work.

Busyout

Three busyout conditions are discussed in the following sections:

Local Voice Busyout

Advanced Voice Busyout

Busyout Monitor

Local Voice Busyout

Local voice busyout is designed to busy out trunks assigned to PVCs so that the PBX does not seize the circuit. Local voice busyout enables the PBX to route a call based on the actual availability of trunks. Local voice busyout enables the following:

A group of voice ports to be marked busy if a link is broken.

Specific voice ports in a PVC application to be marked busy under specified conditions.

When ports are marked busy, a call is forced back to the originating equipment (typically a PBX) that reroutes the call over an alternate path. This action ensures that a caller does not experience "dead air" resulting from a connection that never terminates.

The local voice busyout feature provides a way to busy out a voice port if a monitored network interface changes state. When a monitored interface changes to a specified state—to OOS or in-service—the voice port presents a seized/busyout condition to the attached PBX or other customer premises equipment (CPE). The PBX or other CPE can then attempt to select an alternate route.

Local voice busyout is different from busy-back. Busy-back refers to the signal sent from within the network to the calling party that indicates a busy (or congested) state anywhere along the route, up to and including the condition of the called party.


Note Local voice busyout is supported on analog and digital voice ports using CAS, but not on BRI Voice Modules (BVMs).


Advanced Voice Busyout

Advanced voice busyout monitors links to remote and IP-addressable interfaces and uses an SAA probe signal for VoIP. Voice classes are configured to simplify and speed up the configuration of voice busyout on multiple voice ports. SAA probe monitoring of remote interfaces is intended for use with VoIP, VoFR, and VoATM networks.

Busyout Monitor

Busyout monitor is one aspect of Call Admission Control (CAC) that uses a data network and the PSTN to provide the best possible quality and cost savings for VoIP calls. Busyout monitor CAC functionality also provides the following:

Logical connections between LAN/WAN interfaces of routers in a VoIP gateway with directly connected voice ports.

Port-by-port definition.

Tracking of any directly connected main interface, subinterface, or virtual interface without monitoring the status of remote devices.

Trunk Management Prerequisite Tasks

Before configuring the trunk connections and conditioning features, the one of the following must be configured:

VoFR using FRF.11

VoATM

VoIP

Voice ports

Before configuring the congestion-monitoring features, the following requirements must be met:

Alarm conditioning requires Cisco IOS Release 12.1(3)T or later. The following must also be configured:

VoFR or VoATM, including plain old telephone service (POTS) and network dial peers

Voice ports, including busyout and trunk conditioning

DS0 groups

PSTN fallback requires that VoIP be configured.

Voice busyout and SAA probe enhancements required that the following configuration tasks be completed:

VoFR or VoATM, including POTS and network dial peers

Voice ports

VoIP network

Call fallback on the local router

SAA responder on the target (far-end) router


Note Trunk Management Configuration Tasks List


This section includes procedures for configuring the following trunk management features:

Configuring Trunk-Conditioning Signaling Attributes

Assigning Trunk-Conditioning Attributes to Network Dial Peers

Assigning Voice Classes to Voice Ports

Configuring Trunk Connections

Configuring PLAR (Switched) Connections

Configuring Trunk/Tie-Line Connections

Configuring PLAR-OPX Connections

Configuring T1/E1 Alarm Generation Parameters

Configuring PSTN Fallback

Configuring Local Voice Busyout

Configuring Trunk-Conditioning Signaling Attributes

Different trunk-conditioning signaling attributes may be required to match the characteristics of the different PBXs to which the router connects. For this reason, trunk-conditioning attributes are configured by creating a voice class for each set of attributes required. The trunk-conditioning attributes are configured for the voice class and the voice class is assigned to one or more dial peers.

A voice class must be configured and assigned to at least one dial peer before the trunk conditioning signaling attributes take effect.


Note This configuration supports the North America CAS Protocol and applies only to Cisco private-line or FRF.11 trunk calls. It does not apply to digital T1/E1 trunks using CCS.


To create a voice class and define the trunk-conditioning attributes, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice class permanent tag

Creates a voice class. The tag number range is from 1 to 10000, and it must be unique on the router.

Note The voice-class command in dial-peer configuration mode is entered with a hyphen. The voice class command in global configuration mode is entered without the hyphen.

Step 2 

Router(config-voice-class)# signal keepalive seconds

(Optional) Defines the keepalive signaling packet interval. The seconds range is from 1 to 65535; the default is 5.

Step 3 

Router(config-voice-class)# {no-action | idle-only | 
oos-only | both}

(Optional) Sets the signaling pattern (when the far-end keepalive message is lost or when AIS is received from the far end). The keywords are as follows:

no-action—Sends no signaling pattern.

idle-only or oos-only—Sends only one signaling pattern.

both—Restores the default (both signaling patterns are sent).

Note The no form of the command restores the default also.

Step 4 

Router(config-voice-class)# signal pattern 
{idle receive | idle transmit | oos receive | 
oos transmit} bit-pattern

(Optional) Overrides the default values for the idle and receive OOS patterns or configures OOS transmit signaling patterns. The keywords and argument are as follows:

idle receive—Defines the signaling pattern for an idle message from the network and the signaling pattern to be sent to the PBX if the network trunk is OOS and signal sequence oos idle-only or signal sequence oos are configured. The defaults are:

For near-end E&M—0000 (for T1) or 0001 (for E1)

For near-end FXO loop start—0101

For near-end FXO ground start—1111

For near-end FXS—0101

For near-end MELCAS—1101

 

idle transmit—Defines the signaling pattern for an idle message from the PBX. The defaults are:

For near-end E&M—0000

For near-end FXO—0101

For near-end FXS loop start—0101

For near-end FXS ground start—1111

For near-end MELCAS—1101

 

oos receive—Defines the OOS signaling pattern to be sent to the PBX if the network trunk is OOS and signal sequence oos oos-only or signal sequence oos are configured. The defaults are:

For near-end E&M—1111

For near-end FXO loop start—1111

For near-end FXO ground start—0000

For near-end FXS loop start—1111

For near-end FXS ground start—0101

For near-end MELCAS—1111

oos transmit—Defines the signaling pattern for an OOS message from the PBX. There are no default signaling patterns defined.

bit-pattern—Defines the ABCD bit pattern. Valid values are from 0000 to 1111.

The receive signal pattern comes from the data network side to the PBX. The transmit signal pattern comes from the PBX to the data network side. The range for all options is from 0000 to 1111.

Repeat the command entry for each signal pattern required.

Step 5 

Router(config-voice-class)# signal timing oos 
timeout {seconds | disabled}

(Optional) Changes the timeout period for asserting a receive OOS pattern to the PBX when signaling packets are lost. This action changes the delay time before a busyout is sent to the PBX. The keyword and argument are as follows:

secondsDefines the delay duration between the loss of signaling packets and the beginning of the OOS state. The range is from 1 to 65535. The default is 30.

disabledDeactivates the detection of packet loss. If no signaling packets are received from the network, the router does not send an OOS pattern to the PBX and it continues sending voice packets. Use this option to disable busyout to the PBX.

Step 6 

Router(config-voice-class)# signal timing oos 
restart seconds

(Optional) Configures permanent voice connections to be restarted after the trunk has been OOS for a specified time. The default is no signal timing OOS pattern parameters are configured.

Note This command has no effect if signal timing oos timeout is set to disabled.

Step 7 

Router(config-voice-class)# signal timing oos 
slave-standby seconds

(Optional) Configures a slave port to return to its initial standby state after the trunk has been OOS for a specified time. The default is no signal timing OOS pattern parameters are configured.

Note This command has no effect if signal timing oos timeout is set to disabled.

Step 8 

Router(config-voice-class)# signal timing oos 
{suppress-all | suppress-voice} seconds

(Optional) Configures the router or concentrator to stop sending voice packets or voice and signaling packets to the network if it detects a transmit OOS signaling pattern from the PBX for a specified time. The default is no signal timing OOS pattern parameters are configured.

Note An OOS transmit signaling pattern must be configured with the signal pattern oos transmit command (see Step 4).

Step 9 

Router(config-voice-class)# signal timing idle 
suppress-voice seconds

(Optional) Configures the router or concentrator to stop sending voice packets after the trunk has been idle for a specified time. The default is no signal timing OOS pattern parameters are configured.

Assigning Trunk-Conditioning Attributes to Network Dial Peers

After the voice class has been created, it must be applied to the dial-peer configuration. The trunk-conditioning attributes can be assigned to VoIP, VoFR, or VoATM dial peers, but not to POTS dial peers.


Note This feature applies only to Cisco trunk (private-line) or FRF.11 trunk calls and does not apply to digital T1/E1 trunks using CCS.


To apply trunk-conditioning signaling attributes to a network dial peer, specify the dial peer type and then use the following command in dial-peer voice configuration mode:

Command
Purpose

Router(config-dial-peer)# voice-class permanent tag

Assigns the voice class to the dial peer. The tag argument specifies the unique number. The valid range is from 1 to 10000.

Note The voice-class command in dial-peer configuration mode is entered with a hyphen. The voice class command in global configuration mode is entered without the hyphen.

Assigning Voice Classes to Voice Ports

To assign a voice class to a voice port, specify the voice port, and then use the following command in voice-port configuration mode:

Command
Purpose
Router(config-voice-port)# voice-class permanent tag

Assigns the voice class to a voice port. The tag argument is a unique number assigned to the voice class. Valid range is from 1 to 10000.

Note The voice-class command for assigning a voice class to a voice port has a hyphen. The voice class command in global configuration mode is entered without the hyphen.

Verifying the Signaling Attributes and Trunk Conditioning

To verify the signaling attributes (timing parameters) using voice-port 1/5 on a Cisco MC3810 multiservice concentrator, enter the show voice trunk-conditioning signaling command. The following is a sample output from this command:

Router# show voice trunk-conditioning signaling 1/5

1/5 : 
TX INFO :slow-mode seq#= 25, sig pkt cnt= 42, last-ABCD=0000
hardware-state ACTIVE signal type is NorthamericanCAS
signal path is OPEN
 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
RX INFO :slow-mode, sig pkt cnt= 37
missing = 0, out of seq = 0, very late = 0 
playout depth = 0 (ms), refill count = 1
prev-seq#= 25, last-ABCD=0000
trunk_down_timer = 4212 (ms), idle timer = 0 (sec),
tx_oos_timer = 0 (sec), rx_ais_duration = 0 (ms)
forced playout signal pattern = NONE
signaling playout history
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000

To verify the status of trunk supervision and configuration parameters on a Cisco MC3810 multiservice concentrator, enter the show voice trunk-conditioning supervisory command. The following is a sample output from this command.

Router# show voice trunk-conditioning supervisory 1/5

1/5 : state : TRUNK_SC_CONNECT, voice : on, signal : on, slave 
status: trunk connected
sequence oos : idle and oos
pattern :rx_idle = 0x0 rx_oos = 0xF tx_oos =  0xF
timing : idle = 0, restart = 0, standby = 0, timeout = 40
supp_all = 50, supp_voice = 0, keep_alive = 5
timer: oos_ais_timer = 0, timer = 0

To verify signaling and timing parameters for the configuration for voice-ports 0:0, 0:1, and 0:2 on a Cisco MC3810 multiservice concentrator, enter the show running-config command. The trunks do not have to be connected and active. The following is a sample output from this command.

Router# show running-config

Building configuration...

Current configuration:
.
.
.
voice class permanent 100
signal timing idle suppress-voice 2000
signal timing oos restart 1000
.
.
.
voice-port 0:0
 voice-class permanent 100
 compand-type a-law
!
voice-port 0:1
 voice-class permanent 100
 compand-type a-law
!
voice-port 0:2
 voice-class permanent 100
 compand-type a-law
.
.
.

To display the status of trunk-conditioning signaling and timing parameters for a voice port on a Cisco MC3810 multiservice concentrator, enter one of the following commands:

show voice trunk-conditioning signaling. The following output sample is for voice port 1/5 on a Cisco MC3810 multiservice concentrator:

Router# show voice trunk-conditioning signaling 1/5

1/5 : 
TX INFO :slow-mode seq#= 25, sig pkt cnt= 42, last-ABCD=0000
hardware-state ACTIVE signal type is NorthamericanCAS
signal path is OPEN
 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
RX INFO :slow-mode, sig pkt cnt= 37
missing = 0, out of seq = 0, very late = 0 
playout depth = 0 (ms), refill count = 1
prev-seq#= 25, last-ABCD=0000
trunk_down_timer = 4212 (ms), idle timer = 0 (sec),
tx_oos_timer = 0 (sec), rx_ais_duration = 0 (ms)
forced playout signal pattern = NONE
signaling playout history
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000

show voice trunk-conditioning signaling summary. The following output sample is for voice ports on a Cisco MC3810 multiservice concentrator:

Router# show voice trunk-conditioning signaling summary

1/1 is shutdown
1/4 is shutdown
1/5 : 
TX INFO :slow-mode seq#= 25, sig pkt cnt= 40, last-ABCD=0000
hardware-state ACTIVE signal type is NorthamericanCAS signal path is OPEN
RX INFO :slow-mode, sig pkt cnt= 36, prev-seq#= 25, last-ABCD=0000

show voice call summary. The following output sample is for voice port 1/5 on a Cisco MC3810 multiservice concentrator:

Router# show voice call summary

PORT      CODEC    VAD VTSP STATE            VPM STATE
========= ======== === ===================== ========================
1/1                                          *shutdown*
1/2       -         -  -                     FXSLS_ONHOOK 
1/3       -         -  -                     FXSLS_ONHOOK 
1/4                                          *shutdown* 
1/5       g729r8    n  S_CONNECT             S_TRUNKED 
1/6       -         -  -                     EM_ONHOOK 

Configuring Trunk Connections

This section covers the following three types of trunk connections:

PLARs (switched) connections enable the user to make a call without dialing any digits. The router uses the digits that follow the command internally to send the call to a dial peer.

Trunk and tie-line connections are virtual connections to PBXs and are dedicated until disabled.

OPXs are off-premise extension connections that are used with the Cisco MC3810 concentrators only.

Configuring PLAR (Switched) Connections

To configure a PLAR connection, enter voice-port configuration mode for the required voice port.


Note The syntax of the voice-port command is hardware specific. Refer to the Cisco IOS Voice, Video, and Fax Command Reference for more information.


To configure a PLAR connection, use the following command in voice-port configuration mode:

Command
Purpose

Router(config-voice-port)# connection plar string

Specifies a PLAR connection and associates a peer directly with an interface. The string argument is a destination telephone number. Valid entries are any series of digits that specify the E.164 standard.

Configuring Trunk/Tie-Line Connections

The following restrictions apply to the trunk/tie-line configuration:

Trunk/tie-line connections are applicable only to Cisco 2600 and 3600 series routers.

Use the following voice port combinations:

E&M to E&M (same type)

FXS to FXO

FXS to FXS (without signaling)

Do not perform number expansion on the destination pattern telephone numbers configured for trunk connection.

Configure both end routers to establish the trunk connection.

Use the shutdown/no shutdown command sequence on the voice port to activate the configuration.

To configure a trunk or tie-line connection, use the following commands in dial-peer configuration mode for the required POTS dial peer:

 
Command
Purpose

Step 1 

Router(config-dial-peer)# destination-pattern [+]string [T]

Defines the telephone number associated with the POTS dial peer. The keywords and argument are as follows:

Plus sign (+)—(Optional) Character indicating an E.164 standard number. The plus sign (+) is not supported on the Cisco MC3810.

string—Series of digits that specify the E.164 or private dialing plan telephone number. Valid entries are the digits 0 through 9, the letters A through D, and the following special characters:

Asterisk (*) and pound sign (#) that appear on standard touch-tone dial pad.

Comma (,) inserts a pause between digits.

Period (.) matches any entered digit (this character is used as a wildcard).

T—Indicates that the control character that the destination-pattern value is a variable length dial-string.

Step 2 

Router(config-dial-peer)# port {slot-number/subunit-number/port} | {slot/port:ds0-group-no}

Associates the POTS dial peer with a specific logical dial interface. The arguments are as follows:

slot-numberLocation of the voice interface card. Valid entries are from 0 to 3, depending on the slot where the card is installed.

subunit-numberSubunit on the voice interface card where the voice port is located. Valid entries are 0 and 1.

portVoice-port number. Valid entries are 0 and 1.

slotRouter location of the installed voice port adapter. Valid entries are from 0 to 3.

portVoice interface card location. Valid entries are from 0 to 3.

ds0-group-no—Defined DS0 group number. Each group number is represented on a separate voice port. This enables definition of individual DS0s on the digital T1/E1 card.

Step 3 

Router(config-dial-peer)# prefix string

(Optional) Specifies the prefix for this POTS dial peer. The string argument is sent to the telephony interface first, before the telephone number (destination pattern) associated with the dial peer is sent.

Step 4 

Router(config-dial-peer)# exit

Exits dial-peer configuration mode.

Step 5 

Router(config)# dial-peer voice number voip

Configures a VoIP peer. The number argument uniquely identifies the VoIP dial peer.

Step 6 

Router(config-dial-peer)# destination-pattern [+]string [T]

Defines the destination telephone number associated with this VoIP dial peer.

Step 7 

Router(config-dial-peer)# session target {ipv4:destination-address | dns:[$s$. | $d$. | $e$. | $u$.]host-name | loopback:rtp | loopback:compressed | loopback:uncompressed | ras}

Identifies the IP address of the appropriate port on the destination end router. The keywords and arguments are as follows:

ipv4:destination-address—Specifies the IP address of the dial peer.

dns:host-name—Specifies the domain name server that is the name of the IP address. Valid entries are characters representing the name of the host device.

$s$.—Source destination pattern is part of the domain name.

$d$.—Destination number is part of the domain name.

$e$.—Called number digits are reversed, periods are added in-between each digit of the called number. The string is part of the domain name.

$u$.—Unmatched portion of the destination pattern (such as a defined extension number) is part of the domain name.

loopback:rtp—Specifies that all voice data is looped back to the originating source. Applicable for VoIP peers.

loopback:compressed—Specifies that all voice data is looped back in compressed mode to the originating source. Applicable for POTS peers.

loopback:uncompressedSpecifies that all voice data is looped back in an uncompressed mode to the originating source. Applicable for POTS peers.

ras—Indicates that the RAS signaling function protocol is used. A gatekeeper will translate the E.164 address into an IP address.

Step 8 

Router(config-dial-peer)# exit

Exits dial-peer configuration mode and returns to global configuration mode.

Step 9 

Router(config)# voice-port {slot-number/subunit-number/port} | {slot/port:ds0-group-no}

Enters voice-port configuration mode. The arguments are as follows:

slot-numberDefines the location of the voice interface card. Valid entries are from 0 to 3, depending on the slot where the card is installed.

subunit-numberSpecifies the subunit on the voice interface card where the voice port is located. Valid entries are 0 and 1.

port—Specifies the voice-port number. Valid entries are 0 and 1.

slotDefines the router location of the installed voice port adapter. Valid entries are from 0 to 3.

portIndicates the voice interface card location. Valid entries are from 0 to 3.

ds0-group-no—Defines the DS0 group number. Each group number is represented on a separate voice port. This enables definition of individual DS0s on the digital T1/E1 card.

Step 10 

Router(config-voice-port)# connection {tie-line | trunk [answer-mode]} string

Specifies a tie-line connection to a PBX. The keywords and arguments are as follows:

tie-line—Used only on the Cisco MC3810 multiservice concentrator when additional prefixed digits are required. The combined set of digits route the call into the network using the dial peers. The tie-line digits are automatically stripped by a terminating port.

trunk—Specifies a straight tie-line connection to a PBX.

answer-mode—(Optional) Specifies that the router should not attempt to initiate a trunk connection, but should wait for an incoming call before establishing the trunk. If one of the devices is for receiving calls only, use this option.

string—Specifies the destination telephone number configured for the destination VoIP dial peer. The value configured for the connection trunk command must match the value configured for the VoIP dial peer exactly.

Configuring PLAR-OPX Connections

The plar-opx command is specific to the Cisco MC3810 concentrator and configures an OPX connection. The local voice port provides a local response before the remote voice port receives an answer. On FXO interfaces, the voice port does not answer until the remote side answers.

To configure a PLAR-OPX connection, use the following command in voice-port configuration mode for the required voice port:

Command
Purpose

Router(config-voice-port)# connection plar-opx string

Specifies a PLAR-OPX connection, associating a peer directly with an interface.

Configuring T1/E1 Alarm Generation Parameters

A network can be configured to monitor any combination of DS0 groups on a T1 or E1 trunk. An alarm is triggered only if all of the monitored DS0 groups on a T1 or E1 trunk are OOS. If one monitored DS0 group is in service, no alarm is triggered. The DS0 groups can be either of the following types:

DS0 groups configured as voice ports for permanent point-to-point voice connections created using the connection command (for private lines and tie-lines). These DS0 groups can go OOS due to a trunk-conditioning event or busyout event (except forced busyout).

DS0 groups configured as voice ports for switched voice traffic using CAS. These DS0 groups can go OOS, because of a busyout event (except forced busyout).


Note Alarm conditioning is not supported on CCS trunks.


To specify the DS0 group to be monitored and the alarm type, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller {t1 | e1} {0 | 1}

Enters controller configuration mode.

Step 2 

Router(config-controller)# mode {cas | atm}

Configures the controller for CAS.

Step 3 

Router(config-controller)# ds0-group ds0-group-no timeslots timeslot-list type {e&m-immediate | e&m-delay | e&m-wink | fxs-ground-start | fxs-loop-start | fxo-ground-start | fxp-loop-start}

Configures DS0 groups on the controller. The keywords and arguments are as follows:

ds0-group-no—Identifies the DS0 group and must be a value from 0 to 23 for T1 and 0 to 30 for E1.

timeslots timeslot-list—Specifies a single time slot number, a single range of numbers, or multiple ranges of numbers separated by commas. For T1/E1, allowable values are from 1 to 24. Examples are:

2

1-15, 17-24

1-23

2, 4, 6-12

 

type—Specifies the signaling method that depends upon the connection. The E&M interface enables connection for PBX lines and telephone equipment. The FXS interface connects basic telephone equipment and the PBX. The FXO interface connects the CO to a standard PBX interface where permitted by local regulations. It is often used for OPXs. The keywords are as follows:

 

e&m-immediate specifies no specific off-hook and on-hook signaling.

e&m-delay specifies that the originating endpoint sends an off-hook signal and then and waits for an off-hook signal followed by an on-hook signal from the destination.

e&m-wink specifies that the originating endpoint sends an off-hook signal and waits for a wink signal from the destination.

 

fxs-ground-start specifies FXS ground-start signaling support.

fxs-loop-start specifies FXS loop-start signaling support.

fxo-ground-start specifies FXO ground-start signaling support.

fxo-loop-start specifies FXO loop-start signaling support.

 

Repeat Step 3 for each DS0 group to be configured.

Step 4 

Router(config-controller)# alarm-trigger blue ds0-group-list

Enables alarm conditioning and configures the system to monitor one or more DS0 groups. The keyword and argument is as follows:

blueSpecifies an AIS alarm and is required.

ds0-group-list—Values can be a single DS0 group number, a single range of numbers, or multiple ranges of numbers separated by commas. Allowable values are from 0 to 23 for T1 and from 0 to 30 for E1.

Verifying Alarm-Generation Parameters

Use one or more of the following methods to verify that the T1/E1 controller is correctly configured for generating alarms:

Enter the show running-config command. The following output sample is for a Cisco MC3810 multiservice concentrator, with controller E1 0 configured so that a blue alarm is generated if DS0 groups 0, 1, and 2 (voice ports 0:0, 0:1, and 0:2) are all busied out:

Router# show running-config

Building configuration...
.
controller E1 0
 mode cas
 ds0-group 0 timeslots 1-10 type e&m-immediate-start
 ds0-group 1 timeslots 11-15,17-20 type e&m-immediate-start
 ds0-group 2 timeslots 21-30 type e&m-immediate-start
 alarm-trigger blue 0-2

Create an OOS state on all voice ports on the controller (this should cause a blue alarm to be generated).

For voice ports with the busyout monitor function enabled (switched or trunked), busy out the voice ports by completing the following two steps:

Step 1. Shut down or disconnect any serial and Ethernet interfaces that are monitored for OOS busyout.
Step 2. Activate any serial and Ethernet interfaces that are monitored for in-service busyout.

Note All the configured voice ports for switched connections and monitored for alarm trigger must have the busyout monitor function enabled; otherwise, no alarm can be triggered.


For voice ports with the busyout monitor function disabled (trunked only), create an OOS condition on the trunks by shutting down or disconnecting the associated local serial interface, or by shutting down the associated far-end T1/E1 controller.

Enter the show controller command. This displays the alarm status of the T1 or E1 trunk on a Cisco MC3810. A yellow alarm is received and detected, and a blue alarm is generated and transmitted:

Router# show controller t1 0

T1 0 is up.
  Applique type is Channelized T1
  Cablelength is long gain36 0db
  Yellow alarm detected.
  alarm-trigger is set to Blue
  Alarm is triggered
  Slot 3 CSU Serial #00000056 Model TEB HWVersion 3.70 RX level = 0DB
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  Data in current interval (827 seconds elapsed):

Configuring PSTN Fallback

The following restrictions and limitations apply to PSTN fallback:

When network congestion is detected, the fallback feature does not affect the existing call. It affects only subsequent calls.

There can only be one ICPIF/delay-loss value per system.

There is a small additional call setup delay for the first call to a new IP destination.

PSTN fallback is supported for H.323 VoIP calls only.

The following sections describe the configuration tasks for PSTN fallback. Each task in the list is identified as either optional or required:

Configuring Fallback to Alternate Dial Peers (required)

Configuring Destination Monitoring without Fallback to Alternate Dial Peers (optional)

Configuring Call Fallback Cache Parameters (optional)

Configuring Call Fallback Jitter-Probe Parameters (optional)

Configuring Call Fallback Probe-Timeout and Weight Parameters (optional)

Configuring Call Fallback Threshold Parameters (optional)

Verifying PSTN Fallback Configuration (optional)

Configuring Fallback to Alternate Dial Peers

To configure fallback to alternate dial peers in case of network congestion, use the following command in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# call fallback active

Enables the PSTN fallback feature to alternate dial peers in case of network congestion.

Step 2 

Router(config)# call fallback key-chain name-of-chain

Specifies MD5 configuration.

Configuring Destination Monitoring without Fallback to Alternate Dial Peers

To monitor call destinations without fallback to alternate dial peers, use the following command in global configuration mode:

Command
Purpose

Router(config)# call fallback monitor

Enables the monitoring of destinations without fallback to alternate dial peers.

Configuring Call Fallback Cache Parameters

To configure the call fallback cache parameters, use the following commands beginning in beginning in configuration mode:

 
Command
Purpose

Step 1 

Router(config)# call fallback cache-size number

Specifies the call fallback cache size.

Step 2 

Router(config)# call fallback cache-timeout seconds

Specifies the time after which the cache entry is purged. Default is 600 seconds.

Step 3 

Router# clear call fallback cache [ip-address]

Clears the current ICPIF estimates for all IP addresses or a specific IP address in the cache.

Configuring Call Fallback Jitter-Probe Parameters

To configure the call fallback jitter-probe parameters, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# call fallback jitter-probe num-packets number-of-packets

Specifies the number of packets for jitter. Default is 15 packets.

Step 2 

Router(config)# call fallback jitter-probe precedence precedence

Specifies the treatment of the jitter-probe transmission. Default is two.

Step 3 

Router(config)# call fallback jitter-probe priority-queue

Assigns a priority to the queue for jitter probes.

Configuring Call Fallback Probe-Timeout and Weight Parameters

To configure call fallback probe-timeout and weight parameters, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# call fallback probe-timeout seconds

Sets the timeout for an SAA probe. Default is 30 seconds.

Step 2 

Router(config)# call fallback instantaneous-value-weight weight

Configures the call fallback subsystem to take an average from the last two probes registered in the cache for call requests.

Configuring Call Fallback Threshold Parameters

To configure the call fallback threshold parameters that monitor network traffic for call requests, use one of the following commands in global configuration mode:

Command
Purpose

Router(config)# call fallback threshold delay delay-value loss loss-value

Specifies fallback threshold to use packet delay and loss values. Delay and loss have no default values.

or

 

Router(config)# call fallback threshold icpif threshold-value

Specifies fallback threshold to use the Calculated Planning Impairment Factor (ICPIF) threshold for network traffic.

Configuring Call Fallback Map Parameters

To configure the call fallback map parameters, use one of the following commands in global configuration mode:

Command
Purpose

Router(config)# call fallback map map target ip-address address-list ip-address1 ip-address2 ... ip-address7

Specifies the call fallback router to keep a cache table (by IP addresses) of distances for several destination peers sitting behind the router.

or

 

Router(config)# call fallback map map target ip-address subnet ip-network netmask

Specifies the call fallback router to keep a cache table (by subnet addresses) of distances for several destination peers sitting behind the router.

Verifying PSTN Fallback Configuration

To verify the PSTN fallback configuration, use the following commands in EXEC mode, as needed:

Command
Purpose

Router# show call fallback cache

Displays the current ICPIF estimates for all IP addresses in the call fallback cache.

Router# show call fallback config

Displays the current configuration.

Router# show call fallback stats

Displays the call fallback statistics.


Troubleshooting Tips

To troubleshoot PSTN fallback, use the following debug commands and ensure that VoIP is working before PSTN fallback is configured:

debug call fallback detail to display details of the VoIP call fallback.

debug call fallback probes to verify that probes are being sent correctly.

Monitoring and Maintaining PSTN Fallback

To monitor and maintain PSTN fallback, use the following commands in EXEC mode, as needed:

Command
Purpose

Router# clear call fallback cache

Clears the current ICPIF estimates for all IP addresses in the cache.

Router# clear call fallback stats

Clears the call fallback statistics.

Router# debug call fallback detail

Displays details of the voice fallback.

Router# debug call fallback probes

Displays details of the voice fallback probes.

Router# test call fallback probe ip-address

Tests a probe to a particular IP address and displays the ICPIF SAA values.


Configuring Local Voice Busyout

This section contains configuration information for the following features:

Configuring the Busyout Trigger Event

Configuring Busyout of Voice Ports

Configuring a Voice Port to Monitor the Link to a Remote Interface

Configuring a Busyout Monitoring Voice Class

The following restrictions and limitations apply to the local voice busyout feature:

A maximum of 32 network interfaces can be monitored for a voice port.

The busyout feature is not activated when there are no DSP resources or bandwidth available. These two conditions can be addressed by configuring alternate routing.

This feature is not supported on the BVM.

When the Cisco MC3810 concentrator is configured, the busyout feature is not activated if there are no DSP resources or bandwidth available. These two conditions can be addressed by configuring alternate routing.

A busyout trigger event can be configured at both the serial interface level and the voice-port level. If there is a conflict between the interface-level trigger event and the voice-port level trigger event (trigger events for each are different), the voice-port-level trigger event overrides the interface level trigger event.

If more than one interface is configured for a busyout trigger event, voice ports are not busied out until all of the interfaces are down.


Note ITU-T G.113, General Characteristics of International Telephone Connections and Telephone Circuits, is supported.


Configuring the Busyout Trigger Event

To configure the voice-port busyout trigger event for a serial or ATM network interface, select the required interface and use the following commands beginning in interface configuration mode:

 
Command
Purpose

Step 1 

Router(config-if)# voice-port busyout

Busies out all voice ports associated with this serial interface.

Note This command does not busy out any voice ports configured to busy out under specific conditions, as described in the "Forcing the Voice Port into Busyout State" section.

Step 2 

Router(config-if)# ctrl z

Exits interface configuration mode and enters EXEC mode.

Step 3 

Router# show voice busyout

Displays the voice busyout status.


Note When voice-port busyout from a serial network interface is configured, all voice ports are placed into a busyout state if the serial interface goes down.


Configuring Busyout of Voice Ports

A voice port can be configured to busy out under specified conditions or it can be manually forced into a busyout state using the following procedures:

Configuring Busyout Under Specified Conditions

Configuring Seize Conditions

Forcing the Voice Port into Busyout State

The default is to busyout when the monitored interface is OOS.

Configuring Busyout Under Specified Conditions

To configure the busyout of a voice port under specified conditions, use the following command in voice-port configuration mode for the required voice port:

Command
Purpose
Router(config-voice-port)# busyout monitor 
interface {serial interface-number | ethernet 
interface-number} [in-service]

Specifies an interface to be monitored. When multiple interfaces are configured for OOS, busy out occurs only if all of the interfaces are OOS. When multiple interfaces are configured for in-service, busy out occurs only when any one interface returns to service.


The keywords and arguments are as follows:

serial—Specifies monitoring of a serial interface. More than one can be entered for a voice port.

interface-number—Identifies an interface to be monitored for the voice-port busyout function.

ethernet—Specifies monitoring of an ethernet interface.

interface-number—Identifies an interface to be monitored for the voice-port busyout function.

in-serviceConfigures the voice port for busy out when the monitored interface returns to service.

Note The voice-port command is hardware specific. Refer to the Cisco IOS Voice, Video, and Fax Command Reference for more information.

Note Reenter the command for each additional interface to be monitored.

Configuring Seize Conditions

To configure seize conditions, use the following commands in voice-port configuration mode for the required voice port:

 
Command
Purpose

Step 1 

Router(config-voice-port)# busyout seize 
{ignore | repeat}

For FXO and FXS only. Configures the busyout seize action for this voice port. The keywords are as follows:

 

ignoreLeaves the loop open and ignores the incoming signal.

repeatSeizes the far end and ignores all incoming signals until the far end releases. Remove the seize signal and wait for one second before starting to seize the far end again.

Note For E&M voice ports, the busyout action is always to seize the far-end line.

Note The voice-port command is hardware specific. Refer to the Cisco IOS Voice, Video, and Fax Command Reference for more information.

Step 2 

Router(config-voice-port)# ctrl z

Exits voice port configuration mode and enters EXEC mode.

Step 3 

Router# show voice port

Displays the configured busyout seize actions for the voice ports.


Note The Cisco MC3810 multiservice concentrator returns the voice ports to an idle state when the event that triggered the busyout disappears.


The busyout seize action depends on the voice port signaling type. Table 45 contains information on the busyout actions that take place. For E&M voice ports, the busyout action is always seize.

Table 45 Procedure Settings and Busyout Actions 

Voice-Port
Signaling Types
Procedure Settings
(Busyout-Option Command)
Busyout Actions

FXS Loop Start

Default

Removes the power from the loop. For analog voice ports, this is equivalent to removing the ground from the tip lead. For digital voice ports, the port generates the bit pattern equivalent to removing the ground from the tip lead or busies out if the bit pattern exists.

FXS Loop Start

Ignore

Ignores the ground on the ring lead.

FXS Ground Start

Default

Grounds the tip lead and stays at this state.

FXS Ground Start

Ignore

Leaves the tip lead open and ignores the ground on the ring lead.

FXS Ground Start

Repeat

Grounds the tip lead and waits for the far end to close the loop. The far end closes the loop. If the far end opens the loop again, the FXS removes the ground from the tip lead. FXS waits for several seconds before starting the process again.

FXO Loop Start

Default

Closes the loop and stays at this state.

FXO Loop Start

Ignore

Leaves the loop open and ignores the ringing current on the ring level.

FXO Loop Start

Repeat

Closes the loop. After the detected far end starts the power denial procedure, FXO opens the loop. After the detected far end has completed the power denial procedure, FXO waits for several seconds before starting the process again.

FXO Ground Start

Default

Grounds the tip lead.

FXO Ground Start

Ignore

Leaves the loop open and ignores the running current on the ring lead or ground on the tip lead.

FXO Ground Start

Repeat

Grounds the ring lead and removes the ground from the ring lead. Closes the loop after the detected far end grounds the tip lead. When the detected far end removes the ground from the tip lead, FXO opens the loop. The FXO waits for several seconds before starting the process again.

E&M Immediate Start

Default (only option available)

Seizes the far end by setting lead busy.

E&M Delay Start

Default (only option available)

Seizes the far end by setting lead busy.

E&M Wink Start

Default (only option available)

Seizes the far end by setting lead busy.


Forcing the Voice Port into Busyout State

When busyout is configured, the specified voice port is forced into a busyout state when the interface is down. When the busyout forced command is entered, the voice port is forced unconditionally into a busyout state. If more than one interface has the voice-port busyout interface command configured, all interfaces must be down for the busyout to take effect.

To configure the voice port for a forced busyout state, use the following commands in voice-port configuration mode for the required voice port:

 
Command
Purpose

Step 1 

Router(config-voice-port)# busyout forced

Places the voice port into the busyout state.

Note If no busyout forced is entered, the busyout state is controlled by the busyout monitor interface command. If the busyout monitor interface command has not been entered, the no busyout forced command forces the voice port out of the busyout state.

Note The voice-port command is hardware specific. Refer to the Cisco IOS Voice, Video, and Fax Command Reference for more information.

Step 2 

Router(config-voice-port)# ctrl z

Exits voice-port mode and enters EXEC mode.

Step 3 

router# show voice busyout

Displays the busyout status.


Note When the voice port is forced into the busyout state, it must be manually forced out of the busyout state by entering the no busyout forced command.


Configuring a Voice Port to Monitor the Link to a Remote Interface

The following restrictions and limitations apply to SAA probe monitoring of remote interfaces:

A maximum of 32 network interfaces can be monitored for a voice port.

The maximum number of simultaneous SAA probes is controlled by the SAA subsystem design and its configuration.

Busyout based on monitoring of a remote, IP-addressable interface is not activated when DSP resources and bandwidth are unavailable.

PSTN Fallback must be enabled for the busyout monitor probe command to function.

PSTN Fallback must also be configured on the router and the SAA responder on the target router.

The SAA responder function must be enabled on the router at the remote IP address targeted by the SAA probe.

The SAA probe feature can be configured on CAS trunks only (not CCS).

If a voice port monitors multiple links, busyout occurs only when all of the monitored links go below the threshold.

Individual voice ports can be configured for busyout, or a voice class can be applied that includes all of the busyout parameters (see the "Assigning Voice Classes to Voice Ports" section).


Note If a busyout voice class has already been assigned to a voice port, a busyout using an SAA probe cannot be configured using this procedure.


To configure a voice port to monitor the link to a remote interface, use the following command in voice-port configuration mode:

Command
Purpose

Router(config-voice-port)# busyout monitor probe ip-address [codec codec-type] [icpif number | loss percent delay milliseconds]

Configures the busyout probe that monitors the link to the remote interface identified by an IP address. Reenter the command for each additional interface to be monitored. The keywords and arguments are as follows:

codec-type—(Optional) Specifies the SAA probe signal.

icpif number—(Optional) Specifies a threshold for ICPIF.

loss percent delay—(Optional) Specifies a threshold in milliseconds, or specifies loss and delay thresholds individually.

Note If icpif values are not entered, the packet delay values from the call fallback active command are used.

Verifying the Voice-Port Busyout Configuration

Complete the following tasks to verify that a voice port is correctly configured to monitor the link to a remote interface:

Shut down the remote interface associated with the configured IP address. This busies out the voice port.

Enter the show voice busyout command to display information about the busyout state. The following is a sample display for voice ports on a Cisco MC3810:

Router# show voice busyout

Voice port busyout will be triggered by the 
following network interfaces states 
 1/1 probe 209.165.202.128 codec g711u icpif 25 
 1/2 probe 209.165.202.128 codec g711u icpif 25 
 1/3 probe 209.165.202.128 codec g711u icpif 25
The following voice ports are in busyout state 

1/1	is in busyout state caused by  
probe 209.165.202.128 codec g711u icpif 2
1/2	is in busyout state caused by  
probe 209.165.202.128 codec g711u icpif 2
1/3	is in busyout state caused by  
probe 209.165.202.128 codec g711u icpif 2

Configuring a Busyout Monitoring Voice Class

A busyout voice class monitors local ports (serial and Ethernet) and links to remote IP addresses. Busyout occurs when all of the monitored local ports are OOS or when all of the monitored links go below the configured threshold value. If a voice port is configured to monitor multiple links, busyout occurs only when all of the monitored links go below the threshold.

To define a voice class with specified busyout conditions, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice class busyout tag

Creates a voice class for defining busyout conditions. The range for the tag number is 1 to 10000. The tag number must be unique on the router.

Step 2 

Router(config-voice-class)# busyout monitor serial interface-number [in-service]

(Optional) Specifies a local serial interface to be monitored by the voice port. To configure the voice port to monitor multiple interfaces, reenter the command for each additional interface to be monitored.1

Step 3 

Router(config-voice-class)# busyout monitor ethernet interface-number} [in-service]

(Optional) Specifies a local Ethernet interface to be monitored by the voice port. To configure the voice port to monitor multiple interfaces, reenter the command for each additional interface.1

Step 4 

Router(config-voice-class)# busyout monitor probe ip-address [codec codec-type] [icpif number | loss loss-value delay milliseconds]

(Optional) Configures the voice port to use an SAA probe to monitor the link to the remote interface identified by an IP address.

(Optional) Specifies a codec profile for the SAA probe signal and ICPIF loss/delay threshold or loss and delay thresholds individually. Packet loss and delay determine the threshold for initiating the busyout state.

Note To configure the voice port to monitor multiple remote interfaces, reenter the command for each additional interface to be monitored.

If a threshold value is not entered, the packet delay values from the call fallback active command are used.

Note PSTN fallback must be configured on this router and the SAA responder on the target router.

1 The default is that the voice port is busied out when the monitored interface is OOS. Enter the keyword in-service to configure the voice port for busyout when the monitored interface comes into service. If a voice port is configured to monitor multiple interfaces for OOS, busyout occurs only when all the monitored serial and Ethernet interfaces are OOS. If a voice port is configured to monitor multiple interfaces for the in-service state, busyout occurs when any one monitored serial or Ethernet interface comes into service.

After the voice class for the busyout function has been created, assign it to all voice ports that have these busyout requirements. See the "Assigning Voice Classes to Voice Ports" section.

Verifying the Voice- and Voice-Class Busyout Configuration

To verify the voice-class busyout, assign the voice class to a voice port as described in the "Assigning Voice Classes to Voice Ports" section, and verify the busyout function of the voice port.

To verify that a voice port is correctly configured for busyout monitoring, perform the following tasks:

Shut down or bring up the monitored interface or interfaces, as required. The voice port is busied out. Monitored interfaces can be any of the following, depending on the configuration:

Local interfaces—for busyout monitor serial and for busyout monitor ethernet. If the voice port is configured to monitor multiple local interfaces for OOS, busyout occurs only when all the monitored interfaces are OOS. If a voice port is configured to monitor multiple local interfaces for the in-service state, busyout occurs when any one monitored interface comes into service.

Remote interface—for busyout monitor probe

The voice port monitors a remote IP address for OOS only.


Note Ensure that PSTN fallback is configured on the local router and SAA responder is configured on the target router.


Enter the show voice busyout command to display information about the busyout state. The following is a sample display for voice ports on a Cisco MC3810 multiservice concentrator:

Router# show voice busyout

Voice port busyout will be triggered by the  
following network interfaces states 
 1/2 busyout monitor ATM0 
 1/3 busyout monitor ATM0 
 1/4 busyout monitor Serial0 
 1/5 busyout monitor Serial0 
 1/6 probe 209.165.202.128 codec g711u icpif 25
The following voice ports are in busyout state
 
1/1 is forced into busyout state 
1/2 is in busyout state caused by ATM0 
1/3 is in busyout state caused by ATM0 
1/4 is in busyout state caused by Serial0 
1/5 is in busyout state caused by Serial0
1/6 is in busyout state caused by probe 209.165.202.128 codec g711u icpif 2

Trunk Connections and Conditioning Configuration Examples

This section has the following examples:

Trunk Conditioning Configuration Example

Voice Class for VoFR and VoATM Dial Peers Configuration Example

Voice Class for Voice Ports Configuration Example

Voice Class for Default Signaling Patterns Configuration Example

Voice Class for Specified Signaling Patterns Configuration Example

PLAR (Switched Calls) Configuration Example

Permanent Trunks Configuration Example

Trunk Conditioning Configuration Example

The following example configures a voice class and then applies it to a VoFR and VoATM dial peer on Cisco  MC3810 series concentrators:

Router(config)# voice class permanent 10 
Router(config-class)# signal keepalive 10 
Router(config-class)# signal pattern idle receive 0101 
Router(config-class)# signal pattern idle transmit 0101 
Router(config-class)# signal timing idle suppress-voice 5 
Router(config-class)# signal pattern oos receive 0001 
Router(config-class)# signal pattern oos transmit 0001 
Router(config-class)# signal timing oos timeout 60 
Router(config-class)# signal timing oos restart 120 
Router(config-class)# signal timing oos suppress-voice 30 
Router(config)# dial peer voice vofr 10 
Router(config-dial-peer)# voice-class permanent 10 
Router(config)# dial peer voice voatm 20 
Router(config-dial-peer)# voice-class permanent 10

Voice Class for VoFR and VoATM Dial Peers Configuration Example

The following example configures a voice class using default idle and OOS signaling patterns and configures busyout to the PBX after a 60-second loss of signaling packets, with restart after 120 seconds:

Router(config)# voice class permanent 10 
Router(config-class)# signal keepalive 10 
Router(config-class)# signal timing oos timeout 60 
Router(config-class)# signal timing idle suppress-voice 5 
Router(config-class)# signal timing oos restart 120 
Router(config-class)# exit 
Router(config)# dial peer voice vofr 10 
Router(config-dial-peer)# voice-class permanent 10 
Router(config-dial-peer)# exit 
Router(config)# dial peer voice voatm 20 
Router(config-dial-peer)# voice-class permanent 10
Router(config-dial-peer)# exit

Voice Class for Voice Ports Configuration Example

The following configuration example shows a voice class with specified signaling bit patterns for the idle receive and transmit; OOS receive and transmit states; and busyout to the PBX after a 90-second loss of signaling packets with restart after 240 seconds:

Router(config)# voice class permanent 30 
Router(config-class)# signal keepalive 10 
Router(config-class)# signal pattern idle receive 0101 
Router(config-class)# signal pattern idle transmit 0101 
Router(config-class)# signal pattern oos receive 0001 
Router(config-class)# signal pattern oos transmit 0001
Router(config-class)# signal timing oos timeout 90 
Router(config-class)# signal timing idle suppress-voice 5 
Router(config-class)# signal timing oos restart 240 
Router(config-class)# exit
Router(config)# voice-port 0/1:5
Router(config-voiceport)# voice-class permanent 30

Voice Class for Default Signaling Patterns Configuration Example

The following configuration example shows a voice class using default idle and OOS signaling patterns and configures busyout after 60 seconds to the PBX, with restart after 120 seconds. It applies the voice class to both VoFR and VoATM dial peers:

Router(config)# voice class permanent 10 
Router(config-class)# signal keepalive 10 
Router(config-class)# signal timing oos timeout 60 
Router(config-class)# signal timing idle suppress-voice 5 
Router(config-class)# signal timing oos restart 120 
Router(config-class)# exit 
Router(config)# dial peer voice vofr 10 
Router(config-dial-peer)# voice-class permanent 10 
Router(config-dial-peer)# exit 
Router(config)# dial peer voice voatm 20 
Router(config-dial-peer)# voice-class permanent 10
Router(config-dial-peer)# exit

Voice Class for Specified Signaling Patterns Configuration Example

The following example configures a voice class with specified signaling bit patterns for the idle receive, idle transmit, OOS receive, and OOS transmit states, and it configures busyout after 90 seconds to the PBX, with restart after 240 seconds. It applies the voice class to digital voice port 0:5 on a Cisco MC3810:

Router(config)# voice class permanent 30 
Router(config-class)# signal keepalive 10 
Router(config-class)# signal pattern idle receive 0101 
Router(config-class)# signal pattern idle transmit 0101 
Router(config-class)# signal pattern oos receive 0001 
Router(config-class)# signal pattern oos transmit 0001
Router(config-class)# signal timing oos timeout 90 
Router(config-class)# signal timing idle suppress-voice 5 
Router(config-class)# signal timing oos restart 240 
Router(config-class)# exit
Router(config)# voice-port 0:5
Router(config-voiceport)# voice-class permanent 30

PLAR (Switched Calls) Configuration Example

The following example configures the DTMF relay and PLAR for router alpha:

hostname router-alpha
!
voice-card 1
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 1 timeslot 1 type fxo-loop
 ds0-group 2 timeslot 2 type fxo-loop
!
dial-peer voice 1 voip
 dtmf-relay  h245-alpha
 codec g729a
 destination-pattern 2..
 session target ipv4:192.168.100.2 
!
dial-peer voice 2 pots
 destination-pattern 101 
 port 1/0:1
!
dial-peer voice 3 pots
 destination-pattern 102
 port 1/0:2
!
voice-port 1/0:1
 connection plar 201
!
voice-port 1/0:2
 connection plar 202
!
interface s0/0
 ip address 192.168.100.1 255.255.255.0

The following example configures the DTMF relay for router beta:

hostname router-beta
!
dial-peer voice 1 voip
 destination-pattern 1..
 dtmf-relay h245-alpha
 codec g729a
 session target ipv4:192.168.100.1
!
dial-peer voice 2 pots
 destination-pattern 201
 port 1/1
!
dial-peer voice 3 pots
 destination-pattern 202
 port 1/2
!
voice-port 1/1
!
voice-port 1 / 2
!
interface serial 0/0
 ip address 192.168.100.2 255.255.255.0

Permanent Trunks Configuration Example

A trunk connection can be used only between E&M ports or with FXO-to-FXS connections. The following example configures the alpha router:

hostname router-alpha
!
voice-card 1
!
controller T1 1/0
 framing esf 
 linecode b8zs
 ds0-group 1 timeslot 1 type e&m-wink
 ds0-group 2 timeslot 2 type e&m-wink
 clock source line
!
voice-port 1/0:1
 connection trunk 1111 
!
voice-port 1/0:2 
 connection trunk 1112
!
dial-peer voice 1 voip
 dtmf-relay h245-alpha
 codec g729a
 destination-pattern 111.
 session target ipv4:192.168.100.2
!
dial-peer voice 2 pots
 destination-pattern 2221
port 1/0:1
!
dial-peer voice 3 pots
 destination-pattern 2222
 port 1/0:2
!
interface serial 0/0
 ip address 192.168.100.1 255.255.255.0

The following example configures the beta router:

hostname router-beta
!
voice-card 1 
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 1 timeslot 1 type e&m-wink
 ds0-group 2 timeslot 2 type e&m-wink
 clock source line
!
voice-port 1/0:1
 connection trunk 2221
!
voice-port 1/0:2
 connection trunk 2222
!
dial-peer voice 1 voip
 dtmf-relay h245-alpha
 codec g729a
 destination-pattern 222.
 session target ipv4:192.168.100.1
!
dial-peer voice 2 pots
 destination-pattern 1111
 port 1/0:1
!
dial-peer voice 3 pots
 destination-pattern 1112
 port 1/0:2
!
interface serial 0/0
 ip address 192.168.100.2 255.255.255.0

In this configuration, a permanent and transparent path is set up between individual DS0s on each router. It passes dial tone from the remote PBX and passes DTMF digits out of band.

The connection command, using the keyword trunk, establishes the permanent trunk connection between the routers. The digits after the command are passed internally within the router to match a dial peer so that the call can be set up.

Congestion Monitoring and Management Configuration Examples

This section has the following examples:

Configuring PSTN Fallback for VoIP over Frame Relay Example

Configuring PSTN Fallback for VoIP over MLP Example

Local Voice Busyout Configuration Examples

Alarm Trigger for Busyout of Voice Ports Configuration Example

Configuring PSTN Fallback for VoIP over Frame Relay Example

The following output sample shows the PSTN fallback configuration with default fallback values on Router1 for VoIP over Frame Relay as shown in Figure 106. The direction of the calls is from Router1, a Cisco 3640, to Router2, a Cisco 3660. In this example, MD5 authentication is not configured.

Also, SAA responder is configured on Router2 to answer the probes from Router1. When the number 3666 is called from Router1 and congestion is on the link between 10.6.6.77 and 10.6.6.78, the call is not admitted. The user hears a busy tone because there is only one dial peer, 3666, and the IP network that is connected to it is congested. To help avoid this congestion, the call fallback active command is enabled here for PSTN fallback. No other call fallback parameters have been configured.

Figure 106 Network Example for VoIP over Frame Relay

Router(config)# show running-config
Current configuration:
!
version 12.2
service timestamps debug datetime msec localtime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
voice-card 3
!
ip subnet-zero
no ip domain-lookup
!
frame-relay switching
!
call fallback active
!
interface Ethernet0/0
 ip address 10.3.3.77 255.255.0.0
 no ip directed-broadcast
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 load-interval 30
 no keepalive
 frame-relay traffic-shaping
 frame-relay inverse-arp interval 15
!
interface Serial0/0.1 point-to-point
 ip address 10.6.6.77 255.255.0.0
 no ip directed-broadcast
 frame-relay interface-dlci 100   
  class frs0
!
interface Ethernet0/1
 ip address 10.4.4.77 255.255.0.0
 no ip directed-broadcast
 load-interval 30
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
ip route 10.5.0.0 255.255.0.0 10.4.4.78
ip route 10.255.254.254 255.255.255.255 Ethernet0/0
no ip http server
!
map-class frame-relay frs0
 no frame-relay adaptive-shaping
 frame-relay cir 100000
 frame-relay bc 560
 frame-relay mincir 100000
 frame-relay fair-queue
 frame-relay fragment 100
 frame-relay ip rtp priority 16384 16383 75
!
line con 0
 exec-timeout 35791 0
 transport input none
line aux 0
line vty 0 4
 password ard
 login
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 10 pots
 destination-pattern 6666
 port 1/0/0
!
dial-peer voice 20 pots
 destination-pattern 6777
 port 1/0/1
!
dial-peer voice 300 voip
 destination-pattern 3...
 no vad   
 session target ipv4:10.6.6.78
!
dial-peer voice 60 pots
 destination-pattern 6111
 port 1/1/0
!
end

Call fallback is not configured on this router. Router2 is a dial peer for Router1, but is not handling calls directly from the PSTN. SAA is configured on Router2 to answer the probes from Router1.

Router(config)# show running-config

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
voice-card 4
!
ip subnet-zero
!
isdn voice-call-failure 0
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown 
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 10.3.22.80 255.255.0.0
 no ip directed-broadcast
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 load-interval 30
 no keepalive
 clockrate 256000
 frame-relay traffic-shaping
 frame-relay inverse-arp interval 15
!
interface Serial1/0.1 point-to-point
 ip address 10.6.6.78 255.255.0.0
 no ip directed-broadcast
 frame-relay interface-dlci 100
  class frs0
!
interface Ethernet1/1
 ip address 10.5.5.74 255.255.0.0
 no ip directed-broadcast
!
map-class frame-relay frs0
 frame-relay fragment 100
 frame-relay ip rtp priority 16384 16383 75
 no frame-relay adaptive-shaping
 frame-relay cir 100000
 frame-relay bc 1000
 frame-relay mincir 100000
 frame-relay fair-queue
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 10 pots
 destination-pattern 3111
 port 2/0/0
!
dial-peer voice 20 pots
 destination-pattern 3222
 port 2/0/1
!
dial-peer voice 100 voip
 destination-pattern 6...
 no vad
 session target ipv4:10.6.6.77
!
dial-peer voice 60 pots
 destination-pattern 3999
 port 3/0/0
!
dial-peer voice 70 pots
destination-pattern 3888
 port 3/0/1
!
saa responder
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring PSTN Fallback for VoIP over MLP Example

The following output sample configures PSTN fallback for VoIP over MLP for Router1 shown in Figure 107. The direction of the calls is from Router1, a Cisco 3660, to Router2, a Cisco 3640. MD5 authentication is configured. Also, SAA is configured on Router2 to answer the probes from Router1. When the number 6666 is called from Router1 and congestion is on the link between Router1 and Router2, the call is sent to port 3/0/1 and hence to Router2 over the PSTN.

Probes are sent every 20 seconds (default) with 15 packets in each probe, and are sent in the priority queue with the other voice packets after the ip rtp priority command is enabled. Also, the delay and loss threshold command is configured with a delay threshold of 150 milliseconds and a loss threshold of 5 percent, and the cache-aging timeout is 10,000 seconds. The link is configured for 128 kilobits per second (kbps), and 80 kbps is reserved for voice using the ip rtp priority command.

Figure 107 Network Example for VoIP over MLP

Router (config)# show running-config

Current configuration:
!
version 12.2
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname Router1
!
voice-card 4
!
ip subnet-zero
!
call fallback probe-timeout 20
call fallback threshold delay 150 loss 5
call fallback jitter-probe num-packets 15
call fallback jitter-probe priority-queue
call fallback cache-timeout 10000
call fallback active
!
interface Multilink1
 ip address 10.10.10.1 255.255.0.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 no keepalive
 fair-queue 64 256 0
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp priority 16384 16383 80
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 10.3.22.80 255.255.0.0
 no ip directed-broadcast
!
interface Serial1/0
 bandwidth 128
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no fair-queue
 clockrate 125000
 ppp authentication chap
 ppp multilink
 multilink-group 1
!
interface Ethernet1/1
 ip address 10.5.5.74 255.255.0.0
 no ip directed-broadcast
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet1/0
ip route 10.4.0.0 255.255.0.0 10.5.5.78
ip route 10.255.254.254 255.255.255.255 10.3.0.1
no ip http server
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 10 pots
 destination-pattern 3111
 port 2/0/0
!
dial-peer voice 20 pots
 destination-pattern 3222
 port 2/0/1
!
dial-peer voice 60 pots
 destination-pattern 3999
 port 3/0/0
!
dial-peer voice 70 pots
 destination-pattern 6666
 port 3/0/1
!
dial-peer voice 200 voip
 destination-pattern 6...
 session target ipv4:10.10.10.1
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
!
end

SAA is configured on Router2 to answer the probes from Router1:

Router (config)# show running-config

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
voice-card 4
!
ip subnet-zero
!
isdn voice-call-failure 0
!
interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown 
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 10.3.22.80 255.255.0.0
 no ip directed-broadcast
!
interface Serial1/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 load-interval 30
 no keepalive
 clockrate 256000
 frame-relay traffic-shaping
 frame-relay inverse-arp interval 15
!
interface Serial1/0.1 point-to-point
 ip address 10.6.6.78 255.255.0.0
 no ip directed-broadcast
 frame-relay interface-dlci 100   
  class frs0
!
interface Ethernet1/1
 ip address 10.5.5.74 255.255.0.0
 no ip directed-broadcast
!
map-class frame-relay frs0
 frame-relay fragment 100
 frame-relay ip rtp priority 16384 16383 75
 no frame-relay adaptive-shaping
 frame-relay cir 100000
 frame-relay bc 1000
 frame-relay mincir 100000
 frame-relay fair-queue
!
voice-port 2/0/0
!
voice-port 2/0/1
!
voice-port 2/1/0
!
voice-port 2/1/1
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 10 pots
 destination-pattern 3111
 port 2/0/0
!
dial-peer voice 20 pots
 destination-pattern 3222
 port 2/0/1
!
dial-peer voice 100 voip
 destination-pattern 6...
 no vad
 session target ipv4:10.6.6.77
!
dial-peer voice 60 pots
 destination-pattern 3999
 port 3/0/0
!
dial-peer voice 70 pots
destination-pattern 3888
 port 3/0/1
!
saa responder
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4

Local Voice Busyout Configuration Examples

The following example configures digital voice port 0:0.4 on a Cisco MC3810 series concentrator to go into the busyout state if serial interface 0:0 goes out of service:

Router(config)# voice-port 0:0.4

  Type of VoicePort is FXS
router(config-voiceport)# busyout monitor interface serial 0:0
1/2 is in busyout state

Router(config-voiceport)# end
Router# show voice busyout

!If following network interfaces are down, voice port will be put into busyout state
The following voice ports are in busyout state

1/1 is forced into busyout state
1/2 is in busyout state caused by Serial0

The following example configures digital voice port 2/1:7 on a Cisco 3600 series router to go into the busyout state if serial interface 0:0 goes out of service:

Router(config)# voice-port 2/1:7

  Type of VoicePort is FXS

Router(config-voiceport)# busyout monitor interface serial 0:0

1/2 is in busyout state

Router(config-voiceport)# end
Router# show voice busyout

!If following network interfaces are down, voice port will be put into busyout state
The following voice ports are in busyout state

2/1:7 is forced into busyout state
2/1:8 is in busyout state caused by Serial0

The following example configures the busyout seize action for analog voice port 0/2/1 on a Cisco 3600 series router to repeat:

Router(config)# voice-port 0/2/1

  Type of VoicePort is FXO

Router(config-voiceport)# busyout seize repeat
Router(config-voiceport)# end
Router# show voice busyout

!If following network interfaces are down, voice port will be put into busyout state
The following voice ports are in busyout state

0/2/1 is forced into busyout state
0/2/2 is in busyout state caused by Serial0

The following example forces DS0 timeslots 1 through 12 on controller T1 0 on a Cisco MC3810 multiservice concentrator into the busyout state:

Router(config)# controller t1 0
Router(config-controller)# ds0 busyout 1-12
Router(config-controller)# end

The following example configures busyout voice class 35, which initiates voice-port busyout whenever either serial port 0 or 1 is in service, and it applies voice class 35 to voice port 1/3:

Router(config)# voice class busyout 35
Router(config-voice-class)# busyout monitor serial 0 in-service
Router(config-voice-class)# busyout monitor serial 1 in-service
Router(config-voice-class)# exit
Router(config)# voice-port 1/3
Router(config-voiceport)# voice class 35

The following example configures busyout voice class 40, which initiates voice-port busyout whenever an SAA probe sent to both of the two specified remote interfaces results in a link with an ICPIF delay/loss average of more than 15, and it applies voice class 40 to voice port 1/4:

Router(config)# voice class busyout 40
Router(config-voice-class)# busyout monitor probe 209.165.202.128 icpif 15
Router(config-voice-class)# busyout monitor probe 209.165.202.129 icpif 15
Router(config-voice-class)# exit
Router(config)# voice-port 1/4
Router(config-voiceport)# voice class 40

The following example configures analog voice port 1/1 on a Cisco MC3810 to use an SAA probe with a G.711 alaw profile to probe the link to the remote interface with IP address 209.165.202.128, and to busyout the voice port if the link has a packet loss of more than 50 percent and a packet delay of more than 25 milliseconds:

Router(config)# voice-port 1/1
Router(config-voiceport)# busyout monitor probe 209.165.202.128 codec g711a loss 50 
delay 25

The following example configures voice port 1/0/1 on a Cisco 3600 series router to use an SAA probe with the default (G.711 ulaw) profile to probe the link to the remote interface with IP address 209.165.202.128, and to busyout the voice port if the link has packet loss and delay that exceed the threshold values configured by the call fallback active command:

Router(config)# voice-port 1/0/1
Router(config-voiceport)# busyout monitor probe 209.165.202.128

The following example configures busyout voice class 60, which configures multiple parameters for voice-port busyout, and it applies voice class 60 to voice ports 1/0/0 and 1/0/1 on a Cisco 3600 series router. The voice ports will busy out under any one the following conditions:

Serial ports 0/0 and 0/1 are both OOS

Serial port 1/0 or 1/0 is in service

The link loss exceeds 50 percent or the link delay exceeds 1 second on the links to both remote interfaces (IP addresses 209.165.202.128 and 209.165.202.129)

Router(config)# voice class busyout 60
Router(config-voice-class)# busyout monitor serial 0/0
Router(config-voice-class)# busyout monitor serial 0/1
Router(config-voice-class)# busyout monitor serial 1/0 in-service
Router(config-voice-class)# busyout monitor serial 1/1 in-service
Router(config-voice-class)# busyout monitor probe 209.165.202.128 loss 50 delay 1000
Router(config-voice-class)# busyout monitor probe 209.165.202.129 loss 50 delay 1000
Router(config-voice-class)# exit
Router(config)# voice-port 1/0/0
Router(config-voiceport)# voice class 60
Router(config-voiceport)# exit
Router(config)# voice-port 1/0/1
Router(config-voiceport)# voice class 60
Router(config-voiceport)# exit

The following example configures voice port 1/1 into forced busyout state:

Router(config)# voice-port 1/1

Type of VoicePort is FXS

Router(config-voiceport)# busyout forced 
00:09:46: port 0 is forced into busyout state 

Router(config-voiceport)# end
Router# show voice busyout

!If following network interfaces are down, voice port will be put into busyout state.
The following voice ports are in busyout state
1/1 is forced into busyout state

The following example configures voice port 1/2 to busyout monitor mode, monitoring serial 0:

Router(config)# voice-port 1/2
Type of VoicePort is FXS

Router(config-voiceport)# busyout-monitor serial 0
1/2 is in busyout state

Router(config-voiceport)# end
Router# show voice busyout

!If following network interfaces are down, voice port will be put into busyout state.
The following voice ports are in busyout state
1/1 is forced into busyout state
1/2 is in busyout state caused by Serial0

The following example configures voice port 1/3 to the busyout seize repeat state:

Router(config)# voice-port 1/3
Type of VoicePort is FXO

router(config-voiceport)# busyout-seize repeat
Router(config-voiceport)# end
Router# show voice busyout

!If following network interfaces are down, voice port will be put into busyout state.
The following voice ports are in busyout state
1/1 is forced into busyout state
1/2 is in busyout state caused by Serial0

Alarm Trigger for Busyout of Voice Ports Configuration Example

This example creates three permanent trunks on controller T1 0 and configures T1 0 to send a blue (AIS) alarm if all three permanent trunks are OOS. These steps create the voice ports and configure the alarm trigger:

Router(config)# controller t1 0
Router(config-controller)# mode cas
Router(config-controller)# ds0-group 0 timeslots 1-10 type fxs-ground-start
Router(config-controller)# ds0-group 1 timeslots 11 type fxs-ground-start
Router(config-controller)# ds0-group 2 timeslots 12-23 type fxs-ground-start
Router(config-controller)# alarm-trigger blue 0-2
Router(config-controller)# exit
Router(config)#

These steps create a voice class to define the trunk conditioning parameters for permanent trunks (in which the default values are not used):

Router(config)# voice class permanent 8 
Router(config-class)# signal keepalive 10 
Router(config-class)# signal timing oos timeout 60 
Router(config-class)# signal timing idle suppress-voice 5 
Router(config-class)# signal timing oos restart 120 
Router(config-class)# exit 
Router(config)#

These steps create a VoIP dial peer to define the network connectivity and trunk conditioning parameters for permanent trunks:

Router(config)# dial-peer voice 100 voip 
Router(config-dial-peer)# session target ipv4:172.20.10.10
Router(config-dial-peer)# destination-pattern 10..
Router(config-dial-peer)# voice-class permanent 8
Router(config-dial-peer)# exit
Router(config)#

These steps assign each voice port to a permanent trunk and associate each trunk with a network dial peer:

Router(config)# voice-port 0:0
Router(config-voiceport)# connection trunk 1001
Router(config-voiceport)# exit
Router(config)# voice-port 0:1
Router(config-voiceport)# connection trunk 1002
Router(config-voiceport)# exit
Router(config)# voice-port 0:2
Router(config-voiceport)# connection trunk 1003
Router(config-voiceport)# exit
Router(config)# 

This example configures voice port 0:0 for busyout if serial port 0.1, 0.2, and Ethernet port 0 all go out of service, or serial port 1 comes into service:

Router(config)# voice-port 0:0
Router(config-voiceport)# busyout monitor serial 0.1
Router(config-voiceport)# busyout monitor serial 0.2
Router(config-voiceport)# busyout monitor ethernet 0
Router(config-voiceport)# busyout monitor serial 1 in-service
Router(config-voiceport)# exit

This example configures voice port 0:1 for busyout if the connections to both of two remote IP addresses are OOS:

Router(config)# voice-port 0:1
Router(config-voiceport)# busyout monitor probe 209.165.202.128 codec g711a icpif 15
Router(config-voiceport)# busyout monitor probe 209.165.202.129 codec g711a icpif 15
Router(config-voiceport)# exit

This example configures voice port 0:2 for busyout under any one of the following conditions:

Serial port 0.1 and 0.2 are both OOS

Serial port 1 comes into service

Connections to both of two remote IP addresses are OOS

Router(config)# voice-port 0:2
Router(config-voiceport)# busyout monitor serial 0.1
Router(config-voiceport)# busyout monitor serial 0.2
Router(config-voiceport)# busyout monitor serial 1 in-service
Router(config-voiceport)# busyout monitor probe 209.165.202.128 codec g711a icpif 15
Router(config-voiceport)# busyout monitor probe 209.165.202.129 codec g711a icpif 15
Router(config-voiceport)# exit
Router(config)# exit