Cisco IOS Voice, Video, and Fax Configuration�Guide, Release�12.2
Configuring PBX Interconnectivity Features
Downloads: This chapterpdf (PDF - 408.0KB) The complete bookPDF (PDF - 9.14MB) | Feedback

Configuring PBX Interconnectivity Features

Table Of Contents

Configuring PBX Interconnectivity Features

Configuring QSIG PRI Signaling Support

Benefits of QSIG Voice Signaling

Configuring Voice over IP QSIG Network Transparency on the Cisco AS5300

QSIG Prerequisite Tasks

QSIG Configuration Task List

Configuring VoIP QSIG

Configuring Fusion Call Control Signaling (NEC Fusion) on the Cisco AS5300

Verifying VoIP QSIG Software on the Cisco AS5300

Configuring QSIG PRI Signaling Support on the Cisco MC3810

QSIG Prerequisite Tasks

Configuring T-CCS

T-CCS Overview

T-CCS Limitations

Related Documents for T-CCS

T-CCS Prerequisite Tasks

T-CCS Configuration Task List

Configuring T-CCS Cross-Connect

Configuring T-CCS Frame Forwarding

Configuring T-CCS for a Clear-Channel Codec

Verifying the T-CCS Configuration

Troubleshooting Tips for T-CCS

Monitoring and Maintaining T-CCS and Frame Forwarding

PBX Interconnectivity Configuration Examples

QSIG Configuration Examples

QSIG for VoIP Configuration Example

QSIG PRI Signaling on the Cisco MC3810 Configuration Example

T-CCS Configuration Examples

T-CCS over Frame Relay Configuration Example

T-CCS over IP Configuration Example


Configuring PBX Interconnectivity Features


This chapter describes how to configure support for the PBX signaling formats QSIG and Transparent Common Channel Signaling (T-CCS). Configuring support for these signaling protocols on your router enables the router to interoperate with PBXs that are running them.

This chapter includes the following sections:

Configuring QSIG PRI Signaling Support

Configuring T-CCS

PBX Interconnectivity Configuration Examples

For a complete description of the commands used in this chapter, refer to the Cisco IOS Voice Command Reference, Release 12.3. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

For information about interconnecting specific PBX equipment with Cisco products, see the PBX Interoperability Portal, located here:

http://www.cisco.com/warp/public/779/largeent/avvid/inter_operability/

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Configuring QSIG PRI Signaling Support

This section describes QSIG PRI voice signaling support for Cisco AS5300 universal access servers and Cisco MC3810 multiservice concentrators.

Benefits of QSIG Voice Signaling

On both the Cisco AS5300 universal access server and the Cisco MC3810 multiservice concentrator, QSIG voice signaling provides the following benefits:

Enabling Cisco devices to connect with digital PBXs that use the QSIG form of common channel signaling (CCS).

Access to multiple remote PBXs with a single connection to a Cisco device.

Transparent support for supplementary PBX services so that proprietary PBX features are not lost when connecting PBXs to Cisco AS5300 and Cisco MC3810 networks.

QSIG support based on widely used ISDN Q.931 standards. Cisco QSIG implementation follows the following European Telecommunications Standards Institute (ETSI) implementation standards:

ECMA-142: Private Integrated Services Network (PISN) - Circuit Mode 64kbit/s Bearer Services - Service Description, Functional Capabilities and Information Flows (BCSD)

ECMA-143: PISN - Circuit Mode Bearer Services - Inter-Exchange Signalling Procedures and Protocol (QSIG-BC) (This specification covers QSIG basic call services.)

ECMA-165: PISN - Generic Functional Protocol for the Support of Supplementary Services - Inter-Exchange Signalling Procedures and Protocol (QSIG-GF)

Compatibility with H.323 for IP call setup and transport of QSIG messaging.

Support for calls that do not require a bearer channel for voice transport.

Support for bandwidth-on-demand, utilizing network resources only when a connection is desired.

Configuration tasks for QSIG PRI signaling support are described in the following sections:

Configuring Voice over IP QSIG Network Transparency on the Cisco AS5300

Configuring QSIG PRI Signaling Support on the Cisco MC3810

Although the procedures for configuring QSIG signaling support on the Cisco AS5300 universal access server and on the Cisco MC3810 multiservice concentrator are very similar, implementation differences are described in the respective sections.

Configuring Voice over IP QSIG Network Transparency on the Cisco AS5300

Integration of QSIG support with VoIP enables Cisco voice switching services to connect PBXs, key systems, and CO switches that communicate by using the QSIG protocol.

The QSIG protocol is a variant of ISDN D-channel voice signaling. It is based on the ISDN Q.921 and Q.931 standards and is becoming a worldwide standard for PBX interconnection. Using QSIG signaling, Cisco devices can route incoming voice calls from a private integrated services network exchange (PINX) device across a WAN to a peer Cisco device, which can then transport the signaling and voice packets to a second PINX device.

QSIG allows the user to place QSIG calls into and receive QSIG calls from Cisco VoIP networks. The Cisco packet network appears to PBXs as a large, distributed transit PBX that can establish calls to any destination served by a Cisco voice node. The switched voice connections are established and torn down in response to QSIG control messages that come over an ISDN PRI D channel. The QSIG message is passed transparently across the IP network and the message appears to the attached PINX devices as a transit network. The PINX devices are responsible for processing and provisioning the attached services.

Figure 112 shows an example of a QSIG signaling configuration. In this example, the Cisco AS5300 acts either as a master to a slave PBX or as a slave to a master PBX.

Figure 112 Cisco AS5300 QSIG Signaling Configuration

The following restrictions and limitations apply to the Cisco AS5300 QSIG implementation:

QSIG functionality on the AS5300 requires Cisco IOS Release 12.0(7)T or later and VCWare version 4.04.

QSIG data calls are not supported. All calls with bearer capability indicating a nonvoice type (such as video telephony) are rejected.

In order to ensure end-to-end QSIG feature transparency, the incoming POTS dial peer must have DID configured so as to prevent generation of a secondary dial tone.

QSIG Prerequisite Tasks

Perform the following configuration tasks before you configure QSIG for VoIP:

Configure the ports used on the Cisco AS5300 as voice ports. For information on how to configure ports to be used as voice ports, see the section "Configuring Voice Ports" in the chapter "Configuring Voice over IP."

Install VCWare version 4.04. For information on how to upgrade or install VCWare, see the section "Managing Cisco AS5300 VFCs" in the chapter "Configuring Voice over IP."

Configure VoIP. For information on how to configure VoIP, see the chapter "Configuring Voice over IP."

QSIG Configuration Task List

To configure QSIG for Voice over IP, complete the tasks shown in the following sections:

Configuring VoIP QSIG (required)

Configuring Fusion Call Control Signaling (NEC Fusion) on the Cisco AS5300 (optional)

Configuring VoIP QSIG

To configure QSIG signaling support on the Cisco AS5300, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# isdn switch-type primary-qsig

(Optional) Globally configures the ISDN switch type to support QSIG signaling.

Note Depending on your configuration, you can configure the ISDN switch type either by using this command in global configuration mode or by using the same command in interface configuration mode. (See Step 6.) If you configure the ISDN switch type for QSIG support using the isdn switch-type command in global configuration mode, you need not use the isdn switch-type command in interface configuration mode.

If the PBX in your configuration is an NEC PBX, and you are using Fusion Call Control Signaling (FCCS), see the section "Configuring Fusion Call Control Signaling (NEC Fusion) on the Cisco AS5300."

Step 2 

Router(config)# controller {T1 | E1} controller number

Enters controller configuration mode.

Step 3 

Router(config-controller)# pri-group [timeslot range]

Configures the PRI group for either T1 or E1 to carry voice traffic. For T1, available time slots are from 1 to 23, and for E1, available time slots are from 1 to 31.

You can configure the PRI group to include all available time slots, or you can configure a select group of time slots for the PRI group. For example, if only time slots 1 to 10 are in the PRI group, enter the pri-group timeslot 1-10 command. If the PRI group includes all channels available for T1 (channels 1 to 23), enter the pri-group timeslot 1-23 command. If the PRI group includes all channels available for E1 (channels 1 to 31), enter the pri-group timeslot 1-31 command.

Step 4 

Router(config-controller)# exit

Exits controller configuration mode.

Step 5 

Router(config)# interface serial 1:channelnumber

Enters interface configuration mode for the ISDN PRI interface.

The argument is as follows:

channelnumber—Channel number. For T1, use 23. For E1, use 15.

Step 6 

Router(config-if)# isdn switch-type primary-qsig

(Optional) For the selected interface, configures the ISDN switch type to support QSIG signaling. Use this command if you did not configure the ISDN switch type for QSIG support globally in Step 1.

The same conditions that apply to this command in global configuration mode also apply to this command in interface configuration mode.

Note For the selected interface, this command, entered in interface configuration mode, overrides any setting made with the isdn switch-type command entered in global configuration mode.

Step 7 

Router(config-if)# isdn protocol-emulate {user | network}

Configures the ISDN interface to serve as either the primary QSIG slave or the primary QSIG master.

The keywords are as follows:

user—Slave

network—Master

If the PINX is the primary QSIG master, configure the Cisco AS5300 to serve as the primary QSIG slave. If the PINX is the primary QSIG slave, configure the Cisco AS5300 to serve as the primary QSIG master.

Step 8 

Router(config-if)# isdn overlap-receiving [T302 value]

(Optional) Activates overlap signaling to send to the destination PBX.

The keyword and argument are as follows:

T302 value—Value of timer T302, in ms. Range: 500 to 20000.

Step 9 

Router(config-if)# isdn incoming-voice modem

Routes incoming voice calls to the modem and treats them as analog data.

Step 10 

Router(config-if)# isdn network-failure-cause [value]

(Optional) Specifies the cause code to pass to the PBX when a call cannot be placed or completed because of internal network failures.

The value argument is a cause code from 1 to 127. All cause codes except Normal Call Clearing (16), User Busy (17), No User Responding (18), and No Answer from User (19) is changed to the specified cause code.

Step 11 

Router(config-if)# isdn bchan-number-order {ascending | descending}

(Optional) Configures the ISDN PRI interface to make the outgoing call selection in ascending or descending order.

The keywords are as follows:

ascending—Ascending order.

descending—Descending order. This is the default.

For descending order, the first call from the Cisco AS5300 uses channel 23 (T1) or channel 31 (E1). The second call then uses channel 22 (T1) or channel 30 (E1), and so on, in descending order.

For ascending order, if the PRI group starts with 1, the first call uses channel 1, the second call uses channel 2, and so on, in ascending order. If the PRI group starts with a different time slot, the ascending order starts with the lowest time slot.

As shown in the procedure, you have a choice of configuring the isdn-switch-type command to support QSIG at either the global configuration level or the interface configuration level. For example, if you have a QSIG connection on one line and on the PRI port, you can configure the ISDN switch type in one of the following combinations:

Set the global isdn-switch-type command to support QSIG and set the interface isdn-switch-type command for interface serial 0:23 to a PRI setting such as 5ess.

Set the global isdn-switch-type command to support PRI 5ess and set the interface isdn-switch-type command for interface serial 1:23 to support QSIG.

Configure the global isdn-switch-type command to another setting (such as switch type VN3), set the interface isdn-switch-type command for interface serial 0:23 to a PRI setting, and set the interface isdn-switch-type command for interface serial 1:23 to support QSIG.

Configuring Fusion Call Control Signaling (NEC Fusion) on the Cisco AS5300

If you have an NEC PBX in your network and you are running FCCS, you need to configure your Cisco AS5300 universal access servers appropriately. FCCS, also known as NEC Fusion, allows individual nodes anywhere within a network to operate as if they were part of a single integrated PBX system. The database storage, share, and access routines of NEC Fusion allow real-time access from any node to any other, enabling individual nodes to learn about the entire network configuration. This capability allows network-wide feature, functional, operational, and administration transparency.

Figure 113 shows an example of a Cisco AS5300 QSIG signaling configuration using an NEC PBX.

Figure 113 QSIG Signaling Configuration with NEC PBX

To configure NEC Fusion signaling support on the Cisco AS5300, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller T1 controller number

Enters controller configuration mode.

Note NEC Fusion does not support fractional T1/E1; all 24 channels must be available. If they are not all available, the configuration request fails.

Step 2 

Router(config-controller)# pri-group nec-fusion {pbx-ip-address/pbx-ip-host-name} pbx-port number

Configures the controller to communicate with an NEC PBX using NEC Fusion.

The number argument is the PBX port number. Range: 49152 to 65535. Default: 55000. If this value is already in use, the next greater value is used.

Verifying VoIP QSIG Software on the Cisco AS5300

After you have completed the configuration for the Cisco AS5300, verify that you configured QSIG properly. Enter the show isdn status command to view the ISDN layer information. The following output shows that you have correctly designated the global ISDN switch type to be primary-QSIG:

Router# show isdn status

Global ISDN Switchtype = primary-qsig
ISDN Serial1:23 interface
        dsl 0, interface ISDN Switchtype = primary-qsig
         **** Slave side configuration ****
    Layer 1 Status:
        DEACTIVATED
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Activated dsl 0 CCBs = 0
    The Free Channel Mask: 0x7FFFFF

Configuring QSIG PRI Signaling Support on the Cisco MC3810

The QSIG protocol provides signaling for PINX devices. It is based on the ISDN Q.931 standard. Using QSIG PRI signaling, the Cisco MC3810 can route incoming voice calls from a PINX device across a WAN to a peer Cisco MC3810, which can then transport the signaling and voice packets to a second PINX device.

The following restrictions and limitations apply to the Cisco MC3810 QSIG PRI implementation:

QSIG data calls are not supported. All calls with bearer capability indicating a nonvoice type (such as for video telephony) are rejected.

QSIG is supported only on T1/E1 controller 1. Each Cisco MC3810 supports only one T1/E1 interface with direct connectivity to a PINX device.

The Cisco MC3810 supports a maximum of 24 bearer channels.

When QSIG is configured, serial interface 1 cannot support speeds higher than 192 kbps. This restriction assumes that the MFT is installed in slot 3 on the Cisco MC3810. If the MFT is not installed, then serial interface 1 does not operate at all, but QSIG is supported on other interfaces.

Figure 114 shows an example of a QSIG signaling configuration. In the example, the Cisco MC3810 acts either as a master to a slave PBX or as a slave to a master PBX.

Figure 114 Cisco MC3810 QSIG Signaling Configuration

QSIG Prerequisite Tasks

The following configuration tasks should be completed before you configure QSIG on the Cisco MC3810:

Configure the ports used on the Cisco MC3810 as voice ports. For information on how to configure ports to be used as voice ports, see the section "Configuring Voice Ports" in the chapter "Configuring Voice over ATM."

Configure Voice over Frame Relay or Voice over ATM. For information on how to configure Voice over Frame Relay, see the "Configuring Voice over Frame Relay" chapter. For information on how to configure Voice over ATM, see the "Configuring Voice over ATM" chapter.

To configure QSIG PRI signaling support on the Cisco MC3810, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# isdn switch-type primary-qsig

(Optional) Globally configures the ISDN switch type to support QSIG signaling.

Note Depending on your configuration, you can configure the ISDN switch type either by using this command in global configuration mode, or by using the same command in interface configuration mode. (See Step 3.) If you configure the ISDN switch type for QSIG support using the isdn switch-type command in global configuration mode, you need not use the isdn switch-type command in interface configuration mode.

Step 2 

Router(config)# interface serial 1:channelnumber

Enters interface configuration mode for the ISDN PRI interface.

The argument is as follows:

channelnumber—Channel number. For T1, use 23. For E1, use 15.

Step 3 

Router(config-if)# isdn switch-type primary-qsig

(Optional) For the selected interface, configures the ISDN switch type to support QSIG signaling. Use this command if you did not configure the ISDN switch type for QSIG support globally in Step 1.

Note For the selected interface, this command, entered in interface configuration mode, overrides any setting made with the isdn switch-type command entered in global configuration mode.

Step 4 

Router(config-if)# isdn overlap-receiving [T302 value]

Activates overlap signaling to send to the destination PBX.

The keyword and argument are as follows:

T302 value—Value of timer T302, in ms. Range: 500 to 20000.

Step 5 

Router(config-if)# isdn network-failure-cause [value]

Specifies the cause code to pass to the PBX when a call cannot be placed or completed because of internal network failures.

The argument is as follows:

value—Cause code. Range: 1 to 127.

Step 6 

Router(config-if)# isdn bchan-number-order {ascending | descending}

(Optional) Configures the ISDN PRI interface to make the outgoing call selection in ascending or descending order.

The keywords are as follows:

ascending—Ascending order.

descending—Descending order. This is the default.

For descending order, the first call from the Cisco MC3810 uses channel 23 (T1) or channel 31 (E1). The second call then uses channel 22 (T1) or channel 30 (E1), and so on, in descending order.

For ascending order, if the PRI group starts with 1, the first call uses channel 1, the second call uses channel 2, and so on, in ascending order. If the PRI group starts with a different time slot, the ascending order starts with the lowest time slot.

Step 7 

Router(config-if)# exit

Exits interface configuration mode.

Step 8 

Router(config)# controller {T1 | E1} 1

Enters controller configuration mode. QSIG is supported only on controller 1.

Step 9 

Router(config-controller)# pri-group timeslot [1-31]

Configures the PRI group for either T1 or E1 to carry voice traffic. Available T1 time slots are 1 to 23; available E1 time slots are 1 to 31.

You can configure the PRI group to include all the time slots available, or you can configure a select group of time slots for the PRI group. For example, if only time slots 1-10 are in the PRI group, enter the pri-group timeslot 1-10 command. If the PRI group includes all channels available for T1, enter the pri-group timeslot 1-24 command. If the PRI group includes all channels available for E1, enter the pri-group timeslot 1-31 command.

Note When a PRI group is configured, T1 time slot 24 or E1 time slot 16 is automatically assigned to handle D-channel signaling.

As shown in the procedure, you have a choice of configuring the isdn-switch-type command to support QSIG at either the global configuration level or at the interface configuration level. For example, if you have a QSIG connection on one line and on the BRI port, you can configure the ISDN switch type in one of the following combinations:

Set the global isdn-switch-type command to support QSIG, and set the interface isdn-switch-type command for interface bri 0 to a BRI setting such as 5ess.

Set the global isdn-switch-type command to support BRI 5ess, and set the interface isdn-switch-type command for interface serial 1:23 to support QSIG.

Configure the global isdn-switch-type command to another setting (such as switch type VN3), and then set the interface isdn-switch-type command for interface bri 0 to a BRI setting, and set the interface isdn-switch-type command for interface serial 1:23 to support QSIG.


Note The codec command must be configured before any calls can be placed over the connection to the PINX. The default codec type is G.729a.


When voice dial peers are configured for use with QSIG PRI, voice port 1/1 is used for all bearer channels.

Configuring T-CCS

This section describes transparent common channel signaling (T-CCS) for Cisco 2600 series, 3600 series, 7200 series, and 7500 series routers and Cisco MC3810 multiservice concentrators and includes the following sections:

T-CCS Overview

T-CCS Prerequisite Tasks

T-CCS Configuration Task List

Verifying the T-CCS Configuration

Troubleshooting Tips for T-CCS

Monitoring and Maintaining T-CCS and Frame Forwarding

T-CCS Overview

T-CCS provides a way to interconnect PBXs and key telephone systems (KTSs) when the PINX does not support QSIG or when the PINX uses a proprietary solution. The following Cisco hardware provides support for T-CCS:

Digital T1/E1 packet voice trunk network modules on Cisco 2600 series and Cisco 3600 series routers

Two-port T1/E1 digital voice port adapters for Cisco 7200 series and Cisco 7500 series routers

Digital voice module (DVM) on Cisco MC3810 multiservice concentrators

T-CCS allows the connection of two PBXs with digital interfaces that use a proprietary or unsupported CCS protocol without the need for interpretation of CCS signaling for call processing. T1/E1 traffic is transported transparently through the data network, and the T-CCS feature preserves proprietary signaling. From the PBX standpoint, this is accomplished through a point-to-point connection. Calls from the PBXs are not routed, but follow a preconfigured route to the destination.

CCS differs from a related technology, channel-associated signaling (CAS), in that it uses a separate transmission channel to relay signaling and address information in embedded packets conforming to standards recommendations. Examples of CCS signaling include Q.931 on ISDN Primary Rate Interface (PRI) and QSIG protocol signaling for PINX devices.

CAS, which is older than CCS, has evolved over many years and is supported on many Cisco routers. CAS signals and the dual tone multifrequency (DTMF) (or dial pulse) digits that indicate the telephone number of the called party are sent within the actual voice band transmission channel. Digital signal processors (DSPs) in Cisco voice nodes monitor these channels, decode the status and address signaling, and report status and state changes for the telephone calls.

If you are configuring your Cisco platform to route signaling traffic for Voice over Frame Relay (VoFR) or Voice over ATM (VoATM), you can configure T-CCS using T-CCS frame forwarding.

If you are configuring your Cisco platform to route signaling traffic for VoIP, T-CCS is configured by routing traffic over a clear channel codec.

The configuration procedures are described in the section "T-CCS Configuration Task List."

The T-CCS feature provides the following benefits:

Efficient and cost-effective services on permanent (virtual) circuits or leased lines.

PBX feature transparency across a WAN, permitting PBX networks to provide advanced features, such as calling name and number display, camp-on/callback, network call forwarding, centralized attendant, and centralized message waiting.

Compressed Voice over Frame Relay, ATM, and IP support for virtually any CCS-based PBX.

Dynamic allocation of bandwidth to voice calls using voice activity detection (VAD).

T-CCS Limitations

The T-CCS feature has the following restrictions:

The digital T1/E1 packet voice trunk network module can have one or two slots for voice/WAN interface cards (VWICs); VWICs supply one or two ports. Only the dual-mode (voice/WAN) multiflex trunk cards are supported in the digital E1 packet voice trunk network module, and not older VICs.

Drop-and-insert capability is supported only between two ports on the same multiflex card.

Digital E1 voice is not manageable through Simple Network Management Protocol (SNMP) using existing versions of Cisco Voice Manager.

On the Cisco MC3810, when T-CCS frame forwarding is configured, the speed (clock rate) of serial interface 1 of the Cisco MC3810 is limited to a maximum of 192 kbps. This restriction assumes that the multiflex trunk module (MFT) is installed in slot 3 on the Cisco MC3810. If the MFT is not installed, then serial interface 1 does not operate, but T-CCS frame forwarding is supported on other interfaces.

The T-CCS feature supports PVCs, not SVCs.

Cross-connections imply fractional trunks.

For Frame Forwarding, preconfigured interfaces can be serial 0, serial 1, or T1/E1 0.

Related Documents for T-CCS

The following documents provide additional information to help implement T-CCS:

Cisco IOS Wide-Area Networking Configuration Guide

Cisco IOS Wide-Area Networking Command Reference

Cisco IOS Voice, Video, and Fax Command Reference

Cisco IOS Debug Command Reference

Configuring Cisco MC3810 Series Concentrators to Use High-Performance Compression Modules

Voice Port Enhancements in Cisco 2600 and Cisco 3600 Series Routers and MC3810 Series Concentrators

Voice over Frame Relay Using FRF.11 and FRF.12 Configuration Updates

For hardware information, including information about the high-performance compression module (HCM), see the Cisco MC3810 Multiservice Concentrator Hardware Installation Guide.

T-CCS Prerequisite Tasks

The following configuration tasks should be completed before you configure a router for T-CCS:

Obtain T1 or E1 service from your service provider.

Establish a working network.

Complete your company's dial plan.

Establish a working telephony network based on your company's dial plan. For information about helpful documents, see the section "Related Documents for T-CCS."

Install required multiflex trunk modules and voice components:

Digital T1/E1 packet voice trunk network modules on Cisco 2600 series and Cisco 3600 series routers

Two-port T1/E1 digital voice port adapters for Cisco 7200 series and Cisco 7500 series routers

DVM on Cisco MC3810 concentrators to support digital cross-connect voice (channel bank functionality)

High-performance compression modules (HCM) to support voice compression. See the section "Related Documents for T-CCS."

Configure voice card and controller settings.

Configure serial and LAN interfaces.

Configure voice ports.

Configure voice dial peers.

T-CCS Configuration Task List

To configure a router for T-CCS, complete the tasks shown in the following sections:

Configuring T-CCS Cross-Connect

Configuring T-CCS Frame Forwarding

Configuring T-CCS for a Clear-Channel Codec


Note Although not always explicitly shown in these procedures, T-CCS also requires you to configure voice ports and dial peers.


Configuring T-CCS Cross-Connect

This section is divided into the following procedures for T-CCS cross-connect:

Configuring T1 and E1 TDM Groups

Configuring T1 and E1 Trunk Bearer Channels

Figure 115 shows an example of T-CCS cross-connect. In this example, the CCS channel from the PBX is cross-connected on the Cisco MC3810 to a time slot on the T1/E1 controller. The channel is then passed through the WAN as a leased line to the second Cisco MC3810, where it is cross-connected to the DVM signaling time slot (time slot 24 for T1, or time slot 16 for E1). The channel is then passed to the second PBX. The CCS signal byte stream is passed through transparently by the Cisco MC3810.

Figure 115 T-CCS Cross-Connect Configuration

Configuring T1 and E1 TDM Groups

When you configure T-CCS cross-connect for E1 or T1, you set up time slot groups, and then configure cross-connect from the first T1/E1 controller to the second T1/E1 controller. The mode ccs cross-connect command allows the cross-connect. This command enables all the channels to perform similarly to normal CAS mode, except that the signaling bit is no longer processed by the router.

To configure T-CCS cross-connect, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller {T1 | E1} 0

Enters controller configuration mode for controller E1 or T1 0.

Step 2 

Router(config-controller)# tdm-group tdm-group-no timeslots timeslot-list

Configures a TDM channel group.

The arguments are as follows:

tdm-group-no—TDM channel group number. Valid values for T1: 0 to 23; valid values for E1: 0 to 30.

timeslot-list—List of time slots. T1 range: 1 to 24. E1 range: 1 to 15 and 17 to 31. You can enter ranges or individual time-slot numbers.

Note Do not specify the type keyword in this command.

Step 3 

Router(config-controller)# exit

Exits controller configuration mode for this controller.

Step 4 

Router(config)# controller {T1 | E1} 1

Enters controller configuration mode for controller E1 or T1 1.

Step 5 

Router(config-controller)# mode ccs cross-connect

Configures the controller to support CCS cross-connect and trigger the signaling channel.

Step 6 

Router(config-controller)# tdm-group tdm-group-no timeslots timeslot-list

(T1 only) Configures a second TDM channel group.

The arguments are as follows:

tdm-group-no—TDM channel group number. Valid values for T1: 0 to 23; valid values for E1: 0 to 30.

timeslot-list—List of time slots. T1 range: 1 to 24. E1 range: 1 to 15 and 17 to 31. You can enter ranges or individual time-slot numbers.

Note Do not specify the type keyword in this command.

Step 7 

Router(config-controller)# ds0-group group-no timeslots timeslot-list type ext-sig

(E1 only) Configures the specified channel group to support CCS mode.

The keywords and arguments are as follows:

dso-group group-no—TDM channel group number. Range: 0 to 30.

timeslots timeslot-list—List of time slots in the DS0 group. Range: 1 to 31. You can enter ranges or individual time slot numbers.

type—Signaling method.

ext-sig—FRF.11 support. This keyword is available only when the mode ccs cross-connect command is enabled.

Note The ds0-group command replaced the voice-group command that was supported in earlier releases. The ext-sig keyword replaced the ext-sig-master and ext-sig-slave keywords that were supported with the voice-group command.

Step 8 

Router(config-controller)# exit

Exits controller configuration mode.

Step 9 

Router(config)# cross-connect id-controller-1 tdm-group-no-1 controller-2 tdm-group-no-2

Configures cross-connect pass-through between the two controllers. Depending on whether you are using T1 or E1, connect the two TDM controller groups (T1) or connect the TDM group controller to the DS0 group controller (E1).

Configuring T1 and E1 Trunk Bearer Channels


Tip After you configure a T-CCS connection by entering the connection trunk command, no change to the configuration takes place until the connection is shut down with a shutdown command and then restarted with a no shutdown command. For example, the phone number supplied in the connection trunk command can be changed while the connection is in the no shutdown state, but the change does not cause the current connection to be closed and a new connection to be opened to the new phone number. This does not take effect until the next no shutdown command following a shutdown command.



Note T-CCS cross-connect is not supported on analog PVC connections.


To use T-CCS cross-connect for bearer channels of the E1 or T1 trunk, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller {T1 | E1} number

Enters controller configuration mode for the controller.

Step 2 

Router(config-controller)# mode ccs cross-connect

Configures the controller to support CCS cross-connect. This command automatically creates serial interface 1:15 (E1) or 1:23 (T1).

Step 3 

Router(config-controller)# ds0-group group-no timeslots timeslot-list type ext-sig

Configures the specified channel group to support CCS mode.

The keywords and arguments are as follows:

group-no—TDM channel group number. Valid values for T1: 0 to 23; valid values for E1: 0 to 30.

timeslots timeslot-list—List of time slots. T1 range: 1 to 24. E1 range: 1 to 31. You can enter ranges or individual time-slot numbers.

type—Signaling method.

ext-sig—FRF.11 support. This keyword is available only when the mode ccs cross-connect command is enabled.

Note The ds0-group command replaced the voice-group command that was supported in earlier releases. The ext-sig keyword replaced the ext-sig-master and ext-sig-slave keywords that were supported with the voice-group command.

Step 4 

Router(config-controller)# exit

Exits controller configuration mode for this controller.

Step 5 

Router(config)# voice-port slot/port

Enters voice-port configuration mode.

The arguments are as follows:

slot—Slot number. Valid value for digital voice ports is 1 for this configuration.

port—Port number. T1 range: 1 to 24. E1 range: 1 to 15 or 17 to 31.

Note The slot:port format is also accepted.

Step 6 

Router(config-voiceport)# connection trunk string

Configures the voice-port connection.

The string argument is the number of the voice channel that was configured as the ext-sig type for the ds0-group command.

Configuring T-CCS Frame Forwarding

Cisco routers provide support for T-CCS frame forwarding, which allows a router to be connected to a Private Telco Network Exchange (PTNX) without having to interpret CCS signaling information for call processing. T-CCS frame forwarding forwards frames over a preconfigured interface running Frame Relay or ATM encapsulation.

With T-CCS frame forwarding, the connection between PTNXs over the network must be point-to-point and preconfigured. With the T-CCS frame forwarding implementation, calls from the PTNXs are not routed, but follow a preconfigured route to the destination.

Figure 116 shows an example of T-CCS frame forwarding. In the example, the first Cisco router captures the signaling frame from the PBX. The first Cisco router transports the signaling frame as a data frame through the Frame Relay or ATM network to the second Cisco router. The second Cisco router forwards the signaling frame to the PBX signaling channel.

Figure 116 T-CCS Frame Forwarding

To configure T-CCS frame forwarding, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller {T1 | E1} slot/port

Enters controller configuration mode for the controller at the specified slot/port location. Valid values for slot and port are 0 and 1.

Step 2 

Router(config-controller)# mode ccs frame-forwarding

Configures the controller to support CCS transparent signaling.

Step 3 

Router(config-controller)# ds0-group ds0-group-no 
timeslots timeslot-list type ext-sig

Defines the T1/E1 channels for use by compressed voice calls as well as the signaling method that the router uses to connect to the PBX or central office (CO).

The keywords and arguments are as follows:

ds0-group-no—DS0 group. Valid values for T1: 0 to 23 for T1; valid values for E1: 0 to 30.

timeslots timeslot-list—List of time slots in the DS0 group. T1 range: 1 to 24. E1 range: 1 to 30. You can enter a single number, a list of numbers separated by commas, or a pair of numbers separated by a hyphen to indicate a range of time slots. To map individual DS0 time slots, define additional groups. The router maps additional voice ports for each defined group.

type—Signaling method.

ext-sig—Signaling method selection for type depends on the connection that you are making: entering the keyword ext-sig specifies the external signaling interface, which signifies that the signaling traffic comes from an outside source.

Note The ds0-group command automatically creates a logical voice port that is numbered as follows: slot/port:ds0-group-no. Although only one voice port is created, applicable calls are routed to any channel in the group.

Note The ds0-group command replaced the voice-group command that was supported in earlier releases. The ext-sig keyword replaced the ext-sig-master and ext-sig-slave keywords that were supported with the voice-group command.

Step 4 

Router(config-controller)# no shutdown

Activates the controller.

Step 5 

Router(config-controller)# exit

Exits controller configuration mode.

Step 6 

Router(config)# interface serial 1:channelnumber

Enters interface configuration mode. This procedure maps the D channel from the digital T1/E1 packet voice trunk network module to the specified interface.

The argument is as follows:

channelnumber—Channel number. For T1, use 23. For E1, use 15.

Step 7 

Router(config-if)# ccs encap frf11

(Frame Relay only) Configures the CCS encapsulation to use the FRF11 packet format.

Step 8 

Router(config-if)# ccs encap atm

(ATM only) Configures the CCS encapsulation to use the ATM packet format.

Step 9 

Router(config-if)# ccs connect {serial |atm} 
slot/number [dlci dlci| pvc vci | pvc vcd | 
pvc vpi/vci | pvc string]

(Frame Relay and ATM) Configures the CCS connection. If the CCS connection is over Frame Relay, specify a serial interface and the DLCI. If the CCS connection is over ATM, specify ATM, slot and interface, and the PVC.

Step 10 

Router(config-if)# no cdp enable

Disables Cisco Discovery Protocol (CDP) on the interface.

Step 11 

Router(config-if)# no keepalive

Disables keepalive packets on the interface.

Configuring T-CCS for a Clear-Channel Codec

The T-CCS feature using a clear-channel codec allows tie-line emulation between two PBXs or PSTN switches running HDLC-based common channel signaling such as ISDN, DPNSS, CORNET, QSIG, and others. This configuration supports VoIP, VoFR and VoATM. Signaling frames are transparently forwarded on IP using an emulated 64-kbps channel. These frames travel over a clear-channel codec that is used on the voice port designated as the signaling channel. This codec passes data without changing the signaling frame.

T-CCS is configured when setting up the codec for the voice dial peer. The task table that follows sets up voice dial peers to support the local and remote stations. Not all possible commands are shown in the task table.

To learn more, see the Cisco IOS Voice, Video, and Fax Command Reference.

To configure T-CCS for a clear-channel codec, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller {T1 | E1} slot/port

Enters controller configuration mode for the controller at the specified slot/port location.

Note Refer to your hardware installation manual for the specific slot and port values.

Step 2 

Router(config-controller)# ds0-group ds0-group-no 
timeslots timeslot-list type ext-sig

Defines the T1/E1 channels for use by compressed voice calls as well as the signaling method the router uses to connect to the PBX or CO.

The keywords and arguments are as follows:

ds0-group-no—A value that identifies the DS0 group. Valid values are: 0 to 23 for T1; 0 to 30 for E1.

timeslots timeslot-list—List of time slots in the DS0 group. T1 range: 1 to 24. E1 range: 1 to 30. You can enter a single number, a list of numbers separated by commas, or a pair of numbers separated by a hyphen to indicate a range of time slots. To map individual DS0 time slots, define additional groups. The router maps additional voice ports for each defined group.

type—Signaling method.

ext-sig—Signaling method selection for type depends on the connection that you are making: entering the keyword ext-sig specifies the external signaling interface, which signifies that the signaling traffic comes from an outside source.

Note The ds0-group command automatically creates a logical voice port that is numbered as follows: slot/port:ds0-group-no. Although only one voice port is created, applicable calls are routed to any channel in the group.

Note The ds0-group command replaced the voice-group command that was supported in earlier releases. The ext-sig keyword replaced the ext-sig-master and ext-sig-slave keywords that were supported with the voice-group command.

Step 3 

Router(config-controller)# no shutdown

Activates the controller.

Step 4 

Router(config-controller)# exit

Exits controller configuration mode.

Step 5 

Router(config)# dial-peer voice number pots

Enters dial-peer configuration mode and defines a local dial peer that connects to the POTS network.

The keywords and arguments are as follows:

number—One or more digits identifying the dial peer. Range: 1 to 2147483647.

pots—A peer using a basic telephone service.

Step 6 

Router(config-dialpeer)# destination-pattern string [T]

Configures the dial peer's destination pattern so that the system can reconcile dialed digits with a telephone number.

The keywords and arguments are as follows:

string—A series of digits that specify the E.164 or private dialing plan phone number. Valid entries are the digits 0 through 9 and the letters A through D. The plus symbol (+) is not valid. You can enter the following special characters:

The star character (*) that appears on standard touch-tone dial pads can be in any dial string.

The period (.) acts as a wildcard character.

Use the comma (,) only in prefixes. The comma inserts a one-second pause.

T—(optional) The timer (T) character. When this character is included at the end of the destination pattern, the system collects dialed digits as they are entered—until the interdigit timer expires (10 seconds, by default) or the user dials the termination of end-of-dialing key (the default is #).

Note The timer character must be a capital T.

Step 7 

Router(config-dialpeer)# port slot/port:ds0-group-no

Associates the dial peer with a specific logical interface.

The arguments are as follows:

slot—Router location where the voice module is installed. Range: 0 to 3.

port—Voice interface card location. Range: 0 to 1.

ds0-group-no—Defined DS0 group number. Each defined DS0 group number is represented on a separate voice port. This allows you to define individual DS0s on the digital T1 card.

Step 8 

Router(config-dialpeer)# exit

Exits dial-peer configuration mode to complete the POTS dial-peer configuration.

Step 9 

Router(config)# dial-peer voice number voip

Enters dial-peer configuration mode and defines a remote VoIP dial peer.

The keywords and arguments are as follows:

number—One or more digits identifying the dial peer. Valid entries are from 1 through 2147483647.

voip—A VoIP peer using voice encapsulation on the IP network.

Step 10 

Router(config-dialpeer)# codec clear-channel

Sets codec complexity to clear-channel to use the clear channel codec.

Note The voice-card configuration codec complexity command sets the codec options that are available when you execute this command.

Step 11 

Router(config-dialpeer)# vad

(Optional) Activates voice activity detection (VAD), which allows the system to reduce unnecessary voice transmissions caused by unfiltered background noise.

Note This setting is enabled by default.

Step 12 

Router(config-dialpeer)# destination-pattern string 
[T]

Configures the dial peer's destination pattern so that the system can reconcile dialed digits with a telephone number.

The keywords and arguments are as follows:

string—A series of digits that specify the E.164 or private dialing plan phone number. Valid entries are the digits 0 through 9 and the letters A through D. The plus symbol (+) is not valid. You can enter the following special characters:

The star character (*) that appears on standard touch-tone dial pads can be in any dial string.

The period (.) acts as a wildcard character.

Use the comma (,) only in prefixes. The comma inserts a one-second pause.

T—(optional) The timer (T) character. When this character is included at the end of the destination pattern, the system collects dialed digits as they are entered—until the interdigit timer expires (10 seconds, by default) or the user dials the termination of end-of-dialing key (the default is #).

Note The timer character must be a capital T.

Step 13 

Router(config-dialpeer)# session target 
{ipv4:destination-address | dns:[$s$. | $d$. | $e$. | $u$.] 
host-name}

Configures the IP session target for the dial peer.

The keywords and arguments are as follows:

ipv4:destination-address—IP address of the dial peer.

dns:host-nameThe domain name server resolves the name of the IP address. Valid entries for the argument are characters representing the name of the host device. There are also wildcards available for defining domain names with the keyword by using source, destination, and dialed information in the host name.

For complete command syntax information, refer to the Cisco IOS Voice Command Reference, Release 12.3.

Verifying the T-CCS Configuration

To verify the T-CCS configuration, perform the following steps:


Step 1 Enter the show controllers e1 command (without specifying a slot and port number) to view the status for all controllers, or enter the show controllers e1 command with a slot and port number to view the status for a particular controller. Make sure that the status indicates that the controller is up (line 2 in the following example) and no alarms (line 4 in the following example) or errors (lines 9, 10, and 11 in the following example) have been reported.

Router# show controllers e1 3/0

E1 3/0 is up.
  Applique type is Channelized E1 - balanced
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware:19990702, FPGA:6
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (2 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail
Secs

!
controller E1 3/0
 mode ccs frame-forwarding
 channel-group 15 timeslots 16
 ds0-group 0 timeslots 15 type ext-sig
 ds0-group 1 timeslots 1 type ext-sig
 ds0-group 2 timeslots 2 type ext-sig
 ds0-group 3 timeslots 3 type ext-sig
 ds0-group 4 timeslots 4 type ext-sig
 ds0-group 5 timeslots 5 type ext-sig
 ds0-group 6 timeslots 6 type ext-sig
 ds0-group 7 timeslots 7 type ext-sig
 ds0-group 8 timeslots 8 type ext-sig
 ds0-group 9 timeslots 9 type ext-sig
 ds0-group 10 timeslots 10 type ext-sig
 ds0-group 11 timeslots 11 type ext-sig
 ds0-group 12 timeslots 12 type ext-sig
 ds0-group 13 timeslots 13 type ext-sig
 ds0-group 14 timeslots 14 type ext-sig
 ds0-group 16 timeslots 31 type ext-sig
 ds0-group 17 timeslots 17 type ext-sig
 ds0-group 18 timeslots 18 type ext-sig
 ds0-group 19 timeslots 19 type ext-sig
 ds0-group 20 timeslots 20 type ext-sig
 ds0-group 21 timeslots 21 type ext-sig
 ds0-group 22 timeslots 22 type ext-sig
 ds0-group 23 timeslots 23 type ext-sig
 ds0-group 24 timeslots 24 type ext-sig
 ds0-group 25 timeslots 25 type ext-sig
 ds0-group 26 timeslots 26 type ext-sig
 ds0-group 27 timeslots 27 type ext-sig
 ds0-group 28 timeslots 28 type ext-sig
 ds0-group 29 timeslots 29 type ext-sig
 ds0-group 30 timeslots 30 type ext-sig

Step 2 To display information about voice-port configuration, enter the show voice port summary command. The following example shows sample output:

Router# show voice port summary
                                  IN      OUT
PORT   CH SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
====== == ========== ===== ==== ======== ======== ==
1:1    1     ext     up    up   on-hook  idle     y
1:2    2     ext     up    up   on-hook  idle     y
1:3    3     ext     up    up   on-hook  idle     y
1:4    4     ext     up    up   on-hook  idle     y
1:5    5     ext     up    up   on-hook  idle     y
1:6    6     ext     up    up   on-hook  idle     y
1:7    7     ext     up    up   on-hook  idle     y
1:8    8     ext     up    up   on-hook  idle     y
1:9    9     ext     up    up   on-hook  idle     y
1:10   10    ext     up    up   on-hook  idle     y
1:11   11    ext     up    up   on-hook  idle     y
1:12   12    ext     up    up   on-hook  idle     y
1:13   13    ext     up    up   on-hook  idle     y
1:14   14    ext     up    up   on-hook  idle     y
1:17   17    ext     up    up   on-hook  idle     y
1:18   18    ext     up    up   on-hook  idle     y
1:19   19    ext     up    up   on-hook  idle     y
1:20   20    ext     up    up   on-hook  idle     y
1:21   21    ext     up    up   on-hook  idle     y
1:22   22    ext     up    up   on-hook  idle     y
1:23   23    ext     up    up   on-hook  idle     y
1:24   24    ext     up    up   on-hook  idle     y
1:25   25    ext     up    up   on-hook  idle     y
1:26   26    ext     up    up   on-hook  idle     y

Step 3 To display information about voice calls, enter the show voice call summary privileged EXEC command. The following example shows sample output:

Router# show voice call summary

PORT      CODEC    VAD VTSP STATE            VPM STATE
========= ======== === ===================== ========================
1:1.1     g729ar8   y  S_CONNECT             S_TRUNKED
1:2.2     g729ar8   y  S_CONNECT             S_TRUNKED
1:3.3     g729ar8   y  S_CONNECT             S_TRUNKED
1:4.4     g729ar8   y  S_CONNECT             S_TRUNKED
1:5.5     g729ar8   y  S_CONNECT             S_TRUNKED
1:6.6     g729ar8   y  S_CONNECT             S_TRUNKED
1:7.7     g729ar8   y  S_CONNECT             S_TRUNKED
1:8.8     g729ar8   y  S_CONNECT             S_TRUNKED
1:9.9     g729ar8   y  S_CONNECT             S_TRUNKED
1:10.10   g729ar8   y  S_CONNECT             S_TRUNKED
1:11.11   g729ar8   y  S_CONNECT             S_TRUNKED
1:12.12   g729ar8   y  S_CONNECT             S_TRUNKED
1:13.13   g729ar8   y  S_CONNECT             S_TRUNKED
1:14.14   g729ar8   y  S_CONNECT             S_TRUNKED
1:17.17   g729ar8   y  S_CONNECT             S_TRUNKED
1:18.18   g729ar8   y  S_CONNECT             S_TRUNKED
1:19.19   g729ar8   y  S_CONNECT             S_TRUNKED
1:20.20   g729ar8   y  S_CONNECT             S_TRUNKED
1:21.21   g729ar8   y  S_CONNECT             S_TRUNKED
1:22.22   g729ar8   y  S_CONNECT             S_TRUNKED
1:23.23   g729ar8   y  S_CONNECT             S_TRUNKED
1:24.24   g729ar8   y  S_CONNECT             S_TRUNKED
1:25.25   g729ar8   y  S_CONNECT             S_TRUNKED
1:26.26   g729ar8   y  S_CONNECT             S_TRUNKED

Step 4 To display information about configured DS0 and TDM groups, enter the show running-config privileged EXEC command. The following example shows sample output:

Router# show running-config
.
.
.
controller T1 0
 tdm-group 1 timeslots 24
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-23 speed 64
!
controller E1 1
 mode ccs cross-connect
 tdm-group 1 timeslots 16
 clock source internal
 ds0-group 0 timeslots 1 type ext-sig
 ds0-group 2 timeslots 2 type ext-sig
 ds0-group 3 timeslots 3 type ext-sig
 ds0-group 4 timeslots 4 type ext-sig
 ds0-group 5 timeslots 5 type ext-sig
 ds0-group 6 timeslots 6 type ext-sig
 .
 .
 .
 ds0-group 23 timeslots 23 type ext-sig
 ds0-group 24 timeslots 24 type ext-sig
 ds0-group 25 timeslots 25 type ext-sig
 ds0-group 26 timeslots 26 type ext-sig
.
.
.
voice-port 1:0
 compand-type a-law
 timeouts wait-release 3
 connection trunk 3001
!
voice-port 1:2
 compand-type a-law
 timeouts wait-release 3
 connection trunk 3002
!
voice-port 1:3
 compand-type a-law
 timeouts wait-release 3
 connection trunk 3003
!
.
.
.
dial-peer voice 12 pots
 destination-pattern 4012
 port 1:12
!
dial-peer voice 13 pots
 destination-pattern 4013
 port 1:13
!
dial-peer voice 14 pots
 destination-pattern 4014
 port 1:14
!
!
cross-connect 1 E1 1 1 T1 0 1


Note For full configuration details, see the "T-CCS Configuration Examples" section.


Troubleshooting Tips for T-CCS

If the T-CCS connection does not come up, check for the following:

Loose wires, splices, connectors, shorts, bridge taps, and grounds

Backwards transmit and receive

Mismatched framing types (for example, CRC-4 versus no-CRC-4)

Transmit and receive pair separation (crosstalk)

Faulty line cards or repeaters

Noisy lines (for example, power and crosstalk)

If you see errors on the line or the line is going up and down, check for the following:

Mismatched line codes (HDB3 vs. AMI)

Improper receive level

Frame slips due to poor clocking plan

Monitoring and Maintaining T-CCS and Frame Forwarding

To monitor your T-CCS configuration, use these commands as needed:

Command
Purpose
Router# show frame-relay vofr [interface [dlci [cid]]]

Displays information about FRF.11 subchannels and CIDs.

Router# show interface serial0

Displays information the serial interface used with VoFR, the DLCIs used on the interface, and the DLCI used for the Local Management Interface (LMI).

Router# show frame-relay pvc [interface interface [dlci] 
[cid]]

Displays information about Frame Relay PVCs, on all PVCs, or for a particular CID.

Router# show atm pvc [vpi/vci] [name]

Displays information about all configured ATM PVCs or about a particular PVC by virtual path identifier (VPI) and virtual channel identifier (VCI) numbers or by name.

Router# show interface atm0

Displays information about ATM interface configuration.


PBX Interconnectivity Configuration Examples

The following sections give sample configurations for both the QSIG and T-CCS PBX signaling formats.

QSIG Configuration Examples

This section contains two examples of QSIG configuration:

QSIG for VoIP Configuration Example

QSIG PRI Signaling on the Cisco MC3810 Configuration Example

QSIG for VoIP Configuration Example

The following configuration example configures interface serial 1:23 for QSIG PRI and to act as the QSIG slave:

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname as5300A
!
ip subnet-zero
!
isdn switch-type primary-qsig
!
controller T1 0
 shutdown
!
controller T1 1
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 shutdown
!
controller T1 3
 shutdown
!
!
voice-port 1:D
!
!
dial-peer voice 3001 pots
 destination-pattern 3001
 port 1:D
!
dial-peer voice 4001 pots
 incoming called-number 4001
 direct-inward dial
!
dial-peer voice 4002 voip
 destination-pattern 4001
 session target ipv4:1.14.82.14
!
!
interface Ethernet0
 ip address 1.14.82.13 255.255.0.0
 no ip directed-broadcast
!
interface 1:23
 no ip address
 no ip directed broadcast
 isdn switch-type primary-qsig
 isdn protocol-emulate user
 isdn incoming-voice modem
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
ip default-gateway 1.14.0.1
ip classless
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

=====================================================
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname as5300B
!
ip subnet-zero
!
isdn switch-type primary-qsig
!
!
controller T1 0
 shutdown
!
controller T1 1
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2
 shutdown
!
controller T1 3
 shutdown
!
!
voice-port 1:D
!
!
dial-peer voice 3001 pots
 incoming called-number 3001
 direct-inward-dial
!
dial-peer voice 3002 voip
 destination-pattern 3001
 session target ipv4:1.14.82.13
!
dial-peer voice 4001 pots
 destination-pattern 4001
 port 1:D
!
interface Ethernet0
 ip address 1.14.82.14 255.255.0.0
 no ip directed-broadcast
!
interface Serial1:23
 no ip address
 no ip directed-broadcast
 isdn switch-type primary-qsig
 isdn protocol-emulate network
 isdn incoming-voice modem
!
interface FastEthernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
ip default-gateway 1.14.0.1
ip classless
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

QSIG PRI Signaling on the Cisco MC3810 Configuration Example

The following configuration example configures interface serial 1:15 for QSIG PRI and sets it to act as the QSIG master. The example shows other commands necessary for the configuration.

! version 12.2
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname c3810a
 !
 network-clock base-rate 56k
 ip subnet-zero
 no ip domain-lookup
 ip host rb 10.1.1.1
 !
 isdn switch-type primary-qsig-master
 !
 !
 stun peer-name 10.1.1.1
 stun protocol-group 1 basic
 !
 controller E1 1
  clock source internal
  pri-group timeslots 1-2,16
 !
 !
 !
 interface Ethernet0
  ip address 144.254.156.169 255.255.255.0
  no ip directed-broadcast
  no ip route-cache
  no ip mroute-cache
  no keepalive
 !
 interface Serial0
  ip address 10.1.1.2 255.255.255.0
  no ip directed-broadcast
  encapsulation frame-relay
  no ip route-cache
  no ip mroute-cache
  no arp frame-relay
  bandwidth 256
  no keepalive
  no fair-queue
  serial restart-delay 0
  frame-relay interface-dlci 30 voice-encap 80
  hold-queue 1024 out
 !
 interface Serial1
  no ip address
  no ip directed-broadcast
  encapsulation stun
  no ip route-cache
  no ip mroute-cache
  stun group 1
  stun route all interface Serial0 dlci 30
 !
 interface Serial1:15
  no ip address
  no ip directed-broadcast
  no logging event link-status
  isdn switch-type primary-qsig-master
  isdn bchan-number-order ascending
  no cdp enable
 !
 interface Switch0
  no ip address
  no ip directed-broadcast
  encapsulation frame-relay
  no fair-queue
 !
 interface FR-ATM0
  no ip address
  no ip directed-broadcast
 !
 interface FR-ATM20
  no ip address
  no ip directed-broadcast
  no ip route-cache
  shutdown
 !
 router rip
  network 10.0.0.0
  network 144.254.0.0
 !
 ip classless
 !
 map-list atm1
 !
 map-class frame-relay A-relay
  frame-relay traffic-rate 256000 1540000
  no frame-relay adaptive-shaping
 !
 line con 0
  transport input none
 line aux 0
 line 2 3
 line vty 0 4
  login
 !
 !
 voice-port 1/1
 !
 voice-port 1/2
 !
 dial-peer voice 1 pots
  destination-pattern 2...
  port 1/1
 !
 dial-peer voice 3 pots
  destination-pattern 3
  port 1/3
 !
 dial-peer voice 5 pots
  destination-pattern 5
  port 1/5
 !
 dial-peer voice 6 pots
  destination-pattern 6
  port 1/6
 !
 dial-peer voice 10 vofr
  destination-pattern 4...
  session target Serial0 30
 !
 end

T-CCS Configuration Examples

This section contains two examples of T-CCS configuration:

T-CCS over Frame Relay Configuration Example

T-CCS over IP Configuration Example

T-CCS over Frame Relay Configuration Example

The following configuration example shows T-CCS frame forwarding on controller E1. Only relevant sections of the configuration are shown. The example assumes that the IP portion of the network is already in place.

hostname routerA
!
voice-card 1
!
controller E1 1/0
 mode ccs frame-forwarding
 channel-group 15 timeslots 16
 ds0-group 0 timeslots 15 type ext-sig
 ds0-group 1 timeslots 1 type ext-sig
.
.
.
 ds0-group 14 timeslots 14 type ext-sig
 ds0-group 17 timeslots 17 type ext-sig
.
.
.
 ds0-group 30 timeslots 30 type ext-sig
!
interface Serial0/0
 ip address 200.200.200.2 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 clockrate 2000000
 frame-relay traffic-shaping
 frame-relay class fr1
 frame-relay map ip 200.200.200.1 231 broadcast
 frame-relay interface-dlci 231
  vofr data 4 call-control 5
 frame-relay intf-type dce
!

The E1 interface must be set to mode ccs frame-forwarding to enable transparent forwarding of the HDLC signaling protocol through the DSP.

The ds0-group command links the specified time slot of the E1 interface to the corresponding voice port, which is automatically created by the router. This allows the voice port to be tied to the correspondent dial-peer using the connection trunk command. The ext-sig type specifies that the signaling traffic is coming from an external source.

The serial interface is set for frame relay traffic.

The example continues with the voice-port and dial-peer configuration.

voice-port 1/0:0
 compand-type a-law
 timeouts wait-release 3
 connection trunk 2000 answer-mode
.
.
.
voice-port 1/0:14
 compand-type a-law
 timeouts wait-release 3
 connection trunk 2014 answer-mode
!
voice-port 1/0:17
 compand-type a-law
 timeouts wait-release 3
 connection trunk 2017 answer-mode
.
.
.
voice-port 1/0:30
 compand-type a-law
 timeouts wait-release 3
 connection trunk 2030 answer-mode
!
dial-peer voice 2000 vofr
 destination-pattern 2000
 session target Serial0/0 231
!
dial-peer voice 1001 pots
 destination-pattern 1001
 port 1/0:1
.
.
.
dial-peer voice 1030 pots
 destination-pattern 1030
 port 1/0:30
!

The dial-peer voice 2000 vofr forwards the signaling channel over Frame Relay.

The dial-peer pots command sends the trunked voice DS0 traffic to the correspondant voice DS0 lines on the E1 port 1/0.

T-CCS over IP Configuration Example

The following configuration example configures T-CCS over IP using the clear-channel codec. The commands used in the configurations are explained inline. Only relevant sections of the configuration are shown. The example assumes that the IP portion of the network is already in place.

hostname routerA
!
voice-card 1
!
controller E1 1/0
 ds0-group 0 timeslots 16 type ext-sig
.
.
.
 ds0-group 10 timeslots 10 type ext-sig
!
interface Ethernet0/0
ip address 30.30.30.2 255.255.255.252
no ip directed-broadcast
!
voice-port 1/0:0
 compand-type a-law
 timeouts wait-release 3
 connection trunk 4000 answer-mode
!
voice-port 1/0:1
  compand-type a-law
  timeouts wait-release 3
  connection trunk 5001 answer-mode
.
.
.
voice-port 1/0:10
  compand-type a-law
  timeouts wait-release 3
  connection trunk 5010 answer-mode
!

The ds0-group command links the specified time slot of the E1 interface to the corresponding voice port, which is automatically created by the router. This allows the voice port to be tied to the corresponding dial peer using the connection trunk command. The ext-sig type specifies that the signaling traffic is coming from an external source.

The DS0 group assigned for signaling, configured as ds0-group 0 timeslots 16, must have the corresponding voice port and dial peer set for the clear-channel codec in order to enable transparent forwarding of the HDLC signaling protocol through the DSP.

The signaling DS0 channel of the E1 port 1/0 is configured to the dial peer whose destination pattern matches the number 4000. The dial-peer voice 4000 voip command forwards the signaling channel over IP.

The voice DS0 channels of the E1 port 1/0 are configured to the dial peer whose destination pattern matches the number 5... . The dial-peer voice 5... voip command trunks the voice channels between routers.

dial-peer voice 4000 voip
 destination-pattern 4000
 codec clear-channel
 session target ipv4:10.49.80.204
!
 dial-peer voice 3000 pots
 destination-pattern 3000
 port 1/0:0
!
dial-peer voice 5000 voip
 destination-pattern 5...
 session target ipv4:10.49.80.204
!
dial-peer voice 2001 pots
 destination-pattern 2001
 port 1/0:1
.
.
.
dial-peer voice 2010 pots
 destination-pattern 2010
 port 1/0:10

The dial-peer voice 4000 voip command forwards the signaling channel from the router over IP. The clear-channel codec must be applied to this dial peer in order to avoid that compression, and VAD is not applied to the signaling channel, which requires a transparent 64-kbps path through the DSP and the IP cloud.

The dial-peer voice 3000 pots command forwards the incoming clear-channel signaling data to the corresponding signaling DS0 channel on the E1 port 1/0 of the router. This is achieved leveraging on the voice-port 1/0:0 created with ds0-group 0 timeslots 16 type ext-sig.

The dial-peer voice 5000 voip command trunks the voice channels between routers. In this case, the codec used is the default G.729.

The dial-peer voice 2001 pots through dial-peer voice 2010 pots commands associate the VoIP legs of the trunked voice DS0s to the corresponding voice DS0s on the E1 port 1/0 of the router.