Cisco IOS Voice, Video, and Fax Configuration�Guide, Release�12.2
Configuring Modem Support for VoIP
Downloads: This chapterpdf (PDF - 239.0KB) The complete bookPDF (PDF - 9.14MB) | Feedback

Configuring Modem Transport Support for VoIP

Table Of Contents

Configuring Modem Transport Support for VoIP

Modem Transport Support Overview

Monitoring and Maintaining Modem Call Status

DS-0 Busyout Traps

ISDN PRI-Requested Channel-Not-Available Traps

Modem Health Traps

show controllers timeslots Command

DS-1 Loopback Traps

Modem Passthrough over VoIP

Modem Tone Detection

Passthrough Switchover

Controlled Redundancy

Packet Size

Clock Slip Buffer Management

Modem Transport Support Prerequisite Tasks

Modem Transport Support Configuration Task List

Configuring Modem Call Status

Enabling DS-0 Busyout Traps

Enabling ISDN PRI-Requested Channel-Not-Available Traps

Enabling Modem Health Traps

Enabling DS-1 Loopback Traps

Verifying Enabled Traps

Troubleshooting Tips

Configuring Modem Passthrough

Configuring Modem Passthrough Globally

Configuring Modem Passthrough for a Specific Dial Peer

Verifying Modem Passthrough

Troubleshooting Tips for Modem Passthrough

Monitoring and Maintaining Modem Passthrough

Modem Transport Support Configuration Examples

Modem Call Status Configuration Example

Modem Passthrough Configuration Example


Configuring Modem Transport Support for VoIP


This chapter explains how to configure modem transport support for Voice over IP (VoIP) and contains the following sections:

Modem Transport Support Overview

Modem Transport Support Prerequisite Tasks

Modem Transport Support Configuration Task List

Modem Transport Support Configuration Examples

For a complete description of the commands used to configure VoIP for modem support, refer to the Cisco IOS Voice, Video, and Fax Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

To identify the hardware platform or software image information associated with a feature in this chapter, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.


Note This chapter does not cover modem operation; it covers the transport via VoIP of modem calls and modem call status.


Modem Transport Support Overview

This section describes modem support features. Modem support includes two areas:

Monitoring and Maintaining Modem Call Status

Modem Passthrough over VoIP

Monitoring and Maintaining Modem Call Status

Modem call status is supported by the following features and commands:

DS-0 busyout traps

ISDN PRI-requested channel-not-available traps

Modem health traps

Show controllers timeslots command

DS-1 loopback traps

These features allow monitoring and maintaining of access server modem call status at digital signal level zero (DS-0), the PRI bearer channel level, and the modem level.

Modem call status offers the following benefits:

Improved visibility into the line status of the access server for comprehensive status monitoring and notification capability

Improved troubleshooting and diagnostics for large dial networks


Note Customers must provide their own management tools.


DS-0 Busyout Traps

A DS-0 busyout trap is generated when any of the following conditions is met:

A request to busy out a DS-0 occurs

A busyout completes and the DS-0 is out of service

A request to take a DS-0 out of busyout mode occurs

DS-0 busyout traps are generated at the DS-0 level for both channel-associated signalling (CAS) and ISDN configured lines.

ISDN PRI-Requested Channel-Not-Available Traps

ISDN PRI-requested channel-not-available traps are generated when a requested DS-0 channel is not available or when there is no modem available to take an incoming call. This feature is available only on ISDN PRI interfaces.

Modem Health Traps

Modem health traps are generated when a modem port is bad, disabled, reflashed, or shut down, or when there is a request to busy out the modem.

show controllers timeslots Command

The show controllers command, with the keyword timeslots, displays the channel state in detail. This command shows whether the DS-0 channels of a particular controller are in idle, in-service, maintenance, or busyout states. The show controllers command applies to both CAS and ISDN PRI interfaces.

DS-1 Loopback Traps

DS-1 loopback traps are generated when a DS-1 line goes into loopback mode.

Modem Passthrough over VoIP

Modem passthrough over VoIP provides for the transport of modem signals through a packet network by using pulse code modulation (PCM)-encoded packets.

Modem passthrough performs the following functions:

Repressing processing functions like compression, echo cancellation, high-pass filter, and voice activity detection (VAD)

Issuing redundant packets to protect against random packet drops

Providing static jitter buffers of 200 milliseconds (ms) to protect against clock skew

Differentiating modem signals from voice and fax signals, indicating the detection of the modem signal across the connection, and placing the connection in a state that transports the signal across the network with the least distortion

Maintaining a modem connection reliably across the packet network for a long duration under normal network conditions

Modem passthrough offers the following benefits:

Detecting modem tones

Passing modem signals over the WAN

Performing proper switchover to pass modem traffic on a bearer channel

Detecting modems at speeds up to V.90

Figure 124 illustrates the connection from the client modem to a modem ISDN channel aggregation (MICA) technologies modem network access server (NAS).

Figure 124 Modem Passthrough Connection

Modem Tone Detection

The gateway detects modems operating at speeds up to V.90.

Passthrough Switchover

See Figure 124. When the gateway detects a data modem, both the originating gateway and the terminating gateway roll over to G.711. The rollover to G.711 disables the high-pass filter, disables echo cancellation, and disables VAD. At the end of the modem call, the voice ports revert to their prior configuration, and the digital signal processor (DSP) goes back to the state it was in before switchover.

For more information about modem passthrough, see the "Configuring Modem Passthrough" section later in this chapter.

Controlled Redundancy

You can enable payload redundancy so that the modem passthrough over VoIP switchover causes the gateway to emit redundant packets.

Packet Size

When redundancy is enabled, 10-ms sample-sized packets are sent. When redundancy is disabled, 20-ms sample-sized packets are sent.

Clock Slip Buffer Management

When the originating gateway detects a data modem, both the originating gateway and the terminating gateway switch from using dynamic jitter buffers to using static jitter buffers of 200-ms depth. The switch from dynamic to static compensates for Public Switched Telephone Network (PSTN) clocking differences at the originating gateway and the terminating gateway. At the modem call conclusion, the voice ports revert to using dynamic jitter buffers.

Modem Transport Support Prerequisite Tasks

Before configuring your access server to monitor modem call status, perform the following tasks:

Install the SNMP manager on your workstation.

Configure the SNMP agent on the access server by entering the following commands:

snmp-server community public RO

snmp-server host 10.1.2.3 public

For more information on these commands, refer to the Cisco IOS Configuration Fundamentals Command Reference.

Before configuring your access server for modem passthrough, perform the following tasks:

Establish a working VoIP-enabled network.

Verify network suitability to pass modem traffic. The key characteristics of the network are packet loss, delay, and jitter. These characteristics can be determined by using the Service Assurance Agent (SAA) feature of Cisco IOS software. For more information on SAA, refer to the Cisco IOS Configuration Fundamentals Configuration Guide.

Modem Transport Support Configuration Task List

To configure modem support, perform the tasks described in the following sections:

Configuring Modem Call Status

Configuring Modem Passthrough

Configuring Modem Call Status

To configure modem call status, perform the tasks in the following sections. All four sections are optional.

Enabling DS-0 Busyout Traps

Enabling ISDN PRI-Requested Channel-Not-Available Traps

Enabling Modem Health Traps

Enabling DS-1 Loopback Traps

Enabling DS-0 Busyout Traps

DS-0 busyout traps are supported on the Cisco AS5300 and Cisco AS5800 universal access servers beginning with Cisco IOS Release 12.2. If you are using another Cisco IOS release, use the Feature Navigator on Cisco.com to determine which platforms support this feature.

To generate DS-0 busyout traps, use the following command in global configuration mode:

Command
Purpose
Router(config)# snmp-server enable traps 
ds0-busyout

Generates a trap when there is a request to busy out a DS-0 or when busyout finishes. DS-0 busyout traps are disabled by default.

The ds0-busyout keyword specifies that DS-0 busyout traps be enabled.


Enabling ISDN PRI-Requested Channel-Not-Available Traps

ISDN PRI-requested channel-not-available traps are supported on the Cisco AS5300 and Cisco AS5800 universal access servers beginning with Cisco IOS Release 12.2. If you are using another Cisco IOS release, use the Feature Navigator on Cisco.com to determine which platforms support this feature.

To generate ISDN PRI-requested channel-not-available traps, use the following command in global configuration mode:

Command
Purpose
Router(config)# snmp-server enable traps isdn 
chan-not-avail 

Generates a trap when the network access server (NAS) rejects an incoming call on an ISDN PRI interface because the channel is not available. ISDN PRI-requested channel-not-available traps are disabled by default.

The isdn chan-not-avail keywords specify that ISDN PRI-requested channel-not-available traps be enabled.


Enabling Modem Health Traps

Modem health traps are supported on the Cisco AS5300 and Cisco AS5800 universal access servers beginning with Cisco IOS Release 12.2. If you are using another Cisco IOS release, use the Feature Navigator on Cisco.com to determine which platforms support this feature.

To generate modem health traps, use the following command in global configuration mode:

Command
Purpose
Router(config)# snmp-server enable traps 
modem-health

Generates a trap when a modem port is bad, disabled, or downloading firmware; when a download fails; when a modem is placed in loopback mode for maintenance; or when there is a request to busy out the modem. Modem health traps are disabled by default.

The modem-health keyword specifies that modem health traps be enabled.


Enabling DS-1 Loopback Traps

DS-1 loopback traps are supported on the Cisco AS5300 universal access server beginning with Cisco IOS Release 12.2. If you are using another Cisco IOS release, use the Feature Navigator on Cisco.com to determine which platforms support this feature.

To generate DS-1 loopback traps, use the following command in global configuration mode:

Command
Purpose
Router(config)# snmp-server enable traps 
ds1-loopback

Generates a trap when the DS-1 line goes into loopback mode. DS-1 loopback traps are disabled by default.

The ds1-loopback keyword specifies that DS-1 loopback traps be enabled.


Verifying Enabled Traps

Use the show running-config command to verify that the traps are enabled. The following output indicates that all the traps are enabled:

.
.
.
Router(config)# show running-config

snmp-server enable traps ds0-busyout
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps modem-health
snmp-server enable traps ds1-loopback
.
.
.

Troubleshooting Tips

To troubleshoot the traps, enable debugging for SNMP packets by entering the debug snmp packets command in privileged EXEC mode. Check the resulting output to see that the SNMP trap information packet is being sent. The output will vary according to the kind of packet sent or received.

The following example shows the debug snmp packets command followed by an excerpt from the debug output. The first and last lines of the sample output show SNMP trap packets that have been sent and received.

Router# debug snmp packets

SNMP: Packet received via UDP from 10.5.4.1 on Ethernet0
SNMP: Get-next request, reqid 23584, errstat 0, erridx 0
sysUpTime = NULL TYPE/VALUE
 system.1 = NULL TYPE/VALUE
 system.6 = NULL TYPE/VALUE
SNMP: Response, reqid 23584, errstat 0, erridx 0
 sysUpTime.0 = 2217027
 system.1.0 = Cisco Internetwork Operating System Software
 system.6.0 = 
SNMP: Packet sent via UDP to 10.5.4.1

You can also use trap monitoring and logging tools such as snmptrapd with debugging flags turned on to monitor output.

Configuring Modem Passthrough

Modem passthrough over VoIP capability is supported on the Cisco AS5300 universal access server beginning with Cisco IOS Release 12.2. If you are using another Cisco IOS release, use the Feature Navigator on Cisco.com to determine which platforms support this feature.

By default, modem passthrough over VoIP capability and redundancy are disabled.


Tips For modem passthrough to operate correctly, you must configure modem passthrough in both the originating gateway and the terminating gateway. If you configure only one of the gateways in a pair, the modem call will not be connected successfully.


Redundancy can be enabled in one or both of the gateways. When only a single gateway is configured for redundancy, the other gateway receives the packets correctly but does not produce redundant packets.

Modem passthrough can be configured either globally or for a specific dial peer, or both. If modem passthrough is configured both globally and for a specific dial peer, the dial peer configuration takes precedence over the global configuration. Consequently, when a call matches a particular dial peer, the access server first applies the modem passthrough configuration on the dial peer. Then, if a specific dial peer is not configured, the access server will use the global configuration. The following sections explain further:

Configuring Modem Passthrough Globally

Configuring Modem Passthrough for a Specific Dial Peer

Configuring Modem Passthrough Globally

For the Modem Passthrough over VoIP feature to operate, you need to configure modem passthrough in both the originating gateway and the terminating gateway so that the modem call matches a voip dial-peer on the gateway.

When using the voice service voip and modem passthrough nse commands on a terminating gateway to globally set up fax or modem pass-through with NSEs, you must also ensure that each incoming call will be associated with a VoIP dial peer to retrieve the global fax or modem configuration. You associate calls with dial peers by using the incoming called-number command to specify a sequence of digits that incoming calls can match. You can ensure that all calls will match at least one dial peer by using the following commands:

Router(config)# dial-peer voice tag voip
Router(config-dial-peer)# incoming called-number . 

To configure modem passthrough for all the dial peers of a gateway, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice service voip

Enters voice-service configuration mode and configures voice service for all gateway connections.

Step 2 

Router(conf-voi-serv)# modem passthrough nse [payload-type number] codec {g711ulaw | g711alaw} [redundancy] [maximum-sessions value]

Configures modem passthrough for all dial peers of a gateway. The default behavior is no modem passthrough.

The keywords and arguments are as follows:

nse—Used to specify named signalling event (NSE).

payload-type—(Optional) The NSE payload type.

number—(Optional) Specifies the value of the payload type (from 96 to 119). The default is 100.

Use the same payload type for the originating and terminating gateways. When the payload type is 100 and you use the show running config command, the payload-type parameter does not appear in the output.

codec—Used to specify the type of codec.

g711ulaw—Specifies the G.711 u-law codec type.

g711alaw—Specifies the G.711 a-law codec type.

Use the same codec type for both the originating gateway and the terminating gateway: g711ulaw codec is required for T1; g711alaw codec is required for E1.

redundancy—(Optional) Specifies redundant packets for modem traffic.

maximum-sessions—(Optional) Used to specify the maximum number of simultaneous modem passthrough sessions with redundancy.

value—(Optional) Specifies the number of simultaneous modem passthrough sessions with redundancy.

Configuring Modem Passthrough for a Specific Dial Peer

Modem passthrough is disabled by default for all dial peers on the gateway. You can configure modem passthrough on a specific dial peer by entering dial-peer configuration mode for the specific dial peer.

You must configure a VoIP dial peer on both the originating and terminating gateways to match the call—for example, using a destination pattern. The modem passthrough parameters associated with those dial peers will then apply to the calls between them.


Note When modem passthrough is configured individually for a specific dial peer, the dial-peer configuration takes precedence over the global configuration for that specific dial peer.


To configure modem passthrough for a specific dial peer, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice number voip

Enters dial-peer configuration mode and names a specific VoIP dial peer.

The keywords and arguments are as follows:

number—Selects a particular dial peer. Valid entries are from 1 to 2147483647.

voip—Indicates that this is a VoIP peer using voice encapsulation on the plain old telephone service (POTS) network.

Step 2 

Router(config-dial-peer)# modem passthrough {system | nse [payload-type number] codec {g711ulaw | g711alaw} [redundancy]}

Configures modem passthrough for a specific dial peer. The default behavior for modem passthrough in dial-peer configuration mode is modem passthrough system.

Note When the system keyword is entered, the following parameters are not available: nse, payload-type, codec, and redundancy. Instead, the values that are used are the ones that were set using the modem passthrough nse command in voice-service configuration mode.

The keywords and arguments are as follows:

system—Causes the gateway to use the values from the global configuration.

nse—Used to specify named signalling event.

payload-type—(Optional) The NSE payload type.

number—(Optional) Specifies the value of the payload type (from 96 to 119). The default is 100.

Use the same payload type for the originating and terminating gateways. When the payload type is 100 and you use the show running-config command, the payload-type parameter does not appear in the output.

codec—Used to specify the type of codec.

g711ulaw—Specifies the G.711 u-law codec type.

g711alaw—Specifies the G.711 a-law codec type.

Use the same codec type for the originating and terminating gateways: g711ulaw codec is required for T1; g711alaw codec is required for E1.

redundancy—(Optional) Specifies redundant packets for modem traffic.


Verifying Modem Passthrough

To verify that modem passthrough is enabled, use the following commands:

show running-config to verify the configuration

show dial-peer voice to verify that modem passthrough over VoIP is enabled

Troubleshooting Tips for Modem Passthrough

To troubleshoot modem passthrough, perform the following checks:

Ensure that you can make a voice call.

Ensure that modem passthrough over VoIP is configured on both the originating gateway and the terminating gateway.

Ensure that the originating and terminating gateways have the same NSE payload-type number.

When two gateways are configured in voice-service configuration mode, ensure that the originating and terminating gateways have the same maximum-sessions value.

Use the debug vtsp dsp and debug vtsp session commands to debug a problem.

Monitoring and Maintaining Modem Passthrough

To monitor and maintain modem passthrough, use the following commands in privileged EXEC mode, as needed:

Command
Purpose

Router# show call active voice [brief]

Displays the voice information for the active call table. The brief keyword displays a truncated version.

Router# show call history voice [brief]

Displays the voice information for the call history table. The brief keyword displays a truncated version.

Router# show dial-peer voice [number | summary]

Displays configuration information for dial peers. The keywords and arguments are as follows:

number—Specifies a specific dial peer from 1 to 32767.

summary—Displays a summary of all dial peers.


Modem Transport Support Configuration Examples

This section provides the following specific configuration examples for modem support:

Modem Call Status Configuration Example

Modem Passthrough Configuration Example

Modem Call Status Configuration Example

The following example shows sample configuration output with DS-0 busyout traps enabled:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
aaa new-model
aaa authentication ppp default group radius
enable password <password>
!
spe 1/0 1/7
 firmware location system:/ucode/mica_port_firmware
spe 2/0 2/7
 firmware location system:/ucode/mica_port_firmware
!
resource-pool disable
!
clock timezone PDT -8
clock calendar-valid
no modem fast-answer
modem country mica usa
modem link-info poll time 60
modem buffer-size 300
ip subnet-zero
!
isdn switch-type primary-5ess
isdn voice-call-failure 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-fgb
 cas-custom 0
!
interface Loopback0
 ip address 10.5.4.1
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface Serial0:23
 no ip address
 ip mroute-cache
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 ip address 10.5.4.1
 duplex full
 speed auto
 no cdp enable
!
interface Group-Async1
 ip unnumbered FastEthernet0
 encapsulation ppp
 ip tcp header-compression passive
 no ip mroute-cache
 async mode interactive
 peer default ip address pool swattest
 no fair-queue
 ppp authentication chap
 ppp multilink
 group-range 1 192
!
interface Dialer1
 ip unnumbered FastEthernet0
 encapsulation ppp
 ip tcp header-compression passive
 dialer-group 1
 peer default ip address pool swattest
 pulse-time 0
 no cdp enable
!
ip local pool swattest 10.5.4.1
ip default-gateway 10.5.4.1
ip classless
!
dialer-list 1 protocol ip permit
snmp-server engineID local 00000009020000D058890CF0
snmp-server community public RO
snmp-server packetsize 2048
snmp-server enable traps pop
snmp-server host 10.5.4.1 public
!
radius-server host 10.5.4.1 auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key <password>
!
line con 0
 transport input none
line 1 192
 autoselect ppp
 modem InOut
 transport preferred none
 transport input all
 transport output none
line aux 0
line vty 0 4

end

Modem Passthrough Configuration Example

The following example shows a sample configuration for modem passthrough:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
voice service voip 
 modem passthrough nse codec g711ulaw redundancy maximum-session 5
!
resource-pool disable
!
ip subnet-zero
ip ftp source-interface Ethernet0
ip ftp username lab
ip ftp password lab
no ip domain-lookup
!
isdn switch-type primary-5ess
cns event-service server
!
mta receive maximum-recipients 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 shutdown
 clock source line secondary 1
!
interface Ethernet0
 ip address 1.1.2.2 255.0.0.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0:23
 no ip address
 encapsulation ppp
 ip mroute-cache
 no logging event link-status
 isdn switch-type primary-5ess
 isdn incoming-voice modem
 no peer default ip address
 no fair-queue
 no cdp enable
 no ppp lcp fast-start
!
interface FastEthernet0
 ip address 26.0.0.1 255.0.0.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 duplex full
 speed auto
 no cdp enable
!
ip classless
ip route 17.18.0.0 255.255.0.0 1.1.1.1
no ip http server
!
voice-port 0:D
!
dial-peer voice 1 pots
 incoming called-number 55511..
 destination-pattern 020..
 direct-inward-dial
 port 0:D 
 prefix 020
!
dial-peer voice 2 voip
 incoming called-number 020..
 destination-pattern 55511..
 modem passthrough nse codec g711ulaw redundancy
 session target ipv4:26.0.0.2
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end