Cisco IOS Voice, Video, and Fax Configuration�Guide, Release�12.2
Configuring MGCP and Related Protocols
Downloads: This chapterpdf (PDF - 288.0KB) The complete bookPDF (PDF - 9.14MB) | Feedback

Configuring Media Gateway Control Protocol and Related Protocols

Table Of Contents

Configuring Media Gateway Control Protocol and Related Protocols

MGCP Configuration Overview

Supported Gateways

Residential Gateway

Trunking Gateway

MGCP Prerequisite Tasks

MGCP Configuration Task List

Configuring a TGW for MGCP

Configuring a TGW for SGCP

Configuring an RGW

Configuring the Cisco Voice Gateway 200 to Support Cisco CallManager

Verifying the TGW or RGW Configuration

Blocking New Calls and Gracefully Terminating Existing Calls

Monitoring and Maintaining MGCP

MGCP Configuration Examples

Configuring the Cisco AS5300 As a TGW with MGCP: Example

Configuring the Cisco AS5300 As a TGW with SGCP: Example

Configuring the Cisco 3660 as a TGW with MGCP: Example

Configuring the Cisco uBR924 as an RGW: Example

Configuring the Cisco 2620 as an RGW: Example

Configuring the Cisco Voice Gateway 200 as an RGW: Example


Configuring Media Gateway Control Protocol and Related Protocols


This chapter describes the concepts and configuration procedures for Media Gateway Control Protocol (MGCP). MGCP defines the call control relationship between VoIP gateways that translate audio signals to and from the packet network, and call agents (CAs). The CAs are responsible for processing the calls.


Note An earlier implementation of the protocol, Simple Gateway Control Protocol (SGCP), is no longer available as a standalone product. MGCP supports SGCP functionality for those customers who want SGCP capabilities. For more information on SGCP, see Simple Gateway Control Protocol Support on the Cisco MC3810 and Cisco 3600 Series Routers.


This chapter includes the following sections:

MGCP Configuration Overview

MGCP Prerequisite Tasks

MGCP Configuration Task List

MGCP Configuration Examples

Cisco IOS Release 12.2 supports the MGCP 0.1, SGCP 1.1+, SIP, and H.323 protocols on these platforms:

Cisco 2600 series modular access routers

Cisco 3640 and Cisco 3660 multiservice platforms

Cisco AS5300 universal access server

Cisco uBR924 cable access router

Cisco Voice Gateway 200 (VG200)

For a complete description of the commands used in this chapter, refer to the Cisco IOS Voice, Video, and Fax Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

To identify the hardware platform or software image information associated with a feature in this chapter, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

MGCP Configuration Overview

MGCP is an extension of the earlier version of the protocol SGCP and supports SGCP functionality in addition to several enhancements. Systems using SGCP can easily migrate to MGCP, and MGCP commands are available to enable the SGCP capabilities.

An MGCP gateway handles the translation between audio signals and the packet network. The gateways interact with a CA, also called a Media Gateway Controller (MGC) that performs signal and call processing on gateway calls. In the MGCP configurations that Cisco IOS supports, the gateway can be a Cisco router, access server, or cable modem, and the CA is a server from a third-party vendor.

Configuration commands for MGCP define the path between the call agent and the gateway, the type of gateway, and the type of calls handled by the gateway.

MGCP uses endpoints and connections to construct a call. Endpoints are sources of or destinations for data, and can be physical or logical locations in a device. Connections can be point-to-point or multipoint.

Similar to SGCP, MGCP uses UDP for establishing audio connections over IP networks. However, MGCP also uses hairpinning to return a call to the PSTN when the packet network is not available.

Creating a call connection involves a series of signals and events that describe the connection process. This information might include such indicators as the off-hook status, a ringing signal, or a signal to play an announcement. These events and signals are specific to the type of endpoint involved in the call.

MGCP groups these events and signals into packages. A trunk package, for example, is a group of events and signals relevant to a trunking gateway, while an announcement package groups events and signals for an announcement server. MGCP supports seven package types that are as follows:

Trunk

Line

Dual-tone multifrequency (DTMF)

Generic media

Real-time Transport Protocol (RTP)

Announcement server

Script

The trunk package and line package are supported by default on certain types of gateways. Although configuring a gateway with additional endpoint package information is optional, you may want to specify the packages for your endpoints to add to or to override the defaults.

MGCP provides the following benefits:

Alternative dial tone for voice over IP environments—Deregulation in the telecommunications industry gives competitive local exchange carriers (CLECs) opportunities to provide toll bypass from the incumbent local exchange carriers (ILECs) by using VoIP. MGCP enables a VoIP system to control call setup and teardown and CLASS features for less sophisticated gateways.

Configuration requirements for static VoIP network dial peers has been removed—When MGCP is used as the call agent in a VoIP environment, configuring static VoIP network dial peers is not required, and so the configuration is simplified. The MGCP call agent provides functions similar to VoIP network dial peers.


Note POTS dial peer configuration is still required.


Migration paths—Systems using earlier versions of the protocol can migrate easily to MGCP.

Multiple protocols support and investment protection—Cisco IOS Release 12.2 supports concurrently on the same hardware and software the MGCP Version 0.1, SGCP 1.1+, SIP, and H.323 protocols. VoIP solutions can use any of these popular protocols. Changing protocols for new network solutions can be done without disrupting the current network or investing in new systems.

Varied network needs supported as follows:

IXCs that have no legacy TDM equipment in their networks and want to deploy a fully featured network that offers both long-distance services to corporate customers and connectivity to local exchange carriers or other IXCs with traditional TDM equipment.

IXCs who have TDM equipment in their networks and want to relieve the congestion in the network using data technologies to carry voice traffic or to cap the growth of TDM ports. In these situations, the packet network provides basic switched trunking without services or features.

Competitive CLECs who want to provide residential and enhanced services.

Dial access customers who want enhanced SS7 access capabilities and increased performance, reliability, scalability, and lower costs.

Supported Gateways

MGCP supports residential and trunking gateways and each gateway is described in the following sections.

Residential Gateway

A residential gateway (RGW) provides an interface between analog (RJ-11) calls from a telephone and the VoIP network. Examples of RGWs include cable modems and the Cisco 2600 series routers. See Figure 37 for an illustration of an RGW configuration.

Figure 37 Residential and Trunking Gateways

RGW functionality supports analog POTS calls for both SGCP and MGCP on the Cisco 2600 series routers and Cisco uBR924 cable access router:

Call waiting and stutter dial tone are supported on the Cisco 2600 series router and Cisco uBR924 cable access router.

On-hook caller ID, distinctive ringing, and ring splash are supported only on the Cisco uBR924 cable access router.

A default call agent address can be specified for each FXS port on the Cisco uBR924 cable access router.

Modem and fax calls are supported on the Cisco 2600 series router and Cisco  uBR924 cable access router.

Trunking Gateway

A trunking gateway (TGW) provides an interface between trunks on the public switched telephone network (PSTN) and a VoIP network. A trunk can be a DS0, T1, or E1 line. Examples of TGWs include access servers and routers. See Figure 38 for an illustration of a TGW configuration.

Figure 38 Trunking Gateways

TGW functionality supports SGCP and MGCP on the following platforms:

Cisco AS5300 universal access servers and the Cisco 3660 router for SS7 calls.

Cisco AS5300 universal access servers with SGCP 1.1+ protocol for Feature Group D Operator Services (FGD-OS) 911 outgoing calls on T1 lines.

Cisco AS5300 universal access servers for PRI/ISDN signaling. These calls are backhauled to the CA.

Cisco AS5300 universal access servers and Cisco 3660 routers for T1 and E1 interfaces.

Cisco AS5300 universal access servers and Cisco 3660 routers for modem and fax calls.

MGCP Prerequisite Tasks

Complete the following tasks on your network before configuring MGCP:

Configure IP routing.

Configure voice ports.

Configure VoIP.

Configure the call agent.

MGCP Configuration Task List

To configure MGCP, perform the tasks in the following sections. Each task in the list is identified as either optional or required.

Do at least one of the following tasks, depending on your network configuration (required):

Configuring a TGW for MGCP

Configuring a TGW for SGCP

Configuring an RGW

Verifying the TGW or RGW Configuration

Blocking New Calls and Gracefully Terminating Existing Calls (optional)

Monitoring and Maintaining MGCP (optional)


Note RGWs are configured only with MGCP.


Configuring a TGW for MGCP

To configure a TGW for MGCP, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Step 2 

Router(config)# mgcp call-agent [ipaddr|hostname] [port] service-type mgcp

Specifies the call agent's IP address or domain name, the port, and gateway control service type. The keywords and arguments are as follows:

ipaddr—Call agent's IP address.

hostname—Call agent's hostname, using the format host.domain.ext.

port—Port for the call agent to use. Valid values are from 1025 through 65535.

service-typeType of gateway control service supported by the call agent. Valid values are mgcp and sgcp. For MGCP configurations, use mgcp.

Step 3 

Router(config)# controller t1 number

Specifies the channel number of the T1 trunk to be used for analog calls.

Step 4 

Router(config-controller)# ds0-group 
channel-number timeslots range type none 
service mgcp

Configures the channelized T1 time slots to accept the analog calls. The keywords and arguments are as follows:

channel-number—DS0 group number. Valid values are from 0 to 23 for T1 interfaces and from 0 to 30 for E1 interfaces.

timeslots range—DS0 time slot range of values. Valid values are from 1 to 24 for T1 interfaces and from 1 to 31 for E1 interfaces. The default value is 24.

typeSignaling type to be applied to the selected group. For MGCP functionality, use none.

service—Type of service supported on the gateway. Valid values are mgcp and sgcp. For MGCP configurations, use mgcp.

Step 5 

Router(config-controller)# exit

Exits controller configuration mode and returns to global configuration mode.

Step 6 

Router(config)# mgcp restart-delay value

(Optional) Specifies the delay value sent in the RSIP graceful teardown method. The value range is from 0 to 600 seconds; the default is 0.

Step 7 

Router(config)# mgcp package-capability {s-package | dtmf-package | gm-package | rtp-package | trunk-package | script-package}

(Optional) Specifies the event packages that are supported on the gateway. The set of supported packages varies with the type of gateway (TGW or RGW). The keywords are as follows:

as-package—Announcement server package.

dtmf-package—DTMF package.

gm-package—Generic media package.

rtp-package—RTP package.

trunk-package (default)—Trunk package.

script-package—Script package. Available only on the Cisco AS5300 universal access server.

Step 8 

Router(config)# mgcp default-package {as-package | dtmf-package | gm-package | rtp-package | trunk-package}

(Optional) Specifies the event package that should act as the default. Overrides the mgcp package-capability default package.

Step 9 

Router(config)# mgcp dtmf-relay {codec | low-bit-rate} mode {cisco | out-of-band}

(Optional) Used for relaying digits through the IP network. The keywords and arguments are as follows:

codec—G.711 or a G.726 codec.

low-bit-rate—Low-bit-rate codec other than G.711 and G.726.

cisco—Removes DTMF tone from the voice stream and sends FRF.11 with special payload 121 for DTMF digits.

out-of-band—Removes DTMF tone from the voice stream and does not send FRF.11.

The default is no mgcp dtmf-relay for all codecs.

Step 10 

Router(config)# mgcp modem passthru {cisco | ca}

(Optional) Configures the gateway for modem and fax data.The keywords and arguments are as follows:

cisco—Switching to the G.711 codec when the gateway detects a modem or fax tone to allow the analog data to pass-through.

ca (default)—Switching to the CA that switches to G.711 codec when the gateway detects a modem or fax tone to allow the analog data to pass through.

The no form of the command disables support for modem and fax data.

Step 11 

Router(config)# mgcp sdp simple

(Optional) Specifies use of a subset of the session description protocol (SDP). Some call agents require this subset to send data through the network. The default is no mgcp sdp simple.

Configuring a TGW for SGCP

To configure a TGW for SGCP, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Step 2 

Router(config)# mgcp call-agent [ipaddr | hostname] [port] service-type sgcp

Specifies the call agent's IP address or domain name, the port, and gateway control service type. The keywords and arguments are as follows:

ipaddr—Call agent's IP address.

hostname—Call agent's hostname, using the format host.domain.ext.

port—Port for the call agent to use. Valid values are from 1025 through 65535.

service-typeType of gateway control service supported by the call agent. Valid values are mgcp and sgcp. For SGCP configurations, use sgcp.

Step 3 

Router(config)# controller t1 number

Specifies the channel number of the T1 trunk to be used for analog calls.

Step 4 

Router(config-controller)# ds0-group channel-number timeslots range type {none | fgdos} [tone_type] [addr_info] service {sgcp | voice}

Configures the channelized T1 time slots to accept the analog calls. For type none, use service sgcp. For type fgdos, use service voice.

 

The keywords and arguments are as follows:

channel-number—DS0 group number. Valid values are 1 to 23 for T1 interfaces and from 0 to 30 for E1 interfaces.

timeslots range—DS0 time slot range of values. Valid values are from 1 to 24 for T1 interfaces and from 1 to 31 for E1 interfaces. The default value is 24.

 

typeSignaling type to be applied to the selected group. For SGCP functionality, use none or fgdos.

tone_type—Tone type supported by the signaling type. For signaling type fgdos, the valid value is mf. This parameter is available if type is fgdos.

 

addr_info—Calling and called party numbers are used. For type fgdos, the valid value is dnis-ani. This parameter is available if type is fgdos.

 

service—Type of service on the gateway. For SGCP configurations, valid values are sgcp or voice. For signaling type none, use sgcp. For signaling type fgdos, use voice.

Configuring an RGW

To configure an RGW, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# mgcp

Initiates the MGCP application.

Note RGWs are configured only with MGCP.

Step 2 

Router(config)# mgcp call-agent [ipaddr | hostname] [port] service-type mgcp

Specifies the call agent IP address or domain name, the port, and gateway control service type. The keywords and arguments are as follows:

ipaddr—Call agent's IP address.

hostname—Call agent's hostname, using the format host.domain.ext.

port—Port for the call agent to use. Valid values are from 1025 through 65535.

service-typeType of gateway control service supported by the call agent. Valid values are mgcp or sgcp. For MGCP configurations, use mgcp.

Step 3 

Router(config)# dial-peer voice number pots

Sets up the dial peer for a voice port.

Step 4 

Router(config-dial-peer)# application MGCPAPP

Selects the MGCP application to run on the voice port.

Step 5 

Router(config-dial-peer)# exit

Exits dial peer configuration mode and returns to global configuration mode.

Step 6 

Router(config)# mgcp package-capability {line-package | dtmf-package | gm-package | rtp-package}

(Optional) Specifies the event packages that are supported on the gateway. The set of supported packages varies with the type of gateway (TGW or RGW). The keywords are as follows:

line-package (default)—Line package.

dtmf-package—DTMF package.

gm-package—Generic media package.

rtp-package—RTP package.

Step 7 

Router(config)# mgcp default-package [line-package | dtmf-package | gm-package]

(Optional) Specifies the event package that should act as the default. Overrides the mgcp package-capability command.

Configuring the Cisco Voice Gateway 200 to Support Cisco CallManager

The Cisco Voice Gateway 200 functions as an RGW and uses the configuration steps shown in the Configuring an RGW section. In addition, the Cisco Voice Gateway 200 has the capability of using MGCP with Cisco CallManager for administration and redundant call agent features. This capability requires additional configuration steps.

To configure the Cisco Voice Gateway 200 so it can be controlled by Cisco CallManager using MGCP, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# ccm-manager MGCP

Enables support for Cisco CallManager within MGCP.

Step 2 

Router(config)# ccm-manager redundant host hostname1 hostname2

Identifies one or two backup Cisco CallManager servers. The arguments hostname1 and hostname2 specify the first and second backup servers, respectively, using the dotted decimal format.

Step 3 

Router(config)# ccm-manager switchback {graceful | immediate | schedule-time hh:mm | uptime-delay minutes}

Specifies how the gateway behaves if the primary server becomes unavailable and later becomes available again. The keywords and arguments are as follows:

graceful—Completes all outstanding calls before returning the gateway to the control of the primary Cisco CallManager server.

immediate—Returns the gateway to the control of the primary Cisco CallManager server without delay, as soon as the network connection to the server is reestablished.

schedule-time hh:mm—Returns the gateway to the control of the primary Cisco CallManager server at the specified time, where hh:mm is the time according to a 24-hour clock. If the gateway reestablishes a network connection to the primary server after the configured time, the switchback will occur at the specified time on the following day.

uptime-delay minutes—Returns the gateway to the control of the primary Cisco CallManager server when the primary server runs for a specified number of minutes after a network connection is reestablished to the primary server. Valid values are from 1 to 1440 (from 1 minute to 24 hours).

To force the Cisco Voice Gateway 200 to use the backup Cisco CallManager server, use the following command in privileged EXEC mode:

Command
Purpose

Router# ccm-manager switchover-to-backup

Redirects the Cisco Voice Gateway 200 gateway to the backup Cisco CallManager server.

Verifying the TGW or RGW Configuration

To verify the configuration settings for all platforms and protocols, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# show running-config

Displays the current configuration settings.

Step 2 

Router(config)# show ccm-manager

Displays the current configuration settings on the Cisco Voice Gateway 200.

Blocking New Calls and Gracefully Terminating Existing Calls

You can block all new MGCP calls to the router and gracefully terminate all existing active calls, which means that an active call is not terminated until the caller hangs up. To block all new calls, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# mgcp block-newcalls

Prevents the gateway from accepting new calls.

Step 2 

Router(config)# no mgcp block-newcalls

Restarts normal MGCP call operation.

Monitoring and Maintaining MGCP

To monitor the MGCP configuration, use the following commands in privileged EXEC mode:

 
Command
Purpose

Step 1 

Router# show mgcp [connection | endpoint | statistics]

Displays all active MGCP connections on the router.

Step 2 

Router# debug mgcp [all | errors | events | packets | parser]

Turns on debugging for the gateway.

Step 3 

Router# clear mgcp statistics

Resets the MGCP statistical counters.

MGCP Configuration Examples

This section provides configuration examples for each of the supported platforms:

Configuring the Cisco AS5300 As a TGW with MGCP: Example

Configuring the Cisco AS5300 As a TGW with SGCP: Example

Configuring the Cisco 3660 as a TGW with MGCP: Example

Configuring the Cisco uBR924 as an RGW: Example

Configuring the Cisco 2620 as an RGW: Example

Configuring the Cisco Voice Gateway 200 as an RGW: Example

Configuring the Cisco AS5300 As a TGW with MGCP: Example

The following example illustrates a configuration only for MGCP calls. FGD-OS calls are not supported.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
resource-pool disable
!
ip subnet-zero
ip ftp username smith
ip host B 209.165.200.225
ip host C 209.165.200.226
ip domain-name cisco.com
ip name-server 209.165.202.129
!
mgcp
mgcp request timeout 10000
mgcp call-agent 192.168.10.10 2302 
mgcp restart-delay 5
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability trunk-package
mgcp package-capability rtp-package
mgcp package-capability as-package
mgcp package-capability mf-package
mgcp package-capability script-package
mgcp default-package trunk-package
mta receive maximum-recipients 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 2
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 3
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
voice-port 0:0
!
voice-port 1:0
!
voice-port 2:0
!
voice-port 3:0
!
interface Ethernet0
 ip address 192.168.10.9 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 172.22.91.73 255.255.255.0
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.22.91.1
ip route 209.165.200.225 255.255.255.255 192.168.0.1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring the Cisco AS5300 As a TGW with SGCP: Example

The following example illustrates a configuration that supports MGCP and FGD-OS calls:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
resource-pool disable
!
ip subnet-zero
ip ftp username smith
ip host B 209.165.200.225
ip host C 209.165.200.226
ip domain-name cisco.com
ip name-server 209.165.202.129
!
mgcp
mgcp request timeout 10000
mgcp call-agent 192.168.10.10 2302 sgcp
mta receive maximum-recipients 0
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 1
 framing esf
 clock source line secondary 1
 linecode b8zs
 ds0-group 0 timeslots 1-24 type fgd-os mf dnis-ani service voice
!
controller T1 2
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
controller T1 3
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type none service mgcp
!
!voice-port 0:0
!
voice-port 1:0
!
voice-port 2:0
!
voice-port 3:0
!
interface Ethernet0
 ip address 192.168.10.9 255.255.255.0
 no ip directed-broadcast
!
interface FastEthernet0
 ip address 172.22.91.73 255.255.255.0
 no ip directed-broadcast
 shutdown
 duplex auto
 speed auto
!
no ip classless
ip route 0.0.0.0 0.0.0.0 172.22.91.1
ip route 209.165.200.225 255.255.255.255 192.168.0.1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring the Cisco 3660 as a TGW with MGCP: Example

The following example illustrates a platform that does not support FGD-OS calls.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
memory-size iomem 40
voice-card 1
!
ip subnet-zero
!
mgcp 4000
mgcp call-agent 209.165.202.129 4000 
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability rtp-package
mgcp package-capability as-package
isdn voice-call-failure 0
cns event-service server
!
controller T1 1/0
 framing esf
 clock source internal
 ds0-group 1 timeslots 1-24 type none service mgcp
!
controller T1 1/1
 framing esf
 clock source internal
 ds0-group 1 timeslots 1-24 type none service mgcp
!
voice-port 1/0:1
!
voice-port 1/1:1
!
interface FastEthernet0/0
 ip address 209.165.202.140 255.255.255.0
 no ip directed-broadcast
 load-interval 30
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 load-interval 30
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 209.165.202.130
ip classless
ip route 209.165.200.225 255.255.255.255 FastEthernet0/0
no ip http server
!
snmp-server engineID local 00000009020000107BD8CD80
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring the Cisco uBR924 as an RGW: Example

The following example illustrates a platform that does not support FGD-OS calls.

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname A
!
logging buffered 200000 debugging
!
clock timezone - -8
ip subnet-zero
no ip routing
no ip domain-lookup
ip host A 192.168.147.91
ip host C 209.165.200.224
ip host D 209.165.200.225
!
mgcp
mgcp call-agent 192.168.10.10 2490 
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability line-package
mgcp default-package line-package
!
voice-port 0
 input gain -3
!
voice-port 1
 input gain -3
!
dial-peer voice 1 pots
 application MGCPAPP
 port 1
!
dial-peer voice 2 pots
 application MGCPAPP
 port 0
!
interface Ethernet0
 ip address 192.168.147.91 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface cable-modem0
 ip address negotiated
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 cable-modem downstream saved channel 459000000 20
cable-modem downstream saved channel 699000000 19 2
 cable-modem mac-timer t2 100000
 no cable-modem compliant bridge
 bridge-group 59
 bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.1
ip classless
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line vty 0 4
 login
!
end

Configuring the Cisco 2620 as an RGW: Example

The following example illustrates a platform that does not support FGD-OS calls.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname D
!
memory-size iomem 10
ip subnet-zero
!
mgcp
mgcp call-agent 172.20.5.20 
mgcp package-capability gm-package
mgcp package-capability dtmf-package
mgcp package-capability line-package
mgcp package-capability rtp-package
mgcp default-package line-package
cns event-service server
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer voice 1 pots
 application MGCPAPP
 port 1/0/0
!
dial-peer voice 2 pots
 application MGCPAPP
 port 1/0/1
!
interface Ethernet0/0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Ethernet0/1
 ip address 172.20.5.25 255.255.255.0
 no ip directed-broadcast
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
ip default-gateway 209.165.202.130
ip classless
ip route 209.165.200.225 255.255.255.224 Ethernet0/1
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

Configuring the Cisco Voice Gateway 200 as an RGW: Example

The following example illustrates the configuration of the Cisco Voice Gateway 200 as an RGW.

version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname MainVG200
!
ip subnet-zero
no ip finger
ip host dirt 172.16.1.129
!
mgcp
mgcp call-agent 172.20.71.44
call rsvp-sync
!
ccm-manager switchback immediate
ccm-manager redundant-host 172.20.71.47
ccm-manager mgcp
!
interface FastEthernet0/0
  ip address 172.21.10.14 255.255.255.0
  duplex auto
  speed auto
!
ip default-gateway 172.21.10.1
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 172.16.0.0 255.255.0.0 172.20.82.1
no ip http server
!
access-list 199 permit udp any any range 16384 32766
access-list 199 permit ip host 10.51.26.6 any
access-list 199 permit ip host 10.51.16.7 any
queue-list 2 protocol ip 2 list 199
queue-list 2 default 5
queue-list 2 queue 2 byte-count 2880 limit 16
queue-list 2 queue 5 limit 1
priority-list 1 protocol ip high list 199
priority-list 1 default low
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
!
dial-peer voice 111 pots
  application mgcpapp
  port 1/1/1
!
gateway
!
line con 0
  exec-timeout 0 0
  transport input none
line aux 0
line vty 0 4
  password lab
  login
!
end