Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2
Appendix C-Cisco Hoot and Holler over IP
Downloads: This chapterpdf (PDF - 400.0KB) The complete bookPDF (PDF - 9.14MB) | Feedback

Cisco Hoot and Holler over IP

Table Of Contents

Cisco Hoot and Holler over IP

Hoot and Holler over IP Overview

Current Hoot and Holler Implementations

Cisco Hoot and Holler over IP Overview

Voice Multicasting

IP/TV Access

Interactive Voice Response

Migration Strategy

Technical Details of the Cisco Hoot and Holler over IP Solution

IP Multicast and DSP Arbitration and Mixing

Bandwidth Planning

Virtual Interface

Connection Trunk

Cisco Hoot and Holler over IP Restrictions

Configuration Tasks

Configuring Multicast Routing

Configuring the Virtual Interface

Configuring VoIP Dial Peers

Configuring E&M Voice Ports

Configuring for Receive Only Mode

Configuring Relevant Interface (Serial/Ethernet)

Configuring Voice Ports in High-Density Voice Network Modules

Configuration Examples

Voice Multicasting over an Ethernet LAN

Configuring the Second Router

Verifying the Configuration

High-Density Voice Modules

Dial-Peer Configuration

Ethernet Configuration

Voice Multicasting over a WAN

Quality of Service

Cisco Hoot and Holler over IP with Ethernet Topology (Two Hoot Groups)

Router-1 (E&M Four-Wire Ports)

Router-2 (FXS Ports)

Router-3 (FXO Ports)

Cisco Hoot and Holler over IP with Frame-Relay Topology (One Hoot Group)

Router-1

Router-2

Router-3


Cisco Hoot and Holler over IP


The voice multicasting feature on Cisco 2600 and 3600 series routers uses Cisco Voice over IP (VoIP) technology to create a permanently connected point-to-multipoint hoot and holler network over an IP connection.

This appendix describes the Cisco hoot and holler over IP feature and contains the following sections:

Hoot and Holler over IP Overview

Cisco Hoot and Holler over IP Overview

Configuration Tasks

Configuration Examples

To identify the hardware platform or software image information associated with a feature in this appendix, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the softsware release notes for a specific release. For more information, see the "Identifrying Supported Platforms" section in the "Using Cisco IOS Software" chapter.

Hoot and Holler over IP Overview

Four-wire ear and mouth (E&M), E1/T1, Foreign Exchange Office (FXO), and Foreign Exchange Station (FXS) configurations provide continuous VoIP connections across a packet network using the connection-trunk mechanism. By using the inherent point-to-multipoint connectivity of IP multicast (IPmc), the routers can take several inbound voice streams from the traditional hoot devices and forward the packetized voice over the IP network to all parties within a defined hoot and holler group.

Hoot and holler networks provide "always on" multiuser conferences without requiring that users dial into a conference. These networks came into being more than 40 years ago when local concentrations of small specialized businesses with common, time-critical informational interests began to install their own phone wires, speakers (called "squawk boxes"), and microphones between their businesses to ask each other about parts that customers needed. These networks functioned as crude, do-it-yourself, business-to-business intercom systems.

Hoot and holler broadcast audio network systems have since evolved into the specialized leased-line networks used by financial and brokerage firms to trade stocks and currency futures and the accompanying time-critical information such as market updates and morning reports.

Users of various forms of hoot and holler networks now include brokerages, news agencies, publishers, weather bureaus, transportation providers, power plant operators, manufacturers, collectibles dealers, talent agencies, and nationwide salvage yard organizations.

Hoot and holler is used in these various industries as a way to provide a one-to-many or many-to-many conferencing service for voice communications. In the past, hoot and holler was deployed using point-to-point telephone company circuits and a hoot and holler bridging and mixing functionality that was provided either by the customer or as a service of the Public Switched Telephone Network (PSTN) carrier.

A common use of hoot and holler is a broadcast audio network that is used throughout the brokerage industry to communicate morning reports as well as to advise the trading community within a brokerage firm on market movements, trade executions, and so on. All users can talk simultaneously with each other, if desired.

But more commonly, a broker in a field office will "shout" an order to the trading floor. The shout ensures that the trading floor can hear the order and a floor trader can confirm the transaction. A typical brokerage firm has several of these networks for equity, retail, and bonds with network size and degree of interactivity varying depending on the application.

Within the financial community there are two general uses for hoot and holler networks:

Market updates—Market update (morning report) hoot networks tend to be active for an hour in the morning and inactive for the rest of the day.

Trading—Trading hoot networks tend to be more widely used throughout the trading day.

Both of these applications can reap significant advantages by running over an IP network because any idle bandwidth can be reclaimed by data applications.

Today most hoot and holler customers pay for separate leased-line charges from a common carrier to transport their hoot and holler to remote branch offices. This recurring charge is usually significant—some larger firms spend more than $2 million to $3 million per year just to distribute hoot and holler feeds.

Cisco's hoot and holler over IP feature:

Eliminates yearly reoccurring switched-circuit telephone company charges (toll-bypass)

Eliminates the need for leased lines and the accompanying charges

Reduces the need for hoot and holler bridges

Improves hoot and holler network manageability

Reduces the time to troubleshoot a problem from hours to minutes

Reduces the time to provision bandwidth from days to a few hours

Increases productivity through future applications (such as IP/TV and turret support)

Provides the ability to integrate voice, video, and data signaling capabilities

Cisco hoot and holler over IP is supported on Cisco 2600 and 3600 series routers and on NM-HDV, NMZV, and NM-2V network modules

For information about installing voice network modules and voice interface cards in Cisco 2600 and Cisco 3600 series routers, refer to the Cisco Network Module Hardware Installation Guide and the WAN Interface Card Hardware Installation Guide.

For information about configuring Voice over IP features, refer to the Software Configuration Guide for Cisco 3600 Series and Cisco 2600 Series Routers, to the Voice over IP Quick Start Guide, and to the "Voice over IP Overview" chapter in this configuration guide.

For further information about IP multicasting, refer to the IP Multicast Site at http://www.cisco.com/ipmulticast.

For further information about IP/TV, refer to the IP/TV Content Manager User Guide.

For further information about interactive voice response (IVR), refer to Configuring Interactive Voice Response for Cisco Access Platforms.

Current Hoot and Holler Implementations

Traditional hoot and holler networks (see Figure 131) are analog, multipoint, four-wire, audio-conference networks that are always up. When a user wants to communicate, the user pushes a button and speaks either through a microphone, a hoot phone, a turret, or a squawk box.

Figure 131 Traditional Hoot and Holler Network

Figure 131 illustrates a traditional hoot and holler network. Each remote location is connected to a central bridge using leased lines. Four-wire connections and N-1 bridges are used to avoid echo problems.

Hoot and holler networks are typically spread over four to eight sites although financial retail networks may have hundreds of sites interconnected. Within a site, bridging (mixing voice signals) is done locally with a standard analog or digital bridge that may be part of a trading turret system. Between sites, there are two prevalent methods for providing transport:

Point-to-point leased lines with customer-provided audio bridging at a central site

Carrier-provided audio bridging

When customers provide their own bridging services with point-to-point leased lines, branch offices in a metropolitan area commonly have 25 to 50 lines or more.

The second method, carrier-provided audio bridging, is prevalent within the United States but rare for overseas transport. In this scenario, the audio bridges are located at the carrier's central office and the four-wire lines are terminated at the client's site on a local audio-bridge equipped with four-wire plug-ins, which then feed to local public address (PA) system speakers. Customer-provided hoot bridging services can now be replaced with a Cisco hoot and holler over IP solution.

Cisco Hoot and Holler over IP Overview

Cisco's VoIP technology, which was initially focused on traditional PBX toll-bypass applications, can be used to combine hoot and holler networks with data networks. While some customers may have done some level of hoot and data integration in the late 1980s with time-division multiplexing (TDM), this form of integration does not allow for the dynamic sharing of bandwidth that is characteristic of VoIP.

This dynamic sharing of bandwidth is even more compelling with hoot and holler than with a toll-bypass application because some hoot circuits may be active for an hour or two for morning reports but dead for the rest of the day—the idle bandwidth can be used by the data applications during these long periods of inactivity.

Beginning with Cisco IOS Release 12.1(2)XH, Cisco hoot and holler over IP can be implemented using Cisco's VoIP technology. This solution leverages Cisco's IOS expertise in VoIP, quality of service (QoS), and IP multicasting (IPmc) and is initially available on Cisco 2600 and 3600 series multiservice routers.

Figure 132 shows a diagram of the Cisco hoot and holler over IP solution connecting legacy hoot equipment over an IP network.


Note The "V" on the Cisco router icons signifies that some of the hoot and holler bridging function is being done by the router's digital signal processors (DSPs).


Figure 132 Hoot and Holler over IP Using Cisco 2600 and Cisco 3600 Series Routers

Four-wire E&M, E1/T1, FXO, and FXS configurations provide continuous VoIP connections across a packet network. By using the inherent point-to-multipoint characteristic of IPmc, the routers can take several inbound voice streams from the traditional hoot devices and forward the packetized voice over the IP network to all parties within a defined hoot and holler group.

Voice Multicasting

The voice multicasting feature on Cisco 2600 and Cisco 3600 series routers uses Cisco VoIP technology to create a point-to-multipoint hoot and holler network over an IP connection.

You can connect voice multicasting telephones to routers in the following ways:

Connect a four-wire E&M telephone, which has no dial and is always off-hook, directly to an E&M voice interface card that is installed in a voice network module. Configure the E&M interface for four-wire trunk operation. For information about configuring E&M interfaces, see the chapter "Configuring Voice Ports" in this configuration guide.

Connect a conventional telephone to a PBX that is connected to an E&M voice interface card.

Connect a conventional telephone to an FXS voice interface card that is installed in a voice network module.

Connect a conventional telephone to a PBX that is connected through a E1/T1 line to a multiflex trunk interface card that is installed in a high-density voice network module.


Note The voice multicasting feature supports only one E1/T1 line per high-density voice network module.


IP/TV Access

The Cisco hoot and holler over IP feature enables you to access ongoing IP/TV multicasts for listening to voice content of the IP/TV session. For complete information on IP/TV, see the IP/TV Content Manager Installation and User Guide.

The following figure illustrates Cisco hoot and holler being used to access IP/TV multicasts:

Figure 133 Cisco Hoot and Holler over IP Access to IP/TV Multicast

For the Cisco hoot and holler over IP and IP/TX interaction to work correctly, do the following:

Ensure that you have properly connected and configured your network for VoIP. Enable the Cisco hoot and holler over IP feature using the session protocol multicast command.

Ensure that the server configured with the IP/TV Content Manager is in the same Ethernet network as the Cisco hoot and holler over IP functionality.

Ensure that the Cisco hoot and holler over IP multicast details are registered with the IP/TV Content Manager.


Note IP/TV support for Cisco hoot and holler over IP uses only G.711 u-law (mu-law) encoding.

IP/TV supports one audio stream for Cisco hoot and holler over IP.

IP/TV does not support arbitration and mixing.


Content Manager

On the configuration screen (Administration Tool>Scheduled Programs>New Program>Configuration), provide the following details:

Multicast address

RTP port—defined by the dial peer in the router

IP/TV server—IP address or name

From the Settings>Content Manager option, do the following:

Click Add New.

Enter the IP/TV server name.

Enter the port number. It must be 80 because it is HTTP.

Click OK and exit.


Note In Content Manager, be sure to specify the multicast IP address and RTP port for the Cisco hoot and holler over IP session.


Interactive Voice Response

The Cisco hoot and holler over IP feature can support interactive voice response (IVR) as a means of authentication, authorization, and accounting (AAA) control. See the "Configuring TCL IVR Applications" chapter in this configuration guide or refer to the Cisco IOS Voice, Video, and Fax Command Reference for more information.

Migration Strategy

To aid troubleshooting and allow for regionalized hoot and holler conferences, most hoot and holler networks today are structured by interconnecting multiple regional hoot networks with a centralized bridge. The regional hoot networks are built using either carrier-based multidrop circuits or point-to- point circuits bridged by the customer. All of these circuits are connected through patch panels that allow for these regional bridges to be connected for a larger corporate-wide conference call. This is typically done for the "morning call" that is broadcast to all locations, advising of market movements, recommendations, and commentary. Later in the day, the patch panel may be reconfigured to allow for local or regional conference bridges. This allows for multiple conference calls for various purposes, without provisioning multiple circuits. By segmenting the network into regions, troubleshooting is also easier because any audio disturbance, feedback, or level problems can be isolated to a smaller subset of remote offices for more specific troubleshooting.

The highly segmented nature of existing hoot and holler networks can be leveraged in the migration from legacy hoot technology to Cisco hoot and holler over IP. A small segment of the hoot network can be converted to Cisco hoot and holler over IP while preserving the operational procedures at the main office.

Note that the migration to Cisco hoot and holler over IP does not require replacing end-user equipment or central bridging equipment. The main impetus for this first phase of migration is to eliminate the recurring expense of carrier multidrop circuits or dedicated leased lines. Migration success is maximized by minimizing changes to the end user while realizing an attractive payback period on the capital costs.

As the entire hoot network converges with the data network, additional functionality can be introduced. Since the hoot and holler connections are now carried in standard multicast RTP packets, hoot channels can now be received by a soft client such as IP/TV, which can receive an IP multicast RTP stream. An alternate migration strategy is to use Cisco hoot and holler over IP technology initially as a backup for the existing hoot circuits within a region with a phased plan of cutting over to Cisco hoot and holler over IP as the primary transport while keeping the existing circuits as a backup for a predefined burn-in period.

Technical Details of the Cisco Hoot and Holler over IP Solution

This section describes how Cisco hoot and holler over IP works from a technical perspective. It covers design considerations in terms of IOS configurations and DSP mixing functionality. It also covers bandwidth planning and QoS, with the following assumptions:

That you have some level of Cisco IOS experience.

That you have some experience configuring QoS features using Cisco IOS software. For assistance, refer to the Cisco IOS IP and IP Routing Configuration Guide at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

That you have some experience configuring VoIP using Cisco IOS software. For assistance, refer to the Cisco IOS Voice over IP Overview at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fvvfax_c/vvfvoip.htm

That you have some experience configuring IP multicasting using Cisco IOS software. For assistance, refer to Cisco IOS Configuring IP Multicast Routing at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcpt3/

That you have a working IP network, with IP multicasting configured using the Cisco 2600 and Cisco 3600 series routers. For assistance, refer to the following documents at the Cisco Connection Online (CCO) Web site:

Cisco IOS Configuration Guides and Command References (http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/index.htm)

Cisco 2600 Series Routers (http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/index.htm)

Cisco 3600 Series Routers (http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/index.htm)

That you are familiar with Cisco IP/TV. For assistance, refer to Cisco IOS Software Configuration at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/webscale/iptv/

That you understand basic hoot and holler concepts and equipment.

IP Multicast and DSP Arbitration and Mixing

When deploying Cisco hoot and holler over IP, first consider how the voice streams are going to be mixed and how they will be distributed to other locations. This is done using a combination of two technologies:

IPmc

DSP arbitration and mixing

Since hoot and holler is generally used to allow many people to simultaneously talk and listen to other people within a hoot group, by definition it requires that the same speech be delivered to multiple parties at the same time. In an IP network, this functionality uses IPmc. IPmc allows a source to send a single packet into the IP network and have it duplicated and sent to many listeners by the other routers within the network. This technique is beneficial in that it does not require the source to know how many listeners there are, and the source does not have the additional processing burden of having to send a copy of each packet to all listeners. IPmc also allows listeners to dynamically join IPmc groups, which eliminates the administrative burden of new users needing to be added every time a new IPmc session is initiated.

The individual router/gateway can handle mixing and arbitrating the various voice streams that can be initiated or terminated on its voice ports. This functionality is handled by the onboard DSPs on each voice card (NM-1V, NM-2V, or NM-HDV). Arbitration involves identifying the various sources of the voice stream, and mixing involves taking some of those voice streams and combining them into a single-sourced voice stream. Cisco hoot and holler over IP can handle many inbound voice streams, but it only arbitrates and mixes three streams to be heard within the hoot group. This value works fine in most applications because, with more than three streams, two things happen in normal conversation:

People are not able to distinguish the content of more than three voice streams.

People normally stop speaking if they hear others talking ahead of them.


Note The mixing functionality does not do a summation of the voice streams.


The DSPs in the Cisco hoot and holler over IP feature can mix up to three streams. The mixing of the three streams is important to network administrators in considering how much bandwidth they should plan for in their Cisco hoot and holler over IP networks. This is especially crucial when planning for WAN bandwidth, which is often much more expensive and much less available than LAN bandwidth.

The advantage to this functionality is that a network administrator never has to be concerned about provisioning voice bandwidth for more than three times each call's bandwidth for each WAN site, which helps to simplify overall network planning.

Bandwidth Planning

Four main factors must be considered with regard to bandwidth planning for Cisco hoot and holler over IP:

Codecs used for VoIP (G.711, G.726, G.729, and G.729a are currently supported).

Bandwidth management techniques.

The number of voice streams to be mixed.

The amount of guaranteed bandwidth available on the IP network. This includes both LAN and WAN bandwidth and should take into consideration other factors, such as Frame Relay committed information rate.

Codecs

By default, Cisco IOS sends all VoIP traffic (media, using RTP) at a rate of 50 packets per second. The packets include not only the voice sample, but also an IP, User Datagram Protocol (UDP), and RTP header. The IP/UDP/RTP header adds an additional 40 bytes to each packet. The amount of bandwidth each VoIP call consumes depends on the codec selected. The resulting bandwidths can be as follows:

G.729 or G.729a = 3,000 bytes * 8 bits = 24 Kb/call

G.726 = 6,000 bytes * 8 bits = 48 Kb/call

G.711 = 10,000 bytes * 8 bits = 80 Kb/call

In addition to these calculations, network administrators must consider the Layer 2 headers (Frame Relay, PPP, Ethernet, and so on) and add the appropriate number of bytes to each packet.

In Table 58, the assumption is that the payload size (in bytes) is 20-millisecond samples per packet with 50 packets per second.

The value of n is equal to the number of voice streams in a session.

The uncompressed bandwidth includes IP/UDP/RTP headers (40 bytes) in the bandwidth calculation. Compressed RTP (cRTP) reduces the IP/UDP/RTP headers to between 2 to 4 bytes per packet. The calculation of compressed bandwidth below uses 4 bytes for a compressed IP/UDP/RTP header per packet.

Maximum RTP Control Protocol (RTCP) bandwidth is 5 percent of the total RTP traffic in a hoot and holler session. Since the Cisco hoot and holler over IP application supports mixing of a maximum of three voice streams, the RTCP bandwidth is limited to 5 percent of three-voice-stream traffic.

In addition to the above, Layer 2 headers (Frame Relay, Point-to-Point Protocol, Ethernet, and so on) should be considered and added to the bandwidth calculation.

Table 58 Bandwidth Consideration Table

Codec
Payload Size (byte)
Bandwidth/ Voice Stream (Kbps)
RTCP Bandwidth per
Cisco Hoot and Holler over IP Session (Kbps)
Example—One Voice Stream in a Session (Bandwidth in Kbps)
 

 

Uncompressed
Compressed

 

=(1)*n+(3)
=(2)*n+(3)
g.729

20

24

9.6

3.6

27.6

13.2

g.726

80

48

33.6

7.2

55.2

40.8

g.711

160

80

65.6

12.0

92.0

77.6


cRTP, Variable-Payload Sizes and VAD

Some network administrators may consider this amount of bandwidth per call unacceptable or outside the limits of the bandwidth they can provide, especially in the WAN. There are several options that network administrators have for modifying the bandwidth consumed per call:

RTP header compression (cRTP)

Adjustable byte size of the voice payload

Voice activity detection (VAD)

IP/UDP/RTP headers add an additional 40 bytes to each packet, but each packet header is basically unchanged throughout the call. Compressed RTP can be enabled for the VoIP calls, which reduces the IP/UDP/RTP headers from 2 bytes to 4 bytes per packet.

More information on cRTP may be found in the "Quality of Service Overview" chapter of the Cisco IOS Quality of Service Solutions Configuration Guide at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/qcfintro.htm

In addition to reducing the IP/UDP/RTP headers per packet, the network administrator also has the option of controlling how much voice payload is included in each packet. This is done using the bytes keyword and argument in a VoIP dial peer. The following example shows a dial-peer configuration:

dial-peer voice 1 voip
 destination-pattern 4085551234 
 codec g729r8 bytes 40
 session protocol multicast
 session target ipv4:239.10.108.252:20102
 

As the number of bytes per packet is modified, so too is the number of packets per second that are sent.

VAD enables the DSPs to dynamically sense when there are pauses in a conversation. When these pauses occur, no VoIP packets are sent into the network. This significantly reduces the amount of bandwidth used per VoIP call, sometimes as much as 40 percent to 50 percent. When voice is present, VoIP packets are again sent. When using Cisco hoot and holler over IP, VAD must be enabled to reduce the amount of processing of idle packets by the DSPs. In basic VoIP, VAD can be enabled or disabled, but since the DSPs also have to do arbitration and mixing, VAD must be disabled to reduce the DSPs' processing load. In addition to enabling VAD (which is only by default), network administrators should modify the VAD parameters that sense background noise so that idle noise does not consume bandwidth.

This can be configured as in the following E&M port example:

voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
voice-port 1/0/0
 voice-class permanent 1
 connection trunk 111
 music-threshold -30
 operation 4-wire

The configuration above is used for a voice port that is in send/receive mode, and only noise above -30Db is considered voice.

Virtual Interface

In all Cisco hoot and holler over IP implementations, the routers are configured with an "interface vif1." This is a virtual interface that is similar to a loopback interface—a logical IP interface that is always up when the router is active. In addition, it must be configured so the Cisco hoot and holler over IP packets that are locally mixed on the DSPs can be fast-switched along with the other data packets. This interface must reside on its own unique subnet, and that subnet should be included in the routing protocol updates (Routing Information Protocol [RIP], Open Shortest Path First [OSPF], and so on).

Connection Trunk

Cisco hoot and holler over IP provides an "always-on" communications bridge—end users do not need to dial any phone numbers to reach the other members of a hoot group. To simulate this functionality, Cisco IOS provides a feature called "connection trunk." Connection trunk provides a permanent voice call, without requiring any input from the end user, because all the digits are internally dialed by the router/gateway.

With traditional VoIP usages of connection trunk, the call is mapped to a remote router/gateway, and all the H.323 signaling is handled dynamically when the trunk is established. With hoot and holler over IP, the connection trunk is associated with the IP address of the IP multicast group that maps to the hoot group.

In addition, all negotiation of UDP ports for the audio stream is manually configured. The following example shows an E&M voice port connection trunk set up for Cisco hoot and holler over IP:

voice-port 1/0/0
 connection trunk 111
 music-threshold -30
 operation 4-wire
!
dial-peer voice 1 voip
 destination-pattern 111
 voice-class permanent 1
 session protocol multicast
 session target ipv4:237.111.0.0:22222
 ip precedence 5

In this example, the digits in the connection trunk 111 string match the destination pattern of the VoIP dial peer. Also, the session protocol is set to multicast and the session target is pointing to the IPmc group number, with the UDP port (22222) predefined.

Cisco Hoot and Holler over IP Restrictions

The restrictions for using Cisco hoot and holler over IP are as follows:

Cisco hoot and holler over IP supports the mixing of only three voice streams.

IP/TV does not support the mixing of audio streams.

IP/TV supports only G.711 u-law (mu-law).

Voice Interface Card Basic Rate Interface (VIC-BRI) is not supported.

Configuration Tasks

To configure Cisco hoot and holler over IP, perform the tasks in the following sections:

Configuring Multicast Routing (Required)

Configuring the Virtual Interface (Required)

Configuring VoIP Dial Peers (Required)

Configuring E&M Voice Ports (Required, if used)

Configuring for Receive Only Mode (Optional)

Configuring Relevant Interface (Serial/Ethernet) (Required)

Configuring Voice Ports in High-Density Voice Network Modules (Required, if using T1/E1)

Configuring Multicast Routing

To enable multicast routing, use the following commands beginning in global configuration mode:

Command
Purpose

Router(config)# ip multicast-routing

Enables multicast routing.

Configuring the Virtual Interface

To configure the virtual interface for multicast fast switching, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type number [name-tag]

Defines a virtual interface for multicast fast switching. Routers joining the same session must have their virtual interfaces on different subnets. Otherwise, packets are not switched to the IP network.

Step 2 

Router(config-if)# ip address ip-address mask 
[secondary]

Assigns the IP address and subnet mask for the virtual interface.

Step 3 

Router(config-if)# ip pim {dense-mode | sparse mode | 
sparse-dense-mode}

Specifies Protocol Independent Multicast (PIM). Whatever mode you choose should match all the interfaces in all the routers of your network.

Configuring VoIP Dial Peers

To configure the VoIP dial peers on the router, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# dial-peer voice tag voip

Assigns a variable number (tag) to the VoIP dial peer and enters dial-peer configuration mode.

Step 2 

Router(config-dial-peer)# destination-pattern 
[+]string[T]

Specifies the E.164 address associated with this dial peer. The destination pattern for the VoIP dial peer must match the value of the multicast-session-number string for the corresponding voice port.

The keywords and arguments are as follows:

+—(Optional) Specifies a character indicating an E.164 standard number. The plus sign (+) is not supported on the Cisco MC3810.

string—Indicates a series of digits that specify the E.164 or private dialing plan telephone number. Valid entries are the digits 0 through 9, the letters A through D, and the following special characters:

The asterisk (*) and pound sign (#)—Indicate the keys that appear on standard touch-tone dial pads.

Comma (,)—Inserts a pause between digits.

Period (.)—Matches any entered digit (this character is used as a wildcard).

Percent sign (%)—Indicates that the previous digit/pattern occurred zero or multiple times, similar to the wild card usage in the regular expression.

 

Plus sign (+)—Matches a sequence of one or more matches of the character/pattern.

Note The plus sign used as part of the digit string is different from the plus sign that can be used in front of the digit string to indicate that the string is an E.164 standard number.

Circumflex (^)—Indicates a match to the beginning of the string.

Dollar sign ($)—Matches the null string at the end of the input string.

Backslash symbol (\)—Is followed by a single character matching that character or used with a single character having no other significance (matching that character).

Question mark (?)— Indicates that the previous digit occurred zero or one time.

Brackets ([])—Indicates a range of digits. A range is a sequence of characters enclosed in the brackets, and only numeric characters from "0" to "9" are allowed in the range. This is similar to a regular expression rule.

Parentheses ( )—Indicates a pattern and is the same as the regular expression rule—for example, 408(555). Parentheses are used in conjunction with symbols ?, %, or +.

For more information on applying wildcard symbols to destination patterns and the dial strings that result, see the "Configuring Dial Plans, Dial Peers, and Digit Manipulation" chapter in this configuration guide.

T—(Optional) Control character indicating that the destination-pattern value is a variable length dial string.

Step 3 

Router(config-dial-peer)# session protocol multicast

This step is mandatory for voice multicasting and is the command introduced specifically for the Cisco hoot and holler over IP application.

Step 4 

Router(config-dial-peer)# session target

Assigns the session target for voice multicasting dial peers. This is a multicast address in the range of from 224.0.1.0 to 239.255.255.255 and must be the same for all ports in a session.

The audio RTP port is an even number in the range of from 16384 to 32767 and must also be the same for all ports in a session. An odd-numbered port (UDP port number + 1) is used for the RTCP traffic for that session.

Step 5 

Router(config-dial-peer)# ip precedence number

(Optional) Specifies the IP precedence.

Step 6 

Router(config-dial-peer)# codec

Configures the codec. You must configure the same codec on all dial peers in a session.

When the default codec g729r8 is used, it does not appear in the configuration when the show running-config command is used.

Configuring E&M Voice Ports

To configure E&M voice ports, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice class permanent tag

Defines voice class for transmit-receive mode.

Step 2 

Router(config-class)# signal timing oos timeout 
seconds disabled

Disables signaling loss detection. (Use the disabled keyword in hoot and holler applications. The seconds argument is not used in these applications.)

Step 3 

Router(config-class)# signal keepalive number

Specifies the keepalive signaling packet interval.

Step 4 

Router(config-class)# exit

Exits voice-class configuration mode.

Step 5 

Router(config)# voice-port 
{slot-number/subunit-number/port} | 
{slot/port:ds0-group-no}

Enters voice-port configuration mode and selects the voice port to configure.

Step 6 

Router(config-voice-port)# voice-class permanent tag

Assigns a previously configured voice class for a Cisco trunk or FRF.11 trunk to a voice port (for the port that is allowed to speak).

Step 7 

Router(config-voice-port)# connection {plar | tie-line 
| plar-opx} digits | {trunk digits [answer-mode]}

Ties the voice port to a multicast-session number. Use the trunk keyword to specify a connection that emulates a permanent trunk connection to a PBX. The digits argument specifies the destination telephone number. Valid entries are any series of digits that specify the E.164 telephone number.

Step 8 

Router(config-voice-port)# music-threshold number

(Optional) Sets the music threshold to make voice-activated dialing (VAD) less sensitive. The number argument is the on-hold music threshold in decibels (dB). Valid entries are any integer from -70 to -30.

Step 9 

Router(config-voice-port)# operation {2-wire | 4-wire}

Specifies the cabling scheme for E&M ports. The 2-wire keyword is the default.

(Choose 4-wire operation for the hoot and holler application.)

Step 10 

Router(config-voice-port)# type {1 | 2 | 3 | 5}

Selects the appropriate E&M interface type (depending on the end connection—such as PBX):

Type 1 indicates the following lead configuration (default—this is the recommended option):

E—Output, relay to ground

M—Input, referenced to ground

Type 2 indicates the following lead configuration:

E—Output, relay to SG

M—Input, referenced to ground

SB—Feed for M, connected to -48V

SG—Return for E, galvanically isolated from ground

Type 3 indicates the following lead configuration:

E—Output, relay to ground

M—Input, referenced to ground

SB—Connected to -48V

SG—Connected to ground

Type 5 indicates the following lead configuration:

E—Output, relay to ground

M—Input, referenced to -48V

Step 11 

Router(config-voice-port)# signal {wink-start | 
immediate | delay-dial}

Configures the signaling type for E&M voice ports. The default is wink-start. Select immediate for the Cisco hoot and holler over IP application. In the immediate-start protocol, the originating side does not wait for a wink before sending addressing information. After receiving addressing digits, the terminating side then goes off-hook for the duration of the call. The originating endpoint maintains off-hook for the duration of the call.

Step 12 

Router(config-voice-port)# voice-port 
{slot-number/subunit-number/port} | 
{slot/port:ds0-group-no} 

Selects another voice port.

Step 13 

Router(config-voice-port)# voice-class permanent tag

Uses the voice class tag for the receive-only port.

Step 14 

Router(config-voice-port)# connection {plar | tie-line 
| plar-opx} digits | {trunk digits [answer-mode]}

Ties the voice port to the same multicast-session number as in Step 12. (Use the trunk keyword and the digits argument for the hoot and holler application.)

Step 15 

Router(config-voice-port)# music-threshold number

(Optional) Sets the music threshold to make VAD less sensitive.

Step 16 

Router(config-voice-port)# operation {2-wire | 4-wire}

Specifies the calling scheme for E&M ports. The 2-wire keyword is the default.

(Specify 4-wire operation for the hoot and holler application.)

Configuring for Receive Only Mode

To configure Cisco hoot and holler over IP as receive-only mode, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config-class)# voice class permanent tag

Enters voice-class configuration mode and defines the voice class for receive-only mode.

Step 2 

Router(config-class)# signal pattern {idle receive | idle transmit | oos receive | oos transmit} word

Specifies the received signal pattern. Configures the ABCD bit pattern for Cisco trunks and FRF.11 trunks. (Specify the oos receive keywords and the word argument for the hoot and holler application.)

Step 3 

Router(config-class)# signal timing oos suppress-all 
seconds

If the transmit out-of-service pattern (from the PBX to the network) matches for the time specified, the router stops sending packets to the network.

Step 4 

Router(config-class)# signal keepalive number

Specifies keepalive signaling packet interval.

Configuring Relevant Interface (Serial/Ethernet)

To configure either the serial or Ethernet interface, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface type slot/port-adapter/port 
[ethernet | serial] 

Configures the physical interface (serial/Ethernet) for transmitting multicast packets and enters interface configuration mode.

Step 2 

Router(config-if)# ip address ip-address mask [secondary]

Assigns the IP address and subnet mask for the interface. The secondary keyword is optional. It specifies that the configured address is a secondary IP address. If this keyword is omitted, the configured address is the primary IP address.

Step 3 

Router(config-if)# ip pim {dense-mode | sparse mode | 
sparse-dense-mode}

Specifies Protocol Independent Multicast (PIM). Whatever mode you choose should match all the interfaces in all the routers of your network.

Step 4 

Router(config-if)# no shutdown

Enables the interface.

Configuring Voice Ports in High-Density Voice Network Modules

A multiflex trunk interface card (NM-HDV) in a high-density voice network module requires special voice-port configuration when connecting for T1/E1 operation. To configure a multiflex trunk interface card in a high-density voice network module, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# voice class permanent tag

Defines voice class for transmit-receive mode and enters voice class configuration mode.

Step 2 

Router(config-class)# signal timing oos timeout 
seconds | disabled

Disables signaling loss detection. (Use the disabled keyword for hoot and holler applications.)

Step 3 

Router(config-class)# signal keepalive number

Specifies the keepalive signaling packet interval in seconds. The valid range is from 1 to 65535.

Step 4 

Router(config-class)# exit

Exits voice class configuration mode.

Step 5 

Router(config)# voice-card slot

Enters voice-card configuration mode and selects the card to configure. The slot argument is a value from 0 to 3 that identifies the physical slot in the chassis where the voice card is located.

Step 6 

Router(config-voicecard)# codec complexity {high | medium}

Specifies call density and codec complexity based on the codec standard you are using. For hoot and holler applications, the codec complexity must be high. Voice multicasting does not support medium complexity, which is the default.

Step 7 

Router(config-voicecard)# exit

Exits voice-card configuration mode.

Step 8 

Router(config)# controller {t1 | e1} number

Enters controller configuration mode and selects the T1 or E1 controller to configure.

Step 9 

Router(config-controller)# ds0-group ds0-group-no 
timeslots timeslot-list type type

Maps a group of time slots to a DS0 group.

Step 10 

Router(config-controller)# exit

Exits controller configuration mode.

Step 11 

Router(config)# voice-port 
{slot-number/subunit-number/port} | 
{slot/port:ds0-group-no}

Enters voice-port configuration mode and configures a DS0 group that was created in Step 9 in this configuration task table.

Step 12 

Router(config-voice-port)# connection {plar | tie-line 
| plar-opx} digits | {trunk digits [answer-mode]}

Ties the connection trunk to a multicast address. This command is repeated for each DS0 group. All groups use the same multicast address if connecting to the same multicast session. (Use the trunk keyword and the digit argument for hoot and holler applications.)

Step 13 

Router(config-voice-port)# voice-class permanent tag

Specifies the receive-only port.

Configuration Examples

This section provides a series of configuration examples to help you become familiar with voice multicasting. These examples also show how to ensure that each configuration is working properly before proceeding to the next step.

Voice Multicasting over an Ethernet LAN

Voice Multicasting over a WAN

Cisco Hoot and Holler over IP with Ethernet Topology (Two Hoot Groups)

Cisco Hoot and Holler over IP with Frame-Relay Topology (One Hoot Group)


Note In all the following configuration examples, the routers are configured with the interface command and the name tag vif1. This is a virtual interface that is similar to a loopback interface—it is a logical IP interface that is always up when the router is active. In addition, it must be configured so that the Cisco hoot and holler over IP packets that are locally mixed on the DSPs can be fast-switched along with the other data packets. This interface needs to reside on its own unique subnet, and that subnet should be included in the routing protocol updates (RIP, OSPF, and so on).


Voice Multicasting over an Ethernet LAN

Figure 134 shows the simplest configuration for voice multicasting over an Ethernet LAN. Two routers are connected to each other over the Ethernet LAN. One E&M phone is connected to each router.

Figure 134 Voice Multicasting over a LAN

In router Abbott (Figure 134), the phone is connected to voice port 2/0/0, using the router-slot/voice-slot/VIC-port numbering convention. This router is configured as in the following example:

hostname Abbott
!
ip multicast-routing
!
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
 ip address 1.1.1.1 255.0.0.0
 ip pim sparse-dense-mode
!
interface Ethernet0/0
 ip address 3.3.3.1 255.0.0.0
 ip pim sparse-dense-mode
!
ip route 2.0.0.0 255.0.0.0 3.3.3.2
!
voice-port 2/0/0
 voice-class permanent 1
 connection trunk 111
 operation 4-wire
!         
dial-peer voice 1 voip
 destination-pattern 111
 session protocol multicast
 session target ipv4:237.111.0.111:22222
!

Note The connection-trunk connection type is a point-to-point connection, similar to a tie-line on a PBX network. All voice traffic—including signaling—placed at one end is immediately transferred to the other.



Note The E&M voice port must be configured for four-wire operation.


Configuring the Second Router

In router Costello (Figure 134), the E&M phone is connected to voice port 3/1/1. Router Costello uses the same configuration as Abbott, except for the following differences:

The virtual interface must be on a different subnet from the first router.

The IP address in the Ethernet configuration must be different from that of the first router.

The voice port and slot should match the router's hardware configuration.

hostname Costello
!
ip multicast-routing
!
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
 ip address 2.2.2.2 255.0.0.0
 ip pim sparse-dense-mode
!
interface Ethernet0/0
 ip address 3.3.3.2 255.0.0.0
 ip pim sparse-dense-mode
!
ip route 1.0.0.0 255.0.0.0 3.3.3.1
!
voice-port 3/1/1
 voice-class permanent 1
 timeouts wait-release 3
 connection trunk 222 
 music-threshold -30
 operation 4-wire
!
dial-peer voice 1 voip
 destination-pattern 111
 session protocol multicast
 session target ipv4:237.111.0.111:22222
!

Note The multicast session for this port, shown in the session target command, must match the multicast session configured on the first router.

The codec configured for this dial peer must match the codec for the dial peer on the first router.

Both routers must be configured to use the same connection trunk and destination pattern.


Verifying the Configuration

If you have configured your routers by following these examples, you should now be able to talk over the telephones. You can also use the show dial-peer voice command on each router to verify that the data you configured is correct.

To verify that an audio path has been established, use the show call active voice command. This command displays all active voice calls traveling through the router.

High-Density Voice Modules

A multiflex trunk interface card in a high-density voice network module requires special voice-port configuration. The card must be configured first as is shown in the following output:

voice-card 6
 codec complexity high
!

Note Codec complexity must be high. Voice multicasting does not support medium complexity, which is the default.


The following commands show how to define the T1 channel and signaling method and how to map each DS0 to voice port slot/port:ds0-group-no:

controller T1 6/0
 ds0-group 1 timeslots 1 type e&m-immediate-start
 ds0-group 2 timeslots 2 type e&m-immediate-start
 ds0-group 3 timeslots 3 type e&m-immediate-start
 ...
 ds0-group 22 timeslots 22 type e&m-immediate-start
 ds0-group 23 timeslots 23 type e&m-immediate-start

The following commands show how to configure the voice ports on the multiflex trunk interface card:

!
voice-port 6/0:1
 connection trunk 111
!
voice-port 6/0:2
 connection trunk 111
!
voice-port 6/0:3
 connection trunk 111
 ...
voice-port 6/0:22
 connection trunk 111
!
voice-port 6/0:23
 connection trunk 111

Dial-Peer Configuration

Cisco IOS software uses dial peers to tie together telephone numbers, voice ports, and other call parameters. Configuring dial peers is similar to configuring static IP routes—you are instructing the router what path to follow to route the call.

Dial peers are identified by numbers, but to avoid confusing these numbers with telephone numbers, they are usually referred to as tags. Dial peer tags are integers that can range from 1 to 231 -1 (2147483647). Dial peers on the same router must have unique tags, but you can reuse the tags on other routers.

The following commands show how to configure a dial peer with tag 1 for this voice port:

!Configure dial peer.
!Conference 1.
!Phone number 111.
!Multicast address 237.111.0.0, udp port 22222.
dial-peer voice 1 voip
 destination-pattern 111
 session protocol multicast
 session target ipv4:237.111.0.0:22222
 ip precedence 5
 codec g711ulaw
!

Note The configuration for the codec g711ulaw in the above configuration is not necessary—the default codec of g729r8 could be used (and it would not display for show config).



TipThe destination-pattern 111 for the VoIP dial peer matches the connection trunk string for the corresponding voice port.

The session protocol multicast command is essential for voice multicasting.

The session target for voice multicasting dial peers is a multicast address in the range of from 224.0.1.0 to 239.255.255.255. This session target must be the same for all routers in a session. The audio RTP port is an even number in the range of from 16384 to 32767 and must also be the same for all routers in a session. An odd-numbered port (UDP port number + 1) is used for the RTCP traffic for that session.

The following codec restrictions apply:

You must configure the same codec on all dial peers and routers in a session.

Only G.711, G.726, and G.729 codecs are supported.

When the default codec, G.729r8, is used, it does not appear in the configuration.

Voice activity detection is enabled by default. Cisco recommends that this setting should not be changed.

Ethernet Configuration

Configure the router's Ethernet interface as follows:

!Configure physical interface for transmitting multicast packets.
!
interface ethernet 0/0
 ip address 1.5.13.13 255.255.255.0
 ip pim sparse-dense-mode!

Voice Multicasting over a WAN

The configuration for voice multicasting sessions over IP on Frame Relay is the same as for the Ethernet LAN in the previous example. Configure the WAN interface on each router with the ip address and ip pim commands and the sparse-dense-mode keywords as shown in the section "Voice Multicasting over an Ethernet LAN."

Quality of Service

Voice traffic is much more sensitive to timing variations than data traffic. For good voice performance, configure your data network so that voice packets are not lost or delayed. The following example shows one way to improve QoS for voice multicasting over a Frame Relay connection:

!Configure physical interface for transmitting multicast packets.
!Listen to packets of Session Announcement Protocol (SAP).
!This example uses a subinterface
!
interface serial0/0
 encapsulation frame-relay
 frame-relay traffic-shaping
 no frame-relay broadcast-queue
!
interface serial0/0.1 point-to-point
 ip address 5.5.5.5 255.255.255.0
 ip pim sparse-dense-mode
 frame-relay class hootie
 frame-relay interface-dlci 100
 frame-relay ip rtp header-compression
!
!Frame relay class commands.
!
map-class frame-relay hootie
 frame-relay cir 64000
 frame-relay bc 2000
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80
 frame-relay ip rtp priority 16384 16383 64

Note In the frame-relay ip rtp priority command, the first number is the audio port. The second number is the number of consecutive audio ports to which the IP RTP priority queuing applies. The third number is the bandwidth, which should equal the bandwidth needed for each call multiplied by the number of calls.


Cisco Hoot and Holler over IP with Ethernet Topology (Two Hoot Groups)

The following figure illustrates Cisco hoot and holler over IP being used with an Ethernet topology:

Figure 135 Cisco Hoot and Holler over IP with Ethernet Topology

In this configuration, two hoot and holler groups are set up by defining two multicast groups (237.16.8.11 and 237.16.26.12) and mapping the connection command and trunk keyword (specifying 11) and connection command and trunk keyword (specifying 12) from the voice ports to the VoIP dial peers associated with each group. Each router is connected to a dedicated switch port, and IP precedence is set to 5 for all Cisco hoot and holler over IP packets.

Router-1 (E&M Four-Wire Ports)

The following output shows that Router 1 has been configured for E&M four-wire ports:

hostname Router-1
!
ip multicast-routing
! 
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 1.1.1.1 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 1.5.13.1 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 1.1.1.0
network 1.5.13.0
!
voice-port 1/0/0
voice-class permanent 1
connection trunk 111
music-threshold -30
operation 4-wire
!
voice-port 1/0/1
voice-class permanent 1
connection trunk 112
music-threshold -30
operation 4-wire
!
dial-peer voice 111 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.111:22222
ip precedence 5
!
dial-peer voice 112 voip
destination-pattern 112
session protocol multicast
session target ipv4:239.194.0.10:22224
ip precedence 5
!

Router-2 (FXS Ports)

The following output shows that Router 2 has been configured for FSX ports:

hostname Router-2
!
ip multicast-routing
! 
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 2.2.2.2 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 1.5.13.2 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 2.2.2.0
network 1.5.13.0
!
dial-peer voice 111 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.111:22222
ip precedence 5
!
dial-peer voice 112 voip
destination-pattern 112
session protocol multicast
session target ipv4:239.194.0.10:22224
ip precedence 5
!

Note If you want to join the hoot and holler session directly without having to dial any session numbers, use the connection command and the plar keyword, followed by the multicast-session number.


Router-3 (FXO Ports)

The following output shows that Router 4 has been configured for FXO ports:

hostname Router-3
!
ip multicast-routing
! 
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 3.3.3.3 255.255.255.0
ip pim sparse-dense-mode
!
interface Ethernet0/0
ip address 1.5.13.3 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 3.3.3.0
network 1.5.13.0
!
dial-peer voice 111 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.111:22222
ip precedence 5
!
dial-peer voice 112 voip
destination-pattern 112
session protocol multicast
session target ipv4:239.194.0.10:22224
ip precedence 5
!

Cisco Hoot and Holler over IP with Frame-Relay Topology (One Hoot Group)

Figure 136 Cisco Hoot and Holler over IP with Frame Relay Topology

In this topology, three routers are connected using 64K Frame Relay PVCs in a hub-and-spoke topology, with Router 1 being the hub. One hoot and holler group has been defined. All three routers have been configured to traffic-shape their data and voice on the WAN to CIR, and all three routers are using IP RTP priority to guarantee QoS for the Cisco hoot and holler over IP packets. In addition, the Frame Relay broadcast-queue is disabled on the serial interfaces. This occurs because, by default, the broadcast queue is only 40 packets deep and Cisco hoot and holler over IP transmits packets at 50 packets per second. Unless the queue is disabled, some packets would be dropped and voice QoS would be degraded.

Router-1

The following output shows that Router 1 has been configured for Cisco hoot and holler over IP with Frame Relay topology:

hostname Router-1
!
ip multicast-routing
!
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 1.1.1.1 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 1.1.1.0
network 5.5.5.0
network 5.5.6.0
!
interface Serial0/0
 no ip address
 ip pim sparse-dense-mode
 encapsulation frame-relay
 frame-relay traffic-shaping
 no frame-relay broadcast-queue
!
interface Serial0/0.1 point-to-point
 ip address 5.5.5.1 255.255.255.0
 ip pim sparse-dense-mode
 frame-relay class hoot-n-holler
 frame-relay interface-dlci 100
 frame-relay ip rtp header-compression
!
interface Serial0/0.2 point-to-point
 ip address 5.5.6.1 255.255.255.0
 ip pim sparse-dense-mode
 frame-relay class hoot-n-holler
 frame-relay interface-dlci 101
 frame-relay ip rtp header-compression
!
map-class frame-relay hoot-n-holler
 frame-relay cir 128000
 frame-relay bc 1280
 frame-relay mincir 128000
 frame-relay fragment 160
 frame-relay ip rtp priority 16384 16384 128
 no frame-relay adaptive-shaping
!
voice-port 1/0/0
voice-class permanent 1
connection trunk 111
music-threshold -30
operation 4-wire
!
dial-peer voice 1 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.0:22222
ip precedence 5

Router-2

The following output shows that Router 2 has been configured for Cisco hoot and holler over IP with a Frame Relay topology:

hostname Router-2
!
ip multicast-routing
!
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 2.2.2.2 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 2.2.2.0
network 5.5.5.0
!
interface Serial0/0
 no ip address
 ip pim sparse-dense-mode
 encapsulation frame-relay
 frame-relay traffic-shaping
 no frame-relay broadcast-queue
!
interface Serial0/0.1 point-to-point
 ip address 5.5.5.2 255.255.255.0
 ip pim sparse-dense-mode
 frame-relay class hoot-n-holler
 frame-relay interface-dlci 100
 frame-relay ip rtp header-compression
!
map-class frame-relay hoot-n-holler
 frame-relay cir 128000
 frame-relay bc 1280
 frame-relay mincir 128000
 frame-relay fragment 160
 frame-relay ip rtp priority 16384 16383 128
 no frame-relay adaptive-shaping
!
voice-port 1/0/0
voice-class permanent 1
connection trunk 111
music-threshold -30
operation 4-wire
!
dial-peer voice 1 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.0:22222
ip precedence 5

Router-3

The following output shows that Router 3 has been configured for Cisco hoot and holler with a Frame Relay topology:

hostname Router-3
!
ip multicast-routing
!
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 3.3.3.3 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 3.3.3.0
network 5.5.6.0
!
interface Serial0/0
 no ip address
 ip pim sparse-dense-mode
 encapsulation frame-relay
 frame-relay traffic-shaping
 no frame-relay broadcast queue
!
interface Serial0/0.1 point-to-point
 ip address 5.5.6.2 255.255.255.0
 ip pim sparse-dense-mode
 frame-relay class hoot-n-holler
 frame-relay interface-dlci 101
 frame-relay ip rtp header-compression
!
map-class frame-relay hoot-n-holler
 frame-relay cir 128000
 frame-relay bc 1280
 frame-relay mincir 128000
 frame-relay fragment 160
 frame-relay ip rtp priority 16384 16383 128
 no frame-relay adaptive-shaping
!
voice-port 1/0/0
voice-class permanent 1
connection trunk 111
music-threshold -30
operation 4-wire
!
dial-peer voice 1 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.0:22222
ip precedence 5