Cisco IOS Quality of Service Solutions Configuration�Guide, Release�12.2
Configuring RSVP Support for Frame Relay
Downloads: This chapterpdf (PDF - 203.0KB) | Feedback

Configuring RSVP Support for Frame Relay

Table Of Contents

Configuring RSVP Support for Frame Relay

RSVP Support for Frame Relay Configuration Task List

Enabling Frame Relay Encapsulation on an Interface

Configuring a Virtual Circuit

Enabling Frame Relay Traffic Shaping on an Interface

Enabling Enhanced Local Management Interface

Enabling RSVP on an Interface

Specifying a Traffic Shaping Map Class for an Interface

Defining a Map Class with WFQ and Traffic Shaping Parameters

Specifying the CIR

Specifying the Minimum CIR

Enabling WFQ

Enabling FRF.12

Configuring a Path

Configuring a Reservation

Verifying RSVP Support for Frame Relay

Multipoint Configuration

Point-to-Point Configuration

Monitoring and Maintaining RSVP Support for Frame Relay

RSVP Support for Frame Relay Configuration Examples

Multipoint Configuration Example

Point-to-Point Configuration Example


Configuring RSVP Support for Frame Relay


This chapter describes the tasks for configuring the RSVP Support for Frame Relay feature.

For complete conceptual information, see the section "RSVP Support for Frame Relay" in the chapter "Signalling Overview" in this book.

For a complete description of the RSVP Support for Frame Relay commands in this chapter, refer to the Cisco IOS Quality of Service Solutions Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

To identify the hardware platform or software image information associated with a feature, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter in this book.

RSVP Support for Frame Relay Configuration Task List

To configure Resource Reservation Protocol (RSVP) support for Frame Relay, perform the tasks described in the following sections. Each task is identified as either optional or required.

Enabling Frame Relay Encapsulation on an Interface (Required)

Configuring a Virtual Circuit (Required)

Enabling Frame Relay Traffic Shaping on an Interface (Required)

Enabling Enhanced Local Management Interface (Optional)

Enabling RSVP on an Interface (Required)

Specifying a Traffic Shaping Map Class for an Interface (Required)

Defining a Map Class with WFQ and Traffic Shaping Parameters (Required)

Specifying the CIR (Required)

Specifying the Minimum CIR (Optional)

Enabling WFQ (Required)

Enabling FRF.12 (Required)

Configuring a Path (Optional)

Configuring a Reservation (Optional)

Verifying RSVP Support for Frame Relay (Optional)

Monitoring and Maintaining RSVP Support for Frame Relay (Optional)

See the end of this chapter for the section "RSVP Support for Frame Relay Configuration Examples."

Enabling Frame Relay Encapsulation on an Interface

To enable Frame Relay encapsulation on an interface, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface s3/0

Enables an interface (for example, serial interface 3/0) and enters configuration interface mode.

Step 2 

Router(config-if)# encapsulation frame-relay [cisco | ietf]

Enables Frame Relay and specifies the encapsulation method.

Configuring a Virtual Circuit

To configure a virtual circuit (VC), use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# frame-relay interface-dlci dlci

Assigns a data-link connection identifier (DLCI) to a specified Frame Relay subinterface on a router or access server.


Enabling Frame Relay Traffic Shaping on an Interface

To enable Frame Relay Traffic Shaping (FRTS) on an interface, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# frame-relay traffic-shaping

Enables traffic shaping and per-VC queueing for all permanent virtual circuits (PVCs) and switched virtual circuits (SVCs) on a Frame Relay interface.


Enabling Enhanced Local Management Interface

To enable enhanced Local Management Interface (LMI), use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# frame-relay lmi-type

Selects the LMI type.


Enabling RSVP on an Interface

To enable RSVP on an interface, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# ip rsvp bandwidth

Enables RSVP on an interface.


Specifying a Traffic Shaping Map Class for an Interface

To specify a traffic shaping map class for an interface, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# frame-relay class name

Associates a map class with an interface or subinterface.


Defining a Map Class with WFQ and Traffic Shaping Parameters

To define a map class with weighted fair queueing (WFQ) and traffic shaping parameters, use the following command in global configuration mode:

Command
Purpose

Router(config)# map-class frame-relay map-class-name

Defines parameters for a specified class.


Specifying the CIR

To specify the committed information rate (CIR), use the following command in map-class configuration mode:

Command
Purpose

Router(config-map-class)# frame-relay cir {in | out} bps

Specifies the maximum incoming or outgoing CIR for a Frame Relay VC.


Specifying the Minimum CIR

To specify the minimum acceptable incoming or outgoing CIR (minCIR) for a Frame Relay VC, use the following command in map-class configuration mode:

Command
Purpose

Router(config-map-class)# frame-relay mincir {in | out} bps

Specifies the minimum acceptable incoming or outgoing CIR for a Frame Relay VC.

Note If the minCIR is not configured, then the admission control value is the CIR/2.

 


Enabling WFQ

To enable WQF, use the following command in map-class configuration mode:

Command
Purpose

Router(config-map-class)# frame-relay fair-queue

Enables WFQ on a PVC.


Enabling FRF.12

To enable FRF.12, use the following command in map-class configuration mode:

Command
Purpose

Router(config-map-class)# frame-relay fragment fragment-size

Enables Frame Relay fragmentation on a PVC.


Configuring a Path

To configure a path, use the following command in global configuration mode:

Command
Purpose

Router(config)# ip rsvp sender

Specifies the RSVP path parameters, including the destination and source addresses, the protocol, the destination and source ports, the previous hop address, the average bit rate, and the burst size.


Configuring a Reservation

To configure a reservation, use the following command in global configuration mode:

Command
Purpose

Router(config)# ip rsvp reservation

Specifies the RSVP reservation parameters, including the destination and source addresses, the protocol, the destination and source ports, the next hop address, the next hop interface, the reservation style, the service type, the average bit rate, and the burst size.


Verifying RSVP Support for Frame Relay

The following sections contain the procedures for verifying RSVP support for Frame Relay in either a multipoint configuration or a point-to-point configuration.

Multipoint Configuration

To verify RSVP support for Frame Relay in a multipoint configuration, perform the following steps:


Step 1 Enter the show ip rsvp installed command to display information about interfaces and their admitted reservations. The output in the following example shows that serial subinterface 3/0.1 has two reservations:

Router# show ip rsvp installed

RSVP:Serial3/0
BPS    To              From            Protoc DPort  Sport  Weight Conversation
RSVP:Serial3/0.1
BPS    To              From            Protoc DPort  Sport  Weight Conversation
40K    145.20.22.212   145.10.10.211   UDP    10     10     0      24
50K    145.20.21.212   145.10.10.211   UDP    10     10     6      25

Note Weight 0 is assigned to voice-like flows, which proceed to the priority queue.


Step 2 Enter the show ip rsvp installed detail command to display additional information about interfaces, subinterfaces, DLCI PVCs, and their current reservations.


Note In the following output, the first flow gets a reserved queue with a weight > 0, and the second flow gets the priority queue with a weight = 0.


Router# show ip rsvp installed detail

RSVP:Serial3/0 has the following installed reservations
RSVP:Serial3/0.1 has the following installed reservations
RSVP Reservation. Destination is 145.20.21.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 10, Source port is 10
  Reserved bandwidth:50K bits/sec, Maximum burst:1K bytes, Peak rate:50K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: RESERVED queue 25.  Weight:6
  Data given reserved service:0 packets (0M bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 68 seconds
  Long-term average bitrate (bits/sec):0M reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.22.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 10, Source port is 10
  Reserved bandwidth:40K bits/sec, Maximum burst:1K bytes, Peak rate:40K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: PRIORITY queue 24.  Weight:0
  Data given reserved service:0 packets (0M bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 707 seconds
  Long-term average bitrate (bits/sec):0M reserved, 0M best-effort

Point-to-Point Configuration

To verify RSVP support for Frame Relay in a point-to-point configuration, perform the following steps:


Step 1 Enter the show ip rsvp installed command to display information about interfaces and their admitted reservations. The output in the following example shows that serial subinterface 3/0.1 has one reservation, and serial subinterface 3/0.2 has one reservation.

Router# show ip rsvp installed

RSVP:Serial3/0
BPS    To              From            Protoc DPort  Sport
RSVP:Serial3/0.1
BPS    To              From            Protoc DPort  Sport
50K    145.20.20.212   145.10.10.211   UDP    10     10

RSVP:Serial3/0.2
BPS    To              From            Protoc DPort  Sport
10K    145.20.21.212   145.10.10.211   UDP    11     11

Note Weight 0 is assigned to voice-like flows, which proceed to the priority queue.


Step 2 Enter the show ip rsvp installed detail command to display additional information about interfaces, subinterfaces, DLCI PVCs, and their current reservations.


Note In the following output, the first flow with a weight > 0 gets a reserved queue and the second flow with a weight = 0 gets the priority queue.


Router# show ip rsvp installed detail

RSVP:Serial3/0 has the following installed reservations
RSVP:Serial3/0.1 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 10, Source port is 10
  Reserved bandwidth:50K bits/sec, Maximum burst:1K bytes, Peak rate:50K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: RESERVED queue 25.  Weight:6
  Data given reserved service:415 packets (509620 bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 862 seconds
  Long-term average bitrate (bits/sec):4724 reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
  Protocol is UDP, Destination port is 11, Source port is 11
  Reserved bandwidth:10K bits/sec, Maximum burst:1K bytes, Peak rate:10K bits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0: PRIORITY queue 24.  Weight:0
  Data given reserved service:85 packets (104380 bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 875 seconds
  Long-term average bitrate (bits/sec):954 reserved, 0M best-effort
RSVP:Serial3/0.2 has the following installedreservations

RSVP Reservation. Destination is 145.20.21.212, Source is 145.10.10.211,

  Protocol is UDP, Destination port is 11, Source port is 11
  Reserved bandwidth:10K bits/sec, Maximum burst:1K bytes, Peak rate:10Kbits/sec
QoS provider for this flow:
    WFQ on FR PVC dlci 101 on Se3/0:PRIORITY queue 24.  Weight:0
  Data given reserved service:85 packets (104380 bytes)
  Data given best-effort service:0 packets (0 bytes)
  Reserved traffic classified for 875 seconds
  Long-term average bitrate (bits/sec):954 reserved, 0M best-effort

Monitoring and Maintaining RSVP Support for Frame Relay

To monitor and maintain RSVP support for Frame Relay, use the following commands in EXEC mode, as needed:

Command
Purpose

Router# show ip rsvp installed

Displays information about interfaces and their admitted reservations.

Router# show ip rsvp installed detail

Displays additional information about interfaces, DLCIs, and their admitted reservations.

Router# show queueing

Displays all or selected configured queueing strategies.


RSVP Support for Frame Relay Configuration Examples

The following sections provide RSVP support for Frame Relay configuration examples:

Multipoint Configuration Example

Point-to-Point Configuration Example

For information on how to configure the RSVP Support for Frame Relay feature, see the section "RSVP Support for Frame Relay Configuration Task List" in this chapter.

Multipoint Configuration Example

Figure 22 shows a multipoint interface configuration commonly used in Frame Relay environments in which multiple PVCs are configured on the same subinterface at router R1.

Figure 22 Multipoint Interface Configuration

RSVP performs admission control based on the minCIR of DLCI 101 and DLCI 201. The congestion point is not the 10.1.1.1/16 subinterface, but the CIR of DLCI 101 and DLCI 201.

The following example is a sample output for serial interface 3/0:

interface Serial3/0
 no ip address
 encapsulation frame-relay
 max-reserved-bandwidth 20
 no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type cisco
 ip rsvp bandwidth 350 350
!
interface Serial3/0.1 multipoint
 ip address 10.1.1.1 255.255.0.0
 frame-relay interface-dlci 101
  class fr-voip
 frame-relay interface-dlci 201
  class fast-vcs
 ip rsvp bandwidth 350 350

ip rsvp pq-profile 6000 2000 ignore-peak-value
!
!
map-class frame-relay fr-voip
 frame-relay cir 800000
 frame-relay bc 8000
 frame-relay mincir 128000
 frame-relay fragment 280
 no frame-relay adaptive-shaping
 frame-relay fair-queue
!
map-class frame-relay fast-vcs
 frame-relay cir 200000
 frame-relay bc 2000
 frame-relay mincir 60000
 frame-relay fragment 280
 no frame-relay adaptive-shaping
 frame-relay fair-queue
!

Note When FRTS is enabled, the Frame Relay Committed Burst (Bc) value (in bits) should be configured to a maximum of 1/100th of the CIR value (in bits per second). This configuration ensures that the FRTS token bucket interval (Bc/CIR) does not exceed 10 Ms, and that voice packets are serviced promptly.


Point-to-Point Configuration Example

Figure 23 shows a point-to-point interface configuration commonly used in Frame Relay environments in which one PVC per subinterface is configured at router R1.

Figure 23 Sample Point-to-Point Interface Configuration

Notice that the router interface bandwidth for R1 is T1 (1.544 Mbps), whereas the CIR value of DLCI 201 toward R3 is 256 kbps. For traffic flows from R1 to R3 over DLCI 201, the congestion point is the CIR for DLCI 201. As a result, RSVP performs admission control based on the minCIR and reserves resources, including queues and bandwidth, on the WFQ system that runs on each DLCI.

The following example is sample output for serial interface 3/0:

interface Serial3/0
 no ip address
 encapsulation frame-relay
 max-reserved-bandwidth 20
 no fair-queue
 frame-relay traffic-shaping
 frame-relay lmi-type cisco
 ip rsvp bandwidth 500 500
!
interface Serial3/0.1 point-to-point
 ip address 10.1.1.1 255.255.0.0
 frame-relay interface-dlci 101
  class fr-voip
 ip rsvp bandwidth 350 350
!
interface Serial3/0.2 point-to-point
 ip address 10.3.1.1 255.255.0.0
 frame-relay interface-dlci 201
  class fast-vcs
 ip rsvp bandwidth 150 150

ip rsvp pq-profile 6000 2000 ignore-peak-value
!
!
map-class frame-relay fr-voip
 frame-relay cir 800000
 frame-relay bc 8000
 frame-relay mincir 128000
 frame-relay fragment 280
 no frame-relay adaptive-shaping
 frame-relay fair-queue

Note When FRTS is enabled, the Frame Relay Committed Burst (Bc) value (in bits) should be configured to a maximum of 1/100th of the CIR value (in bits per second). This configuration ensures that the FRTS token bucket interval (Bc/CIR) does not exceed 10 Ms, and that voice packets are serviced promptly.