RIP Commands
ErrorMessage : Error while constructing the Hinav

null
Downloads: This chapterpdf (PDF - 319.0KB) | Feedback

RIP Commands

Table Of Contents

RIP Commands

auto-summary (RIP)

default-information originate

default-metric (RIP)

distribute-list in (RIP, IGRP, EIGRP)

distribute-list out (RIP, IGRP, EIGRP)

flash-update-threshold

input-queue

ip rip authentication key-chain

ip rip authentication mode

ip rip receive version

ip rip send version

ip rip triggered

ip rip v2-broadcast

ip split-horizon (RIP)

ip summary-address rip

neighbor (RIP)

network (RIP)

offset-list

output-delay

router rip

show ip rip database

timers basic

validate-update-source

version


RIP Commands


Use the commands in this chapter to configure and monitor Routing Information Protocol (RIP). For RIP configuration information and examples, refer to the "Configuring Routing Information Protocol" chapter of the Cisco IOS IP Configuration Guide.

auto-summary (RIP)

To restore the default behavior of automatic summarization of subnet routes into network-level routes, use the auto-summary command in router configuration mode. To disable this function and send subprefix routing information across classful network boundaries, use the no form of this command.

auto-summary

no auto-summary

Syntax Description

This command has no arguments or keywords.

Defaults

Enabled (the software summarizes subprefixes to the classful network boundary when crossing classful network boundaries).

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

Route summarization reduces the amount of routing information in the routing tables.

RIP Version 1 always uses automatic summarization. If you are using RIP Version 2, you can turn off automatic summarization by specifying the no auto-summary command. Disable automatic summarization if you must perform routing between disconnected subnets. When automatic summarization is off, subnets are advertised.

Examples

In the following example, network numbers are not summarized automatically:

router rip
 version 2
 no auto-summary

default-information originate

To generate a default route into Routing Information Protocol (RIP), use the default-information originate command in router configuration mode. To disable this feature, use the no form of this command.

default-information originate [route-map map-name]

no default-information originate

Syntax Description

route-map map-name

(Optional) Routing process will generate the default route if the route map is satisfied.


Defaults

This command is disabled by default.

Command Modes

Router configuration

Command History

Release
Modification

11.2

This command was introduced.


Usage Guidelines

The route map referenced in the default-information originate command cannot use an extended access list; it can use a standard access list.

Examples

The following example originates a default route (0.0.0.0/0) over a certain interface when 172.68.0.0/16 is present. Applying a condition (in this case a route map) to determine when the default route is originated is called "conditional default origination."

router rip 
 version 2
 network 172.68.16.0
 default-information originate route-map condition
!
 route-map condition permit 10
 match ip address 10
 set interface s1/0
!
access-list 10 permit 172.68.16.0 0.0.0.255
!

default-metric (RIP)

To set default metric values for Routing Information Protocol (RIP), use the default-metric command in router configuration mode. To return to the default state, use the no form of this command.

default-metric number-value

no default-metric [number-value]

Syntax Description

number-value

Default metric value.


Defaults

Built-in, automatic metric translations, as appropriate for each routing protocol. The metric of redistributed connected and static routes is set to 0.

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.


Note When enabled, the default-metric command applies a metric value of 0 to redistributed connected routes. The default-metric command does not override metric values that are applied with the redistribute command.


Examples

The following example shows a router in autonomous system 109 using both the RIP and the Open Shortest Path First (OSPF) routing protocols. The example advertises OSPF-derived routes using RIP and assigns the OSPF-derived routes a RIP metric of 10.

router rip
 default-metric 10
 redistribute ospf 109

Related Commands

Command
Description

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.


distribute-list in (RIP, IGRP, EIGRP)

To filter networks received in updates, use the distribute-list in command in address family or router configuration mode. To disable this function, use the no form of this command.

distribute-list {access-list-number | prefix prefix-list-name [gateway prefix-list-name]} in [interface-type interface-number]

no distribute-list {access-list-number | prefix prefix-list-name [gateway prefix-list-name]} in [interface-type interface-number]

Syntax Description

access-list-number

Standard IP access list number. The list defines which networks are to be received and which are to be suppressed in routing updates.

prefix prefix-list-name

Name of a prefix list. The list defines which networks are to be received and which are to be suppressed in routing updates, based upon matching the network prefix to the prefixes in the list.

gateway prefix-list-name

(Optional) Name of the prefix list to be applied to the gateway of the prefix being updated.

in

Applies the access list to incoming routing updates.

interface-type

(Optional) Interface type.

interface-number

(Optional) Interface number on which the access list should be applied to incoming updates. If no interface is specified, the access list will be applied to all incoming updates.


Defaults

This command is disabled by default.

Command Modes

Address family configuration

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

11.2

The access-list-number, interface-type, and interface-number arguments were added.

12.0

The prefix-list-name argument was added.

12.0(7)T

Address family configuration mode was added.


Usage Guidelines

This command is not supported in Intermediate Sytem-to-Intermediate System (IS-IS) or Open Shortest Path First (OSPF).

Using a prefix list allows filtering based upon the prefix length, making it possible to filter either on the prefix list, the gateway, or both for incoming updates.

Specify either an access list or a prefix list with the distribute-list in command.

Use the gateway keyword only with the prefix-list keyword.

To suppress networks from being advertised in updates, use the distribute-list out command.

Examples

In the following example, the BGP routing process accepts only two networks—network 0.0.0.0 and network 131.108.0.0:

access-list 1 permit 0.0.0.0
access-list 1 permit 131.108.0.0
access-list 1 deny 0.0.0.0 255.255.255.255
router bgp 
 network 131.108.0.0
 distribute-list 1 in

In the following example, The RIP process accepts only prefixes with prefix lengths of /8 to /24:

ip prefix-list max24 seq 5 permit 0.0.0.0/0 ge 8 le 24
router rip
 network 131.108.0.0
 distribute-list prefix max24 in

In the following example, the RIP process filters on packet length and accepts routing updates from address 192.1.1.1 only:

ip prefix-list max24 seq 5 permit 0.0.0.0/0 ge 8 le 24
ip prefix-list allowlist seq5 permit 192.1.1.1/32
router rip
 network 131.108.0.0
 distribute-list prefix max24 gateway allowlist in

Related Commands

Command
Description

access-list (IP extended)

Defines an extended IP access list.

distribute-list out (RIP, IGRP, EIGRP)

Suppresses networks from being advertised in updates.

ip prefix-list

Creates an entry in a prefix list.

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.


distribute-list out (RIP, IGRP, EIGRP)

To suppress networks from being advertised in updates, use the distribute-list out command in address family or router configuration mode. To disable this function, use the no form of this command.

distribute-list {access-list-number | prefix prefix-list-name [gateway prefix-list-name]} out [interface-name | routing-process | as-number]

no distribute-list {access-list-number | prefix prefix-list-name [gateway prefix-list-name]} out [interface-name | routing-process | as-number]

Syntax Description

access-list-number

Standard IP access list number. The list defines which networks are to be received and which are to be suppressed in routing updates.

prefix prefix-list-name

Name of a prefix list. The list defines which networks are to be received and which are to be suppressed in routing updates, based upon matching the network prefix to the prefixes in the list.

gateway prefix-list-name

(Optional) Name of the prefix list to be applied to the gateway of the prefix being updated.

out

Applies the access list to outgoing routing updates.

interface-name

(Optional) Name of a particular interface.

routing-process

(Optional) Name of a particular routing process, or the keyword static or connected.

as-number

(Optional) Autonomous system number.


Defaults

This command is disabled by default.

Command Modes

Address family configuration

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

11.2

The access-list-number argument was added.

12.0

The prefix-list-name argument was added.

12.0(7)T

Address family configuration mode was added.


Usage Guidelines

When redistributing networks, a routing process name can be specified as an optional trailing argument to the distribute-list command. Specifying an argument causes the access list or prefix list to be applied to only those routes derived from the specified routing process. After the process-specific access list or prefix list is applied, any access list or prefix list specified by a distribute-list command without a process name argument will be applied. Addresses not specified in the distribute-list command will not be advertised in outgoing routing updates.

Specify either an access list or a prefix list with the distribute-list in command.

Use the gateway keyword only with the prefix-list keyword.


Note To filter networks received in updates, use the distribute-list in command.


Examples

The following example causes only one network (network 131.108.0.0) to be advertised by a RIP routing process:

access-list 1 permit 131.108.0.0
access-list 1 deny 0.0.0.0 255.255.255.255
router rip
 network 131.108.0.0
 distribute-list 1 out

Related Commands

Command
Description

access-list (IP extended)

Defines an extended IP access list.

distribute-list in (RIP, IGRP, EIGRP)

Filters networks received in updates.

ip prefix-list

Creates an entry in a prefix list.


flash-update-threshold

To suppress regularly scheduled flash updates, use the flash-update-threshold command in router configuration mode. To return to the default state, use the no form of this command.

flash-update-threshold seconds

no flash-update-threshold

Syntax Description

seconds

The time interval in seconds for which the suppression of flash updates can be configured.


Defaults

This command is disabled by default.

Command Modes

Router configuration

Command History

Release
Modification

12.0

This command was introduced.


Usage Guidelines

This command suppresses flash updates when the arrival of a regularly scheduled update matches the number of seconds that is configured with the seconds argument. The range of seconds that can be configure is from 0 to 30 seconds. If the number of seconds matches the number of seconds or is less than the number seconds that is configured with the seconds argument, the flash update is suppressed. If the numbers seconds until the flash update arrives exceeds the number of seconds that is configured with the seconds argument, the flash update is not suppressed. The regular scheduled interval for flash updates and the configuration of the suppression of flash updates can be verified with the show ip protocol command.

Examples

The following example configures a router to suppress a regularly scheduled flash update if the update is due in 10 seconds or less:

router rip
 flash-update-threshold 10 

Related Commands

Command
Description

show ip protocols

Displays the parameters and current state of the active routing protocol process.


input-queue

The input-queue command defines the number of received, but not yet processed RIP update packets contained in the Routing Information Protocol (RIP) input queue. Use the input-queue command in router configuration mode. To remove the configured depth and restore the default depth, use the no form of this command.

input-queue depth

no input-queue

Syntax Description

depth

Numerical value associated with the maximum number of packets in the RIP input queue. The larger the numerical value, the larger the depth of the queue. The range is from 0 to 1024. The default is 50.


Defaults

A depth of 50.

Command Modes

Router configuration

Command History

Release
Modification

11.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

Consider using the input-queue command if you have a high-end router that is sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.

Another way to prevent the routing table from losing information is to use the output-delay command to change the interpacket delay for RIP updates.

Examples

The following example sets the depth of the RIP input queue to 100:

router rip
 input-queue 100

Related Commands

Command
Description

output-delay

Changes the interpacket delay for RIP updates sent.


ip rip authentication key-chain

To enable authentication for Routing Information Protocol (RIP) Version 2 packets and to specify the set of keys that can be used on an interface, use the ip rip authentication key-chain command in interface configuration mode. To prevent authentication, use the no form of this command.

ip rip authentication key-chain name-of-chain

no ip rip authentication key-chain [name-of-chain]

Syntax Description

name-of-chain

Enables authentication and specifies the group of keys that are valid.


Defaults

No authentication is provided for RIP packets.

Command Modes

Interface configuration

Command History

Release
Modification

11.1

This command was introduced.


Usage Guidelines

If no key chain is configured with the key-chain command, no authentication is performed on the interface (not even the default authentication).

Examples

The following example configures the interface to accept and send any key belonging to the key chain named trees:

ip rip authentication key-chain trees

Related Commands

Command
Description

key chain

Enables authentication for routing protocols.


ip rip authentication mode

To specify the type of authentication used in Routing Information Protocol (RIP) Version 2 packets, use the ip rip authentication mode command in interface configuration mode. To restore clear text authentication, use the no form of this command.

ip rip authentication mode {text | md5}

no ip rip authentication mode

Syntax Description

text

Clear text authentication.

md5

Keyed Message Digest 5 (MD5) authentication.


Defaults

Clear text authentication is provided for RIP packets.

Command Modes

Interface configuration

Command History

Release
Modification

11.1

This command was introduced.


Usage Guidelines

RIP Version 1 does not support authentication.

Examples

The following example configures the interface to use MD5 authentication:

ip rip authentication mode md5

Related Commands

Command
Description

ip rip authentication key-chain

Enables authentication for RIP Version 2 packets and specifies the set of keys that can be used on an interface.

key chain

Enables authentication for routing protocols.


ip rip receive version

To specify a Routing Information Protocol (RIP) version to receive on an interface basis, use the ip rip receive version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip receive version [1] [2]

no ip rip receive version

Syntax Description

1

(Optional) Accepts only RIP Version 1 packets on the interface.

2

(Optional) Accepts only RIP Version 2 packets on the interface.


Defaults

This command is disabled by default.

Command Modes

Interface configuration

Command History

Release
Modification

11.1

This command was introduced.


Usage Guidelines

Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to accept both RIP versions.

Examples

The following example configures the interface to receive both RIP Version 1 and Version 2 packets:

ip rip receive version 1 2

The following example configures the interface to receive only RIP Version 1 packets:

ip rip receive version 1

Related Commands

Command
Description

key chain

Enables authentication for routing protocols.

ip rip authentication key-chain

Enables authentication for RIP Version 2 packets and specifies the set of keys that can be used on an interface.

ip rip send version

Specifies a RIP version to send on an interface basis.

version

Specifies a RIP version used globally by the router.


ip rip send version

To specify a Routing Information Protocol (RIP) version to send on an interface basis, use the ip rip send version command in interface configuration mode. To follow the global version rules, use the no form of this command.

ip rip send version [1] [2]

no ip rip send version

Syntax Description

1

(Optional) Sends only RIP Version 1 packets out the interface.

2

(Optional) Sends only RIP Version 2 packets out the interface.


Defaults

This command is disabled by default.

Command Modes

Interface configuration

Command History

Release
Modification

11.1

This command was introduced.


Usage Guidelines

Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured.

Examples

The following example configures the interface to send both RIP Version 1 and Version 2 packets out the interface:

ip rip send version 1 2

The following example configures the interface to send only RIP Version 2 packets out the interface:

ip rip send version 2

Related Commands

Command
Description

ip rip receive version

Specifies a RIP version to receive on an interface basis.

version

Specifies a RIP version used globally by the router.


ip rip triggered

To enable triggered extensions to Routing Information Protocol (RIP), use the ip rip triggered command in interface configuration mode. To disable triggered extensions to RIP, use the no form of this command.

ip rip triggered

no ip rip triggered

Syntax Description

This command has no arguments or keywords.

Defaults

This command is disabled by default.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(1)T

This command was introduced.


Usage Guidelines

When triggered extensions to RIP are enabled, routing updates are sent on the WAN only if one of the following events occurs:

The router receives a specific request for a routing update. (Full database is sent.)

Information from another interface modifies the routing database. (Only latest changes are sent.)

The interface comes up or goes down. (Partial database is sent.)

The router is first powered on, to ensure that at least one update is sent. (Full database is sent.)

You might want to enable this feature if you are using an on-demand circuit and you are charged for usage time. Fewer routing updates will incur lower usage costs.

Entries in the routing database can be either temporary or semipermanent. Entries learned from broadcasts on LANs are temporary; they will expire if not periodically refreshed by more broadcasts.

Entries learned from a triggered response on the WAN are semipermanent; they do not time out like other entries. Certain events can cause these routes to time out, such as the interface going down, or if the outgoing interface is the same as the incoming interface. Neighbor updates of the routes with a metric of 16 (infinity) mean the route is unreachable, and those routes are eventually removed from the routing table.

Examples

The following example enables triggered extensions to RIP:

interface serial 0
 ip rip triggered

Related Commands

Command
Description

show ip rip database

Displays the contents of the RIP private database when triggered extensions to RIP are enabled.


ip rip v2-broadcast

To allow Routing Information Protocol (RIP) Version 2 update packets to be sent as broadcast packets instead of multicast packets, use the rip v2-broadcast command in interface configuration mode. To disable the broadcast of IP RIP Version 2 update packets that are sent as broadcast packets, use the no form of this command.

ip rip v2-broadcast

no ip rip v2-broadcast

Syntax Description

This command has no arguments or keywords.

Defaults

This command is disabled by default. Unless the ip rip v2-broadcast commend is entered, RIP Version 2 update packets are sent as multicast packets.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(5)T

This command was introduced.


Usage Guidelines

Use the ip rip v2-broadcast command to broadcast RIP Version 2 broadcast updates to hosts that do not listen to multicast broadcasts. Version 2 updates (requests and responses) will be sent to the IP broadcast address 255.255.255.255 instead of the IP multicast address 244.0.0.9.

In order to reduce unnecessary load on those hosts that are not listening to RIP Version 2 broadcasts, the system uses an IP multicast address for periodic broadcasts. The IP multicast address is 244.0.0.9.


Note It is not necessary to configure Internet Group Management Protocol (IGMP) because the periodic broadcasts are interrouter messages that are not forwarded.


Examples

The following example configures Version 2 IP broadcast updates on RIP Ethernet interface 3/1:

Router(config) interface ethernet3/1
Router(config-if) ip address 172.1.1.1 255.255.255.0
Router(config-if) ip rip v2-broadcast
.
.
.
Router(config-if) router rip
Router(config-if) version 2
Router(config-if) network 172.0.0.0

Enter debug ip rip command to verify that RIP Version 2 IP broadcast updates are being sent to the IP broadcast address 255.255.255 instead of IP multicast address 244.0.0.9:

Router# debug ip rip
14:41:59: RIP: sending v2 update to 255.255.255.255 via Ethernet3/1 (172.1.1.1)

If the ip rip v2-broadcast command has not been entered, the output from the debug ip rip command verifies that the RIP Version 2 IP broadcast updates are being sent to the IP multicast address 244.0.0.9:

Router# debug ip rip
15:45:16: RIP: sending v2 update to 244.0.0.9 via Ethernet3.1 (172.1.1.1)

Related Commands

Command
Description

debug ip rip

Displays information on RIP routing transactions.


ip split-horizon (RIP)

To enable the split horizon mechanism, use the ip split-horizon command in interface configuration mode. To disable the split horizon mechanism, use the no form of this command.

ip split-horizon

no ip split-horizon

Syntax Description

This command has no arguments or keywords.

Defaults

Default behavior varies with media type.

Command Modes

Interface configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

For all interfaces except those for which either Frame Relay or Switched Multimegabit Data Service (SMDS) encapsulation is enabled, the default condition for this command is ip split-horizon; in other words, the split horizon feature is active. If the interface configuration includes either the encapsulation frame-relay or encapsulation smds command, then the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.


Note For networks that include links over X.25 packet switched networks (PSNs), the neighbor router configuration command can be used to defeat the split horizon feature. You can as an alternative explicitly specify the no ip split-horizon command in your configuration. However, if you do so you must similarly disable split horizon for all routers in any relevant multicast groups on that network.



Note If split horizon has been disabled on an interface and you want to enable it, use the ip split-horizon command to restore the split horizon mechanism.



Note In general, changing the state of the default for the ip split-horizon command is not recommended, unless you are certain that your application requires a change in order to properly advertise routes. If split horizon is disabled on a serial interface (and that interface is attached to a PSN), you must disable split horizon for all routers and access servers in any relevant multicast groups on that network.


Examples

The following simple example disables split horizon on a serial link. The serial link is connected to an X.25 network.

interface serial 0
encapsulation x25
no ip split-horizon

Related Commands

Command
Description

neighbor (RIP)

Defines a neighboring router with which to exchange routing information.


ip summary-address rip

To configure a summary aggregrate address under an interface for the Routing Information Protocol (RIP), use the ip summary-address rip command in interface configuration mode. To disable summarization of the specified address or subnet, use the no form of this command.

ip summary-address rip ip-address ip-network-mask

no ip summary-address rip ip-address ip-network-mask

Syntax Description

ip-address

IP address to be summarized.

ip-network-mask

IP network mask that drives route summarization for the specified IP address.


Defaults

RIP automatically summarizes to classful network boundaries.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(6)T

This command was introduced.


Usage Guidelines

The ip summary-address rip command is used to summarize an address or subnet under a specific interface. RIP automatically summarizes to classful network boundaries. Only one summary address can be configured for each classful subnet.

Examples

In the following example the major network is 10.0.0.0. The summary address 10.2.0.0 overrides the autosummary address of 10.0.0.0, so that 10.2.0.0 is advertised out Ethernet interface 1 and 10.0.0.0 is not advertised.


Note If split horizon is enabled, neither autosummary nor interface summary addresses (those configured with the ip summary-address rip command) are advertised.


interface Ethernet1
 ip address 10.1.1.1 255.255.255.0
 ip summary-address rip 10.2.0.0 255.255.0 
 exit

router rip
 network 10.0.0.0
 end

Related Commands

Command
Description

auto-summary (RIP)

Restores the default behavior of automatic summarization of subnet routes into network-level routes.

ip split-horizon (RIP)

Enables the split horizon mechanism.


neighbor (RIP)

To define a neighboring router with which to exchange routing information, use the neighbor command in router configuration mode. To remove an entry, use the no form of this command.

neighbor ip-address

no neighbor ip-address

Syntax Description

ip-address

IP address of a peer router with which routing information will be exchanged.


Defaults

No neighboring routers are defined.

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

This command permits the point-to-point (nonbroadcast) exchange of routing information. When it is used in combination with the passive-interface router configuration command, routing information can be exchanged between a subset of routers and access servers on a LAN.

Multiple neighbor commands can be used to specify additional neighbors or peers.

Examples

In the following example, RIP updates are sent to all interfaces on network 10.108.0.0 except Ethernet interface 1. However, in this case a neighbor router configuration command is included. This command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated per neighbor.

router rip
 network 10.108.0.0
 passive-interface ethernet 1
 neighbor 10.108.20.4

Related Commands

Command
Description

passive-interface

Disables sending routing updates on an interface.


network (RIP)

To specify a list of networks for the Routing Information Protocol (RIP) routing process, use the network command in router configuration mode. To remove an entry, use the no form of this command.

network ip-address

no network ip-address

Syntax Description

ip-address

IP address of the network of directly connected networks.


Defaults

No networks are specified.

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

The network number specified must not contain any subnet information. There is no limit to the number of network commands you can use on the router. RIP routing updates will be sent and received only through interfaces on this network.

RIP sends updates to the interfaces in the specified networks. Also, if the network of an interface is not specified, the interface will not be advertised in any RIP update.

Examples

The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 10.99.0.0 and 192.168.7.0:

router rip
 network 10.99.0.0
 network 192.168.7.0

Related Commands

Command
Description

router rip

Configures the RIP routing process.


offset-list

To add an offset to incoming and outgoing metrics to routes learned via Routing Information Protocol (RIP), use the offset-list command in router configuration mode. To remove an offset list, use the no form of this command.

offset-list {access-list-number | access-list-name} {in | out} offset [interface-type interface-number]

no offset-list {access-list-number | access-list-name} {in | out} offset [interface-type interface-number]

Syntax Description

access-list-number

Standard access list number to be applied. Access list number 0 indicates all access lists. If offset is 0, no action is taken. For IGRP, the offset is added to the delay component only.

access-list-name

Standard access list name to be applied.

in

Applies the access list to incoming metrics.

out

Applies the access list to outgoing metrics.

offset

Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken.

interface-type

(Optional) Interface type to which the offset list is applied.

interface-number

(Optional) Interface number to which the offset list is applied.


Defaults

This command is disabled by default.

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

10.3

The interface-type and interface-number arguments were added.

11.2

The access-list-name argument was added.


Usage Guidelines

The offset value is added to the routing metric. An offset list with an interface type and interface number is considered extended and takes precedence over an offset list that is not extended. Therefore, if an entry passes the extended offset list and the normal offset list, the offset of the extended offset list is added to the metric.

Examples

In the following example, the router applies an offset of 10 to the delay component of a router only to access list 21:

offset-list 21 out 10

In the following example, the router applies an offset of 10 to routes learned from Ethernet interface 0:

offset-list 21 in 10 ethernet 0

output-delay

To change the interpacket delay for Routing Information Protocol (RIP) updates sent, use the output-delay command in router configuration mode. To remove the delay, use the no form of this command.

output-delay delay

no output-delay

Syntax Description

delay

Delay between packets in a multiple-packet RIP update (in milliseconds). The range is from 8 to 50. The default is 0.


Defaults

0 milliseconds

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

Consider using this command if you have a high-end router that is sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.

Examples

The following example sets the interpacket delay to 10 milliseconds:

router rip
 output-delay 10

router rip

To configure the Routing Information Protocol (RIP) routing process, use the router rip command in global configuration mode. To turn off the RIP routing process, use the no form of this command.

router rip

no router rip

Syntax Description

This command has no arguments or keywords.

Defaults

No RIP routing process is defined.

Command Modes

Global configuration

Command History

Release
Modification

10.0

This command was introduced.


Examples

The following example shows how to begin the RIP routing process:

router rip

Related Commands

Command
Description

network (RIP)

Specifies a list of networks for the RIP process.


show ip rip database

To display summary address entries in the Routing Information Protocol (RIP) routing database entries if relevant are routes being summarized based upon a summary address, use the show ip rip database command in EXEC mode.

show ip rip database[ip-address {mask}]

Syntax Description

ip-address

(Optional) Address about which routing information should be displayed.

mask

Argument for the subnet mask. The subnet mask must also be specified if the IP address argument is entered.


Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(6)T

This command was introduced.


Usage Guidelines

Summary address entries will appear in the database only if relevant child routes are being summarized. When the last child route for a summary address becomes invalid, the summary address is also removed from the routing table.

The RIP private database is populated only if triggered extensions to RIP are enabled with the ip rip triggered command.

Examples

The following output shows a summary address entry for route 10.11.0.0/16, with three child routes active:

Router# show ip rip database
 10.0.0.0/8    auto-summary
 10.11.11.0/24    directly connected, Ethernet2
 10.1.0.0/8    auto-summary
 10.11.0.0/16    int-summary
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^
 10.11.10.0/24    directly connected, Ethernet3
 10.11.11.0/24    directly connected, Ethernet4
 10.11.12.0/24    directly connected, Ethernet5

The following is sample output from the show ip rip database command with a prefix and mask:

Router# show ip rip database 172.19.86.0 255.255.255.0
172.19.86.0/24
    [1] via 172.19.67.38, 00:00:25, Serial0
    [2] via 172.19.70.36, 00:00:14, Serial1

Table 3 describes the fields in the displays.

Table 3 show ip rip database Field Descriptions

Field
Description

10.0.0.0/16 auto-summary

Summary address entry.

10.11.11.0/24 directly connected, Ethernet0

Directly connected entry for Ethernet 0.

172.19.65.0/24

[1] via 172.19.70.36, 00:00:17, Serial0

[2] via 172.19.67.38, 00:00:25, Serial1

The destination 172.19.65.0/24 is learned via RIP. There are two sources advertising it. One is 172.19.70.36 via Serial interface0, and it was updated 17 seconds ago. The other source is 172.19.67.38 via Serial interface 1, and it was updated 25 seconds ago.


Related Commands

Command
Description

ip rip triggered

Enables triggered extensions of RIP.

ip summary-address rip

Configures a Cisco router running RIP Version 2 to advertise a summarized local IP address pool on a network access server so that the address pool can be provided to dialup clients, and specifies the IP address and network mask that identify the routes to be summarized.

show ip protocols

Displays the parameters and current state of the active routing protocol process.


timers basic

To adjust Routing Information Protocol (RIP) network timers, use the timers basic command in router configuration mode. To restore the default timers, use the no form of this command.

timers basic update invalid holddown flush

no timers basic

Syntax Description

update

Rate (in seconds) at which updates are sent. This is the fundamental timing parameter of the routing protocol. The default is 30 seconds.

invalid

Interval of time (in seconds) after which a route is declared invalid. The interval should be at least three times the value of update time. The interval is measured from the last update received for the route. The route becomes invalid when there is an absence of updates during the invalid time that refresh the route. The route is marked inaccessible and advertised as unreachable. However, the route still forwards packets until the flush interval expires. The default is 180 seconds.

holddown

Interval (in seconds) during which routing information regarding better paths is suppressed. The interval should be at least three times the value of update time. A route enters into a holddown state when an update packet is received that indicates the route is unreachable. The route is marked inaccessible and advertised as unreachable. However, the route continues to forward packets until an update is received with a better metric or until the holddown time expires. When the holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. The default is 180 seconds.

flush

Amount of time (in seconds) that must pass before the route is removed from the routing table. The interval is measured from the last update received for the route. The interval should be longer than the larger of the invalid and holddown values. If the interval is less than the sum of the update and holddown values, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. The default is 240 seconds.


Defaults

update: 30 seconds
invalid: 180 seconds
holddown: 180 seconds
flush: 240 seconds

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

The basic timing parameters for RIP are adjustable. Because RIP is executing a distributed, asynchronous routing algorithm, these timers must be the same for all routers and access servers in the network.


Note The current and default timer values can be seen by inspecting the output of the show ip protocols EXEC command. The relationships of the various timers should be preserved as described previously.


Examples

The following example sets updates to be broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.

router rip
 timers basic 5  15  15  30


Note By setting a short update period, you run the risk of congesting slow-speed serial lines. A short update period can be a concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.


validate-update-source

To have the Cisco IOS software validate the source IP address of incoming routing updates for Routing Information Protocol (RIP) and Interior Gateway Routing Protocol (IGRP) routing protocols, use the validate-update-source command in router configuration mode. To disable this function, use the no form of this command.

validate-update-source

no validate-update-source

Syntax Description

This command has no arguments or keywords.

Defaults

The behavior of this command is enabled by default.

Command Modes

Router configuration

Command History

Release
Modification

10.0

This command was introduced.


Usage Guidelines

This command is applicable only to RIP and IGRP. The software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.

Disabling split horizon on the incoming interface will also cause the system to perform this validation check.

For unnumbered IP interfaces (interfaces configured as IP unnumbered), no checking is performed.

Examples

The following example configures a router not to perform validation checks on the source IP address of incoming RIP updates:

router rip
 network 10.105.0.0
 no validate-update-source

version

To specify a Routing Information Protocol (RIP) version used globally by the router, use the version command in router configuration mode. To restore the default value, use the no form of this command.

version {1 | 2}

no version

Syntax Description

1

Specifies RIP Version 1.

2

Specifies RIP Version 2.


Defaults

The software receives RIP Version 1 and Version 2 packets, but sends only Version 1 packets.

Command Modes

Router configuration

Command History

Release
Modification

11.1

This command was introduced.


Usage Guidelines

To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.

Examples

The following example enables the software to send and receive RIP Version 2 packets:

version 2

Related Commands

Command
Description

ip rip receive version

Specifies a RIP version to receive on an interface basis.

ip rip send version

Specifies a RIP version to send on an interface basis.

show ip protocols

Displays the parameters and current state of the active routing protocol process.