Multiprotocol BGP Extensions for IP Multicast Commands
ErrorMessage : Error while constructing the Hinav

null
Downloads: This chapterpdf (PDF - 211.0KB) | Feedback

Multiprotocol BGP Extensions for IP Multicast Commands

Table Of Contents

Multiprotocol BGP Extensions for IP Multicast Commands

address-family ipv4

address-family vpnv4

distance mbgp

ip dvmrp metric

ip multicast cache-headers

match nlri

redistribute dvmrp

set nlri

show ip mbgp

show ip bgp ipv4 multicast

show ip mbgp summary

show ip bgp ipv4 multicast summary


Multiprotocol BGP Extensions for IP Multicast Commands


Use the commands in this chapter to configure and monitor multiprotocol BGP. Multiprotocol BGP is based on RFC 2283, Multiprotocol Extensions for BGP-4. For multiprotocol BGP configuration information and examples, refer to the "Configuring Multiprotocol BGP Extensions for IP Multicast" chapter of the Cisco IOS IP Configuration Guide. For BGP configuration information and examples, refer to the "Configuring BGP" chapter of the Cisco IOS IP Configuration Guide. For BGP command descriptions, refer to the "BGP Commands" chapter of this document.

Commands in this chapter that have been replaced by new or existing commands are no longer documented. Table 48 maps the previous commands to their replacements.

Table 48 Mapping Previous Commands to Replacement Commands

Old Command
Replacement Command

distance mbgp

distance bgp

match nlri

address-family ipv4

address-family vpnv4

set nlri

address-family ipv4

or

address-family vpnv4

show ip mbgp

show ip bgp ipv4 multicast

show ip mbgp summary

show ip bgp ipv4 multicast summary


address-family ipv4

To enter address family configuration mode for configuring routing sessions such as BGP that use standard IP Version 4 address prefixes, use the address-family ipv4 command in router configuration mode. To disable address family configuration mode, use the no form of this command.

address-family ipv4 [multicast | unicast | vrf vrf-name]

no address-family ipv4 [multicast | unicast | vrf vrf-name]

Syntax Description

multicast

(Optional) Specifies IP Version 4 multicast address prefixes.

unicast

(Optional) Specifies IP Version 4 unicast address prefixes.

vrf vrf-name

(Optional) Specifies the name of the virtual routing and forwarding (VRF) instance to associate with subsequent IP Version 4 address family configuration mode commands.


Defaults

IP Version 4 address prefixes are not enabled. Unicast address prefixes are the default when IP Version 4 address prefixes are configured.

Command Modes

Router configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

The address-family ipv4 command places the router in address family configuration mode (prompt: config-router-af), from which you can configure routing sessions that use standard IP Version 4 address prefixes. To leave address family configuration mode and return to router configuration mode, type exit.

Routing information for address family IP Version 4 is advertised by default when you configure a BGP routing session using the neighbor remote-as command unless you enter the no bgp default ipv4-unicast command.

The address-family ipv4 command replaces the match nlri and set nlri commands.

Examples

The following example places the router in address family configuration mode for the IP Version 4 address family:

Router(config)# router bgp 100
Router(config-router)# address-family ipv4
Router(config-router-af)#

The following example places the router in address family configuration mode and specifies multicast address prefixes for the IP Version 4 address family:

Router(config)# router bgp 100
Router(config-router)# address-family ipv4 multicast
Router(config-router-af)#

The following example places the router in address family configuration mode and specifies unicast address prefixes for the IP Version 4 address family:

Router(config)# router bgp 100
Router(config-router)# address-family ipv4 unicast
Router(config-router-af)#

The following example places the router in address family configuration mode and specifies cisco as the name of the VRF instance to associate with subsequent IP Version 4 address family configuration mode commands:

Router(config)# router bgp 100
Router(config-router)# address-family ipv4 vrf cisco
Router(config-router-af)#

Use this form of the command, which specifies a VRF, only to configure routing exchanges between provider edge (PE) and customer edge (CE) devices.

Related Commands

Command
Description

address-family vpnv4

Places the router in address family configuration mode for configuring routing sessions such as BGP, RIP, or static routing sessions that use standard VPN Version 4 address prefixes.

neighbor activate

Enables the exchange of information with a BGP neighboring router.


address-family vpnv4

To enter address family configuration mode for configuring routing sessions, such as BGP, that use standard Virtual Private Network (VPN) Version 4 address prefixes, use the address-family vpnv4 command in router configuration mode. To disable address family configuration mode, use the no form of this command.

address-family vpnv4 [unicast]

no address-family vpnv4 [unicast]

Syntax Description

unicast

(Optional) Specifies VPN Version 4 unicast address prefixes.


Defaults

VPN Version 4 address prefixes are not enabled. Unicast address prefixes are the default when VPN Version 4 address prefixes are configured.

Command Modes

Router configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

The address-family vpnv4 command places the router in address family configuration mode (prompt: config-router-af), from which you can configure routing sessions that use VPN Version 4 address prefixes. To leave address family configuration mode and return to router configuration mode, type exit.

The address-family vpnv4 command replaces the match nlri and set nlri commands.

Examples

The following example places the router in address family configuration mode for the VPN Version 4 address family:

Router(config)# router bgp 100
(config-router)# address-family vpnv4
(config-router-af)#

The following example places the router in address family configuration mode for the unicast VPN Version 4 address family:

Router(config)# router bgp 100
(config-router)# address-family vpnv4 unicast
(config-router-af)#

Related Commands

Command
Description

address-family ipv4

Places the router in address family configuration mode for configuring routing sessions such as BGP, RIP, or static routing sessions that use standard IP Version 4 address prefixes.

neighbor activate

Enables the exchange of information with a BGP neighboring router.


distance mbgp

The distance mbgp command is replaced by the distance bgp command. See the description of the distance bgp command in the "BGP Commands" chapter for more information.

ip dvmrp metric

To configure the metric associated with a set of destinations for Distance Vector Multicast Routing Protocol (DVMRP) reports, use the ip dvmrp metric command in interface configuration mode. (Note that this command has two different syntax possibilities.) To disable this function, use the no form of this command.

ip dvmrp metric metric [route-map map-name] [mbgp] [list access-list-number] [[protocol process-id] | dvmrp]

no ip dvmrp metric metric [route-map map-name] [mbgp] [list access-list-number] [[protocol process-id] | dvmrp]

Syntax Description

metric

Metric associated with a set of destinations for DVMRP reports. It can be a value from 0 to 32. A value of 0 means that the route is not advertised. A value of 32 is equivalent to infinity (unreachable).

route-map map-name

(Optional) Name of a route map. If you specify this argument, only the destinations that match the route map are reported with the configured metric. Unicast routes are subject to route map conditions before being injected into DVMRP. Route maps cannot be used for DVMRP routes.

mbgp

(Optional) Configures redistribution of only IP Version 4 multicast routes into DVMRP.

list access-list-number

(Optional) Number of an access list. If you specify this argument, only the multicast destinations that match the access list are reported with the configured metric. Any destinations not advertised because of split horizon do not use the configured metric.

protocol

(Optional) Name of unicast routing protocol, such as bgp, dvmrp, eigrp, igrp, isis, ospf, rip, or static.

If you specify these values, only routes learned by the specified routing protocol are advertised in DVMRP report messages.

process-id

(Optional) Process ID number of the unicast routing protocol.

dvmrp

(Optional) Allows routes from the DVMRP routing table to be advertised with the configured metric value, or filtered.


Defaults

No metric is preconfigured. Only directly connected subnets and networks are advertised to neighboring DVMRP routers.

Command Modes

Interface configuration

Command History

Release
Modification

10.2

This command was introduced.

11.1

The route-map keyword was added.

11.1(20)CC

This mbgp keyword was added.

12.0(7)T

This mbgp keyword was added.


Usage Guidelines

When Protocol Independent Multicast (PIM) is configured on an interface and DVMRP neighbors are discovered, the Cisco IOS software sends DVMRP report messages for directly connected networks. The ip dvmrp metric command enables DVMRP report messages for multicast destinations that match the access list. Usually, the metric for these routes is 1. Under certain circumstances, you might want to tailor the metric used for various unicast routes. This command lets you configure the metric associated with a set of destinations for report messages sent out this interface.

You can use the access-list-number argument in conjunction with the protocol and process-id arguments to selectively list the destinations learned from a given routing protocol.

To display DVMRP activity, use the debug ip dvmrp command.

Examples

The following example connects a PIM cloud to a DVMRP cloud. Access list 1 permits the sending of DVMRP reports to the DVMRP routers advertising all sources in the 172.16.35.0 network with a metric of 1. Access list 2 permits all other destinations, but the metric of 0 means that no DVMRP reports are sent for these destinations.

access-list 1 permit 172.16.35.0 0.0.0.255
access-list 1 deny 0.0.0.0 255.255.255.255
access-list 2 permit 0.0.0.0 255.255.255.255
interface tunnel 0
 ip dvmrp metric 1 list 1
 ip dvmrp metric 0 list 2

The following example redistributes IP Version 4 multicast routes into DVMRP neighbors with a metric of 1:

interface tunnel 0
 ip dvmrp metric 1 mbgp

Related Commands

Command
Description

debug ip dvmrp

Displays information on DVMRP packets received and sent.

ip dvmrp accept-filter

Configures an acceptance filter for incoming DVMRP reports.


ip multicast cache-headers

To allocate a circular buffer to store IP Version 4 multicast packet headers that the router receives, use the ip multicast cache-headers global configuration command. To disable the buffer, use the no form of this command.

ip multicast cache-headers [rtp]

no ip multicast cache-headers

Syntax Description

rtp

(Optional) Caches Real-Time Transport Protocol (RTP) headers.


Defaults

This command is disabled by default.

Command Modes

Global configuration

Command History

Release
Modification

11.1

This command was introduced.

11.1(20)CC

The rtp keyword was added.

12.0(7)T

The rtp keyword was added.


Usage Guidelines

You can store IP Version 4 multicast packet headers in a cache and then display them to determine the following information:

Who is sending IP multicast packets to which groups

Interpacket delay

Duplicate IP multicast packets (if any)

Multicast forwarding loops in your network (if any)

Scope of the group

User Datagram Protocol (UDP) port numbers

Packet length


Note This feature allocates a circular buffer of approximately 32 KB. Do not configure this feature if the router is low on memory.


Use the show ip mpacket command to display the buffer.

Examples

The following example allocates a buffer to store IP Version 4 multicast packet headers:

ip multicast cache-headers

Related Commands

Command
Description

show ip mpacket

Displays the contents of the circular cache-header buffer.


match nlri

The match nlri command is replaced by the address-family ipv4 and address-family vpnv4 commands. See the description of the address-family ipv4 or address-family vpnv4 command for more information.

redistribute dvmrp

To configure redistribution of Distance Vector Multicast Routing Protocol (DVMRP) routes into multiprotocol BGP, use the redistribute dvmrp command in address family or router configuration mode. To stop such redistribution, use the no form of this command.

redistribute dvmrp [route-map map-name]

no redistribute dvmrp [route-map map-name]

Syntax Description

route-map map-name

(Optional) Name of the route map that contains various BGP attribute settings.


Defaults

DVMRP routes are not redistributed into multiprotocol BGP.

Command Modes

Address family configuration

Router configuration

Command History

Release
Modification

11.1(20)CC

This command was introduced.

12.0(7)T

Address family configuration mode was added.


Usage Guidelines

Use this command if you have a subset of DVMRP routes in an autonomous system that you want to take the multiprotocol BGP path. Define a route map to further specify which DVMRP routes get redistributed.

Examples

The following router configuration mode example redistributes DVMRP routes to BGP peers that match access list 1:

router bgp 109
 redistribute dvmrp route-map dvmrp-into-mbgp
route-map dvmrp-into-mbgp
 match ip address 1

The following address family configuration mode example redistributes DVMRP routes to multiprotocol BGP peers that match access list 1:

router bgp 109
address-family ipv4 multicast
 redistribute dvmrp route-map dvmrp-into-mbgp

route-map dvmrp-into-mbgp
 match ip address 1

set nlri

The set nlri command is replaced by the address-family ipv4 and address-family vpnv4 commands. See the description of the address-family ipv4 or address-family vpnv4 command for more information.

show ip mbgp

The show ip mgbp command is replaced by the show ip bgp ipv4 multicast command. See the description of the show ip bgp ipv4 multicast command for more information.

show ip bgp ipv4 multicast

To display IP Version 4 multicast database-related information, use the show ip bgp ipv4 multicast command in EXEC mode.

show ip bgp ipv4 multicast [command]

Syntax Description

command

(Optional) Any multiprotocol BGP command supported by the show ip bgp ipv4 multicast command.


Command Modes

EXEC

Command History

Release
Modification

12.0(7)T

This command was introduced.


Usage Guidelines

Use this command in conjunction with the show ip rpf command to determine if IP multicast routing is using multiprotocol BGP routes.

To determine which multiprotocol BGP commands are supported by the show ip bgp ipv4 multicast command, enter the following command while in EXEC mode:

Router# show ip bgp ipv4 multicast ? 

The show ip bgp ipv4 multicast command replaces the show ip mbgp command.

Examples

The following is sample output from the show ip bgp ipv4 multicast command:

Router# show ip bgp ipv4 multicast

MBGP table version is 6, local router ID is 192.168.200.66
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop          Metric LocPrf Weight Path
*> 10.0.20.16/28     0.0.0.0                0      0 32768 i
*> 10.0.35.16/28     0.0.0.0                0      0 32768 i
*> 10.0.36.0/28      0.0.0.0                0      0 32768 i
*> 10.0.48.16/28     0.0.0.0                0      0 32768 i
*> 10.2.0.0/16       0.0.0.0                0      0 32768 i
*> 10.2.1.0/24       0.0.0.0                0      0 32768 i
*> 10.2.2.0/24       0.0.0.0                0      0 32768 i
*> 10.2.3.0/24       0.0.0.0                0      0 32768 i
*> 10.2.7.0/24       0.0.0.0                0      0 32768 i
*> 10.2.8.0/24       0.0.0.0                0      0 32768 i
*> 10.2.10.0/24      0.0.0.0                0      0 32768 i
*> 10.2.11.0/24      0.0.0.0                0      0 32768 i
*> 10.2.12.0/24      0.0.0.0                0      0 32768 i
*> 10.2.13.0/24      0.0.0.0                0      0 32768 i

Table 49 describes the significant fields shown in the display.

Table 49 show ip bgp ipv4 multicast Field Descriptions 

Field
Description

MBGP table version

Internal version number of the table. This number is incremented whenever the table changes.

local router ID

IP address of the router.

Status codes

Status of the table entry. The status is displayed at the beginning of each line in the table. It can be one of the following values:

s—The table entry is suppressed.

d—The table entry is dampened.

h—The table entry is historical.

*—The table entry is valid.

>—The table entry is the best entry to use for that network.

i—The table entry was learned via an internal BGP (iBGP) session.

Origin codes

Origin of the entry. The origin code is placed at the end of each line in the table. It can be one of the following values:

i—Entry originated from an Interior Gateway Protocol (IGP) and was advertised with a network router configuration or address family configuration command.

e—Entry originated from an Exterior Gateway Protocol (EGP).

?—Origin of the path is not clear. Usually, this is a router that is redistributed into BGP from an IGP.

Network

IP address of a network entity.

Next Hop

IP address of the next system that is used when forwarding a packet to the destination network. An entry of 0.0.0.0 indicates that the router has some non-BGP routes to this network.

Metric

If shown, the value of the interautonomous system metric.

LocPrf

Local preference value as set with the set local-preference route-map configuration command. The default value is 100.

Weight

Weight of the route as set via autonomous system filters.

Path

Autonomous system paths to the destination network. There can be one entry in this field for each autonomous system in the path.


Related Commands

Command
Description

show ip rpf

Displays how IP multicast routing does RPF.


show ip mbgp summary

The show ip mbgp summary command is replaced by the show ip bgp ipv4 multicast summary command. See the description of the show ip bgp ipv4 multicast summary command for more information.

show ip bgp ipv4 multicast summary

To display a summary of IP Version 4 multicast database-related information, use the show ip bgp ipv4 multicast summary command in EXEC mode.

show ip bgp ipv4 multicast summary

Syntax Description

This command has no arguments or keywords.

Command Modes

EXEC

Command History

Release
Modification

12.0(7)T

This command was introduced.


Usage Guidelines

The show ip bgp ipv4 multicast summary command replaces the show ip mbgp summary command.

Examples

The following is sample output from the show ip bgp ipv4 multicast summary command:

Router# show ip bgp ipv4 multicast summary

BGP router identifier 10.0.33.34, local AS number 34
BGP table version is 5, main routing table version 1
4 network entries and 6 paths using 604 bytes of memory
5 BGP path attribute entries using 260 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP community entries using 48 bytes of memory
2 BGP route-map cache entries using 32 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 8/28 prefixes, 12/0 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.33.35      4    35     624     624        5    0    0 10:13:46        3 

Table 50 describes the significant fields shown in the display.

Table 50 show ip bgp ipv4 multicast summary Field Descriptions 

Field
Description

Neighbor

IP address of configured neighbor in the multicast routing table.

V

Version of multiprotocol BGP used.

AS

Autonomous system to which the neighbor belongs.

MsgRcvd

Number of messages received from the neighbor.

MsgSent

Number of messages sent to the neighbor.

TblVer

Number of the table version, which is incremented each time the table changes.

InQ

Number of messages received in the input queue.

OutQ

Number of messages ready to go in the output queue.

Up/Down

Days and hours that the neighbor has been up or down (no information in the State column means the connection is up).

State/PfxRcd

State of the neighbor/number of routes received. If no state is indicated, the state is up.


Related Commands

Command
Description

show ip rpf

Displays how IP multicast routing does RPF.