Cisco IOS IP Configuration Guide, Release 12.2
Configuring Multiprotocol BGP Extensions for IP Multicast
Downloads: This chapterpdf (PDF - 226.0KB) The complete bookPDF (PDF - 6.41MB) | Feedback

Configuring Multiprotocol BGP Extensions for IP Multicast

Table Of Contents

Configuring Multiprotocol BGP Extensions for IP Multicast

Multiprotocol BGP Configuration Task List

Understanding NLRI Keywords and Address Families

Configuring a Multiprotocol BGP Peer

Configuring a Multiprotocol BGP Peer Group

Advertising Routes into Multiprotocol BGP

Configuring Route Maps for Multiprotocol BGP Prefixes

Redistributing Prefixes into Multiprotocol BGP

Configuring DVMRP Interoperability with Multiprotocol BGP

Redistributing Multiprotocol BGP Routes into DVMRP

Redistributing DVMRP Routes into Multiprotocol BGP

Configuring a Multiprotocol BGP Route Reflector

Configuring Aggregate Multiprotocol BGP Addresses

Verifying Multiprotocol BGP Configuration and Operation

Multiprotocol BGP Configuration Examples

Multiprotocol BGP Peer Examples

Multiprotocol BGP Peer Group Examples

Multiprotocol BGP Network Advertisement Examples

Multiprotocol BGP Route Map Examples

Multiprotocol BGP Route Redistribute Examples

Multiprotocol BGP Route Reflector Examples

Aggregate Multiprotocol BGP Address Examples


Configuring Multiprotocol BGP Extensions for IP Multicast


This chapter describes the multiprotocol Border Gateway Protocol (BGP) based upon RFC 2283, Multiprotocol Extensions for BGP-4. For a complete description of the multiprotocol BGP commands in this chapter, refer to the "Multiprotocol BGP Extensions for IP Multicast Commands" chapter of the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols. To locate documentation for other commands that appear in this chapter, use the command reference master index, or search online. For BGP configuration information and examples, refer to the "Configuring BGP" chapter of the Cisco IOS IP Configuration Guide. For BGP command descriptions, refer to the "BGP Commands" chapter of the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols.

To identify the hardware platform or software image information associated with a feature, use the Feature Navigator on Cisco.com to search for information about the feature or refer to the software release notes for a specific release. For more information, see the "Identifying Supported Platforms" section in the "Using Cisco IOS Software" chapter in this book.

An extension of BGP, multiprotocol BGP offers the following benefits:

A network can support incongruent unicast and multicast topologies.

A network can support congruent unicast and multicast topologies that have different policies (BGP filtering configurations).

A network can carry routing information for multiple network layer protocol address families (for example, IP Version 4 or VPN Version 4) as specified in RFC 1700, Assigned Numbers.

A network that is backward compatible—routers that support the multiprotocol extensions can interoperate with routers that do not support the extensions.

All of the routing policy capabilities of BGP can be applied to multiprotocol BGP.

All of the BGP commands can be used with multiprotocol BGP.

You should be familiar with BGP and IP multicast routing before you attempt to configure multiprotocol BGP. For IP multicast configuration information and examples, refer to the "IP Multicast" part of this document and Cisco IOS IP Command Reference, Volume 3 of 3: Multicast.

Multiprotocol BGP is an enhanced BGP that carries routing information for multiple network layer protocols and IP multicast routes. BGP carries two sets of routes, one set for unicast routing and one set for multicast routing. The routes associated with multicast routing are used by the Protocol Independent Multicast (PIM) feature to build data distribution trees.

Multiprotocol BGP is useful when you want a link dedicated to multicast traffic, perhaps to limit which resources are used for which traffic. Perhaps you want all multicast traffic exchanged at one network access point (NAP). Multiprotocol BGP allows you to have a unicast routing topology different from a multicast routing topology. Thus, you have more control over your network and resources.

In BGP, the only way to perform interdomain multicast routing was to use the BGP infrastructure that was in place for unicast routing. If those routers were not multicast-capable, or there were differing policies where you wanted multicast traffic to flow, multicast routing could not be supported without multiprotocol BGP.


Note It is possible to configure BGP peers that exchange both unicast and multicast network layer reachability information (NLRI), but you cannot connect multiprotocol BGP clouds with a BGP cloud. That is, you cannot redistribute multiprotocol BGP routes into BGP.


Figure 60 illustrates a simple example of unicast and multicast topologies that are incongruent, and therefore are not possible without multiprotocol BGP.

Autonomous systems 100, 200, and 300 are each connected to two NAPs that are FDDI rings. One is used for unicast peering (and therefore the exchanging of unicast traffic). The Multicast Friendly Interconnect (MFI) ring is used for multicast peering (and therefore the exchanging of multicast traffic). Each router is unicast- and multicast-capable.

Figure 60 Incongruent Unicast and Multicast Routes

Figure 61 is a topology of unicast-only routers and multicast-only routers. The two routers on the left are unicast-only routers (that is, they do not support or are not configured to perform multicast routing). The two routers on the right are multicast-only routers. Routers A and B support both unicast and multicast routing. The unicast-only and multicast-only routers are connected to a single NAP.

In Figure 61, only unicast traffic can travel from Router A to the unicast routers to Router B and back. Multicast traffic could not flow on that path, so another routing table is required. Multicast traffic uses the path from Router A to the multicast routers to Router B and back.

Figure 61 illustrates a multiprotocol BGP environment with a separate unicast route and multicast route from Router A to Router B. Multiprotocol BGP allows these routes to be noncongruent. Both of the autonomous systems must be configured for internal multiprotocol BGP (IMBGP) in the figure.

A multicast routing protocol, such as PIM, uses the multicast BGP database to perform Reverse Path Forwarding (RPF) lookups for multicast-capable sources. Thus, packets can be sent and accepted on the multicast topology but not on the unicast topology.

Figure 61 Multicast BGP Environment

Multiprotocol BGP Configuration Task List

To configure multiprotocol BGP, perform the following tasks described in the following sections. Each section in the list is identified as either required or optional.

Understanding NLRI Keywords and Address Families (Required)

Configuring a Multiprotocol BGP Peer (Required)

Configuring a Multiprotocol BGP Peer Group (Optional)

Advertising Routes into Multiprotocol BGP (Required)

Configuring Route Maps for Multiprotocol BGP Prefixes (Optional)

Redistributing Prefixes into Multiprotocol BGP (Required)

Configuring DVMRP Interoperability with Multiprotocol BGP (Optional)

Configuring a Multiprotocol BGP Route Reflector (Optional)

Configuring Aggregate Multiprotocol BGP Addresses (Optional)

Verifying Multiprotocol BGP Configuration and Operation (Optional)

Understanding NLRI Keywords and Address Families

Multiprotocol BGP was introduced in Cisco IOS Release 11.1(20)CC and Cisco IOS Release 12.0(2)S prior to it being integrated into Cisco IOS Release 12.1. In Cisco IOS Release 11.1(20)CC and later releases and Cisco IOS Release 12.0(2)S and later releases, the Cisco IOS software uses NLRI keywords to enable multiprotocol BGP over a BGP session and to populate unicast BGP prefixes in the unicast database and multicast BGP prefixes in the multicast database. In Cisco IOS Release 12.1, the Cisco IOS software uses separate address families to enable multiprotocol BGP over a BGP session and to populate unicast BGP prefixes in the unicast database and multicast BGP prefixes in the multicast database.

Cisco IOS Release 12.1 does not support the NLRI keywords. However, for backward compatibility, the NLRI keyword configuration of a Cisco router is automatically converted to an address family configuration when a router is upgraded to Cisco IOS Release 12.1. The following example shows an NLRI keyword configuration for a Cisco router that is running Cisco IOS Release 12.0(8)S:

router bgp 5
 no synchronization
 network 172.16.214.0 mask 255.255.255.0 nlri unicast multicast
 neighbor 172.16.214.34 remote-as 5
 neighbor 172.16.214.38 remote-as 2 nlri unicast multicast
 neighbor 172.16.214.42 remote-as 5
 neighbor 172.16.214.59 remote-as 5
 no auto-summary

The following example shows the resulting address family configuration after the same router is upgraded to Cisco IOS Release 12.1:

router bgp 5
 no synchronization
 network 172.16.214.0 mask 255.255.255.0
 neighbor 172.16.214.34 remote-as 5
  neighbor 172.16.214.38 remote-as 2
 neighbor 172.16.214.42 remote-as 5
 neighbor 172.16.214.59 remote-as 5
 no auto-summary

Note Although supported in Cisco IOS Release 12.1, the following sections do not explain how to configure the BGP-4 extensions for Virtual Private Network (VPN) address family prefixes. Configuring VPN address family prefixes will be explained in a later release of the Cisco IOS IP Configuration Guide and the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols.


Configuring a Multiprotocol BGP Peer

To configure multiprotocol BGP between two routers, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# neighbor ip-address remote-as autonomous-system-number

Adds the IP address of the neighbor in the remote autonomous system to the multiprotocol BGP neighbor table of the local router.

Step 3 

Router(config-router)# address-family ipv4 multicast

Specifies the IPv4 address family type and places the router in address family configuration mode.

Step 4 

Router(config-router-af)# neighbor {ip-address | peer-group-name} activate

Enables the neighbor to exchange prefixes for the specified family type with the local router.


Note By default, neighbors that are defined using the neighbor remote-as command in router configuration mode exchange only unicast address prefixes. To exchange other address prefix types, such as multicast and VPNv4, neighbors must also be activated using the neighbor activate command in address family configuration mode, as shown.


See the "Multiprotocol BGP Peer Examples" section for multiprotocol BGP peer configuration examples.

Configuring a Multiprotocol BGP Peer Group

To configure a peer group to perform multiprotocol BGP routing, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# neighbor peer-group-name peer-group

Creates a multiprotocol BGP peer group.

Step 3 

Router(config-router)# neighbor ip-address remote-as autonomous-system-number

Adds the IP address of the neighbor in the remote autonomous system to the multiprotocol BGP neighbor table of the local router.

Step 4 

Router(config-router)# neighbor ip-address peer-group peer-group-name

Assigns the IP address of a BGP neighbor to a peer group.

Step 5 

Router(config-router)# address-family ipv4 multicast

Specifies the IP Version 4 address family type and places the router in address family configuration mode.

Step 6 

Router(config-router-af)# neighbor peer-group-name activate

Enables the peer group to exchange prefixes for the specified family type with the neighbor and the local router.

Step 7 

Router(config-router-af)# neighbor ip-address peer-group peer-group-name

Assigns the IP address of a BGP neighbor to a peer group.


Note By default, neighbors that are defined using the neighbor remote-as command in router configuration mode exchange only unicast address prefixes. To exchange other address prefix types, such as multicast and VPNv4, neighbors must also be activated using the neighbor activate command in address family configuration mode, as shown.



Note Peer groups that are defined in router configuration mode using the neighbor peer-group command exchange only unicast address prefixes by default. To exchange other address prefix types, such as multicast, peer groups must be defined in address family configuration mode using the neighbor activate command, as shown.

Members of a peer group automatically inherit the address prefix configuration of the peer group.


Refer to the section "Configure BGP Peer Groups" of the "Configuring BGP" chapter in the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols for information and instructions on assigning options to the peer group and making a BGP or multiprotocol BGP neighbor a member of the peer group.

See the "Multiprotocol BGP Peer Group Examples" section for an example of configuring multiprotocol BGP peer groups.

Advertising Routes into Multiprotocol BGP

To advertise (inject) a network number and mask into multiprotocol BGP, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# address-family ipv4 multicast

Specifies the IP Version 4 address family type and places the router in address family configuration mode.

Step 3 

Router(config-router-af)# network network-number [mask network-mask]

Advertises (injects) this network number and mask into the multicast BGP database. (The routes must first be found in the unicast forwarding table.) Specifically, the network number and mask are injected into the multicast database for the address family specified in the previous step.

Routes are tagged from the specified network as "local origin."


Note Networks that are defined in router configuration mode using the network command are injected into the unicast database by default. To inject a network into another database, such as the multicast database, the network must be defined in address family configuration mode using the network command, as shown.


To redistribute Distance Vector Multicast Routing Protocol (DVMRP) routes into multiprotocol BGP, see the "Redistributing DVMRP Routes into Multiprotocol BGP" section. See the "Multiprotocol BGP Network Advertisement Examples" section for multiprotocol BGP network advertisement configuration examples.

Configuring Route Maps for Multiprotocol BGP Prefixes

To configure a route map for multiprotocol BGP prefixes, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# neighbor ip-address remote-as autonomous-system-number

Adds the IP address of the neighbor in the remote autonomous system to the multiprotocol BGP neighbor table of the local router.

Step 3 

Router(config-router)# address-family ipv4 multicast

Specifies the IP Version 4 address family type and places the router in address family configuration mode.

Step 4 

Router(config-router-af)# neighbor ip-address activate

Enables the address family for the neighbor in the remote autonomous system.

Step 5 

Router(config-router-af)# neighbor ip-address route-map route-map-name {in | out}

Applies a route map to incoming or outgoing routes.

Step 6 

Router(config)# route-map map-tag [permit | deny] [sequence-number]

Defines a route map.

Step 7 

Router(config-route-map)# match ip-address access-list-number

Distributes any routes that have a destination network number address permitted by a standard or extended access list, or performs policy routing on packets.


Note By default, neighbors that are defined using the neighbor remote-as command in router configuration mode exchange only unicast address prefixes. To exchange other address prefix types, such as multicast and VPNv4, neighbors must also be activated using the neighbor activate command in address family configuration mode, as shown.



Note Route maps that are applied in router configuration mode using the neighbor route-map command are applied to unicast address prefixes by default. Route maps for other address families, such as multicast, must be applied in address family configuration mode using the neighbor route-map command, as shown. The route maps are applied either as the inbound or outbound routing policy for neighbors under each address family. Configuring separate route maps under each address family simplifies managing complicated or different policies for each address family.


See the "Multiprotocol BGP Route Map Examples" section for multiprotocol BGP route map configuration examples.

Redistributing Prefixes into Multiprotocol BGP

Redistribution is the process of injecting prefixes from one routing protocol into another routing protocol. The tasks in this section explain how to inject prefixes from a routing protocol into multiprotocol BGP. Specifically, prefixes that are redistributed into multiprotocol BGP using the redistribute command are injected into the unicast database, the multicast database, or both.

To inject prefixes from a routing protocol into multiprotocol BGP, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# address-family ipv4 multicast

Specifies the IP Version 4 address family type and places the router in address family configuration mode.

Step 3 

Router(config-router-a)# redistribute protocol [process-id] [route-map map-name]

Specifies the routing protocol from which prefixes should be redistributed into multiprotocol BGP. Issue the exit command two times to return to global configuration mode.

Step 4 

Router(config)# route-map map-tag [permit | deny] [sequence-number]

Defines a route map and places the router in route map configuration mode.

Follow this step with a match command.

Step 5 

Router(config-route-map)# match ip-address access-list-number

Distributes any prefixes that have a destination network number address permitted by a standard or extended access list, or performs policy routing on packets.


Note Route maps that are applied in router configuration mode using the redistribute route-map command are applied to unicast address prefixes by default. Route maps for other address families, such as multicast, must be applied in address family configuration mode using the redistribute route-map command, as shown.


See the "Multiprotocol BGP Route Redistribute Examples" section for multiprotocol BGP route redistribution configuration examples.

Configuring DVMRP Interoperability with Multiprotocol BGP

Cisco multicast routers using PIM can interoperate with non-Cisco multicast routers that use DVMRP.

PIM routers dynamically discover DVMRP multicast routers on attached networks. Once a DVMRP neighbor has been discovered, the router caches DVMRP routes that the neighbor sends. Those routes describe sources in a DVMRP cloud that want their packets to be received by receivers outside of this routing domain. Multiprotocol BGP allows the source prefixes of those sources to be known outside of the routing domain.

The router periodically sends DVMRP report messages advertising the unicast sources reachable in the PIM domain.

Redistributing Multiprotocol BGP Routes into DVMRP

By default, no multiprotocol BGP routes are redistributed into DVMRP. However, you can configure all multiprotocol BGP routes to be redistributed into DVMRP with a specified metric. Furthermore, to redistribute only certain multiprotocol BGP routes into DVMRP, you can configure the metric and subject it to route map conditions. If you supply a route map, you can specify various match criteria options for the multiprotocol BGP routes. If the route passes the route map, then the route is redistributed into DVMRP.

If there are multicast sources in other routing domains that are known via multiprotocol BGP and there are receivers in a DVMRP cloud, they will want to receive packets from those sources. Therefore, you need to redistribute the multiprotocol BGP prefix routes into DVMRP. This will be the scenario when distributing multiprotocol BGP prefixes into the MBONE.

To redistribute multiprotocol BGP routes into DVMRP, use the following command in interface configuration mode:

Command
Purpose

Router(config-if)# ip dvmrp metric metric [route-map map-name] mbgp

Redistributes multiprotocol BGP routes into DVMRP with a specified metric. An optional route map controls which routes are redistributed; otherwise, all multiprotocol BGP routes are redistributed.


Redistributing DVMRP Routes into Multiprotocol BGP

If there are multicast sources in a DVMRP routing domain that need to reach receivers in multiprotocol BGP routing domains, you need to redistribute DVMRP prefixes into multiprotocol BGP. If you supply a route map, you can also use the set route-map configuration commands to specify various BGP attribute settings.

To redistribute DVMRP prefixes into multiprotocol BGP, use the following command in address family configuration mode:

Command
Purpose

Router(config-router-af)# redistribute dvmrp [route-map map-name]

Redistributes DVMRP routes into multiprotocol BGP.


To redistribute DVMRP prefixes into multiprotocol BGP, use the following command in router configuration mode:

Command
Purpose

Router(config-router)# redistribute dvmrp [route-map map-name]

Redistributes DVMRP routes into multiprotocol BGP.


See the "Multiprotocol BGP Route Redistribute Examples" section for an example of redistributing DVMRP routers into a multiprotocol BGP routing domain.

Configuring a Multiprotocol BGP Route Reflector

To configure a local router as a route reflector of multiprotocol BGP prefixes, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# neighbor ip-address remote-as autonomous-system-number

Adds the IP address of the neighbor in the remote autonomous system to the multiprotocol BGP neighbor table of the local router.

Step 3 

Router(config-router)# address-family ipv4 multicast

Specifies the IP Version 4 address family type and places the router in address family configuration mode.

Step 4 

Router(config-router-af)# neighbor ip-address activate

Enables the specified address family for the neighbor in the remote autonomous system.

Step 5 

Router(config-router-af)# neighbor ip-address route-reflector-client

Configures the router as a route reflector of prefixes for the specified address family type and configures the specified neighbor as its client.


Note By default, neighbors that are defined using the neighbor remote-as command in router configuration mode exchange only unicast address prefixes. To exchange other address prefix types, such as multicast and VPNv4, neighbors must also be activated using the neighbor activate command in address family configuration mode, as shown.



Note Route reflectors and clients (neighbors or internal BGP peer groups) that are defined in router configuration mode using the neighbor route-reflector-client command reflect unicast address prefixes to and from those clients by default. To reflect prefixes for other address families, such as multicast, define the reflectors and clients in address family configuration mode using the neighbor route-reflector-client command, as shown.


See the "Multiprotocol BGP Route Reflector Examples" section for multiprotocol BGP route reflector configuration examples.

Configuring Aggregate Multiprotocol BGP Addresses

The tasks in this section explain how to configure an aggregate address for multiprotocol BGP. Specifically, the tasks in this section explain how to inject an aggregate address into the multicast database, the unicast database, or both.

To configure an aggregate address for multiprotocol BGP, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router bgp autonomous-system

Configures a BGP routing process and places the router in router configuration mode.

Step 2 

Router(config-router)# address-family ipv4 multicast

Specifies the IP Version 4 address family type and places the router in address family configuration mode.

Step 3 

Router(config-router-af)# aggregate-address address mask [as-set] [summary-only] [suppress-map map-name] [advertise-map map-name] [attribute-map map-name]

Configures an aggregate address with various options.


Note Aggregate addresses that are defined in router configuration mode using the aggregate-address as-set command are injected into the unicast database by default. To enter an aggregate address in another database, such as the multicast database, the aggregate address must be defined in address family configuration mode using the aggregate-address as-set command, as shown.


See the "Aggregate Multiprotocol BGP Address Examples" section for aggregate multiprotocol BGP address configuration examples.

Verifying Multiprotocol BGP Configuration and Operation

To verify multiprotocol BGP configuration and operation, perform the following steps:


Step 1 Enter the show ip bgp ipv4 multicast EXEC command to display information related to the multicast database:

Router# show ip bgp ipv4 multicast

MBGP table version is 6, local router ID is 192.168.200.66
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop          Metric LocPrf Weight Path
*> 10.0.20.16/28     0.0.0.0                0      0 32768 i
*> 10.0.35.16/28     0.0.0.0                0      0 32768 i
*> 10.0.36.0/28      0.0.0.0                0      0 32768 i
*> 10.0.48.16/28     0.0.0.0                0      0 32768 i
*> 10.2.0.0/16       0.0.0.0                0      0 32768 i
*> 10.2.1.0/24       0.0.0.0                0      0 32768 i
*> 10.2.2.0/24       0.0.0.0                0      0 32768 i
*> 10.2.3.0/24       0.0.0.0                0      0 32768 i
*> 10.2.7.0/24       0.0.0.0                0      0 32768 i
*> 10.2.8.0/24       0.0.0.0                0      0 32768 i
*> 10.2.10.0/24      0.0.0.0                0      0 32768 i
*> 10.2.11.0/24      0.0.0.0                0      0 32768 i
*> 10.2.12.0/24      0.0.0.0                0      0 32768 i
*> 10.2.13.0/24      0.0.0.0                0      0 32768 i

Note For a description of each output display field, refer to the show ip bgp ipv4 multicast command in the Cisco IOS IP Command Reference, Volume 3 of 3: Multicast.


Step 2 Enter the show ip bgp ipv4 multicast summary EXEC command to display a summary of multicast database information:

Router# show ip bgp ipv4 multicast summary

BGP router identifier 10.0.33.34, local AS number 34
BGP table version is 5, main routing table version 1
4 network entries and 6 paths using 604 bytes of memory
5 BGP path attribute entries using 260 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP community entries using 48 bytes of memory
2 BGP route-map cache entries using 32 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 8/28 prefixes, 12/0 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.33.35      4    35     624     624        5    0    0 10:13:46        3 

Step 3 Enter the debug ip mbgp dampening EXEC command to log the route flap dampening activity:

Router# debug ip mbgp dampening

BGP: charge penalty for 173.19.0.0/16 path 49 with halflife-time 15 reuse/suppress 
750/2000
BGP: flapped 1 times since 00:00:00. New penalty is 1000
BGP: charge penalty for 173.19.0.0/16 path 19 49 with halflife-time 15 reuse/suppress 
750/2000
BGP: flapped 1 times since 00:00:00. New penalty is 1000

Step 4 Enter the debug ip mbgp updates EXEC command to log the multiprotocol BGP-related information passed in BGP Update messages:

Router# debug ip mbgp updates

BGP: NEXT_HOP part 1 net 200.10.202.0/24, neigh 171.69.233.49, next 171.69.233.34
BGP: 171.69.233.49 send UPDATE 200.10.202.0/24, next 171.69.233.34, metric 0, path 33 34 
19 49 109 65000 297 1239 1800 3597
BGP: NEXT_HOP part 1 net 200.10.228.0/22, neigh 171.69.233.49, next 171.69.233.34
BGP: 171.69.233.49 rcv UPDATE about 222.2.2.0/24, next hop 171.69.233.49, path 49 109 
metric 0
BGP: 171.69.233.49 rcv UPDATE about 131.103.0.0/16, next hop 171.69.233.49, path 49 109 
metric 0
BGP: 171.69.233.49 rcv UPDATE about 206.205.242.0/24, next hop 171.69.233.49, path 49 109 
metric 0

Step 5 Enter the show ip mpacket quality EXEC command to display the quality of Real-Time Transport Protocol (RTP) data based on packets captured in the IP multicast cache header buffer:

Router# show ip mpacket 224.2.163.188 quality

Calculating RTP data quality for 224.2.163.188
  Session: UO Presents KKNU New Country
  Source: 128.223.83.27 (sand.uoregon.edu), Port: 23824
    Packets received: 83, lost: 5, loss percentage: 5.6%
    Packets misordered: 7, average loss gap: 0


Multiprotocol BGP Configuration Examples

This section provides the following multiprotocol BGP configuration examples:

Multiprotocol BGP Peer Examples

Multiprotocol BGP Peer Group Examples

Multiprotocol BGP Network Advertisement Examples

Multiprotocol BGP Route Map Examples

Multiprotocol BGP Route Redistribute Examples

Multiprotocol BGP Route Reflector Examples

Aggregate Multiprotocol BGP Address Examples

Multiprotocol BGP Peer Examples

The following example shows how to use an address family to configure a neighbor as both unicast and multicast-capable:

router bgp 50000 
 address-family ipv4 unicast
  neighbor 10.1.1.1 activate

router bgp 50000 
 address-family ipv4 multicast
  neighbor 10.1.1.1 activate

Multiprotocol BGP Peer Group Examples

The following example shows how to use an address family to configure a peer group so that all members of the peer group are both unicast and multicast-capable:

router bgp 50000
 neighbor 10.1.1.1 remote-as 1
 neighbor 12.2.2.2 remote-as 1
 address-family ipv4 unicast
  neighbor mygroup peer-group 
  neighbor 10.1.1.1 peer-group mygroup
  neighbor 12.2.2.2 peer-group mygroup

router bgp 50000
 neighbor 10.1.1.1 remote-as 1
 neighbor 12.2.2.2 remote-as 1
 address-family ipv4 multicast
  neighbor mygroup peer-group
  neighbor 10.1.1.1 peer-group mygroup
  neighbor 12.2.2.2 peer-group mygroup


Note The neighbor activate command is not required in this configuration because peer groups are activated automatically as peer group configuration parameters are applied.


Multiprotocol BGP Network Advertisement Examples

The following examples show how to use an address family to inject a network number and mask into the unicast database and the multicast database:

router bgp 100
 address-family ipv4 unicast
  network 10.0.0.0 mask 255.0.0.0
 
router bgp 100
 address-family ipv4 multicast
  network 10.0.0.0 mask 255.0.0.0

Multiprotocol BGP Route Map Examples

The following example shows how to use an address family to configure BGP so that any unicast and multicast routes from neighbor 10.1.1.1 are accepted if they match access list 1:

router bgp 50000 
 neighbor 10.1.1.1 remote-as 1
 address-family ipv4 unicast
  neighbor 10.1.1.1 route-map filter-some-multicast in

router bgp 50000 
 neighbor 10.1.1.1 remote-as 1
 address-family ipv4 multicast
  neighbor 10.1.1.1 route-map filter-some-multicast in
  neighbor 10.1.1.1 activate

route-map filter-some-multicast
 match ip address 1

Multiprotocol BGP Route Redistribute Examples

The following example shows how to use an address family to redistribute DVMRP routes that match access list 1 into the multicast database and the unicast database of the local router:

router bgp 50000 
 address-family ipv4 unicast
  redistribute dvmrp route-map dvmrp-into-mbgp

router bgp 50000 
 address-family ipv4 multicast
  redistribute dvmrp route-map dvmrp-into-mbgp

route-map dvmrp-into-mbgp
 match ip address 1

Multiprotocol BGP Route Reflector Examples

The following example shows how to use an address family to configure internal BGP peer 10.1.1.1 as a route reflector client for both unicast and multicast prefixes:

router bgp 50000 
 address-family ipv4 unicast
  neighbor 10.1.1.1 activate
  neighbor 10.1.1.1 route-reflector-client

router bgp 50000 
 address-family ipv4 multicast
  neighbor 10.1.1.1 activate
  neighbor 10.1.1.1 route-reflector-client

Aggregate Multiprotocol BGP Address Examples

The following example shows how to use an address family to configure an aggregate multiprotocol BGP address entry in both the unicast database and the multicast database:

router bgp 50000 
 address-family ipv4 unicast
  aggregate-address 172.16.0.0 255.0.0.0 as-set
 
router bgp 50000 
 address-family ipv4 multicast
  aggregate-address 172.16.0.0 255.0.0.0 as-set