Cisco IOS Configuration Fundamentals Command�Reference, Release�12.2
The Setup Command
Downloads: This chapterpdf (PDF - 165.0KB) The complete bookPDF (PDF - 7.32MB) | Feedback

The Setup Command

Table Of Contents

The Setup Command

setup


The Setup Command


The "Using AutoInstall and Setup" chapter of the Release 12.2 Cisco IOS Configuration Fundamentals Configuration Guide describes the tasks associated with using the AutoInstall and Setup features.

The AutoInstall process does not require you to use any commands on the new routing device. Therefore, this chapter discusses only the setup command, which is used to enter Setup mode.

To locate documentation of other commands that appear in the "Using AutoInstall and Setup" chapter, use the Cisco IOS Command Reference Master Index or search online.

Setup is an interactive Cisco IOS software feature that allows you to perform first-time configuration or other basic configuration procedures on all Cisco devices. Setup mode guides you through the configuration process by prompting you for the information required to make the routing device function in the network.

While the use of the setup command is a quick way to set up a Cisco device, you can also use it after first-time startup to perform configuration changes. This chapter focuses on using the setup command after first-time startup.

Refer to the hardware-specific documentation that came with your platform for details on how to use Setup mode for first-time startup.

setup

To enter Setup mode, use the setup privileged EXEC command.

setup

Syntax Description

This command has no arguments or keywords.

Command Modes

Privileged EXEC

Command History

Release
Modification

11.1

This command was introduced.


Usage Guidelines

Setup mode gives you the option of configuring your system without using the Cisco IOS CLI. For some tasks, you may find it easier to use Setup than to enter Cisco IOS commands individually. For example, you might want to use Setup to add a protocol suite, to make major addressing scheme changes, or to configure a newly installed interface. Although you can use the CLI to make these changes, Setup provides you with a high-level view of the configuration and guides you through the configuration process.

If you are not familiar with Cisco products and the CLI, Setup is a particularly valuable tool because it prompts you for the specific information required to configure your system.


Note If you use Setup to modify a configuration because you have added or modified the hardware, be sure to verify the physical connections using the show version EXEC command. Also, verify the logical port assignments using the show running-config EXEC command to ensure that you configure the correct port. Refer to the hardware documentation for your platform for more information on physical and logical port assignments.


Before using Setup, you should have the following information so that you can configure the system properly:

Which interfaces you want to configure

Which routing protocols you wish to enable

Whether the router is to perform bridging

Network addresses for the protocols being configured

Password strategy for your environment

When you enter the setup EXEC command after first-time startup, an interactive dialog called the System Configuration Dialog appears on the system console screen. The System Configuration Dialog guides you through the configuration process. It prompts you first for global parameters and then for interface parameters. The values shown in brackets next to each prompt reflect either the default settings or the last configured setting.

The prompts and the order in which they appear on the screen vary depending on the platform and the interfaces installed in the device.

You must progress through the System Configuration Dialog until you come to the item that you intend to change. To accept default settings for items that you do not want to change, press the Return or Enter key. The default choice is indicated by square brackets (for example, [yes]) before the prompt colon (:).

To exit Setup and return to privileged EXEC mode without making changes and without progressing through the entire System Configuration Dialog, press Ctrl-C.

The facility also provides help text for each prompt. To access help text, press the question mark (?) key at a prompt.

When you complete your changes, the system will automatically display the configuration file that was created during the Setup session. It also asks you if you want to use this configuration. If you answer Yes, the configuration is saved to NVRAM as the startup configuration file. If you answer No, the configuration is not saved and the process begins again. There is no default for this prompt; you must answer either Yes or No.

Examples

The following example displays the setup command facility to configure serial interface 0 and to add ARAP and IP/IPX PPP support on the asynchronous interfaces:

Router# setup

         --- System Configuration Dialog ---

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Continue with configuration dialog? [yes]: 

First, would you like to see the current interface summary? [yes]: 

Interface          IP-Address      OK?  Method    Status                 Protocol
Ethernet0          172.16.72.2     YES  manual    up                     up      
Serial0            unassigned      YES  not set   administratively down  down    
Serial1            172.16.72.2     YES  not set   up                     up    

Configuring global parameters:

  Enter host name [Router]: 

The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.

  Enter enable secret [<Use current secret>]: 
The enable password is used when there is no enable secret
and when using older software and some boot images.
  Enter enable password [ww]: 
  Enter virtual terminal password [ww]: 
  Configure SNMP Network Management? [yes]: 
    Community string [public]: 
  Configure DECnet? [no]: 
  Configure AppleTalk? [yes]: 
    Multizone networks? [no]: yes
  Configure IPX? [yes]: 
  Configure IP? [yes]: 
    Configure IGRP routing? [yes]: 
      Your IGRP autonomous system number [15]: 
  Configure Async lines? [yes]: 
    Async line speed [9600]: 57600
    Configure for HW flow control? [yes]: 
    Configure for modems? [yes/no]: yes
      Configure for default chat script? [yes]: no
    Configure for Dial-in IP SLIP/PPP access? [no]: yes
      Configure for Dynamic IP addresses? [yes]: no 
      Configure Default IP addresses? [no]: yes
      Configure for TCP Header Compression? [yes]: no
      Configure for routing updates on async links? [no]: 
    Configure for Async IPX? [yes]: 
    Configure for Appletalk Remote Access? [yes]: 
      AppleTalk Network for ARAP clients [1]: 20
      Zone name for ARAP clients [ARA Dialins]: 
 
   
Configuring interface parameters:

Configuring interface Ethernet0:
  Is this interface in use? [yes]: 
  Configure IP on this interface? [yes]: 
    IP address for this interface [172.16.72.2]: 
    Number of bits in subnet field [8]: 
    Class B network is 172.16.0.0, 8 subnet bits; mask is /24
  Configure AppleTalk on this interface? [yes]: 
    Extended AppleTalk network? [yes]: 
    AppleTalk starting cable range [1]: 
    AppleTalk ending cable range [1]: 
    AppleTalk zone name [Sales]: 
    AppleTalk additional zone name: 
  Configure IPX on this interface? [yes]: 
    IPX network number [1]: 

Configuring interface Serial0:
  Is this interface in use? [no]: yes
  Configure IP on this interface? [no]: yes
  Configure IP unnumbered on this interface? [no]: yes
    Assign to which interface [Ethernet0]: 
  Configure AppleTalk on this interface? [no]: yes
    Extended AppleTalk network? [yes]: 
    AppleTalk starting cable range [2]: 3
    AppleTalk ending cable range [3]: 3
    AppleTalk zone name [myzone]: ZZ Serial
    AppleTalk additional zone name: 
  Configure IPX on this interface? [no]: yes
    IPX network number [2]: 3

Configuring interface Serial1:
  Is this interface in use? [yes]: 
  Configure IP on this interface? [yes]: 
  Configure IP unnumbered on this interface? [yes]: 
    Assign to which interface [Ethernet0]: 
  Configure AppleTalk on this interface? [yes]: 
    Extended AppleTalk network? [yes]: 
    AppleTalk starting cable range [2]: 
    AppleTalk ending cable range [2]: 
    AppleTalk zone name [ZZ Serial]: 
    AppleTalk additional zone name: 
  Configure IPX on this interface? [yes]: 
    IPX network number [2]: 
Configuring interface Async1: 
    IPX network number [4]: 
    Default client IP address for this interface [none]: 172.16.72.4 
Configuring interface Async2:
    IPX network number [5]: 
    Default client IP address for this interface [172.16.72.5]: 
Configuring interface Async3:
    IPX network number [6]: 
    Default client IP address for this interface [172.16.72.6]: 
Configuring interface Async4:
    IPX network number [7]: 
    Default client IP address for this interface [172.16.72.7]: 
Configuring interface Async5:
    IPX network number [8]: 
    Default client IP address for this interface [172.16.72.8]: 
Configuring interface Async6:
    IPX network number [9]: 
    Default client IP address for this interface [172.16.72.9]: 
Configuring interface Async7:
    IPX network number [A]: 
    Default client IP address for this interface [172.16.72.10]: 
Configuring interface Async8:
    IPX network number [B]: 
    Default client IP address for this interface [172.16.72.11]: 
Configuring interface Async9:
    IPX network number [C]:  
    Default client IP address for this interface [172.16.72.12]:  
Configuring interface Async10:
    IPX network number [D]: 
    Default client IP address for this interface [172.16.72.13]: 
Configuring interface Async11:
    IPX network number [E]: 
    Default client IP address for this interface [172.16.72.14]: 
Configuring interface Async12:
    IPX network number [F]: 
    Default client IP address for this interface [172.16.72.15]: 
Configuring interface Async13:
    IPX network number [10]: 
    Default client IP address for this interface [172.16.72.16]: 
Configuring interface Async14:
    IPX network number [11]: 
    Default client IP address for this interface [172.16.72.17]: 
Configuring interface Async15:
    IPX network number [12]: 
    Default client IP address for this interface [172.16.72.18]: 
Configuring interface Async16: 
    IPX network number [13]: 
    Default client IP address for this interface [172.16.72.19]:  

The following configuration command script was created:

hostname Router
enable secret 5 $1$krIg$emfYm/1OwHVspDuS8Gy0K1
enable password ww
line vty 0 4
password ww
snmp-server community public
!
no decnet routing
appletalk routing
ipx routing
ip routing
!
line 1 16
speed 57600
flowcontrol hardware
modem inout
!
arap network 20 ARA Dialins
line 1 16
arap enable
autoselect
!
! Turn off IPX to prevent network conflicts.
interface Ethernet0
no ipx network
interface Serial0
no ipx network
interface Serial1
no ipx network
!
interface Ethernet0
ip address 172.16.72.2 255.255.255.0
appletalk cable-range 1-1 1.204
appletalk zone Sales
ipx network 1
no mop enabled
!
interface Serial0
no shutdown
no ip address
ip unnumbered Ethernet0
appletalk cable-range 3-3
appletalk zone ZZ Serial
ipx network 3
no mop enabled
!
interface Serial1
no ip address
ip unnumbered Ethernet0
appletalk cable-range 2-2 2.2
appletalk zone ZZ Serial
ipx network 2
no mop enabled
!
Interface Async1
ipx network 4
ip unnumbered Ethernet0
peer default ip address 172.16.72.4
async mode interactive
!
Interface Async2
ipx network 5
ip unnumbered Ethernet0
peer default ip address 172.16.72.5
async mode interactive
!
Interface Async3
ipx network 6
ip unnumbered Ethernet0
peer default ip address 172.16.72.6
async mode interactive
!
Interface Async4
ipx network 7
ip unnumbered Ethernet0
peer default ip address 172.16.72.7
async mode interactive
async dynamic address
!
Interface Async5
ipx network 8
ip unnumbered Ethernet0
peer default ip address 172.16.72.8
async mode interactive
!
Interface Async6
ipx network 9
ip unnumbered Ethernet0
peer default ip address 172.16.72.9
async mode interactive
!
Interface Async7
ipx network A
ip unnumbered Ethernet0
peer default ip address 172.16.72.10
async mode interactive
!
Interface Async8
ipx network B
ip unnumbered Ethernet0
peer default ip address 172.16.72.11
async mode interactive
!
Interface Async9
ipx network C
ip unnumbered Ethernet0
peer default ip address 172.16.72.12
async mode interactive
!
Interface Async10
ipx network D
ip unnumbered Ethernet0
peer default ip address 172.16.72.13
async mode interactive
!
Interface Async11
ipx network E
ip unnumbered Ethernet0
peer default ip address 172.16.72.14
async mode interactive
!
Interface Async12
ipx network F
ip unnumbered Ethernet0
peer default ip address 172.16.72.15
async mode interactive
!
Interface Async13
ipx network 10
ip unnumbered Ethernet0
peer default ip address 172.16.72.16
async mode interactive
!
Interface Async14
ipx network 11
ip unnumbered Ethernet0
peer default ip address 172.16.72.17
async mode interactive
!
Interface Async15
ipx network 12
ip unnumbered Ethernet0
peer default ip address 172.16.72.18
async mode interactive
!
Interface Async16
ipx network 13
ip unnumbered Ethernet0
peer default ip address 172.16.72.19
async mode interactive
!
router igrp 15
network 172.16.0.0
!
end

Use this configuration? [yes/no]: yes

Building configuration...

Use the enabled mode 'configure' command to modify this configuration.      

Router#

Related Commands

Command
Description

erase nvram:

Erases a file system.

show running-config

Displays the running configuration file. Command alias for the more system:running-config command.

show startup-config

Displays the startup configuration file. Command alias for the more system:startup-config command.

show version

Displays the configuration of the system hardware, the software version, the names and sources of configuration files, and the boot images.