Guest

Support

Cisco SRST V3.0: Setting Up the Network

  • Viewing Options

  • PDF (225.0 KB)
  • Feedback
Setting Up the Network

Table Of Contents

Setting Up the Network

Contents

Information About Setting Up the Network

How to Set Up the Network

Enabling IP Routing

Enabling SRST on an MGCP Gateway

Configuring DHCP for Cisco SRST Phones

Defining a Single DHCP IP Address Pool

Defining a Separate DHCP IP Address Pool for Each Cisco IP Phone

Defining the DHCP Relay Server

Specifying Keepalive Intervals

Example

Configuring Cisco SRST to Support Phone Functions

Verifying That Cisco SRST Is Enabled

Troubleshooting

Where to Go Next


Setting Up the Network


This chapter describes how to configure your Cisco Survivable Remote Site Telephony (SRST) router to run Dynamic Host Configuration Protocol (DHCP) and to communicate with the IP phones during Cisco CallManager fallback.

Contents

Information About Setting Up the Network

How to Set Up the Network

Where to Go Next

Information About Setting Up the Network

When the WAN link fails, the Cisco IP phones detect that they are no longer receiving keepalive packets from Cisco CallManager. The Cisco IP phones then register with the router. The Cisco SRST software is automatically activated and builds a local database of all Cisco IP phones attached to it (up to its stated maximum). The IP phones are configured to query the router as a backup call-processing source when the central Cisco CallManager does not acknowledge keepalive packets. The Cisco SRST router now performs call setup and processing, call maintenance, and call termination.

When the WAN is up, Cisco CallManager uses DHCP. To provide call handling during Cisco CallManager fallback, the branch office or Cisco SRST router must also use DHCP. Configuring DHCP is one of two main steps in setting up network communication. The other is configuring the Cisco SRST router to receive messages from the Cisco IP phones through the specified IP addresses. Keepalive intervals are also set at this time.

How to Set Up the Network

This section contains the following procedures:

Enabling IP Routing

Enabling SRST on an MGCP Gateway (Required)

Configuring DHCP for Cisco SRST Phones (Required)

Specifying Keepalive Intervals (Optional)

Configuring Cisco SRST to Support Phone Functions (Required)

Verifying That Cisco SRST Is Enabled

Enabling IP Routing

For information about enabling IP routing, refer to "Enabling IP Routing" in the "IP Addressing and Services" chapter of the Cisco IOS IP Configuration Guide, Release 12.2.

Enabling SRST on an MGCP Gateway

To use SRST as your fallback mode with an MGCP gateway, SRST and MGCP fallback must both be configured on the same gateway. The configuration below allows SRST to assume control over the voice port and over call processing on the MGCP gateway.


Note The commands described in the configuration below are ineffective unless both commands are configured. For instance, your configuration will not work if you only configure the ccm-manager fallback-mgcp command.


SUMMARY STEPS

1. enable

2. configure terminal

3. ccm-manager fallback-mgcp

4. call application alternate [application-name]

5. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password when prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ccm-manager fallback-mgcp

Example:

Router(config)# ccm-manager fallback-mgcp

Enables the gateway fallback feature and allows an MGCP voice gateway to provide call processing services through SRST or other configured applications when Cisco CallManager is unavailable.

Step 4 

call application alternate [application-name]

The call application alternate command specifies that the default voice application takes over if the MGCP application is not available. The application-name argument is optional and indicates the name of the specific voice application to use if the application in the dial peer fails. If a specific application name is not entered, the gateway uses the DEFAULT application.

Step 5 

exit

Example:

Router(config)# exit

Exits global configuration mode and returns to privileged EXEC mode.

Configuring DHCP for Cisco SRST Phones

To perform this task, you must have your network configured with DHCP. For further details about DHCP configuration, refer to the Cisco IOS DHCP Server document.

When a Cisco IP phone is connected to the Cisco SRST system, it automatically queries for a DHCP server. The DHCP server responds by assigning an IP address to the Cisco IP phone and providing the IP address of the Trivial File Transfer Protocol (TFTP) server through DHCP option 150. Then the phone registers with the Cisco SRST system server and attempts to get configuration and phone firmware files from the TFTP server.

Choose one of the following tasks to set up DHCP service for your IP phones:

Defining a Single DHCP IP Address Pool—Use this method if the Cisco SRST router is a DHCP server and if you can use a single shared address pool for all your DHCP clients.

Defining a Separate DHCP IP Address Pool for Each Cisco IP Phone—Use this method if the Cisco SRST router is a DHCP server and you need separate pools for non-IP-phone DHCP clients.

Defining the DHCP Relay Server—Use this method if the Cisco SRST router is not a DHCP server and you want to relay DHCP requests from IP phones to a DHCP server on a different router.

Defining a Single DHCP IP Address Pool

This process creates a large shared pool of IP addresses, in which all DHCP clients receive the same information, including the option 150 TFTP server IP address. The benefit of selecting this method is you set up only one DHCP pool. However, defining a single DCHP IP address pool can be a problem if some (non-IP phone) clients need to use a different TFTP server address.

SUMMARY STEPS

1. ip dhcp pool poolname

2. network ip-address [mask | prefix-length]

3. option 150 ip ip-address

4. default-router ip-address

5. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 6 

ip dhcp pool poolname

Example:

Router(config)# ip dhcp pool mypool

Creates a name for the DHCP server address pool and enters DHCP pool configuration mode.

Step 7 

network ip-address [mask | prefix-length]

Example:
Router(config-dhcp)# network 10.0.0.0 255.255.0.0

Specifies the IP address of the DHCP address pool and optional mask or number of bits in the address prefix, preceded by a forward slash.

Step 8 

option 150 ip ip-address

Example:
Router(config-dhcp)# option 150 ip 10.0.0.1

Specifies the TFTP server address from which the Cisco IP phone downloads the image configuration file. This needs to be the IP address of CallManager.

Step 9 

default-router ip-address

Example:
Router(config-dhcp)# default-router 10.0.0.1

Specifies the router to which the Cisco IP phones are connected directly. This router is either a Cisco SRST router or any Cisco router attached to the Cisco SRST router.

Note As long as the Cisco IP phones have connection to the Cisco SRST router, the Cisco IP phones are able to get the required network details.

Step 10 

exit

Example:

Router(config-dhcp)# exit

Exits DHCP configuration mode.

Defining a Separate DHCP IP Address Pool for Each Cisco IP Phone

This process creates a name for the DHCP server address pool and specifies IP addresses. This method requires you to make an entry for every IP phone.

SUMMARY STEPS

1. ip dhcp pool poolname

2. host ip-address subnet-mask

3. option 150 ip ip-address

4. default-router ip-address

5. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

ip dhcp pool poolname

Example:

Router(config)# ip dhcp pool pool2

Creates a name for the DHCP server address pool and enters DHCP pool configuration mode.

Step 2 

host ip-address subnet-mask

Example:

Router(config-dhcp)# host 10.0.0.0 255.255.0.0

Specifies the IP address you want the phone to use.

Step 3 

option 150 ip ip-address

Example:

Router(config-dhcp)# option 150 ip 10.0.0.1

Specifies the TFTP server IP address from which the Cisco IP phone downloads the image configuration file, XmlDefault.cnf.xml. This is your Cisco SRST router IP address.

Step 4 

default-router ip-address

Example:
Router(config-dhcp)# default-router 10.0.0.1

Specifies the IP address of the default router. The Cisco IP phones are directly connected to this router. This router is either a Cisco SRST router or any Cisco router attached to the Cisco SRST router.

Note As long as the Cisco IP phones have connection to the Cisco SRST router, the Cisco IP phones are able to get the required network details.

Step 5 

exit

Example:

Router(config-dhcp)# exit

Exits DHCP configuration mode.

Defining the DHCP Relay Server

This process sets up DHCP relay on the LAN interface where the Cisco IP phones are connected and enables the Cisco IOS DHCP server feature to relay requests from DHCP clients (phones) to a DHCP server. For further details about DHCP configuration, refer to the Cisco IOS DHCP Server document.

The Cisco IOS DHCP server feature is enabled on routers by default. If the DHCP server is not enabled on your Cisco SRST router, use the following steps to enable it.

SUMMARY STEPS

1. service dhcp

2. interface type number

3. ip helper-address ip-address

4. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

service dhcp

Example:

Router(config)# service dhcp

Enables the Cisco IOS DHCP Server feature on the router.

Step 2 

interface type number

Example:

Router(config)# interface

Enters interface configuration mode for the specified interface.

Step 3 

ip helper-address ip-address

Example:

Router(config-if)# ip helper-address 10.0.0.1

Specifies the helper address for any unrecognized broadcast for TFTP server and Domain Name System (DNS) requests. For each server, a separate ip helper-address command is required if the servers are on different hosts. You can also configure multiple TFTP server targets by using the ip helper-address commands for multiple servers.

Step 4 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Specifying Keepalive Intervals

The keepalive interval is the period of time between keepalive messages sent by a network device. A keepalive message is a message sent by one network device to inform another network device that the virtual circuit between the two is still active.


Note If you plan to use the default time interval between keepalive messages, which is 30 seconds, you do not have to perform this task.


SUMMARY STEPS

1. call-manager-fallback

2. keepalive seconds

3. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

call-manager-fallback

Example:

Router(config)# call-manager-fallback

Enters call-manager-fallback configuration mode.

Step 2 

keepalive seconds

Example:

Router(config-cm-fallback)# keepalive 60

Sets the time interval, in seconds, between keepalive messages that are sent to the router by Cisco IP phones.

seconds—Range is 10 to 65535. Default is 30.

Step 3 

exit

Example:

Router(config-cm-fallback)# exit

Exits call-manager-fallback configuration mode.

Example

The following example sets a keepalive interval of 45 seconds:

call-manager-fallback
 keepalive 45

Configuring Cisco SRST to Support Phone Functions


Tip When the Cisco SRST is enabled, Cisco IP phones do not have to be reconfigured while in Cisco CallManager fallback mode because phones retain the same configuration that was used with Cisco CallManager.


To configure Cisco SRST on the router to support the Cisco IP phone functions, use the following commands beginning in global configuration mode.

SUMMARY STEPS

1. call-manager-fallback

2. ip source-address ip-address [port port] [any-match | strict-match]

3. max-dn max-directory-numbers

4. max-ephones max-phones

5. limit-dn {7910 | 7935 | 7940 | 7960} max-lines

6. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

call-manager-fallback

Example:

Router(config)# call-manager-fallback

Enters call-manager-fallback configuration mode.

Step 2 

ip source-address ip-address [port port] [any-match | strict-match]

Example:

Router(config-cm-fallback)# ip source-address 10.6.21.4 port 2002 strict-match

Enables the router to receive messages from the Cisco IP phones through the specified IP addresses and provides for strict IP address verification. The default port number is 2000.

Step 3 

max-dn max-directory-numbers

Example:

Router(config-cm-fallback)# max-dn 12

Sets the maximum number of directory numbers or virtual voice ports that can be supported by the router. The default is 0. The maximum number is platform dependent. See the "Specifications" section for further details.

Note You must reboot the router in order to reduce the limit of the directory numbers or virtual voice ports after the maximum allowable number is configured.

Step 4 

max-ephones max-phones

Example:
Router(config-cm-fallback)# max-ephones 24

Configures the maximum number of Cisco IP phones that can be supported by the router. The default is 0. The maximum number is platform dependent. See the "Specifications" section for further details.

Note You must reboot the router in order to reduce the limit of the directory numbers or virtual voice ports after the maximum allowable number is configured.

Step 5 

limit-dn {7910 | 7935 | 7940 | 7960} max-lines

Example:
Router(config-cm-fallback)# limit-dn 7910 2

Limits the directory number lines on Cisco IP phones during Cisco CallManager fallback.

Note You must configure this command during initial Cisco SRST router configuration, before any phone actually registers with the Cisco SRST router. However, you can modify the number of lines at a later time.

The setting for maximum lines is from 1 to 6. The default number of maximum directory lines is set to 6. If there is any active phone with last line number greater than this limit, warning information is displayed for phone reset.

Step 6 

exit

Example:
Router(config-cm-fallback)# exit

Exits call-manager-fallback configuration mode.

Verifying That Cisco SRST Is Enabled

To verify that the Cisco SRST feature is enabled, perform the following steps:


Step 1 Enter the show run command to verify the configuration.

Step 2 Enter the show call-manager-fallback all command to verify that Cisco SRST feature is enabled.

Step 3 Use the Settings display on the Cisco IP phones in your network to verify that the default router IP address on the phones matches the IP address of the Cisco SRST router.

Step 4 To temporarily block the TCP port 2000 Skinny Client Control Protocol (SCCP) connection for one of the Cisco IP phones to force the Cisco IP phone to lose its connection to the Cisco CallManager and register with the Cisco SRST router, perform the following steps:

a. Use the appropriate IP access-list command to temporarily disconnect a Cisco IP phone from the Cisco CallManager.

During a WAN connection failure, when Cisco SRST is enabled, Cisco IP phones display a message informing you that they are operating in Cisco CallManager fallback mode. The Cisco IP Phone 7960 and Cisco IP Phone 7940 display a "CM Fallback Service Operating" message and the Cisco IP Phone 7910 displays a "CM Fallback Service" message when operating in Cisco CallManager fallback mode. When the Cisco CallManager is restored, the message goes away and full Cisco IP phone functionality is restored.

b. Enter the no form of the appropriate access-list command to restore normal service for the phone.

c. Use the debug ephone register command to observe the registration process of the Cisco IP phone on the Cisco SRST router.

d. Use the show ephone command to display the Cisco IP phones that have registered to the Cisco SRST router.


Troubleshooting

To troubleshoot your Cisco SRST configuration, use the following commands:

To set keepalive debugging for the Cisco IP phone, use the debug ephone keepalive command.

To set registration debugging for the Cisco IP phone, use the debug ephone register command.

To set state debugging for the Cisco IP phone, use the debug ephone state command.

To set detail debugging for the Cisco IP phones, use the debug ephone detail command.

To set error debugging for the Cisco IP phones, use the debug ephone error command.

To set call statistics debugging for the Cisco IP phones, use the debug ephone statistics command.

To provide voice-packet-level debugging and print the contents of one voice packet in every 1024 voice packets, use the debug ephone pak command.

To provide raw low-level protocol debugging display for all SCCP messages, use the debug ephone raw command.

For further debugging, you can use the debug commands in the Cisco IOS Debug Command Reference.

Where to Go Next

The next step is setting up the phone and getting a dial tone. For instructions, see Chapter 3, "Setting Up Cisco IP Phones."