Guest

Cisco IOS Software Releases 12.2 Special and Early Deployments

Voice and Quality of Service Features for ADSL and G.SHDSL on Cisco 1700, Cisco 2600, and Cisco 3600 Series Routers

  • Viewing Options

  • PDF (467.9 KB)
  • Feedback
Voice and Quality of Service Features for ADSL and G.SHDSL on Cisco 1700, Cisco 2600, and Cisco 3600 Series Routers

Table Of Contents

Voice and Quality of Service Features for ADSL and G.SHDSL on Cisco 1700, Cisco 2600, and Cisco 3600 Series Routers

Feature Overview

Classification and Marking

Class-Based Packet Marking with Differentiated Services

Committed Access Rate

Dial-Peer DSCP and IP Precedence Marking

Local Policy Routing

Policy-Based Routing

Queueing and Scheduling

Class-Based Weighted Fair Queueing

Low Latency Queueing

Per-VC Queueing

Congestion Avoidance

Class-Based WRED with DSCP (egress)

Policing and Traffic Shaping

Class-Based Policing

VC Shaping for VBR-NRT

Link Latency

MLP with LFI - Bundling of VCs Across xDSL Interfaces

Tunable Transmission Ring

Other (IP QoS)

Access Control Lists

IP QoS Map to ATM CoS

Additional Supported Features

F5 OAM CC Segment Functionality

H.323 and Media Gateway Control Protocol

ILMI

Multiple PVC Support

RFC 1483 Routing

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring the Error Duration for Digital Subscriber Line Access Multiplexers

Configuring the Tx Ring Limit

Verifying the TX Ring Limit

Configuration Examples

Differentiated Data Services over ADSL Example

Verifying the Differentiated Data Services over ADSL Configuration

VoIP and Data over ADSL Example

Verifying the VoIP and Data over ADSL Configuration

Tx Ring-Limit Tuning over ADSL Example

MLP with LFI over G.SHDSL Example

Verifying the MLP with LFI over G.SHDSL Configuration

Command Reference

dsl equipment-type

tx-ring-limit


Voice and Quality of Service Features for ADSL and G.SHDSL on Cisco 1700, Cisco 2600, and Cisco 3600 Series Routers


Feature History
Release
Modification

12.2(2)XQ

Voice and quality of service features for ADSL were introduced for Cisco 1700 series routers.

12.2(2)XK

Voice and quality of service features for ADSL were introduced for Cisco 2600 and Cisco 3600 series routers.

12.2(4)XL

This release further expanded voice and quality of service features for ADSL on Cisco 2600 and Cisco 3600 routers and provided full support for G.SHDSL on Cisco 1700 and Cisco 2600 series routers.

12.2(13)T

The voice and quality of service features for ADSL and G.SHDSL were fully implemented on Cisco 1700 series routers.

Note The Tunable Transmission Ring feature is not supported on Cisco 1700 series routers in Cisco IOS Release 12.2(13)T.


This document describes the voice and quality of service (QoS) features for asymmetric digital subscriber lines (ADSL) and for single-pair high-bit-rate digital subscriber lines (G.SHDSL) on Cisco 1700 series, Cisco 2600 series, and Cisco 3600 series routers in Cisco IOS Release 12.2(13)T.

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuration Examples

Command Reference

Feature Overview

Cisco 1700 series, Cisco 2600 series, and Cisco 3600 series routers with ADSL or G.SHDSL WAN interface cards support the integration of voice and data over the same ADSL or G.SHDSL circuit using Voice over IP (VoIP). Cisco 2600 series and Cisco 3600 series routers with ADSL or G.SHDSL WAN interface cards also support the integration of voice and data over the same ADSL or G.SHDSL circuit using Voice over ATM (VoATM).


NoteTo configure these voice and QoS features, you must first install and configure the ADSL or G.SHDSL WAN interface card (WIC) on your Cisco 1700 series, Cisco 2600 series, or Cisco 3600 series router. Refer to the installation and configuration instructions in the following documents:

Configuring an ADSL WAN Interface Card on Cisco 1700 Series Routers

Installing the G.SHDSL WIC on the Cisco 1700 Series Router

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T

1-Port G.SHDSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers,
Release 12.2(4)XL


Quality of service (QoS) features make it possible to effectively combine voice and data traffic in the same WAN connection without sacrificing quality and reliability. Service providers can increase revenue by building differentiated service options based on premium, standard, or best-effort service classes.

The following voice and QoS features are supported in the Cisco IOS Release 12.2(13)T.

Classification and Marking

Class-Based Packet Marking with Differentiated Services

Committed Access Rate

Dial-Peer DSCP and IP Precedence Marking

IP QoS Map to ATM CoS

Local Policy Routing

Policy-Based Routing

Queueing and Scheduling

Class-Based Weighted Fair Queueing

Low Latency Queueing

Per-VC Queueing

Congestion Avoidance

Class-Based WRED with DSCP (egress)

Policing and Traffic Shaping

Class-Based Policing

VC Shaping for VBR-NRT

Link Latency

MLP with LFI - Bundling of VCs Across xDSL Interfaces

Tunable Transmission Ring (supported only on Cisco 2600 and Cisco 3600 series routers; not supported on Cisco 1700 series routers until Cisco IOS Release 12.2(8)YN)

Other (IP QoS)

Access Control Lists

IP QoS Map to ATM CoS

Additional Supported Features

F5 OAM CC Segment Functionality

H.323 and Media Gateway Control Protocolf

ILMI

Multiple PVC Support

RFC 1483 Routing

Table 1 lists the voice and QoS features for ADSL and G.SHDSL and the releases in which they are available.

Table 1 Voice and QoS Features and the Releases in Which They Are Available 

Feature
ADSL
G.SHDSL

Access Control Lists

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Class-Based Packet Marking with DSCP

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Class-Based Policing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Class-Based Weighted Fair Queueing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Class-Based WRED with DSCP (egress)

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Committed Access Rate

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Dial-Peer DSCP and IP Precedence Marking

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

F5 OAM CC Segment Functionality

12.2(4)XL and 12.2(13)T

12.2(4)XL and 12.2(13)T

H.323 and Media Gateway Control Protocol

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

ILMI

12.2(4)XL and 12.2(13)T

12.2(4)XL and 12.2(13)T

IP QoS Map to ATM CoS

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Local Policy Routing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Low Latency Queueing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

MLP with LFI - Bundling of VCs Across xDSL Interfaces

12.2(2)XK and 12.2(13)T

12.2(4)XL and 12.2(13)T

Multiple PVC Support

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Per-VC Queueing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Policy-Based Routing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

RFC 1483 Routing

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Tunable Transmission Ring

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

VC shaping for VBR-NRT

12.2(2)XK, 12.2(4)XL, and 12.2(13)T

12.2(4)XL and 12.2(13)T

Note G.SHDSL WICs are not supported on Cisco 3600 series routers in the Cisco IOS Release 12.2(4)XL


Classification and Marking

The following existing Cisco IOS classification and marking features are supported on ADSL and G.SHDSL WICs:

Class-Based Packet Marking with Differentiated Services

Committed Access Rate

Dial-Peer DSCP and IP Precedence Marking

Local Policy Routing

Policy-Based Routing

Class-Based Packet Marking with Differentiated Services

For information about class-based packet marking with differentiated services, refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Committed Access Rate

For information about committed access rate (CAR), refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Dial-Peer DSCP and IP Precedence Marking

For information about dial-peer differentiated services code points (DSCPs) and IP precedence marking, refer to the following document:

The chapter "Quality of Service for Voice over IP" in the Cisco IOS Quality of Service Solutions.

Local Policy Routing

For information about local policy routing (LPR), refer to the following documents:

The chapter "Configuring IP Routing Protocol—Independent Features" in the Cisco IOS IP Configuration Guide, Release 12.2

The chapter "Configuring IP Routing Protocols" in the Router Products Configuration Guide

Policy-Based Routing

For information about policy-based routing (PBR), refer to the following documents:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

The chapter "Configuring Policy-Based Routing" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Queueing and Scheduling

The following existing Cisco IOS queueing and scheduling features are supported on ADSL WICs and G.SHDSL WICs:

Class-Based Weighted Fair Queueing

Low Latency Queueing

Per-VC Queueing

Class-Based Weighted Fair Queueing

For information about class-based weighted fair queueing (CBWFQ), refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Low Latency Queueing

For information about low latency queueing (LLQ), refer to the following documents:

The chapter "Congestion Management Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

The chapter "Quality of Service for Voice over IP" in the Cisco IOS Quality of Service Solutions document


Note Low latency queueing works in conjunction with setting the transmission (tx) ring. (For more information about setting the tx ring, see the section "Tunable Transmission Ring.")


Per-VC Queueing

Per-virtual circuit (per-VC) queueing is supported on ADSL and G.SHDSL interfaces at the driver level, similar to VC-queueing features on other ATM interfaces. This feature underlies many of the Cisco IOS QoS queueing features, such as LLQ.

For more information about per-VC queueing, refer to the following documents:

Understanding Weighted Fair Queuing on ATM

Per-VC Class-Based, Weighted Fair Queuing (Per-VC CBWFQ) on the Cisco 7200, 3600,
and 2600 Routers

Congestion Avoidance

The following existing Cisco IOS congestion avoidance feature is supported on ADSL and G.SHDSL WICs:

Class-Based WRED with DSCP (egress)

Class-Based WRED with DSCP (egress)

For information about class-based weighted random early detection (WRED), refer to the following documents:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2

DiffServ Compliant Weighted Random Error Detection

Policing and Traffic Shaping

The following existing Cisco IOS policing and shaping features are now supported on ADSL and G.SHDSL WICs:

Class-Based Policing

VC Shaping for VBR-NRT

Class-Based Policing

For information about traffic classes and traffic policies, refer to the following document:

The chapter "Configuring Traffic Policing" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

VC Shaping for VBR-NRT

For information about VC shaping for variable bit rate-nonreal time (VBR-NRT), refer to the following document:

Understanding the VBR-nrt Service Category and Traffic Shaping for ATM VCs

Link Latency

The following link latency features are supported on ADSL and G.SHDSL WICs:

MLP with LFI - Bundling of VCs Across xDSL Interfaces

Tunable Transmission Ring

MLP with LFI - Bundling of VCs Across xDSL Interfaces

For information about the Multilink PPP Link Fragmentation and Interleaving (MLP and LFI) - Bundling of VCs Across ADSL and G.SHDSL (xDSL) Interfaces feature, refer to the following document:

The chapter "Configuring Link Fragmentation and Interleaving for Multilink PPP" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Tunable Transmission Ring

The tx ring is the first-in, first-out (FIFO) buffer used to hold frames before transmission at the DSL driver level. The tx ring defines the maximum number of packets that can wait for transmission at Layer 2.

The tx ring complements the ability of LLQ to minimize jitter and latency of voice packets. For maximum voice quality, a low tx ring setting should be used. For maximum data throughput, a high tx ring setting should be used.

You can configure the size of the tx ring for each permanent virtual circuit (PVC). The default value is 60. However, the value of the setting can be changed to 2 or 3. (The only permitted values are 2, 3, or 60). A low tx ring setting, such as 2 or 3, is required for latency-critical traffic. For example, when the tx ring limit is configured as 3 and LLQ is configured on the PVC, the worst case delay for a voice packet is the time required to transmit three data packets. When the buffering is reduced by configuring the tx ring limit, the delay experienced by voice packets is reduced by a combination of the tx ring and LLQ mechanism.


NoteThe size of the tx ring buffer is measured in packets, not particles.

The Tunable Transmission Ring feature is not supported on Cisco 1700 series routers until Cisco IOS Release 12.2(8)YN.


Other (IP QoS)

The following IP QoS features are supported on ADSL and G.SHDSL WICs:

Access Control Lists

IP QoS Map to ATM CoS

Access Control Lists

For information about configuring access control lists, refer to the following document:

The chapter "Configuring IP Services" in the Cisco IOS IP Configuration Guide, Release 12.2

IP QoS Map to ATM CoS

For information about IP QoS map to ATM class of service (CoS), refer to the following document:

The chapter "Configuring IP to ATM Class of Service" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Additional Supported Features

The following existing IOS features are supported on ADSL and G.SHDSL WICs:

F5 OAM CC Segment Functionality

H.323 and Media Gateway Control Protocol

ILMI

Multiple PVC Support

RFC 1483 Routing

F5 OAM CC Segment Functionality

For information about F5 Operation, Administration, and Maintenance Continuity Check (F5 OAM CC) segment functionality, refer to the following documents:

Cisco Product Bulletin No. 1518 about Cisco IOS software Release 12.2(2)XJ

Release Notes for the Cisco 1700 Series Routers for Cisco IOS Release 12.2(XJ)

H.323 and Media Gateway Control Protocol

For information about Cisco H.323 and Media Gateway Control Protocol (MGCP) features, refer to the following documents:

The chapter "Configuring Voice over IP" in the Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

The chapter "H.323 Applications" in the Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

ILMI

For information about Integrated Local Management Interface (ILMI) protocol implementation for Cisco digital subscriber loop access multiplexers (DSLAMs) with N1-2 cards, refer to the following document:

The chapter "Configuring ILMI" in the Configuration Guide for Cisco DSLAMS with N1-2

Multiple PVC Support

For information about PVCs, refer to the following documents:

The chapter "Wide-Area Networking Overview" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

The chapter "Configuring ATM" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

RFC 1483 Routing

For information about ATM and ATM adaptation layers (AALs), refer to the following document:

The chapter "Wide-Area Networking Overview" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

For information regarding AAL5 Subnetwork Access Protocol (AAL5SNAP) encapsulations, refer to the following document:

The chapter "Configuring ATM" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

Benefits

QoS provides improved and more predictable network service for ADSL and G.SHDSL by

Supporting dedicated bandwidth.

Improving loss characteristics.

Avoiding and managing network congestion.

Shaping network traffic.

Setting traffic priorities across the network.

Restrictions

G.SHDSL WICs are not supported on Cisco 3600 series routers in the Cisco IOS Release 12.2(4)XL.


Note The G.SHDSL WIC is supported on Cisco 2600 series routers in the Cisco IOS Release 12.2(4)XL.


Analog and BRI voice on the NM-1V/2V cards are not supported over VoATM in AAL2.

Refer to the following documents for caveat information for multiple PVCs on Cisco 1700 series, Cisco 2600 series, and Cisco 3600 series routers:

Release Notes for the Cisco 1700 Series Routers for Cisco IOS Release 12.2(8)YN

Release Notes for the Cisco 1700 Series Routers for Cisco IOS Release 12.2(2)XK

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XL

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XL

F5 OAM CC segment functionality is not currently supported on Cisco DSLAMs.

Related Documents

Table 2 lists related documents about the Voice and QoS for ADSL and G.SHDSL features on Cisco 1700, Cisco 2600, and Cisco 3600 series routers.

Table 2 Related Documents

Related Topic
Document Titles

ADSL WAN interface card

Configuring an ADSL WAN Interface Card on Cisco 1700 Series Routers

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T

ATM, configuring

Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

Cisco IOS Wide-Area Networking Command Reference, Release 12.2

Caveat information for the Cisco 1700 series, Cisco 2600 series, and Cisco 3600 series routers

Release Notes for the Cisco 1700 Series Routers for Cisco IOS Release 12.2(2)XK

Release Notes for the Cisco 1700 Series Routers for Cisco IOS Release 12.2(8)YN

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XL

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XL

Dial-peer DSCPs and IP precedence marking

The chapter "Quality of Service for Voice over IP" in the Cisco IOS Quality of Service Solutions

F5 OAM CC segment functionality

"Cisco Product Bulletin No. 1518" about Cisco IOS software Release 12.2(2)XJ

Release Notes for the Cisco 1700 Series Routers for Cisco IOS Release 12.2(XJ)

G.SHDSL WAN interface card

Installing the G.SHDSL WIC on the Cisco 1700 Series Router

1-Port G.SHDSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)XL

ILMI

The chapter "Configuring ILMI" in the Configuration Guide for Cisco DSLAMS with N1-2

IP, configuring

Cisco IOS IP Configuration Guide, Release 12.2

Cisco IOS IP Command Reference, Release 12.2 (there are three volumes)

Local policy routing

The chapter "Configuring IP Routing Protocols" in Router Products Configuration Guide

Per-VC queueing

Understanding Weighted Fair Queuing on ATM

Per-VC Class-Based, Weighted Fair Queuing (Per-VC CBWFQ) on the Cisco 7200, 3600,
and 2600 Routers

QoS, configuring

Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2

QoS features on Cisco 1700 series routers

Cisco IOS Software Release 12.2(2)XQ1

VC shaping for VBR-NRT

Understanding the VBR-nrt Service Category and Traffic Shaping for ATM VCs

Voice configuration

Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

Cisco IOS Voice, Video, and Fax Command Reference, Release 12.2

WRED

DiffServ Compliant Weighted Random Error Detection


Supported Platforms

Cisco 1720

Cisco 1721

Cisco 1751

Cisco 1751V

Cisco 1760

Cisco 1760V

Cisco 2650

Cisco 2651

Cisco 2600XM

Cisco 3640

Cisco 3660

Determining Platform Support Through Feature Navigator

Cisco IOS software is packaged in feature sets that are supported on specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.


Note As of Cisco IOS Release 12.2(2)XK and Release 12.2(4)XL, Feature Navigator does not support features included in these limited-lifetime releases.


Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

No new or modified RFCs are supported by these features.

RFCs

No new or modified RFCs are supported by this feature.

Prerequisites

To configure the voice and QoS features, you must first install and configure the ADSL or G.SHDSL WIC on your Cisco 1700 series, Cisco 2600 series, or Cisco 3600 series router. Refer to the installation and configuration instructions in the following documents:

Configuring an ADSL WAN Interface Card on Cisco 1700 Series Routers

Installing the G.SHDSL ATM WIC on the Cisco 1700 Series Router

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T

1-Port G.SHDSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)XL

Configuration Tasks

See the following section to configure voice and QoS features over ADSL and G.SHDSL:

Configuring the Error Duration for Digital Subscriber Line Access Multiplexers (required)

Configuring the Tx Ring Limit (required)

Verifying the TX Ring Limit

Configuration Examples

Configuring the Error Duration for Digital Subscriber Line Access Multiplexers

To configure the error duration for digital subscriber line access multiplexers (DSLAMs), use the following command in interface configuration mode:

Command
Purpose
Router(config-if)# dsl equipment-type 
ignore-error duration {seconds}

Configures the DSLAMs. The seconds argument has a valid range from 15 to 30 seconds.

Configuring the Tx Ring Limit

To configure the tx ring limit, use the following commands beginning in global configuration mode:


Note The Tunable Transmission Ring (tx ring) feature is not supported on Cisco 1700 series routers until Cisco IOS Release 12.2(8)YN.


 
Command
Purpose

Step 1 

Router (config)# interface atm 
slot/port

Configures an ATM interface type and enters interface configuration mode.

The arguments are as follows:

slot—Specifies the backplane slot number on your router. The value ranges from 0 to 4, depending on what router you are configuring. Refer to your router hardware documentation.

/port—ATM port number on a Cisco 2600 or 3600 series router, indicating the T1 link that you are configuring. Enter a value from 0 to 3 or from 0 to 7, depending on whether the network module has four ports or eight ports.

Step 2 

Router (config-if)# pvc [name] vpi/vci 
[ces | ilmi | qsaal | smds]

Creates or assigns a name to an ATM permanent virtual circuit (PVC), specifies the encapsulation type on an ATM PVC, and enters interface-ATM-VC configuration mode.

The keywords and arguments are as follows:

name—(Optional) Specifies the name of the PVC or map. The name can be a maximum of 16 characters.

vpi/—Specifies the ATM network virtual path identifier (VPI) for this PVC. The absence of the "/" and a VPI value defaults the VPI value to 0.

On Cisco 2600 and 3600 series routers using inverse multiplexing over ATM (IMA), the ranges are 0 to 15, 64 to 79, 128 to 143, and 192 to 207.

vci—Specifies the ATM network virtual channel identifier (VCI) for this PVC. This value ranges from 0 to 1 less than the maximum value set for this interface by the atm vc-per-vp command. Typically, lower values 0 to 31 are reserved for specific traffic (for example, F4 Operation, Administration, and Maintenance [OAM], switched virtual circuit [SVC] signaling, and Integrated Local Management Interface [ILMI] and should not be used).

The VCI is a 16-bit field in the header of the ATM cell. The VCI value is unique only on a single link, not throughout the ATM network, because it has local significance only.

The vpi and vci arguments cannot both be set to 0; if one is 0, the other cannot be 0.

ces—(Optional) circuit emulation service encapsulation. This keyword is available on the OC-3/STM-1 ATM Circuit Emulation Service network module only.

 

ilmi—(Optional) Used to set up communication with the ILMI; the associated vpi and vci values ordinarily are 0 and 16, respectively.

 

qsaal—(Optional) A signaling-type PVC used for setting up or tearing down SVCs; the associated vpi and vci values ordinarily are 0 and 5, respectively.

 

smds—(Optional) Specifies encapsulation for Switched Multimegabit Data Service (SMDS) networks. If you are configuring an ATM PVC on the ATM Interface Processor (AIP), you must configure AAL3/4SMDS using the atm aal aal3/4 command before specifying SMDS encapsulation. If you are configuring an ATM network processor module (NPM), the atm aal aal3/4 command is not required. SMDS encapsulation is not supported on the ATM port adapter.

Step 3 

Router (config-if-atm-vc)# 
tx-ring-limit ring-limit

Limits the number of packets that can be used on a transmission ring on the permanent virtual circuit (PVC).

The arguments are as follows:

ring-limit—The maximum number of allowable packets that can be placed on the transmission ring. The default value is 60. On Cisco 2600 and Cisco 3600 series routers, the value can be changed to 2 or 3. (The only permitted values are 2, 3, and 60.)

Verifying the TX Ring Limit

The following output examples are for a tx ring limit over ADSL configuration:

The following show policy-map interface command output is for a tx ring-limit tuning configuration on a Cisco 2600 router. The show policy-map interface command displays the policy-map setup.

Router# show policy-map interface atm 0/1.1

ATM0/1.1:VC 11/201 -

 Service-policy output:SERVICE-PACK-640

Class-map:VOICE-CLASS (match-all)
 5295 packets, 402420 bytes
 30 second offered rate 30000 bps, drop rate 0 bps
 Match:access-group 100
 Weighted Fair Queueing
  Strict Priority
  Output Queue:Conversation 72
  Bandwidth 160 (kbps) Burst 4000 (Bytes)
  (pkts matched/bytes matched) 5295/402420
  (total drops/bytes drops) 0/0

Class-map:class-default (match-any)
 42365 packets, 63625280 bytes
 30 second offered rate 4675000 bps, drop rate 4069000 bps
 Match:any

The following show interfaces atm command output is for a tx ring-limit tuning configuration on a Cisco 2600 router. The show interfaces atm command displays statistics for the ATM interface.

Router# show interfaces atm0/1

ATM0/1 is up, line protocol is up
 Hardware is DSLSAR (with Globespan G.SHDSL module)
 MTU 4470 bytes, sub MTU 4470, BW 2304 Kbit, DLY 880 usec,
  reliability 255/255, txload 59/255, rxload 1/255
 Encapsulation ATM, loopback not set
 Encapsulation(s):AAL5, PVC mode
 23 maximum active VCs, 256 VCs per VP, 1 current VCCs
 VC idle disconnect time:300 seconds
 Last input 00:01:35, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 queue:0/75/0/0 (size/max/drops/flushes); Total output drops:66321
 Queueing strategy:None
 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 541000 bits/sec, 93 packets/sec
  227 packets input, 5355 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  15 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  517351 packets output, 133910269 bytes, 0 underruns
  93 output errors, 0 collisions, 2 interface resets
  0 output buffer failures, 0 output buffers swapped out

The following show queue command output for a tx ring-limit tuning configuration on a Cisco 2600 router displays the flow of traffic that is currently being transported over the ATM interface:

Router# show queue atm 0/1

Interface ATM0/1 VC 11/201
Queueing strategy:weighted fair
Output queue:65/512/64/52265 (size/max total/threshold/drops)
 Conversations 2/3/64 (active/max active/max total)
 Reserved Conversations 0/0 (allocated/max allocated)
 Available Bandwidth 320 kilobits/sec

 (depth/weight/total drops/no-buffer drops/interleaves) 1/0/0/0/0
 Conversation 72, linktype:ip, length:76
 source:10.1.1.204, destination:10.10.11.254, id:0x0000, ttl:59,
 TOS:160 prot:17, source port 400, destination port 400

 (depth/weight/total drops/no-buffer drops/interleaves) 64/32384/52267/0/0
 Conversation 49, linktype:ip, length:1502
 source:10.1.1.205, destination:10.10.11.254, id:0x0000, ttl:59,
 TOS:0 prot:17, source port 500, destination port 500

The following show atm vc command outputs are for a tx ring-limit tuning configuration on a Cisco 2600 router. The show atm vc command displays all ATM PVCs and SVCs and traffic information.

Router# show atm vc

VC not configured on interface ATM0/0
          VCD /                                       Peak  Avg/Min Burst
Interface Name   VPI   VCI  Type  Encaps SC     Kbps  Kbps  Cells   Sts
0/1.1     1      11    201  PVC   SNAP   VBR    640   64    0       UP

Router# show atm vc 1

VC 1 doesn't exist on interface ATM0/0
ATM0/1.1:VCD:1, VPI:11, VCI:201
VBR-NRT, PeakRate:640, Average Rate:640, Burst Cells:0
AAL5-LLC/SNAP, etype:0x0, Flags:0x2000020, VCmode:0x0
OAM frequency:10 second(s)
InARP frequency:15 minutes(s)
InPkts:5, OutPkts:14707, InBytes:560, OutBytes:10698804
InPRoc:5, OutPRoc:5
InFast:0, OutFast:3, InAS:0, OutAS:0
InPktDrops:0, OutPktDrops:56701/0/56701 (holdq/outputq/total)
CrcErrors:0, SarTimeOuts:0, OverSizedSDUs:0, LengthViolation:0, CPIErrors:0
OAM cells received:46
OAM cells sent:51
Status:UP

Configuration Examples

This section provides the following configuration examples:

Differentiated Data Services over ADSL Example

VoIP and Data over ADSL Example

Tx Ring-Limit Tuning over ADSL Example

MLP with LFI over G.SHDSL Example

Differentiated Data Services over ADSL Example

The following is from a Cisco 1751 router. The output displays that the router is configured for differentiated services:

access-list 102 permit udp host 16.0.0.4 host 15.0.0.5
access-list 103 permit udp host 16.0.0.4 host 13.0.0.5
ip cef
class-map match-all traffic-INTRA
 match access-group 102
class-map match-all traffic-INTER
 match access-group 103
class-map match-all traffic-dscp1
 match ip dscp 1
class-map match-any traffic-prec3
 match ip dscp 24
 match ip dscp 25
 match ip dscp 26
 match ip dscp 27
policy-map ADSL-out
 class traffic-INTRA
  bandwidth percent 8
 class traffic-dscp1
  set ip dscp 5
 class traffic-prec3
  set ip precedence 2
 class traffic-INTER
  bandwidth percent 8
 class class-default
  fair-queue
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point
 description COLLEGAMENTO
 mtu 576
 ip address 1.0.0.1 255.0.0.0
 pvc 99/99
  protocol ip 2.0.0.2 broadcast
  vbr-nrt 142 142 1
  oam-pvc 0
  oam retry 5 5 1
  encapsulation aal5snap
  service-policy out ADSL-out
!
dial-peer voice 201 voip
 destination-pattern 3640200
 session target ipv4:14.0.0.3
 playout-delay maximum 300
 ip qos dscp cs4 media
 ip qos dscp cs4 signaling

The following is from a Cisco 2600 router. The output displays how CBWFQ, CAR, and WRED can be applied in the same configuration to provide differentiated services using QoS:

Building configuration...

Current configuration: 2603 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2600-1
!
memory-size iomem 20
!
ip subnet-zero
!
ip cef
!
class-map match-all GOLD
 match access-group 1
class-map match-all SILVER
 match access-group 2
!
policy-map GOLD-160-DATA-PACK-640
 class GOLD
  bandwidth 160
  random-detect dscp-based
  random-detect exponential-weighting-constant 3
  random-detect dscp 16   2     4     10
  random-detect dscp 32   4     12    10
 class SILVER
  bandwidth 320
  random-detect dscp-based
  random-detect exponential-weighting-constant 3
  random-detect dscp 0   30    60    10
  set ip dscp 0
!
interface ATM0/0
 no ip address
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
 ip address 192.168.1.2 255.255.255.0
 pvc 0/201
  protocol ip 192.168.1.1 broadcast
  vbr-nrt 640 640
  tx-ring-limit 3
  service-policy output GOLD-160-DATA-PACK-640
!
interface Ethernet0/0
 ip address 1.3.214.9 255.255.0.0
 half-duplex
!
interface Ethernet0/1
 ip address 10.1.1.1 255.255.255.0
 rate-limit input access-group 1 160000 4470 4470 conform-action set-dscp-transmit 32 
exceed-action continue
 rate-limit input access-group 1 80000 4470 4470 conform-action set-dscp-transmit 16 
exceed-action drop
 half-duplex
!
ip classless
ip route 10.10.11.200 255.255.255.255 192.168.3.1
ip route 223.255.254.254 255.255.255.255 1.3.0.1
ip http server
!
access-list 1 permit 10.1.1.201
access-list 2 permit 10.1.1.202
access-list 3 permit 10.1.1.203
access-list 100 permit udp any any precedence critical
!
snmp-server manager
call rsvp-sync
alias exec s sh run
alias exec c conf t
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!

Verifying the Differentiated Data Services over ADSL Configuration

The following show policy-map interface command output is for the CBWFQ, CAR, and WRED configuration. The show policy-map interface command displays the policy-map setup.

Router# show policy-map interface atm0/0.1

ATM0/0.1:VC 0/201 -

 Service-policy output:GOLD-160-DATA-PACK-640

Class-map:GOLD (match-all)
 22738 packets, 34379856 bytes
 30 second offered rate 239000 bps, drop rate 50000 bps
 Match:access-group 1
 Weighted Fair Queueing
  Output Queue:Conversation 73
  Bandwidth 160 (kbps)
  (pkts matched/bytes matched) 22738/34379856
  (depth/total drops/no-buffer drops) 4/4739/0
   exponential weight:3
   mean queue depth:4

     dscp       Random drop     Tail drop       Minimum   Maximum   Mark
                pkts/bytes      pkts/bytes      threshold threshold probability
     af11       0/0             0/0             32        40       1/10
     af12       0/0             0/0             28        40       1/10
     af13       0/0             0/0             24        40       1/10
     af21       0/0             0/0             32        40       1/0
     af22       0/0             0/0             28        40       1/10
     af23       0/0             0/0             24        40       1/10
     af31       0/0             0/0             32        40       1/10
     af32       0/0             0/0             28        40       1/10
     af33       0/0             0/0             24        40       1/10
     af41       0/0             0/0             32        40       1/10
     af42       0/0             0/0             28        40       1/10
     af43       0/0             0/0             24        40       1/10
     cs1        0/0             0/0             22        40       1/10
     cs2        332/501984      3907/5907384     2         4       1/10
     cs3        0/              0/0             26        40       1/10
     cs4        506/765072      0/0              4        12       1/10
     cs5        0/0             0/0             30        40       1/10
     cs6        0/0             0/0             32        40       1/10
     cs7        0/0             0/0             34        40       1/10
     ef         0/0             0/0             36        40       1/10
     rsvp       0/0             0/0             36        40       1/10
     default    0/0             0/0             20        40       1/10

Class-map:SILVER (match-all)
 114748 packets, 173498976 bytes
 30 second offered rate 1212000 bps, drop rate 832000 bps
 Match:access-group 2
 Weighted Fair Queueing
  Output Queue:Conversation 74
  Bandwidth 320 (kbps)
  (pkts matched/bytes matched) 115126/174070512
  (depth/total drops/no-buffer drops) 61/79012/0
   exponential weight:3
   mean queue depth:61

     dscp       Random drop     Tail drop       Minimum   Maximum   Mark
                pkts/bytes      pkts/bytes      threshold threshold probability
     af11       0/0             0/0             32        40         1/10
     af12       0/0             0/0             28        40         1/10
     af13       0/0             0/0             24        40         1/10
     af21       0/0             0/0             32        40         1/10
     af22       0/0             0/0             28        40         1/10
     af23       0/0             0/0             24        40         1/10
     af31       0/0             0/0             32        40         1/10
     af32       0/0             0/0             28        40         1/10
     af33       0/0             0/0             24        40         1/10
     af41       0/0             0/0             32        40         1/10
     af42       0/0             0/0             28        40         1/10
     af43       0/0             0/0             24        40         1/10
     cs1        0/0             0/0             22        40         1/10
     cs2        0/0             0/0             24        40         1/10
     cs3        0/0             0/0             26        40         1/10
     cs4        0/0             0/0             28        40         1/10
     cs5        0/0             0/0             30        40         1/10
     cs6        0/0             0/0             32        40         1/10
     cs7        0/0             0/0             34        40         1/10
     ef         0/0             0/0             36        40         1/10
     rsvp       0/0             0/0             36        60         1/10
     default    9096/13753152   70065/105938280 30        60         1/10

 QoS Set
  ip dscp 0
   Packets marked 115344

Class-map:class-default (match-any)
 114747 packets, 173497464 bytes
 30 second offered rate 1212000 bps, drop rate 1209000 bps
 Match:any

The following show interfaces command is from a Cisco 2600 router. The show interfaces command displays statistics for all interfaces configured on the router.

Router# show interfaces e0/1 rate-limit

Ethernet0/1
 Input
  matches:access-group 1
   params: 160000 bps, 4470 limit, 4470 extended limit
   conformed 15673 packets, 23728922 bytes; action:set-dscp-transmit 32
   exceeded 102965 packets, 155889010 bytes; action:continue
   last packet:0ms ago, current burst:4146 bytes
   last cleared 00:19:46 ago, conformed 160000 bps, exceeded 1051000 bps
  matches:access-group 1
   params: 80000 bps, 4470 limit, 4470 extended limit
   conformed 7836 packets, 11863704 bytes; action:set-dscp-transmit 16
   exceeded 95130 packets, 144026820 bytes; action:drop
   last packet:4ms ago, current burst:3708 bytes
   last cleared 00:19:46 ago, conformed 79000 bps, exceeded 971000 bps

The following show interfaces atm command output is from a Cisco 2600 router. The show interfaces atm command displays information about the ATM interface.

Router# show interfaces atm 0/0

ATM0/0 is up, line protocol is up
 Hardware is DSLSAR (with Alcatel ADSL Module)
 MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec,
  reliability 255/255, txload 181/255, rxload 1/255
 Encapsulation ATM, loopback not set
 Encapsulation(s):AAL5  AAL2, PVC mode
 23 maximum active VCs, 256 VCs per VP, 2 current VCCs
 VC idle disconnect time:300 seconds
 Last input 00:33:22, output 00:00:00, output hang never
 Last clearing of "show interface" counters 00:20:09
 Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:208908
 Queueing strategy:None
 30 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 569000 bits/sec, 48 packets/sec
  0 packets input, 0 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  57315 packets output, 86075268 bytes, 0 underruns
  0 output errors, 0 collisions, 0 interface resets
  0 output buffer failures, 0 output buffers swapped out

The following show queue command output from a Cisco 2600 router displays the flow of traffic that is currently being transported over the ATM interface:

Router# show queue atm0/0

Interface ATM0/0 VC 0/201
Queueing strategy:weighted fair
Output queue:130/512/64/214301 (size/max total/threshold/drops)
 Conversations  3/3/64 (active/max active/max total)
 Reserved Conversations 2/2 (allocated/max allocated)
 Available Bandwidth 0 kilobits/sec

(depth/weight/total drops/no-buffer drops/random/tail/interleaves) 5/228/5124/0/0/0/0
Conversation 73, linktype:ip, length:1512
source:10.1.1.201, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:128 prot:17, source port 100, destination port 100

(depth/weight/total drops/no-buffer drops/random/tail/interleaves) 
61/114/85189/0/9843/75346/0
Conversation 74, linktype:ip, length:1512
source:10.1.1.202, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:0 prot:17, source port 200, destination port 200

(depth/weight/total drops/no-buffer drops/interleaves) 64/32384/123990/0/0
Conversation 41, linktype:ip, length:1512
source:10.1.1.203, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:0 prot:17, source port 300, destination port 300

VoIP and Data over ADSL Example

The following is sample output from a Cisco 2611 router. In this example, the customer premises equipment (CPE) is restricted to only a single PVC. Voice and data are sent over a single VC. The tx-ring-limit command and LLQ are used to give preferential treatment for voice traffic.

Building configuration...

Current configuration :1861 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CPE-2611-1
!
voice-card 1
 dspfarm
!
ip subnet-zero
!
ip cef
!
class-map match-all VOICE
 match access-group 100
!
policy-map VOICE-160-DATA-480-PACK
 class VOICE
  priority 160
 class class-default
  bandwidth 320
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
 framing sf
 linecode ami
!
interface ATM0/0
 no ip address
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
 ip address 192.168.1.2 255.255.255.0
 pvc 0/201 
  protocol ip 192.168.1.1 broadcast
  vbr-nrt 640 640
  tx-ring-limit 3
  service-policy output VOICE-160-DATA-480-PACK
!
interface Ethernet0/0
 ip address 1.3.214.51 255.255.0.0
 half-duplex
!
interface ATM0/1
 no ip address
 shutdown
 atm vc-per-vp 256
 no atm ilmi-keepalive
 atm voice aal2 aggregate-svc upspeed-number 0
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/1
 ip address 10.1.1.1 255.255.255.0
 half-duplex
!
ip classless
ip route 223.255.254.254 255.255.255.255 1.3.0.1
ip http server
!
access-list 100 permit udp any any precedence critical
!
snmp-server manager
call rsvp-sync
!
voice-port 1/0:0
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 1 pots
 destination-pattern 7...
 port 1/0:0
!
dial-peer voice 2 voip
 destination-pattern 8...
 session target ipv4:192.168.3.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
alias exec s sh run
alias exec c conf t
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
line vty 5 15
 login

Verifying the VoIP and Data over ADSL Configuration

The following show policy-map interface command output from a Cisco 2600 router displays the service-policy setup:

Router# show policy-map interface atm0/0

ATM0/0:VC 0/201 -

Service-policy output:VOICE-160-DATA-480

Class-map:class-default (match-any)
 27234 packets, 41109865 bytes
 30 second offered rate 7000 bps, drop rate 3000 bps
 Match:any 
 Weighted Fair Queueing
 Queue:Conversation 73 
 Bandwidth 320 (kbps) Max Threshold 64 (packets)
 (pkts matched/bytes matched) 27231/41105329
 (depth/total drops/no-buffer drops) 0/14711/0

For
Class-map:class-default (match-any)
 113187 packets, 140760375 bytes
 30 second offered rate 1205000 bps, drop rate 787000 bps
 Match:any

The following show queue command output from a Cisco 2600 router displays the flow of traffic that is currently being transported over an ATM interface:

Router# show queue atm 0/0

Interface ATM0/0 VC 0/201
Queueing strategy:weighted fair
Output queue:70/512/64/70462 (size/max total/threshold/drops)
 Conversations  3/6/64 (active/max active/max total)
 Reserved Conversations 0/0 (allocated/max allocated)
 Available Bandwidth 320 kilobits/sec

(depth/weight/total drops/no-buffer drops/interleaves) 3/0/0/0/0
Conversation 72, linktype:ip, length:72
source:192.168.1.2, destination:192.168.1.1, id:0xC77E, ttl:254,
TOS:160 prot:17, source port 19406, destination port 16406

(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/0/0/0
Conversation 23, linktype:ip, length:196
source:192.168.1.2, destination:192.168.1.1, id:0x0000, ttl:255,
TOS:0 prot:17, source port 18653, destination port 18691

(depth/weight/total drops/no-buffer drops/interleaves) 64/32384/65793/0/0
Conversation 59, linktype:ip, length:1502
source:10.1.1.205, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:0 prot:17, source port 500, destination port 500

The following show queueing interface command output from a Cisco 2600 router displays the queueing configuration of the ATM interface:

Router# show queueing interface atm0/0

Interface ATM0/0 VC 0/201
Queueing strategy:weighted fair
Output queue:66/512/64/61642 (size/max total/threshold/drops)
 Conversations  2/6/64 (active/max active/max total)
 Reserved Conversations 0/0 (allocated/max allocated)
 Available Bandwidth 320 kilobits/sec

The following show interfaces atm command output from a Cisco 2600 router displays statistics for the ATM interface:

Router# show interfaces atm0/0

ATM0/0 is up, line protocol is up
 Hardware is DSLSAR (with Alcatel ADSL Module)
 Internet address is 192.168.1.2/24
 MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec,
  reliability 255/255, txload 166/255, rxload 21/255
 Encapsulation ATM, loopback not set
 Encapsulation(s):AAL5  AAL2, PVC mode
 23 maximum active VCs, 256 VCs per VP, 2 current VCCs
 VC idle disconnect time:300 seconds
 Last input 00:00:02, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:62360
 Queueing strategy:None
 30 second input rate 66000 bits/sec, 113 packets/sec
 30 second output rate 523000 bits/sec, 229 packets/sec
  1603630 packets input, 403845485 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  2680554 packets output, 518308502 bytes, 0 underruns
  0 output errors, 0 collisions, 4 interface resets
  buffer failures, 0 output buffers swapped out

The following show atm vc command output from a Cisco 2600 router displays information about the ATM virtual circuit:

Router# show atm vc

            VCD /                                             Peak  Avg/Min Burst
Interface   Name        VPI VCI   Type   Encaps   SC    Kbps  Kbps  Cells   Sts
0/0         1           0   201   PVC    SNAP     VBR   640   640   0       UP
VC not configured on interface ATM0/1

The following show atm vc command output from a Cisco 2600 router displays detailed information about the virtual circuit descriptor (VCD):

Router# show atm vc 1

ATM0/0:VCD:1, VPI:0, VCI:201
VBR-NRT, PeakRate:640, Average Rate:640, Burst Cells:0
AAL5-LLC/SNAP, etype:0x0, Flags:0x2000820, VCmode:0x0
OAM frequency:10 second(s)
InARP frequency:15 minutes(s)
InPkts:1606861, OutPkts:2682709, InBytes:404080341, OutBytes:519701804
InPRoc:108900, OutPRoc:109133, Broadcasts:1
InFast:1497961, OutFast:0, InAS:0, OutAS:0
InPktDrops:0, OutPktDrops:64078/0/64078 (holdq/outputq/total)
CrcErrors:0, SarTimeOuts:0, OverSizedSDUs:0, LengthViolation:0, CPIErrors:0
OAM cells received:4765
OAM cells sent:4767
Status:UP
VC 1 doesn't exist on interface ATM0/1

Tx Ring-Limit Tuning over ADSL Example

The following is output from a Cisco 2600 router. The output shows that tx ring-limit tuning is configured:


Note The Tunable Transmission Ring (tx ring) feature is not supported on Cisco 1700 series routers until Cisco IOS Release 12.2(8)YN.


Building configuration...

Current configuration :2018 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CPE-2600-1
!
voice-card 1
 dspfarm
!
ip subnet-zero
!
ip cef
!
class-map match-all VOICE-CLASS
  match access-group 100
!
policy-map SERVICE-PACK-640
  class VOICE-CLASS
    priority 160
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
 framing sf
 linecode ami
!
interface FastEthernet0/0
 ip address 1.3.214.50 255.255.0.0
 duplex auto
 speed auto
!
interface ATM0/1
 no ip address
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 atm voice aal2 aggregate-svc upspeed-number 0
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface ATM0/1.1 point-to-point
 ip address 192.168.1.2 255.255.255.0
 pvc 11/201
  protocol ip 192.168.1.1 broadcast
  vbr-nrt 640 640
  tx-ring-limit 3
  oam-pvc manage
  service-policy output SERVICE-PACK-640
!
interface FastEthernet0/1
 ip address 10.10.11.1 255.255.255.0
 load-interval 30
 duplex auto
 speed auto
!
ip classless
ip route 10.10.11.254 255.255.255.255 192.168.1.1
ip route 223.255.254.254 255.255.255.255 1.3.0.1
ip http server
ip pim bidir-enable
!
ip director cache time 60
access-list 100 permit udp any any precedence critical
!
snmp-server manager
call rsvp-sync
!
voice-port 1/0:0
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 1 pots
 destination-pattern 7...
!
dial-peer voice 2 voip
 destination-pattern 8...
 session target ipv4:192.168.1.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
alias exec s sh run
alias exec c conf t
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!

MLP with LFI over G.SHDSL Example

The following output is from a Cisco 1751 router. The output shows that MLP with LFI is configured for G.SHDSL:

class-map match-all VOIP
 match ip dscp 32
class-map CRITICAL
match access-group 100
!
policy-map 1751_DSL
 class CRITICAL
 priority 48
class VOIP
 priority 64
 set ip precedence 6
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point
 pvc 0/33
 vbr-rt 150 150 30
 protocol ppp Virtual-Template1
!
interface Loopback1
 ip address 10.0.0.10 255.255.255.255
interface Virtual-Template1
 bandwidth 320
 ip unnumbered Loopback1
 service-policy output 1751_DSL
 ppp multilink
 ppp multilink fragment-delay 4
 ppp multilink interleave
! 
access-list 100 permit udp any any precedence critical
dial-peer voice 201 voip
   destination-pattern 3640200
   session target ipv4:10.0.0.11
   ip qos dscp cs4 media

   ip qos dscp cs4 signalling

The following output is from a Cisco 2600 router. The output shows that MLP with LFI is configured for G.SHDSL:

Building configuration...

Current configuration :2107 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CPE-2600-1
!
memory-size iomem 20
voice-card 1
 dspfarm
!
ip subnet-zero
!
ip cef
!
class-map match-all VOICE-CLASS
 match access-group 100
!
policy-map SERVICE-PACK-640
 class VOICE-CLASS
  priority 160
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
 framing sf
 linecode ami
!
interface FastEthernet0/0
 ip address 1.3.214.50 255.255.0.0
 duplex auto
 speed auto
!
interface ATM0/1
 no ip address
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 atm voice aal2 aggregate-svc upspeed-number 0
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface ATM0/1.1 point-to-point
 pvc 11/201
  vbr-nrt 640 640
  tx-ring-limit 3
  oam-pvc manage
  protocol ppp Virtual-Template1
!
interface FastEthernet0/1
 ip address 10.10.11.1 255.255.255.0
 load-interval 30
 duplex auto
 speed auto
!
interface Virtual-Template1
 bandwidth 640
 ip address 192.168.1.2 255.255.255.0
 load-interval 30
 service-policy output SERVICE-PACK-640
 ppp multilink
 ppp multilink fragment-delay 4
 ppp multilink interleave
!
ip classless
ip route 10.10.11.254 255.255.255.255 192.168.1.1
ip route 223.255.254.254 255.255.255.255 1.3.0.1
ip http server
ip pim bidir-enable
!
ip director cache time 60
access-list 100 permit udp any any precedence critical
!
snmp-server manager
call rsvp-sync
!
voice-port 1/0:0
!
mgcp profile default
!
dial-peer cor custom
!
 destination-pattern 7...
!
dial-peer voice 2 voip
 destination-pattern 8...
 session target ipv4:192.168.1.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
alias exec s sh run
alias exec c conf t
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
line vty 5 15
 login

Verifying the MLP with LFI over G.SHDSL Configuration

The following show users command output is for the MLP with LFI configuration on a Cisco 2600 router. The show users command displays information about the active lines on the router.

Router# show users

   Line        User       Host(s               Idle         Location
*  0 con 0                idle                 00:00:00

   Interface   User     Mode                   Idle      Peer Address
   Vi1                  Virtual PPP (ATM)      -
   Vi2                  Virtual PPP (Bundle)   00:14:06  192.168.1.1

The following show interfaces command output is for the MLP with LFI configuration on a Cisco 2600 router. The show interfaces command displays statistics for all interfaces configured on the router.

Router# show interfaces virtual-access 2

Virtual-Access2 is up, line protocol is up
 Hardware is Virtual Access interface
 Internet address is 192.168.1.2/24
 MTU 1500 bytes, BW 640 Kbit, DLY 100000 usec,
  reliability 255/255, txload 207/255, rxload 1/255
 Encapsulation PPP, loopback not set
 DTR is pulsed for 5 seconds on reset
 LCP Open, multilink Open
 Open:IPCP
 Last input 00:14:20, output never, output hang never
 Last clearing of "show interface" counters 00:26:31
 Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:477969
 Queueing strategy:weighted fair
 Output queue:64/1000/64/477969 (size/max total/threshold/drops)
  Conversations  1/2/256 (active/max active/max total)
  Reserved Conversations 0/0 (allocated/max allocated)
  Available Bandwidth 320 kilobits/sec
 30 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 522000 bits/sec, 91 packets/sec
  12 packets input, 911 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  136585 packets output, 97029054 bytes, 0 underruns
  0 output errors, 0 collisions, 0 interface resets
  0 output buffer failures, 0 output buffers swapped out
  0 carrier transitions

The following show policy-map interface command is for the MLP with LFI configuration on a Cisco 2600 route. The show policy-map interface command displays the policy-map setup.

Router# show policy-map interface virtual-access 2

 Virtual-Access2

 Service-policy output:SERVICE-PACK-640

  Class-map:VOICE-CLASS (match-all)
   30887 packets, 2100316 bytes
   30 second offered rate 27000 bps, drop rate 0 bps
   Match:access-group 100
   Weighted Fair Queueing
    Strict Priority
    Output Queue:Conversation 264
    Bandwidth 160 (kbps) Burst 4000 (Bytes)
    (pkts matched/bytes matched) 30888/2100384
    (total drops/bytes drops) 0/0

  Class-map:class-default (match-any)
   247101 packets, 369168894 bytes
   30 second offered rate 4785000 bps, drop rate 4283000 bps
   Match:any

The following show ppp multilink command output is for the MLP with LFI configuration on a Cisco 2600 router. The show ppp multilink command displays bundle information for the Multilink PPP bundles.

Router# show ppp multilink

Virtual-Access2, bundle name is green-gateway-3660
 Bundle up for 00:26:05
 0 lost fragments, 0 reordered, 0 unassigned
 0 discarded, 0 lost received, 215/255 load
 0xC received sequence, 0x55914 sent sequence
 Member links:1 (max not set, min not set)
  Virtual-Access1, since 00:26:05, last rcvd seq 00000B  320 weight

The following show interfaces atm command output is for the MLP with LFI configuration. The show interfaces atm command displays information about the ATM interface.

Router# show interfaces atm 0/1

ATM0/1 is up, line protocol is up
 Hardware is DSLSAR (with Globespan G.SHDSL module)
 MTU 4470 bytes, sub MTU 4470, BW 2304 Kbit, DLY 880 usec,
  reliability 255/255, txload 59/255, rxload 1/255
 Encapsulation ATM, loopback not set
 Encapsulation(s):AAL5 , PVC mode
 23 maximum active VCs, 256 VCs per VP, 1 current VCCs
 VC idle disconnect time:300 seconds
 Last input never, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:75
 Queueing strategy:None
 30 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 539000 bits/sec, 257 packets/sec
  186 packets input, 3409 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  433482 packets output, 103985075 bytes, 0 underruns
  0 output errors, 0 collisions, 2 interface resets
  0 output buffer failures, 0 output buffers swapped out

Command Reference

This section documents a modified command. All other commands used with this feature are documented in the Cisco IOS Release 12.2 command reference publications.

Modified

dsl equipment-type

tx-ring-limit

dsl equipment-type

To configure the DSL ATM interface to function as central office equipment or customer premises equipment, use the dsl equipment-type command in ATM interface mode. To restore the default (no equipment type), use the no form of this command.

dsl equipment-type {co | cpe} ignore-error-duration {seconds}

no dsl equipment-type

Syntax Description

co

Configures the DSL ATM interface to function as central office equipment.

cpe

Configures the DSL ATM interface to function as customer premises equipment.

ignore-error-duration seconds

Number of seconds that errors are ignored. The valid range is from 15 to 30 seconds. The default is 0.

Note This keyword was added for digital subscriber line access multiplexers (DSLAMs).


Defaults

The DSL ATM interface functions as customer premises equipment.

Command Modes

ATM interface

Command History

Release
Modification

12.2(4)XL

This command was integrated into Cisco IOS Release 12.2(4)XL on the G.SHDSL WIC on the Cisco 2600 series routers.

12.2(8)T

This command was integrated into Cisco IOS Release 12.2(8)T on the G.SHDSL WIC on the Cisco 2600 series and Cisco 3600 series routers.

12.2(13)T

The ignore-error-duration keyword was added for DSLAMs.


Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you enter this command.

The ATM interface must be in the shutdown state before you enter this command.

Examples

The following example shows the configuration of 20 seconds to ignore errors for a DSLAM on DSL ATM interface 1/1:

interface atm 1/1 
 dsl equipment-type ignore-error-duration 20

Related Commands

Command
Description

dsl linerate

Specifies a line rate for the DSL ATM interface.

dsl operating-mode (G.SHDSL)

Specifies an operating mode of the DSL ATM interface.


tx-ring-limit

To limit the number of packets that can be used on a transmission ring on the DSL WIC, use the tx-ring-limit command in ATM VC configuration mode. To not limit the number of packets that can be used on a transmission ring on a DSL WIC, use the no form of this command.

tx-ring-limit ring-limit

no tx-ring-limit ring-limit

Syntax Description

ring-limit

Maximum number of allowable packets that can be placed on the transmission ring. The default value is 60. On a Cisco 2600 or Cisco 3600 series router, the value can be changed to 3. (The only permitted values are 3 or 60.) A tx ring setting of 3 is required for latency-critical traffic. When the buffering is reduced by configuring the tx ring limit, the delay experienced by voice packets is reduced by a combination of the tx ring and LLQ mechanism.

Note The tx-ring-limit command is not supported on the Cisco 1700 in Cisco IOS Release 12.2(13)T.


Defaults

The default value of the ring-limit argument is 60.

Command Modes

ATM VC configuration

Command History

Release
Modification

12.0(7)XE1

This command was introduced.

12.0(9)S

This command was integrated into Cisco IOS Release 12.0 S.

12.1(5)T

This command was integrated into Cisco IOS Release 12.1(5)T.

12.2(13)T

This command was integrated into Cisco IOS Release 12.2(13)T.


Examples

The following example configures the transmission ring limit to three packets on an ATM interface:

interface atm 1/0/0
 atm pvc 32 0 32 aal5snap 10000 8000 2000 tx-ring-limit 3

The following example configures the transmission ring limit to 60 packets on an ATM permanent virtual circuit (PVC) subinterface:

interface ATM1/0/0.1 point-to-point
 pvc 2/200
 tx-ring-limit 60

Related Commands(

Command
Description

dsl

Specifies DSL equipment and the seconds to ignore errors.

show atm vc

Displays all ATM PVCs and traffic information.

tx-queue-limit

Controls the number of transmit buffers available to a specified interface or the MCI and SCI cards.