Guest

Cisco IOS Software Releases 12.2 Special and Early Deployments

1-Port G.SHDSL WAN Interface Card For Cisco 2600 Series Routers

  • Viewing Options

  • PDF (316.5 KB)
  • Feedback
1-Port G.SHDSL WAN Interface Card for Cisco 2600 Series Routers

Table Of Contents

1-Port G.SHDSL WAN Interface Card for Cisco 2600 Series Routers

Feature Overview

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring G.SHDSL on a Cisco Router

Configuring ILMI on the DSLAM Connected to the G.SHDSL WIC

Verifying ATM Configuration

Configuration Examples

Configuration in CPE Mode Example

Configuration in CO Mode Example

Command Reference

dsl equipment-type

dsl linerate

dsl operating-mode (G.SHDSL)

Glossary


1-Port G.SHDSL WAN Interface Card for Cisco 2600 Series Routers


Feature History
Release
Modification

12.2(4)XL

This feature was integrated into Cisco IOS Release 12.2(4)XL for Cisco 2600 series routers.


This document describes the Multirate Symmetrical High-Speed Digital Subscriber Line (G.SHDSL) feature supported on the 1-port G.SHDSL WAN interface card (WIC) (WIC-1SHDSL) on Cisco 2600 series routers in Cisco IOS Release 12.2(4)XL. This document describes the benefits of the new feature, supported platforms, configuration, and related documents and provides command reference information.

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuration Examples

Command Reference

Glossary

Feature Overview

G.SHDSL is ATM-based, multirate, high-speed (up to 2.3 MB), symmetrical digital subscriber line technology for data transfer between a single customer premises equipment (CPE) subscriber and a central office.

G.SHDSL is supported on the G.SHDSL WAN interface card (WIC-1SHDSL), a 1-port WAN interface card (WIC) for Cisco 2600 series routers.

The G.SHDSL WIC is compatible with the Cisco 6015, Cisco 6130, Cisco 6160, and Cisco 6260 Digital Subscriber Line Access Multiplexers (DSLAMs). The DSLAM must be equipped with G.SHDSL line cards that are compatible with the DSL service to be configured.

The G.SHDSL WIC supports ATM Adaptation Layer 2 (AAL2), ATM Adaptation Layer 5 (AAL5), and various classes of quality of service (QoS) for both voice and data service.

Benefits

Enables business-class broadband service with voice integration, scalable performance, flexibility, and security.

Symmetrical WAN speeds (up to 2.3Mbps) over a single copper pair.

Repeatable and has thirty percent longer reach than SDSL.

Rate adaptive with G.HS "handshake" Protocol.

Based on ITU Recommendation G.991.2 (Accepted Worldwide).

Support for G.SHDSL Annex A (U.S. signaling) and Annex B (European signaling).

Multiple G.SHDSL WAN Interface Cards configurable per Cisco 2600 series chassis.

Toll-quality voice over delivery over AAL2, AAL5, and VoIP.

Provides ATM traffic management and quality of service (QoS) features to enable service providers to manage their core ATM network infrastructures.

Critical IP QoS features.

Supports ATM class of service features constant bit rate (CBR), variable bit rate-nonreal time (VBR-nrt), variable bit rate-real time (VBR-rt), and unspecified bit rate (UBR and UBR+).

Operates back-to-back or through a DSLAM.

Sustains up to 23 virtual circuits Per WAN on a WIC in Cisco 2600 series routers.

Restrictions

The G.SHDSL WIC does not support dual latency. When the DSL link is intended to support both voice and data traffic simultaneously, the total supported data rate must be reduced to adjust for the reduced coding gain, which is usually present with high-latency traffic.

The G.SHDSL WIC does not support Dying Gasp in ANSI T1.413 Issue 2.

The G.SHDSL WIC does not support available bit rate (ABR) class of service (CoS).

The G.SHDSL WIC should be inserted only into onboard WIC slots or 1FE2W network modules. This WIC is not supported in old combination network modules.

Related Documents

For more information about voice configuration, see the following Cisco IOS Release 12.2 guides:

Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

Cisco IOS Voice, Video, and Fax Command Reference, Release 12.2

The following configuration guides describe the configuration of IP and ATM:

For more information about configuring IP, see the Cisco IOS IP Configuration Guide, Release 12.2.

For more information about configuring ATM, see "Configuring ATM"  in the Wide-Area Networking Configuration Guide, Release 12.2.

For information about configuring a DSLAM, see the Configuration Guide for Cisco DSLAMs with NI-2.

The following online feature documentation and installation guides describe the configuration and installation of hardware components:

For information about installing Cisco 2600 series hardware, see the documents listed at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/index.htm

Supported Platforms

This feature is supported on the following router platforms:

Cisco 2610

Cisco 2611

Cisco 2612

Cisco 2613

Cisco 2620

Cisco 2621

Cisco 2650

Cisco 2651

Supported Standards, MIBs, and RFCs

Standards

Supports ITU-T G.991.2 (SHDSL).

MIBs

No new or modified MIBs are supported by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

No new or modified RFCs are supported by this feature.

Prerequisites

A G.SHDSL WIC must be installed in the router to match the DSL service to be configured. A compatible G.SHDSL line card must be installed in the DSLAM.

Configuration Tasks

See the following sections for configuration tasks for this feature. Each task in the list is identified as either required or optional:

Configuring G.SHDSL on a Cisco Router (required)

Configuring ILMI on the DSLAM Connected to the G.SHDSL WIC (optional)

Verifying ATM Configuration (optional)

Configuring G.SHDSL on a Cisco Router

To configure G.SHDSL service on a Cisco router containing a G.SHDSL WIC, complete the following steps, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface atm 1/0

Enters ATM configuration mode for interface ATM 0 in slot 1.

Note If a slot has two subslots for WIC modules and no ATM interface is present in subslot 0, the WIC will take ATM x/0 as its interface number even if placed in subslot 1 (ATMx/1).

If a two-port ATM module is present in subslot 0, the WIC will use ATM x/2 as its interface number. This subslot number is pertainent to all interface commands such as show interface atm and show dsl interface atm.

Step 2 

Router(config-if)# ip-address IP-address

Assigns an IP address to the DSL ATM interface.

Step 3 

Router(config-if)# atm ilmi-keepalive seconds

(Optional) Enables Integrated Local Management Interface (ILMI) keepalives.

If you enable ILMI keepalives without specifying the seconds, the default time interval is 3 seconds.

Step 4 

Router(config-if)# pvc [name] vpi/vci

Enters atm-virtual-circuit (interface-atm-vc) configuration mode, and configures a new ATM permanent virtual circuit (PVC) by assigning a name (optional) and VPI/VCI numbers.

The default traffic shaping is UBR; the default encapsulation is AAL5+LLC/SNAP.

Step 5 

Router(config-if-vc)# protocol ip IP-address

(Optional) Enables IP connectivity and create a point-to-point IP address for the virtual circuit (VC).

Step 6 

Router(config-if-vc)# vbr-rt peak-rate average-rate burst

(Optional) Configures the PVC for real-time variable bit rate (VBR) traffic shaping.

Peak rate—Peak information rate (PIR)

Average rate—Average information rate (AIR)

Burst—Burst size in cells

Step 7 

Router(config-if-vc)# encapsulation {aal1 | aal2 | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap}

(Optional) Configures the ATM adaptation layer (AAL) and encapsulation type.

aal1—AAL1

aal2—AAL2

aal5ciscoppp—Cisco PPP over AAL5

aal5mux—AAL5+MUX

aal5nlpid—AAL5+NLPID

aal5snap—AAL5+LLC/SNAP (the default)

Step 8 

Router(config-if-vc)# exit

Exits from interface-atm-vc configuration mode.

Step 9 

Router(config-if)# dsl operating-mode 
{gshdsl symmetric annex {A | B}}

Configures the DSL interface to operate in a specified DSL mode:

gshdsl—Configures multirate, high-speed DSL per ITU G.991.2

symmetric—Configures symmetrical mode per ITU G.992.1.

annex—Configures the regional operating parameters.

A—Sets the operating parameters for North America. This value is the default.

B—Sets the operating parameters for Europe.

The default is gshdsl symmetric annex A.

Step 10 

Router(config-if)# equipment-type 
{co | cpe}

Configures the DSL interface to function as central office equipment or customer premises equipment:

co—The WIC functions as central office equipment and can interface with another G.SHDSL WIC configured as cpe.

cpe—The WIC functions as customer premises equipment and can interface with a DSLAM or with another G.SHDSL WIC configured as co.

The default is cpe.

Step 11 

Router(config-if)# dsl linerate {kbps | 
auto }

Configures the DSL line rate:

kbps—Line rate (data transfer rate) in kilobits per second. Allowable entries are 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, and 2312.

auto—The WIC automatically trains for an optimal line rate by negotiating with the far-end DSLAM or WIC.

The default is auto.

Step 12 

Router(config-if)# exit

Exits from ATM interface configuration mode.

Step 13 

Router(config)# exit

Exits from global configuration mode.

Step 14 

Router> show interface atm 1/0

Verifies the ATM interface configuration.

Step 15 

Router clear interface atm 1/0

Permits the configuration changes to take effect.

Configuring ILMI on the DSLAM Connected to the G.SHDSL WIC

The ILMI protocol allows DSLAMs to be used for ATM address registration across an ATM User-Network Interface (UNI). If ILMI is configured on the G.SHDSL WIC, the ATM PVC must be configured on the DSLAM. All switch terminating connections use interface 0/0 to connect to the switch CPU.

For information about configuring the DSLAM, see the Configuration Guide for Cisco DSLAMs with NI-2.

Verifying ATM Configuration

Use the following commands to verify your configuration:

To verify current configuration and to view the status for all controllers, use the show running-config command.

To view ATM controller statistics, use the show controllers atm slot/port command.

To verify the PVC status, use the show atm vc command. Make sure that active PVCs are up.

To help identify ATM related events as they are generated, use the debug atm events command.

To indicate which interfaces are having trouble, use the debug atm errors command.

To identify an entry for the ATM interface you configured and to show an entry for the ATM slot/port you configured, use the show ip route command.

To view the status of ATM interface, use the show interface atm command. Make sure that the ATM slot/port and the line protocol are up, as shown in the following example:

Router# show interface atm 1/0
ATM1/0 is up, line protocol is up 
  Hardware is DSLSAR (with Globespan G.SHDSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Keepalive not supported 
  Encapsulation(s):AAL5 AAL2, PVC mode
  24 maximum active VCs, 256 VCs per VP, 2 current VCCs
  VC idle disconnect time:300 seconds
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters 03:16:00
  Queueing strategy:fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  30 second input rate 0 bits/sec, 0 packets/sec
  30 second output rate 0 bits/sec, 0 packets/sec
     2527 packets input, 57116 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     10798 packets output, 892801 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out

Router# show atm vc
            VCD /                                      Peak  Avg/Min Burst
Interface   Name       VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts
1/0.3      2            9    36   PVC    MUX      UBR     800                UP
1/0.2      1            9    37   PVC    SNAP     UBR     800                UP

Router# show controllers atm 1/0
Interface ATM1/0 is up
  Hardware is DSLSAR (with Globespan G.SHDSL Module)
IDB:    62586758  Instance:6258E054  reg_dslsar:3C810000  wic_regs:3C810080
PHY Inst:62588490  Ser0Inst:62573074  Ser1Inst: 6257CBD8  us_bwidth:800     
Slot:   1         Unit:    1         Subunit:  0         pkt Size:4496    
VCperVP:256       max_vp:  256       max_vc:   65536     total vc:2       
rct_size:65536     vpivcibit:16        connTblVCI:8         vpi_bits:8       
vpvc_sel:3         enabled: 0         throttled:0       

WIC    Register   Value      Notes
---------------   ---------- ----------
FPGA Dev ID (LB)  0x44       'D'
FPGA Dev ID (UB)  0x53       'S'
FPGA Revision     0x99       
WIC Config Reg    0x45       WIC / VIC select = WIC; 
                             CTRLE addr bit 8 = 1; 
                             OK LED on; 
                             LOOPBACK LED off; 
                             CD LED on; 
WIC Config Reg2   0x07       Gen bus error on bad ADSL access
Int 0 Enable Reg  0x03       ADSL normal interrupt enabled
                             ADSL error interrupt enabled

To view the status of the G.SHDSL modem, use the show dsl interface atm command. If the line is down, the following statement appears: Line is not active. Some of the values may not be accurate. You can also verify whether the equipment type and operating mode configuration are correct for your application.

Sample output—The WIC is configured as central office equipment, and the line is up

Router# show dsl interface atm 0/0
Globespan G.SHDSL Chipset Information

 Equipment Type:        Central Office
 Operating Mode:        G.SHDSL
 Clock Rate Mode:       Auto rate selection Mode
 Reset Count:           2
 Actual rate:           2320 Kbps
 Modem Status:          Data
 Noise Margin:          43 dB
 Loop Attenuation:      0.0 dB
 Transmit Power:        13.5 dB
 Receiver Gain:         204.8000 dB
 Last Activation Status:No Failure
 CRC Errors:            0
 Chipset Version:       1
 Firmware Version:      R1.0

 Farend Statistics since CO boot-time:

	CRC Errors:      0
	Errored Seconds: 0
	Severly ES:      0
	Un Available S:  48
	Loss Of Sync S:  0

Sample output—The WIC is configured as customer premises equipment, and the line is up

Router# show dsl interface atm 0/0
Globespan G.SHDSL Chipset Information

 Equipment Type:        Customer Premise
 Operating Mode:        G.SHDSL
 Clock Rate Mode:       Auto rate selection Mode
 Reset Count:           1
 Actual rate:           2320 Kbps
 Modem Status:          Data
 Noise Margin:          42 dB
 Loop Attenuation:      0.0 dB
 Transmit Power:        13.5 dB
 Receiver Gain:         204.8000 dB
 Last Activation Status:No Failure
 CRC Errors:            0
 Chipset Version:       1
 Firmware Version:      R1.0

Configuration Examples

This section provides the following configuration examples:

Configuration in CPE Mode Example

Configuration in CO Mode Example

Configuration in CPE Mode Example

The following example shows a G.SHDSL configuration of VoATM over AAL2, operating in customer premises equipment (CPE) mode, on a Cisco 2600 series router. This router in CPE mode can be linked to either a DSLAM or to another router that is configured to operate in central office (CO) mode.

Router#
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname host1
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
ip host host2 225.255.255.224
!
no mgcp timer receive-rtcp
call rsvp-sync
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1 type e&m-wink-start
 ds0-group 1 timeslots 2 type e&m-wink-start
.
.
.
ds0-group 23 timeslots 24 type e&m-wink-start
!
controller T1 1/1
 framing esf
 linecode b8zs
!
interface Ethernet0/0
 ip address 209.165.202.128 255.255.255.224
 half-duplex
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
!
interface ATM0/1
 ip address 209.165.201.1 255.255.255.224
 dsl operating-mode gshdsl symmetric annex A
 dsl equipment-type cpe
 dsl linerate auto
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 pvc 10/100 
  vbr-rt 672 672 512
  encapsulation aal2
 !
 pvc 10/200 
  protocol ip 209.165.202.159 broadcast
  encapsulation aal5snap
 !
 no fair-queue
!
interface Ethernet0/1
 no ip address
 shutdown
!
ip classless
ip route 209.165.202.128 255.255.255.224 Ethernet0/0
no ip http server
!
!
snmp-server engineID local 000000090200003080477F20
snmp-server manager
!
voice-port 1/0:0
 local-alerting
 timeouts wait-release 3
 connection trunk 3001 
!
voice-port 1/0:1
 local-alerting
 timeouts wait-release 3
 connection trunk 3002 
.
.
.
voice-port 1/0:23
 local-alerting
 timeouts wait-release 3
 connection trunk 3024 
 shutdown
!
dial-peer cor custom
!
dial-peer voice 3001 voatm
 destination-pattern 3001
 called-number 4001
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 31
 codec aal2-profile ITUT 1 g711ulaw
 no vad
!
dial-peer voice 3002 voatm
 destination-pattern 3002
 called-number 4002
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 32
 codec aal2-profile custom 100 g726r32
 no vad
!
dial-peer voice 3003 voatm
 destination-pattern 3003
 called-number 4003
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 33
 codec aal2-profile ITUT 7 g729abr8
 no vad
.
.
.
dial-peer voice 3024 voatm
 destination-pattern 3024
 called-number 3024
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 54
 codec aal2-profile ITUT 7 g729abr8
 no vad
!
dial-peer voice 1 pots
 destination-pattern 4001
 port 1/0:0
!
dial-peer voice 2 pots
 destination-pattern 4002
 port 1/0:1
.
.
.
dial-peer voice 24 pots
 destination-pattern 4024
 port 1/0:23
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

Configuration in CO Mode Example

The following example shows a G.SHDSL configuration of VoATM over AAL2, operating in central office (CO) mode, on a Cisco 2600 series router. This router in CO mode can be linked to another router that is configured to operate in CPE mode.

Router#
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname host2
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
ip host host2 225.255.255.224
!
no mgcp timer receive-rtcp
call rsvp-sync
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1 type e&m-wink-start
 ds0-group 1 timeslots 2 type e&m-wink-start
.
.
.
ds0-group 23 timeslots 24 type e&m-wink-start
!
controller T1 1/1
 framing esf
 linecode b8zs
!
interface Ethernet0/0
 ip address 209.165.202.128 255.255.255.224
 half-duplex
 no cdp enable
!
interface Serial0/0
 no ip address
 shutdown
!
interface ATM0/1
 ip address 209.165.201.1 255.255.255.224
 dsl operating-mode gshdsl symmetric annex A
 dsl equipment-type co
 dsl linerate auto
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 pvc 10/100 
  vbr-rt 672 672 512
  encapsulation aal2
 !
 pvc 10/200 
  protocol ip 209.165.202.159 broadcast
  encapsulation aal5snap
 !
 no fair-queue
!
interface Ethernet0/1
 no ip address
 shutdown
!
ip classless
ip route 209.165.202.128 255.255.255.224 Ethernet0/0
no ip http server
!
!
snmp-server engineID local 000000090200003080477F20
snmp-server manager
!
voice-port 1/0:0
 local-alerting
 timeouts wait-release 3
 connection trunk 3001 
!
voice-port 1/0:1
 local-alerting
 timeouts wait-release 3
 connection trunk 3002 
.
.
.
voice-port 1/0:23
 local-alerting
 timeouts wait-release 3
 connection trunk 3024 
 shutdown
!
dial-peer cor custom
!
dial-peer voice 3001 voatm
 destination-pattern 3001
 called-number 4001
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 31
 codec aal2-profile ITUT 1 g711ulaw
 no vad
!
dial-peer voice 3002 voatm
 destination-pattern 3002
 called-number 4002
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 32
 codec aal2-profile custom 100 g726r32
 no vad
!
dial-peer voice 3003 voatm
 destination-pattern 3003
 called-number 4003
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 33
 codec aal2-profile ITUT 7 g729abr8
 no vad
.
.
.
dial-peer voice 3024 voatm
 destination-pattern 3024
 called-number 3024
 session protocol aal2-trunk
 session target ATM0/1 pvc 10/100 54
 codec aal2-profile ITUT 7 g729abr8
 no vad
!
dial-peer voice 1 pots
 destination-pattern 4001
 port 1/0:0
!
dial-peer voice 2 pots
 destination-pattern 4002
 port 1/0:1
.
.
.
dial-peer voice 24 pots
 destination-pattern 4024
 port 1/0:23
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 login
!
no scheduler allocate
end

Command Reference

This section documents the changed Cisco IOS commands for configuring the ADSL WAN Interface Card feature. All other commands used to configure the ADSL WAN Interface Card feature are documented in the Cisco IOS Release 12.2 command reference publications.

Reference information is provided in this section for configuring the following Cisco IOS commands on the Cisco 2600 series routers:

Modified Commands

dsl equipment-type

dsl linerate

dsl operating-mode (G.SHDSL)

dsl equipment-type

To configure the DSL ATM interface to function as central office equipment or customer premises equipment, use the dsl equipment-type command in ATM interface mode. To restore the default equipment type, use the no form of this command.

dsl equipment-type {co | cp }

no dsl equipment-type

Syntax Description

co

Configures the DSL ATM interface to function as central office equipment.

cpe

Configures the DSL ATM interface to function as customer premises equipment.


Defaults

The DSL ATM interface functions as customer premises equipment.

Command Modes

ATM interface.

Command History

Release
Modification

12.2(4)XL

This command was integrated into Cisco IOS Release 12.2(4)XL on the G.SHDSL WIC on the Cisco 2600 series routers.


Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you enter this command.

The ATM interface must be in the shutdown state before you enter this command.

Examples

The following example shows how to configure DSL ATM interface 1/1 to function as central office equipment.

Router# configure terminal 

Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)# interface atm 1/1 
Router(config-if)# dsl equipment-type co
Router(config-if)# end 
Router# clear interface atm 0/1
Router#

Related Commands

Command
Description

dsl linerate

Specifies a line rate for the DSL ATM interface.

dsl operating-mode (G.SHDSL)

Specifies an operating mode of the DSL ATM interface.


dsl linerate

To specify a line rate for the DSL ATM interface, use the dsl linerate command in ATM interface mode. To restore the default line rate, use the no form of this command.

dsl linerate {kbps | auto}

no dsl linerate

Syntax Description

kbps

Specifies a line rate in kilobits per second for the DSL ATM interface.

Allowable entries are 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, and 2312.

auto

Configures the DSL ATM interface to automatically train for an optimal line rate by negotiating with the far-end DSLAM or WIC.


Defaults

The DSL ATM interface automatically synchronizes its line rate with the far-end DSLAM or WIC.

Command Modes

ATM interface.

Command History

Release
Modification

12.2(4)XL

This command was integrated into Cisco IOS Release 12.2(4)XL on the G.SHDSL WIC on the Cisco 2600 series routers.


Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you enter this command.

The ATM interface must be in the shutdown state before you enter this command.

Examples

The following example shows how to configure DSL ATM interface 0/1 to operate at a line rate of 1040 kbps.

Router# configure terminal 

Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)# interface atm 0/1 
Router(config-if)# dsl linerate 1040
Router(config-if)# end 
Router# clear interface atm 0/1
Router#

Related Commands

Command
Description

dsl equipment-type

Configures the DSL ATM interface to function as central office equipment or customer premises equipment.

dsl operating-mode (G.SHDSL)

Specifies an operating mode of the DSL ATM interface.


dsl operating-mode (G.SHDSL)

To specify an operating mode of the digital subscriber line for an ATM interface, use the dsl operating-mode ATM interface command. To restore the default operating mode, use the no form of this command.

dsl operating-mode gshdsl symmetric annex {A | B}

no dsl operating-mode

Syntax Description

gshdsl

Configures the DSL ATM interface to operate in multirate high-speed mode per ITU G.991.2.

symmetric

Configures the DSL ATM interface to operate in symmetrical mode per ITU G.991.2.

annex{A | B}

Specifies the regional operating parameters. Enter A for North America and B for Europe. The default is A.

A

Configures the regional operating parameters for North America. This value is the default.

B

Configures the regional operating parameters for Europe.


Defaults

The default operating mode is gshdsl symmetric annex A.

Command Modes

ATM interface

Command History

Release
Modification

12.1(3)XJ

This command was introduced on the Cisco 1700 series routers.

12.2(2)T

This command was integrated into Cisco IOS Release 12.2(2)T for the Cisco 1700 series routers.

12.2(4)XL

This command was integrated into Cisco IOS Release 12.2(4)XL for the G.SHDSL WIC on the Cisco 2600 series routers.


Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you enter this command.

The ATM interface must be in the shutdown state before you enter this command.

Examples

The following example shows how to configure DSL ATM interface 0/0 to operate in G.SHDSL mode:

Router# configure terminal 

Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)# interface atm 0/0 
Router(config-if)# dsl operating-mode gshdsl symmetric annex A
Router(config-if)# end 
Router# clear interface atm 0/1
Router#

Related Commands

Command
Description

dsl equipment-type

Configures the DSL ATM interface to function as central office equipment or customer premises equipment.

dsl linerate

Specifies a line rate for the DSL ATM interface.


Glossary

ABR—available bit rate.

ADSL—asymmetric digital subscriber line (ADSL) available through several telecommunications carriers to accommodate the need for increased bandwidth for Internet access and telecommuting applications.

ATM—Asynchronous Transfer Mode. International standard for cell relay in which multiple service types (such as voice, video, or data) are conveyed in fixed-length (53-byte) cells. Fixed-length cells allow cell processing to occur in hardware, thereby reducing transit delays. ATM is designed to take advantage of high-speed transmission media such as E3, SONET, and T3.

CLI—command-line interface.

CO—Central office, or local exchange (local switch), which terminates individual local telephone subscriber lines for switching, and connects to the public network. Known as a class 5 switch office. For example, 5ESS by Lucent and DMS 100 by Nortel.

CPE—customer premise equipment, including devices such as channel service units (CSUs)/data service units (DSUs), modems, and ISDN terminal adapters, required to provide an electromagnetic termination for wide-area network circuits before connecting to the router or access server. This equipment was historically provided by the telephone company, but is now typically provided by the customer in North American markets.

DSL—digital subscriber line available through several telecommunications carriers to accommodate the need for increased bandwidth for Internet access and telecommuting applications.

FXO—foreign exchange office. A FXO interface connects to a central office.

FXS—foreign exchange station: A FXS interface connects directly to a standard telephone, supplying ring voltage, dial tone, etc.

G.SHDSL—Multirate Symmetrical High-Speed Digital Subscriber Line

IAD—integrated access device. A CPE device used to combine services from various sources onto a common platform for transmission on a common transport span. Typically, an IAD combines various voice and data services such as circuit-based services like traditional POTS and packet-switched services such as frame relay or ATM.

PVC—permanent virtual circuit.