Guest

Cisco IOS Software Releases 12.2 Special and Early Deployments

Voice and Quality of Service Features for ADSL on Cisco 2600 and 3600 Series Routers

  • Viewing Options

  • PDF (297.0 KB)
  • Feedback
Voice and Quality of Service Features for ADSL on Cisco 2600 and 3600 Series Routers

Table Of Contents

Voice and Quality of Service Features for ADSL on Cisco 2600 and 3600 Series Routers

Feature Overview

Classification and Marking

Class-Based Packet Marking with DSCP

Committed Access Rate

Dial-Peer DSCP and IP Precedence Marking

Queuing and Scheduling

Class-Based Weighted Fair Queuing

Low Latency Queuing

Driver Per-VC Queuing

Congestion Avoidance

Class-Based WRED with DSCP (egress)

Policing and Traffic Shaping

Class-Based Policing

Per-ATM VC Shaping for VBR-NRT

Link Latency

Selectable Transmission Ring

Other (IP QoS)

Local Policy Routing

Policy-Based Routing

IP QoS Mapping to ATM CoS

Access Lists

Additional Features Supported in Release 12.2(2)XK

Multiple PVC Support

RFC1483 Routing

H.323 VoIP

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring the Tx Ring Limit

Verifying

Configuration Examples

Differentiated Data Services Example

Verifying the Differentiated Data Services Configuration

VoIP and Data Example

Command Reference


Voice and Quality of Service Features for ADSL on Cisco 2600 and 3600 Series Routers


Feature History
Release
Modification

12.2(2)XK

Voice and quality of service features for ADSL were introduced for Cisco 2600 and 3600 series routers.


This document describes the voice and quality of service (QoS) features for asymmetric digital subscriber lines (ADSL) on Cisco 2600 and 3600 series routers in Cisco IOS Release 12.2(2)XK.

For information about QoS features on Cisco 1700 series routers, refer to the following document:

Cisco IOS Software Release 12.2(2)XQ1

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuration Examples

Command Reference

Feature Overview

Cisco 2600 and 3600 series routers with an ADSL WAN interface card support the integration of voice and data over the same ADSL circuit using Voice over IP (VoIP) and Voice over ATM (VoATM). QoS features make it possible to effectively combine voice and data traffic in the same WAN connection without sacrificing quality and reliability. Service providers can increase revenue by building differentiated service options based on premium, standard, or best-effort service classes.

The following voice and QoS features are supported in the 12.2(2)XK release:


Note To configure these voice and QoS features, you must first install and configure the ADSL WAN interface card on your Cisco 2600 or 3600 router. Refer to the installation and configuration instructions in the following document:

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T


Classification and Marking

Class-Based Packet Marking with DSCP

Committed Access Rate

Dial-Peer DSCP and IP Precedence Marking

Queuing and Scheduling

Class-Based Weighted Fair Queuing

Low Latency Queuing

Driver Per-VC Queuing

Congestion Avoidance

Class-Based WRED with DSCP (egress)

Policing and Traffic Shaping

Class-Based Policing

Per-ATM VC Shaping for VBR-NRT

Link Latency

Selectable Transmission Ring

Other (IP QoS)

Local Policy Routing

Policy-Based Routing

IP QoS Mapping to ATM CoS

Access Lists

Additional Features Supported in Release 12.2(2)XK

Multiple PVC Support

RFC1483 Routing

H.323 VoIP

Classification and Marking

The following existing Cisco IOS classification and marking features are now supported on ADSL:

Class-Based Packet Marking with DSCP

Committed Access Rate

Dial-Peer DSCP and IP Precedence Marking

Class-Based Packet Marking with DSCP

For information about class-based packet marking with differentiated services code point (DSCP), refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Committed Access Rate

For information about committed access rate (CAR), refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release12.2

Dial-Peer DSCP and IP Precedence Marking

For information about dial-peer DSCPs and IP precedence marking, refer to the following document:

The chapter "Quality of Service Overview" in Cisco IOS Quality of Service Solutions

Queuing and Scheduling

The following existing Cisco IOS queuing and scheduling features are now supported on ADSL:

Class-Based Weighted Fair Queuing

Low Latency Queuing

Driver Per-VC Queuing

Class-Based Weighted Fair Queuing

For information about class-based weighted fair queuing (CBWFQ), refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Low Latency Queuing

For information about low latency queuing (LLQ), refer to the following documents:

The chapter "Congestion Management Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

The chapter "Quality of Service for Voice over IP" in Cisco IOS Quality of Service Solutions


Note Setting the tx ring works in conjunction with low latency queuing. (For more information, see the section "Selectable Transmission Ring.")


Driver Per-VC Queuing

In Cisco IOS Release 12.2(2)XK, per-virtual circuit (per-VC) queuing is supported on ADSL interfaces at the driver level, similar to VC-queuing features on other ATM interfaces. This feature underlies many of the IOS QoS queuing features, such as LLQ.

For more information about per-VC queuing, refer to the following documents:

Understanding Weighted Fair Queuing on ATM

Per-VC Class-Based, Weighted Fair Queuing (Per-VC CBWFQ) on the Cisco 7200, 3600, and 2600 Routers

Congestion Avoidance

The following existing Cisco IOS congestion avoidance feature is now supported on ADSL:

Class-Based WRED with DSCP (egress)

Class-Based WRED with DSCP (egress)

Weighted random early detection (WRED) is supported in Release 12.2(2)XK.

For more information about WRED, refer to the following documents:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2

DiffServ Compliant Weighted Random Error Detection

Policing and Traffic Shaping

The following existing Cisco IOS policing and shaping features are now supported on ADSL:

Class-Based Policing

Per-ATM VC Shaping for VBR-NRT

Class-Based Policing

For information about traffic classes and traffic policies, refer to the following document:

The chapter "Configuring Traffic Policing" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Per-ATM VC Shaping for VBR-NRT

For information about per-ATM VC shaping for variable bit rate-nonreal time (VBR-NRT), refer to the following document:

Understanding the VBR-nrt Service Category and Traffic Shaping for ATM VCs

Link Latency

The following existing Cisco IOS link latency feature is now supported on ADSL:

Selectable Transmission Ring

Selectable Transmission Ring

The transmission ring (tx ring) is the first-in, first-out (FIFO) buffer used to hold frames before transmission at the digital subscriber line (DSL) driver level. The tx ring defines the maximum number of packets that can wait for transmission at Layer 2.

The tx ring complements the ability of LLQ to minimize jitter and latency of voice packets. For maximum voice quality, a low tx ring setting should be used. For maximum data throughput, a high tx ring setting should be used.

You can configure the size of the tx ring for each permanent virtual circuit (PVC). The default value is 24. The value can be changed to 3. (The only permitted values are 24 and 3.) A tx ring setting of 3 is required for latency-critical traffic. For example, when the tx ring limit is configured as 3 and LLQ is configured on the PVC, the worst case delay for a voice packet is the time required to transmit three data packets. When the buffering is reduced by configuring the tx ring limit, the delay experienced by voice packets is reduced by a combination of the tx ring and LLQ mechanism.


Note The size of the tx ring buffer is measured in packets, not bits.


Other (IP QoS)

The following IP QoS features are now supported on ADSL:

Local Policy Routing

Policy-Based Routing

IP QoS Mapping to ATM CoS

Access Lists

Local Policy Routing

For information about local policy routing (LPR), refer to the following documents:

The chapter "Configuring IP Routing Protocol—Independent Features" in the Cisco IOS IP Configuration Guide, Release 12.2

The chapter "Configuring IP Routing Protocols" in the Router Products Configuration Guide

Policy-Based Routing

For information about policy-based routing (PBR), refer to the following document:

The chapter "Quality of Service Overview" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

IP QoS Mapping to ATM CoS

For more information about IP QoS mapping to ATM class of service (CoS), refer to the following document:

The chapter "Configuring IP to ATM Class of Service" in the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Access Lists

For information about configuring access lists, refer to the following document:

The chapter "Configuring IP Services" in the Cisco IOS IP Configuration Guide, Release 12.2

Additional Features Supported in Release 12.2(2)XK

The following existing Cisco IOS features are now supported on ADSL:

Multiple PVC Support

RFC1483 Routing

H.323 VoIP

Multiple PVC Support

For information about PVCs, refer to the following documents:

The chapter "Wide-Area Networking Overview" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

The chapter "Configuring ATM" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

For caveat information for the Cisco 2600 and 3600 series routers, refer to the following documents:

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XK

RFC1483 Routing

For information about ATM and ATM adaptation layers (AALs), refer to the following document:

The chapter "Wide-Area Networking Overview" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

For information regarding AAL5 Subnetwork Access Protocol (AAL5SNAP) encapsulations, refer to the following document:

The chapter "Configuring ATM" in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

H.323 VoIP

For information about Cisco H.323 VoIP features, refer to the following documents:

The chapter "Configuring Voice over IP" in the Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

The chapter "H.323 Applications" in the Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

Benefits

QoS provides improved and more predictable network service for ADSL by

Supporting dedicated bandwidth.

Improving loss characteristics.

Avoiding and managing network congestion.

Shaping network traffic.

Setting traffic priorities across the network.

Restrictions

Analog and BRI voice on the NM-1V/2V card are not supported over VoATM in AAL2.

Refer to the following documents for caveat information for multiple PVCs on Cisco 2600 and 3600 series routers:

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XK

Multilink Point-to-Point Protocol link fragmentation with interleaving (MLP with LFI) is not supported in this release.

Related Documents

For information about configuring the ADSL WAN interface card, refer to the following document:

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T

For information about QoS features on Cisco 1700 series routers, refer to the following document:

Cisco IOS Software Release 12.2(2)XQ1

For information about voice configuration, refer to the following documents:

Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

Cisco IOS Voice, Video, and Fax Command Reference, Release 12.2

For information about configuring IP, refer to the following documents:

Cisco IOS IP Configuration Guide, Release 12.2

Cisco IOS IP Command Reference, Release 12.2 (there are three volumes)

For information about configuring ATM, refer to the following documents:

Cisco IOS Wide-Area Networking Configuration Guide, Release 12.2

Cisco IOS Wide-Area Networking Command Reference, Release 12.2

For information about configuring QoS, refer to the following documents:

Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2

For information about dial-peer DSCPs and IP precedence marking, refer to the following document:

The chapter "Quality of Service for Voice over IP" in Cisco IOS Quality of Service Solutions

For information about WRED, refer to the following document:

DiffServ Compliant Weighted Random Error Detection, Release 12.1(5)T

For information about per-ATM VC shaping for VBR-NRT, refer to the following document:

Understanding the VBR-nrt Service Category and Traffic Shaping for ATM VCs

For information about local policy routing, refer to the following document:

The chapter "Configuring IP Routing Protocols" in the Router Products Configuration Guide

For caveat information for the Cisco 2600 and 3600 series routers, refer to the following documents:

Release Notes for Cisco 2600 Series for Cisco IOS Release 12.2 XK

Release Notes for Cisco 3600 Series for Cisco IOS Release 12.2 XL

Supported Platforms

Cisco 2600 series routers

Cisco 3600 series routers

Determining Platform Support Through Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Feature Navigator. Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image.

To access Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn


Note As of Cisco IOS Release 12.2(2)XK, Feature Navigator does not support features included in this limited-lifetime release.


Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFCs

No new or modified RFCs are supported by this feature.

Prerequisites

To configure these voice and QoS features, you must first install and configure the ADSL WAN interface card on your Cisco 2600 or 3600 router. Refer to the installation and configuration instructions in the following document:

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T

Configuration Tasks

See the following section to configure the tx ring limit.

Configuring the Tx Ring Limit (required)


Note For information about configuring the ADSL WAN interface card, refer to the following document:

1-Port ADSL WAN Interface Card for Cisco 2600 Series and 3600 Series Routers, Release 12.2(4)T


Configuring the Tx Ring Limit

To configure the tx ring limit, use the following commands beginning in global configuration mode.

 
Command
Purpose

Step 1 

Router (config)# interface atm 
slot/port

Configures an ATM interface type and enters interface configuration mode.

The arguments are as follows:

slot—Specifies the backplane slot number on your router. The value ranges from 0 to 4, depending on what router you are configuring. Refer to your router hardware documentation.

port—ATM port number on a Cisco 2600 or 3600 series router, indicating the T1 link that you are configuring. Enter a value from 0 to 3 or from 0 to 7, depending on whether the network module has four ports or eight ports.

Step 2 

Router (config-if)# pvc [name] vpi/vci 
[ces | ilmi | qsaal | smds]

Creates or assigns a name to an ATM permanent virtual circuit (PVC), specifies the encapsulation type on an ATM PVC, and enters interface-ATM-VC configuration mode.

The keywords and arguments are as follows:

name—(Optional) Specifies the name of the PVC or map. The name can be a maximum of 16 characters.

vpi/—Specifies the ATM network virtual path identifier (VPI) for this PVC. The absence of the "/" and a VPI value defaults the VPI value to 0.

On Cisco 2600 and 3600 series routers using inverse multiplexing over ATM (IMA), the ranges are 0 to 15, 64 to 79, 128 to 143, and 192 to 207.

vci—Specifies the ATM network virtual channel identifier (VCI) for this PVC. This value ranges from 0 to 1 less than the maximum value set for this interface by the atm vc-per-vp command. Typically, lower values 0 to 31 are reserved for specific traffic (for example, F4 Operation, Administration, and Maintenance [OAM], switched virtual circuit [SVC] signaling, and Integrated Local Management Interface [ILMI]) and should not be used.

The VCI is a 16-bit field in the header of the ATM cell. The VCI value is unique only on a single link, not throughout the ATM network, because it has local significance only.

The vpi and vci arguments cannot both be set to 0; if one is 0, the other cannot be 0.

ces—(Optional) circuit emulation service encapsulation. This keyword is available on the OC-3/STM-1 ATM Circuit Emulation Service network module only.

 

ilmi—(Optional) Used to set up communication with the ILMI; the associated vpi and vci values ordinarily are 0 and 16, respectively.

qsaal—(Optional) A signaling-type PVC used for setting up or tearing down SVCs; the associated vpi and vci values ordinarily are 0 and 5, respectively.

smds—(Optional) Specifies encapsulation for Switched Multimegabit Data Service (SMDS) networks. If you are configuring an ATM PVC on the ATM Interface Processor (AIP), you must configure AAL3/4SMDS using the atm aal aal3/4 command before specifying SMDS encapsulation. If you are configuring an ATM network processor module (NPM), the atm aal aal3/4 command is not required. SMDS encapsulation is not supported on the ATM port adapter.

Step 3 

Router (config-if-atm-vc)# 
tx-ring-limit ring-limit

Limits the number of packets that can be used on a transmission ring on the WIC-180SL. The ring-limit argument specifies the maximum number of allowable packets that can be placed on the transmission ring.

Note The default value is 24. The value can be changed to 3. (The only permitted values are 24 and 3.)

Verifying

The tx ring limit has been set in the following VoIP and data configuration examples:

The following show policy-map interface command output from a Cisco 2600 router displays a service-policy setup:

Router# show policy-map interface atm0/0

ATM0/0:VC 0/201 -

Service-policy output:VOICE-160-DATA-480

Class-map:class-default (match-any)
 27234 packets, 41109865 bytes
 30 second offered rate 7000 bps, drop rate 3000 bps
 Match:any 
 Weighted Fair Queueing
 Queue:Conversation 73 
 Bandwidth 320 (kbps) Max Threshold 64 (packets)
 (pkts matched/bytes matched) 27231/41105329
 (depth/total drops/no-buffer drops) 0/14711/0

For
Class-map:class-default (match-any)
 113187 packets, 140760375 bytes
 30 second offered rate 1205000 bps, drop rate 787000 bps
 Match:any

The following show queue command output from a Cisco 2600 router displays the flow of traffic currently being transported over an ATM interface:

Router# show queue atm 0/0

Interface ATM0/0 VC 0/201
Queueing strategy:weighted fair
Output queue:70/512/64/70462 (size/max total/threshold/drops)
 Conversations 3/6/64 (active/max active/max total)
 Reserved Conversations 0/0 (allocated/max allocated)
 Available Bandwidth 320 kilobits/sec

(depth/weight/total drops/no-buffer drops/interleaves) 3/0/0/0/0
Conversation 72, linktype:ip, length:72
source:192.168.1.2, destination:192.168.1.1, id:0xC77E, ttl:254,
TOS:160 prot:17, source port 19406, destination port 16406

(depth/weight/total drops/no-buffer drops/interleaves) 1/32384/0/0/0
Conversation 23, linktype:ip, length:196
source:192.168.1.2, destination:192.168.1.1, id:0x0000, ttl:255,
TOS:0 prot:17, source port 18653, destination port 18691

(depth/weight/total drops/no-buffer drops/interleaves) 64/32384/65793/0/0
Conversation 59, linktype:ip, length:1502
source:10.1.1.205, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:0 prot:17, source port 500, destination port 500

The following show queueing interface command output from a Cisco 2600 router displays the queuing configuration of an ATM interface:

Router# show queueing interface atm0/0

Interface ATM0/0 VC 0/201
Queueing strategy:weighted fair
Output queue:66/512/64/61642 (size/max total/threshold/drops)
 Conversations  2/6/64 (active/max active/max total)
 Reserved Conversations 0/0 (allocated/max allocated)
 Available Bandwidth 320 kilobits/sec

The following show interfaces atm command output from a Cisco 2600 router displays statistics for an ATM interface:

Router# show interfaces atm0/0

ATM0/0 is up, line protocol is up
 Hardware is DSLSAR (with Alcatel ADSL Module)
 Internet address is 192.168.1.2/24
 MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec,
  reliability 255/255, txload 166/255, rxload 21/255
 Encapsulation ATM, loopback not set
 Encapsulation(s):AAL5  AAL2, PVC mode
 23 maximum active VCs, 256 VCs per VP, 2 current VCCs
 VC idle disconnect time:300 seconds
 Last input 00:00:02, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:62360
 Queueing strategy:None
 30 second input rate 66000 bits/sec, 113 packets/sec
 30 second output rate 523000 bits/sec, 229 packets/sec
  1603630 packets input, 403845485 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  2680554 packets output, 518308502 bytes, 0 underruns
  0 output errors, 0 collisions, 4 interface resets
  buffer failures, 0 output buffers swapped out

The following show atm vc command output from a Cisco 2600 router displays information about an ATM virtual circuit:

Router# show atm vc

           VCD /                                      Peak  Avg/Min Burst
Interface  Name         VPI VCI   Type   Encaps   SC  Kbps  Kbps    Cells Sts
0/0        1            0   201   PVC    SNAP     VBR 640   640     0     UP
VC not configured on interface ATM0/1

The following show atm vc command output from a Cisco 2600 router displays detailed information about a virtual circuit descriptor (VCD):

Router# show atm vc 1

ATM0/0:VCD:1, VPI:0, VCI:201
VBR-NRT, PeakRate:640, Average Rate:640, Burst Cells:0
AAL5-LLC/SNAP, etype:0x0, Flags:0x2000820, VCmode:0x0
OAM frequency:10 second(s)
InARP frequency:15 minutes(s)
InPkts:1606861, OutPkts:2682709, InBytes:404080341, OutBytes:519701804
InPRoc:108900, OutPRoc:109133, Broadcasts:1
InFast:1497961, OutFast:0, InAS:0, OutAS:0
InPktDrops:0, OutPktDrops:64078/0/64078 (holdq/outputq/total)
CrcErrors:0, SarTimeOuts:0, OverSizedSDUs:0, LengthViolation:0, CPIErrors:0
OAM cells received:4765
OAM cells sent:4767
Status:UP
VC 1 doesn't exist on interface ATM0/1

Configuration Examples

This section provides the following configuration examples:

Differentiated Data Services Example

VoIP and Data Example

Differentiated Data Services Example

Following is an example showing how CBWFQ, CAR, and WRED can be applied in the same configuration to provide differentiated services using QoS. The sample is from a Cisco 2600 router.

Building configuration...

Current configuration :2603 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2600-1
!
memory-size iomem 20
!
ip subnet-zero
!
ip cef
!
class-map match-all GOLD
 match access-group 1
class-map match-all SILVER
 match access-group 2
!
policy-map GOLD-160-DATA-PACK-640
 class GOLD
  bandwidth 160
  random-detect dscp-based
  random-detect exponential-weighting-constant 3
  random-detect dscp 16   2     4     10
  random-detect dscp 32   4     12    10
 class SILVER
  bandwidth 320
  random-detect dscp-based
  random-detect exponential-weighting-constant 3
  random-detect dscp 0   30    60    10
  set ip dscp 0
!
interface ATM0/0
 no ip address
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
 ip address 192.168.1.2 255.255.255.0
 pvc 0/201
  protocol ip 192.168.1.1 broadcast
  vbr-nrt 640 640
  tx-ring-limit 3
  service-policy output GOLD-160-DATA-PACK-640
!
interface Ethernet0/0
 ip address 1.3.214.9 255.255.0.0
 half-duplex
!
interface Ethernet0/1
 ip address 10.1.1.1 255.255.255.0
 rate-limit input access-group 1 160000 4470 4470 conform-action set-dscp-transmit 32 
exceed-action continue
 rate-limit input access-group 1 80000 4470 4470 conform-action set-dscp-transmit 16 
exceed-action drop
 half-duplex
!
ip classless
ip route 10.10.11.200 255.255.255.255 192.168.3.1
ip route 223.255.254.254 255.255.255.255 1.3.0.1
ip http server
!
access-list 1 permit 10.1.1.201
access-list 2 permit 10.1.1.202
access-list 3 permit 10.1.1.203
access-list 100 permit udp any any precedence critical
!
snmp-server manager
call rsvp-sync
alias exec s sh run
alias exec c conf t
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!

Verifying the Differentiated Data Services Configuration

The following show policy-map interface command output is for the LLQ, CAR, and WRED configuration.

Router# show policy-map interface atm0/0.1

ATM0/0.1:VC 0/201 -

 Service-policy output:GOLD-160-DATA-PACK-640

Class-map:GOLD (match-all)
 22738 packets, 34379856 bytes
 30 second offered rate 239000 bps, drop rate 50000 bps
 Match:access-group 1
 Weighted Fair Queueing
  Output Queue:Conversation 73
  Bandwidth 160 (kbps)
  (pkts matched/bytes matched) 22738/34379856
  (depth/total drops/no-buffer drops) 4/4739/0
   exponential weight:3
   mean queue depth:4

    dscp       Random drop     Tail drop        Minimum   Maximum     Mark
                pkts/bytes      pkts/bytes      threshold threshold probability
     af11        0/0              0/0             32        40       1/10
     af12        0/0              0/0             28        40       1/10
     af13        0/0              0/0             24        40       1/10
     af21        0/0              0/0             32        40       1/10
     af22        0/0              0/0             28        40       1/10
     af23        0/0              0/0             24        40       1/10
     af31        0/0              0/0             32        40       1/10
     af32        0/0              0/0             28        40       1/10
     af33        0/0              0/0             24        40       1/10
     af41        0/0              0/0             32        40       1/10
     af42        0/0              0/0             28        40       1/10
     af43        0/0              0/0             24        40       1/10
     cs1         0/0              0/0             22        40       1/10
     cs2       332/501984      3907/5907384        2         4       1/10
     cs3         0/0              0/0             26        40       1/10
     cs4       506/765072         0/0              4        12       1/10
     cs5         0/0              0/0             30        40       1/10
     cs6         0/0              0/0             32        40       1/10
     cs7         0/0              0/0             34        40       1/10
     ef          0/0              0/0             36        40       1/10
     rsvp        0/0              0/0             36        40       1/10
     default     0/0              0/0             20        40       1/10

Class-map:SILVER (match-all)
 114748 packets, 173498976 bytes
 30 second offered rate 1212000 bps, drop rate 832000 bps
 Match:access-group 2
 Weighted Fair Queueing
  Output Queue:Conversation 74
  Bandwidth 320 (kbps)
  (pkts matched/bytes matched) 115126/174070512
  (depth/total drops/no-buffer drops) 61/79012/0
   exponential weight:3
   mean queue depth:61

    dscp       Random drop     Tail drop        Minimum   Maximum     Mark
                pkts/bytes      pkts/bytes      threshold threshold probability
     af11        0/0              0/0             32        40       1/10
     af12        0/0              0/0             28        40       1/10
     af13        0/0              0/0             24        40       1/10
     af21        0/0              0/0             32        40       1/10
     af22        0/0              0/0             28        40       1/10
     af23        0/0              0/0             24        40       1/10
     af31        0/0              0/0             32        40       1/10
     af32        0/0              0/0             28        40       1/10
     af33        0/0              0/0             24        40       1/10
     af41        0/0              0/0             32        40       1/10
     af42        0/0              0/0             28        40       1/10
     af43        0/0              0/0             24        40       1/10
     cs1         0/0              0/0             22        40       1/10
     cs2         0/0              0/0             24        40       1/10
     cs3         0/0              0/0             26        40       1/10
     cs4         0/0              0/0             28        40       1/10
     cs5         0/0              0/0             30        40       1/10
     cs6         0/0              0/0             32        40       1/10
     cs7         0/0              0/0             34        40       1/10
     ef          0/0              0/0             36        40       1/10
     rsvp        0/0              0/0             36        60       1/10
     default  9096/13753152   70065/105938280     30        60       1/10

 QoS Set
  ip dscp 0
   Packets marked 115344

Class-map:class-default (match-any)
 114747 packets, 173497464 bytes
 30 second offered rate 1212000 bps, drop rate 1209000 bps
 Match:any

The following show interfaces command output is from a Cisco 2600 router:

Router# show interfaces e0/1 rate-limit

Ethernet0/1
 Input
  matches:access-group 1
   params: 160000 bps, 4470 limit, 4470 extended limit
   conformed 15673 packets, 23728922 bytes; action:set-dscp-transmit 32
   exceeded 102965 packets, 155889010 bytes; action:continue
   last packet:0ms ago, current burst:4146 bytes
   last cleared 00:19:46 ago, conformed 160000 bps, exceeded 1051000 bps
  matches:access-group 1
   params: 80000 bps, 4470 limit, 4470 extended limit
   conformed 7836 packets, 11863704 bytes; action:set-dscp-transmit 16
   exceeded 95130 packets, 144026820 bytes; action:drop
   last packet:4ms ago, current burst:3708 bytes
   last cleared 00:19:46 ago, conformed 79000 bps, exceeded 971000 bps

The following show interfaces atm command output is from a Cisco 2600 router:

Router# show interfaces atm0/0

ATM0/0 is up, line protocol is up
 Hardware is DSLSAR (with Alcatel ADSL Module)
 MTU 4470 bytes, sub MTU 4470, BW 800 Kbit, DLY 2560 usec,
  reliability 255/255, txload 181/255, rxload 1/255
 Encapsulation ATM, loopback not set
 Encapsulation(s):AAL5  AAL2, PVC mode
 23 maximum active VCs, 256 VCs per VP, 2 current VCCs
 VC idle disconnect time:300 seconds
 Last input 00:33:22, output 00:00:00, output hang never
 Last clearing of "show interface" counters 00:20:09
 Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:208908
 Queueing strategy:None
 30 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 569000 bits/sec, 48 packets/sec
  0 packets input, 0 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  57315 packets output, 86075268 bytes, 0 underruns
  0 output errors, 0 collisions, 0 interface resets
  0 output buffer failures, 0 output buffers swapped out

The following show queue command output is from a Cisco 2600 router:

Router# show queue atm0/0

Interface ATM0/0 VC 0/201
Queueing strategy:weighted fair
Output queue:130/512/64/214301 (size/max total/threshold/drops)
 Conversations  3/3/64 (active/max active/max total)
 Reserved Conversations 2/2 (allocated/max allocated)
 Available Bandwidth 0 kilobits/sec

(depth/weight/total drops/no-buffer drops/random/tail/interleaves) 5/228/5124/0/0/0/0
Conversation 73, linktype:ip, length:1512
source:10.1.1.201, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:128 prot:17, source port 100, destination port 100

(depth/weight/total drops/no-buffer drops/random/tail/interleaves) 
61/114/85189/0/9843/75346/0
Conversation 74, linktype:ip, length:1512
source:10.1.1.202, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:0 prot:17, source port 200, destination port 200

(depth/weight/total drops/no-buffer drops/interleaves) 64/32384/123990/0/0
Conversation 41, linktype:ip, length:1512
source:10.1.1.203, destination:10.10.11.200, id:0x0000, ttl:59,
TOS:0 prot:17, source port 300, destination port 300

VoIP and Data Example

The following is sample output from a Cisco 2611 router. In this example, the customer premises equipment (CPE) is restricted to only a single PVC. Voice and data are sent over a single VC. The tx-ring-limit command and LLQ are used to give preferential treatment for voice traffic.

Building configuration...

Current configuration :1861 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CPE-2611-1
!
voice-card 1
 dspfarm
!
ip subnet-zero
!
ip cef
!
class-map match-all VOICE
 match access-group 100
!
policy-map VOICE-160-DATA-480-PACK
 class VOICE
  priority 160
 class class-default
  bandwidth 320
!
controller T1 1/0
 framing esf
 linecode b8zs
 ds0-group 0 timeslots 1-24 type e&m-wink-start
!
controller T1 1/1
 framing sf
 linecode ami
!
interface ATM0/0
 no ip address
 load-interval 30
 atm vc-per-vp 256
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
 ip address 192.168.1.2 255.255.255.0
 pvc 0/201 
  protocol ip 192.168.1.1 broadcast
  vbr-nrt 640 640
  tx-ring-limit 3
  service-policy output VOICE-160-DATA-480-PACK
!
interface Ethernet0/0
 ip address 1.3.214.51 255.255.0.0
 half-duplex
!
interface ATM0/1
 no ip address
 shutdown
 atm vc-per-vp 256
 no atm ilmi-keepalive
 atm voice aal2 aggregate-svc upspeed-number 0
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/1
 ip address 10.1.1.1 255.255.255.0
 half-duplex
!
ip classless
ip route 223.255.254.254 255.255.255.255 1.3.0.1
ip http server
!
access-list 100 permit udp any any precedence critical
!
snmp-server manager
call rsvp-sync
!
voice-port 1/0:0
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 1 pots
 destination-pattern 7...
 port 1/0:0
!
dial-peer voice 2 voip
 destination-pattern 8...
 session target ipv4:192.168.3.1
 ip qos dscp cs5 media
 ip qos dscp cs5 signaling
 no vad
!
alias exec s sh run
alias exec c conf t
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
line vty 5 15
 login

Command Reference

There are no new or modified commands associated with the voice and QoS features in Cisco IOS Release 12.2(2)XK.