Guest

Cisco IOS Software Releases 12.2 T

SIP Media Inactivity Timer

  • Viewing Options

  • PDF (228.7 KB)
  • Feedback
SIP Media Inactivity Timer

Table Of Contents

SIP Media Inactivity Timer

Feature Overview

Benefits

Related Features and Technologies

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuring the SIP Media Inactivity Timer

Verifying the SIP Media Inactivity Timer

Troubleshooting Tips

Configuration Examples

Configuring the SIP Media Inactivity Timer Feature Example

Command Reference

ip rtcp report interval

timer receive-rtcp (SIP)

Glossary


SIP Media Inactivity Timer


Document Update Alert


This document was originally produced for Cisco IOS Release 12.2(11)T. This feature has been updated in subsequent releases, and more recent documentation is available.

If you are using Cisco IOS Release 12.2(11)T or higher, refer to the following section in the Configuring Additional SIP Features chapter of the Cisco IOS SIP Configuration Guide, Cisco IOS Voice Configuration Library, Release 12.3:

SIP Media Inactivity Timer


Feature History

Release
Modification

12.2(2)XB

This feature was introduced on the Cisco 2600 series, Cisco 3600 series, Cisco 7200 series, Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms.

12.2(8)T

This feature was integrated into Cisco IOS Release 12.2(8)T. The Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms were not supported in this release.

12.2(11)T

Support was added for the Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms.


This document describes the Session Initiation Protocol (SIP) Media Inactivity Timer feature. It includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuration Examples

Command Reference

Glossary

Feature Overview

The SIP Media Inactivity Timer feature enables Cisco gateways to monitor and disconnect Voice-over-IP (VoIP) calls if no Real-Time Control Protocol (RTCP) packets are received within a configurable time period.

When RTCP reports are not received by a Cisco gateway, the SIP Media Inactivity Timer feature releases the hung session and its network resources in an orderly manner. These network resources include the gateway digital signal processor (DSP) and time-division multiplexing (TDM) channel resources that are utilized by the hung sessions. Because call signaling is sent to tear down the call, any stateful SIP proxies involved in the call are also notified to clear the state that they have associated with the hung session. The call is also cleared back through the TDM port so that any attached TDM switching equipment also clears its resources.

Benefits

Provides a mechanism for detecting and freeing hung network resources when no RTCP packets are received by the gateway.

Related Features and Technologies

Cisco VoIP

Related Documents

The following documents contain information related to the Cisco SIP functionality:

Cisco IOS Voice, Video, and Fax Configuration Guide, Release 12.2

Cisco IOS Voice, Video, and Fax Command Reference, Release 12.2

Supported Platforms

Cisco 2600 series

Cisco 3600 series

Cisco 7200 series

Cisco AS5300

Cisco AS5350

Cisco AS5400

Cisco AS5850

Table 1 Cisco IOS Release and Platform Support for this Feature

Platform
12.2(2)XB
12.2(8)T
12.2(11)T

Cisco 2600 series

X

X

X

Cisco 3600 series

X

X

X

Cisco 7200 series

X

X

X

Cisco AS5300

X

Not supported

X

Cisco AS5350

X

Not supported

X

Cisco AS5400

X

Not supported

X

Cisco AS5850 universal gateway

X

Not supported

X


Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

CISCO-SIP-UA-MIB

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml.

RFCs

RFC 2543, SIP: Session Initiation Protocol

RFC 1889, RTP: A Transport Protocol for Real-Time Applications

Configuration Tasks

See the following sections for configuration tasks for this feature. Each task in the list is identified as either required or optional.

Configuring the SIP Media Inactivity Timer (required)

Verifying the SIP Media Inactivity Timer (optional)

Configuring the SIP Media Inactivity Timer

The SIP Media Inactivity Timer feature requires the configuration of the ip rtcp report interval command and the timer receive-rtcp command to enable detection of RTCP packets by the gateway. When these commands are configured, the gateway uses RTCP report detection, rather than Real-Time Protocol (RTP) packet detection, to determine whether calls on the gateway are still active or should be disconnected. This method is more reliable because there are periods during voice calls when one or both parties are not sending RTP packets.

One common example of a voice session in which no RTP is sent is when a caller dials into a conference call and mutes his endpoint. If voice activity detection (VAD, also known as silence suppression) is enabled, no RTP packets are sent while the endpoint is muted. However, the muted endpoint continues to send RTCP reports at the interval specified by the ip rtcp report interval command.

The timer receive-rtcp value argument (or Mfactor) is multiplied with the interval that is set using the ip rtcp report interval command. If no RTCP packets are received in the resulting time period, the call is disconnected. The gateway signals the disconnect to the SIP network and the TDM network so that upstream and downstream devices can clear their resources. The gateway sends a SIP BYE to disconnect the call and sends a Q.931 DISCONNECT back to the TDM network to clear the call upon the expiration of the timer. The Q.931 DISCONNECT is sent with a Cause code value of 3 (no route). There is no Q.931 Progress Indicator (PI) value included in the DISCONNECT.

To configure the SIP Media Inactivity Timer feature, enter the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# gateway

Enters gateway configuration mode.

Step 2 

Router(config-gateway)# timer receive-rtcp timer

Enables the RTCP timer and configures a multiplication factor for the timer interval. The argument timer is multiplied by the interval that is set with the ip rtcp report interval command. The valid range for the timer argument is 2 to 1,000. The default is 5.

Step 3 

Router(config-gateway)# exit

Exits gateway configuration mode.

Step 4 

Router(config)# ip rtcp report interval timer

Enters the minimum interval of RTCP report transmissions in milliseconds. The valid range is 1 to 65,535.


Note RFC 1889, RTP: A Transport Protocol for Real-Time Applications, recommends a minimum 5-second average reporting interval between successive RTCP reports. It also recommends that this interval be varied randomly. The randomization function is performed automatically and cannot be disabled. Therefore, the reporting interval does not remain constant throughout a given voice session, but its average is the specified reporting interval.


Verifying the SIP Media Inactivity Timer

To verify that the SIP Media Inactivity Timer feature is enabled, follow these steps:


Step 1 Enter the show running-config command to verify the configuration.

Step 2 Enter the debug ccsip events command to verify that the timer is enabled.


Troubleshooting Tips

To troubleshoot the SIP Media Inactivity Timer feature, perform the following tasks:

Make sure that you can make a voice call.

Use the debug ccsip all command to enable all SIP debugging capabilities, or use one of the following more specific SIP debug commands:

debug ccsip calls

debug ccsip error

debug ccsip messages

Use the debug ccsip events command, which includes new output specific to the SIP Media Inactivity Timer feature. The following example trace shows a timer being set:

Router# debug ccsip events

00:04:29: sipSPICreateAndStartRtpTimer: Valid RTP/RTCP session found and CLI ena 
bled to create and start the inactivity timer 
00:04:29: sipSPICreateAndStartRtpTimer:Media Inactivity timer created for call. 
Mfactor(from CLI): 5 RTCP bandwidth: 500 
RTCP Interval(in ms): 5000 
Normalized RTCP interval (in ms):25000 

The following example trace shows a timer expiring:

Router# debug ccsip events

02:41:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to 
down 
*Jan 1 02:41:34.107: sipSPIRtpDiscTimerExpired:RTP/RTCP receive timer expired. 
Disconnect the call. 
*Jan 1 02:41:34.107: Queued event From SIP SPI to CCAPI/DNS : 
SIPSPI_EV_CC_CALL_DISCONNECT 
*Jan 1 02:41:34.107: CCSIP-SPI-CONTROL: act_active_disconnect 

Note The timer receive-rtcp command configures a media activity timer that is common to both H.323 and SIP. If set, it affects both H.323 and SIP calls.


Configuration Examples

This section provides the following configuration example:

Configuring the SIP Media Inactivity Timer Feature Example

Configuring the SIP Media Inactivity Timer Feature Example


Note IP addresses and host names in examples are fictitious.


Router# show running-config

! 
version 12.2 
no parser cache 
service timestamps debug datetime msec 
service timestamps log uptime 
no service password-encryption 
! 
hostname madison 
boot system flash 
no logging buffered 
aaa new-model 
! 
aaa authentication login h323 group radius 
aaa authorization exec h323 group radius 
aaa accounting connection passsword stop-only group radius 
aaa accounting connection h323 start-stop group radius 
aaa session-id common 
!
resource-pool disable 
clock timezone EST -5 
! 
ip subnet-zero 
ip tcp path-mtu-discovery 
ip name-server 172.18.192.48 
ip dhcp smart-relay 
! 
isdn switch-type primary-ni 
! 
voice service voip 
h323 
! 
voice class codec 1 
 codec preference 1 g723ar53 
 codec preference 2 g723r53 
 codec preference 3 g729br8 
 codec preference 4 gsmfr 
 codec preference 5 g726r24 
 codec preference 6 g726r32 
voice class codec 2 
 codec preference 1 g729br8 
 codec preference 2 g729r8 
 codec preference 3 g723ar53 
 codec preference 4 g723ar63 
 codec preference 5 g723r53 
 codec preference 6 g723r63 
 codec preference 7 gsmfr 
 codec preference 8 gsmefr 
! 
voice class codec 3 
 codec preference 1 g726r24 
 codec preference 2 gsmefr 
 codec preference 3 g726r16 
! 
fax interface-type modem 
 mta receive maximum-recipients 0 
controller T1 0 
 framing esf 
 clock source line secondary 1 
 linecode ami 
 pri-group timeslots 1-24 
 description summa_pbx 
! 
controller T1 1 
 framing esf 
 linecode ami 
 pri-group timeslots 1-24 
 description summa_pbx 
! 
controller T1 2 
 framing sf 
 linecode ami 
! 
controller T1 3 
 framing esf 
 clock source line primary 
 linecode b8zs 
 ds0-group 0 timeslots 1-24 type e&m-fgb dtmf dnis 
 cas-custom 0 
! 
gw-accounting h323 vsa 
gw-accounting voip 
interface Ethernet0 
 ip address 172.18.193.99 255.255.255.0 
 no ip route-cache 
 no ip mroute-cache 
 ip rsvp bandwidth 7500 7500 
! 
interface Serial0:23 
 no ip address 
 isdn switch-type primary-ni 
 isdn incoming-voice modem 
 isdn guard-timer 3000 
 isdn T203 10000 
 isdn T306 30000 
 isdn T310 4000 
 isdn disconnect-cause 1 
 fair-queue 64 256 0 
 no cdp enable 
interface Serial1:23 
 no ip address 
 isdn switch-type primary-ni 
 isdn incoming-voice modem 
 isdn guard-timer 3000 
 isdn T203 10000 
 isdn disconnect-cause 1 
 fair-queue 64 256 0 
 no cdp enable 
! 
interface FastEthernet0 
 ip address 10.1.1.1 255.255.255.0 
 no ip route-cache 
 no ip mroute-cache 
 duplex auto 
 speed auto 
 ip rsvp bandwidth 7 7 
! 
ip classless 
ip route 10.0.0.0 255.0.0.0 172.18.193.1 
ip route 172.18.0.0 255.255.0.0 172.18.193.1 
no ip http server 
ip pim bidir-enable 
! 
ip radius source-interface Ethernet0 
! 
map-class dialer test 
dialer voice-call 
dialer-list 1 protocol ip permit 
! 
radius-server host 172.18.192.108 auth-port 1645 acct-port 1646 
radius-server retransmit 1 
radius-server key lab 
radius-server vsa send accounting 
radius-server vsa send authentication 
call rsvp-sync 
call application voice voice_billing tftp://172.18.207.16/app_passport_silent.2.0.0.0.tcl 
! 
voice-port 0:D 
voice-port 1:D 
voice-port 3:0 
! 
no mgcp timer receive-rtcp 
! 
mgcp profile default 
! 
dial-peer voice 10 pots 
 destination-pattern 2021010119 
 port 3:0 
 prefix 2021010119 
! 
dial-peer voice 11 pots 
 incoming called-number 3111100 
 destination-pattern 3100802 
 progress_ind progress enable 8 
 port 0:D 
 prefix 93100802 
! 
dial-peer voice 36 voip 
 application session 
 incoming called-number 3100802 
 destination-pattern 3100801 
 session protocol sipv2 
 session target ipv4:172.18.193.100 
 codec g726r16 
! 
dial-peer voice 5 voip 
 destination-pattern 5555555 
 session protocol sipv2 
 session target ipv4:172.18.192.218 
! 
dial-peer voice 12 pots 
 destination-pattern 3111100 
 prefix 93111100 
! 
dial-peer voice 19 pots 
 destination-pattern 2017030200 
 port 1:D 
 prefix 2017030200 
! 
dial-peer voice 30 voip 
 destination-pattern 36602 
 voice-class codec 2 
 session protocol sipv2 
 session target ipv4:172.18.193.120 
 dial-peer voice 47 pots 
 destination-pattern 2021030100 
 port 3:0 
! 
dial-peer voice 3111200 pots 
 destination-pattern 311200 
 prefix 93100802 
! 
dial-peer voice 31 voip 
 destination-pattern 36601 
 session protocol sipv2 
 session target ipv4:172.18.193.98 
! 
dial-peer voice 1234 voip 
 incoming called-number 1234 
 destination-pattern 1234 
 session target loopback:rtp 
! 
gateway 
 timer receive-rtcp 5 
! 
sip-ua 
 aaa username proxy-auth 
 retry invite 1 
 retry bye 1 
! 
line con 0 
 exec-timeout 0 0 
 line aux 0 
 line vty 0 4 
 password zebra 
! 
end

Command Reference

This section documents new commands. All other commands used with this feature are documented in the Cisco IOS Release12.2 command reference publications.

ip rtcp report interval

timer receive-rtcp (SIP)

ip rtcp report interval

To configure the average reporting interval between subsequent Real-Time Control Protocol (RTCP) report transmissions, use the ip rtcp report interval command in global configuration mode. To restore the default value, use the no form of this command.

ip rtcp report interval value

no ip rtcp report interval

Syntax Description

value

Sets the average interval for RTCP report transmissions in milliseconds. The valid range is from 1 to 65,535.


Defaults

The default is 5000 milliseconds.

Command Modes

Global configuration

Command History

Release
Modification

12.2(2)XB

This command was introduced.

12.2(8)T

This command was integrated into Cisco IOS Release 12.2(8)T. The Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms were not supported in this release.

12.2(11)T

Support was added for the Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms.


Usage Guidelines

The ip rtcp report interval command configures the average interval between subsequent RTCP report transmissions for a given voice session. For example, if the value argument is set to 25,000 milliseconds, then an RTCP report is sent every 25 seconds, on average.

For more information about RTCP, see RFC 1889, RTP: A Transport Protocol for Real-Time Applications.

Examples

The following example shows the ip rtcp report interval command interval being set to 5000 milliseconds:

Router(config)# ip rtcp report interval 5000

Related Commands

Command
Description

debug ccsip events

Displays all SIP service provider interface (SPI) events tracing and traces the events posted to SIP SPI from all interfaces.

timer receive-rtcp

Enables the RTCP timer and configures a multiplication factor for the RTCP timer interval.


timer receive-rtcp (SIP)

To enable the Real-Time Control Protocol (RTCP) timer and to configure a multiplication factor for the RTCP timer interval for the Session Initiation Protocol (SIP), use the timer receive-rtcp command in gateway configuration mode. To restore the default value, use the no form of this command.

timer receive-rtcp timer

no timer receive-rtcp

Syntax Description

timer

Sets multiples of the RTCP report transmission interval. The valid range is from 2 to 1000. The default is 5.


Defaults

The default multiplication factor is 5.

Command Modes

Gateway configuration

Command History

Release
Modification

12.2(2)XB

This command was introduced.

12.2(8)T

This command was integrated into Cisco IOS Release 12.2(8)T. The Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms were not supported in this release.

12.2(11)T

Support was added for the Cisco AS5300, Cisco AS5350, Cisco AS5400, and Cisco AS5850 platforms.


Usage Guidelines

When the ip rtcp report interval and timer receive-rtcp commands are configured, the gateway uses RTCP report detection, rather than Real-Time Protocol (RTP) packet detection, to determine whether calls on the gateway are still active or should be disconnected. This method is more reliable because there are periods during voice calls when one or both parties are not sending RTP packets.

One common example of a voice session in which no RTP is sent is when a caller dials into a conference call and mutes his endpoint. If voice activity detection (VAD, also known as silence suppression) is enabled, no RTP packets are sent while the endpoint is muted. However, the muted endpoint continues to send RTCP reports at the interval specified by the ip rtcp report interval command.

The timer receive-rtcp value argument (or Mfactor) is multiplied with the interval that is set using the ip rtcp report interval command. If no RTCP packets are received in the resulting time period, the call is disconnected. The gateway signals the disconnect to the SIP network and the TDM network so that upstream and downstream devices can clear their resources. The gateway sends a SIP BYE to disconnect the call and sends a Q.931 DISCONNECT back to the TDM network to clear the call upon the expiration of the timer. The Q.931 DISCONNECT is sent with a cause code value of 3 (no route). There is no Q.931 Progress Indicator (PI) value included in the DISCONNECT.

To show timer-related output for SIP calls, use the debug ccsip events command.

Examples

The following example shows the multiplication factor being set to10 (or x * 10, where x is the interval that is set with the ip rtcp report interval command):

Router(config)# gateway
Router(config-gateway)# timer receive-rtcp 10
Router(config-gateway)# exit

Related Commands

Command
Description

debug ccsip events

Displays all SIP service provider interface (SPI) events tracing and traces the events posted to SIP SPI from all interfaces.

ip rtcp report interval

Configures the minimum interval of RTCP report transmissions.


Glossary

call—In SIP, a call consists of all participants in a conference invited by a common source. A SIP call is identified by a globally unique call identifier. A point-to-point IP telephony conversation maps into a single SIP call.

DSP—digital signal processor. Specialized computer chip designed to perform speedy and complex operations on digitized waveforms. Useful in processing sound, such as voice phone calls, and video.

Q.931—ITU-T Recommendation for signaling to establish, maintain, and clear ISDN network connections. Recommendation for specifying the UNI signaling protocol in N-ISDN. Q.931 was developed for out-of-band call control.

QoS—quality of service. Measure of performance for a transmission system that reflects its transmission quality and service availability.

RTCP—Real-Time Control Protocol. Monitors the QoS of an IPv6 RTP connection and conveys information about the ongoing session.

RTP—Real-Time Transport Protocol. A network protocol used to carry packetized audio and video traffic over an IP network.

session—A SIP session is a set of multimedia senders and receivers and the data streams flowing between the senders and receivers. A SIP multimedia conference is an example of a session. The called party can be invited several times by different calls to the same session.

SIP—Session Initiation Protocol. An application-layer protocol originally developed by the Multiparty Multimedia Session Control (MMUSIC) working group of the Internet Engineering Task Force (IETF). Their goal was to equip platforms to signal the setup of voice and multimedia calls over IP networks. SIP features are compliant with IETF RFC 2543, published in March 1999.

TDM—time-division multiplexing. A technique for transmitting a number of separate data, voice, and video signals simultaneously over one communications medium by quickly interleaving a piece of each signal one after the other.

VAD—voice activity detection. When enabled on voice port or a dial peer, silence is not transmitted over the network, only audible speech. When VAD is enabled, the sound quality is slightly degraded, but the connection monopolizes much less bandwidth.