Guest

Cisco IOS Software Releases 12.0 S

MPLS VPN support for EIGRP between Provider Edge (PE) and Customer Edge (CE)

  • Viewing Options

  • PDF (539.5 KB)
  • Feedback
MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge

Table Of Contents

MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge

Contents

Prerequisites for MPLS VPN Support for EIGRP Between PE and CE

Restrictions for MPLS VPN Support for EIGRP Between PE and CE

Information About MPLS VPN Support for EIGRP Between PE and CE

MPLS VPN Support for EIGRP

EIGRP Extended Community Attributes

Benefits of MPLS VPN Support for EIGRP

How to Configure an MPLS VPN Using EIGRP

Configuring the VRF for the EIGRP MPLS VPN

Creating a VRF

Prerequisites

Restrictions

What to Do Next

Configuring EIGRP Redistribution in the MPLS VPN

Creating the MPLS VPN

Prerequisites

Restrictions

Troubleshooting Tips

What to Do Next

Configuring the PE Routers to Support the EIGRP MPLS VPN

Basic BGP Configuration

Prerequisites

Verifying the VPN Configuration

Verifying PE-to-PE Connectivity

Verifying EIGRP VRF Configuration

Configuration Examples for the EIGRP MPLS VPN

EIGRP MPLS VPN Configuration Example

BGP Network Configuration Example

EIGRP Redistribution Example

EIGRP MPLS VPN Verification Examples

Verifying Route Distinguisher and MPLS Configuration Example

Verifying PE-to-PE Connectivity Example

Verifying EIGRP VRF Configuration Example

Where to Go Next

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

address-family ipv4 (EIGRP)

autonomous-system (EIGRP)

clear ip eigrp vrf neighbor

default-metric (EIGRP)

exit-address-family

ip vrf

network (EIGRP)

rd

redistribute (IP)

show ip eigrp vrf interfaces

show ip eigrp vrf neighbors

show ip eigrp vrf topology

show ip eigrp vrf traffic

show ip protocols vrf

show ip route vrf

show ip vrf


MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge


The MPLS VPN Support for EIGRP Between Provider Edge (PE) and Customer Edge (CE) feature introduces the capability to redistribute Enhanced Interior Gateway Routing Protocol (EIGRP) routes through a Multiprotocol Label Switching (MPLS) Virtual Private Network (VPN) over a Border Gateway Protocol (BGP) core network. This feature is configured only on PE routers and requires no upgrade or configuration changes to customer equipment. This feature also introduces EIGRP support for MPLS and support for EIGRP extended community attributes.

Feature History for the MPLS VPN Support for EIGRP Between Provider Edge (PE) and Customer (CE) feature

Release
Modification

12.0(22)S

This feature was introduced.

12.2(15)T

This feature was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This feature was integrated into Cisco IOS Release 12.2(18)S.

12.0(27)S

EIGRP back door link support was introduced. This support is provided by a new POI in the BGP Cost Community (Updated in this release) and EIGRP MPLS VPN PE-CE Site of Origin (SoO) (Introduced in this release) features.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for MPLS VPN Support for EIGRP Between PE and CE

Restrictions for MPLS VPN Support for EIGRP Between PE and CE

Information About MPLS VPN Support for EIGRP Between PE and CE

How to Configure an MPLS VPN Using EIGRP

Configuration Examples for the EIGRP MPLS VPN

Additional References

Command Reference

Prerequisites for MPLS VPN Support for EIGRP Between PE and CE

This document assumes that BGP is configured in the network core. You will also need to complete the following tasks before you can configure this feature:

MPLS and Cisco Express Forwarding (CEF) must be configured in the BGP core network. EIGRP and multiprotocol BGP (mBGP) must be configured on all PE routers that provide VPN services to the CE routers at the customer sites.

The metric must be configured for routes from external EIGRP autonomous systems and non-EIGRP networks before these routes can be redistributed into an EIGRP CE router. The metric can be configured in the redistribute statement using the redistribute (IP) command or configured with the default-metric (EIGRP) command.

Restrictions for MPLS VPN Support for EIGRP Between PE and CE

Metric Must Be Configured for Routes from Other Autonomous Systems and Non-EIGRP Networks

If an external route is received from another EIGRP autonomous system or a non-EIGRP network without a configured metric, the route will not be advertised to the CE router. The metric can be configured in the redistribute statement using the redistribute command or configured with the default-metric command.

Native EIGRP VRF to VRF Redistribution is Not Supported

Redistribution between native EIGRP VRFs is not supported. This is designed behavior.

Information About MPLS VPN Support for EIGRP Between PE and CE

To configure this feature, you must understand the following concepts:

MPLS VPN Support for EIGRP

EIGRP Extended Community Attributes

Benefits of MPLS VPN Support for EIGRP

MPLS VPN Support for EIGRP

The MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge feature provides the capability to transparently connect EIGRP customer networks through an MPLS-enabled BGP core network so that EIGRP routes are redistributed through the VPN across the BGP network as internal BGP (iBGP) routes. The configuration of this feature does not require any customer equipment upgrades or configuration changes; this feature is configured only on PE routers within the service provider network.

Customer networks and remote sites are connected to each other through the MPLS VPN. The configuration of this feature allows several EIGRP sites to connect seamlessly and appear as a single network. This integration is transparent to the customer sites. When this feature is enabled, EIGRP routes are converted to iBGP routes and transported through the BGP core network. EIGRP extended community attributes are used to define EIGRP routes and preserve internal metrics. These attributes are carried across the core network by multiprotocol BGP.

Figure 1 shows 2 customer EIGRP networks that are connected by the VPN over a service provider backbone:"Site1" and "Site 2."

Figure 1

EIGRP Connectivity Between VPN Client Sites over a Service Provider Backbone

In Figure 1, the EIGRP routes in Site 1 are carried through the BGP core network as iBGP routes. The EIGRP routes in "Site 1" and "Site 2" are converted to iBGP routes and EIGRP extended community attributes are appended to the iBGP routes. (See Table 1 for a description of these attributes.) The EIGRP extended community attributes are appended to the EIGRP routes when they are redistributed into BGP as iBGP routes, and VPN routing information is redistributed between the PE routers by multiprotocol BGP.

The routes that originate in "Site 1" travel to the PE router that is connected to the CE router in "Site 2" of the VPN and are then converted back to EIGRP routes using the EIGRP extended community attributes. EIGRP routes are treated the same in "Site 1" and "Site 2." If the route is internal in "Site 1", it will be internal in "Site 2", and if the route is external in "Site 1", it will be external in "Site 2." All EIGRP metrics are preserved, and EIGRP metric information, along with the autonomous system, tag, and external data, is carried across the VPN over the BGP core network.


Note EIGRP adjacencies, EIGRP updates, and EIGRP queries are not sent across the VPN. If a route is received from another EIGRP autonomous system without a configured metric, the route is not advertised to the CE router.


Each VPN is associated with a single VPN routing or forwarding instance (VRF). A VRF consists of an IP routing table, a CEF table, and a set of interfaces that use the CEF forwarding table. The router maintains a separate routing and CEF table for each VRF, which prevents information being sent outside the VPN and allows the same addresses to be used in several VPNs without causing problems that are associated with duplicate IP addresses.

A single EIGRP routing process can support multiple VRFs. This support is limited only by the available system resources on the router, which are determined by the number of configured VRF instances, running processes, and amount of available memory. However, only a single VRF can be supported by each VPN. Separate VRFs are unique and do not share neighbor, routing, or topology information. Redistribution between native EIGRP VRFs is not supported. An EIGRP process must be created for the default VRF even if it is not used for establishing EIGRP neighbors, and a separate VRF address family must be configured in BGP for each EIGRP VRF.

EIGRP Extended Community Attributes

EIGRP routes are converted to iBGP routes on the PE router by appending EIGRP extended community attributes. The PE router uses multiprotocol BGP to distribute the VPN routing information using the these extended community attributes. The BGP routes are converted back to EIGRP routes using the extended community attribute information when the iBGP routes reach the PE router that is connected to the destination CE router.

Table 1 describes the extended community attributes that are appended to BGP routes and used to carry EIGRP information across the service provider backbone.

Table 1 EIGRP-Specific Extended Community Attribute Descriptions

EIGRP Appended Attributes
Usage
Values

Type 0x8800

EIGRP General Route Information

Route Flag and Tag

EIGRP Metric Information
Usage
Values

Type 0x8801

EIGRP Route Metric Information and Autonomous System

Autonomous System and Delay

Type 0x8802

EIGRP Route Metric Information

Reliability, Next Hop, and Bandwidth

Type 0x8803

EIGRP Route Metric Information

Reserve, Load and MTU

EIGRP External Route Information
Usage
Values

Type 0x8804

EIGRP External Route Information

Remote Autonomous System and Remote ID

Type 0x8805

EIGRP External Route Information

Remote Protocol and Remote Metric


Benefits of MPLS VPN Support for EIGRP

Multiple VRFs Are Supported

A single EIGRP routing process can support multiple VRFs. This support is limited only by the available system resources on the router, which are determined by the number of configured VRF instances, running processes, and amount of available memory. However, only a single VRF can be supported by each VPN.

Seamless Integration of Existing Customer EIGRP Deployments

This feature is configured only on PE routers that provide VPN services across the service provider network. The customer need not upgrade their version of Cisco IOS software or make any changes to their equipment or configurations.

Secure, Scalable, and Cost-Effective Alternative

Remote sites can be seamlessly and securely connected through VPNs to customer networks. This feature provides a cost-effective alternative to traditional methods, such as WAN leased lines.

How to Configure an MPLS VPN Using EIGRP

This section contains the following procedures:

Configuring the VRF for the EIGRP MPLS VPN (required)

Configuring EIGRP Redistribution in the MPLS VPN (required)

Configuring the PE Routers to Support the EIGRP MPLS VPN (required)

Verifying the VPN Configuration, page 13 (optional)

Verifying PE-to-PE Connectivity, page 13 (optional)

Verifying EIGRP VRF Configuration, page 14 (optional)

Configuring the VRF for the EIGRP MPLS VPN

Creating a VRF

A VRF must be created, and a route distinguisher and route target must be configured in order for the PE routers in the BGP network to carry EIGRP routes to the EIGRP CE site. The VRF must also be associated with an interface in order for the PE router to send routing updates to the CE router. Use the following steps to create and configure the VRF and associate the VRF with an interface.

Prerequisites

Before this feature can be configured, MPLS and CEF must be configured in the BGP network, and multiprotocol BGP and EIGRP must be configured on all PE routers that provide VPN services to CE routers.

Restrictions

Native EIGRP VRF to VRF redistribution is not supported.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target {import | export | both} route-target-ext-community

6. exit

7. interface interface-type

8. ip vrf forwarding vrf-name

9. ip address ip-address subnet-mask

10. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip vrf vrf-name

Example:

Router(config)# ip vrf RED

Creates a VRF routing table and specifies the VRF name (or tag).

The ip vrf vrf-name command creates a VRF routing table and a CEF table, and both are named using the vrf-name argument. Associated with these tables is the default route distinguisher value.

Step 4 

rd route-distinguisher

Example:

Router(config-vrf)# rd 100:1

Creates routing and forwarding tables for the VRF instance created in step 3.

There are two formats for configuring the route distinguisher argument. It can be configured in the as-number:network number (ASN:nn) format, as shown in the example, or it can be configured in the IP address:network number format (IP-address:nn).

Step 5 

route-target {import | export | both} route-target-extcommunity

Example:

Router(config-vrf)# route-target both 100:1

Creates a list of import and/or export route target communities for the specified VRF.

There are two formats for configuring the route target extcommunity argument. It can be configured in the as-number:network number (ASN:nn) format, as shown in the example, or it can be configured in the IP address:network number format (IP-address:nn).

Step 6 

exit

Example:

Router(config-vrf)# exit

Exits VRF configuration mode and enters global configuration mode.

Step 7 

interface type number

Example:

Router(config)# interface FastEthernet 0/0

Enters interface configuration mode to configure the specified interface.

Step 8 

ip vrf forwarding vrf-name

Example:

Router(config-if)# ip vrf forwarding RED

Associates the VRF with an interface or subinterface.

The VRF name configured in this step should match the VRF name created in step 3.

Step 9 

ip address ip-address subnet-mask

Example:

Router(config-if)# ip address 10.0.0.1 255.255.255.0

Configures the IP address for the interface.

The IP address needs to be reconfigured after enabling VRF forwarding.

Step 10 

end

Example:

Router(config-if)# end

Exits interface configuration mode and enters privileged EXEC mode.

What to Do Next

The next task is to configure the EIGRP redistribution in the MPLS VPN. Use the steps in the following section.

Configuring EIGRP Redistribution in the MPLS VPN

Creating the MPLS VPN

Perform this task to enable EIGRP redistribution in the MPLS VPN. This task should be applied to every PE router that provides VPN services.

Prerequisites

Before EIGRP SoO BGP Cost Community support was introduced, BGP preferred locally sourced routes over routes learned from BGP peers. Back door links in an EIGRP MPLS VPN topology will be preferred by BGP if the back door link is learned first. (A back door link or a route is a connection that is configured outside of the VPN between a remote and main site. For example, a WAN leased line that connects a remote site to the corporate network).

The "pre-bestpath" point of insertion (POI) has been introduced in the BGP Cost Community feature to support mixed EIGRP VPN network topologies that contain VPN and backdoor links. This POI is applied automatically to EIGRP routes that are redistributed into BGP. The "pre-best path" POI carries the EIGRP route type and metric. This POI influences the best path calculation process by configuring BGP to consider this POI before any other comparison step. No configuration is required. This feature is enabled automatically for EIGRP VPN sites when Cisco IOS Release 12.0(27)S is installed to a PE, CE, or back door router.

For more information about the BGP Cost Community feature and the absolute value POI, refer to the BGP Cost Community feature documentation in Cisco IOS Release 12.0(27)S.

For more information about the EIGRP MPLS VPN PE-CE Site of Origin (SoO) feature, refer to the EIGRP MPLS VPN PE-CE Site of Origin (SoO) feature documentation in Cisco IOS Release 12.0(27)S.

Restrictions

Metrics must be configured for routes from other EIGRP autonomous systems and non-EIGRP networks. If an external route is received from another EIGRP autonomous system or a non-EIGRP network without a configured metric, the route will not be advertised to the CE router. The metric can be configured in the redistribute statement using the redistribute command or configured with the default-metric command.

SUMMARY STEPS

1. enable

2. configure terminal

3. router eigrp autonomous-system-number

4. address-family ipv4 vrf vrf-name

5. network ip-address wildcard-mask

6. redistribute bgp [autonomous-system-number] [metric bandwidth delay reliability load mtu]

7. autonomous-system autonomous-system-number

8. exit-address-family

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router eigrp autonomous-system-number

Example:

Router(config)# router eigrp 1

Enters router configuration mode and creates an EIGRP routing process.

The EIGRP routing process for the PE router is created in this step.

Step 4 

address-family ipv4 [multicast | unicast | vrf vrf-name]

Example:

Router(config-router)# address-family ipv4 vrf RED

Enters address-family configuration mode and creates a VRF.

The VRF name (or tag) must match the VRF name that was created in Step 3 of the previous section.

Step 5 

network ip-address wildcard-mask

Example:

Router(config-router-af)# network 172.16.0.0 0.0.255.255

Specifies the network for the VRF.

The network statement is used to identify which interfaces to include in EIGRP. The VRF must be configured with addresses that fall within the wildcard-mask range of the network statement.

Step 6 

redistribute bgp {autonomous-system-number} [metric bandwidth delay reliability load mtu] [route-map map-name]

Example:

Router(config-router-af)# redistribute bgp 10 metric 10000 100 255 1 1500

Redistributes BGP into the EIGRP.

The autonomous system number and metric of the BGP network is configured in this step. BGP must be redistributed into EIGRP for the CE site to accept the BGP routes that carry the EIGRP information. A metric must also be specified for the BGP network and is configured in this step.

Step 7 

autonomous-system autonomous-system-number

Example:

Router(config-router-af)# autonomous-system 101

Specifies the autonomous system number of the EIGRP network for the customer site.

Step 8 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Exits address family configuration mode and enters router configuration mode.

Troubleshooting Tips

If the MPLS VPN is not working properly, verify the following:

Verify the configurations on each router. Make sure that the VRF and route distinguisher have been correctly configured. Check the VRF routing table and VRF CEF table.

Verify that there is connectivity between both PE routers. Check the PE router and other neighbors that carry the VPN. The network operator should be able to ping between the PE routers that carry the VPN to verify the neighbor relationships.

The commands in the following table can also be useful for monitoring and troubleshooting the configuration of this feature:

Command
Purpose

Router# clear ip eigrp vrf vrf-name neighbor

Clears EIGRP neighbors from the VRF table.

Router# debug ip eigrp vrf vrf-name

Specifies a VRF for trace debugging.

A VRF name must be specified with the vrf-name argument, or the "*" can be used as a wildcard to specify all configured VRFs.

Router# show ip eigrp vrf vrf-name interfaces

Displays EIGRP interfaces that are defined under the specified VRF.

If an interface is specified, only that interface is displayed. Otherwise, all interfaces on which EIGRP is running as part of the specified VRF are displayed.

Router# show ip eigrp vrf vrf-name neighbors

Displays when VRF neighbors become active and inactive.

This command can be used to help debug transport problems.

Router# show ip eigrp vrf vrf-name topology

Displays VRF entries in the EIGRP topology table.

This command can be used to determine Diffusing Update Algorithm (DUAL) states and to troubleshoot possible DUAL problems.

Router# show ip vrf

Displays the set of defined VRFs and associated interfaces.

This command is used to verify that the correct route distinguishers (RDs) are configured for the VRF.

Router# show mpls interfaces

Displays information about one or more interfaces that have been configured for label switching.

This command is used to verify that MPLS is configured for interfaces that are used with this feature.


What to Do Next

The next task is to configure the PE routers to support the EIGRP MPLS VPN. Use the steps in the following section.

Configuring the PE Routers to Support the EIGRP MPLS VPN

Basic BGP Configuration

The BGP configuration provided in this section includes the minimum required elements necessary to configure this feature. Steps 11 through 13 will need to be repeated on a per EIGRP VRF basis if multiple EIGRP VRFs need to be configured.

Prerequisites

Before this feature can be configured, MPLS and CEF must be enabled in the BGP network, and multiprotocol BGP must be enabled on all PE routers that provide VPN services to CE routers.

SUMMARY STEPS

1. enable

2. configure terminal

3. router bgp as-number

4. no synchronization

5. neighbor ip-address remote-as as-number

6. neighbor ip-address update-source loopback interface-number

7. address-family vpnv4

8. neighbor ip-address activate

9. neighbor ip-address send-community extended

10. exit-address-family

11. address-family ipv4 vrf vrf-name

12. redistribute eigrp as-number

13. no synchronization

14. exit-address-family

15. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router bgp autonomous-system-number

Example:

Router(config)# router bgp 10

Enters router configuration mode, and creates a BGP routing process.

Step 4 

no synchronization

Example:

Router(config-router)# no synchronization

Configures BGP to send advertisements without waiting to synchronize with the IGP.

Step 5 

neighbor ip-address remote-as autonomous-system-number

Example:

Router(config-router)# neighbor 10.0.0.1 remote-as 10

Establishes peering with the specified neighbor or peer-group.

In this step, you are establishing an iBGP session with the PE router that is connected to the CE router at the other CE site.

Step 6 

neighbor ip-address update-source loopback interface-number

Example:

Router(config-router)# neighbor 10.0.0.1 update-source loopback 0

Configures BGP to use any operational interface for TCP connections.

This configuration step is not required. However, the BGP routing process will be less susceptible to the affects of interface or link flapping.

Step 7 

address-family vpnv4

Example:

Router(config-router)# address-family vpnv4

Enters address family configuration mode for configuring routing sessions that use standard IPv4 address prefixes, such as BGP, RIP, and static routing sessions.

Step 8 

neighbor ip-address activate

Example:

Router(config-router-af)# neighbor 10.0.0.1 activate

Establishes peering with the specified neighbor or peer-group.

In this step, you are activating the exchange of VPNv4 routing information between the PE routers.

Step 9 

neighbor ip-address send-community extended

Example:

Router(config-router-af)# neighbor 10.0.0.1 send-community extended

Configures the local router to send extended community attribute information to the specified neighbor.

This step is required for the exchange of EIGRP extended community attributes.

Step 10 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Exits address family configuration mode and enters router configuration mode.

Step 11 

address-family ipv4 vrf vrf-name

Example:

Router(config-router)# address-family ipv4 vrf RED

Configures an IPv4 address-family for the EIGRP VRF.

An address-family VRF needs to be configured for each EIGRP VRF that runs between the PE and CE routers.

Step 12 

redistribute eigrp autonomous-system-number [metric metric-value][route-map map-name]

Example:

Router(config-router-af)# redistribute eigrp 101

Redistributes the EIGRP VRF into BGP.

The autonomous system number from the CE network is configured in this step.

Step 13 

no synchronization

Example:

Router(config-router-af)# no synchronization

Configures BGP to send advertisements without waiting to synchronize with the IGP.

Step 14 

exit-address-family

Example:

Router(config-router-af)# exit-address-family

Exits address family configuration mode and enters router configuration mode.

Step 15 

end

Example:

Router(config-router)# end

Exits address family configuration mode and enters privileged EXEC mode.

Verifying the VPN Configuration

A route distinguisher must be configured for the VRF, and MPLS must be configured on the interfaces that carry the VRF. Use the show ip vrf command to verify the route distinguisher (RD) and interface that are configured for the VRF.

SUMMARY STEPS

1. show ip vrf

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

show ip vrf

Example:

Router> show ip vrf

Displays the set of defined VRF instances and associated interfaces.

The output also maps the VRF instances to the configured route distinguisher.

Verifying PE-to-PE Connectivity

Perform this task to verify PE-to-PE connectivity in the service provider network.

SUMMARY STEPS

1. enable

2. ping ip-address

3. show ip route vrf vrf-name

4. show ip cef vrf vrf-name

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Note The ping command can be issued only from privileged EXEC mode. The other commands in this table can be issued from both user EXEC and privileged EXEC mode.

Step 1 

ping ip-address

Example:

Router# ping 172.16.0.1

The ping command can be used to verify PE to PE connectivity within the service provider network.

If a PE router cannot be reached with the ping command, use the commands in the following steps to isolate the problem.

Step 2 

show ip route vrf vrf-name [connected] [protocol [as-number] [tag] [output-modifiers]] [ip-prefix] [list number [output-modifiers]] [profile] [static [output-modifiers]] [summary [output-modifiers]] [supernets-only [output-modifiers]] [traffic-engineering [output-modifiers]]

Example:

Router# show ip route vrf RED

Displays the IP routing table associated with a VRF instance.

The show ip route vrf command is used to verify that the VRF is in the routing table. If the VRF is in the routing table but the PE router still cannot be reached with the ping command, proceed to the next step.

Step 3 

show ip cef [vrf vrf-name] [[unresolved [detail]] | [detail | summary]]

Example:

Router# show ip cef vrf RED

Displays the CEF forwarding table associated with a VRF instance.

The show ip cef vrf command is used to verify that the interfaces and networks associated with the VRF are not in the global CEF database. If the VRF route is in the global CEF table, deconfigure and reconfigure CEF.

Verifying EIGRP VRF Configuration

Use the following steps to verify EIGRP VRF configuration.

SUMMARY STEPS

1. enable

1. show ip eigrp vrf vrf-name topology

2. show ip bgp vpnv4 vrf vrf-name

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 1 

show ip eigrp vrf vrf-name topology

Example:

Router# show ip eigrp vrf RED topology

The show ip eigrp vrf command verifies that the correct VRF routes are in the EIGRP topology table.

If the VRF route is not in the EIGRP topology table, proceed to the next step.

Step 1 

show ip bgp vpnv4 {all | rd route-distinguisher | vrf vrf-name} [ip-prefix/length] [[longer-prefixes] [output-modifiers]] [network-address [mask] [longer-prefixes] [output-modifiers]] [cidr-only] [community] [community-list] [dampened-paths] [filter-list] [flap-statistics] [inconsistent-as] [neighbors] [paths [line]] [peer-group] [quote-regexp] [regexp] [summary] [tags]

Example:

Router# show ip bgp vpnv4 vrf RED

Displays VPN address information from the BGP table.

The show ip bgp vpnv4 command is used to verify that the route is in the BGP VRF table. If the VRF route is not in the BGP VRF, reconfigure the VRF and route distinguisher.

Configuration Examples for the EIGRP MPLS VPN

EIGRP MPLS VPN Configuration Example

BGP Network Configuration Example

EIGRP Redistribution Example

EIGRP MPLS VPN Verification Examples

EIGRP MPLS VPN Configuration Example

The following configuration example in global configuration mode creates a VRF named RED and associates it with an interface:

ip vrf RED
 rd 100:1
 route-target both 100:1
 exit
interface FastEthernet 0/0
 ip vrf forwarding RED
 ip address 10.0.0.1 255.255.255.0
 end

BGP Network Configuration Example

The following configuration example shows the minimum BGP configuration required on the PE routers to support the EIGRP MPLS VPN:

router bgp 10
 no synchronization
 neighbor 10.0.0.1 remote-as 10
 neighbor 10.0.0.1 update-source loopback 0
 address-family vpnv4 
 neighbor 10.0.0.1 remote-as 10
 neighbor 10.0.0.1 send-community extended 
 exit-address-family
 address-family ipv4 vrf RED
 redistribute eigrp 101
 no synchronization
 exit-address-family

EIGRP Redistribution Example

The following configuration example configures EIGRP redistribution through the MPLS VPN over the BGP core network:

router eigrp 1
 address-family ipv4 vrf RED
 network 172.16.0.0 0.0.255.255
 redistribute bgp 10 metric 10000 100 255 1 1500
 autonomous-system 101
 exit-address-family 

EIGRP MPLS VPN Verification Examples

The examples in the following section show how to verify the configuration of the MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge feature:

Verifying Route Distinguisher and MPLS Configuration Example

Verifying PE-to-PE Connectivity Example

Verifying EIGRP VRF Configuration Example

Verifying Route Distinguisher and MPLS Configuration Example

A route distinguisher must be configured for the VRF, and MPLS must be configured on the interfaces that carry the VRF.

Use the show ip vrf command to verify the route distinguisher (RD) and interface that are configured for the VRF. The VRF name, RD, and configured interface are displayed in the output. The following sample output is similar to the output that will be displayed when the show ip vrf command is issued:

Router# show ip vrf
  Name                             Default RD          Interfaces
  BLUE                             120:1
  PINK                             130:1               Ethernet3/0
  RED                              100:1
  YELLOW                           110:1               Serial12/0

Use the show ip eigrp vrf interfaces command to display and verify specific information about VRFs configured under EIGRP. The interface to VRF mapping that is displayed in the output of this command should match the mapping that is displayed for the show ip vrf command. The following sample output is similar to the output that will be displayed when the show ip eigrp vrf interfaces command is issued:

Router# show ip eigrp vrf PINK interfaces
IP-EIGRP interfaces for process 1 
                        Xmit Queue   Mean   Pacing Time   Multicast  Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer Routes
Et3/0              1        0/0       131       0/10         528       0

Use the show mpls interfaces command to verify that MPLS is configured for interfaces that need to carry any configured VRFs. The following sample output is similar to the output that will be displayed when the show mpls interfaces command is issued:

Router# show mpls interfaces
Interface              IP            Tunnel   Operational
Ethernet2/0            Yes (tdp)     No       Yes

Verifying PE-to-PE Connectivity Example

The ping command can be used to verify PE-to-PE connectivity within the service provider network. If a PE router cannot be reached with the ping command, use the following steps to isolate the problem:


Step 1 Verify that the VRF is in the routing table with the show ip route vrf vrf-name command.

Router# show ip route vrf PINK

Routing Table:PINK
Codes:C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D       172.16.17.0 [90/409600] via 10.10.10.2, 1d15h, Ethernet3/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet3/0
     10.19.0.0/24 is subnetted, 1 subnets
D       10.19.19.0 [90/409600] via 10.10.10.2, 1d15h, Ethernet3/0
     192.168.0.0/24 is subnetted, 1 subnets
B       192.168.10.0 [200/0] via 10.14.14.14, 1d15h

Step 2 If the VRF is in the routing table but the PE router still cannot be reached with the ping command, verify that the VRF is in the CEF table with the show ip cef vrf vrf-name command.

Router# show ip cef vrf PINK
Prefix              Next Hop             Interface
0.0.0.0/0           drop                 Null0 (default route handler
entry)
0.0.0.0/32          receive
172.16.17.0/24       10.10.10.2           Ethernet3/0
10.19.19.0/24       10.10.10.2           Ethernet3/0
10.10.10.0/24       attached             Ethernet3/0
10.10.10.0/32       receive
10.10.10.1/32       receive
10.10.10.2/32       10.10.10.2           Ethernet3/0
10.10.10.255/32     receive
172.16.10.0/24      10.22.10.1           Ethernet2/0
224.0.0.0/24        receive
255.255.255.255/32  receive

Step 3 If the VRF is in the CEF table but the PE router still cannot be reached with the ping command, verify that the interfaces and networks associated with the VRF are not in the global CEF database with the show ip cef command.

Router# show ip cef
Prefix              Next Hop             Interface
0.0.0.0/0           drop                 Null0 (default route handler
entry)
0.0.0.0/32          receive
10.14.14.14/32      10.22.10.1           Ethernet2/0
10.15.15.15/32      receive
10.16.16.16/32      10.22.10.1           Ethernet2/0
172.16.17.17/32      10.22.10.1           Ethernet2/0
10.22.10.0/24       attached             Ethernet2/0
10.22.10.0/32       receive
10.22.10.1/32       10.22.10.1           Ethernet2/0
10.22.10.2/32       receive
10.22.10.255/32     receive
10.23.10.0/24       10.22.10.1           Ethernet2/0
224.0.0.0/4         drop
224.0.0.0/24        receive
255.255.255.255/32  receive

If the VRF route is in the global CEF table, deconfigure and reconfigure CEF.

Verifying EIGRP VRF Configuration Example

To verify EIGRP VRF configuration, perform the following steps:


Step 1 Use the show ip eigrp vrf vrf-name topology command to verify that the correct VRF route is in the EIGRP topology table.

Router# show ip eigrp vrf PINK topology
IP-EIGRP Topology Table for AS(1)/ID(10.10.10.1) Routing Table:PINK

Codes:P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.17.0/24, 1 successors, FD is 409600
         via 10.10.10.2 (409600/128256), Ethernet3/0
P 10.19.19.0/24, 1 successors, FD is 409600
         via 10.10.10.2 (409600/128256), Ethernet3/0
P 10.10.10.0/24, 1 successors, FD is 281600
         via Connected, Ethernet3/0
P 172.16.10.0/24, 1 successors, FD is 281600
         via Redistributed (281600/0)

Step 2 If the VRF route is not in the EIGRP topology table, verify that the route is in the BGP VRF table with the show ip bgp vpnv4 vrf vrf-name command.

Router# show ip bgp vpnv4 vrf PINK
BGP table version is 17, local router ID is 10.15.15.15
Status codes:s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes:i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher:130:1 (default for vrf PINK)
*> 172.16.17.0/24    10.10.10.2          409600         32768 ?
*> 10.19.19.0/24    10.10.10.2          409600         32768 ?
*> 10.10.10.0/24    0.0.0.0                  0         32768 ?
*>i172.16.10.0/24   10.14.14.14              0    100      0 ?

Where to Go Next

For more information about the BGP Cost Community feature, refer to the BGP Cost Community feature documentation in Cisco IOS Release 12.0(27)S.

For more information about the EIGRP MPLS VPN PE-CE Site of Origin (SoO) feature, refer to the EIGRP MPLS VPN PE-CE Site of Origin (SoO) feature documentation in Cisco IOS Release 12.0(27)S.

Additional References

For additional information related to the MPLS VPN support for EIGRP between Provider Edge (PE) and Customer (CE) feature, refer to the following references:

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Related Documents

Related Topic
Document Title

BGP Cost Community

BGP Cost Community, Cisco IOS Release 12.0(27)S

CEF commands

Cisco IOS Switching Services Configuration Guide, Release 12.3

CEF configuration tasks

Cisco IOS Switching Services Command Reference, Release 12.3

EIGRP commands

Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols, Release 12.3

EIGRP configuration tasks

Cisco IOS IP Configuration Guide, Release 12.3

EIGRP Site of Origin

EIGRP MPLS VPN PE-CE Site of Origin (SoO), Cisco IOS Release 12.0(27)S.

MPLS VPNs

MPLS Virtual Private Networks, Cisco IOS Release 12.0(5)T


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


RFCs


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

This section documents new and modified commands. All other commands used with this feature are documented in the Cisco IOS command reference publications.

address-family ipv4 (EIGRP)

autonomous-system (EIGRP)

clear ip eigrp vrf neighbor

default-metric (EIGRP)

exit-address-family

ip vrf

network (EIGRP)

rd

redistribute (IP)

show ip eigrp vrf interfaces

show ip eigrp vrf neighbors

show ip eigrp vrf topology

show ip eigrp vrf traffic

show ip protocols vrf

show ip route vrf

show ip vrf

address-family ipv4 (EIGRP)

To enter IPv4 address family configuration mode to configure an Enhanced Interior Gateway Routing Protocol (EIGRP) Virtual Private Network (VPN), use the address-family ipv4 command in address family configuration mode. To remove the address family from the EIGRP configuration, use the no form of this command.

address-family ipv4 [unicast] [vrf vrf-name]

no address-family ipv4 [unicast] [vrf vrf-name]

Syntax Description

unicast

(Optional) Specifies the unicast subaddress family.

vrf vrf-name

(Optional) Specifies the name of the VRF.


Defaults

A default VRF is automatically created when this command is entered without the vrf keyword.

Command Modes

Address family configuration

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into 12.2(15)T.


Usage Guidelines

The address-family ipv4 command is used to configure IPv4 address family sessions under EIGRP. To leave address family configuration mode without removing the address family configuration, use the exit-address-family command.

EIGRP VPNs can be configured only under IPv4 address family configuration mode. A virtual routing and forwarding instance (VRF) and route distinguisher must be defined before the address family session can be created.

A single EIGRP routing process can support multiple VRFs. The number of VRFs that can be configured is limited by only available system resources on the router, which is determined by the number of VRFs, running processes, and available memory. However, only a single VRF can be supported by each VPN, and redistribution between different VRFs is not supported.

MPLS VPN support between PE and CE routers is configured only on PE routers that provide VPN services over the service provider backbone. The customer site does not require any changes to equipment or configurations to support the EIGRP VPN. A metric must be configured for routes to be advertised to the CE router. The metric can be configured using the redistribute (IP) command or configured with the default-metric (EIGRP) command.

Examples

The following example, starting in Global configuration mode, configures an IPv4 address family session for the VRF named RED:

Router(config)# ip vrf RED 
Router(config-vrf)# rd 1:1 
Router(config-vrf)# exit 
Router(config)# router eigrp 1 
Router(config-router)#  address-family ipv4 vrf RED
Router(config-router-af)# autonomous-system 101 
Router(config-router-af)# network 172.16.0.0 
Router(config-router-af)# redistribute bgp 10 metric 10000 100 255 1 1500 
Router(config-router-af)# exit-address-family 

Related Commands

Command
Description

default-metric (EIGRP)

Sets metric for EIGRP.

exit-address-family

Exits from address family configuration mode.

network (EIGRP)

Specifies a list of networks for the EIGRP routing process.

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.


autonomous-system (EIGRP)

To configure an Enhanced Interior Gateway Routing Protocol (EIGRP) routing process to run within a VPN routing and forwarding instance (VRF), use the autonomous-system command in address family configuration mode.

autonomous-system as-number

Syntax Description

as-number

Specifies the autonomous system number of the EIGRP routing process.


Defaults

No default behavior or values

Command Modes

Address family configuration

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

The command was integrated into Cisco IOS Release 12.2(18)S.


Usage Guidelines

This command can only be configured if a VRF name is specified when entering address family configuration mode.

Examples

The following example shows how to exit address family configuration mode:

router eigrp 1
 address-family ipv4 vrf VRF-NAME 
 autonomous-system 101 

Related Commands

Command
Description

address-family ipv4 (EIGRP)

Enters address family configuration mode for EIGRP.


clear ip eigrp vrf neighbor

To clear neighbor entries of the specified Enhanced Interior Gateway Routing Protocol (EIGRP) virtual routing and forwarding instance (VRF) from the Routing Information Base (RIB), use the clear ip eigrp vrf command in privileged EXEC mode.

clear ip eigrp vrf {vrf-name | as-number} neighbor [interface-number]

Syntax Description

vrf-name

Specifies the name of the VRF whose EIGRP neighbors will be cleared. The * keyword can be used as a wild card to specify all VRFs.

as-number

Specifies the autonomous system number of the VRF whose neighbors will be cleared.

interface-number

(Optional) Specifies the interface that VRF neighbors were learned through. The exact interface is specified by interface number with the interface-number argument.


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

The command was integrated into Cisco IOS Release 12.2(18)S.


Examples

The following example clears EIGRP neighbors reached through the VRF named RED in autonomous system 101:

clear ip eigrp vrf RED 101 neighbor 

The following example clears EIGRP neighbors reached through the VRF named GREEN in autonomous-system 202 learned through Ethernet interface 0/0:

clear ip eigrp vrf GREEN 202 neighbor ethernet 0/0

Related Commands

Command
Description

show ip eigrp vrf interfaces

Displays EIGRP interfaces that are defined under the specified VRF.

show ip eigrp vrf neighbors

Displays neighbors discovered by EIGRP that carry VRF information.

show ip eigrp vrf topology

Displays VRF entries in the EIGRP topology table.

show ip eigrp vrf traffic

Displays EIGRP VRF traffic statistics.

show ip protocols vrf

Displays routing protocol information that is associated with a VRF.


default-metric (EIGRP)

To set metrics for the Enhanced Interior Gateway Routing Protocol (EIGRP), use the default-metric command in router configuration mode. To remove the metric value and restore the default state, use the no form of this command.

default-metric bandwidth delay reliability loading mtu

no default-metric bandwidth delay reliability loading mtu

Syntax Description

bandwidth

Minimum bandwidth of the route in kbps. It can be 0 or any positive integer.

delay

Route delay (in tens of microseconds). It can be 0 or any positive number that is a multiple of 39.1 nanoseconds.

reliability

Likelihood of successful packet transmission expressed as a number from 0 to 255. The value 255 means 100 percent reliability; 0 means no reliability.

loading

Effective bandwidth of the route expressed as a number from 0 to 255 (255 is 100 percent loading).

mtu

Maximum transmission unit (MTU) size of the route in bytes. It can be 0 or any positive integer.


Defaults

Only connected routes and interface static routes can be redistributed without a default metric.

Command Modes

Address family configuration

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

12.0(22)S

Address family support was added.

12.2(15)T

Address family support was added.

12.2(18)S

Address family support was added.


Usage Guidelines

A default metric is required to redistribute a protocol into EIGRP. Automatic metric translations occur between IGRP and EIGRP. You do not need default metrics to redistribute EIGRP into itself.


Note The default-metric command does not affect EIGRP-to-EIGRP or IGRP-to-EIGRP distribution. To configure EIGRP-to-EIGRP or IGRP-to-EIGRP distribution, use route maps.


Metric defaults have been carefully set to work for a wide variety of networks. Take great care when changing these values.

Keeping the same metrics is supported only when redistributing from IGRP, EIGRP, or static routes.

Examples

The following example takes redistributed Routing Information Protocol (RIP) metrics and translates them into EIGRP metrics with values as follows: bandwidth = 1000, delay = 100, reliability = 250, load = 100, and MTU = 1500.

router eigrp 101
 network 172.16.0.0
 redistribute rip
 default-metric 1000 100 250 100 1500

Related Commands

Command
Description

redistribute (IP)

Redistributes routes from one routing domain into another routing domain.


exit-address-family

To exit from address family configuration mode, use the exit-address-family command in address family configuration mode.

exit-address-family

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values

Command Modes

Address family configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(22)S

EIGRP support was added.

12.2(15)T

EIGRP support was added.

12.2(18)S

EIGRP support was added.


Usage Guidelines

This command can be abbreviated to exit.

Examples

The following example shows how to exit address family configuration mode:

exit-address-family

Related Commands

Command
Description

address-family ipv4 (EIGRP)

Enters address family configuration mode for EIGRP.


ip vrf

To configure a VPN routing and forwarding (VRF) routing table, use the ip vrf command in global configuration mode or router configuration mode. To remove a VRF routing table, use the no form of this command.

ip vrf vrf-name

no ip vrf vrf-name

Syntax Description

vrf-name

Name assigned to a VRF.


Defaults

No VRFs are defined. No import or export lists are associated with a VRF. No route maps are associated with a VRF.

Command Modes

Global configuration

Router configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

The ip vrf vrf-name command creates a VRF routing table and a Cisco Express Forwarding (CEF) table. The vrf-name argument is used to apply a unique name or tag. The rd command is used to associate the VRF routing table with the route distinguisher.

Examples

The following example imports a route map to a VRF:

ip vrf vpn1 
 rd 100:2
 route-target both 100:2
 route-target import 100:1

Related Commands

Command
Description

ip vrf forwarding (interface configuration)

Associates a VRF with an interface or subinterface.


network (EIGRP)

To specify the network for an EIGRP routing process, use the network command in router configuration mode. To remove an entry, use the no form of this command.

network ip-address [wildcard-mask]

no network ip-address [wildcard-mask]

Syntax Description

ip-address

IP address of the directly connected networks.

wildcard-mask

(Optional) Wildcard mask.


Defaults

No networks are specified.

Command Modes

Address family configuration

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

12.0(22)S

Address family support for EIGRP was added.

12.2(15)T

Address family support for EIGRP was added.

12.2(18)S

Address family support for EIGRP was added.


Usage Guidelines

When the network command is configured for an EIGRP routing process, the router matches one or more local interfaces. The network command will match only local interfaces that are configured with addresses that are within the same wildcard mask range as the address that has been configured with the network command. The router will then establish neighbors through the matched interfaces. There is no limit to the number of network statements (network commands) that can be configured on a router.

Examples

The following example configures EIGRP autonomous system 101 and establishes neighbors through network 172.16.0.0 and 192.168.7.0:

router eigrp 101
 network 172.16.0.0
 network 192.168.7.0 

rd

To create routing and forwarding tables for a VRF, use the rd command in VRF configuration mode.

rd route-distinguisher

Syntax Description

route-distinguisher

Adds an 8-byte value to an IPv4 prefix to create a VPN IPv4 prefix.


Defaults

There is no default. A route distinguisher (RD) must be configured for a VRF to be functional.

Command Modes

VRF configuration

Command History

Release
Modification

12.0(5)T

This command was introduced.


Usage Guidelines

An RD creates routing and forwarding tables and specifies the default route distinguisher for a VPN. The RD is added to the beginning of the customer's IPv4 prefixes to change them into globally unique VPN IPv4 prefixes.

There are two formats for configuring the route-distinguisher argument. It can be configured in the as-number:network number (ASN:nn) format, or it can be configured in the IP address:network number format (IP-address:nn). The network number is an arbitrary number

You can enter an RD in either of these formats:

16-bit AS number: your 32-bit number
For example, 101:3.

32-bit IP address: your 16-bit number
For example, 192.168.122.15:1.

Examples

The following example configures a default RD for two VRFs. It illustrates the use of both AS-relative and IP-address-relative RDs:

ip vrf BLUE
 rd 100:3
!
ip vrf RED
 rd 172.16.0.12:200

Related Commands

Command
Description

ip vrf

Configures a VRF routing table.

show ip vrf

Displays the set of defined VRFs and associated interfaces.


redistribute (IP)

To redistribute routes from one routing domain into another routing domain, use the redistribute command in router configuration mode. To disable redistribution, use the no form of this command.

redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [tag tag-value] [route-map map-tag] [weight number-value] [subnets]

no redistribute protocol [process-id] {level-1 | level-1-2 | level-2} [as-number] [metric metric-value] [metric-type type-value] [match {internal | external 1 | external 2}] [ tag tag-value] [route-map map-tag] [weight number-value] [subnets]

Syntax Description

protocol

Source protocol from which routes are being redistributed. It can be one of the following keywords: bgp, connected, eigrp, igrp, isis, mobile, ospf, static [ip], or rip.

The static [ip] keyword is used to redistribute IP static routes. The optional ip keyword is used when redistributing into the Intermediate System-to-Intermediate System (IS-IS) protocol.

The connected keyword refers to routes that are established automatically by virtue of having enabled IP on an interface. For routing protocols such as Open Shortest Path First (OSPF) and IS-IS, these routes will be redistributed as external to the autonomous system.

process-id

(Optional) For the bgp, egp, or igrp keyword, this is an autonomous system number, which is a 16-bit decimal number.

For the isis keyword, this is an optional tag value that defines a meaningful name for a routing process. You can specify only one IS-IS process per router. Creating a name for a routing process means that you use names when configuring routing.

For the ospf keyword, this is an appropriate OSPF process ID from which routes are to be redistributed. This identifies the routing process. This value takes the form of a nonzero decimal number.

For the rip keyword, no process-id value is needed.

level-1

Specifies (for IS-IS) that Level 1 routes are redistributed into other IP routing protocols independently.

level-1-2

Specifies (for IS-IS) that both Level 1 and Level 2 routes are redistributed into other IP routing protocols.

level-2

Specifies (for IS-IS) that Level 2 routes are redistributed into other IP routing protocols independently.

as-number

(Optional) Autonomous system number for the redistributed route.

metric metric-value

(Optional) Metric used for the redistributed route. If a value is not specified for this option, and no value is specified using the default-metric command, the default metric value is 0. Use a value consistent with the destination protocol.

metric-type type-value

(Optional) For OSPF, the external link type associated with the default route advertised into the OSPF routing domain. It can be one of two values:

1—Type 1 external route

2—Type 2 external route

If a metric-type is not specified, the Cisco IOS software adopts a Type 2 external route.

For IS-IS, it can be one of two values:

internal—IS-IS metric that is < 63.

external—IS-IS metric that is > 64 < 128.

The default is internal.

match {internal | external 1 | external 2}

(Optional) Specifies the criteria by which OSPF routes are redistributed into other routing domains. It can be one of the following:

internal—Routes that are internal to a specific autonomous system.

external 1—Routes that are external to the autonomous system, but are imported into OSPF as Type 1 external routes.

external 2—Routes that are external to the autonomous system, but are imported into OSPF as Type 2 external routes.

tag tag-value

(Optional) A 32-bit decimal value attached to each external route. This is not used by OSPF itself. It may be used to communicate information between Autonomous System Boundary Routers (ASBRs). If none is specified, then the remote autonomous system number is used for routes from Border Gateway Protocol (BGP) and Exterior Gateway Protocol (EGP); for other protocols, zero (0) is used.

route-map

(Optional) Route map that should be interrogated to filter the importation of routes from this source routing protocol to the current routing protocol. If not specified, all routes are redistributed. If this keyword is specified, but no route map tags are listed, no routes will be imported.

map-tag

(Optional) Identifier of a configured route map.

weight number-value

(Optional) Network weight when redistributing into BGP. An integer from 0 to 65,535.

subnets

(Optional) For redistributing routes into OSPF, the scope of redistribution for the specified protocol.


Defaults

Route redistribution is disabled.

protocol: No source protocol is defined.

process-id: No process ID is defined.

metric metric-value: 0

metric-type type-value: Type 2 external route

match {internal | external}: Internal, external 1, external 2

external: Internal

tag tag-value: If no value is specified, the remote autonomous system number is used for routes from BGP and EGP; for other protocols, the default is 0.

route-map map-tag: If the route-map keyword is not entered, all routes are redistributed.

weight number-value: No network weight is defined.

subnets: No subnets are defined.

Command Modes

Address family configuration

Router configuration

Command History

Release
Modification

10.0

This command was introduced.

12.0(5)T

Address family configuration mode was added.

12.0(22)S

Address family support under EIGRP was added.

12.2(15)T

Address family support under EIGRP was added.

12.2(18)S

Address family support under EIGRP was added.


Usage Guidelines

Changing or disabling any keyword will not affect the state of other keywords.

A router receiving a link-state protocol with an internal metric will consider the cost of the route from itself to the redistributing router plus the advertised cost to reach the destination. An external metric only considers the advertised metric to reach the destination.

Routes learned from IP routing protocols can be redistributed at Level 1 into an attached area or at Level 2. The level-1-2 keyword allows both Level 1 and Level 2 routes in a single command.

Redistributed routing information must be filtered by the distribute-list out router configuration command. This guideline ensures that only those routes intended by the administrator are passed along to the receiving routing protocol.

Whenever you use the redistribute or the default-information router configuration command to redistribute routes into an OSPF routing domain, the router automatically becomes an ASBR. However, an ASBR does not, by default, generate a default route into the OSPF routing domain.

When routes are redistributed between OSPF processes, no OSPF metrics are preserved.

When routes are redistributed into OSPF and no metric is specified with the metric keyword, OSPF uses a default metric of 20 for routes from all protocols except BGP, which is assigned a metric of 1. Furthermore, when the router redistributes from one OSPF process to another OSPF process on the same router, and if no default metric is specified, the metrics in one process are carried to the redistributing process.

When redistributing routes into OSPF, only routes that are not subnetted are redistributed if the subnets keyword is not specified.

Routes configured with the connected keyword affected by this redistribute command are the routes not specified by the network router configuration command.

You cannot use the default-metric command to affect the metric used to advertise connected routes.


Note The metric value specified in the redistribute command supersedes the metric value specified using the default-metric command.


Default redistribution of IGPs or EGP into BGP is not allowed unless the default-information originate router configuration command is specified.

Examples

The following example causes OSPF routes to be redistributed into a BGP network:

router bgp 109
 redistribute ospf 901

The following example causes Enhanced Interior Gateway Routing Protocol (EIGRP) routes to be redistributed into an OSPF network:

router ospf 101
 redistribute eigrp 202

The following example causes the specified EIGRP process routes to be redistributed into an OSPF network. The EIGRP-derived metric will be remapped to 100 and RIP routes to 200.

router ospf 303
 redistribute eigrp 404 metric 100 subnets
 redistribute rip metric 200 subnets

The following example configures BGP routes to be redistributed into IS-IS. The link-state cost is specified as 5, and the metric type will be set to external, indicating that it has lower priority than internal metrics.

router isis
 redistribute bgp 101 metric 5 metric-type external

In the following example, network 172.16.0.0 will appear as an external link-state advertisement (LSA) in OSPF 1 with a cost of 100 (the cost is preserved):

interface ethernet 0
 ip address 172.16.0.1 255.0.0.0
 ip ospf cost 100
interface ethernet 1
 ip address 10.0.0.1 255.0.0.0
!
router ospf 1
 network 10.0.0.0 0.255.255.255 area 0
 redistribute ospf 2 subnet
router ospf 2
 network 172.16.0.0 0.255.255.255 area 0

The following example configuration creates a VRF named RED under EIGRP to be redistributed through a BGP network:

router eigrp 1
 address-family ipv4 vrf RED
 autonomous-system 101
 network 172.16.0.0
 redistribute BGP 10 metric 10000 100 255 1 1500

 exit-address-family

Related Commands

Command
Description

address-family ipv4 (BGP)

Places the router in address family configuration mode for configuring routing sessions such as BGP, RIP, or static routing sessions that use standard IPv4 address prefixes.

address-family ipv4 (EIGRP)

Places the router in address family configuration mode for an EIGRP process.

address-family vpnv4

Places the router in address family configuration mode for configuring routing sessions such as BGP, RIP, or static routing sessions that use standard VPNv4 address prefixes.

default-information originate (BGP)

Allows the redistribution of network 0.0.0.0 into BGP.

default-information originate (IS-IS)

Generates a default route into an IS-IS routing domain.

default-information originate (OSPF)

Generates a default route into an OSPF routing domain.

distribute-list out (IP)

Suppresses networks from being advertised in updates.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

show route-map

Displays all route maps configured or only the one specified.


show ip eigrp vrf interfaces

To display information about interfaces that carry virtual routing and forwarding instance (VRF) information and are configured for Enhanced Interior Gateway Routing Protocol (EIGRP), use the show ip eigrp vrf interfaces command in privileged EXEC mode.

show ip eigrp vrf {vrf-name | *} interfaces [as-number] [interface-type] [detail interface-type] [static interface-type]

Syntax Description

vrf-name

Specifies the VRF name.

The * keyword can be used as a wild card to display all VRFs, instead of specifying a single VRF with the vrf-name argument.

as-number

(Optional) Specifies the autonomous system number.

interface-type

(Optional) Specifies the VRF interface for which to display EIGRP information.

detail interface-type

(Optional) Displays detailed VRF peer information. The interface can be specified after this keyword is entered.

static interface-type

(Optional) Displays VRF information for static neighbors. The interface can be specified after this keyword is entered. The interface-type argument allows you to display information about static neighbors for VRFs that are configured on specific interfaces.


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.


Usage Guidelines

Use the show ip eigrp vrf interfaces command to display EIGRP interfaces that are defined under the specified VRF. If an interface is specified with the interface-type argument, only the specified interface is displayed. Otherwise, all interfaces on which EIGRP is running as part of the specified VRF are displayed.

Examples

The following is sample output from the show ip eigrp vrf interfaces command:

Router# show ip eigrp vrf PINK interfaces
IP-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et3/0              1        0/0       131       0/10         528        0

Table 2 describes the significant fields shown in the display.

Table 2 show ip eigrp vrf interfaces Field Descriptions 

Field
Description

IP-EIGRP interfaces for process...

Displays the autonomous-system number for the specified VRF.

Interface

Interface over which EIGRP is configured.

Peers

Number of directly connected EIGRP neighbors.

Xmit Queue Un/Reliable

Number of packets remaining in the Unreliable and Reliable transmit queues.

Mean SRTT

Mean smooth round-trip time (SRTT) interval (in seconds).

Pacing Time Un/Reliable

Pacing time used to determine when EIGRP packets should be sent out the interface (unreliable and reliable packets).

Multicast Flow Timer

Maximum number of seconds in which the router will send multicast EIGRP packets.

Pending Routes

Number of routes in the packets in the transmit queue waiting to be sent.


Related Commands

Command
Description

clear ip eigrp vrf neighbor

Clears neighbor entries of the specified VRF from the RIB.

show ip eigrp vrf neighbors

Displays neighbors discovered by EIGRP that carry VRF information.

show ip eigrp vrf topology

Displays VRF entries in the EIGRP topology table.

show ip eigrp vrf traffic

Displays EIGRP VRF traffic statistics.


show ip eigrp vrf neighbors

To display EIGRP neighbors that are on interfaces that are part of the specified VRF, use the show ip eigrp vrf neighbors command in privileged EXEC mode.

show ip eigrp vrf {vrf-name| *} neighbors [as-number] [interface-type] [detail interface-type] [static interface-type]

Syntax Description

vrf-name

Specifies the VRF name. The * keyword can be used as a wild card to display all VRFs, instead of specifying a single VRF with the vrf-name argument.

as-number

(optional) Specifies the autonomous system number.

interface-type

(optional) Specifies the interface to display neighbor information under the specified VRF.

detail interface-type

(optional) Displays detailed VRF peer information. The interface can be specified after this keyword is entered.

static interface-type

(optional) Displays VRF information for static neighbors. The interface can be specified after this keyword is entered. The interface-type argument allows you to display information about static neighbors for VRFs that are configured on specific interfaces.


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.


Usage Guidelines

Use the show ip eigrp vrf neighbors command to determine when VRF neighbors become active and inactive. This command is also useful for debugging certain types of transport problems.

Examples

The following is sample output from the show ip eigrp vrf neighbors command:

Router# show ip eigrp vrf GREEN neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q
Seq Type
                                            (sec)         (ms)       Cnt
Num

0 10.10.10.2 Et3/0 10 1d16h 131 786 0 3

Table 3 describes the significant fields shown in the display.

Table 3 show ip eigrp vrf neighbors Field Descriptions 

Field
Description

IP-EIGRP neighbors for process...

Displays the autonomous-system number for the specified EIGRP VRF.

Address

IP address of the EIGRP peer.

Interface

Interface on which the router is receiving hello packets from the peer.

Hold Uptime

Length of time (in seconds) that the Cisco IOS software will wait to hear from the peer before declaring it down, and the length in time (in seconds) since the local router first heard from this neighbor.

SRTT

Smooth round-trip time. This is the number of milliseconds required for an EIGRP packet to be sent to this neighbor and for the local router to receive an acknowledgment of that packet.

RTO

Retransmission timeout (in milliseconds). This is the amount of time the software waits before resending a packet from the retransmission queue to a neighbor.

Q

Number of EIGRP packets (update, query, and reply) that the software is waiting to send.


show ip eigrp vrf topology

To display VRF entries in the EIGRP topology table, use the show ip eigrp topology command in privileged EXEC mode.

show ip eigrp vrf {vrf-name | *} topology [as-number] [ip-address [mask]] [active | all-links | pending | summary | zero-successors]

Syntax Description

vrf-name

Specifies the VRF name. The * keyword can be used as a wild card to display all VRFs, instead of specifying a single VRF with the vrf-name argument.

as-number

(Optional) Autonomous system number.

ip-address

(Optional) IP address. When specified with a mask, a detailed description of the entry is provided.

mask

(Optional) Subnet mask.

active

(Optional) Displays only active entries in the EIGRP topology table.

all-links

(Optional) Displays all entries in the EIGRP topology table.

pending

(Optional) Displays all entries in the EIGRP topology table that are waiting for an update from a neighbor or are waiting to reply to a neighbor.

summary

(Optional) Displays a summary of the EIGRP topology table.

zero-successors

(Optional) Displays available routes in the EIGRP topology table.


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(15)T.


Usage Guidelines

The show ip eigrp vrf topology command can be used without any keywords or arguments, but you must specify either a VRF name or use * character as a wild card in place of the vrf-name argument. If this command is this way, only routes that are feasible successors are displayed. The show ip eigrp vrf topology command can be used to determine Diffusing Update Algorithm (DUAL) states and to debug possible DUAL problems.

Examples

The following is sample output from the show ip eigrp vrf topology command:

Router# show ip eigrp vrf PINK topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.10.1) Routing Table:PINK

Codes:P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.17.17.0/24, 1 successors, FD is 409600
         via 10.10.10.2 (409600/128256), Ethernet3/0
P 172.16.19.0/24, 1 successors, FD is 409600
         via 10.10.10.2 (409600/128256), Ethernet3/0
P 192.168.10.0/24, 1 successors, FD is 281600
         via Connected, Ethernet3/0
P 10.10.10.0/24, 1 successors, FD is 281600
         via Redistributed (281600/0)

Table 4 describes the significant fields shown in the display.

Table 4 show ip vrf eigrp topology Field Descriptions 

Field
Description

Codes

State of this topology table entry. Passive and Active refer to the EIGRP state with respect to this destination; Update, Query, and Reply refer to the type of packet that is being sent.

P - Passive

No EIGRP computations are being performed for this destination.

A - Active

EIGRP computations are being performed for this destination.

U - Update

Indicates that an update packet was sent to this destination.

Q - Query

Indicates that a query packet was sent to this destination.

R - Reply

Indicates that a reply packet was sent to this destination.

r - reply Status

Flag that is set after the software has sent a query and is waiting for a reply.

s - sia Status

Flag that is set if a route is in a stuck in active state.

successors

Number of successors. This number corresponds to the number of next hops in the IP routing table. If "successors" is capitalized, then the route or next hop is in a transition state.

FD

Feasible distance. The feasible distance is the best metric to reach the destination or the best metric that was known when the route went active. This value is used in the feasibility condition check. If the reported distance of the router (the metric after the slash) is less than the feasible distance, the feasibility condition is met and that path is a feasible successor. Once the software determines it has a feasible successor, it need not send a query for that destination.

replies

(Not shown in the output) Number of replies that are still outstanding (have not been received) with respect to this destination. This information appears only when the destination is in Active state.

state

(Not shown in the output) Exact EIGRP state that this destination is in. It can be the number 0, 1, 2, or 3. This information appears only when the destination is in the active state.

via

IP address of the peer that told the software about this destination. The first N of these entries, where N is the number of successors, is the current successors. The remaining entries on the list are feasible successors.

(409600/128256)

The first number is the EIGRP metric that represents the cost to the destination. The second number is the EIGRP metric that this peer advertised.

Ethernet 3/0

Interface from which this information was learned.


show ip eigrp vrf traffic

To display sent and received statistics for EIGRP VRF packets, use the show ip eigrp vrf traffic command in privileged EXEC mode.

show ip eigrp vrf {vrf-name| *} traffic [as-number]

Syntax Description

vrf-name

Specifies the VRF name. The * keyword can be used as a wild card to display all VRFs, instead of specifying a single VRF with the vrf-name argument.

as-number

(Optional) Specifies the autonomous system number.


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.2(15)T

This command was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

This command was integrated into Cisco IOS Release 12.2(18)S.


Examples

The following is sample output from the show ip eigrp vrf traffic command:

Router# show ip eigrp vrf RED traffic 
IP-EIGRP Traffic Statistics for AS 101
  Hellos sent/received: 600/585
  Updates sent/received: 23/22
  Queries sent/received: 7/0
  Replies sent/received: 0/6
  Acks sent/received: 55/42
  Input queue high water mark 0, 0 drops

Table 5 describes the significant fields shown in the display.

Table 5 show ip eigrp vrf traffic Field Descriptions 

Field
Description

IP-EIGRP Traffic Statistics for AS...

Displays the autonomous system number for the specified EIGRP VRF.

Hellos sent/received

Number of hello packets sent and received.

Updates sent/received

Number of update packets sent and received.

Queries sent/received

Number of query packets sent and received.

Replies sent/received

Number of reply packets sent and received.

Acks sent/received

Number of acknowledgment packets sent and received.

Input queue high water mark..., ... drops

Number of received packets that are approaching the maximum receive threshold and number of dropped packets.


show ip protocols vrf

To display the routing protocol information associated with a VRF, use the show ip protocols vrf command in EXEC mode.

show ip protocols vrf {vrf-name} [summary]

Syntax Description

vrf-name

Name assigned to a VRF.

summary

(Optional) Displays abbreviated output.


Defaults

No default behavior or values

Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(22)S

The summary keyword was added. EIGRP VRF support was added.

12.2(15)T

The summary keyword was added. EIGRP VRF support was added.

12.2(18)S

The summary keyword was added. EIGRP VRF support was added.


Usage Guidelines

Use this command to display routing information associated with a VRF.

Examples

The following example shows information about a VRF named vpn1:

router# show ip protocols vrf vpn1

Routing Protocol is "bgp 100"
  Sending updates every 60 seconds, next due in 0 sec
  Outgoing update filter list for all interfaces is 
  Incoming update filter list for all interfaces is 
  IGP synchronization is disabled
  Automatic route summarization is disabled
  Redistributing:connected, static
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.13.13.13          200      02:20:54
    10.18.18.18          200      03:26:15
  Distance:external 20 internal 200 local 200

Table 6 describes the significant fields shown in the output.

Table 6 show ip protocols vrf Field Descriptions 

Field
Description

Gateway

Displays the IP address of the router identifier for all routers in the network.

Distance

Displays the metric used to access the destination route.

Last Update

Displays the last time (in hours:minutes:seconds) that the routing table was updated from the source.


Related Commands

Command
Description

show ip vrf

Displays the set of defined VRFs and associated interfaces.



show ip route vrf

To display the IP routing table associated with a VRF, use the show ip route vrf command in EXEC mode.

show ip route vrf vrf-name [connected] [protocol [as-number] [tag] [output-modifiers]] [list number [output-modifiers]] [profile] [static [output-modifiers]] [summary [output-modifiers]] [supernets-only [output-modifiers]] [traffic-engineering [output-modifiers]]

Syntax Description

vrf-name

Name assigned to the VRF.

connected

(Optional) Displays all connected routes in a VRF.

protocol

(Optional) To specify a routing protocol, use one of the following keywords: bgp, egp, eigrp, hello, igrp, isis, ospf, or rip.

as-number

(Optional) Autonomous system number.

tag

(Optional) Cisco IOS routing area label.

output-modifiers

(Optional) For a list of associated keywords and arguments, use context-sensitive help.

list number

(Optional) Specifies the IP access list to display.

profile

(Optional) Displays the IP routing table profile.

static

(Optional) Displays static routes.

summary

(Optional) Displays a summary of routes.

supernets-only

(Optional) Displays supernet entries only.

traffic-engineering

(Optional) Displays only traffic-engineered routes.


Defaults

No default behavior or values

Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(22)S

EIGRP VRF support was added.

12.2(15)T

EIGRP VRF support was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

EIGRP VRF support was integrated into Cisco IOS Release 12.2(18)S.


Usage Guidelines

This command displays specified information from the IP routing table of a VRF.

Examples

This example shows the IP routing table associated with the VRF named vrf1:

router# show ip route vrf vrf1

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR
       T - traffic engineered route
 
Gateway of last resort is not set
 
B    10.51.0.0/8 [200/0] via 10.13.13.13, 00:24:19
C    10.10.0.0/8 is directly connected, Ethernet1/3
B    10.11.0.0/8 [20/0] via 10.0.0.1, 02:10:22
B    10.12.0.0/8 [200/0] via 10.13.13.13, 00:24:20

This example shows BGP entries in the IP routing table associated with the VRF named vrf1:

Router# show ip route vrf vrf1 bgp

B  10.51.0.0/8 [200/0] via 10.13.13.13, 03:44:14
B  10.11.0.0/8 [20/0] via 10.51.0.1, 03:44:12
B  10.12.0.0/8 [200/0] via 10.13.13.13, 03:43:14

Related Commands

Command
Description

show ip cache

Displays the CEF forwarding table associated with a VRF.

show ip vrf

Displays the set of defined VRFs and associated interfaces.


show ip vrf

To display the set of defined VRFs and associated interfaces, use the show ip vrf command in EXEC mode.

show ip vrf [brief | detail | interfaces] [vrf-name] [output-modifiers]

Syntax Description

brief

(Optional) Displays concise information on the VRFs and associated interfaces.

detail

(Optional) Displays detailed information on the VRFs and associated interfaces.

interfaces

(Optional) Displays detailed information about all interfaces bound to a particular VRF, or any VRF.

vrf-name

(Optional) Name assigned to a VRF.


Defaults

When no optional parameters are specified, the command shows concise information about all configured VRFs.

Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(22)S

EIGRP VRF support was added.

12.2(15)T

EIGRP VRF support was integrated into Cisco IOS Release 12.2(15)T.

12.2(18)S

EIGRP VRF support was integrated into Cisco IOS Release 12.2(18)S.


Usage Guidelines

Use this command to display information about VRFs. Two levels of detail are available: use the brief keyword or no keyword to display concise information, or use the detail keyword to display all information. To display information about all interfaces bound to a particular VRF, or to any VRF, use the interfaces keyword.

Examples

This example shows brief information for the VRFs currently configured:

Router# show ip vrf
  Name                Default RD          Interfaces
  vrf1                100:1               Ethernet1/3
  vrf2                100:2               Ethernet0/3

Table 7 describes the fields shown in this example.

Table 7 show ip vrf Field Descriptions 

Field
Description

Name

Specifies the VRF name.

Default RD

Specifies the default route distinguisher.

Interfaces

Specifies the network interfaces.


This example shows detailed information for the VRF called vrf1:

Router# show ip vrf detail vrf1
VRF vrf1; default RD 100:1
 Interfaces:
  Ethernet1/3
 Connected addresses are in global routing table
 Export VPN route-target communities
  RT:100:1
 Import VPN route-target communities
  RT:100:1
 No import route-map

Table 8 describes the significant fields shown in the output.

Table 8 show ip vrf detail Field Descriptions

Field
Description

Interfaces

Specifies the network interfaces.

Export

Specifies VPN route-target export communities.

Import

Specifies VPN route-target import communities.


This example shows the interfaces bound to a particular VRF:

Router# show ip vrf interfaces
Interface       IP-Address      VRF                       Protocol
Ethernet2       10.22.0.33      blue_vrf                  up      
Ethernet4       10.77.0.33      hub                       up      

Table 9 describes the significant fields shown in the output.

Table 9 show ip vrf interfaces Field Descriptions

Field
Description

Interface

Specifies the network interfaces for a VRF.

IP-Address

Specifies the IP address of a VRF interface.

VRF

Specifies the VRF name.

Protocol

Displays the state of the protocol (up/down) for each VRF interface.


Related Commands

Command
Description

import map

Configures an import route map for a VRF.

ip vrf

Configures a VRF routing table.

ip vrf forwarding (interface configuration)

Associates a VRF with an interface or subinterface.

rd

Creates routing and forwarding tables for a VRF.

route-target

Creates a route-target extended community for a VRF.