Guest

Cisco IOS Software Releases 12.0 S

OSPF Per-Interface Link-Local Signaling

  • Viewing Options

  • PDF (250.3 KB)
  • Feedback
OSPF Per-Interface Link-Local Signaling

Table Of Contents

OSPF Per-Interface Link-Local Signaling

Contents

Information About OSPF Per-Interface Link-Local Signaling

Benefits of the OSPF Per-Interface Link-Local Signaling Feature

How to Configure the OSPF Per-Interface Link-Local Signaling Feature

Turning Off LLS on a Per-Interface Basis

What to Do Next

Configuration Examples for the OSPF Per-Interface Link-Local Signaling Feature

Configuring and Verifying the OSPF Per-Interface Link-Local Signaling Feature: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

ip ospf lls

Feature Information for OSPF Per-Interface Link-Local Signaling


OSPF Per-Interface Link-Local Signaling


The OSPF Per-Interface Link-Local Signaling feature allows you to selectively enable or disable Link-Local Signaling (LLS) for a specific interface regardless of the global (router level) setting that you have previously configured.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for OSPF Per-Interface Link-Local Signaling" section.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Information About OSPF Per-Interface Link-Local Signaling

How to Configure the OSPF Per-Interface Link-Local Signaling Feature

Configuration Examples for the OSPF Per-Interface Link-Local Signaling Feature

Additional References

Command Reference

Feature Information for OSPF Per-Interface Link-Local Signaling

Information About OSPF Per-Interface Link-Local Signaling

Before configuring the feature, you should understand the concept in the following section:

Benefits of the OSPF Per-Interface Link-Local Signaling Feature

Benefits of the OSPF Per-Interface Link-Local Signaling Feature

LLS allows for the extension of existing OSPF packets in order to provide additional bit space. The additional bit space enables greater information per packet exchange between OSPF neighbors. This functionality is used, for example, by the OSPF Nonstop Forwarding (NSF) Awareness feature that allows customer premises equipment (CPE) routers that are NSF-aware to help NSF-capable routers perform nonstop forwarding of packets.

When LLS is enabled at the router level, it is automatically enabled for all interfaces. The OSPF Per-Interface Link-Local Signaling feature allows you to selectively enable or disable LLS for a specific interface. You may want to disable LLS on a per-interface basis depending on your network design. For example, disabling LLS on an interface that is connected to a non-Cisco device that may be noncompliant with RFC 2328 can prevent problems with the forming of Open Shortest Path First (OSPF) neighbors in the network.

How to Configure the OSPF Per-Interface Link-Local Signaling Feature

This section contains the following procedure:

Turning Off LLS on a Per-Interface Basis (optional)

Turning Off LLS on a Per-Interface Basis

This task disables LLS on a specific interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type slot/port

4. ip address ip-address mask [secondary]

5. no ip directed-broadcast [access-list-number | extended access-list-number]

6. ip ospf message-digest-key key-id encryption-type md5 key

7. [no | default] ip ospf lls [disable]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type slot/port

Example:

Router(config)# interface Ethernet 1/0


Configures an interface type and enters interface configuration mode.

Step 4 

ip address ip-address mask [secondary]

Example:

Router(config-if)# ip address 10.2.145.20 255.255.255.0

Sets a primary or secondary IP address for an interface.

Step 5 

no ip directed-broadcast [access-list-number | extended access-list-number]

Example:

Router(config-if)# no ip directed-broadcast

Drops directed broadcasts destined for the subnet to which that interface is attached, rather than broadcasting them.

The forwarding of IP directed broadcasts on Ethernet interface 1/0 is disabled.

Step 6 

ip ospf message-digest-key key-id encryption-type 
md5 key
Example:

Router(config-if)# ip ospf message-digest-key 100 md5 testing

Enables OSPF Message Digest 5 (MD5) algorithm authentication.

Step 7 

[no | default] ip ospf lls [disable]

Example:

Router(config-if)# ip ospf lls disable

Disables LLS on an interface, regardless of the global (router level) setting.

What to Do Next

To verify that LLS has been enabled or disabled for a specific interface, use the show ip ospf interface command. See the "Configuring and Verifying the OSPF Per-Interface Link-Local Signaling Feature: Example" section for an example of the information displayed.

Configuration Examples for the OSPF Per-Interface Link-Local Signaling Feature

This section contains the following configuration example:

Configuring and Verifying the OSPF Per-Interface Link-Local Signaling Feature: Example

Configuring and Verifying the OSPF Per-Interface Link-Local Signaling Feature: Example

In the following example, LLS has been enabled on Ethernet interface 1/0 and disabled on Ethernet interface 2/0:

interface Ethernet1/0
 ip address 10.2.145.2 255.255.255.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 testing
 ip ospf lls
!
interface Ethernet2/0
 ip address 10.1.145.2 255.255.0.0
 no ip directed-broadcast
 ip ospf message-digest-key 1 md5 testing
!
 ip ospf lls disable
interface Ethernet3/0
 ip address 10.3.145.2 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 log-adjacency-changes detail
 area 0 authentication message-digest
 redistribute connected subnets
 network 10.0.0.0 0.255.255.255 area 1
 network 10.2.3.0 0.0.0.255 area 1

In the following example, the show ip ospf interface command has been entered to verify that LLS has been enabled for Ethernet interface 1/0 and disabled for interface Ethernet 2/0:

Router# show ip ospf interface

Ethernet1/0 is up, line protocol is up 
  Internet Address 10.2.145.2/24, Area 1 
  Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 10.2.2.3, Interface address 10.2.145.1
  Backup Designated router (ID) 10.22.222.2, Interface address 10.2.145.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
!   Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 8
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 10.2.2.3  (Designated Router)
  Suppress hello for 0 neighbor(s)
Ethernet2/0 is up, line protocol is up 
  Internet Address 10.1.145.2/16, Area 1 
  Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 10.2.2.3, Interface address 10.1.145.1
  Backup Designated router (ID) 10.22.222.2, Interface address 10.1.145.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
!   Does not support Link-local Signaling (LLS)
Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 11
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 45.2.2.3  (Designated Router)
    Suppress hello for 0 neighbor(s)
Ethernet3/0 is up, line protocol is up 
  Internet Address 10.3.145.2/24, Area 1 
  Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 10.2.2.3, Interface address 10.3.145.1
  Backup Designated router (ID) 10.22.222.2, Interface address 10.3.145.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:07
!   Supports Link-local Signaling (LLS)
Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 11
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 10.2.2.3  (Designated Router)
  Suppress hello for 0 neighbor(s)

Additional References

The following sections provide references related to the OSPF Per-Interface Link-Local Signaling feature.

Related Documents

Related Topic
Document Title

Configuring OSPF

Cisco IOS IP Configuration Guide, Release 12.4

Configuring OSPF NSF Awareness

OSPF Nonstop Forwarding (NSF) Awareness

OSPF commands

Cisco IOS IP Routing Protocols Command Reference, Release 12.2(33)SRA


Standards

Standards
Title

None


MIBs

MIBs
MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 2328

OSPF Version 2


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents a modified command only.

ip ospf lls

ip ospf lls

To enable Link-Local Signaling (LLS) on an interface, regardless of the router-level LLS setting, use the ip ospf lls command in interface configuration mode. To reconfigure the router-level LLS setting on the specific interface, use the no or default version of this command.

ip ospf lls [disable]

{no | default} ip ospf lls [disable]

Syntax Description

no

Restores the default LLS setting for the interface that has been configured at the router level.

default

Inherits the global (router level) LLS settings for the interface that has been specified.

disable

(Optional) Disables LLS on a specified interface regardless of the global (router level) setting.


Command Default

LLS is enabled.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.3(7)T

This command was integrated into Cisco IOS Release 12.3(7)T.

12.2(25)S

This command was integrated into Cisco IOS Release 12.2(25)S.

12.2(18)SXE

This command was integrated into Cisco IOS Release 12.2(18)SXE.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

By default, each Open Shortest Path First (OSPF) interface inherits the LLS setting from the router level. The ip ospf lls interface-level command takes precedence over the capability lls router-level command. For example, if you have entered the no capability lls command to disable LLS at the router level, you can use the ip ospf lls command to selectively enable LLS for specific interfaces, in order to allow the router to enable OSPF nonstop forwarding (NSF) awareness only for these specified interfaces.

To unconfigure the interface LLS setting, enter either the default ip ospf lls command or the no ip ospf lls command to restore the default LLS setting for the interface that has been configured at the router level. For example, if the capability lls command is enabled (by default) at the router level, you can use either the default ip ospf lls command or the no ip ospf lls command to disable LLS on specific interfaces, for instance, to interoperate on network segments where there are routers that do not properly handle LLS.


Note If the network is running OSPF with the LLS feature enabled by default, LLS is globally enabled for all interfaces. If a router in the network is connected to a non-Cisco device that is not in compliance with RFC 2328, there may be network difficulties involving the forming of OSPF neighbors. In this situation, we recommend that you use the ip ospf lls command with the disable keyword to disable LLS on the router that is connected to the non-Cisco device.


Examples

In following example, LLS is disabled on Ethernet interface 2/0:

Router(config)# interface Ethernet2/0
Router(config-if)# ip address 10.1.145.2 255.255.0.0
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip ospf message-digest-key 1 md5 testing
Router(config-if)# ip ospf lls disable

Related Commands

Command
Description

capability lls

Enables the use of the LLS data block in originated OSPF packets and reenables OSPF NSF awareness.

show ip ospf interface

Displays OSPF-related interface information.


Feature Information for OSPF Per-Interface Link-Local Signaling

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for OSPF Per-Interface Link-Local Signaling 

Feature Name
Releases
Feature Information

OSPF Per-Interface Link-Local Signaling

12.0(27)S
12.3(7)T
12.2(25)S
12.2(18)SXE
12.2(27)SBC
12.2(33)SRA

The OSPF Per-Interface Link-Local Signaling feature allows you to selectively enable or disable Link-Local Signaling (LLS) for a specific interface regardless of the global (router level) setting that you have previously configured.