Guest

Cisco IOS Software Releases 12.0 S

OSPF Support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels

  • Viewing Options

  • PDF (236.9 KB)
  • Feedback
OSPF Support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels

Table Of Contents

OSPF Support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels

Contents

Prerequisites for OSPF Forwarding Adjacency

Information About OSPF Forwarding Adjacency

Benefits of OSPF Forwarding Adjacency

How to Configure OSPF Forwarding Adjacency

Configuring OSPF Forwarding Adjacency

Configuration Examples for OSPF Forwarding Adjacency

OSPF Forwarding Adjacency: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference


OSPF Support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels


The OSPF Support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels feature adds Open Shortest Path First (OSPF) support to the Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Forwarding Adjacency feature, which allows a network administrator to handle a traffic engineering, label-switched path (LSP) tunnel as a link in an Interior Gateway Protocol (IGP) network based on the shortest path first (SPF) algorithm. An OSPF forwarding adjacency can be created between routers in the same area.

History for the OSPF Support for Forwarding Adjacencies over MPLS Traffic Engineered Tunnels Feature

Release
Modification

12.0(24)S

This feature was introduced.

12.2(25)S

This feature was integrated into Cisco IOS Release 12.2(25)S.

12.2(18)SXE

This feature was integrated into Cisco IOS Release 12.2(18)SXE.

12.2(27)SBC

This feature was integrated into Cisco IOS Release 12.2(27)SBC.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for OSPF Forwarding Adjacency

Information About OSPF Forwarding Adjacency

How to Configure OSPF Forwarding Adjacency

Configuration Examples for OSPF Forwarding Adjacency

Additional References

Command Reference

Prerequisites for OSPF Forwarding Adjacency

OSPF must be configured in your network.

Cisco Express Forwarding (CEF) must be enabled.

You should understand MPLS TE tunnels for forwarding adjacency as described in MPLS Traffic Engineering Forwarding Adjacency at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s15/fs_tefa.htm

Information About OSPF Forwarding Adjacency

Before you configure the OSPF Forwarding Adjacency feature, you should understand the concept described in this section.

Benefits of OSPF Forwarding Adjacency

Benefits of OSPF Forwarding Adjacency

OSPF includes MPLS TE tunnels in the OSPF link-state database in the same way that other links appear for purposes of routing and forwarding traffic. When an MPLS TE tunnel is configured between networking devices, that link is considered a forwarding adjacency. The user can assign a cost to the tunnel to indicate the link's preference. Other networking devices will see the tunnel as a link in addition to the physical link.

How to Configure OSPF Forwarding Adjacency

This section contains the following procedure:

Configuring OSPF Forwarding Adjacency (required)

Configuring OSPF Forwarding Adjacency

This section describes how to configure the OSPF Forwarding Adjacency feature. You must configure a forwarding adjacency on two LSP tunnels bidirectionally, from A to B and B to A. Otherwise, the forwarding adjacency is advertised, but not used in the IGP network.

For the configuration to work, you need to set up a loopback interface with a 32-bit mask, enable CEF, enable MPLS traffic engineering, and set up a routing protocol (OSPF) for the MPLS network.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef distributed

4. mpls traffic-eng tunnels

5. interface loopback number

6. ip address ip-address mask

7. no shutdown

8. exit

9. interface tunnel number

10. tunnel mode mpls traffic-eng

11. tunnel mpls traffic-eng forwarding-adjacency {holdtime value}

12. ip ospf cost cost

13. exit

14. router ospf process-id

15. mpls traffic-eng router-id interface

16. mpls traffic-eng area number

17. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef distributed

Example:

Router(config)# ip cef distributed

Enables Cisco Express Forwarding (CEF).

Step 4 

mpls traffic-eng tunnels

Example:

Router(config)# mpls traffic-eng tunnels

Enables MPLS traffic engineering tunnel signaling on a device.

Step 5 

interface loopback number

Example:

Router(config)# interface loopback0

Configures a loopback interface and enters interface configuration mode.

Step 6 

ip address ip-address mask

Example:

Router(config-if)# ip address 10.1.1.1 255.255.255.255

Configures the IP address and subnet mask of the loopback interface.

Step 7 

no shutdown

Example:

Router(config-if)# no shutdown

Enables the interface.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 9 

interface tunnel number

Example:

Router(config)# interface tunnel 1

Designates a tunnel interface for the forwarding adjacency and enters interface configuration mode.

Step 10 

tunnel mode mpls traffic-eng

Example:

Router(config-if)# tunnel mode mpls traffic-eng

Sets the mode of a tunnel to MPLS for traffic engineering.

Step 11 

tunnel mpls traffic-eng forwarding-adjacency {holdtime value}

Example:

Router(config-if)# tunnel mpls traffic-eng forwarding-adjacency holdtime 10000

Advertises a TE tunnel as a link in an IGP network.

The holdtime value keyword argument combination is the time in milliseconds (ms) that a TE tunnel waits after going down before informing the network. The range is 0 to 4,294,967,295 ms. The default value is 0.

Step 12 

ip ospf cost cost

Example:

Router(config-if)# ip ospf cost 4

(Optional) Configures the cost metric for a tunnel interface to be used as a forwarding adjacency.

Step 13 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 14 

router ospf process-id

Example:

Router(config)# router ospf 1

Configures an OSPF routing process and enters router configuration mode.

Step 15 

mpls traffic-eng router-id interface

Example:

Router(config-router)# mpls traffic-eng router-id ethernet 1/0

Specifies that the traffic engineering router identifier for the node is the IP address associated with a given interface.

Step 16 

mpls traffic-eng area number

Example:

Router(config-router)# mpls traffic-eng area 1

Configures a router running OSPF MPLS so that it floods traffic engineering for the indicated OSPF area.

Step 17 

end

Example:

Router(config-router)# end

Exits router configuration mode.

Configuration Examples for OSPF Forwarding Adjacency

This section contains an example of configuring OSPF forwarding adjacency:

OSPF Forwarding Adjacency: Example

OSPF Forwarding Adjacency: Example

In the following example, the tunnel destination is the loopback interface on the other router. The router is configured with OSPF TE extensions and it floods traffic engineering link-state advertisements (LSAs) in OSPF area 0. The traffic engineering router identifier for the node is the IP address associated with Loopback 0. The last five lines of the example set up the routing protocol for the MPLS network, which is OSPF in this case.


Note Do not use the mpls traffic-eng autoroute announce command if you configure a forwarding adjacency in the tunnel.


ip routing
ip cef distributed
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 127.0.0.1 255.255.255.255
 no shutdown
!
interface Tunnel1
 ip unnumbered Loopback0
 no ip directed-broadcast
 tunnel destination 10.1.1.1
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng forwarding-adjacency holdtime 10000
 ip ospf cost 4
 tunnel mpls traffic-eng priority 2 2
 tunnel mpls traffic-eng bandwidth  10
 tunnel mpls traffic-eng path-option 2 dynamic

router ospf 5
 log-adjacency-changes
 network 10.1.1.1 0.0.0.0 area 0
 mpls traffic-eng router-id loopback0
 mpls traffic-eng area 0

When you look at the self-generated router LSA, you will see it as one of the links in router LSA (shown in bold in the following output).

Router# show ip ospf database route self-originate

OSPF Router with ID (10.5.5.5) (Process ID 5)

                Router Link States (Area 0)

  LS age:332
  Options:(No TOS-capability, DC)
  LS Type:Router Links
  Link State ID:10.5.5.5
  Advertising Router:10.5.5.5
  LS Seq Number:80000004
  Checksum:0x1D24
  Length:72
  Number of Links:4

    Link connected to another Router (point-to-point)
     (Link ID) Neighboring Router ID:10.3.3.3
     (Link Data) Router Interface address:0.0.0.23
      Number of TOS metrics:0
       TOS 0 Metrics:1562 

    Link connected to:a Transit Network
     (Link ID) Designated Router address:172.16.0.1
     (Link Data) Router Interface address:172.16.0.2
      Number of TOS metrics:0
       TOS 0 Metrics:10

    Link connected to:a Transit Network
     (Link ID) Designated Router address:172.16.0.3
     (Link Data) Router Interface address:172.16.0.4
      Number of TOS metrics:0
       TOS 0 Metrics:10

    Link connected to:a Stub Network
     (Link ID) Network/subnet number:10.5.5.5
     (Link Data) Network Mask:255.255.255.255
      Number of TOS metrics:0
       TOS 0 Metrics:1

Additional References

The following sections provide references related to OSPF Forwarding Adjacency.

Related Documents

Related Topic
Document Title

MPLS traffic engineering forwarding adjacency

MPLS Traffic Engineering Forwarding Adjacency

Configuring OSPF for MPLS traffic engineering

MPLS Traffic Engineering and Enhancements

MPLS Traffic Engineering

Multiprotocol Label Switching (MPLS) Traffic Engineering

MPLS Traffic Engineering


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This feature uses no new or modified commands.