Guest

Cisco IOS Software Releases 12.0 S

MPLS Traffic Engineering—AutoTunnel Mesh Groups

  • Viewing Options

  • PDF (414.1 KB)
  • Feedback
MPLS Traffic Engineering—AutoTunnel Mesh Groups

Table Of Contents

MPLS Traffic Engineering—AutoTunnel Mesh Groups

Contents

Prerequisites for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Restrictions for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Information About MPLS Traffic Engineering—AutoTunnel Mesh Groups

AutoTunnel Mesh Groups Description and Benefits

Access Lists for Mesh Tunnel Interfaces

AutoTunnel Template Interfaces

OSPF Flooding of Mesh Group Information

How to Configure MPLS Traffic Engineering—AutoTunnel Mesh Groups

Configuring a Mesh of TE Tunnel LSPs

Enabling Autotunnel Mesh Groups Globally

Creating an Access List Using a Name

Creating an Autotunnel Template Interface

Specifying the Range of Mesh Tunnel Interface Numbers

Showing Configuration Information About Tunnels

Monitoring Your Autotunnel Mesh Network

Troubleshooting Tips

Configuring IGP Flooding for Autotunnel Mesh Groups

Configuration Examples for MPLS Traffic Engineering—Autotunnel Mesh Groups

Configuring a Mesh of TE Tunnel LSPs: Examples

Enabling Autotunnel Mesh Groups Globally: Example

Creating an Access List Using a Name: Example

Creating a Template Interface: Example

Specifying the Range of Mesh Tunnel Interface Numbers: Example

Configuring IGP Flooding for Autotunnel Mesh Groups: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

clear mpls traffic-eng auto-tunnel mesh

interface auto-template

mpls traffic-eng auto-tunnel mesh

mpls traffic-eng auto-tunnel mesh tunnel-num

mpls traffic-eng mesh-group

show interface tunnel configuration

show mpls traffic-eng auto-tunnel mesh

show mpls traffic-eng tunnels

show running interface auto-template

tunnel destination access-list

tunnel destination mesh-group

Feature Information for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Glossary


MPLS Traffic Engineering—AutoTunnel Mesh Groups


First Published: January 27, 2004
Last Updated: August 6, 2007

This document shows how to configure autotunnel mesh groups for Multiprotocol Label Switching (MPLS) traffic engineering (TE) label switch routers (LSRs).

The MPLS Traffic Engineering—AutoTunnel Mesh Groups feature allows a network administrator to configure TE label-switched paths (LSPs) by using a few command-line interface (CLI) commands.

In a network topology where edge TE LSRs are connected by core LSRs, the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature automatically constructs a mesh of TE LSPs among the provider edge (PE) routers.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for MPLS Traffic Engineering—AutoTunnel Mesh Groups" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Restrictions for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Information About MPLS Traffic Engineering—AutoTunnel Mesh Groups

How to Configure MPLS Traffic Engineering—AutoTunnel Mesh Groups

Configuration Examples for MPLS Traffic Engineering—Autotunnel Mesh Groups

Additional References

Command Reference

Feature Information for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Glossary

Prerequisites for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Be knowledgeable about MPLS TE. See the "Additional References" section.

Decide how you will set up autotunnels (that is, identify the tunnel commands that you will include in the template interface).

Identify a block of addresses that you will reserve for mesh tunnel interfaces.

Restrictions for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Mesh groups do not support interarea tunnels because the destinations of those tunnels do not exist in the local area TE database.

You cannot enable autotunnel mesh groups on a router that is also configured with stateful switchover (SSO) redundancy. This restriction does not prevent an MPLS TE tunnel that is automatically configured via TE Autotunnel from being successfully recovered on a midpoint router along the LSP's path if that router experiences an SSO switchover.

Information About MPLS Traffic Engineering—AutoTunnel Mesh Groups

To configure autotunnel mesh groups, you need information about the following:

AutoTunnel Mesh Groups Description and Benefits

Access Lists for Mesh Tunnel Interfaces

AutoTunnel Template Interfaces

OSPF Flooding of Mesh Group Information

AutoTunnel Mesh Groups Description and Benefits

An autotunnel mesh group (referred to as a mesh group) is a set of connections between edge LSRs in a network. There are two types of mesh groups:

Full—All the edge LSRs are connected. Each PE router has a tunnel to each of the other PE routers.

Partial—Some of the edge LSRs are not connected to each other by tunnels.

In a network topology where edge TE LSRs are connected by core LSRs, the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature automatically constructs a mesh of TE LSPs among the provider edge (PE) routers.

Initially, you must configure each existing TE LSR to be a member of the mesh by using a minimal set of configuration commands. When the network grows (that is, when one or more TE LSRs are added to the network as PE routers), you do not need to reconfigure the existing TE LSR members of that mesh.

Mesh groups have the following benefits:

Minimize the initial configuration of the network. You configure one template interface per mesh, and it propagates to all mesh tunnel interfaces, as needed.

Minimize future configurations resulting from network growth. The feature eliminates the need to reconfigure each existing TE LSR to establish a full mesh of TE LSPs whenever a new PE router is added to the network.

Enable existing routers to set up TE LSPs to new PE routers.

Enable the construction of a mesh of TE LSPs among the PE routers automatically.

Access Lists for Mesh Tunnel Interfaces

The access list determines the destination addresses for the mesh tunnel interfaces. It is useful if you preallocate a block of related IP addresses. You can use that block of addresses to control the PE routers to which a full or partial mesh of TE tunnel LSPs is established. The access list allows matches for only the addresses that are learned and stored in the TE topology database.

For example, you can create an access list that matches all 10.1.1.1 IP addresses. You configure a template with the access list, then the template creates mesh tunnel interfaces to destinations within the TE topology database that match destinations in that access list.

Whenever the TE topology database is updated (for example, when a new TE LSR is inserted into the IGP), the destination address is stored in the TE topology database of each router in the IGP. At each update, the Mesh Group feature compares the destination address contained in the database to IP addresses in the access list associated with all template interfaces. If there is a match, the Mesh Group feature establishes a mesh tunnel interface to the tunnel destination IP address.

AutoTunnel Template Interfaces

An autotunnel template interface is a logical entity; that is, it is a configuration for a tunnel interface that is not tied to specific tunnel interfaces. It can be applied dynamically, when needed.

Mesh tunnel interfaces are tunnel interfaces that are created, configured dynamically (for example, by the applying [or cloning] of a template interface), used, and then freed when they are no longer needed.

A mesh tunnel interface obtains its configuration information from a template, except for the tunnel's destination address, which it obtains from the TE topology database that matches an access list or from the IGP mesh group advertisement.

The template interface allows you to enter commands once per mesh group. These commands specify how mesh tunnel interfaces are created. Each time a new router is added to the network, a new mesh tunnel interface is created. The configuration of the interface is duplicated from the template. Each mesh tunnel interface has the same path constraints and other parameters configured on the template interface. Only the tunnel destination address is different.

OSPF Flooding of Mesh Group Information

A former release of the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature uses an address-based discovery to identify mesh group members. Cisco IOS Release 12.0(29)S introduces an Open Shortest Path First (OSPF)-based discovery for identifying mesh group members.

For OSPF to advertise or flood mesh group information, you need to configure a mesh group in OSPF and add that mesh group to an autotemplate interface. When the configuration is complete, OSPF advertises the mesh group IDs to all LSRs. MPLS TE LSPs automatically connect the edge LSRs in each mesh group. For configuration information, see the "Configuring IGP Flooding for Autotunnel Mesh Groups" section.

OSPF can advertise mesh group IDs for an OSPF area. OSPF is the only IGP supported in the Cisco IOS 12.0(29)S, 12,2(33)SRA, and 12.(33)SXH releases of the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature.

How to Configure MPLS Traffic Engineering—AutoTunnel Mesh Groups

Perform the following procedures to configure the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature:

Configuring a Mesh of TE Tunnel LSPs (required)

Specifying the Range of Mesh Tunnel Interface Numbers (optional)

Showing Configuration Information About Tunnels (optional)

Monitoring Your Autotunnel Mesh Network (required)

Configuring IGP Flooding for Autotunnel Mesh Groups (optional)

Configuring a Mesh of TE Tunnel LSPs

Perform the following tasks on each PE router in your network to configure a mesh of TE tunnel LSPs:

Enabling Autotunnel Mesh Groups Globally

Creating an Access List Using a Name

Creating an Autotunnel Template Interface


Note You can perform these tasks in any order.


Enabling Autotunnel Mesh Groups Globally

Perform the following task to enable autotunnel mesh groups globally. Perform this task on all PE routers in your network that you want to be part of an autotunnel mesh group.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls traffic-eng auto-tunnel mesh

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls traffic-eng auto-tunnel mesh

Example:

Router(config)# mpls traffic-eng auto-tunnel mesh

Enables autotunnel mesh groups globally.

Step 4 

end

Example:

Router(config)# end

Exits to privileged EXEC mode.


Creating an Access List Using a Name

Perform the following task to create an access list using a name.

The access list determines the destination addresses for the mesh tunnel interfaces. You can use an access list to control the PE routers to which a full or partial mesh of TE tunnel LSPs is established. The access list allows matches for only the addresses that are learned and stored in the TE topology database.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip access-list {standard | extended} access-list-name

4. permit source [source-wildcard]

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip access-list {standard | extended} access-list-name

Example:

Router(config)# ip access-list standard a1

Defines an IP access list using a name and enters standard named access list configuration mode.

The standard keyword specifies a standard IP access list.

The extended keyword specifies an extended IP access list.

The access-list-name argument is the name of the access list. A name cannot contain a space or quotation mark and must begin with an alphabetic character. This prevents confusion with numbered access lists.

Step 4 

permit source [source-wildcard]

Example:

Router(config-std-nacl)# permit 10.0.0.0 0.255.255.255

Sets conditions to allow a packet to pass a named IP access list.

The source argument is the number of the network or host from which the packet is being sent. There are three alternative ways to specify the source:

Use a 32-bit quantity in four-part dotted decimal format.

Use the any keyword as an abbreviation for a source and source-wildcard of 0.0.0.0 255.255.255.255.

Use host source as an abbreviation for a source and source-wildcard of source 0.0.0.0.

The source-wildcard argument is the wildcard bits to be applied to source. There are three alternative ways to specify the source wildcard:

Use a 32-bit quantity in four-part dotted decimal format. Place 1s in the bit positions you want to ignore.

Use the any keyword as an abbreviation for a source and source-wildcard of 0.0.0.0 255.255.255.255.

Use host source as an abbreviation for a source and source-wildcard of source 0.0.0.0.

Step 5 

end

Example:

Router(config-std-nacl)# end

Exits to privileged EXEC mode.

Creating an Autotunnel Template Interface

Perform the following task to create an autotunnel template interface. This helps minimize the initial configuration of the network. You configure one template interface per mesh, and it propagates to all mesh tunnel interfaces, as needed.


Note You can enter various commands. The commands shown below are used to create a minimal configuration.


SUMMARY STEPS

1. enable

2. configure terminal

3. interface auto-template interface-num

4. ip unnumbered type number

5. tunnel mode {aurp | cayman | dvmrp | eon | gre | ipip | iptalk | mpls | nos}

6. tunnel mpls traffic-eng autoroute announce

7. tunnel mpls traffic-eng priority setup-priority [hold-priority]

8. tunnel mpls traffic-eng auto-bw [collect-bw] [frequency seconds] [max-bw kbps] [min-bw kbps]

9. tunnel mpls traffic-eng path-option number {dynamic | explicit {name path-name | path-number}} [lockdown]

10. tunnel destination access-list num

11. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface auto-template interface-num

Example:

Router(config)# interface auto-template 1

Creates a template interface and enters interface configuration mode.

The interface-num argument is the interface number. Valid values are 1 to 25.

Step 4 

ip unnumbered type number

Example:

Router(config-if)# ip unnumbered Loopback 0

Enables IP processing on an interface without assigning an explicit IP address to the interface.

The type and number arguments name the type and number of another interface on which the router has an assigned IP address. It cannot be another unnumbered interface.

Step 5 

tunnel mode {aurp | cayman | dvmrp | eon | gre | ipip | iptalk | mpls | nos}

Example:

Router(config-if)# tunnel mode mpls

Sets the encapsulation mode for the tunnel interface.

Step 6 

tunnel mpls traffic-eng autoroute announce

Example:

Router(config-if)# tunnel mpls traffic-eng autoroute announce

Specifies that the IGP should use the tunnel (if the tunnel is up) in its enhanced shortest path first algorithm (SPF) calculation.

Step 7 

tunnel mpls traffic-eng priority setup-priority [hold-priority]

Example:

Router(config-if)# tunnel mpls traffic-eng priority 1 1

Configures the setup and reservation priority for an MPLS TE tunnel.

The setup-priority argument is the priority used when an LSP is signaled for this tunnel and determines which existing tunnels can be preempted. Valid values are from 0 to 7, where a lower number indicates a higher priority. Therefore, an LSP with a setup priority of 0 can preempt any LSP with a non-0 priority.

The hold-priority argument is the priority associated with an LSP for this tunnel and determines if it should be preempted by other LSPs that are being signaled. Valid values are from 0 to 7, where a lower number indicates a higher priority.

Step 8 

tunnel mpls traffic-eng auto-bw [collect-bw] [frequency seconds] [max-bw kbps] [min-bw kbps]

Example:

Router(config-if)# tunnel mpls traffic-eng auto-bw

Configures a tunnel for automatic bandwidth adjustment and for control of the manner in which the bandwidth for a tunnel is adjusted.

The collect-bw keyword collects output rate information for the tunnel, but does not adjust the tunnel's bandwidth.

The frequency seconds keyword-argument pair is the interval between bandwidth adjustments. The specified interval can be from 300 to 604800 seconds. Do not specify a value lower than the output rate sampling interval specified in the mpls traffic-eng auto-bw command in global configuration mode.

The max-bw kbps keyword-argument pair is the maximum automatic bandwidth, in kbps, for this tunnel. The value can be from 0 to 4294967295.

The min-bw kbps keyword-argument pair is the minimum automatic bandwidth, in kbps, for this tunnel. The value can be from 0 to 4294967295.

Step 9 

tunnel mpls traffic-eng path-option number {dynamic | explicit {name path-name | path-number}} [lockdown]

Example:

Router(config-if)# tunnel mpls traffic-eng path-option 1 dynamic

Configures a path option for an MPLS TE tunnel.

The number argument is the number of the path option. When multiple path options are configured, lower numbered options are preferred.

The dynamic keyword specifies that the path of the LSP is dynamically calculated.

The explicit keyword specifies that the path of the LSP is an IP explicit path.

The name path-name keyword-argument pair is the path name of the IP explicit path that the tunnel uses with this option.

The path-number argument is the path number of the IP explicit path that the tunnel uses with this option.

The lockdown keyword specifies that the LSP cannot be reoptimized.

Note The only meaningful keyword to use within an explicit-path that is linked to an Auto-Template is exclude-address.

Step 10 

tunnel destination access-list num

Example:

Router(config-if)# tunnel destination access-list 1

Specifies the access list that the template interface uses for obtaining the mesh tunnel interface destination address.

The num argument is the number of the access list.

Step 11 

end

Example:

Router(config)# end

Exits to privileged EXEC mode.

Specifying the Range of Mesh Tunnel Interface Numbers

Perform the following task to specify the range of mesh tunnel interface numbers.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls traffic-eng auto-tunnel mesh tunnel-num min num max num

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls traffic-eng auto-tunnel mesh tunnel-num min num max num

Example:

Router(config)# mpls traffic-eng auto-tunnel mesh tunnel-num min 1000 max 2000

Configures the range of mesh tunnel interface numbers.

The min num keyword-argument pair specifies the beginning number of the range of mesh tunnel interface numbers. Valid values are from 1 to 65535.

The max num keyword-argument pair specifies the ending number of the range of mesh tunnel interface numbers. Valid values are from 1 to 65535.

Step 4 

end

Example:

Router(config)# end

Exits to privileged EXEC mode.

Showing Configuration Information About Tunnels

Perform the following task to show tunnel configuration information, such as tunnel interface and mesh tunnel configuration.

SUMMARY STEPS

1. enable

2. show running interface auto-template num

3. show interface tunnel num configuration

4. exit

DETAILED STEPS


Step 1 enable

Use this command to enable privileged EXEC mode. Enter your password if prompted. For example:

Router> enable
Router#

Step 2 show running interface auto-template num

Use this command to display interface configuration information for a tunnel interface. For example:

Router# show running interface auto-template 1

interface auto-template1 
 ip unnumbered Loopback0 
 no ip directed-broadcast 
 no keepalive 
 tunnel destination access-list 1 
 tunnel mode mpls traffic-eng 
 tunnel mpls traffic-eng autoroute announce 
 tunnel mpls traffic-eng path-option 1 dynamic

This output shows that autotunnel template interface auto-template1 uses an access list (access-list 1) to determine the destination addresses for the mesh tunnel interfaces.

Step 3 show interface tunnel num configuration

Use this command to display the configuration of the mesh tunnel interface. For example:

Router# show interface tunnel 5 configuration

interface tunnel 5
 ip unnumbered Loopback0 
 no ip directed-broadcast 
 no keepalive 
 tunnel destination access-list 1 
 tunnel mode mpls traffic-eng 
 tunnel mpls traffic-eng autoroute announce 
 tunnel mpls traffic-eng path-option 1 dynamic

Step 4 exit

Use this command to exit to user EXEC mode. For example:

Router# exit
Router>


Monitoring Your Autotunnel Mesh Network

Perform the following task to monitor your autotunnel mesh network.

SUMMARY STEPS

1. enable

2. show mpls traffic-eng tunnels property auto-tunnel mesh [brief]

3. show mpls traffic-eng auto-tunnel mesh

4. exit

DETAILED STEPS


Step 1 enable

Use this command to enable privileged EXEC mode. Enter your password if prompted. For example:

Router> enable
Router#

Step 2 show mpls traffic-eng tunnels property auto-tunnel mesh [brief]

Use this command to monitor mesh tunnel interfaces. This command restricts the output of the show mpls traffic-eng tunnels command to display only mesh tunnel interfaces. For example:

Router# show mpls traffic-eng tunnels property auto-tunnel mesh brief

Signalling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 491 seconds
    Periodic FRR Promotion:         Not Running
    Periodic auto-bw collection:    disabled
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF
STATE/PROT
router_t64336                   10.2.2.2         -         Se2/0
up/up
router_t64337                   10.3.3.3         -         Se2/0
up/up
Displayed 2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails

Step 3 show mpls traffic-eng auto-tunnel mesh

Use this command to display the cloned mesh tunnel interfaces of each autotemplate interface and the current range of mesh tunnel interface numbers. For example:

Router# show mpls traffic-eng auto-tunnel mesh

Auto-Template1:

 Using access-list 1 to clone the following tunnel interfaces:

  Destination  Interface
  -----------  ---------
  10.2.2.2     Tunnel64336
  10.3.3.3     Tunnel64337

Mesh tunnel interface numbers: min 64336 max 65337

Step 4 exit

Use this command to exit to user EXEC mode. For example:

Router# exit
Router>


Troubleshooting Tips

You can configure mesh tunnel interfaces directly. However, you cannot delete them manually, and manual configuration is not permanent. The configuration is overwritten when the template changes or the mesh tunnel interface is deleted and recreated. If you attempt to manually delete a mesh tunnel interface, an error message appears.

You can enter the show mpls traffic-eng tunnels destination address command to display information about tunnels that are destined for a specified IP address.

Enter the show mpls traffic-eng tunnels property auto-tunnel mesh command to display information about mesh tunnel interfaces.

Configuring IGP Flooding for Autotunnel Mesh Groups

Perform the following task to configure IGP flooding for autotunnel mesh groups. Use this task to configure an OSPF-based discovery for identifying mesh group members and advertising the mesh group IDs to all LSRs.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls traffic-eng auto-tunnel mesh

4. router ospf process-id

5. mpls traffic-eng mesh-group mesh-group-id interface-type interface-number area area-id

6. exit

7. Repeat steps 4 and 5 at other LSRs to advertise the mesh group numbers to which they belong.

8. interface auto-template interface-num

9. tunnel destination mesh-group mesh-group-id

10. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls traffic-eng auto-tunnel mesh

Example:

Router(config)# mpls traffic-eng auto-tunnel mesh

Enables autotunnel mesh groups globally.

Step 4 

router ospf process-id

Example:

Router(config)# router ospf 100

Enters router configuration mode and configures an OSPF routing process.

The process-id argument is an internally used identification parameter for an OSPF routing process. It is locally assigned and can be any positive integer. A unique value is assigned for each OSPF routing process.

Step 5 

mpls traffic-eng mesh-group mesh-group-id interface-type interface-number area area-id

Example:

Router(config-router)# mpls traffic-eng mesh-group 10 loopback 0 area 100

Advertises the autotunnel mesh group number of an LSR.

The mesh-group-id is a number that identifies a specific mesh group.

The interface-type and interface-number arguments specify a type of interface and an interface number.

The area area-id keyword-argument pair identifies the area.

Step 6 

exit

Example:

Router(config-router)# exit

Exits to global configuration mode.

Step 7 

Repeat steps 4 and 5 at other LSRs to advertise the mesh group numbers to which they belong.

Step 8 

interface auto-template interface-num

Example:

Router(config)# interface auto-template 1

Creates a template interface and enters interface configuration mode.

The interface-num argument identifies the interface number. Valid values are 1 to 25.

Step 9 

tunnel destination mesh-group mesh-group-id

Example:

Router(config-if)# tunnel destination mesh-group 10

Specifies a mesh group that a template interface uses to signal tunnels for all mesh group members.

The mesh-group-id is a number that identifies a specific mesh group.

Step 10 

end

Example:

Router(config-if)# end

Exits to privileged EXEC mode.

Configuration Examples for MPLS Traffic Engineering—Autotunnel Mesh Groups

This section provides the following configuration examples for the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature:

Configuring a Mesh of TE Tunnel LSPs: Examples

Specifying the Range of Mesh Tunnel Interface Numbers: Example

Configuring IGP Flooding for Autotunnel Mesh Groups: Example

Configuring a Mesh of TE Tunnel LSPs: Examples

This section contains the following configuration examples for configuring a mesh of TE tunnel LSP:

Enabling Autotunnel Mesh Groups Globally: Example

Creating an Access List Using a Name: Example

Creating a Template Interface: Example

Enabling Autotunnel Mesh Groups Globally: Example

The following example shows how to enable autotunnel mesh groups globally:

configure terminal
!

mpls traffic-eng auto-tunnel mesh
end

Creating an Access List Using a Name: Example

The following examples shows how to create an access list using a name to determine the destination addresses for the mesh tunnel interfaces:

configure terminal
!
ip access-list standard a1
 permit 10.0.0.0 0.255.255.255
end

In this example, any IP address in the TE topology database that matches access list a1 causes the creation of a mesh tunnel interface with that destination address.

Creating a Template Interface: Example

This example shows how to create a template interface. In the following example, a template is created and configured with a typical set of TE commands. The mesh group created from the template consists of mesh tunnel interfaces with destination addresses that match access list a1.


Note You can enter various commands. The following commands show a typical configuration.


configure terminal
!
interface Auto-Template 1
 ip unnumbered Loopback0
 tunnel mode mpls 
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 1 1
 tunnel mpls traffic-eng auto-bw
 tunnel mpls traffic-eng path-option 1 dynamic
 tunnel destination access-list a1
 end

Specifying the Range of Mesh Tunnel Interface Numbers: Example

In the following example, the lowest mesh tunnel interface number can be 1000, and the highest mesh tunnel interface number can be 2000:

configure terminal
!
mpls traffic-eng auto-tunnel mesh tunnel-num min 1000 max 2000
end

Configuring IGP Flooding for Autotunnel Mesh Groups: Example

In the following example, OSPF is configured to advertise the router membership in mesh group 10:

configure terminal
!
mpls traffic-eng auto-tunnel mesh
router ospf 100
 mpls traffic-eng mesh-group 10 loopback 0 area 100
 exit
!
interface auto-template 1
 tunnel destination mesh-group 10
 end

Additional References

The following sections provide references related to the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature.

Related Documents

Related Topic
Document Title

Configuration tasks for MPLS traffic engineering

Part 3: MPLS Traffic Engineering in the Cisco IOS Multiprotocol Label Switching Configuration Guide, Release 12.4

MPLS traffic engineering command descriptions

Cisco IOS Multiprotocol Label Switching Command Reference, Release 12.2 SR


Standards

Standards
Title

None


MIBs

MIBs
MIBs Link

None

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

None


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Command Reference

This section documents modified commands only.

clear mpls traffic-eng auto-tunnel mesh

interface auto-template

mpls traffic-eng auto-tunnel mesh

mpls traffic-eng auto-tunnel mesh tunnel-num

mpls traffic-eng mesh-group

show interface tunnel configuration

show mpls traffic-eng auto-tunnel mesh

show mpls traffic-eng tunnels

show running interface auto-template

tunnel destination access-list

tunnel destination mesh-group

clear mpls traffic-eng auto-tunnel mesh

To remove all the mesh tunnel interfaces and re-create them, use the clear mpls traffic-eng auto-tunnel mesh command in privileged EXEC mode.

clear mpls traffic-eng auto-tunnel mesh

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Examples

The following example shows how to remove all mesh tunnel interfaces and re-create them:

Router# clear mpls traffic-eng auto-tunnel mesh

Related Commands

Command
Description

interface auto-template

Creates the template interface.


interface auto-template

To create the template interface, use the interface auto-template command in global configuration mode. To delete this interface, use the no form of this command.

interface auto-template interface-num

no interface auto-template

Syntax Description

interface-num

Interface number. Valid values are 1 to 25.


Command Default

No default behavior or values.

Command Modes

Global configuration

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

The space before the interface-num argument is optional.

Use the shutdown command to disable mesh tunnel interface creation in this template.

Examples

The following example shows how to create template interface 1:

Router(config)# interface auto-template 1

Related Commands

Command
Description

clear mpls traffic-eng auto-tunnel mesh

Removes all the mesh tunnel interfaces and re-creates them.

mpls traffic-eng auto-tunnel mesh

Enables autotunnel mesh groups globally.

show mpls traffic-eng auto-tunnel mesh

Displays the cloned mesh tunnel interfaces of each autotemplate interface and the current range of mesh tunnel interface numbers.


mpls traffic-eng auto-tunnel mesh

To enable autotunnel mesh groups globally, use the mpls traffic-eng auto-tunnel mesh command in global configuration mode. To disable this feature, use the no form of this command.

mpls traffic-eng auto-tunnel mesh

no mpls traffic-eng auto-tunnel mesh

Syntax Description

This command has no arguments or keywords.

Command Default

Autotunnel mesh groups are not enabled globally.

Command Modes

Global configuration

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Examples

The following example shows how to enable autotunnel mesh groups globally:

Router(config)# mpls traffic-eng auto-tunnel mesh

Related Commands

Command
Description

interface auto-template

Creates the template interface.


mpls traffic-eng auto-tunnel mesh tunnel-num

To configure a range of mesh tunnel interface numbers, use the mpls traffic-eng auto-tunnel mesh tunnel-num command in global configuration mode. To use the default values, use the no form of this command.

mpls traffic-eng auto-tunnel mesh tunnel-num min num max num

no mpls traffic-eng auto-tunnel mesh tunnel-num

Syntax Description

min num

Beginning number of the range of mesh tunnel interface numbers. Valid values are from 1 to 65535. The default value is 64336.

max num

Ending number of the range of mesh tunnel interface numbers. Valid values are from 1 to 65535. The default value is 65335.


Command Default

The min default is 64336. The max default is 65335.

Command Modes

Global configuration

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

If you change an access control list (ACL) and tunnels are deleted because they no longer match the ACL, tunnels that are recreated might not be numbered sequentially; that is, the range of tunnel numbers might not be sequential.

Examples

The following example shows how to specify 1000 as the beginning number of the mesh tunnel interface and 2000 as the ending number:

Router(config)# mpls traffic-eng auto-tunnel mesh tunnel-num min 1000 max 2000

Related Commands

Command
Description

show mpls traffic-eng auto-tunnel mesh

Displays the cloned mesh tunnel interfaces of each autotemplate interface and the current range of mesh tunnel interface numbers.


mpls traffic-eng mesh-group

To configure a mesh group in an Interior Gateway Protocol (IGP) to allow Multiprotocol Label Switching (MPLS) traffic engineering (TE) label switch routers (LSRs) that belong to the same mesh group to signal tunnels to the local router, use the mpls traffic-eng mesh-group command in router configuration mode. To disable signaling of tunnels from LSRs in the same mesh group to the local router, use the no form of this command.

mpls traffic-eng mesh-group mesh-group-id interface-type interface-number area area-id

no mpls traffic-eng mesh-group mesh-group-id interface-type interface-number area area-id

Syntax Description

mesh-group-id

Number that identifies a specific mesh group.

interface-type

Type of interface.

interface-number

Interface number.

area area-id

Identifies an IGP area.


Command Default

No tunnels are signaled for routers in the same mesh group.

Command Modes

Router configuration

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

Use this command to configure a mesh group in an IGP. This allows the MPLS TE LSRs that belong to the specified mesh group to signal tunnels to the local router. The IGP floods mesh group configuration to all routers belonging to the same mesh group. An autotemplate determines how a router participates in an autotunnel. A router can participate in a mesh group through two-way tunnels or one-way tunnels.

Open Shortest Path First (OSPF) is the only IGP supported in this release of the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature.

Examples

The following example shows how to configure OSPF to allow LSRs that belong to the same mesh group (mesh group 10) to signal tunnels to the local router:

Router(config)# router ospf 100
Router(config-router)# mpls traffic-eng mesh-group 10 loopback 0 area 100

Related Commands

Command
Description

tunnel destination mesh-group

Configures an autotemplate to signal tunnels to all other members of a specified mesh group.


show interface tunnel configuration

To display the configuration of a mesh tunnel interface, use the show interface tunnel configuration command in privileged EXEC mode.

show interface tunnel num configuration

Syntax Description

num

Number of the mesh tunnel for which you want to display configuration information.


Command Default

No default behavior or values.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

The space before the num argument is optional.

Use this command to show the running configuration of the mesh tunnel interface.

Examples

The following command output shows the configuration of mesh tunnel interface 5:

Router# show interface tunnel 5 configuration

interface tunnel 5
 ip unnumbered Loopback0 
 no ip directed-broadcast 
 no keepalive 
 tunnel destination access-list 1 
 tunnel mode mpls traffic-eng 
 tunnel mpls traffic-eng autoroute announce 
 tunnel mpls traffic-eng path-option 1 dynamic

Table 1 describes the significant fields shown in the display.

Table 1 show interface tunnel configuration Field Descriptions 

Field
Description

ip unnumbered Loopback0

Indicates the type and number of another interface on which the router has an assigned IP address. It cannot be another unnumbered interface.

no ip directed-broadcast

Indicates that no IP broadcast addresses are used for the mesh tunnel interface.

no keepalive

Indicates that no keepalives are set for the mesh tunnel interface.

tunnel destination access-list 1

Indicates that access-list 1 is the access list that the template interface will use for obtaining the mesh tunnel interface destination address.

tunnel mode mpls traffic-eng

Indicates that the mode of the mesh tunnel is set to Multiprotocol Label Switching (MPLS) for traffic engineering.

tunnel mpls traffic-eng autoroute announce

Indicates that the Interior Gateway Protocol (IGP) should use the tunnel (if the tunnel is up) in its enhanced shortest path first (SPF) calculation.

tunnel mpls traffic-eng path-option 1 dynamic

Indicates that a path option (path-option1) for the label switch router (LSR) for the MPLS traffic engineering (TE) mesh tunnel is configured dynamically.


Related Commands

Command
Description

tunnel destination access-list

Specifies the access list that the template interface will use for obtaining the mesh tunnel interface destination address.


show mpls traffic-eng auto-tunnel mesh

To display the cloned mesh tunnel interfaces of each autotemplate interface and the current range of mesh tunnel interface numbers, use the show mpls traffic-eng auto-tunnel mesh command in user EXEC mode or privileged EXEC mode.

show mpls traffic-eng auto-tunnel mesh

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Examples

The following is output of the show mpls traffic-eng auto-tunnel mesh command that shows the cloned mesh tunnel interfaces for autotemplate1 and shows the range of mesh tunnel interface numbers. Information for only one autotemplate is displayed because only one autotemplate was configured.

Router# show mpls traffic-eng auto-tunnel mesh 

Auto-Template1:

 Using access-list 1 to clone the following tunnel interfaces:

  Destination  Interface
  -----------  ---------
  10.2.2.2     Tunnel64336
  10.3.3.3     Tunnel64337

Mesh tunnel interface numbers: min 64336 max 65337

Table 2 describes the significant fields shown in the display.

Table 2 show mpls traffic-eng auto-tunnel mesh Field Descriptions 

Field
Description

Auto-Template1

Name of the autotemplate.

Destination

Destination addresses for the mesh tunnel interface cloned from access list 1.

Interface

Mesh tunnel interfaces cloned from access list 1.

min 64336 max 65337

Range of mesh tunnel interface numbers for this Auto-Template1—minimum (64336) and maximum (65337).


Related Commands

Command
Description

interface auto-template

Creates the template interface.

mpls traffic-eng auto-tunnel mesh tunnel-num

Configures the range of mesh tunnel interface numbers.


show mpls traffic-eng tunnels

To display information about tunnels, use the show mpls traffic-eng tunnels command in user EXEC or privileged EXEC mode.

show mpls traffic-eng tunnels
[tunnel number]
[accounting]
[attributes]
[backup | brief | protection]
[destination address]
[interface in phys-intf] [interface out phys-intf | interface phys-intf]
[name name]
[name-regexp reg-exp]
[property {auto-tunnel | backup-tunnel | fast-reroute}]
[role {all | head | middle | tail | remote}]
[source-id {num | ipaddress | ipaddress num}]
[statistics]
[suboptimal constraints {none | current | max}]
[summary]
[up | down]

Syntax Description

tunnel number

(Optional) Restricts the display to the specified tunnel interface.

accounting

(Optional) Displays accounting information (the rate of the traffic flow) for tunnels.

attributes

(Optional) Restricts the display to tunnels that use a matching attributes list.

backup

(Optional) Displays information about the Fast Reroute protection provided by each tunnel selected by other options specified with this command. The information includes the physical interface protected by the tunnel, the number of traffic engineering (TE) label-switched packets (LSPs) (that is, tunnels) protected, and the bandwidth protected.

brief

(Optional) Specifies a format with one line per tunnel.

protection

(Optional) Displays information about the protection provided by each tunnel selected by other options specified with this command. The information includes whether protection is configured for the tunnel, the protection (if any) provided to the tunnel by this router, and the bandwidth protected.

destination address

(Optional) Restricts the display to tunnels destined to the specified IP address.

interface in phys-intf

(Optional) Displays information for the specified input interface.

interface out phys-intf

(Optional) Displays information for the specified output interface.

interface phys-intf

(Optional) Displays tunnels that use the specified interface as an input or output interface.

name name

(Optional) Displays tunnel with the specified string. The tunnel string is derived from the interface description, if specified; otherwise, it is the interface name. The tunnel string is included in the signaling message so that it is available at all hops.

name-regexp regexp

(Optional) Displays tunnels whose descriptions match the specified regular expression.

property auto-tunnel

(Optional) Displays information about autotunnels.

property backup-tunnel

(Optional) Selects Multiprotocol Label Switching (MPLS) traffic engineering (TE) tunnels being used to protect physical interfaces on this router. A tunnel configured to protect a link against failure is a backup tunnel and has the backup tunnel property.

property fast-reroute

(Optional) Selects Fast Reroute-protected MPLS TE tunnels originating, transmitting, or terminating on this router.

role

(Optional) Restricts the display to tunnels with the indicated role (all, head, middle, tail, or remote).

all

Displays all tunnels.

head

Displays tunnels with their head at this router.

middle

Displays tunnels with a midpoint at this router.

tail

Displays tunnels with a tail at this router.

remote

Displays tunnels with their head at some other router; this is a combination of middle and tail.

source-id

(Optional) Restricts the display to tunnels with a matching source IP address or tunnel number.

num

Tunnel number.

ipaddress

Source IP address.

ipaddress num

Source IP address and tunnel number.

statistics

(Optional) Displays tunnel counters and statistics.

suboptimal constraints none

(Optional) Displays tunnels whose path metric is greater than the shortest unconstrained path. Selected tunnels have a longer path than the Interior Gateway Protocol's (IGP) shortest path.

suboptimal constraints current

(Optional) Displays tunnels whose path metric is greater than the current shortest path, constrained by the tunnel's configured options. Selected tunnels would have a shorter path if they were reoptimized immediately.

suboptimal constraints max

(Optional) Displays information for the specified tunneling interface.

summary

(Optional) Displays summary information about tunnels that provide Fast Reroute protection.

up

(Optional) Displays tunnels if the tunnel interface is up. Tunnel midpoints and tails are typically up or not present.

down

(Optional) Displays tunnels that are down.


Defaults

If you specify this command without any arguments or keywords, the command displays general information about each MPLS TE tunnel known to the router.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.0(5)S

This command was introduced.

12.1(3)T

Input and output interface information was added to the new brief form of the output. The suboptimal and interface keywords were added to the nonbrief format. The nonbrief, nonsummary formats contain the history of the LSP selection.

12.0(10)ST

This command was integrated into Cisco IOS Release 12.0(10)ST.

12.0(22)S

The property and protection keywords were added. The command is supported on the Cisco 10000 series routers.

12.2(18)S

The following keywords were added: accounting, attributes, property auto-tunnel, and name-regexp. The property backup keyword was changed to property backup-tunnel.

12.2(18)SXD1

This command was integrated into Cisco IOS Release 12.2(18)SXD1.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

To select the tunnels for which information is displayed, use the tunnel, attributes, destination, name, name-regexp, source-id, role, up, down, name, suboptimal constraints, interface, and property keywords and options singly or combined.

To select the type of information displayed about the selected tunnels, use the accounting, backup, protection, statistics, and summary keywords.

The tunnel and property keywords display the same information, except that the property keyword restricts the display to autotunnels, backup tunnels, or tunnels that are Fast Reroute-protected.

The name-regexp keyword displays output for each tunnel whose name contains a specified string. For example, if there are tunnels named iou-100_t1, iou-100_t2, and iou-100_t100, the following command displays output for the three tunnels whose name contains the string iou-100.

Router# show mpls traffic-eng tunnels name-regexp iou-100

If you specify the name keyword, there is command output only if the command name is an exact match. For example: iou-100_t1.

Examples

The following is sample output from the show mpls traffic-eng tunnels brief command. It displays brief information about every MPLS TE tunnel known to the router.

Router# show mpls traffic-eng tunnels brief 500 

Signalling Summary:
    LSP Tunnels Process:           running
    RSVP Process:                  running
    Forwarding:                    enabled
    Periodic reoptimization:       every 3600 seconds, next in 1706 seconds
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Router_t1                        10.112.0.12      -         PO4/0/1   up/up     
Router_t2                        10.112.0.12      -         unknown   up/down   
Router_t3                        10.112.0.12      -         unknown   admin-down
Router_t1000                     10.110.0.10      -         unknown   up/down   
Router_t2000                     10.110.0.10      -         PO4/0/1   up/up     
Displayed 5 (of 5) heads, 0 (of 0) midpoints, 0 (of 0) tails

Table 3 describes the significant fields shown in the displays.

Table 3 show mpls traffic-eng tunnels Field Descriptions 

Field
Description

LSP Tunnels Process

Status of the LSP tunnels process.

RSVP Process

Status of the Resource Reservation Protocol (RSVP) process.

Forwarding

Status of forwarding (enabled or disabled).

Periodic reoptimization

Schedule for periodic reoptimization (in seconds).

TUNNEL NAME

Name of the interface that is configured at the tunnel head.

DESTINATION

Identifier of the tailend router.

UP IF

Upstream interface that the tunnel used.

DOWN IF

Downstream interface that the tunnel used.

STATE/PROT

For tunnel heads, admin-down. up, or down. For nonheads, signaled.


The following is sample output from the show mpls traffic-eng tunnels property backup brief command. It displays brief information about all MPLS TE tunnels acting as Fast Reroute backup tunnels (property backup) for interfaces on the router.

Router# show mpls traffic-eng tunnels property backup brief

Signalling Summary:
    LSP Tunnels Process:            running
    RSVP Process:                   running
    Forwarding:                     enabled
    Periodic reoptimization:        every 3600 seconds, next in 2231 seconds
    Periodic FRR Promotion:         every 300 seconds, next in 131 seconds
    Periodic auto-bw collection:    disabled
TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
Router_t2000                     10.110.0.10      -         PO4/0/1   up/up     
Router_t2                        10.112.0.12      -         unknown   up/down   
Router_t3                        10.112.0.12      -         unknown   admin-down
Displayed 3 (of 9) heads, 0 (of 1) midpoints, 0 (of 0) tails

The following is sample output from the show mpls traffic-eng tunnels backup command. This command selects every MPLS TE tunnel known to the router and displays information about the Fast Reroute protection each selected tunnels provides for interfaces on this router; the command does not generate output for tunnels that do not provide Fast Reroute protection of interfaces on this router.

Router# show mpls traffic-eng tunnels backup

Router_t578
  LSP Head, Tunnel578, Admin: up, Oper: up
  Src 10.55.55.55, Dest 10.88.88.88, Instance 1
  Fast Reroute Backup Provided: 
    Protected i/fs: PO1/0, PO1/1, PO3/3
    Protected lsps: 1
    Backup BW: any pool unlimited; inuse: 100 kbps
Router_t5710
  LSP Head, Tunnel5710, Admin: admin-down, Oper: down
  Src 10.55.55.55, Dest 192.168.7.7, Instance 0
  Fast Reroute Backup Provided: 
    Protected i/fs: PO1/1
    Protected lsps: 0
    Backup BW: any pool unlimited; inuse: 0 kbps
Router_t5711
  LSP Head, Tunnel5711, Admin: up, Oper: up
  Src 10.55.55.55, Dest 10.7.7.7, Instance 1
  Fast Reroute Backup Provided: 
    Protected i/fs: PO1/0
    Protected lsps: 2
    Backup BW: any pool unlimited; inuse: 6010 kbps

The following is sample output from the show mpls traffic-eng tunnels property fast-reroute protection command. This command selects every MPLS TE tunnel known to the router that was signaled as a Fast Reroute-protected LSP (property fast-reroute) and displays information about the protection this router provides each selected tunnel.

Router# show mpls traffic-eng tunnels property fast-reroute protection

Router_t1
  LSP Head, Tunnel1, Admin: up, Oper: up
  Src 10.55.55.55, Dest 10.88.88.88, Instance 25
  Fast Reroute Protection: Requested
    Outbound: FRR Ready
      Backup Tu5711 to LSP nhop
        Tu5711: out i/f: PO1/1, label: implicit-null
      LSP signalling info:
        Original: out i/f: PO1/0, label: 12304, nhop: 10.1.1.7
        With FRR: out i/f: Tu5711, label: 12304
      LSP bw: 6000 kbps, Backup level: any unlimited, type: any pool
Router_t2
  LSP Head, Tunnel2, Admin: up, Oper: up
  Src 10.55.55.55, Dest 10.88.88.88, Instance 2
  Fast Reroute Protection: Requested
    Outbound: FRR Ready
      Backup Tu578 to LSP nhop
        Tu578: out i/f: PO1/0, label: 12306
      LSP signalling info:
        Original: out i/f: PO3/3, label: implicit-null, nhop: 10.3.3.8
        With FRR: out i/f: Tu578, label: implicit-null
      LSP bw: 100 kbps, Backup level: any unlimited, type: any pool
r9_t1
  LSP Midpoint, signalled, connection up
  Src 10.9.9.9, Dest 10.88.88.88, Instance 2347
  Fast Reroute Protection: Requested
    Inbound:  FRR Inactive
      LSP signalling info:
        Original: in i/f: PO1/2, label: 12304, phop: 10.205.0.9
    Outbound: FRR Ready
      Backup Tu5711 to LSP nhop
        Tu5711: out i/f: PO1/1, label: implicit-null
      LSP signalling info:
        Original: out i/f: PO1/0, label: 12305, nhop: 10.1.1.7
        With FRR: out i/f: Tu5711, label: 12305
      LSP bw: 10 kbps, Backup level: any unlimited, type: any pool

The following is sample output from the show mpls traffic-eng tunnels tunnel command. This command displays information about just a single tunnel.

Router# show mpls traffic-eng tunnels tunnel 1

Name: swat76k1_t1                         (Tunnel1) Destination: 10.0.0.4
   Status:
     Admin: admin-down Oper: down   Path: not valid   Signalling: Down
     path option 1, type explicit gi7/4-R4

   Config Parameters:
     Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
     Metric Type: TE (default)
     AutoRoute:  disabled  LockDown: disabled  Loadshare: 0        bw-based
     auto-bw: disabled

   Shortest Unconstrained Path Info:
     Path Weight: 2 (TE)
     Explicit Route: 10.1.0.1 10.1.0.2 172.16.0.1 192.168.0.4
   History:
     Tunnel:
       Time since created: 13 days, 52 minutes
       Number of LSP IDs (Tun_Instances) used: 0 swat76k1#

swat76k1#sh mpls traf tun property ?
   auto-tunnel    auto-tunnel created tunnels
   backup-tunnel  Tunnels used as fast reroute
   fast-reroute   Tunnels protected by fast reroute 

The following is sample output from the show mpls traffic-eng tunnels accounting command. This command displays the rate of the traffic flow for the tunnels.

Router# show mpls traffic-eng tunnels accounting

Tunnel1 (Destination 10.103.103.103; Name iou-100_t1)
 5 minute output rate 0 kbits/sec, 0 packets/sec
Tunnel2 (Destination 10.103.103.103; Name iou-100_t2)
 5 minute output rate 0 kbits/sec, 0 packets/sec Tunnel100 (Destination 10.101.101.101; 
Name iou-100_t100)
 5 minute output rate 0 kbits/sec, 0 packets/sec Totals for 3 Tunnels
 5 minute output rate 0 kbits/sec, 0 packets/sec

Related Commands

Command
Description

mpls traffic-eng reoptimize timers frequency

Controls the frequency with which tunnels with established LSPs are checked for better LSPs.

mpls traffic-eng tunnels (configuration)

Enables MPLS traffic engineering tunnel signaling on a device.

mpls traffic-eng tunnels (interface)

Enables MPLS traffic engineering tunnel signaling on an interface.


show running interface auto-template

To display configuration information for a tunnel's interface, use the show running interface auto-template command in privileged EXEC mode.

show running interface auto-template num

Syntax Description

num

Number of the tunnel interface for which you want to display information.


Command Default

No default behavior or values.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

The space before the num argument is optional.

Examples

The following is output from the show running interface auto-template command:

Router# show running interface auto-template 1

interface auto-template1 
 ip unnumbered Loopback0 
 no ip directed-broadcast 
 no keepalive 
 tunnel destination access-list 1 
 tunnel mode mpls traffic-eng 
 tunnel mpls traffic-eng autoroute announce 
 tunnel mpls traffic-eng path-option 1 dynamic

Table 4 describes the significant fields shown in the display.

Table 4 show running interface auto-template Field Descriptions 

Field
Description

ip unnumbered Loopback0

Indicates the type and number of another interface on which the router has an assigned IP address. It cannot be another unnumbered interface.

no ip directed-broadcast

Indicates that no IP broadcast addresses are used for the autotunnel interface.

no keepalive

Indicates that no keepalives are set for the autotunnel interface.

tunnel destination access-list 1

Indicates that access list 1 is the access list that the template interface will use for obtaining the autotunnel interface destination address.

tunnel mode mpls traffic-eng

Indicates that the mode of the autotunnel is set to Multiprotocol Label Switching (MPLS) for traffic engineering.

tunnel mpls traffic-eng autoroute announce

Indicates that the Interior Gateway Protocol (IGP) should use the tunnel (if the tunnel is up) in its enhanced shortest path first (SPF) calculation.

tunnel mpls traffic-eng path-option 1 dynamic

Indicates that a path option (path-option1) for the label switch router (LSR) for the MPLS traffic engineering (TE) mesh tunnel is configured dynamically.


Related Commands

Command
Description

interface auto-template

Creates the template interface.

tunnel destination access-list

Specifies the access-list that the template interface will use for obtaining the mesh tunnel interface destination address.


tunnel destination access-list

To specify the access list that the template interface uses for obtaining the mesh tunnel interface destination address, use the tunnel destination access-list command in interface configuration mode. To remove the access list from this template interface, use the no form of this command.

tunnel destination access-list num

no tunnel destination access-list num

Syntax Description

num

Number of the access list.


Command Default

No default behavior or values.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(27)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

This command can be used only on template interfaces.

If you specify an access list that does not exist, no tunnels are set up. You need an access list to set up the destination addresses for the mesh tunnel interfaces.

If you enter the shutdown command on the autotemplate interface, the command is executed on all the cloned tunnel interfaces. To delete all the cloned tunnel interfaces, enter no tunnel destination on the autotemplate. To delete tunnel interfaces for a particular autotemplate, go to the particular interface and enter no tunnel destination.

Examples

The following example shows how to configure the template interface to use access-list 1 to obtain the tunnel destination address:

Router (config)# interface auto-template 1
Router(config-if)# tunnel destination access-list 1

Related Commands

Command
Description

interface auto-template

Creates the template interface.

mpls traffic-eng auto-tunnel mesh tunnel-num

Configures a range of mesh tunnel interface numbers.


tunnel destination mesh-group

To specify a mesh group that an autotemplate interface uses to signal tunnels for all mesh group members, use the tunnel destination mesh group command in interface configuration mode. To remove a mesh group from the template, use the no form of this command.

tunnel destination mesh group mesh-group-id

no tunnel destination mesh group mesh-group-id

Syntax Description

mesh-group-id

Number that identifies a specific mesh group.


Command Default

Mesh groups are not advertised.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.


Usage Guidelines

Use this command to associate a specific mesh group with an autotemplate. When a mesh group is associated with an autotemplate, the template interface signals tunnels for all mesh group members.

Examples

The following example shows how to configure an autotemplate to signal tunnels for mesh group 10:

Router(config)# interface autotemplate 1 
Router(config-if)# tunnel destination mesh-group 10

Related Commands

Command
Description

mpls traffic-eng mesh-group

Configures an IGP to allow MPLS TE LSRs that belong to the same mesh group to signal tunnels to the local router.


Feature Information for MPLS Traffic Engineering—AutoTunnel Mesh Groups

Table 5 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 5 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 5 Feature Information for MPLS Traffic Engineering—AutoTunnel Mesh Groups 

Feature Name
Releases
Feature Information

MPLS Traffic Engineering—AutoTunnel Mesh Groups

12.0(27)S
12.0(29)S
12.2(33)SRA
12.2(33)SXH

This document shows how to configure autotunnel mesh groups for Multiprotocol Label Switching (MPLS) traffic engineering (TE) label switch routers (LSRs).

The MPLS Traffic Engineering—AutoTunnel Mesh Groups feature allows a network administrator to configure TE label-switched paths (LSPs) by using a few command-line interface (CLI) commands.

In a network topology where edge TE LSRs are connected by core LSRs, the MPLS Traffic Engineering—AutoTunnel Mesh Groups feature automatically constructs a mesh of TE LSPs among the provider edge (PE) routers.

In 12.2(27)S, this feature was introduced.

In 12.0(29)S, this feature was updated to include Interior Gateway Protocol (IGP) flooding of autotunnel mesh groups.

In 12.2(33)SRA, support was added for a Cisco IOS 12.2SR release.

In 12.2(33)SXH, support was added for a Cisco IOS 12.2SX release.


Glossary

CE router—customer edge router. A router that is part of a customer's network and interfaces to a provider edge (PE) router.

customer network—A network that is under the control of an end customer. Private addresses can be used in a customer network. Customer networks are logically isolated from each other and from the service provider's network.

edge router—A router at the edge of the network that receives and transmits packets. It can define the boundaries of the Multiprotocol Label Switching (MPLS) network.

headend—The label switch router (LSR) where a tunnel originates. The tunnel's "head" or tunnel interface resides at this LSR as well.

label—A short, fixed-length data construct that tells switching nodes how to forward data (packets).

LSP—label switched path. A path that a labeled packet follows over several hops, starting at an ingress label switch router (LSR) and ending at an egress LSR.

label-switched path (LSP) tunnel—A configured connection between two routers, in which label switching is used to carry the packets.

LSR—label switch router. A Layer 3 router that forwards a packet based on the value of a label encapsulated in the packet.

mesh group—A set of label switch routers (LSRs) that are members of a full or partial network of traffic engineering (TE) label switched paths (LSPs).

P router—provider core router.

PE router—provider edge router. A router at the edge of the service provider's network that interfaces to customer edge (CE) routers.

router—A network layer device that uses one or more metrics to determine the optimal path along which network traffic should be forwarded. Routers forward packets from one network to another based on network layer information.

tailend—The downstream, receive end of a tunnel.

traffic engineering—The techniques and processes used to cause routed traffic to travel through the network on a path other than the one that would have been chosen if standard routing methods had been used.

tunnel—A secure communication path between two peers, such as two routers. A traffic engineering tunnel is a label-switched tunnel that is used for traffic engineering. Such a tunnel is set up through means other than normal Layer 3 routing.


Note See Internetworking Terms and Acronyms for terms not included in this glossary.