Guest

Cisco IOS Software Releases 12.0 S

RSVP Refresh Reduction and Reliable Messaging

  • Viewing Options

  • PDF (321.1 KB)
  • Feedback
RSVP Refresh Reduction and Reliable Messaging

Table Of Contents

RSVP Refresh Reduction and Reliable Messaging

Contents

Prerequisites for RSVP Refresh Reduction and Reliable Messaging

Restrictions for RSVP Refresh Reduction and Reliable Messaging

Information About RSVP Refresh Reduction and Reliable Messaging

Feature Design of RSVP Refresh Reduction and Reliable Messaging

Types of Messages in RSVP Refresh Reduction and Reliable Messaging

Reliable Messages

Bundle Messages

Summary Refresh Messages

Benefits of RSVP Refresh Reduction and Reliable Messaging

How to Configure RSVP Refresh Reduction and Reliable Messaging

Enabling RSVP on an Interface

Enabling RSVP Refresh Reduction

Verifying RSVP Refresh Reduction and Reliable Messaging

Configuration Examples for RSVP Refresh Reduction and Reliable Messaging

RSVP Refresh Reduction and Reliable Messaging Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

ip rsvp signalling refresh interval

ip rsvp signalling refresh misses

show ip rsvp

Glossary


RSVP Refresh Reduction and Reliable Messaging


The RSVP Refresh Reduction and Reliable Messaging feature includes refresh reduction, which improves the scalability, latency, and reliability of Resource Reservation Protocol (RSVP) signalling to enhance network performance and message delivery.

Feature Specifications for RSVP Refresh Reduction and Reliable Messaging

Feature History
 
Release
Modification

12.2(13)T

This feature was introduced.

12.0(24)S

This feature was integrated into Cisco IOS Release 12.0(24)S.

12.0(26)S

Two commands, ip rsvp signalling refresh misses and ip rsvp signalling refresh interval, were added into Cisco IOS Release 12.0(26)S.

Supported Platforms

For platforms supported in Cisco IOS Release 12.0(26)S, 12.0(24)S, and 12.2(13)T, consult Cisco Feature Navigator.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for RSVP Refresh Reduction and Reliable Messaging

Restrictions for RSVP Refresh Reduction and Reliable Messaging

Information About RSVP Refresh Reduction and Reliable Messaging

How to Configure RSVP Refresh Reduction and Reliable Messaging

Configuration Examples for RSVP Refresh Reduction and Reliable Messaging

Additional References

Command Reference

Glossary

Prerequisites for RSVP Refresh Reduction and Reliable Messaging

RSVP must be configured on two or more routers within the network before you can use the RSVP Refresh Reduction and Reliable Messaging feature.

Restrictions for RSVP Refresh Reduction and Reliable Messaging

Multicast flows are not supported for the reliable messaging and summary refresh features.

Information About RSVP Refresh Reduction and Reliable Messaging

To configure RSVP Refresh Reduction and Reliable Messaging, you need to understand the following concepts:

Feature Design of RSVP Refresh Reduction and Reliable Messaging

Types of Messages in RSVP Refresh Reduction and Reliable Messaging

Benefits of RSVP Refresh Reduction and Reliable Messaging

Feature Design of RSVP Refresh Reduction and Reliable Messaging

RSVP is a network-control, soft-state protocol that enables Internet applications to obtain special qualities of service (QoS) for their data flows. As a soft-state protocol, RSVP requires that state be periodically refreshed. If refresh messages are not transmitted during a specified interval, RSVP state automatically times out and is deleted.

In a network using RSVP signaling, reliability and latency problems occur when an RSVP message is lost in transmission. A lost RSVP setup message can cause a delayed or failed reservation; a lost RSVP refresh message can cause a delay in the modification of a reservation, or in a reservation timeout. Intolerant applications can fail as a result.

Reliability problems can also occur when there is excessive RSVP refresh message traffic caused by a large number of reservations in the network. Using summary refresh messages can improve reliability by significantly reducing the amount of RSVP refresh traffic.


Note RSVP packets consist of headers that identify the types of messages, and object fields that contain attributes and properties describing how to interpret and act on the content.


Types of Messages in RSVP Refresh Reduction and Reliable Messaging

The RSVP Refresh Reduction and Reliable Messaging feature includes refresh reduction, which improves the scalability, latency, and reliability of RSVP signalling by introducing the following extensions:

Reliable messages (MESSAGE_ID, MESSAGE_ID_ACK objects (Figure 1), and ACK messages)

Bundle messages (reception and processing only)

Summary refresh messages (MESSAGE_ID_LIST and MESSAGE_ID_NACK objects)

Figure 1 RSVP Refresh Reduction and Reliable Messaging

Reliable Messages

The reliable messages extension supports dependable message delivery among neighboring routers by implementing an acknowledgment mechanism that consists of a MESSAGE_ID object and a MESSAGE_ID_ACK object. The acknowledgments can be transmitted in an ACK message or piggybacked in other RSVP messages.

Each RSVP message contains one MESSAGE_ID object. If the ACK_Desired flag field is set within the MESSAGE_ID object, then the receiver transmits a MESSAGE_ID_ACK object to the sender to confirm delivery.

Bundle Messages

A bundle message consists of several standard RSVP messages grouped into a single RSVP message.

A bundle message must contain at least one submessage. A submessage can be any RSVP message type other than another bundle message. Submessage types include Path, PathErr, Resv, ResvTear, ResvErr, ResvConf, and ACK.

Bundle messages are addressed directly to the RSVP neighbor. The bundle header immediately follows the IP header, and there is no intermediate transport header.

When a router receives a bundle message that is not addressed to one of its local IP addresses, it forwards the message.


Note In this release, bundle messages can be received, but not sent.


Summary Refresh Messages

A summary refresh message supports refreshing the RSVP state without the transmission of conventional Path and Resv messages. Therefore, the amount of information that must be transmitted and processed to maintain RSVP state synchronization is greatly reduced.

A summary refresh message carries a set of MESSAGE_ID objects that identify the Path and Resv states that should be refreshed. When an RSVP node receives a summary refresh message, the node matches each received MESSAGE_ID object with the locally installed Path or Resv state. If the MESSAGE_ID objects match the local state, the state is updated as if a standard RSVP refresh message were received. However, if a MESSAGE_ID object does not match the receiver's local state, the receiver notifies the sender of the summary refresh message by transmitting a MESSAGE_ID_NACK object.

When a summary refresh message is used to refresh the state of an RSVP session, the transmission of conventional refresh messages are suppressed. The summary refresh extension cannot be used for a Path or Resv message that contains changes to a previously advertised state. Also, only a state that was previously advertised in Path or Resv messages containing MESSAGE_ID objects can be refreshed by using a summary refresh message.

Benefits of RSVP Refresh Reduction and Reliable Messaging

Enhanced Network Performance

Refresh reduction reduces the volume of steady-state network traffic generated, the amount of CPU resources used, and the response time, thereby enhancing network performance.

Improved Message Delivery

The MESSAGE_ID and the MESSAGE_ID_ACK objects ensure the reliable delivery of messages and support rapid state refresh when a network problem occurs. For example, MESSAGE_ID_ACK objects are used to detect link transmission losses.

How to Configure RSVP Refresh Reduction and Reliable Messaging

This section contains the following procedures:

Enabling RSVP on an Interface (required)

Enabling RSVP Refresh Reduction (required)

Verifying RSVP Refresh Reduction and Reliable Messaging (optional)

Enabling RSVP on an Interface

Perform this task to enable RSVP on an interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface [type number]

4. ip rsvp bandwidth [interface-kbps [sub-pool]]

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface [type number]

Example:

Router(config)# interface Ethernet1

Enters interface configuration mode.

The type number argument identifies the interface to be configured.

Step 4 

ip rsvp bandwidth [interface-kbps [sub-pool]]

Example:

Router(config-if)# ip rsvp bandwidth 7500 7500

Enables RSVP on an interface.

The optional interface-kbps and sub-pool arguments specify the amount of bandwidth that can be allocated by RSVP flows or to a single flow, respectively. Values are from 1 to 10,000,000, and 0 to 10,000,000, respectively.

Step 5 

end

Example:

Router(config-if)# end

Exits to privileged EXEC mode.


Enabling RSVP Refresh Reduction

Perform this task to enable RSVP refresh reduction.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip rsvp signalling refresh reduction

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip rsvp signalling refresh reduction

Example:

Router(config)# ip rsvp signalling refresh reduction

Enables refresh reduction.

Step 4 

end

Example:

Router(config)# end

Exits to privileged EXEC mode.


Verifying RSVP Refresh Reduction and Reliable Messaging

Perform this task to verify that the RSVP Refresh Reduction and Reliable Messaging feature is functioning.

SUMMARY STEPS

1. enable

2. clear ip rsvp counters [confirm]

3. show ip rsvp

4. show ip rsvp counters [interface interface_unit | summary | neighbor]

5. show ip rsvp interface [interface-type interface-number] [detail]

6. show ip rsvp neighbor [detail]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

clear ip rsvp counters [confirm]

Example:

Router# clear ip rsvp counters

(Optional) Clears (sets to zero) all IP RSVP counters that are being maintained by the router.

Step 3 

show ip rsvp

Example:

Router# show ip rsvp

(Optional) Displays RSVP rate-limiting, refresh-reduction, and neighbor information.

Step 4 

show ip rsvp counters [interface interface_unit | summary | neighbor]

Example:

Router# show ip rsvp counters summary

(Optional) Displays the number of RSVP messages that were sent and received on each interface.

The optional summary keyword displays the cumulative number of RSVP messages sent and received by the router over all interfaces.

Step 5 

show ip rsvp interface [interface-type interface-number] [detail]

Example:

Router# show ip rsvp interface detail

(Optional) Displays information about interfaces on which RSVP is enabled including the current allocation budget and maximum available bandwidth.

The optional detail keyword displays the bandwidth and signalling parameters.

Step 6 

show ip rsvp neighbor [detail]

Example:

Router# show ip rsvp neighbor detail

(Optional) Displays RSVP-neighbor information including IP addresses.

The optional detail keyword displays the current RSVP neighbors and identifies if the neighbor is using IP, User Datagram Protocol (UDP), or RSVP encapsulation for a specified interface or all interfaces.

Configuration Examples for RSVP Refresh Reduction and Reliable Messaging

This section provides the following configuration example:

RSVP Refresh Reduction and Reliable Messaging Example

RSVP Refresh Reduction and Reliable Messaging Example

In the following example, RSVP refresh reduction is enabled:

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)# interface Ethernet1

Router(config-if)# ip rsvp bandwidth 7500 7500

Router(config-if)# exit

Router(config)# ip rsvp signalling refresh reduction

Router(config)# end

The following example verifies that RSVP refresh reduction is enabled:

Router# show running-config

Building configuration...
Current configuration : 1503 bytes

!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname router
!
no logging buffered
logging rate-limit console 10 except errors
!
ip subnet-zero
ip cef
!
ip multicast-routing
no ip dhcp-client network-discovery
lcp max-session-starts 0
mpls traffic-eng tunnels
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 ip rsvp bandwidth 1705033 1705033
!
interface Tunnel777
 no ip address
 shutdown
!
interface Ethernet0
 ip address 192.168.0.195 255.0.0.0
 no ip mroute-cache
 media-type 10BaseT
!
interface Ethernet1
 ip address 192.168.5.2 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip pim dense-mode
 no ip mroute-cache
 media-type 10BaseT
 ip rsvp bandwidth 7500 7500
!
interface Ethernet2
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip pim dense-mode
 no ip mroute-cache
 media-type 10BaseT
 mpls traffic-eng tunnels
 ip rsvp bandwidth 7500 7500
!
interface Ethernet3
 ip address 192.168.2.2 255.255.255.0
 ip pim dense-mode
 media-type 10BaseT
 mpls traffic-eng tunnels
!
!
router eigrp 17
 network 192.168.0.0
 network 192.168.5.0
 network 192.168.12.0
 network 192.168.30.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip rsvp signalling refresh reduction
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
 transport input pad v120 telnet rlogin udptn
!
end

Additional References

The following sections provide additional references related to the RSVP Refresh Reduction and Reliable Messaging feature:

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Related Documents

Related Topic
Document Title

RSVP commands: complete command syntax, command mode, defaults, usage guidelines, and examples

Cisco IOS Release 12.0 Quality of Service Solutions Command Reference

QoS features including signaling, classification, and congestion management

Cisco IOS Release 12.0 Quality of Service Solutions Configuration Guide


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs 1
MIBs Link

RFC 2206, RSVP Management Information Base using SMIv2

RFC 2702, Requirements for Traffic Engineering over MPLS

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

1 Not all supported MIBs are listed.


RFCs

RFCs 1
Title

RFC 2205

Resource Reservation Protocol

RFC 2209

RSVP—Version 1 Message Processing Rules

RFC 2210

The Use of RSVP with IETF Integrated Services

RFC 2211/2212

Specification of the Controlled-Load Network Element Service

RFC 2749

Common Open Policy Service (COPS) Usage for RSVP

RFC 2750

RSVP Extensions for Policy Control

RFC 2814

SBM Subnet Bandwidth Manager: A Protocol for RSVP-based Admission Control over IEEE 802-style networks

RFC 2961

RSVP Refresh Overhead Reduction Extensions

RFC 2996

Format of the RSVP DCLASS Object

1 Not all supported RFCs are listed.


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

This section documents new and modified commands. All other commands used with this feature are documented in the Cisco IOS Release 12.0 command reference publications.

New Commands

ip rsvp signalling refresh interval

ip rsvp signalling refresh misses

Modified Commands

show ip rsvp

ip rsvp signalling refresh interval

To specify the interval between sending refresh messages for each Resource Reservation Protocol (RSVP) state, use the ip rsvp signalling refresh interval command in global configuration mode. To set the interval to its default value, use the no form of the command.

ip rsvp signalling refresh interval interval-value

no ip rsvp signalling refresh-interval

Syntax Description

interval-value

Time between sending refreshes for each RSVP state. Specified in milliseconds and ranges from 5000 to 4294967295 milliseconds; default value is 30000 milliseconds (30 seconds).


Defaults

30 seconds

Command Modes

Global configuration

Command History

Release
Modification

12.0(26)S

This command was introduced.


Usage Guidelines

Use the ip rsvp signalling refresh interval command to specify the interval between sending refresh messages for each RSVP state.

The RSVP protocol relies on a soft-state mechanism to maintain state consistency in the face of network losses. This mechanism is based on continuous refresh messages to keep a state current. Each RSVP router is responsible for sending periodic refresh messages to its neighbors.

Examples

The following example specifies a refresh interval of 60000 milliseconds (60 seconds):

Router(config)# ip rsvp signalling refresh interval 60000

The following example returns the refresh interval to the default value of 30 seconds:

Router(config)# no ip rsvp signalling refresh interval

Related Commands

Command
Description

ip rsvp signalling refresh misses

Specifies the number of successive refresh messages that can be missed before RSVP removes a state from the database.


ip rsvp signalling refresh misses

To specify the number of successive refresh messages that can be missed before Resource Reservation Protocol (RSVP) removes a state from the database, use the ip rsvp signalling refresh misses command in global configuration mode. To return the missed refresh limit to its default value, use the no form of this command.

ip rsvp signalling refresh misses msg-count

no ip rsvp signalling refresh misses

Syntax Description

msg-count

Number of successive refresh messages that can be missed before RSVP considers the state expired and tears it down. Range is 2 to 10.


Defaults

4 messages

Command Modes

Global configuration

Command History

Release
Modification

12.0(26)S

This command was introduced.


Usage Guidelines

Use the ip rsvp signalling refresh misses command to specify the number of successive refresh messages that can be missed before RSVP regards the router state as expired and removes that state from the database.

Examples

The following example specifies a missed refresh limit of 6 messages:

Router(config)# ip rsvp signalling refresh misses 6

The following example returns the refresh misses limit to the default value of 4:

Router(config)# no ip rsvp signalling refresh misses

Related Commands

Command
Description

ip rsvp signalling refresh interval

Specifies the interval between sending refresh messages for each RSVP state.


show ip rsvp

To display specific information for Resource Reservation Protocol (RSVP) categories, use the show ip rsvp command in EXEC mode.

show ip rsvp [counters | fast-reroute | hello | host | installed | interface | listeners | neighbor | request | reservation | sender | signalling]

Syntax Description

counters

(Optional) RSVP statistics.

fast-reroute

(Optional) RSVP fast-reroute (FRR) database.

hello

(Optional) RSVP hello extension.

host

(Optional) RSVP endpoint senders and receivers.

installed

(Optional) RSVP installed reservations.

interface

(Optional) RSVP interface information.

listeners

(Optional) RSVP listeners.

neighbor

(Optional) RSVP neighbor information.

request

(Optional) RSVP reservations upstream.

reservation

(Optional) RSVP reservation requests from downstream.

sender

(Optional) RSVP path state information.

signalling

(Optional) RSVP signalling information.


Defaults

No default behavior or values

Command Modes

EXEC

Command History

Release
Modification

12.0(3)T

This command was introduced.

12.2(13)T

The listeners and policy keywords were added. This command was also modified to display RSVP global settings when no keywords or arguments are entered.

12.0(24)S

The atm-peak-rate-limit, policy, precedence, sbm, and tos keywords were deleted, and this command was integrated into Cisco IOS Release 12.0(24)S.

12.0(26)S

Signaling parameters were added to the output display.


Examples

The following example shows RSVP rate-limiting, refresh-reduction, and neighbor information:

Router# show ip rsvp

RSVP:enabled (on 2 interface(s))
Signalling:
  Refresh interval (msec):100000
  Refresh misses:6

Rate Limiting:enabled
  Max msgs per interval:4
  Interval length (msec):20
  Max queue size:500
  Max msgs per second:200

Refresh Reduction:enabled
  ACK delay (msec):250
  Initial retransmit delay (msec):1000
  Local epoch:0x16528C
  Message IDs:in use 580, total allocated 3018, total freed 2438

Neighbors:1
  RSVP encap:1 UDP encap:0 RSVP and UDP encap:0

Local policy:
COPS:

Generic policy settings:
    Default policy:Accept all
    Preemption:    Disabled

Table 1 describes the significant fields shown in the display.

Table 1 show ip rsvp Field Descriptions 

Field
Description

RSVP: enabled (active) or disabled (not active)

The RSVP state and the number of interfaces affected (if state is enabled).

Signalling:

The signaling parameters in effect including the following:

Refresh interval (msecs) = timeframe in milliseconds between sending refresh messages for each RSVP state.

Refresh misses = number of successive refresh messages that can be missed before RSVP removes a state from the database.

Rate Limiting: enabled (active) or disabled (not active)

The RSVP rate-limiting parameters in effect including the following:

Max msgs per interval = number of messages allowed to be sent per interval (timeframe).

Interval length (msecs) = interval (timeframe) length in milliseconds.

Max queue size = maximum size of the message queue in bytes.

Max msgs per second = maximum number of messages allowed to be sent per second.

Refresh Reduction: enabled (active) or disabled (not active)

The RSVP refresh-reduction parameters in effect including the following:

ACK delay (msec) = how long in milliseconds before the receiving router sends an acknowledgment (ACK).

Initial retransmit delay (msec) = how long in milliseconds before the router retransmits a message.

Local epoch = the RSVP message ID number space identifier; randomly generated each time a node reboots or the RSVP process restarts.

Message IDs = the number of message IDs in use, the total number allocated, and the total number available (freed).

Neighbors

The total number of neighbors and the types of encapsulation in use including RSVP and User Datagram Protocol (UDP).

Local policy

The local policy currently configured.

COPS

The Common Open Policy Service (COPS) currently in effect.

Generic policy settings

Policy settings that are not specific to COPS or the local policy.

Default policy: Accept all means all RSVP messages are accepted and forwarded. Reject all means all RSVP messages are rejected.

Preemption: Disabled means RSVP is not prioritizing reservations and allocating bandwidth accordingly. Enabled means RSVP is prioritizing reservations and allocating more bandwidth to those with the highest priority.


Related Commands

Command
Description

debug ip rsvp

Displays debug messages for RSVP categories.


Glossary

flow—A stream of data traveling between two endpoints across a network (for example, from one LAN station to another). Multiple flows can be transmitted on a single circuit.

latency—The delay between the time a device receives a packet and the time that packet is forwarded out the destination port.

MPLS—Multiprotocol Label Switching. A method for directing packets primarily through Layer 2 switching rather than Layer 3 routing. In MPLS, packets are assigned short, fixed-length labels at the ingress to an MPLS cloud by using the concept of forwarding equivalence classes. Within the MPLS domain, the labels are used to make forwarding decisions mostly without recourse to the original packet headers. MPLS is formerly known as tag switching.

packet—A logical grouping of information that includes a header containing control information and (usually) user data. Packets most often refer to network layer units of data.

refresh message—A message that represents a previously advertised state, contains the same objects and information as a previously transmitted message, and is sent over the same path.

router—A network layer device that uses one or more metrics to determine the optimal path along which network traffic should be forwarded. Routers forward packets from one network to another based on network layer information.

RSVP—Resource Reservation Protocol. A protocol that supports the reservation of resources across an IP network. Applications running on IP end systems can use RSVP to indicate to other nodes the nature (bandwidth, jitter, maximum burst, and so on) of the packet streams they want to receive.

soft state—The status that RSVP maintains in routers and end nodes so that they can be updated by certain RSVP messages. The soft state characteristic permits an RSVP network to support dynamic group membership changes and adapt to changes in routing.

subpool—A division of bandwidth such that no one tunnel dominates.

tunnel—A secure communication path between two peers, such as routers.


Note Refer to the Internetworking Terms and Acronyms for terms not included in this glossary.