Guest

Cisco IOS Software Releases 12.0 S

RSVP Refresh Reduction and Reliable Messaging

  • Viewing Options

  • PDF (222.7 KB)
  • Feedback
RSVP Refresh Reduction and Reliable Messaging

Table Of Contents

RSVP Refresh Reduction and Reliable Messaging

Contents

Prerequisites for RSVP Refresh Reduction and Reliable Messaging

Restrictions for RSVP Refresh Reduction and Reliable Messaging

Information About RSVP Refresh Reduction and Reliable Messaging

Feature Design of RSVP Refresh Reduction and Reliable Messaging

Types of Messages in RSVP Refresh Reduction and Reliable Messaging

Reliable Messages

Bundle Messages

Summary Refresh Messages

Benefits of RSVP Refresh Reduction and Reliable Messaging

How to Configure RSVP Refresh Reduction and Reliable Messaging

Enabling RSVP on an Interface

Enabling RSVP Refresh Reduction

Verifying RSVP Refresh Reduction and Reliable Messaging

Configuration Examples for RSVP Refresh Reduction and Reliable Messaging

RSVP Refresh Reduction and Reliable Messaging: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

ip rsvp signalling rate-limit

show ip rsvp signalling rate-limit

Glossary


RSVP Refresh Reduction and Reliable Messaging


First Published: November 25, 2002
Last Updated: February 19, 2007

The RSVP Refresh Reduction and Reliable Messaging feature includes refresh reduction, which improves the scalability, latency, and reliability of Resource Reservation Protocol (RSVP) signaling to enhance network performance and message delivery.

History for the RSVP Refresh Reduction and Reliable Messaging Feature

Release
Modification

12.2(13)T

This feature was introduced.

12.0(24)S

This feature was integrated into Cisco IOS Release 12.0(24)S.

12.2(14)S

This feature was integrated into Cisco IOS Release 12.2(14)S.

12.0(26)S

Two commands, ip rsvp signalling refresh misses and ip rsvp signalling refresh interval, were added into Cisco IOS Release 12.0(26)S.

12.0(29)S

The burst and max-size argument defaults for the ip rsvp signalling rate-limit command were increased to 8 messages and 2000 bytes, respectively.

12.2(28)SB

This feature was integrated into Cisco IOS Release 12.2(28)SB.

12.2(18)SXF5

This feature was integrated into Cisco IOS Release 12.2(18)SXF5.

12.2(33)SRB

This feature was integrated into Cisco IOS Release 12.2(33)SRB.


Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for RSVP Refresh Reduction and Reliable Messaging

Restrictions for RSVP Refresh Reduction and Reliable Messaging

Information About RSVP Refresh Reduction and Reliable Messaging

How to Configure RSVP Refresh Reduction and Reliable Messaging

Configuration Examples for RSVP Refresh Reduction and Reliable Messaging

Additional References

Command Reference

Glossary

Prerequisites for RSVP Refresh Reduction and Reliable Messaging

RSVP must be configured on two or more routers within the network before you can use the RSVP Refresh Reduction and Reliable Messaging feature.

Restrictions for RSVP Refresh Reduction and Reliable Messaging

Multicast flows are not supported for the reliable messages and summary refresh features.

Information About RSVP Refresh Reduction and Reliable Messaging

To configure the RSVP Refresh Reduction and Reliable Messaging feature, you should understand the following concepts:

Feature Design of RSVP Refresh Reduction and Reliable Messaging

Types of Messages in RSVP Refresh Reduction and Reliable Messaging

Benefits of RSVP Refresh Reduction and Reliable Messaging

Feature Design of RSVP Refresh Reduction and Reliable Messaging

RSVP is a network-control, soft-state protocol that enables Internet applications to obtain special qualities of service (QoS) for their data flows. As a soft-state protocol, RSVP requires that state be periodically refreshed. If refresh messages are not transmitted during a specified interval, RSVP state automatically times out and is deleted.

In a network that uses RSVP signaling, reliability and latency problems occur when an RSVP message is lost in transmission. A lost RSVP setup message can cause a delayed or failed reservation; a lost RSVP refresh message can cause a delay in the modification of a reservation or in a reservation timeout. Intolerant applications can fail as a result.

Reliability problems can also occur when there is excessive RSVP refresh message traffic caused by a large number of reservations in the network. Using summary refresh messages can improve reliability by significantly reducing the amount of RSVP refresh traffic.


Note RSVP packets consist of headers that identify the types of messages, and object fields that contain attributes and properties describing how to interpret and act on the content.


Types of Messages in RSVP Refresh Reduction and Reliable Messaging

The RSVP Refresh Reduction and Reliable Messaging feature (Figure 1) includes refresh reduction, which improves the scalability, latency, and reliability of RSVP signaling by introducing the following extensions:

Reliable messages (MESSAGE_ID, MESSAGE_ID_ACK objects, and ACK messages)

Bundle messages (reception and processing only)

Summary refresh messages (MESSAGE_ID_LIST and MESSAGE_ID_NACK objects)

Figure 1 RSVP Refresh Reduction and Reliable Messaging

Reliable Messages

The reliable messages extension supports dependable message delivery among neighboring routers by implementing an acknowledgment mechanism that consists of a MESSAGE_ID object and a MESSAGE_ID_ACK object. The acknowledgments can be transmitted in an ACK message or piggybacked in other RSVP messages.

Each RSVP message contains one MESSAGE_ID object. If the ACK_Desired flag field is set within the MESSAGE_ID object, the receiver transmits a MESSAGE_ID_ACK object to the sender to confirm delivery.

Bundle Messages

A bundle message consists of several standard RSVP messages that are grouped into a single RSVP message.

A bundle message must contain at least one submessage. A submessage can be any RSVP message type other than another bundle message. Submessage types include Path, PathErr, Resv, ResvTear, ResvErr, ResvConf, and ACK.

Bundle messages are addressed directly to the RSVP neighbor. The bundle header immediately follows the IP header, and there is no intermediate transport header.

When a router receives a bundle message that is not addressed to one of its local IP addresses, it forwards the message.


Note Bundle messages can be received, but not sent.


Summary Refresh Messages

A summary refresh message supports the refreshing of RSVP state without the transmission of conventional Path and Resv messages. Therefore, the amount of information that must be transmitted and processed to maintain RSVP state synchronization is greatly reduced.

A summary refresh message carries a set of MESSAGE_ID objects that identify the Path and Resv states that should be refreshed. When an RSVP node receives a summary refresh message, the node matches each received MESSAGE_ID object with the locally installed Path or Resv state. If the MESSAGE_ID objects match the local state, the state is updated as if a standard RSVP refresh message were received. However, if a MESSAGE_ID object does not match the receiver's local state, the receiver notifies the sender of the summary refresh message by transmitting a MESSAGE_ID_NACK object.

When a summary refresh message is used to refresh the state of an RSVP session, the transmission of conventional refresh messages is suppressed. The summary refresh extension cannot be used for a Path or Resv message that contains changes to a previously advertised state. Also, only a state that was previously advertised in Path or Resv messages containing MESSAGE_ID objects can be refreshed by using a summary refresh message.

Benefits of RSVP Refresh Reduction and Reliable Messaging

Enhanced Network Performance

Refresh reduction reduces the volume of steady-state network traffic generated, the amount of CPU resources used, and the response time, thereby enhancing network performance.

Improved Message Delivery

The MESSAGE_ID and the MESSAGE_ID_ACK objects ensure the reliable delivery of messages and support rapid state refresh when a network problem occurs. For example, MESSAGE_ID_ACK objects are used to detect link transmission losses.

How to Configure RSVP Refresh Reduction and Reliable Messaging

This section contains the following procedures:

Enabling RSVP on an Interface (required)

Enabling RSVP Refresh Reduction (required)

Verifying RSVP Refresh Reduction and Reliable Messaging (optional)

Enabling RSVP on an Interface

Perform the following task to enable RSVP on an interface.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip rsvp bandwidth [interface-kbps [sub-pool]]

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface Ethernet1

Enters interface configuration mode.

The type and number arguments identify the interface to be configured.

Step 4 

ip rsvp bandwidth [interface-kbps [sub-pool]]

Example:

Router(config-if)# ip rsvp bandwidth 7500 7500

Enables RSVP on an interface.

The optional interface-kbps and sub-pool arguments specify the amount of bandwidth that can be allocated by RSVP flows or to a single flow, respectively. Values are from 1 to 10000000, and from 0 to 10000000, respectively.

Step 5 

end

Example:

Router(config-if)# end

Returns to privileged EXEC mode.


Enabling RSVP Refresh Reduction

Perform the following task to enable RSVP refresh reduction.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip rsvp signalling refresh reduction

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip rsvp signalling refresh reduction

Example:

Router(config)# ip rsvp signalling refresh reduction

Enables refresh reduction.

Step 4 

end

Example:

Router(config)# end

Returns to privileged EXEC mode.


Verifying RSVP Refresh Reduction and Reliable Messaging

Perform the following task to verify that the RSVP Refresh Reduction and Reliable Messaging feature is functioning.

SUMMARY STEPS

1. enable

2. clear ip rsvp counters [confirm]

3. show ip rsvp

4. show ip rsvp counters [interface interface-unit | summary | neighbor]

5. show ip rsvp interface [interface-type interface-number] [detail]

6. show ip rsvp neighbor [detail]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

clear ip rsvp counters [confirm]

Example:

Router# clear ip rsvp counters

(Optional) Clears (sets to zero) all IP RSVP counters that are being maintained by the router.

Step 3 

show ip rsvp

Example:

Router# show ip rsvp

(Optional) Displays RSVP rate-limiting, refresh-reduction, and neighbor information.

Step 4 

show ip rsvp counters [interface interface-unit | summary | neighbor]

Example:

Router# show ip rsvp counters summary

(Optional) Displays the number of RSVP messages that were sent and received on each interface.

The optional summary keyword displays the cumulative number of RSVP messages sent and received by the router over all interfaces.

Step 5 

show ip rsvp interface [interface-type interface-number] [detail]

Example:

Router# show ip rsvp interface detail

(Optional) Displays information about interfaces on which RSVP is enabled including the current allocation budget and maximum available bandwidth.

The optional detail keyword displays the bandwidth and signaling parameters.

Step 6 

show ip rsvp neighbor [detail]

Example:

Router# show ip rsvp neighbor detail

(Optional) Displays RSVP-neighbor information including IP addresses.

The optional detail keyword displays the current RSVP neighbors and identifies if the neighbor is using IP, User Datagram Protocol (UDP), or RSVP encapsulation for a specified interface or all interfaces.

Configuration Examples for RSVP Refresh Reduction and Reliable Messaging

This section provides the following configuration example:

RSVP Refresh Reduction and Reliable Messaging: Example

RSVP Refresh Reduction and Reliable Messaging: Example

In the following example, RSVP refresh reduction is enabled:

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface Ethernet1
Router(config-if)# ip rsvp bandwidth 7500 7500
Router(config-if)# exit
Router(config)# ip rsvp signalling refresh reduction
Router(config)# end

The following example verifies that RSVP refresh reduction is enabled:

Router# show running-config

Building configuration...
Current configuration : 1503 bytes

!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname Router
!
no logging buffered
logging rate-limit console 10 except errors
!
ip subnet-zero
ip cef
!
ip multicast-routing
no ip dhcp-client network-discovery
lcp max-session-starts 0
mpls traffic-eng tunnels
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 ip rsvp bandwidth 1705033 1705033
!
interface Tunnel777
 no ip address
 shutdown
!
interface Ethernet0
 ip address 192.168.0.195 255.0.0.0
 no ip mroute-cache
 media-type 10BaseT
!
interface Ethernet1
 ip address 192.168.5.2 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip pim dense-mode
 no ip mroute-cache
 media-type 10BaseT
 ip rsvp bandwidth 7500 7500
!
interface Ethernet2
 ip address 192.168.1.2 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip pim dense-mode
 no ip mroute-cache
 media-type 10BaseT
 mpls traffic-eng tunnels
 ip rsvp bandwidth 7500 7500
!
interface Ethernet3
 ip address 192.168.2.2 255.255.255.0
 ip pim dense-mode
 media-type 10BaseT
 mpls traffic-eng tunnels
!
!
router eigrp 17
 network 192.168.0.0
 network 192.168.5.0
 network 192.168.12.0
 network 192.168.30.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip rsvp signalling refresh reduction
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
 transport input pad v120 telnet rlogin udptn
!
end

Additional References

The following sections provide references related to the RSVP Refresh Reduction and Reliable Messaging feature.

Related Documents

Related Topic
Document Title

RSVP commands: complete command syntax, command mode, defaults, usage guidelines, and examples

Cisco IOS Quality of Service Solutions Command Reference, Release 12.4T

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2SB

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2SR

QoS features including signaling, classification, and congestion management

Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.4


Standards

Standard
Title

None


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 2205

Resource Reservation Protocol

RFC 2206

RSVP Management Information Base Using SMIv2

RFC 2209

RSVP—Version 1 Message Processing Rules

RFC 2210

The Use of RSVP with IETF Integrated Services

RFC 2211/2212

Specification of the Controlled-Load Network Element Service

RFC 2702

Requirements for Traffic Engineering over MPLS

RFC 2749

Common Open Policy Service (COPS) Usage for RSVP

RFC 2750

RSVP Extensions for Policy Control

RFC 2814

SBM Subnet Bandwidth Manager: A Protocol for RSVP-based Admission Control over IEEE 802-style Networks

RFC 2961

RSVP Refresh Overhead Reduction Extensions

RFC 2996

Format of the RSVP DCLASS Object


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Command Reference

This section documents modified commands only.

ip rsvp signalling rate-limit

show ip rsvp signalling rate-limit

ip rsvp signalling rate-limit

To control the transmission rate for Resource Reservation Protocol (RSVP) messages sent to a neighboring router during a specified amount of time, use the ip rsvp signalling rate-limit command in global configuration mode. To disable this function, use the no form of this command.

Syntax for T Releases

ip rsvp signalling rate-limit [burst] [max-size] [period]

no ip rsvp signalling rate-limit

Syntax for 12.0S and 12.2S Releases

ip rsvp signalling rate-limit [burst] [limit] [max-size] [period]

no ip rsvp signalling rate-limit

Syntax Description

burst

(Optional) Maximum number of RSVP messages allowed to be sent to a neighboring router during this interval. The range is from 1 to 5000. The default is 8.

limit

(Optional) Maximum number of messages to send per queue interval. The range is from 1 to 5000. The default is 37.

max-size

(Optional) Maximum size of the message queue, in bytes. The range is from 1 to 5000. The default is 2000.

period

(Optional) Length of the interval (time frame) in milliseconds (ms). The range is from 10 to 5000. The default is 20.


Command Default

This command is disabled by default; therefore, no messages are sent.

Command Modes

Global configuration

Command History

Release
Modification

12.2(13)T

This command was changed from ip rsvp msg-pacing to ip rsvp signalling rate-limit.

12.0(24)S

The limit argument was added and this command was integrated into Cisco IOS Release 12.0(24)S.

12.0(29)S

The burst and max-size defaults were increased to 8 messages and 2000 bytes, respectively.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(18)SXF5

This command was integrated into Cisco IOS Release 12.2(18)SXF5.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

Use the ip rsvp signalling rate-limit command to prevent a burst of RSVP traffic engineering signaling messages from overflowing the input queue of a receiving router, which would cause the router to drop some messages. Dropped messages substantially delay the completion of signaling.

This command replaces the ip rsvp msg-pacing command.

Examples

The following command shows how every 10 ms 6 messages with a message queue of 500 bytes are sent to any neighboring router:

Router(config)# ip rsvp signalling rate-limit 10 6 500

Related Commands

Command
Description

debug ip rsvp rate-limit

Displays debug messages for RSVP rate-limiting events.


show ip rsvp signalling rate-limit

To display the Resource Reservation Protocol (RSVP) rate-limiting parameters, use the show ip rsvp signalling rate-limit command in user EXEC or privileged EXEC mode.

show ip rsvp signalling rate-limit

Syntax Description

This command has no arguments or keywords.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.2(13)T

This command was introduced.

12.0(24)S

This command was integrated into Cisco IOS Release 12.0(24)S.

12.0(29)S

The command output was modified to show the revised rate-limiting parameters.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.2(18)SXF5

This command was integrated into Cisco IOS Release 12.2(18)SXF5.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Examples

The following command shows the rate-limiting parameters:

Router# show ip rsvp signalling rate-limit

Rate Limiting:
  Max msgs per interval: 4
  Interval length (msec): 20
  Max queue size: 500
  Max msgs per second: 200

Table 1 describes the fields shown in the display.

Table 1 show ip rsvp signalling rate-limit Field Descriptions 

Field
Description

Rate Limiting

The RSVP rate-limiting parameters are enabled or disabled. They include the following:

Burst = number of messages sent each period from the queue.

Limit = maximum number of messages sent each period from the queue.

Max size = maximum size of the message queue in bytes.

Period (msec) = interval (time frame) length in milliseconds.

Max rate (msgs/sec) = maximum number of messages allowed to be sent per second.


Related Commands

Command
Description

clear ip rsvp signalling rate-limit

Clears (sets to zero) the number of messages that were dropped because of a full queue.

debug ip rsvp rate-limit

Displays debug messages for RSVP rate-limiting events.

ip rsvp signalling rate-limit

Controls the transmission rate for RSVP messages sent to a neighboring router during a specified amount of time.


Glossary

flow—A stream of data traveling between two endpoints across a network (for example, from one LAN station to another). Multiple flows can be transmitted on a single circuit.

latency—The delay between the time a device receives a packet and the time that packet is forwarded out the destination port.

MPLS—Multiprotocol Label Switching. A method for directing packets primarily through Layer 2 switching rather than Layer 3 routing. In MPLS, packets are assigned short, fixed-length labels at the ingress to an MPLS cloud by using the concept of forwarding equivalence classes. Within the MPLS domain, the labels are used to make forwarding decisions mostly without recourse to the original packet headers. MPLS is formerly known as tag switching.

packet—A logical grouping of information that includes a header containing control information and (usually) user data. Packets most often refer to network layer units of data.

refresh message—A message that represents a previously advertised state, contains the same objects and information as a previously transmitted message, and is sent over the same path.

router—A network layer device that uses one or more metrics to determine the optimal path along which network traffic should be forwarded. Routers forward packets from one network to another based on network layer information.

RSVP—Resource Reservation Protocol. A protocol that supports the reservation of resources across an IP network. Applications running on IP end systems can use RSVP to indicate to other nodes the nature (bandwidth, jitter, maximum burst, and so on) of the packet streams they want to receive.

soft state—The status that RSVP maintains in routers and end nodes so that they can be updated by certain RSVP messages. The soft state characteristic permits an RSVP network to support dynamic group membership changes and adapt to changes in routing.

subpool—A division of bandwidth such that no one tunnel dominates.

tunnel—A secure communication path between two peers, such as routers.


Note See Internetworking Terms and Acronyms for terms not included in this glossary.