Guest

Cisco IOS Software Releases 12.0 S

MPLS LDP-IGP Synchronization

  • Viewing Options

  • PDF (330.8 KB)
  • Feedback
MPLS LDP-IGP Synchronization

Table Of Contents

MPLS LDP-IGP Synchronization

Contents

Prerequisites for MPLS LDP-IGP Synchronization

Restrictions for MPLS LDP-IGP Synchronization

Information About MPLS LDP-IGP Synchronization

How MPLS LDP-IGP Synchronization Works

MPLS LDP-IGP Synchronization Requires Peer To Be Reachable

MPLS LDP-IGP Synchronization Compatibility with IGP Nonstop Forwarding

MPLS LDP-IGP Synchronization Compatibility with LDP Graceful Restart

How to Configure MPLS LDP-IGP Synchronization

Configuring MPLS LDP-IGP Synchronization with OSPF Interfaces

Selectively Disabling MPLS LDP-IGP Synchronization from Some OSPF Interfaces

Verifying MPLS LDP-IGP Synchronization with OSPF

Configuring MPLS LDP-IGP Synchronization with IS-IS Interfaces

Configuring MPLS LDP-IGP Synchronization on All IS-IS Interfaces

Configuring MPLS LDP-IGP Synchronization on an IS-IS Interface

Selectively Disabling MPLS LDP-IGP Synchronization from Some IS-IS Interfaces

Verifying MPLS LDP-IGP Synchronization with IS-IS

Troubleshooting Tips

Configuration Examples for MPLS LDP-IGP Synchronization

MPLS LDP-IGP Synchronization with OSPF Examples

MPLS LDP-IGP Synchronization with IS-IS Examples

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

debug mpls ldp igp sync

mpls ldp igp sync

mpls ldp igp sync holddown

mpls ldp sync

show ip ospf mpls ldp interface

show isis mpls ldp

show mpls ldp igp sync


MPLS LDP-IGP Synchronization


First Published: November 20, 2004
Last Updated: February 19, 2007

Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) Interior Gateway Protocol (IGP) Synchronization ensures that LDP is fully established before the IGP path is used for switching.

Feature History for MPLS LDP-IGP Synchronization

Release
Modification

12.0(30)S

This feature was introduced.

12.3(14)T

This feature was integrated into Cisco IOS Release 12.3(14)T.

12.0(32)SY

Support for enabling synchronization on interfaces running Intermediate System-to-Intermediate System (IS-IS) processes was added to Cisco IOS Release 12.0(32)SY.

12.2(33)SRB

This feature was integrated into Cisco IOS Release 12.2(33)SRB.

Note MPLS LDP-IGP Synchronization for IS-IS is not supported in this release.


Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for MPLS LDP-IGP Synchronization

Restrictions for MPLS LDP-IGP Synchronization

Information About MPLS LDP-IGP Synchronization

How to Configure MPLS LDP-IGP Synchronization

Configuration Examples for MPLS LDP-IGP Synchronization

Additional References

Command Reference

Prerequisites for MPLS LDP-IGP Synchronization

This feature is only supported on interfaces running OSPF or IS-IS processes.

This feature works when LDP is enabled on interfaces with either the mpls ip or mpls ldp autoconfig command.

Restrictions for MPLS LDP-IGP Synchronization

In Cisco IOS Release 12.2(33)SRB, the MPLS LDP-IGP Synchronization is not supported with IS-IS. Only OSPF is supported.

TDP is not supported. You must specify that the default label distribution protocol is LDP for a router or for an interface.

This feature is not supported on tunnel interfaces or LC-ATM interfaces.

This feature is not supported with interface-local label space or downstream-on-demand (DoD) requests.

This feature does not support targeted LDP sessions. Therefore, Any Transport over MPLS (AToM) sessions are not supported.

Information About MPLS LDP-IGP Synchronization

To configure LDP-IGP Synchronization, you should understand the following concepts:

How MPLS LDP-IGP Synchronization Works

MPLS LDP-IGP Synchronization Requires Peer To Be Reachable

MPLS LDP-IGP Synchronization Compatibility with IGP Nonstop Forwarding

MPLS LDP-IGP Synchronization Compatibility with LDP Graceful Restart

How MPLS LDP-IGP Synchronization Works

Packet loss can occur because the actions of the IGP and LDP are not synchronized. Packet loss can occur in the following situations:

When an IGP adjacency is established, the router begins forwarding packets using the new adjacency before the LDP label exchange completes between the peers on that link.

If an LDP session closes, the router continues to forward traffic using the link associated with the LDP peer rather than an alternate pathway with a fully synchronized LDP session.

The MPLS LDP-IGP Synchronization feature:

Provides a means to synchronize LDP and IGPs to minimize MPLS packet loss.

Enables you to globally enable LDP-IGP Synchronization on each interface associated with an IGP Open Shortest Path First (OSPF) or IS-IS process.

Provides a means to disable LDP-IGP Synchronization on interfaces that you do not want enabled.

Prevents MPLS packet loss due to synchronization conflicts.

Works when LDP is enabled on interfaces using either the mpls ip or mpls ldp autoconfig command.

To enable LDP-IGP Synchronization on each interface that belongs to an OSPF or IS-IS process, enter the mpls ldp sync command. If you do not want some of the interfaces to have LDP-IGP Synchronization enabled, issue the no mpls ldp igp sync command on those interfaces.

If the LDP peer is reachable, the IGP waits indefinitely (by default) for synchronization to be achieved. To limit the length of time the IGP session must wait, enter the mpls ldp igp sync holddown command. If the LDP peer is not reachable, the IGP establishes the adjacency to enable the LDP session to be established.

When an IGP adjacency is established on a link but LDP-IGP Synchronization is not yet achieved or is lost, the IGP advertises the max-metric on that link.

MPLS LDP-IGP Synchronization Requires Peer To Be Reachable

When the MPLS LDP-IGP Synchronization feature is enabled on an interface, LDP determines if any peer connected by the interface is reachable by looking up the peer's transport address in routing table. If a routing entry (including longest match and/or default routing entry) for the peer exists, LDP assumes that LDP-IGP Synchronization is required for the interface and notifies the IGP to wait for LDP convergence.

This requires that the routing table be correct and accurate for peer's transport address. If the routing table shows there is a route for the peer's transport address, that route must be able to reach the peer's transport address. However, if the route is a summary route, default route, or a statically configured route, it might not the correct route for the peer. You must verify that the route in the routing table can reach the peer's transport address.

When the routing table has an inaccurate route for peer's transport address, LDP cannot set up a session with the peer, which causes the IGP wait for LDP convergence unnecessarily for the sync holddown time.

MPLS LDP-IGP Synchronization Compatibility with IGP Nonstop Forwarding

The MPLS LDP-IGP Synchronization feature is not supported during the startup period if IGP NSF is configured. The MPLS LDP-IGP Synchronization feature conflicts with IGP NSF when the IGP is performing NSF during startup. After the NSF startup is complete, the MPLS LDP-IGP Synchronization feature is supported.

MPLS LDP-IGP Synchronization Compatibility with LDP Graceful Restart

LDP Graceful Restart protects traffic when an LDP session is lost. If an interface that supports a Graceful Restart-enabled LDP session fails, MPLS LDP-IGP Synchronization is still achieved on the interface while it is protected by Graceful Restart. MPLS LDP-IGP Synchronization is eventually lost under the following circumstances:

If LDP fails to restart before the LDP Graceful Restart reconnect timer expires.

If an LDP session restarts through other interfaces, but the LDP session on the protected interface fails to recover when the LDP Graceful Restart recovery timer expires.

How to Configure MPLS LDP-IGP Synchronization

This section contains the following procedures:

Configuring MPLS LDP-IGP Synchronization with OSPF Interfaces (required)

Selectively Disabling MPLS LDP-IGP Synchronization from Some OSPF Interfaces (optional)

Verifying MPLS LDP-IGP Synchronization with OSPF (optional)

Configuring MPLS LDP-IGP Synchronization with IS-IS Interfaces (required)

Selectively Disabling MPLS LDP-IGP Synchronization from Some IS-IS Interfaces (optional)

Verifying MPLS LDP-IGP Synchronization with IS-IS (optional)

Configuring MPLS LDP-IGP Synchronization with OSPF Interfaces

The following sections contain the steps and examples for configuring MPLS LDP-IGP Synchronization for interfaces running OSPF processes:

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. interface interface

6. ip address prefix mask

7. mpls ip

8. exit

9. router ospf process-id

10. network ip-address wildcard-mask area area-id

11. mpls ldp sync

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 4 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 5 

interface interface

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 6 

ip address prefix mask

Example:

Router(config-if)# ip address 10.25.0.11 255.255.255.255

Assigns an IP address to the interface.

Step 7 

mpls ip

Example:

Router(config-if)# mpls ip

Enables hop-by-hop forwarding on the interface.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 9 

router ospf process-id

Example:

Router(config)# router ospf 1

Enables OSPF routing and enters router configuration mode.

Step 10 

network ip-address wildcard-mask area area-id

Example:

Router(config-router)# network 10.0.0.0 0.255.255.255 area 3

Defines an interface on which OSPF runs and defines the area ID for that interface.

Step 11 

mpls ldp sync

Example:

Router(config-router)# mpls ldp sync

Enables LDP-IGP Synchronization for interfaces belonging to an OSPF process.

Selectively Disabling MPLS LDP-IGP Synchronization from Some OSPF Interfaces

When you issue the mpls ldp sync command, all of the interfaces that belong to an OSPF process are enabled for LDP-IGP Synchronization. To remove LDP-IGP Synchronization from some interfaces, use the no form of the mpls ldp igp sync command on those interfaces. The following configuration steps show how to disable LDP-IGP Synchronization from some of the interfaces after they are configured with LDP-IGP Synchronization through the mpls ldp sync command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface

4. no mpls ldp igp sync

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface interface

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp sync

Example:

Router(config-if)# no mpls ldp igp sync

Disables LDP-IGP Synchronization for that interface.

Verifying MPLS LDP-IGP Synchronization with OSPF

After you configure the interfaces for LDP, OSPF, and LDP-IGP Synchronization, verify that the configuration is working correctly using the show mpls ldp igp sync and show ip ospf mpls ldp interface commands.

SUMMARY STEPS

1. show mpls ldp igp sync

2. show ip ospf mpls ldp interface

DETAILED STEPS


Step 1 show mpls ldp igp sync

The output of this command (as shown in the following example) shows that LDP-IGP Synchronization is configured correctly, because LDP is configured and the SYNC status shows that synchronization is achieved.

Router# show mpls ldp igp sync

Ethernet0/0:
       LDP configured;  SYNC enabled.
       SYNC status: sync achieved; peer reachable.
       IGP holddown time: infinite.
       Peer LDP Ident: 10.0.0.1:0
       IGP enabled: OSPF 1

If LDP-IGP Synchronization is not enabled on an interface, the output appears as follows:

Ethernet5/1:
    LDP configured; LDP-IGP Synchronization not enabled.

Step 2 show ip ospf mpls ldp interface

The output of the show ip ospf mpls ldp interface command in the following example shows that the interfaces are properly configured:

Router# show ip ospf mpls ldp interface

Ethernet3/0/0
  Process ID 1, Area 0
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization: Yes
  Holddown timer is not configured
  Timer is not running
Ethernet3/0/2
  Process ID 1, Area 0
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization: Yes
  Holddown timer is not configured
  Timer is not running 

Configuring MPLS LDP-IGP Synchronization with IS-IS Interfaces


Note In Cisco IOS Release 12.2(33)SRB, the MPLS LDP-IGP Synchronization is not supported with IS-IS. Only OSPF is supported.


The following sections contain the steps and examples for configuring MPLS LDP-IGP Synchronization for interfaces running IS-IS processes:

Configuring MPLS LDP-IGP Synchronization on All IS-IS Interfaces

Configuring MPLS LDP-IGP Synchronization on an IS-IS Interface

Configuring MPLS LDP-IGP Synchronization on All IS-IS Interfaces

This section contains the steps for configuring MPLS LDP-IGP Synchronization on all interfaces running IS-IS processes.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. router isis word

6. mpls ldp sync

7. interface interface

8. ip address prefix mask

9. ip router isis word

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 4 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 5 

router isis word

Example:

Router(config)# router isis ISIS

Enables IS-IS protocol on the router and specifies an IS-IS process. Enters router configuration mode.

Step 6 

mpls ldp sync

Example:

Router(config-router)# mpls ldp sync

Enables LDP-IGP Synchronization for interfaces belonging to an IS-IS process.

Step 7 

interface interface

Example:

Router(config-router)# interface POS0/3

Specifies the interface to configure and enters interface configuration mode.

Step 8 

ip address prefix mask

Example:

Router(config-if)# ip address 10.25.25.11 255.255.255.0

Assigns an IP address to the interface.

Step 9 

ip router isis word

Example:

Router(config-if)# ip router isis ISIS

Enables IS-IS.

Configuring MPLS LDP-IGP Synchronization on an IS-IS Interface

This section contains the steps for configuring MPLS LDP-IGP Synchronization on an interface that is running an IS-IS process.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface

4. ip address prefix mask

5. ip router isis

6. router isis

7. mpls ldp sync

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface interface

Example:

Router(config)# interface POS0/2

Specifies the interface to configure and enters interface configuration mode.

Step 4 

ip address prefix mask

Example:

Router(config-if)# ip address 10.50.72.4 255.0.0.0

Assigns an IP address to the interface.

Step 5 

ip router isis

Example:

Router(config-if)# ip router isis

Enables IS-IS for IP on the interface.

Step 6 

router isis

Example:

Router(config-if)# router isis

Enables IS-IS process on the router and enters router configuration mode.

Step 7 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 8 

mpls ldp sync

Example:

Router(config-router)# mpls ldp sync

Enables LDP-IGP Synchronization for interfaces belonging to an IS-IS process.

Selectively Disabling MPLS LDP-IGP Synchronization from Some IS-IS Interfaces

When you issue the mpls ldp sync command, all of the interfaces that belong to an IS-IS process are enabled for LDP-IGP Synchronization. To remove LDP-IGP Synchronization from some interfaces, use the no form of the mpls ldp igp sync command on those interfaces. The following configuration steps show how to disable LDP-IGP Synchronization from some of the interfaces after they are configured with LDP-IGP Synchronization through the mpls ldp sync command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface

4. no mpls ldp igp sync

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface interface

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp sync

Example:

Router(config-if)# no mpls ldp igp sync

Disables LDP-IGP Synchronization for that interface.

Verifying MPLS LDP-IGP Synchronization with IS-IS

After you configure the interfaces for LDP-IGP Synchronization with IS-IS, you can verify that the configuration is working correctly with the show isis mpls ldp command.

SUMMARY STEPS

1. enable

2. show isis mpls ldp

DETAILED STEPS


Step 1 enable

Enables privileged EXEC mode. Enter your password if prompted.

Step 2 show isis mpls ldp

The output of the following command shows that IS-IS is configured on the interface and LDP-IGP Synchronization with IS-IS is configured properly:

ISIS is UP

SYNC achieved

Router# show isis mpls ldp

Interface: POS0/2; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: YES
   Achieved: YES
   IGP Delay: NO
   Holddown time: Infinite
   State: SYNC achieved

If LDP-IGP Synchronization with IS-IS is not enabled on an interface, the output looks like the following:

Interface: Ethernet0; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: NO

If LDP-IGP Synchronization with IS-IS is configured but is not achieved, the output looks like the following:

Interface: Ethernet0/0; ISIS tag ISIS-1 enabled
  ISIS is UP on interface
  AUTOCONFIG Information :
    LDP enabled: YES
  SYNC Information :
    Required: YES
    Achieved: NO
    IGP Delay: YES
    Holddown time: Infinite
    State: Holding down until SYNC

The IS-IS process holds down the adjacency of the interface until synchronization is achieved.


Troubleshooting Tips

Use the debug mpls ldp igp sync command to display events related to MPLS LDP-IGP Synchronization.

Configuration Examples for MPLS LDP-IGP Synchronization

The following sections show examples for MPLS LDP-IGP Synchronization with OSPF and IS-IS processes:

MPLS LDP-IGP Synchronization with OSPF Examples

MPLS LDP-IGP Synchronization with IS-IS Examples

MPLS LDP-IGP Synchronization with OSPF Examples

The following configuration commands enable LDP for OSPF process 1. The mpls ldp sync command and the OSPF network commands enable LDP on interfaces POS0/0, POS0/1, and POS1/1, respectively. The no mpls ldp igp sync command on interface POS1/0 prevents LDP from being enabled on interface POS1/0, even though OSPF is enabled for that interface.

Router# configure terminal
Router(config)# interface POS0/0
Router(config-if)# ip address 10.0.0.1
Router(config-if)# mpls ip
!
Router(config)# interface POS0/1
Router(config-if)# ip address 10.0.1.1
Router(config-if)# mpls ip
!
Router(config)# interface POS1/1
Router(config-if)# ip address 10.1.1.1
Router(config-if)# mpls ip
!
Router(config)# interface POS1/0
Router(config-if)# ip address 10.1.0.1
Router(config-if)# mpls ip
!
Router(config)# router ospf 1
Router(config-router)# network 10.0.0.0 0.0.255.255 area 3
Router(config-router)# network 10.1.0.0 0.0.255.255 area 3
Router(config-router)# mpls ldp sync 
Router(config-router)# exit
Router(config)# interface POS1/0
Router(config-if)# no mpls ldp igp sync

MPLS LDP-IGP Synchronization with IS-IS Examples


Note In Cisco IOS Release 12.2(33)SRB, the MPLS LDP-IGP Synchronization is not supported with IS-IS. Only OSPF is supported.


The following examples show the configuration commands you can use to configure LDP-IGP Synchronization on interfaces, POS0/2 and POS0/3, which are running IS-IS processes:

Router# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# interface POS0/2
Router(config-if)# ip router isis
Router(config-if)# router isis
Router(config-router)# mpls ldp sync
.
.
.
Router(config)# interface POS0/3
Router(config-if)# ip router isis
Router(config-if)# router isis
Router(config-router)# mpls ldp sync

Additional References

The following sections provide references related to the MPLS LDP-IGP Synchronization feature.

Related Documents

Related Topic
Document Title

MPLS LDP

MPLS Label Distribution Protocol

MPLS LDP Autoconfiguration

MPLS LDP Autoconfiguration

MPLS LDP Session Protection

MPLS LDP Session Protection


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

MPLS LDP MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 3036

LDP Specification

RFC 3037

LDP Applicability


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Command Reference

This section documents only commands that are new or modified.

debug mpls ldp igp sync

mpls ldp igp sync

mpls ldp igp sync holddown

mpls ldp sync

show ip ospf mpls ldp interface

show isis mpls ldp

show mpls ldp igp sync

debug mpls ldp igp sync

To enable the display of events related to the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP)-Interior Gateway Protocol (IGP) Synchronization feature, use the debug mpls ldp igp sync command in privileged EXEC mode. To disable this feature, use the no form of this command.

debug mpls ldp igp sync [interface interface] [peer acl]

no debug mpls ldp igp sync [interface interface] [peer acl]

Syntax Description

interface interface

(Optional) Enables the display of LDP-IGP Synchronization events for the specified interface.

peer acl

(Optional) Enables the display of LDP-IGP Synchronization events for the specified peer access control list (ACL).


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.0(32)S

The command output was modified to display events related to the delay timer on interfaces running Open Shortest Path First (OSPF) processes, if the delay timer is configured.

12.0(32)SY

The command output was modified to display events related to synchronization on interfaces running Intermediate System-to-Intermediate System (IS-IS) processes.

12.4(12)

This command was integrated into Cisco IOS Release 12.4(12).

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Examples

The following example shows events related to MPLS LDP-IGP Synchronization on interfaces running OSPF:

Router# debug mpls ldp igp sync 

LDP-SYNC: Et0/0, OSPF 1: notify status (required, not achieved, no delay, holddown 
infinite) internal status (achieved, timer running)
LDP-SYNC: E1/0, 10.0.0.1: Adj being deleted, sync_achieved goes down
LDP-SYNC: E1/0, OSPF 1: notify status (required, not achieved, delay, holddown infinite)

LDP-SYNC: Et0/0: Session already up and interface address advertised, sync_achieved comes 
up.
LDP-SYNC: Et0/0, OSPF 1: notify status (required, achieved, no delay, holddown infinite)

The following example shows events associated when an IS-IS instance, ISIS-1, is configured for Synchronization:

Router# debug mpls ldp igp sync

07:59:27: LDP-SYNC: Et0/0, OSPF 1: notify status (required, not achieved, no delay, 
holddown infinite) internal status (achieved, timer running)
07:59:27: LDP-SYNC: Enqueue request req_type 0 IGP ISIS ISIS-1 interface none.
07:59:27: LDP-SYNC: ISIS ISIS-1: SYNC enabled, added to global tree, informed IGP.
07:59:27: LDP-SYNC: Enqueue request req_type 3 IGP ISIS ISIS-1 interface Et0/0.
07:59:27: LDP-SYNC: Enqueue request req_type 3 IGP ISIS ISIS-1 interface Et0/0.
07:59:27: LDP-SYNC: Et0/0, ISIS ISIS-1: Added to per-interface IGP list.
07:59:27: LDP-SYNC: Et0/0: Enabled for SYNC by IGP
07:59:27: LDP-SYNC: Et0/0, ISIS ISIS-1: notify status (required, not achieved, delay, 
holddown infinite)
07:59:27: LDP-SYNC: Et0/0, ISIS ISIS-1: Ignore IGP enable-interface request: already 
enabled.

Table 1 describes the significant fields shown in the displays.

Table 1 debug mpls ldp igp sync Field Descriptions 

Field
Description

sync_achieved

The first line of the output for an interface shows the status of the MPLS LDP-IGP Synchronization in relation to the status of the interface.

notify status

The notify status shows the following MPLS LDP-IGP Synchronization information for each interface:

If LDP-IGP Synchronization is required.

If LDP-IGP Synchronization has been achieved.

If the IGP should wait for LDP Synchronization to be achieved.

The length of time the IGP should wait for the LDP Synchronization to be achieved.

internal status

The internal status displays LDP internal synchronization status and the state of the timer. The internal status can be achieved or not achieved. The timer state can be running or not running.


The following example shows events associated with MPLS LDP-IGP Synchronization on interfaces running OSPF when you have configured a delay timer:

Router# debug mpls ldp igp sync

*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: notify status (required, not achieved, no 
delay, holddown infinite) internal status (achieved, timer running)
!
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: Sync disabled by IGP. Stop delay timer
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: TAGSW subblock destroyed. Stop delay timer
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: Sync down. Stop delay timer
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: Delay notifying IGP of sync achieved for 60 
seconds
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: Delay timer expired, notify IGP of sync 
achieved
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: Delay timer expired but sync is no longer 
required won't notify IGP of sync achieved
*Jan 3 04:38:49.571: LDP-SYNC: Et0/0, OSPF 1: Delay timer expired but sync is down won't 
notify IGP of sync achieved

Related Commands

Command
Description

mpls ldp sync

Enables LDP-IGP Synchronization on all interfaces that belong to an OSPF process or IS-IS process.

show mpls ldp igp sync

Displays information about interfaces configured for LDP-IGP Synchronization.


mpls ldp igp sync

To enable Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) Interior Gateway Protocol (IGP) synchronization on an interface that belongs to an Open Shortest Path First (OSPF) process, use the mpls ldp igp sync command in interface configuration mode. To disable MPLS LDP synchronization, use the no form of the command.

mpls ldp igp sync [delay delay-time]

no mpls ldp igp sync [delay]

Syntax Description

delay

(Optional) Sets a delay timer for MPLS LDP Interior Gateway Protocol (IGP) synchronization.

delay-time

(Optional) Delay time in seconds. The range is from 5 to 60 seconds.


Command Default

If MPLS LDP synchronization is enable on an OSPF process, MPLS LDP synchronization is enabled on all interfaces configured for the process by default. A delay timer is not set.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.0(32)S

The optional delay delay-time keyword and argument were added.

12.4(12)

This command was integrated into Cisco IOS Release 12.4(12).

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.(33)SRB.


Usage Guidelines

This command works with the mpls ldp sync command, which enables MPLS LDP synchronization on all interfaces that belong to an OSPF process. To disable MPLS LDP synchronization on a selected interface, use the no mpls ldp igp sync command in the configuration for that interface.

Use the mpls ldp igp sync delay delay-time command to configure a delay time for MPLS LDP and IGP synchronization on an interface-by-interface basis. To remove the delay timer from a specified interface, enter the no mpls ldp igp sync delay command. This command sets the delay time to 0 seconds, but leaves MPLS LDP IGP synchronization enabled.

When LDP is fully established and synchronized, LDP checks the delay timer:

If you configured a delay time, LDP starts the timer. When the timer expires, LDP checks that synchronization is still valid and notifies the OSPF process.

If you did not configure a delay time, or if synchronization is disabled or down, or if an interface was removed from an IGP process, LDP stops the timer and immediately notifies the OSPF process.

If you configure a new delay time while a timer is running, LDP saves the new delay time but does not reconfigure the running timer.

Examples

The following example shows how to disable MPLS LDP synchronization on POS interface 1/0:

Router(config)# interface pos1/0
Router(config-if)# no mpls ldp igp sync

The following example shows how to set a delay timer of 45 seconds for MPLS LDP-IGP synchronization on FastEthernet interface 0/0:

Router(config)# interface FastEthernet 0/0
Router(config-if)# mpls ldp igp sync delay 45

Related Commands

Command
Description

mpls ldp sync

Globally enables LDP on all interfaces that belong to an OSPF process.

show mpls ldp igp sync

Displays information about interfaces configured for MPLS LDP synchronization.


mpls ldp igp sync holddown

To specify how long an Interior Gateway Protocol (IGP) should wait for Label Distribution Protocol (LDP) Synchronization to be achieved, use the mpls ldp igp sync holddown command in global configuration mode. To disable the holddown timer, use the no form of this command.

mpls ldp igp sync holddown milliseconds

no mpls ldp igp sync holddown

Syntax Description

milliseconds

The number of milliseconds an IGP should wait for an LDP session to be established. The valid range of values is 1 to 2,147,483,647.


Defaults

An IGP will wait indefinitely for LDP synchronization to be achieved.

Command Modes

Global configuration

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

This command enables you to limit the amount of time an IGP waits for LDP synchronization to be achieved.

Examples

In the following example, the IGP is limited to 10,000 milliseconds (10 seconds):

Router(config)# mpls ldp igp holddown 10000

Related Commands

Command
Description

mpls ldp sync

Globally enables LDP on all interfaces that belong to an OSPF process.

show mpls ldp igp sync

Displays information about interfaces configured for MPLS LDP Synchronization.


mpls ldp sync

To enable Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP)-Interior Gateway Protocol (IGP) Synchronization on interfaces for an Open Shortest Path First (OSPF) process or an Intermediate System-to-Intermediate System (IS-IS) process, use the mpls ldp sync command in router configuration mode. To disable this feature, use the no form of this command.

mpls ldp sync

no mpls ldp sync

Syntax Description

This command has no arguments or keywords.

Defaults

MPLS LDP-IGP Synchronization is not enabled on interfaces belonging to the OSPF or IS-IS processes.

Command Modes

Router configuration

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.0(32)SY

This command is supported on interfaces running IS-IS processes in Cisco IOS Release 12.0(32)SY.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

If the mpls ldp sync command is configured, you cannot issue the global no mpls ip command. If you want to disable LDP Synchronization, you must issue the no mpls ldp igp sync command first.

The mpls ldp sync command is supported with OSPF or IS-IS. Other IGPs are not supported.

Examples

In the following example, MPLS LDP Synchronization is enabled for an OSPF process or an IS-IS process:

Router(config-router)# mpls ldp sync 

Related Commands

Command
Description

mpls ldp igp sync

Enables LDP-IGP Synchronization on an interface running an OSPF process.

show isis mpls ldp

Displays LDP-IGP Synchronization and LDP Autoconfiguration information for interfaces running IS-IS processes.

show mpls ldp igp sync

Displays information about interfaces configured for LDP-IGP Synchronization.


show ip ospf mpls ldp interface

To display information about interfaces belonging to an Open Shortest Path First (OSPF) process that are configured for Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP)-Interior Gateway Protocol (IGP), use the show ip ospf mpls ldp interface command in privileged EXEC mode.

show ip ospf [process-id] mpls ldp interface [interface]

Syntax Description

process-id

(Optional) Process ID. If this argument is included, only information for the specified routing process is included.

interface

(Optional) Defines the interface about which to display LDP IGP-synchronization information.


Defaults

If you do not specify a keyword or argument, information is displayed for each interface that has been configured for MPLS LDP IGP-synchronization.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

This command shows MPLS LDP IGP-synchronization information for specified interfaces or OSPF processes.

Examples

The following shows sample output generated by the show ip ospf mpls ldp interface command:

Router# show ip ospf mpls ldp interface

Serial1/2.4
  Process ID 2, Area 0
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization : Not required
  Holddown timer is disabled
  Interface is up 
Serial1/2.11
  Process ID 6, VRF VFR1, Area 2
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization : Not required
  Holddown timer is disabled
  Interface is up 
Ethernet2/0
  Process ID 1, Area 0
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization : Required
  Holddown timer is configured : 1 msecs
  Holddown timer is not running
  Interface is up 
Loopback1
  Process ID 1, Area 0
  LDP is not configured through LDP autoconfig
  LDP-IGP Synchronization : Not required
  Holddown timer is disabled
  Interface is up 
Serial1/2.1
  Process ID 1, Area 10.0.1.44
  LDP is configured through LDP autoconfig
  LDP-IGP Synchronization : Required
  Holddown timer is configured : 1 msecs
  Holddown timer is not running
  Interface is up 

Table 2 describes the significant fields shown in the display.

Table 2 show ip ospf mpls ldp interface Field Descriptions 

Field
Description

Process ID

The number of the OSPF process to which the interface belongs.

Area

The OSPF area to which the interface belongs.

LDP is configured through

The means by which LDP was configured on the interface. LDP can be configured on the interface by the mpls ip or mpls ldp command.

LDP-IGP Synchronization

Indicates whether LDP-IGP synchronization has been enabled on this interface.

Holddown timer

Indicates whether the holddown timer was specified for this interface.

Timer

Indicates whether the timer is running on this interface.


Related Commands

Command
Description

debug mpls ldp igp sync

Displays events related to MPLS LDP-IGP synchronization.

show mpls ldp igp sync

Displays information about interfaces enabled for MPLS LDP-IGP synchronization.


show isis mpls ldp

To display synchronization and autoconfiguration information about interfaces belonging to Intermediate System-to-Intermediate System (IS-IS) processes, use the show isis mpls ldp command in privileged EXEC mode.

show isis [process-tag] mpls ldp [interface interface]

Syntax Description

process-tag

(Optional) Process ID. If this argument is included, only information for the specified routing process appears.

interface interface

(Optional) Defines the interface about which to display Label Distribution Protocol (LDP)-Interior Gateway Protocol (IGP) Synchronization and LDP Autoconfiguration information.


Defaults

If you do not specify a keyword or argument for this command, information appears for each interface that is configured for MPLS LDP Synchronization and Autoconfiguration.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modifications

12.0(32)SY

This command was introduced.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

This command shows MPLS LDP Synchronization and Autoconfiguration information for interfaces that are running IS-IS processes.

Examples

In the following example, interface POS0/2 is running IS-IS. Autoconfiguration is enabled. Synchronization is configured.

Router# show isis mpls ldp

Interface: POS0/2; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: YES
 SYNC Information :
   Required: YES
   Achieved: YES
   IGP Delay: NO
   Holddown time: Infinite
   State: SYNC achieved

This command returns information for interfaces that are configured for IS-IS which are indicated by the message ISIS is UP on interface.

Table 3 describes the fields shown in the display.

Table 3 show isis mpls ldp Field Descriptions 

Field
Description

AUTOCONFIG Information

LDP enabled—Indicates whether or not LDP Autoconfiguration is enabled on this interface. Value is either Yes or No.

SYNC Information

Required—Indicates whether or not synchronization is required on the interface.

Achieved—Indicates whether or not synchronization has been achieved with LDP. If IS-IS has been configured on an interface but synchronization is not achieved, the Achieved field indicates No. The Required field still indicates Yes. See the following example:

Interface: POS0/3; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: YES
   Achieved: NO
   IGP Delay: YES
   Holddown time: Infinite
   State: Holding down until SYNC

IGP Delay—Indicates whether the IS-IS process is required to wait for synchronization with LDP before bringing up the interface adjacency.

Holddown Time—Indicates a finite or infinite.

The finite value is equal to the holddown delay that you configured using the mpls ldp igp sync holddown command.

If this field indicates Infinite, holddown time was not configured. Therefore, IS-IS waits until synchronization is achieved before bringing adjacency UP.

Note This field is significant only if the IGP Delay field indicates YES.

State—Indicates information about the state of synchronization on the interface.

If synchronization is achieved, the output shows the following:

SYNC achieved—Synchronization was required and has been achieved.

If synchronization is not achieved, the output shows one of the following:

Holding down until SYNC—No holddown timer has been configured, so IS-IS continues to hold down adjacency until synchronization is achieved.

Holding down with timer—A holddown timer has been configured, and IS-IS is holding down adjacency until the timer, indicated in the IGP Delay field, expires.

Maximum metric in effect—Although synchronization was not achieved, the IGP brought UP adjacency with maximum metric.


Related Commands

Command
Description

mpls ldp autoconfig

Globally enables LDP Autoconfiguration on all interfaces that belong to an OSPF or IS-IS process.

mpls ldp sync

Globally enables LDP Synchronization on all interfaces that belong to an OSPF or IS-IS process.


show mpls ldp igp sync

To display the status of the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) Interior Gateway Protocol (IGP) synchronization process, use the show mpls ldp igp sync command in user EXEC or privileged EXEC mode.

show mpls ldp igp sync [interface interface | vpn vpn-name]

Syntax Description

interface interface

(Optional) Displays the MPLS LDP synchronization information for the specified interface.

vpn vpn-name

(Optional) Displays the MPLS LDP synchronization information for the specified Virtual Private Network (VPN) routing and forwarding instance (vpn-name).


Defaults

This command displays LDP synchronization for all interfaces enabled for MPLS LDP synchronization if an optional argument is not specified.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.0(32)S

This command was integrated into Cisco IOS Release 12.0(32)S. The output of this command was changed to display the configured delay time and the time remaining on the delay timer.

12.4(12)

This command was integrated into Cisco IOS Release 12.4(12).

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Examples

The following shows sample output from the show mpls ldp igp sync command:

Router# show mpls ldp igp sync

Ethernet0/0:
       LDP configured;  SYNC enabled.
       SYNC status: sync achieved; peer reachable.
       IGP holddown time: infinite.
       Peer LDP Ident: 10.130.0.1:0
       IGP enabled: OSPF 1

Table 4 describes the significant fields shown in the display.

Table 4 show mpls ldp igp sync Field Descriptions 

Field
Description

Ethernet0/0

Interface name and type.

LDP configured

Label Distribution Protocol is configured.

SYNC enabled

Synchronization is active.

SYNC status

Synchronization is successful.

Note Peer reachable is an LDP internal state used only for MPLS LDP synchronization. It should not be used to verify that LDP can reach the peer or to troubleshoot LDP functionality.

IGP holddown time

Interior Gateway Protocol hold-down time. Infinite—No specific time is set.

Peer LDP Ident

IP address of the peer.

IGP enabled

Interior Gateway Protocol is enabled for Open Shortest Path First (OSPF) 1.


If LDP synchronization is not enabled on an interface, the output looks like the following:

Router# show mpls ldp igp sync

Ethernet5/1:
       LDP configured; LDP-IGP Synchronization not enabled.

The following is sample output from the show mpls ldp igp sync command when you configured a time delay for MPLS LDP IGP synchronization:

Router# show mpls ldp igp sync

Ethernet0/0:
       LDP configured; LDP-IGP Synchronization enabled.
       Sync status: sync achieved; peer reachable.
       Sync delay time: 20 seconds (10 seconds left) 
       IGP holddown time: infinite.
       IGP enabled: OSPF 1

Related Commands

Command
Description

debug mpls ldp igp sync

Displays events related to MPLS LDP synchronization.

mpls ldp igp sync

Enables MPLS LDP synchronization on an interface that belongs to an OSPF process.

mpls ldp igp sync holddown

Specifies how long an IGP should wait for LDP synchronization to be achieved.

mpls ldp sync

Globally enables LDP on all interfaces that belong to an OSPF process.