Guest

Cisco IOS Software Releases 12.0 S

MPLS LDP Autoconfiguration

  • Viewing Options

  • PDF (312.9 KB)
  • Feedback
MPLS LDP Autoconfiguration

Table Of Contents

MPLS LDP Autoconfiguration

Contents

Restrictions for MPLS LDP Autoconfiguration

Information About MPLS LDP Autoconfiguration

How to Configure MPLS LDP Autoconfiguration

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces

Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces

Verifying MPLS LDP Autoconfiguration with OSPF

Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces

Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces

Verifying MPLS LDP Autoconfiguration with IS-IS

Troubleshooting Tips

Configuration Examples for MPLS LDP Autoconfiguration

MPLS LDP Autoconfiguration Examples with OSPF

MPLS LDP Autoconfiguration Examples with IS-IS

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

debug mpls ldp autoconfig

mpls ldp autoconfig

mpls ldp igp autoconfig

show isis mpls ldp

show mpls ldp discovery

Feature Information for MPLS LDP Autoconfiguration


MPLS LDP Autoconfiguration


First Published: November 8, 2004
Last Updated: February 20, 2007

The MPLS LDP Autoconfiguration feature enables you to globally configure Label Distribution Protocol (LDP) on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To access links to specific feature documentation in this module and to view a list of releases in which each feature is supported, use the "Feature Information for MPLS LDP Autoconfiguration" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Restrictions for MPLS LDP Autoconfiguration

Information About MPLS LDP Autoconfiguration

How to Configure MPLS LDP Autoconfiguration

Configuration Examples for MPLS LDP Autoconfiguration

Additional References

Command Reference

Feature Information for MPLS LDP Autoconfiguration

Restrictions for MPLS LDP Autoconfiguration

This feature has the following restrictions:

In Cisco IOS Release 12.2(33)SRB, the MPLS LDP Autoconfiguration feature is supported only with Open Shortest Path First (OSPF). Intermediate System to Intermediat System (IS-IS) is not supported.

In Cisco IOS Release 12.0(32)SY, the mpls ldp autoconfig command is supported with OSPF and IS-IS interfaces. Other IGPs are not supported.

If LDP is disabled globally, the mpls ldp autoconfig command fails and generates a console message explaining that LDP must first be enabled globally by means of the global mpls ip command.

If the mpls ldp autoconfig command is configured for an IGP instance, you cannot issue the global no mpls ip command. To disable LDP, you must first issue the no mpls ldp autoconfig command.

For interfaces running IS-IS processes, you can enable Multiprotocol Label Switching (MPLS) for each interface, using the router mode command mpls ldp autoconfig or mpls ldp igp autoconfig at the interface level.

You specify that the default label distribution protocol is LDP for a router or for an interface. Tag Distribution Protocol (TDP) is not supported.

The MPLS LDP Autoconfiguration feature is not supported on traffic engineering tunnel interfaces.

Information About MPLS LDP Autoconfiguration

To enable LDP, you should configure it globally and on each interface where it is needed. Configuring LDP on many interfaces can be time consuming.

The MPLS LDP Autoconfiguration feature enables you to globally enable LDP on every interface associated with an IGP instance. This feature is supported on OSPF and IS-IS IGPs. Further, it provides a means to block LDP from being enabled on interfaces that you do not want enabled. The goal of the MPLS LDP Autoconfiguration feature is to make configuration easier, faster, and error free.


Note In Cisco IOS Release 12.2(33)SRB, the MPLS LDP Autoconfiguration feature is supported only with OSPF. IS-IS is not supported.


You issue the mpls ldp autoconfig command to enable LDP on each interface that is running an OSPF or IS-IS process. If you do not want some of the interfaces to have LDP enabled, you can issue the no form of the mpls ldp igp autoconfig command on those interfaces.

How to Configure MPLS LDP Autoconfiguration

This section contains the following procedures:

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces (required)

Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces (optional)

Verifying MPLS LDP Autoconfiguration with OSPF (optional)

Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces (required)

Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces (optional)

Verifying MPLS LDP Autoconfiguration with IS-IS (optional)

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces

The following steps explain how to configure LDP for interfaces running OSPF processes.

SUMMARY STEPS

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. interface interface

6. ip address prefix mask

7. exit

8. router ospf process-id

9. network ip-address wildcard-mask area area-id

10. mpls ldp autoconfig [area area-id]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 4 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 5 

interface interface

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 6 

ip address prefix mask

Example:

Router(config-if)# ip address 10.0.0.11 255.255.255.255

Assigns an IP address to the interface.

Step 7 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 8 

router ospf process-id

Example:

Router(config)# router ospf 1

Enables OSPF routing and enters router configuration mode.

Step 9 

network ip-address wildcard-mask area area-id

Example:

Router(config-router)# network 10.0.0.0 0.0.255.255 area 3

Specifies the interface on which OSPF runs and defines the area ID for that interface.

Step 10 

mpls ldp autoconfig [area area-id]

Example:

Router(config-router)# mpls ldp autoconfig area 3

Enables the MPLS LDP Autoconfiguration feature to enable LDP on interfaces belonging to an OSPF process. If no area is specified, the command applies to all interfaces associated with the OSPF process. If an area ID is specified, then only interfaces associated with that OSPF area are enabled with LDP.

Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces

When you issue the mpls ldp autoconfig command, all the interfaces that belong to an OSPF area are enabled for LDP. To remove LDP from some interfaces, use the no mpls ldp igp autoconfig command on those interfaces. The following configuration steps show how to disable LDP from some of the interfaces after they were configured with MPLS LDP Autoconfiguration with the mpls ldp autoconfig command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface

4. no mpls ldp igp autoconfig

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface interface

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp autoconfig

Example:

Router(config-if)# no mpls ldp igp autoconfig

Disables LDP for that interface.

Verifying MPLS LDP Autoconfiguration with OSPF

The following steps explain how to verify the MPLS LDP Autoconfiguration feature.

SUMMARY STEPS

1. show mpls interfaces [detail]

2. show mpls ldp discovery [detail]

DETAILED STEPS


Step 1 show mpls interfaces

The show mpls interfaces command lists the method that was used to enable LDP on an interface.

If LDP is enabled by the mpls ldp autoconfig command, the output displays:

IP labeling enabled (ldp):
   IGP config

If LDP is enabled by the mpls ip command, the output displays:

IP labeling enabled (ldp):
  Interface config

If LDP is enabled by the mpls ip command and the mpls ldp autoconfig command, the output displays:

IP labeling enabled (ldp):
  Interface config
  IGP config

The following example shows that LDP was enabled on the interface by both the mpls ip and mpls 
ldp autoconfig commands: 

Router# show mpls interfaces S2/0 detail 

Interface Serial2/0:
        IP labeling enabled (ldp):
          Interface config
          IGP config
        LSP Tunnel labeling enabled
        BGP labeling not enabled
        MPLS operational
        Fast Switching Vectors:
          IP to MPLS Fast Switching Vector
          MPLS Turbo Vector
        MTU = 1500

Step 2 show mpls ldp discovery

The show mpls ldp discovery details command also show how LDP was enabled on the interface. In the following example, LDP was enabled by both the mpls ip and mpls ldp autoconfig commands:

Router# show mpls ldp discovery detail

Local LDP Identifier:
    10.11.11.11:0
    Discovery Sources:
    Interfaces:
        Serial2/0 (ldp): xmit/recv
            Enabled: Interface config, IGP config;
            Hello interval: 5000 ms; Transport IP addr: 10.11.11.11 
            LDP Id: 10.10.10.10:0
              Src IP addr: 10.0.0.1; Transport IP addr: 10.10.10.10
              Hold time: 15 sec; Proposed local/peer: 15/15 sec

Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces

The following steps explain how to configure the MPLS LDP Autoconfiguration feature for interfaces running IS-IS processes.


Note In Cisco IOS Release 12.2(33)SRB, the MPLS LDP Autoconfiguration feature is supported only with OSPF. IS-IS is not supported.


SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface

4. ip address prefix mask

5. ip router isis

6. exit

7. mpls ip

8. mpls label protocol ldp

9. router isis

10. mpls ldp autoconfig [level-1 | level-2]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface interface

Example:

Router(config)# interface POS0/2

Specifies the interface to configure and enters interface configuration mode.

Step 4 

ip address prefix mask

Example:

Router(config-if)# ip address 10.50.72.4 255.0.0.0

Assigns an IP address to the interface.

Step 5 

ip router isis

Example:

Router(config-if)# ip router isis

Enables IS-IS for IP on the interface.

Step 6 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 7 

mpls ip

Example:

Router(config)# mpls ip

Globally enables hop-by-hop forwarding.

Step 8 

mpls label protocol ldp

Example:

Router(config)# mpls label protocol ldp

Specifies LDP as the default label distribution protocol.

Step 9 

router isis

Example:

Router(config)# router isis

Enables an IS-IS process on the router and enters router configuration mode.

Step 10 

mpls ldp autoconfig [level-1 | level-2]

Example:

Router(config-router)# mpls ldp autoconfig

Enables the LDP for interfaces belonging to an IS-IS process.

Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces

When you issue the mpls ldp autoconfig command, all the interfaces that belong to an IS-IS process are enabled for LDP. To remove LDP from some interfaces, you can use the no form of the mpls ldp igp autoconfig command on those interfaces. The following configuration steps show how to disable LDP from some of the interfaces after they were configured with the MPLS LDP Autoconfiguration through the mpls ldp autoconfig command.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface interface

4. no mpls ldp igp autoconfig

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface interface

Example:

Router(config)# interface POS3/0

Specifies the interface to configure and enters interface configuration mode.

Step 4 

no mpls ldp igp autoconfig

Example:

Router(config-if)# no mpls ldp igp autoconfig

Disables LDPfor that interface.

Verifying MPLS LDP Autoconfiguration with IS-IS

You can verify that the MPLS LDP Autoconfiguration feature is working correctly with the show isis mpls ldp command.

SUMMARY STEPS

1. enable

2. show isis mpls ldp

DETAILED STEPS


Step 1 enable

Enables privileged EXEC mode.

Step 2 show isis mpls ldp

The output of the following show isis mpls ldp command shows that IS-IS is configured on the interface and LDP is enabled:

Router# show isis mpls ldp

Interface: POS0/2; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: YES
 SYNC Information :
   Required: NO

The output shows :

IS-IS is up.

LDP is enabled.

If the MPLS LDP Autoconfiguration feature is not enabled on an interface, the output looks like the following:

Interface: Ethernet0; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: NO

Troubleshooting Tips

You can use the debug mpls ldp autoconfig command to display events related to the MPLS LDP Autoconfiguration feature.

Configuration Examples for MPLS LDP Autoconfiguration

The following sections show examples for MPLS LDP Autoconfiguration with OSPF and IS-IS processes.

MPLS LDP Autoconfiguration Examples with OSPF

MPLS LDP Autoconfiguration Examples with IS-IS

MPLS LDP Autoconfiguration Examples with OSPF

The following configuration commands enable LDP for OSPF process 1 area 3. The mpls ldp autoconfig area 3 command and the OSPF network commands enable LDP on interfaces POS0/0, POS0/1, and POS1/1. The no mpls ldp igp autoconfig command on interface POS1/0 prevents LDP from being enabled on interface POS1/0, even though OSPF is enabled for that interface.

configure terminal
 interface POS0/0
  ip address 10.0.0.1
!
 interface POS0/1
  ip address 10.0.1.1
!
 interface POS1/1
  ip address 10.1.1.1
!
 interface POS1/0
  ip address 10.1.0.1
  exit
!
 router ospf 1
  network 10.0.0.0 0.0.255.255 area 3
  network 10.1.0.0 0.0.255.255 area 3
  mpls ldp autoconfig area 3
  exit
 interface POS1/0
  no mpls ldp igp autoconfig

MPLS LDP Autoconfiguration Examples with IS-IS


Note In Cisco IOS Release 12.2(33)SRB, MPLS LDP Autoconfiguration is supported only with OSPF. IS-IS is not supported.


The following example shows the configuration of MPLS LDP Autoconfiguration on interfaces POS0/2 and POS0/3, which are running IS-IS processes:

configure terminal
 interface POS0/2
  ip address 10.0.0.1
  ip router isis
!
 interface POS0/3
  ip address 10.1.1.1
  ip router isis
  exit

 mpls ip

 mpls label protocol ldp

 router isis

  mpls ldp autoconfig

Additional References

The following sections provide references related to the MPLS LDP Autoconfiguration feature.

Related Documents

Related Topic
Document Title

MPLS LDP

MPLS Label Distribution Protocol

The MPLS LDP-IGP Synchronization feature

MPLS LDP-IGP Synchronization

The MPLS LDP Session Protection feature

MPLS LDP Session Protection

Configuring integrated IS-IS

Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature


MIBs

MIB
MIBs Link

MPLS LDP MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

RFC 3036

LDP Specification

RFC 3037

LDP Applicability


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Command Reference

This section documents only commands that are new or modified.

debug mpls ldp autoconfig

mpls ldp autoconfig

mpls ldp igp autoconfig

show isis mpls ldp

show mpls ldp discovery

debug mpls ldp autoconfig

To enable the display of events related to Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP), use the debug mpls ldp autoconfig command in privileged EXEC mode. To disable this feature, use the no form of this command.

debug mpls ldp autoconfig [interface interface]

no debug mpls ldp autoconfig [interface interface]

Syntax Description

interface interface

(Optional) Enables the display of autoconfiguration events for the specified interface.


Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(28)SB

This command was integrated into Cisco IOS Releases 12.2(28)SB.

12.0(32)SY

This command was updated to display IS-IS information.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Examples

In the following example, the display of events related to MPLS LDP Autoconfiguration are enabled:

Router# debug mpls ldp autoconfig 

00:06:06: LDP-AC: OSPF area 1 [flags 0x8, handle 0x1030110]:: Adding record 
00:06:06: LDP-AC: OSPF area 1 [flags 0x8, handle 0x1030110]:: Received
enable request for Serial2/0
00:06:06: LDP-AC: OSPF area 1 [flags 0xA, handle 0x1030110]:: Adding record
to Serial2/0
00:06:06: LDP-AC: OSPF area 1 [flags 0xA, handle 0x1030110]:: Enqueued LDP
enable request on Serial2/0
00:06:06: LDP-AC: OSPF area 1 [flags 0x8, handle 0x1030110]:: Received
enable request for Tunnel1
00:06:06: LDP-AC: OSPF area 1 [flags 0xA, handle 0x1030110]:: Adding record
to Tunnel1
00:06:06: LDP-AC: OSPF area 1 [flags 0xA, handle 0x1030110]:: Enqueued LDP
enable request on Tunnel1
00:06:06: LDP-AC: Enabling LDP on interface Serial2/0
00:06:06: LDP-AC: Enabling LDP on interface Tunnel1

The following example shows events associated when an IS-IS instance, ISIS-1, is configured for autoconfiguration:

Router# debug mpls ldp autoconfig 

07:49:02: LDP-AC: ISIS level 1-2 [flags 0x8, handle 0x1AADBE0]:: Adding record 
07:49:02: LDP-AC: ISIS level 1-2 [flags 0x8, handle 0x1AADBE0]:: Received enable request 
for Et0/0; area/level=1
07:49:02: LDP-AC: ISIS level 1-2 [flags 0xA, handle 0x1AADBE0]:: Adding record to Et0/0
07:49:02: LDP-AC: ISIS level 1-2 [flags 0xA, handle 0x1AADBE0]:: Enqueued LDP enable 
request on Et0/0
07:49:02: LDP-AC: ISIS level 1-2 [flags 0x8, handle 0x1AADBE0]:: Received enable request 
for Et0/0; area/level=1
07:49:02: LDP-AC: ISIS level 1-2 [flags 0x8, handle 0x1AADBE0]:: Received enable request 
for Et0/0; area/level=2
07:49:02: LDP-AC: ISIS level 1-2 [flags 0x8, handle 0x1AADBE0]:: Received enable request 
for Et0/0; area/level=2
07:49:02: LDP-AC: Enabling LDP autoconfig on interface Et0/0

Note MPLS LDP Autoconfiguration for IS-IS is supported only in Cisco IOS Release 12.0(32)SY.


Related Commands

Command
Description

mpls ldp autoconfig

Enables LDP on all interfaces that belong to an OSPF area.

show mpls ldp discovery

Displays information about interfaces configured for LDP.


mpls ldp autoconfig

To enable Label Distribution Protocol (LDP) on interfaces for which an Open Shortest Path First (OSPF) instance or Intermediate System-to-Intermediate System (IS-IS) instance has been defined, use the mpls ldp autoconfig command in router configuration mode. To disable this feature, use the no form of this command.

For OSPF

mpls ldp autoconfig [area area-id]

no mpls ldp autoconfig [area area-id]

For IS-IS

mpls ldp autoconfig [level-1 | level-2]

no mpls ldp autoconfig

Syntax Description

area area-id

(Optional) Enables LDP on the interfaces belonging to the specified OSPF area.

level-1 | level-2

(Optional) Enables LDP for a specified IS-IS level. If an interface is enabled for the same level as autoconfiguration, then LDP is enabled over that interface. If the interface has a different level than autoconfiguration, LDP is not enabled.

By default, without the use of these arguments, the configuration is applied to both the levels.


Defaults

LDP is not enabled on interfaces. If an OSPF area or an IS-IS level is not specified, LDP is enabled on all interfaces belonging to the OSPF or IS-IS process.

Command Modes

Router configuration

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.0(32)SY

This command was modified to support IS-IS processes in Cisco IOS Release 12.0(32)SY.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

You can specify this command multiple times to enable LDP on different routing areas with interfaces running OSPF.

If LDP is disabled globally, the mpls ldp autoconfig command fails. LDP must be enabled globally by means of the global mpls ip command first.

If the mpls ldp autoconfig command is configured, you cannot issue the global no mpls ip command. If you want to disable LDP, you must issue the no mpls ldp autoconfig command first.

The mpls ldp autoconfig command is supported only with OSPF and IS-IS interior gateway protocols (IGPs).

The MPLS LDP Autoconfiguration feature supports IS-IS only in Cisco IOS Release 12.0(32)SY.

For interfaces running IS-IS processes, you can enable Multiprotocol Label Switching (MPLS) for each interface using the router mode command mpls ldp autoconfig or mpls ldp igp autoconfig at the interface level.

For IS-IS interfaces, the level for which an interface is configured must be compatible with the level for which autoconfiguration is desired.

For IS-IS interfaces, each application of the configuration command overwrites the earlier configuration. If initial autoconfiguration is enabled for level-1 and a later configuration specifies level-2, LDP is enabled only on IS-IS level-2 interfaces.

Examples

In the following example, MPLS LDP Autoconfiguration is enabled for OSPF area 5:

Router(config-router)# mpls ldp autoconfig area 5

Related Commands

Command
Description

mpls ldp igp autoconfig

Enables LDP on an interface.

show mpls interfaces

Displays information about interfaces configured for LDP.

show mpls ldp discovery

Displays the status of the LDP discovery process.


mpls ldp igp autoconfig

To enable Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) autoconfiguration on an interface that belongs to an Open Shortest Path First (OSPF) area, use the mpls ldp igp autoconfig command in interface configuration mode. To disable MPLS LDP autoconfiguration, use the no form of the command.

mpls ldp igp autoconfig

no mpls ldp igp autoconfig

Syntax Description

This command has no arguments or keywords.

Defaults

This command works with the mpls ldp autoconfig command, which enables LDP on all interfaces that belong to an OSPF area. So, by default, all interfaces are enabled for LDP.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(30)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.0(32)SY

This command was integrated into Cisco IOS Release 12.0(32)SY.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

This command works with the mpls ldp autoconfig command, which enables LDP on all interfaces that belong to an OSPF area. To disable LDP on selected interfaces, use the no mpls ldp igp autoconfig command.

Examples

In the following example, LDP is disabled on interface POS1/0:

Router(config)# interface pos1/0
Router(config-if)# no mpls ldp igp autoconfig

Related Commands

Command
Description

mpls ldp autoconfig

Globally enables LDP on all interfaces that belong to an OSPF area.

show mpls interfaces

Displays information about interfaces configured for LDP.

show mpls ldp discovery

Displays the status of the LDP discovery process.


show isis mpls ldp

To display synchronization and autoconfiguration information about interfaces belonging to Intermediate System-to-Intermediate System (IS-IS) processes, use the show isis mpls ldp command in privileged EXEC mode.

show isis [process-tag] mpls ldp [interface interface]

Syntax Description

process-tag

(Optional) Process ID. If this argument is included, only information for the specified routing process appears.

interface interface

(Optional) Defines the interface about which to display Label Distribution Protocol (LDP)-Interior Gateway Protocol (IGP) synchronization and LDP autoconfiguration information.


Defaults

If you do not specify a keyword or argument for this command, information appears for each interface that is configured for Multiprotocol Label Switching (MPLS) LDP synchronization and autoconfiguration.

Command Modes

Privileged EXEC

Command History

Release
Modifications

12.0(32)SY

This command was introduced.

12.2(33)SRB

This command was integrated into Cisco IOS Release 12.2(33)SRB.


Usage Guidelines

This command shows MPLS LDP synchronization and autoconfiguration information for interfaces that are running IS-IS processes.

MPLS LDP synchronization and autoconfiguration for IS-IS is supported only in Cisco IOS
Release 12.0(32)SY.

Examples

In the following example, interface POS0/2 is running IS-IS. Autoconfiguration is enabled. Synchronization is configured.

Router# show isis mpls ldp

Interface: POS0/2; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: YES
 SYNC Information :
   Required: YES
   Achieved: YES
   IGP Delay: NO
   Holddown time: Infinite
   State: SYNC achieved

This command returns information for interfaces that are configured for IS-IS, which are indicated by the message "ISIS is UP" on interface.

Table 1 describes the significant fields shown in the display.

Table 1 show isis mpls ldp Field Descriptions 

Field
Description

AUTOCONFIG Information

LDP enabled—Indicates whether LDP Autoconfiguration is enabled on this interface. Value is either YES or NO.

SYNC Information

Required—Indicates whether synchronization is required on the interface.

Achieved—Indicates whether synchronization has been achieved with LDP. If IS-IS has been configured on an interface but synchronization is not achieved, the Achieved field indicates NO. The Required field still indicates YES. See the following example:

Interface: POS0/3; ISIS tag null enabled
 ISIS is UP on interface
 AUTOCONFIG Information :
   LDP enabled: NO
 SYNC Information :
   Required: YES
   Achieved: NO
   IGP Delay: YES
   Holddown time: Infinite
   State: Holding down until SYNC

IGP Delay—Indicates whether the IS-IS process is required to wait for synchronization with LDP before bringing up the interface adjacency.

Holddown Time—Indicates a finite or infinite.

The finite value is equal to the hold-down delay that you configured using the mpls ldp igp sync holddown command.

If this field indicates Infinite, hold-down time was not configured. Therefore, IS-IS waits until synchronization is achieved before bringing adjacency UP.

Note This field is significant only if the IGP Delay field indicates YES.

State—Indicates information about the state of synchronization on the interface.

If synchronization is achieved, the output shows the following:

SYNC achieved—Synchronization was required and has been achieved.

If synchronization is not achieved, the output shows one of the following:

Holding down until SYNC—No hold-down timer has been configured, so IS-IS continues to hold down adjacency until synchronization is achieved.

Holding down with timer—A hold-down timer has been configured, and IS-IS is holding down adjacency until the timer, indicated in the IGP Delay field, expires.

Maximum metric in effect—Although synchronization was not achieved, the IGP brought UP adjacency with the maximum metric.


Related Commands

Command
Description

mpls ldp autoconfig

Globally enables LDP autoconfiguration on all interfaces that belong to an OSPF or IS-IS process.

mpls ldp sync

Globally enables LDP synchronization on all interfaces that belong to an OSPF or IS-IS process.


show mpls ldp discovery

To display the status of the Label Distribution Protocol (LDP) discovery process, use the show mpls ldp discovery command in user EXEC or privileged EXEC mode.

show mpls ldp discovery [vrf vrf-name | all] [detail]

Syntax Description

vrf vrf-name

(Optional) Displays the neighbor discovery information for the specified Virtual Private Network (VPN) routing and forwarding (VRF) instance (vrf-name).

all

(Optional) When the all keyword is specified alone in this command, the command displays LDP discovery information for all VPNs, including those in the default routing domain.

detail

(Optional) Displays detailed information about all LDP discovery sources on a label switch router (LSR).


Defaults

This command displays neighbor discovery information for the default routing domain if an optional vrf keyword is not specified.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

11.1CT

This command was introduced.

12.0(10)ST

This command was integrated into Cisco IOS Release 12.0(10)ST. The command was modified to comply with Multiprotocol Label Switching (MPLS) Internet Engineering Task Force (IETF) command syntax and terminology.

12.0(14)ST

This command was modified for MPLS VPN support for LDP. The vrf and all keywords were added.

12.1(8a)E

This command was integrated into Cisco IOS Release 12.1(8a)E.

12.2(2)T

This command was integrated into Cisco IOS Release 12.2(2)T.

12.2(8)T

This command was modified for MPLS VPN support for LDP. The vrf and all keywords were added.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.

12.2(14)S

This command was integrated into Cisco IOS Release 12.2(14)S.

12.3(14)T

The detail keyword was added to the command to display information related to the LDP Autoconfiguration feature.

12.2(28)SB

The detail keyword was updated to display information related to LDP Message Digest 5 (MD5) password configuration.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

This command displays neighbor discovery information for LDP or Tag Distribution Protocol (TDP). It generates a list of interfaces over which the LDP discovery process is running.

Examples

The following is sample output from the show mpls ldp discovery command:

Router# show mpls ldp discovery

Local LDP Identifier:
    10.1.1.1:0
Discovery Sources:
    Interfaces:
        Ethernet1/1/3 (ldp): xmit/recv
            LDP Id: 172.23.0.77:0
            LDP Id: 10.144.0.44:0
            LDP Id: 10.155.0.55:0
        ATM3/0.1 (ldp): xmit/recv
            LDP Id: 10.203.0.7:2
        ATM0/0.2 (tdp): xmit/recv
            TDP Id: 10.119.0.1:1
Targeted Hellos:
        10.8.1.1 -> 10.133.0.33 (ldp): active, xmit/recv
            LDP Id: 10.133.0.33:0
        10.8.1.1 -> 192.168.7.16 (tdp): passive, xmit/recv
            TDP Id: 10.133.0.33:0
Router#

The following is sample output from the show mpls ldp discovery all command, which shows the interfaces engaged in LDP discovery activity for all the VPN routing and forwarding instances, including those in the default routing domain. In this example, note that the same neighbor LDP ID (10.14.14.14) appears in all the listed VRF interfaces, highlighting the fact that the same IP address can coexist in different VPN routing and forwarding instances.

Router# show mpls ldp discovery all 

Local LDP Identifier:
    10.12.12.12:0
    Discovery Sources:
    Interfaces:
        ATM1/1/0.1 (tdp):xmit/recv
            TDP Id:10.11.11.11:0
VRF vpn1:Local LDP Identifier:
    172.30.7.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.1 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn2:Local LDP Identifier:
    172.30.13.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.2 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn3:Local LDP Identifier:
    172.30.15.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.3 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn4:Local LDP Identifier:
    172.30.17.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.4 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn5:Local LDP Identifier:
    172.30.19.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.5 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn6:Local LDP Identifier:
    172.30.21.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.6 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn7:Local LDP Identifier:
    172.23.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.7 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn8:Local LDP Identifier:
    172.30.25.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.8 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn9:Local LDP Identifier:
    172.30.27.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.9 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn10:Local LDP Identifier:
    172.30.29.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.10 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn11:Local LDP Identifier:
    172.30.31.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.11 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn12:Local LDP Identifier:
    172.30.33.2:0
    Discovery Sources:
    Interfaces:
        ATM3/0/0.12 (ldp):xmit/recv
            LDP Id:10.14.14.14:0
VRF vpn13:Local LDP Identifier:
          
Router#

Table 2 describes the significant fields shown in the display.

Table 2 show mpls ldp discovery Field Descriptions 

Field
Description

Local LDP Identifier

The LDP identifier for the local router. An LDP identifier is 6-bytes displayed in the form "IP address:number."

By convention, the first four bytes of the LDP identifier constitute the router ID; integers, starting with 0, constitute the final two bytes of the IP address:number construct.

Interfaces

Lists the interfaces that are engaging in LDP discovery activity:

The xmit field—Indicates that the interface is sending LDP discovery hello packets.

The recv field—Indicates that the interface is receiving LDP discovery hello packets.

The (LDP) or (TDP) field—Indicates the label distribution protocol configured for the interface.

The LDP (or TDP) identifiers indicate the LDP (or TDP) neighbors discovered on the interface.

Targeted Hellos

Lists the platforms to which targeted hello messages are being sent:

The xmit, recv, (ldp), and (tdp) fields are as described for the Interfaces field.

The active field indicates that this LSR has initiated targeted hello messages.

The passive field indicates that the neighbor LSR has initiated targeted hello messages and that this LSR is configured to respond to the targeted hello messages from the neighbor.

Note The entry for a given target platform may indicate both active and passive.


The following is sample output from the show mpls ldp discovery detail command showing that LDP was enabled by the mpls ip command and the mpls ldp autoconfig command:

Router# show mpls ldp discovery detail

Local LDP Identifier:
    10.11.11.11:0
    Discovery Sources:
    Interfaces:
        Serial2/0 (ldp): xmit/recv
            Enabled: Interface config, IGP config;
            Hello interval: 5000 ms; Transport IP addr: 10.11.11.11 
            LDP Id: 10.10.10.10:0
              Src IP addr: 172.140.0.1; Transport IP addr: 10.10.10.10
              Hold time: 15 sec; Proposed local/peer: 15/15 sec

Table 3 describes the significant fields shown in the display.

Table 3 show mpls ldp discovery detail Field Descriptions 

Field
Description

Local LDP Identifier

The LDP identifier for the local router. An LDP identifier is a 6-byte construct displayed in the form "IP address:number."

By convention, the first four bytes of the LDP identifier constitute the router ID; integers, starting with 0, constitute the final two bytes of the IP address:number construct.

Interfaces

Lists the interfaces that are engaging in LDP discovery activity:

The xmit field—Indicates that the interface is sending LDP discovery hello packets.

The recv field—Indicates that the interface is receiving LDP discovery hello packets.

The (LDP) or (TDP) field—Indicates the label distribution protocol configured for the interface.

The LDP (or TDP) identifiers indicate the LDP (or TDP) neighbors discovered on the interface.

Interface config, IGP config;

Describes how LDP is enabled:

Interface config—Enabled by the mpls ip command.

IGP config—Enabled by the mpls ldp autoconfig command.

Interface config;,IGP config;—Enabled by the mpls ip command and the mpls ldp autoconfig command.

Hello interval

Period of time (in milliseconds) between the sending of consecutive hello messages.

Transport IP addr

Specifies that the interface address should be advertised as the transport address in the LDP discovery hello messages.

LDP Id

LDP ID of the peer router.

Src IP addr

Source IP address of the local router.

Transport IP addr

Specifies that the named IP address should be advertised as the transport address in the LDP discovery hello messages sent on an interface.

Hold time

Period of time (in seconds) a discovered LDP neighbor is remembered without receipt of an LDP hello message from the neighbor.

Proposed local/peer

Hold times (in seconds) proposed for LDP hello timer by the local router and the peer router. LDP uses the lower of these two values as the hold time.


The following is sample output from the show mpls ldp discovery detail command that displays information related to LDP MD5 passwords. Information related to MD5 passwords is pointed out in bold text in the output.

Router# show mpls ldp discovery detail

 Local LDP Identifier:
    10.10.10.10:0
    Discovery Sources:
    Interfaces:
        Ethernet1/0 (ldp): xmit/recv
            Hello interval: 5000 ms; Transport IP addr: 10.10.10.10 
            LDP Id: 10.4.4.4:0
              Src IP addr: 10.0.20.4; Transport IP addr: 10.4.4.4
              Hold time: 15 sec; Proposed local/peer: 15/15 sec
              Password: not required, none, stale       <-- LDP MD5 password information
    Targeted Hellos:
        10.10.10.10 -> 10.3.3.3 (ldp): passive, xmit/recv
            Hello interval: 10000 ms; Transport IP addr: 10.10.10.10
            LDP Id: 10.3.3.3:0
              Src IP addr: 10.3.3.3; Transport IP addr: 10.3.3.3
              Hold time: 90 sec; Proposed local/peer: 90/90 sec
              Password: required, neighbor, in use     <-- LDP MD5 password information

Password information displayed by this command includes:

Password requirement for the neighbor (required or not required).

Password source in the current configuration. The source is described by one of the following:

neighbor—This indicates that the password for the neighbor is retrieved from the mpls ldp neighbor [vrf vrf-name] ip-address password [0 | 7] password command. The ip-address argument is the router ID of the neighbor.

num—This indicates that the password for the neighbor is retrieved from mpls ldp [vrf vrf-name] password option number for acl [0 | 7] password command. The number argument is a number from 1 to 32767. The acl argument is the name or number of an IP standard access list that permits the neighbor router ID.

fallback—The password for the neighbor is retrieved from mpls ldp [vrf vrf-name] fallback password command.

none—No password is configured for this neighbor.

Password used by LDP sessions established with the neighbor is from current or previous configuration (in use or stale).

Related Commands

Command
Description

mpls label protocol (global configuration)

Specifies the label distribution protocol (LDP or TDP) to be used on a platform.

mpls label protocol (interface configuration)

Specifies the label distribution protocol (LDP or TDP) to be used on a given interface.

show mpls interfaces

Displays information about one or more interfaces that have been configured for label switching.

show mpls ldp neighbor

Displays the status of LDP sessions.


Feature Information for MPLS LDP Autoconfiguration

Table 4 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 4 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 4 Feature Information for MPLS LDP Autoconfiguration 

Feature Name
Releases
Feature Information

MPLS LDP Autoconfiguration

12.0(30)S
12.3(14)T
12.2(28)SB
12.0(32)SY
12.2(33)SRB

This feature enables you to globally configure LDP on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

The following sections provide information about this feature:

Information About MPLS LDP Autoconfiguration

How to Configure MPLS LDP Autoconfiguration

In Cisco IOS Release 12.2(32)SY, support for IS-IS was added.

This feature was integrated into Cisco IOS
Release 12.2(33)SRB. The MPLS LDP Autoconfiguration feature is not supported with IS-IS in this release.


All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (0612R)

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental.

© 2006-2007 Cisco Systems, Inc. All rights reserved.