Guest

Cisco IOS Software Releases 12.0 S

IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

  • Viewing Options

  • PDF (276.5 KB)
  • Feedback
IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Table Of Contents

IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Contents

Prerequisites for IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Information About IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Convergence

Two Alternative Methods to Reduce IS-IS Convergence Time

Small-Scale Method to Reduce IS-IS Convergence Time

Large-Scale Method to Reduce IS-IS Convergence Time

Benefit of Excluding IP Prefixes of Connected Networks in LSP Advertisements

How to Exclude Connected IP Prefixes from IS-IS LSP Advertisements

Excluding Connected IP Prefixes on a Small Scale

Excluding Connected IP Prefixes on a Large Scale

Configuration Examples for IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Excluding Connected IP Prefixes on a Small Scale: Example

Excluding Connected IP Prefixes on a Large Scale: Example

Where to Go Next

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

advertise-passive-only

isis advertise-prefix


IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements


This document describes two Integrated Intermediate System-to-Intermediate System (IS-IS) mechanisms to exclude IP prefixes of connected networks from link-state packet (LSP) advertisements, thereby reducing IS-IS convergence time.

Feature History for the IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements Feature

Release
Modification

12.0(22)S

This feature was introduced.

12.3(2)T

This feature was integrated into Cisco IOS Release 12.3(2)T.

12.2(18)S

This feature was integrated into Cisco IOS Release 12.2(18)S.

12.2(27)SBC

This feature was integrated into Cisco IOS Release 12.2(27)SBC.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Information About IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

How to Exclude Connected IP Prefixes from IS-IS LSP Advertisements

Configuration Examples for IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Where to Go Next

Additional References

Command Reference

Prerequisites for IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

Before you can use either mechanism to exclude IP prefixes of connected networks from IS-IS LSP advertisements, the integrated IS-IS routing protocol must be configured.

Information About IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

To exclude IP prefixes of connected networks from LSP advertisements, you should understand the following concepts:

Convergence

Two Alternative Methods to Reduce IS-IS Convergence Time

Benefit of Excluding IP Prefixes of Connected Networks in LSP Advertisements

Convergence

Convergence is the process of all routers coming to agreement on optimal routes in a network. When a network event causes routes to become available or unavailable, routers send routing update messages through the network that cause routing algorithms to recalculate optimal routes. Eventually all the routers agree on the routes. Fast convergence benefits the network performance. Routing algorithms that converge slowly may cause routing loops or network unavailability.

Two Alternative Methods to Reduce IS-IS Convergence Time

In order to speed up IS-IS convergence, the number of IP prefixes carried in LSPs needs to be limited. Configuring interfaces as unnumbered would limit the prefixes. However, for network management reasons, you might want to have numbered interfaces and also want to prevent advertising interface addresses into IS-IS.

The IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements feature provides two methods to avoid the overpopulation of routing tables and thereby reduce IS-IS convergence time. These methods are described in the following sections.

Small-Scale Method to Reduce IS-IS Convergence Time

You can explicitly configure an IS-IS interface not to advertise its IP network to the neighbors (by using the no isis advertise-prefix command). This method is feasible for a small network; it does not scale well. If you have dozens or hundreds of routers in your network, with possibly ten times as many physical interfaces involved, it would be difficult to add this command to each router's configuration.

Large-Scale Method to Reduce IS-IS Convergence Time

An easier way to reduce IS-IS convergence is to configure the IS-IS instance on a router to advertise only passive interfaces (by configuring the advertise-passive-only command). This command relies on the fact that when enabling IS-IS on a loopback interface, you usually configure the loopback as passive (to prevent sending unnecessary hello packets out through it because there is no chance of finding a neighbor behind it). Thus, if you want to advertise only the loopback and if it has already been configured as passive, configuring the advertise-passive-only command per IS-IS instance would prevent the overpopulation of the routing tables.

Benefit of Excluding IP Prefixes of Connected Networks in LSP Advertisements

Whether you choose to prevent the advertising of IS-IS interface subnetworks or advertise only the IS-IS prefixes that belong to passive (loopback) interfaces, you will reduce IS-IS convergence time. The IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements feature is recommended in any case where fast convergence is required.

How to Exclude Connected IP Prefixes from IS-IS LSP Advertisements

This section provides two alternative IS-IS mechanisms to exclude connected IP prefixes from LSP advertisements:

Excluding Connected IP Prefixes on a Small Scale (optional)

Excluding Connected IP Prefixes on a Large Scale (optional)

Excluding Connected IP Prefixes on a Small Scale

This section provides the steps necessary to exclude connected IP prefixes from IS-IS LSP advertisements in a small network.

For a configuration example of this feature where IS-IS acts as the MPLS backbone, see the "Excluding Connected IP Prefixes on a Small Scale: Example" section.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address net-mask

5. no ip directed-broadcast

6. ip router isis [area-tag]

7. no isis advertise-prefix

8. exit

9. Repeat Steps 3 through 8 for each interface on which you do not want to advertise IP prefixes.

10. router isis area-tag

11. net network-entity-title

12. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface Ethernet 0

Configures an interface type and enters interface configuration mode.

Step 4 

ip address ip-address net-mask

Example:

Router(config-if)# ip address 192.168.20.1 255.255.255.0

Sets a primary IP address for an interface.

The network mask can be indicated as a 4-part dotted decimal address or as a prefix. This example uses a 4-part dotted decimal number.

Step 5 

no ip directed-broadcast

Example:

Router(config-if)# no ip directed-broadcast

(Optional) Disables the translation of a directed broadcast to physical broadcasts.

Step 6 

ip router isis [area-tag]

Example:

Router(config-if)# ip router isis

Configures an IS-IS routing process on an interface and attaches an area designator to the routing process.

Step 7 

no isis advertise-prefix

Example:

Router(config-if)# no isis advertise-prefix

Prevents the advertising of IP prefixes of connected networks in LSP advertisements per IS-IS interface.

Step 8 

exit

Example:

Router(config-if)# exit

Returns to global configuration mode.

Step 9 

Repeat Steps 3 through 8 for each interface on which you do not want to advertise IP prefixes.

(Optional)

Step 10 

router isis area-tag

Example:

Router(config)# router isis

Enables the IS-IS routing protocol and specifies an IS-IS process.

Step 11 

net network-entity-title

Example:

Router(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

Configures an IS-IS network entity title (NET) for the routing process.

Step 12 

end

Example:

Router(config-router)# end

(Optional) Saves configuration commands to the running configuration file, exits configuration mode, and returns to privileged EXEC mode.

Use this command when you are ready to exit configuration mode and save the configuration to the running configuration file.


Excluding Connected IP Prefixes on a Large Scale

This section provides the steps necessary to exclude connected IP prefixes from LSP advertisements in a large network where IS-IS acts as the MPLS backbone.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface loopback number

4. ip address ip-address net-mask

5. no ip directed-broadcast

6. exit

7. interface type number

8. ip address ip-address net-mask

9. no ip directed-broadcast

10. ip router isis [area-tag]

11. exit

12. router isis area-tag

13. passive-interface [default] {type number}

14. net network-entity-title

15. advertise-passive-only

16. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface loopback number

Example:

Router(config)# interface loopback 0

Configures a loopback interface and enters interface configuration mode.

Step 4 

ip address ip-address net-mask

Example:

Router(config-if)# ip address 192.168.10.1 255.255.255.255

Sets a primary IP address for an interface.

The network mask can be indicated as a 4-part dotted decimal address or as a prefix. This example uses a 4-part dotted decimal number.

Step 5 

no ip directed-broadcast

Example:

Router(config-if)# no ip directed-broadcast

(Optional) Disables the translation of a directed broadcast to physical broadcasts.

Step 6 

exit

Example:

Router(config-if)# exit

Returns to global configuration mode.

Step 7 

interface type number

Example:

Router(config)# interface Ethernet 0

Configures an interface type and enters interface configuration mode.

Step 8 

ip address ip-address net-mask

Example:

Router(config-if)# ip address 192.168.20.1 255.255.255.0

Sets a primary IP address for an interface.

The network mask can be indicated as a 4-part dotted decimal address or as a prefix. This example uses a 4-part dotted decimal number.

Step 9 

no ip directed-broadcast

Example:

Router(config-if)# no ip directed-broadcast

(Optional) Disables the translation of a directed broadcast to physical broadcasts.

Step 10 

ip router isis [area-tag]

Example:

Router(config-if)# ip router isis

Configures an IS-IS routing process on an interface and attaches an area designator to the routing process.

Step 11 

exit

Example:

Router(config-if)# exit

Returns to global configuration mode.

Step 12 

router isis area-tag

Example:

Router(config)# router isis

Enables the IS-IS routing protocol and specifies an IS-IS process.

Step 13 

passive-interface [default] {type number}

Example:

Router(config-router)# passive-interface loopback 0

Disables sending routing updates on an interface.

Step 14 

net network-entity-title

Example:

Router(config-router)# net 47.0004.004d.0001.0001.0c11.1111.00

Configures an IS-IS NET for the routing process.

Step 15 

advertise-passive-only

Example:

Router(config-router)# advertise-passive-only

Configures IS-IS to advertise only prefixes that belong to passive interfaces.

Step 16 

end

Example:

Router(config-router)# end

(Optional) Saves configuration commands to the running configuration file, exits configuration mode, and returns you to privileged EXEC mode.

Use this command when you are ready to exit configuration mode and save the configuration to the running configuration file.


Configuration Examples for IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements

This section provides the following examples:

Excluding Connected IP Prefixes on a Small Scale: Example

Excluding Connected IP Prefixes on a Large Scale: Example

Excluding Connected IP Prefixes on a Small Scale: Example

The following example uses the no isis advertise-prefix command on Ethernet interface 0. Only the IP address of loopback interface 0 is advertised.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet 0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 no isis advertise-prefix
!
!.
!.
!.
!
router isis 
 passive-interface loopback 0
 net 47.0004.004d.0001.0001.0c11.1111.00
 log-adjacency-changes
!

Excluding Connected IP Prefixes on a Large Scale: Example

The following example uses the advertise-passive-only command, which applies to the entire IS-IS instance, thereby preventing IS-IS from advertising the IP network of Ethernet interface 0. Only the IP address of loopback interface 0 is advertised.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
!
interface Ethernet0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
!.
!.
!.
!
router isis 
 passive-interface Loopback0
 net 47.0004.004d.0001.0001.0c11.1111.00
 advertise-passive-only
 log-adjacency-changes
!

Where to Go Next

You might want to propagate the prefixes configured on interfaces by means other than IS-IS, such as internal BGP (iBGP), because fast convergence is not requested for interface addresses. If so, refer to the "Configuring BGP" chapter in the Cisco IOS IP Configuration Guide, Release 12.2.

Additional References

The following sections provide references related to the IS-IS Mechanisms to Exclude Connected IP Prefixes from LSP Advertisements feature.

Related Documents

Related Topic
Document Title

Integrated IS-IS commands

"Integrated IS-IS Commands" chapter in the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2

IS-IS configuration tasks

"Configuring Integrated IS-IS" chapter in the Cisco IOS IP Configuration Guide, Release 12.2

BGP configuration tasks

"Configuring BGP" chapter in the Cisco IOS IP Configuration Guide, Release 12.2


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents new commands only.

advertise-passive-only

isis advertise-prefix

advertise-passive-only

To configure Intermediate System-to-Intermediate System (IS-IS) to advertise only prefixes that belong to passive interfaces, use the advertise-passive-only command in router configuration mode. To remove the restriction, use the no form of this command.

advertise-passive-only

no advertise-passive-only

Syntax Description

This command has no arguments or keywords.

Defaults

This command has no default behavior.

Command Modes

Router configuration

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.3(2)T

This command was integrated into Cisco IOS Release 12.3(2)T.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.


Usage Guidelines

This command is an IS-IS mechanism to exclude IP prefixes of connected networks from link-state packet (LSP) advertisements, thereby reducing IS-IS convergence time.

Configuring this command per IS-IS instance is a scalable solution to reduce IS-IS convergence time because fewer prefixes will be advertised in the router nonpseudonode LSP.

This command relies on the fact that when enabling IS-IS on a loopback interface, you usually configure the loopback as passive (to prevent sending unnecessary hello packets out through it because there is no chance of finding a neighbor behind it). Thus, if you want to advertise only the loopback and if it has already been configured as passive, configuring the advertise-passive-only command per IS-IS instance would prevent the overpopulation of the routing tables.

An alternative to this command is the no isis advertise-prefix command. The no isis advertise-prefix command is a small-scale solution because it is configured per interface.

Examples

The following example uses the advertise-passive-only command, which affects the IS-IS instance, and thereby prevents advertising the IP network of Ethernet interface 0. Only the IP address of loopback interface 0 is advertised.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
!
interface Ethernet0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
!.
!.
!.
!
router isis 
 passive-interface Loopback0
 net 47.0004.004d.0001.0001.0c11.1111.00
 advertise-passive-only
 log-adjacency-changes
!

Related Commands

Command
Description

isis advertise-prefix

Allows the advertising of IP prefixes of connected networks in LSP advertisements per IS-IS interface.

passive-interface

Suppresses the sending of routing updates through the specified interface.


isis advertise-prefix

To allow the advertising of IP prefixes of connected networks in link-state packet (LSP) advertisements per Intermediate System-to-Intermediate System (IS-IS) interface, use the isis advertise-prefix command in interface configuration mode. To prevent IP prefixes of connected networks from being advertised, use the no form of this command.

isis advertise-prefix

no isis advertise-prefix

Syntax Description

This command has no arguments or keywords.

Defaults

Enabled; IP prefixes are advertised.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(22)S

This command was introduced.

12.3(2)T

This command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.


Usage Guidelines

The no isis advertise-prefix command is an IS-IS mechanism to exclude IP prefixes of connected networks from LSP advertisements, thereby reducing IS-IS convergence time.

Configuring the no form of this command per IS-IS interface is a small-scale solution to reduce IS-IS convergence time because fewer prefixes will be advertised in the router nonpseudonode LSP.

An alternative to this command is the advertise-passive-only command. The latter is a scalable solution because it is configured per IS-IS instance.

Examples

The following example uses the no isis advertise-prefix command on Ethernet interface 0. Only the IP address of loopback interface 0 is advertised.

!
interface loopback 0
 ip address 192.168.10.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet 0
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 no isis advertise-prefix
!
!.
!.
!.
!
router isis 
 passive-interface loopback 0
 net 47.0004.004d.0001.0001.0c11.1111.00
 log-adjacency-changes
!

Related Commands

Command
Description

advertise-passive-only

Configures the IS-IS instance to advertise only prefixes that belong to passive interfaces.