Guest

Cisco IOS Software Releases 12.0 S

MPLS LDP Graceful Restart

  • Viewing Options

  • PDF (500.0 KB)
  • Feedback
MPLS LDP Graceful Restart

Table Of Contents

MPLS LDP Graceful Restart

Contents

Information About MPLS LDP Graceful Restart

How MPLS LDP Graceful Restart Works

How a Route Processor Advertises That It Supports MPLS LDP Graceful Restart

What Happens If a Route Processor Does Not Have LDP Graceful Restart

How to Configure MPLS LDP Graceful Restart

Configuring MPLS LDP Graceful Restart

Restrictions

Verifying the Configuration

Configuration Example for MPLS LDP Graceful Restart

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

debug mpls ldp graceful-restart

mpls ldp graceful-restart

mpls ldp graceful-restart timers max-recovery

mpls ldp graceful-restart timers neighbor-liveness

show mpls ip binding

show mpls ldp bindings

show mpls ldp graceful-restart

show mpls ldp neighbor


MPLS LDP Graceful Restart


When a router is configured with Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) Graceful Restart (GR), it assists a neighboring router that has MPLS LDP Stateful Switchover/Nonstop Forwarding (SSO/NSF) Support and Graceful Restart to recover gracefully from an interruption in service. In this Cisco IOS release, MPLS LDP GR functions strictly in helper mode, which means it can only help other routers that are enabled with MPLS SSO/NSF and GR to recover. If the router with LDP GR fails, its peer routers cannot help it recover.

Notes:

MPLS LDP SSO/NSF Support and Graceful Restart is supported in Cisco IOS Release 12.2(25)S. For brevity, this feature is called LDP SSO/NSF in this document.

The MPLS LDP GR feature described in this document refers to helper mode.

When you enable MPLS LDP GR on a router that peers with an MPLS LDP SSO/NSF-enabled router, the SSO/NSF-enabled router can maintain its forwarding state when the LDP session between them is interrupted. While the SSO/NSF-enabled router recovers, the peer router forwards packets using stale information. This enables the SSO/NSF-enabled router to become operational more quickly.

Feature History for MPLS LDP Graceful Restart

Release
Modification

12.0(29)S

The MPLS LDP Graceful Restart feature (in helper mode) was introduced.

12.3(14)T

This feature was integrated into Cisco IOS Release 12.3(14)T.

12.2(33)SRA

This feature was integrated into Cisco IOS Release 12.2(33)SRA.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Information About MPLS LDP Graceful Restart

How to Configure MPLS LDP Graceful Restart

Configuration Example for MPLS LDP Graceful Restart

Additional References

Command Reference

Information About MPLS LDP Graceful Restart

To configure MPLS LDP GR, you need to understand the following concepts:

How MPLS LDP Graceful Restart Works

How a Route Processor Advertises That It Supports MPLS LDP Graceful Restart

What Happens If a Route Processor Does Not Have LDP Graceful Restart

How MPLS LDP Graceful Restart Works

MPLS LDP GR works in strict helper mode, which means it helps a neighboring route processor that has MPLS LDP SSO/NSF to recover from disruption in service without losing its MPLS forwarding state. The disruption in service could be the result of a TCP or UDP event or the stateful switchover of a route processor. When the neighboring router establishes a new session, the LDP bindings and MPLS forwarding states are recovered.

In the topology shown in Figure 1, the following elements have been configured:

LDP sessions are established between Router 1 and Router 2, as well as between Router 2 and Router 3.

Router 2 has been configured with MPLS LDP SSO/NSF. Routers 1 and 3 have been configured with MPLS LDP GR.

A label switched path (LSP) has been established between Router 1 and Router 3.

Figure 1 Example of a Network Using LDP Graceful Restart

The following process shows how Routers 1 and 3, which have been configured with LDP GR help Router 2, which has been configured with LDP SSO/NSF recover from a disruption in service:

1. Router 1 notices an interruption in service with Router 2. (Router 3 also performs the same actions in this process.)

2. Router 1 marks all the label bindings from Router 2 as stale, but it continues to use the bindings for MPLS forwarding.

Router 1 reestablishes an LDP session with Router 2, but keeps its stale label bindings. If you issue a show mpls ldp neighbor command with the graceful-restart keyword, the command output displays the recovering LDP sessions.

3. Both routers readvertise their label binding information. If Router 1 relearns a label from Router 2 after the session has been established, the stale flags are removed. The show mpls forwarding-table command displays the information in the MPLS forwarding table, including the local label, outgoing label or VC, prefix, label-switched bytes, outgoing interface, and next hop.

You can set various graceful restart timers. See the following commands for more information:

mpls ldp graceful-restart timers neighbor-liveness

mpls ldp graceful-restart timers max-recovery

How a Route Processor Advertises That It Supports MPLS LDP Graceful Restart

A route processor that is configured to perform MPLS LDP GR includes the Fault Tolerant (FT) Type Length Value (TLV) in the LDP initialization message. The route processor sends the LDP initialization message to a neighbor to establish an LDP session.

The FT session TLV includes the following information:

The Learn from Network (L) flag is set to 1, which indicates that the route processor is configured to perform MPLS LDP GR.

The Reconnect Timeout field shows the time (in milliseconds) that the neighbor should wait for a reconnection if the LDP session is lost. In this release, the timer is set to 0, which indicates that if the local router fails, its peers should not wait for it to recover. The timer setting indicates that the local router is working in helper mode.

The Recovery Time field shows the time (in milliseconds) that the neighbor should retain the MPLS forwarding state during a recovery. If a neighbor did not preserve the MPLS forwarding state before the restart of the control plane, the neighbor sets the recovery time to 0.

What Happens If a Route Processor Does Not Have LDP Graceful Restart

If two route processors establish an LDP session and one route processor is not configured for MPLS LDP GR, the two route processors create a normal LDP session but do not have the ability to perform MPLS LDP GR. Both route processors must be configured for MPLS LDP GR.

How to Configure MPLS LDP Graceful Restart

This section contains the following procedures:

Configuring MPLS LDP Graceful Restart (required)

Verifying the Configuration (optional)

Configuring MPLS LDP Graceful Restart

You must enable MPLS LDP GR on all route processors for an LDP session to be preserved during an interruption in service.

MPLS LDP GR is enabled globally. When you enable MPLS LDP GR, it has no effect on existing LDP sessions. New LDP sessions that are established can perform MPLS LDP GR.

Restrictions

MPLS LDP GR is supported in strict helper mode.

Tag Distribution Protocol (TDP) sessions are not supported. Only LDP sessions are supported.

MPLS LDP GR cannot be configured on label-controlled ATM (LC-ATM) interfaces.

MPLS LDP SSO/NSF is supported in IOS Release 12.2(25)S. It is not supported in this release.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef [distributed]

4. mpls ldp graceful-restart

5. interface type slot/port

6. mpls ip

7. mpls label protocol {ldp | tdp | both}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef [distributed]

Example:

Router(config)# ip cef distributed

Enables Cisco Express Forwarding (CEF).

Step 4 

mpls ldp graceful-restart
Example:
Router(config)# mpls ldp graceful-restart

Enables the router to protect the LDP bindings and MPLS forwarding state during a disruption in service.

Step 5 

interface type slot/port
Example:
Router(config)# interface pos 3/0 

Specifies an interface and enters interface configuration mode.

Step 6 

mpls ip
Example:

Router(config-if)# mpls ip

Configures MPLS hop-by-hop forwarding for an interface.

Step 7 

mpls label protocol {ldp | tdp | both}
Example:

Router(config-if)# mpls label protocol ldp

Configures the use of LDP for an interface. You must use LDP.



Note You can also issue the mpls label protocol ldp command in global configuration mode, which enables LDP on all interfaces configured for MPLS.


Verifying the Configuration

The following commands help verify that MPLS LDP GR has been configured correctly:

show mpls ldp neighbor with the graceful-restart keyword

Displays the Graceful Restart information for LDP sessions.

show mpls ldp graceful-restart

Displays Graceful Restart sessions and session parameters.


Configuration Example for MPLS LDP Graceful Restart

Figure 2 shows a configuration where MPLS LDP GR is enabled on Router 1 and MPLS LDP SSO/NSF is enabled on Routers 2 and 3. In this configuration example, Router 1 creates an LDP session with Router 2. Router 1 also creates a targeted session with Router 3 through a traffic engineering tunnel using Router 2.


Note MPLS LDP SSO/NSF is supported in Cisco IOS Release 12.2(25)S. It is not supported in this release.


Figure 2 MPLS LDP Graceful Restart Configuration Example

Router 1 configured with LDP GR:

boot system slot0:rsp-pv-mz 
hw-module slot 2 image slot0:rsp-pv-mz 
hw-module slot 3 image slot0:rsp-pv-mz  
!
ip subnet-zero
ip cef
mpls label range 16 10000 static 10001 1048575
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 20.20.20.20 255.255.255.255
 no ip directed-broadcast
 no ip mroute-cache
!
interface Tunnel1
 ip unnumbered Loopback0
 no ip directed-broadcast
 mpls label protocol ldp
 mpls ip
 tunnel destination 19.19.19.19
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth  500
 tunnel mpls traffic-eng path-option 1 dynamic
!
interface ATM5/1/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM5/1/0.5 point-to-point
 ip address 12.0.0.2 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 pvc 6/100 
  encapsulation aal5snap
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1000
!
router ospf 100
 log-adjacency-changes
 redistribute connected
     network 12.0.0.0 0.255.255.255 area 100
 network 20.20.20.20 0.0.0.0 area 100
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 100

Router 2 configured with LDP SSO/NSF:

boot system slot0:rsp-pv-mz 
hw-module slot 2 image slot0:rsp-pv-mz 
hw-module slot 3 image slot0:rsp-pv-mz  
!
redundancy
  mode sso
!
ip cef
no ip domain-lookup
mpls label range 17 10000 static 10001 1048575
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
no mpls advertise-labels
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 17.17.17.17 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/0/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM4/0/0.5 point-to-point
 ip address 12.0.0.1 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 pvc 6/100 
  encapsulation aal5snap
mpls label protocol ldp
mpls traffic-eng tunnels
mpls ip
ip rsvp bandwidth 1000
!
interface POS5/1/0
 ip address 11.0.0.1 255.0.0.0
 no ip directed-broadcast
 encapsulation ppp
 mpls label protocol ldp
 mpls traffic-eng tunnels
 mpls ip
 no peer neighbor-route
 clock source internal
 ip rsvp bandwidth 1000
!
router ospf 100
 log-adjacency-changes
 redistribute connected
 nsf enforce global
 network 11.0.0.0 0.255.255.255 area 100
 network 12.0.0.0 0.255.255.255 area 100
 network 17.17.17.17 0.0.0.0 area 100
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 100
!
ip classless

Router 3 configured with LDP SSO/NSF:

boot system slot0:rsp-pv-mz 
hw-module slot 2 image slot0:rsp-pv-mz 
hw-module slot 3 image slot0:rsp-pv-mz  
!
redundancy
  mode sso
!
ip subnet-zero
ip cef
!
no ip finger
no ip domain-lookup
mpls label protocol ldp
mpls ldp neighbor 11.11.11.11 targeted ldp
mpls ldp logging neighbor-changes
mpls ldp graceful-restart
mpls traffic-eng tunnels
no mpls traffic-eng auto-bw timers frequency 0
mpls ldp discovery directed-hello interval 12
mpls ldp discovery directed-hello holdtime 130
mpls ldp discovery directed-hello accept
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 19.19.19.19 255.255.255.255
 no ip directed-broadcast
!
interface POS1/0
 ip address 11.0.0.2 255.0.0.0
 no ip directed-broadcast
 encapsulation ppp
 mpls label protocol ldp
 mpls traffic-eng tunnels
 mpls ip
 no peer neighbor-route
 clock source internal
 ip rsvp bandwidth 1000
!
router ospf 100
 log-adjacency-changes
 redistribute connected
 nsf enforce global
network 11.0.0.0 0.255.255.255 area 100
network 19.19.19.19 0.0.0.0 area 100
mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 100
!
ip classless

Additional References

The following sections provide references related to MPLS LDP GR.

Related Documents

Related Topic
Document Title

MPLS Label Distribution Protocol

MPLS Label Distribution Protocol (LDP)


Standards

Standards
Title

None


MIBs

MIBs 1
MIBs Link

MPLS Label Distribution Protocol MIB Version 8 Upgrade

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

1 Not all supported MIBs are listed.


RFCs

RFCs 1
Title

RFC 3036

LDP Specification

RFC 3478

Graceful Restart Mechanism for Label Distribution

1 Not all supported RFCs are listed.


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents modified commands.

New Commands

debug mpls ldp graceful-restart

mpls ldp graceful-restart

mpls ldp graceful-restart timers max-recovery

mpls ldp graceful-restart timers neighbor-liveness

Modified Commands

show mpls ip binding

show mpls ldp bindings

show mpls ldp graceful-restart

show mpls ldp neighbor

debug mpls ldp graceful-restart

To display debugging information for Multiprotocol (MPLS) Label Distribution Protocol (LDP) Stateful Switchover (SSO) Nonstop Forwarding (NSF) Support and Graceful Restart, use the debug mpls ldp graceful-restart command in privileged EXEC mode. To disable the display of this debugging information, use the no form of this command.

debug mpls ldp graceful-restart

no debug mpls ldp graceful-restart

Syntax Description

This command has no arguments or keywords.

Defaults

The display of debugging information is not enabled.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(25)S

This command was introduced.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

This command shows events and errors related to LDP Graceful Restart.

Examples

The following example shows sample output from the debug mpls ldp graceful-restart command. The output shows that a session was lost. The status message show the events that happen during recovery of the bindings.

Router# debug mpls ldp graceful-restart

LDP GR: GR session 10.110.0.10:0:: lost
LDP GR: down nbr 10.110.0.10:0:: created [1 total]
LDP GR: GR session 10.110.0.10:0:: bindings retained
LDP GR: down nbr 10.110.0.10:0:: added all 7 addresses [7 total]
LDP GR: down nbr 10.110.0.10:0:: state change (None -> Reconnect-Wait)
LDP GR: down nbr 10.110.0.10:0:: reconnect timer started [120000 msecs]
LDP GR: down nbr 10.110.0.10:0:: added to bindings task queue [1 entries]
LDP GR: searching for down nbr record (10.110.0.10:0, 10.2.0.10)
LDP GR: search for down nbr record (10.110.0.10:0, 10.2.0.10) returned 10.110.0.10:0
LDP GR: Added FT Sess TLV (Rconn 120000, Rcov 120000) to INIT msg to 10.110.0.10:0
LDP GR: Tagcon querying for up to 12 bindings update tasks
LDP GR: down nbr 10.110.0.10:0:: requesting bindings MARK for {10.110.0.10:0, 1}
LDP GR: down nbr 10.110.0.10:0:: removed from bindings task queue [0 entries]
LDP GR: Requesting 1 bindings update tasks [0 left in queue]
LDP GR: 10.0.0.0/8:: updating binding from 10.110.0.10:0, inst 1:: marking stale; 
LDP GR: 10.2.0.0/16:: updating binding from 10.110.0.10:0, inst 1:: marking stale; 
LDP GR: 14.0.0.14/32:: updating binding from 10.110.0.10:0, inst 1:: marking stale; 
LDP GR: searching for down nbr record (10.110.0.10:0, 10.2.0.10)
LDP GR: search for down nbr record (10.110.0.10:0, 10.2.0.10) returned 10.110.0.10:0
LDP GR: Added FT Sess TLV (Rconn 120000, Rcov 120000) to INIT msg to 10.110.0.10:0
LDP GR: searching for down nbr record (10.110.0.10:0, 10.2.0.10)
LDP GR: search for down nbr record (10.110.0.10:0, 10.2.0.10) returned 10.110.0.10:0
LDP GR: Added FT Sess TLV (Rconn 120000, Rcov 120000) to INIT msg to 10.110.0.10:0
LDP GR: searching for down nbr record (10.110.0.10:0, 10.2.0.10)
LDP GR: search for down nbr record (10.110.0.10:0, 10.2.0.10) returned 10.110.0.10:0
LDP GR: Added FT Sess TLV (Rconn 120000, Rcov 120000) to INIT msg to 10.110.0.10:0
LDP GR: searching for down nbr record (10.110.0.10:0, 10.2.0.10)
LDP GR: search for down nbr record (10.110.0.10:0, 10.2.0.10) returned 10.110.0.10:0
LDP GR: Added FT Sess TLV (Rconn 120000, Rcov 120000) to INIT msg to 10.110.0.10:0
LDP GR: searching for down nbr record (10.110.0.10:0, 10.2.0.10)
LDP GR: search for down nbr record (10.110.0.10:0, 10.2.0.10) returned 10.110.0.10:0
LDP GR: Added FT Sess TLV (Rconn 120000, Rcov 120000) to INIT msg to 10.110.0.10:0
LDP GR: Received FT Sess TLV from 10.110.0.10:0  (fl 0x1, rs 0x0, rconn 120000, rcov 
120000)
LDP GR: GR session 10.110.0.10:0:: allocated instance, 2
LDP GR: GR session 10.110.0.10:0:: established
LDP GR: GR session 10.110.0.10:0:: found down nbr 10.110.0.10:0
LDP GR: down nbr 10.110.0.10:0:: reconnect timer stopped
LDP GR: down nbr 10.110.0.10:0:: state change (Reconnect-Wait -> Recovering)
LDP GR: down nbr 10.110.0.10:0:: recovery timer started [120000 msecs]
%LDP-5-GR: GR session 10.110.0.10:0 (inst. 2): starting graceful recovery
%LDP-5-NBRCHG: LDP Neighbor 10.110.0.10:0 is UP
LDP GR: 2.0.0.0//8:: refreshing stale binding from 10.110.0.10:0, inst 1 -> inst 2
LDP GR: 10.43.0.0//16:: refreshing stale binding from 10.110.0.10:0, inst 1 -> inst 2
LDP GR: down nbr 10.110.0.10:0:: recovery timer expired
%LDP-5-GR: GR session 10.110.0.10:0 (inst. 2): completed graceful recovery
LDP GR: down nbr 10.110.0.10:0:: destroying record [0 left]
LDP GR: down nbr 10.110.0.10:0:: state change (Recovering -> Delete-Wait)
LDP GR: down nbr 10.110.0.10:0:: added to bindings task queue [1 entries]
LDP GR: Tagcon querying for up to 12 bindings update tasks
LDP GR: down nbr 10.110.0.10:0:: requesting bindings DEL for {10.110.0.10:0, 1}
LDP GR: down nbr 10.110.0.10:0:: removed from bindings task queue [0 entries]
LDP GR: Requesting 1 bindings update tasks [0 left in queue]
LDP GR: GR session 10.110.0.10:0:: released instance, 1

The debug output is formatted in three general ways. Table 1 describes the fields for the debug command output:

Table 1 debug mpls ldp graceful-restart Command Field Descriptions 

Field
Description

LDP GR: GR session 10.110.0.10:0:: found down nbr 10.110.0.10:0

LDP GR

Identifies LDP Graceful Restart application

GR session 10.110.0.10:0

ID of the LDP session that is enabled for Graceful Restart.

found down nbr 10.110.0.10:0

Describes the event that is happening to that LDP session.

LDP GR: down nbr 10.110.0.10:0:: removed from bindings task queue [0 entries]

down nbr 10.110.0.10:0::

Identifies the Down Neighbor record, which logs the state of a recently lost Graceful Restart session.

removed from bindings task queue [0 entries]

Describes the event that is happening to the recently lost Graceful Restart session.

LDP GR: 10.0.0.0/8:: updating binding from 10.110.0.10:0, inst 1:: marking stale;

10.0.0.0/8::

Identifies the Forwarding Equivalence Class (FEC) associated with the remote label binding being modified. The FEC identifies the Label Information Base (LIB) entry.

updating binding

Lists the operation being performed on the remote label binding.

10.110.0.10:0, inst 1:: marking stale;

Identifies the LDP session during which the remote label binding was learned.


:

Related Commands

Command
Description

show mpls ldp graceful-restart

Displays a summary of the LDP Graceful Restart status.


mpls ldp graceful-restart

To enable Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) Graceful Restart, use the mpls ldp graceful-restart command in global configuration mode. To disable LDP Graceful Restart, use the no form of this command.

mpls ldp graceful-restart

no mpls ldp graceful-restart

Syntax Description

This command has no arguments or keywords.

Defaults

LDP Graceful Restart is not enabled.

Command Modes

Global configuration

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(25)S

This command was integrated into Cisco IOS Release 12.2(25)S.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

LDP Graceful Restart must be enabled before an LDP session is established.

Using the no form of the command disables the Graceful Restart functionality on all LDP sessions.

Examples

The command in the following example enables LDP Graceful Restart on a router:

Router(config)# mpls ldp graceful-restart

Related Commands

Command
Description

mpls ldp graceful-restart timers forwarding-holding

Specifies the amount of time the MPLS forwarding state should be preserved after the control plane restarts.

mpls ldp graceful-restart timers neighbor-liveness

Specifies the amount of time a router should wait for an LDP session to be reestablished.

mpls ldp graceful-restart timers max-recovery

Specifies the amount of time a router should hold stale label-FEC bindings after an LDP session has been reestablished.


mpls ldp graceful-restart timers max-recovery

To specify the amount of time a router should hold stale label-Forwarding Equivalence Class (FEC) bindings after a Label Distribution Protocol (LDP) session has been reestablished, use the mpls ldp graceful-restart timers max-recovery command in global configuration mode. To revert to the default timer value, use the no form of this command.

mpls ldp graceful-restart timers max-recovery secs

no mpls ldp graceful-restart timers max-recovery

Syntax Description

secs

The amount of time (in seconds) that the router should hold stale label-FEC bindings after an LDP session has been reestablished. The default is 120 seconds. The acceptable range of values is 15 to 600 seconds.


Defaults

Stale label-FEC bindings are held for 120 seconds after an LDP session has been reestablished.

Command Modes

Global configuration

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

After the timer expires, all stale label-FEC bindings learned from the associated LDP session are removed, which results in the removal of any forwarding table entries that are based on those bindings.

Examples

In the following example, the router should hold stale label-FEC bindings after an LDP session has been reestablished for 180 seconds:

Router(config)# mpls ldp graceful-restart timers max-recovery 180

Related Commands

Command
Description

mpls ldp graceful-restart timers forwarding-holding

Specifies the amount of time the MPLS forwarding state should be preserved after the control plane restarts.

mpls ldp graceful-restart timers neighbor-liveness

Specifies the amount of time a router should wait for an LDP session to be reestablished.


mpls ldp graceful-restart timers neighbor-liveness

To specify the upper bound on the amount of time a router should wait for a Label Distribution Protocol (LDP) session to be reestablished, use the mpls ldp graceful-restart timers neighbor-liveness command in global configuration mode. To revert to the default timer value, use the no form of this command.

mpls ldp graceful-restart timers neighbor-liveness secs

no mpls ldp graceful-restart timers neighbor-liveness

Syntax Description

secs

The amount of time (in seconds) that the router should wait for an LDP session to be reestablished. The default is 120 seconds. The range is 5 to 300 seconds.


Defaults

The default is a maximum of 120 seconds.

Command Modes

Global configuration

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

The amount of time a router waits for an LDP session to be reestablished is the lesser of the following values:

The value of the peers Fault Tolerant (FT) Type Length Value (TLV) Reconnect Timeout

The value of the neighbor liveness timer

If the router cannot reestablish an LDP session with the neighbor in the time allotted, the router deletes the stale label-FEC bindings received from that neighbor.

Examples

The command in the following example sets the amount of time that the router should wait for an LDP session to be reestablished to 30 seconds:

Router(config)# mpls ldp graceful-restart timers neighbor-liveness 30

Related Commands

Command
Description

mpls ldp graceful-restart timers forwarding-holding

Specifies the amount of time the MPLS forwarding state should be preserved after the control plane restarts.

mpls ldp graceful-restart timers max-recovery

Specifies the amount of time a router should hold stale label-FEC bindings after an LDP session has been reestablished.


show mpls ip binding

To display specified information about label bindings learned by the Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP), use the show mpls ip binding command in user EXEC or privileged EXEC mode.

show mpls ip binding [vrf vrf-name | all] [network {mask | length} [longer-prefixes]]
[
neighbor address | local] [local-label {atm vpi vci | label  [- label]}]
[
remote-label {atm vpi vci | label  [- label]}] [interface interface] [generic | atm]

show mpls ip binding [vrf vrf-name | all] [detail | summary]

Cisco 10000 Series Routers

show mpls ip binding [network {mask | length} [longer-prefixes]] [neighbor address | local] [local-label label [- label]] [remote-label label  [- label]] [generic]

show mpls ip binding [detail | summary]

Syntax Description

vrf vrf-name

(Optional) Displays the LDP neighbors for the specified Virtual Private Network (VPN) routing and forwarding (VRF) instance (vrf-name).

Note This keyword and argument pair does not apply to the Cisco 10000 series routers.

all

(Optional) Displays binding information for all VRFs.

Note This keyword does not apply to the Cisco 10000 series routers.

network

(Optional) Defines the destination network number.

mask

(Optional) Defines the network mask, written as A.B.C.D.

length

(Optional) Defines the mask length (1 to 32 characters).

longer-prefixes

(Optional) Selects any prefix that matches the mask with a length from 1 to 32 characters.

neighbor address

(Optional) Displays label bindings assigned by the selected neighbor.

local

(Optional) Displays the local label bindings.

local-label atm vpi vci

(Optional) Displays the entry with the locally assigned ATM label that matches the specified ATM label value. The virtual path identifier (VPI) range is 0 to 4095. The virtual channel identifier (VCI) range is 0 to 65535.

Note These keywords and arguments do not apply to the Cisco 10000 series routers.

local-label label - label

(Optional) Displays entries with locally assigned labels that match the specified label values. Use the labellabel arguments and keyword to indicate the label range. The hyphen (-) keyword is required for a label range.

remote-label atm vpi vci

(Optional) Displays entries with remotely assigned ATM label values learned from neighbor routers that match the specified ATM label value. The VPI range is 0 to 4095. The VCI range is 0 to 65535.

Note These keywords and arguments do not apply to the Cisco 10000 series routers.

remote-label label label

(Optional) Displays entries with remotely assigned labels learned from neighbor routers that match the specified label values. Use the label - label arguments and keyword to indicate the label range. The hyphen (-) keyword is required for a label range.

interface interface

(Optional) Displays label bindings associated with the specified interface (for label-controlled (LC)-ATM only).

Note This keyword and argument pair does not apply to the Cisco 10000 series routers.

generic

(Optional) Displays only generic (non-LC-ATM) label bindings.

atm

(Optional) Displays only LC-ATM label bindings.

Note This keyword does not apply to the Cisco 10000 series routers.

detail

(Optional) Displays detailed information about label bindings learned by LDP.

summary

(Optional) Displays summary information about label bindings learned by LDP.


Defaults

All label bindings are displayed when no optional arguments or keywords are specified.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(14)ST

This command was modified to reflect MPLS VPN support for LDP.

12.1(2)T

This command was integrated into Cisco IOS Release 12.1(2)T.

12.1(8a)E

This command was integrated into Cisco IOS Release 12.1(8a)E.

12.2(2)T

This command was integrated into Cisco IOS Release 12.2(2)T.

12.2(4)T

The VPI range of values was extended to 4095.


12.2(8)T

This command was integrated into Cisco IOS Release 12.2(8)T.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.

12.0(23)S

This command was integrated into Cisco IOS Release 12.0(23)S.

12.2(13)T

This command was integrated into Cisco IOS Release 12.2(13)T.

12.2(14)S

This command was integrated into Cisco IOS Release 12.2(14)S.

12.2(25)S

The detail keyword was added to display checkpoint status for local label bindings.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

The show mpls ip binding command displays label bindings learned by LDP or the Tag Distribution Protocol (TDP).


Note TDP is not supported for LDP features in Cisco IOS 12.0(30)S and later releases, 12.2(27)SBC and later 12.2S releases, and 12.3(14)T and later releases.


To summarize information about label bindings learned by LDP, use the show mpls ip binding summary command in user EXEC or privileged EXEC mode.

A request can specify that the entire database be displayed, that a summary of entries from the database be displayed, or that the display be limited to a subset of entries. The subset can be limited according to any of the following:

Prefix

Input or output label values or ranges

Neighbor advertising the label

Interface for label bindings of interest (LC-ATM only)


Note LC-ATM label binding interface does not apply to the Cisco 10000 series routers.


Generic (non-LC-ATM) label bindings

LC-ATM label bindings


Note LC-ATM label binding interface does not apply to the Cisco 10000 series routers.


Examples

The following is sample output from the show mpls ip binding command. The output shows all the label bindings in the database.

Router# show mpls ip binding 

  10.0.0.0/8 
        in label:     20        
        out label:    26        lsr: 10.0.0.55:0    
        out vc label: 1/80      lsr: 10.0.7.7:2      ATM1/0.8
                      Active    ingress 3 hops (vcd 49) 
  172.16.0.0/8 
        in label:     25        
        in vc label:  1/36      lsr: 10.0.7.7:2      ATM1/0.8
                      Active    egress (vcd 55) 
        out label:    imp-null  lsr: 10.0.0.55:0     inuse
  192.168.0.66/32 
        in label:     26        
        in vc label:  1/39      lsr: 10.0.7.7:2      ATM1/0.8
                      Active    egress (vcd 58) 
        out label:    16        lsr: 10.0.0.55:0     inuse
.
.
.

In the following example, a request is made for the display of the label binding information for prefix 192.168.44.0/24:

Router# show mpls ip binding 192.168.44.0 24

  192.168.44.0/24 
        in label:     24        
        in vc label:  1/37      lsr: 10.0.7.7:2      ATM1/0.8
                      Active    egress (vcd 56) 
        out label:    imp-null  lsr: 10.0.0.55:0     inuse
Router# 

In the following example, the local-label keyword is used to request that label binding information be displayed for the prefix with local label 58:

Router# show mpls ip binding local-label 58

  192.168.0.0/16 
        in label:     58        
        out label:    imp-null  lsr: 10.0.0.55:0     inuse
Router#

The following sample output shows the label bindings for the VPN routing and forwarding instance named vpn1:

Router# show mpls ip binding vrf vpn1

  10.3.0.0/16 
        in label:    117       
        out label:   imp-null  lsr:10.14.14.14:0   
  10.13.13.13/32 
        in label:    1372      
        out label:   268       lsr:10.14.14.14:0   
  10.14.14.14/32 
        in label:    118       
        out label:   imp-null  lsr:10.14.14.14:0   
  10.15.15.15/32 
        in label:    1370      
        out label:   266       lsr:10.14.14.14:0   
  10.16.16.16/32 
        in label:    8370      
        out label:   319       lsr:10.14.14.14:0   
  10.18.18.18/32 
        in label:    21817     
        out label:   571       lsr:10.14.14.14:0   
  30.2.0.0/16 
        in label:    6943      
        out label:   267       lsr:10.14.14.14:0   
  10.30.3.0/16 
        in label:    2383      
        out label:   imp-null  lsr:10.14.14.14:0   
  10.30.4.0/16 
        in label:    77        
        out label:   imp-null  lsr:10.14.14.14:0   
  10.30.5.0/16 
        in label:    20715     
        out label:   504       lsr:10.14.14.14:0   
  10.30.7.0/16 
        in label:    17        
        out label:   imp-null  lsr:10.14.14.14:0   
  10.30.10.0/16 
        in label:    5016      
        out label:   269       lsr:10.14.14.14:0   
  10.30.13.0/16 
        in label:    76        
        out label:   imp-null  lsr:10.14.14.14:0 

The following sample output shows label binding information for all VRFs:

Router# show mpls ip binding all     

  10.0.0.0/24 
        in label:     imp-null  
        out label:    imp-null  lsr: 10.131.0.1:0     
  10.11.0.0/24 
        in label:     imp-null  
        out label:    imp-null  lsr: 10.131.0.1:0 
  10.101.0.1/32 
        out label:    imp-null  lsr: 10.131.0.1:0 
  10.131.0.1/32 
        in label:     20        
        out label:    imp-null  lsr: 10.131.0.1:0      inuse
  10.134.0.1/32 
        in label:     imp-null  
        out label:    16        lsr: 10.131.0.1:0     
VRF vrf1:
  10.0.0.0/24 
        out label:    imp-null  lsr: 10.132.0.1:0     
  10.11.0.0/24 
        out label:    imp-null  lsr: 10.132.0.1:0     
  10.12.0.0/24 
        in label:     17        
        out label:    imp-null  lsr: 10.132.0.1:0     
  10.132.0.1/32 
        out label:    imp-null  lsr: 10.132.0.1:0     
  10.134.0.2/32 
        in label:     18        
        out label:    16        lsr: 10.132.0.1:0     
  10.134.0.4/32 
        in label:     19        
        out label:    17        lsr: 10.132.0.1:0     
  10.138.0.1/32 
        out label:    imp-null  lsr: 10.132.0.1:0

Cisco 10000 Series Examples Only

The following sample shows binding information for a Cisco 10000 series router:

Router# show mpls ip binding 

  0.0.0.0/0 
        in label:     imp-null  
  10.29.0.0/16 
        in label:     imp-null  
        out label:    imp-null  lsr: 10.66.66.66:0   
        out label:    imp-null  lsr: 10.44.44.44:0   
  10.20.0.0/24 
        in label:     imp-null  
        out label:    26        lsr: 10.66.66.66:0   
        out label:    imp-null  lsr: 10.44.44.44:0   
  10.30.0.0/24 
        in label:     imp-null  
        out label:    imp-null  lsr: 10.66.66.66:0   
        out label:    18        lsr: 10.44.44.44:0   
  10.44.44.44/32 
        in label:     21        
        out label:    19        lsr: 10.66.66.66:0   
        in label:     imp-null  
        out label:    26        lsr: 10.66.66.66:0   
        out label:    imp-null  lsr: 10.44.44.44:0   
  10.30.0.0/24 
        in label:     imp-null  
        out label:    imp-null  lsr: 10.66.66.66:0   
        out label:    18        lsr: 10.44.44.44:0   
  10.44.44.44/32 
        in label:     21        
        out label:    19        lsr: 10.66.66.66:0   
        out label:    imp-null  lsr: 10.44.44.44:0    inuse
  10.55.55.55/32 
        in label:     imp-null  
        out label:    25        lsr: 10.66.66.66:0   
        out label:    55        lsr: 10.44.44.44:0   
  10.66.66.66/32 
        in label:     18        
        out label:    imp-null  lsr: 10.66.66.66:0    inuse
        out label:    16        lsr: 10.44.44.44:0   
  10.255.254.244/32 
        in label:     24        
        out label:    16        lsr: 10.66.66.66:0   
        out label:    59        lsr: 10.44.44.44:0   

In the following example on a Cisco 10000 series router, a request is made for the display of the label binding information for prefix 172.16.44.44/32:

Router# show mpls ip binding 172.16.44.44 32

  172.16.44.44/32 
        in label:     21        
        out label:    19        lsr: 10.66.66.66:0   
        out label:    imp-null  lsr: 10.44.44.44:0    inuse

In the following example on a Cisco 10000 series router, the local-label keyword is used to request that label binding information be displayed for the prefix with local label 21:

Router# show mpls ip binding local-label 21

  10.44.44.44/32 
        in label:     21

Table 2 describes the significant fields shown in the displays.

Table 2 show mpls ip binding Field Descriptions 

Field
Description

172.16.44.44/32

Destination prefix. Indicates that the following lines are for a particular destination (network/mask).

in label

Incoming label. This is the local label assigned by the label switch router (LSR) and advertised to other LSRs. The label value imp-null indicates the well-known Implicit NULL label.

out label

Outgoing label. This is a remote label learned from an LDP neighbor. The neighbor is identified by its LDP ID in the lsr field.

inuse

Indicates that the outgoing label is in use for Multiprotocol Label Switching (MPLS) forwarding, that is, it is installed in the MPLS forwarding table (the Label Forwarding Information Base [LFIB]).

in vc label

Incoming MPLS ATM label. This is the local VPI/VCI assigned by the LSR as the incoming label for the destination and advertised to the upstream LSRs.

Note This field applies to the Cisco 7000 series routers only.

out vc label

Outgoing MPLS ATM label. This is the VPI/VCI learned from the destination next hop as its label for the destination and advertised to this LSR.

Note This field applies to the Cisco 7000 series routers only.

ATM1/0.8

The ATM interface with which the MPLS ATM label is associated.

Note This field applies to the Cisco 7000 series routers only.

Active

State of the label VC (LVC) associated with the destination prefix.

Note This field applies to the Cisco 7000 series routers only.

States are the following:

Active. Established and operational.

Bindwait. Waiting for a response from the destination next hop.

Remote Resource Wait. Waiting for resources (VPI/VCI) to become available on the destination next hop.

Parent Wait. Transit LVC upstream side waiting for downstream side to become active.

AbortAckWait. Waiting for response to a Label Abort message sent to the destination next hop.

ReleaseWait. Waiting for response to a Label Withdraw message sent to an upstream neighbor.

vcd 49

Virtual circuit descriptor number for the LVC.

Note This field applies to the Cisco 7000 series routers only.

ingress 3 hops

Indicates whether the LSR is an ingress, transit, or egress node for the destination.

Note This field applies to the Cisco 7000 series routers only.

Options include the following:

Ingress 3 hops. The LSR is an ingress edge router for the MPLS ATM cloud for the destination.

Egress. The LSR is an egress edge router for the MPLS ATM cloud for the destination.

Transit. The LSR is a transit LSR within the MPLS ATM cloud for the destination.


The following sample output displays detailed information about the label bindings:

Router# show mpls ip binding detail 

  10.0.0.0/8, rev 2, chkpt: add-skipped
        in label:     imp-null   (owner LDP)
          Advertised to:
          10.60.60.60:0          10.30.30.30:0          
        out label:    imp-null  lsr: 10.60.60.60:0   
        out label:    imp-null  lsr: 10.30.30.30:0   
  10.10.10.10/32, rev 18, chkpt: added
        in label:     17         (owner LDP)
          Advertised to:
          10.60.60.60:0          10.30.30.30:0          
        out label:    142       lsr: 10.60.60.60:0   
        out label:    19        lsr: 10.30.30.30:0    inuse
  10.0.0.1/32, rev 10, chkpt: add-skipped
        in label:     imp-null   (owner LDP)
          Advertised to:
          10.60.60.60:0          10.30.30.30:0          
        out label:    21        lsr: 10.60.60.60:0   
        out label:    17        lsr: 10.30.30.30:0   
  10.30.30.30/32, rev 20, chkpt: added
        in label:     18         (owner LDP)
          Advertised to:
          10.60.60.60:0          10.30.30.30:0          
        out label:    22        lsr: 10.60.60.60:0   

Table 3 describes the significant fields shown in the display.

Table 3 show mpls ip binding detail Field Descriptions 

Field
Description

chkpt

The status of the checkpointed entry.

add-skipped—Means that the local label is a null label and does not need to be checkpointed.

added— Means that the checkpoints entry was copied to the backup Route Processor (RP)

owner

The application that created the binding.

owner LDP—Means that LDP created the binding.

owner other—Means that another application created the binding, possibly Border Gateway protocol (BGP).

Advertised to

The LSRs that received the local label binding.

inuse or stale

The status of the label.

inuse—Indicates that the outgoing label is in use for MPLS forwarding, that is, it is installed in the MPLS forwarding table (LFIB).

stale—Indicates a label that is no longer in use. This happens when an LDP session is lost and the routers begin a graceful restart. Then the remote label bindings are marked stale.


Cisco 7000 Series Example Only

The following sample output shows summary information about the label bindings learned by LDP:

Router# show mpls ip binding summary 

Total number of prefixes: 53
 
Generic label bindings
                      assigned        learned
       prefixes      in labels     out labels
             53             53             51
 
ATM label bindings summary
      interface   total  active   local  remote   Bwait   Rwait  IFwait
       ATM1/0.8      47      47      40       7       0       0       0
Router#

Table 4 describes the significant fields shown in the display.

Table 4 show mpls ip binding summary Field Descriptions (Cisco 7000 Series Example) 

Field
Description

Total number of prefixes

Number of destinations for which the LSR has label bindings.

Generic label bindings

Indicates the start of summary information for "generic" label bindings. Generic labels are used for MPLS forwarding on all interface types except MPLS ATM interfaces.

prefixes

Number of destinations for which the LSR has a generic label binding.

assigned in labels

Number of prefixes for which the LSR has assigned an incoming (local) label.

learned out labels

Number of prefixes for which the LSR has learned an outgoing (remote) label from an LDP neighbor.

ATM label bindings summary

Indicates the start of summary information for MPLS ATM label bindings. An ATM label is a VPI/VCI.

interface

Indicates a row in the ATM label bindings summary table. The summary information in the row is for ATM labels associated with this interface.

total

Total number of ATM labels associated with the interface.

active

Number of ATM labels (LVCs) in the active (operational) state.

local

Number of ATM labels assigned by this LSR for the interfaces. These are incoming labels.

remote

Number of ATM labels learned from the neighbor LSR for this interface. These are outgoing labels.

Bwait

Number of bindings (LVCs) waiting for a label assignment from the neighbor LSR for the interface.

Rwait

Number of bindings (LVCs) waiting for resources (VPI/VCIs) to become available on the neighbor LSR for the interface.

IFwait

Number of bindings (LVCs) waiting for labels to be installed for switching use.


Cisco 10000 Series Example Only

The following sample output displays summary information about the label bindings learned by LDP:

Router# show mpls ip binding summary 

Total number of prefixes: 53
 
Generic label bindings
                      assigned        learned
       prefixes      in labels     out labels
             53             53             51

Table 5 describes the significant fields shown in the display.

Table 5 show mpls ip binding summary Field Descriptions (Cisco 10000 Series Example) 

Field
Description

Total number of prefixes

Number of destinations for which the LSR has label bindings.

Generic label bindings

Indicates the start of summary information for "generic" label bindings. Generic labels are used for MPLS forwarding on all interface types except MPLS ATM interfaces.

prefixes

Number of destinations for which the LSR has a generic label binding.

assigned in labels

Number of prefixes for which the LSR has assigned an incoming (local) label.

learned out labels

Number of prefixes for which the LSR has learned an outgoing (remote) label from an LDP neighbor.


Related Commands

Command
Description

show mpls atm-ldp bindings

Displays specified entries from the ATM label binding database.

show mpls ldp bindings

Displays the contents of the LIB.


show mpls ldp bindings

To display the contents of the Label Information Base (LIB), use the show mpls ldp bindings command in user EXEC or privileged EXEC mode:

show mpls ldp bindings [vrf vrf-name | all] [network {mask | length} [longer-prefixes]]
[
local-label label  [- label]] [remote-label label [- label]] [neighbor address | local] [detail]

Syntax Description

vrf vrf-name

(Optional) Displays the label bindings for the specified Virtual Private Network (VPN) routing and forwarding (VRF) instance (vrf-name).

all

(Optional) Displays LIB information for all VPNs.

network

(Optional) Defines the destination network number.

mask

(Optional) Specifies the network mask, written as A.B.C.D.

length

(Optional) Specifies the mask length (1 to 32 characters).

longer-prefixes

(Optional) Selects any prefix that matches mask with a length from 1 to 32 characters.

local-label label - label

(Optional) Display entries matching local label values. Use the labellabel arguments and keyword to indicate the label range. The hyphen (-) keyword is required for a label range.

remote-label label label

(Optional) Displays entries matching the label values assigned by a neighbor router. Use the label label arguments and keyword to indicate the label range. The hyphen (-) keyword is required for a label range.

neighbor address

(Optional) Displays the label bindings assigned by the selected neighbor.

local

(Optional) Displays the local label bindings.

detail

(Optional) Displays the checkpoint status of the local label bindings.


Defaults

If no optional keywords or arguments are supplied, the command displays the LIB for the default routing domain only.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

11.1CT

This command was introduced.

12.0(10)ST

This command was modified to reflect Multiprotocol Label Switching (MPLS) Internet Engineering Task Force (IETF) command syntax and terminology.

12.0(14)ST

This command was modified to reflect MPLS Virtual Private Network (VPN) support for Label Distribution Protocol (LDP).

12.1(2)T

This command was integrated into Cisco IOS Release 12.1(2)T.

12.1(8a)E

This command was integrated into Cisco IOS Release 12.1(8a)E.

12.2(2)T

This command was integrated into Cisco IOS Release 12.2(2)T.

12.2(4)T

This command was integrated into Cisco IOS Release 12.2(4)T.

12.2(8)T

This command was integrated into Cisco IOS Release 12.2(8)T.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.

12.0(23)S

This command was integrated into Cisco IOS Release 12.0(23)S.

12.2(13)T

This command was integrated into Cisco IOS Release 12.2(13)T.

12.2(14)S

This command was integrated into Cisco IOS Release 12.2(14)S.

12.2(25)S

The detail keyword was added.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

The show mpls ldp bindings command displays label bindings learned by the LDP or Tag Distribution Protocol (TDP).


Note TDP is not supported for LDP features in Cisco IOS 12.0(30)S and later releases, 12.2(27)SBC and later 12.2S releases, and 12.3(14)T and later releases.


A request can specify that the entire database be displayed, or that the display be limited to a subset of entries according to the following:

Prefix

Input or output label values or ranges

Neighbor advertising the label


Note The show mpls ip binding command includes the output generated by the show mpls ldp bindings command. On the Cisco 7000 series router, this command displays information about label bindings for LC-ATM interfaces.


Examples

The following is sample output from the show mpls ldp bindings command. This form of the command displays the contents of the LIB for the default routing domain.

Router# show mpls ldp bindings

  10.0.0.0/8, rev 9
        local binding:  label: imp-null
        remote binding: lsr: 10.10.0.55:0, label: 17
        remote binding: lsr: 10.66.0.66:0, label: 18
        remote binding: lsr: 10.0.0.44:0, label: imp-null
  172.16.0.0/8, rev 17
        local binding:  label: 19
        remote binding: lsr: 10.0.0.55:0, label: imp-null
        remote binding: lsr: 10.66.0.66:0, label: 16
        remote binding: lsr: 10.0.0.44:0, label: imp-null
  192.168.0.66/32, rev 19
        local binding:  label: 20
        remote binding: lsr: 10.0.0.55:0, label: 19
        remote binding: lsr: 10.66.0.66:0, label: imp-null
        remote binding: lsr: 10.0.0.44:0, label: 18
.
.
.

The following is sample output from the show mpls ldp bindings network length longer-prefixes neighbor address variant of the command; it displays labels learned from label switch router (LSR) 10.144.0.44 for network 10.166.0.0 and any of its subnets. The use of the neighbor keyword suppresses the output of local labels and labels learned from other neighbors.

Router# show mpls ldp bindings 10.166.0.0 8 longer-prefixes neighbor 10.144.0.44

  10.166.44.0/16, rev 31
        remote binding: lsr: 10.144.0.44:0, label: 25
  10.166.45.0/16, rev 33
        remote binding: lsr: 10.144.0.44:0, label: 26
  10.166.245.0/16, rev 71
        remote binding: lsr: 10.144.0.44:0, label: 45
  10.166.246.0/16, rev 73
        remote binding: lsr: 10.144.0.44:0, label: 46
. 
. 
.

The following is sample output from the show mpls ldp bindings vrf vpn1 command, which displays the label bindings for the specified VPN routing and forwarding instance named vpn1:

Router# show mpls ldp bindings vrf vpn1

  10.3.3.0/16, rev 164
        local binding: label:117
        remote binding:lsr:10.14.14.14:0, label:imp-null
  10.13.13.13/32, rev 1650
        local binding: label:1372
        remote binding:lsr:10.14.14.14:0, label:268
  10.14.14.14/32, rev 165
        local binding: label:118
        remote binding:lsr:10.14.14.14:0, label:imp-null
  10.15.15.15/32, rev 1683
        local binding: label:1370
        remote binding:lsr:10.14.14.14:0, label:266
  10.16.16.16/32, rev 775
        local binding: label:8370
        remote binding:lsr:10.14.14.14:0, label:319
  10.18.18.18/32, rev 1655
        local binding: label:21817
        remote binding:lsr:10.14.14.14:0, label:571
  10.30.2.0/16, rev 1653
        local binding: label:6943
        remote binding:lsr:10.14.14.14:0, label:267
  10.30.3.0/16, rev 413
        local binding: label:2383
        remote binding:lsr:10.14.14.14:0, label:imp-null
  10.30.4.0/16, rev 166
        local binding: label:77
        remote binding:lsr:10.14.14.14:0, label:imp-null
  10.30.5.0/16, rev 1429
        local binding: label:20715
        remote binding:lsr:10.14.14.14:0, label:504
  10.30.7.0/16, rev 4
        local binding: label:17
        remote binding:lsr:10.14.14.14:0, label:imp-null
  10.30.10.0/16, rev 422
        local binding: label:5016
        remote binding:lsr:10.14.14.14:0, label:269
. 
. 
. 

The following is sample output from the show mpls ldp bindings all command, which displays the label bindings for all VRFs:

Router# show mpls ldp bindings all 
   
  lib entry: 10.0.0.0/24, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 10.131.0.1:0, label: imp-null
  lib entry: 10.11.0.0/24, rev 15
        local binding:  label: imp-null
        remote binding: lsr: 10.131.0.1:0, label: imp-null
  lib entry: 10.101.0.1/32, rev 18
        remote binding: lsr: 10.131.0.1:0, label: imp-null
  lib entry: 10.131.0.1/32, rev 17
        local binding:  label: 20
        remote binding: lsr: 10.131.0.1:0, label: imp-null
  lib entry: 10.134.0.1/32, rev 6
        local binding:  label: imp-null
        remote binding: lsr: 10.131.0.1:0, label: 16
VRF vrf1:
  lib entry: 10.0.0.0/24, rev 6
        remote binding: lsr: 10.132.0.1:0, label: imp-null
  lib entry: 10.11.0.0/24, rev 7
        remote binding: lsr: 10.132.0.1:0, label: imp-null
  lib entry: 10.12.0.0/24, rev 8
        local binding:  label: 17
        remote binding: lsr: 10.132.0.1:0, label: imp-null
  lib entry: 10.132.0.1/32, rev 4
        remote binding: lsr: 10.132.0.1:0, label: imp-null
  lib entry: 10.134.0.2/32, rev 9
        local binding:  label: 18
        remote binding: lsr: 10.132.0.1:0, label: 16
  lib entry: 10.134.0.4/32, rev 10
        local binding:  label: 19
        remote binding: lsr: 10.132.0.1:0, label: 17
  lib entry: 10.138.0.1/32, rev 5
        remote binding: lsr: 10.132.0.1:0, label: imp-null

The following is sample output from the show mpls ldp bindings detail command:

Router# show mpls ldp bindings detail

lib entry: 10.3.3.0/16, rev 2, 
        local binding:  label: imp-null
          Advertised to:
          10.20.20.20:0          10.25.25.25:0          
        remote binding: lsr: 10.20.20.20:0, label: imp-null  stale
        remote binding: lsr: 10.25.25.25:0, label: imp-null  stale
  lib entry: 10.13.1.0/24, rev 4, 
        local binding:  label: imp-null
          Advertised to:
          10.20.20.20:0          10.25.25.25:0          
        remote binding: lsr: 10.20.20.20:0, label: imp-null  stale
        remote binding: lsr: 10.25.25.25:0, label: 16  stale
  lib entry: 10.13.2.0/24, rev 6, 
        local binding:  label: imp-null
          Advertised to:
          10.20.20.20:0          10.25.25.25:0          
        remote binding: lsr: 10.20.20.20:0, label: 16  stale
        remote binding: lsr: 10.25.25.25:0, label: imp-null  stale
  lib entry: 10.6.1.0/24, rev 22, 
        local binding:  label: 21
          Advertised to:
          10.20.20.20:0          10.25.25.25:0          
        remote binding: lsr: 10.20.20.20:0, label: 19  stale
        remote binding: lsr: 10.25.25.25:0, label: imp-null  stale

Table 6 describes the significant fields shown in the display.

Table 6 show mpls ldp bindings Field Descriptions 

Field
Description

10.3.3.0/16

IP prefix and mask for a particular destination (network/mask).

rev 9

Revision number that is used internally to manage label distribution for this destination.

Advertised to

The LSRs that received the label binding.

local binding

Labels assigned by the local LSR.

remote binding

List of outgoing labels for this destination learned from other LSRs. Each item in this list identifies the LSR from which the outgoing label was learned and the label itself. The LSR is identified by its LDP identifier.

stale

After an LDP session is lost and the routers begin a graceful restart, the remote label bindings are marked stale.


Related Commands

Command
Description

show mpls ip binding

Displays specified information about label bindings learned by the MPLS LDP.

show mpls ldp neighbor

Displays the status of LDP sessions.


show mpls ldp graceful-restart

To display a summary of the Label Distribution Protocol (LDP) Graceful Restart status, use the show mpls ldp graceful-restart command in user EXEC or privileged EXEC mode.

show mpls ldp graceful-restart

Syntax Description

This command has no arguments or keywords.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

12.0(29)S

This command was introduced.

12.2(25)S

This command was integrated into Cisco IOS Release 12.2(25)S.

12.3(14)T

This command was integrated into Cisco IOS Release 12.3(14)T.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

This command shows the following information about LDP sessions:

Configured parameters.

The state of the LDP sessions (for which Graceful Restart was negotiated during initialization).

The list of LDP sessions for which graceful recovery is pending. However, the router has retained the state information from those neighbors.

Examples

The following example shows a summary of the LDP Graceful Restart settings and configuration:

Router# show mpls ldp graceful-restart

LDP Graceful Restart is enabled
Neighbor Liveness Timer: 5 seconds
Max Recovery Time: 200 seconds
Down Neighbor Database (0 records):
Graceful Restart-enabled Sessions:
VRF default:
    Peer LDP Ident: 10.18.18.18:0, State: estab
    Peer LDP Ident: 10.17.17.17:0, State: estab

Table 7 describes the significant fields shown in the display.

Table 7 show mpls ldp graceful-restart Field Descriptions 

Field
Description

Neighbor Liveness Timer

The number of seconds the neighbor liveness timer is set for.

Max Recovery Time

The number of seconds the maximum recovery timer is set for.

Down Neighbor Database

Information about the down (failed or restarting) LDP neighbor.

Graceful Restart-enabled Sessions

Information about the LDP sessions that are enabled for Graceful Restart.

Peer LDP Ident

The LDP ID of the provider edge (PE) neighbor.

State

The state of the session with the neighbor.


Related Commands

Command
Description

show mpls ldp neighbor

Displays the status of LDP sessions.


show mpls ldp neighbor

To display the status of Label Distribution Protocol (LDP) sessions, use the show mpls ldp neighbor command in user EXEC or privileged EXEC mode.

show mpls ldp neighbor [all | vrf vrf-name] [address | interface] [detail] [graceful-restart]

Syntax Description

all

(Optional) Displays LDP neighbor information for all VPNs, including those in the default routing domain.

vrf vrf-name

(Optional) Displays the LDP neighbors for the specified Virtual Private Network (VPN) routing and forwarding (VRF) instance (vrf-name).

address

(Optional) Identifies the neighbor with this IP address.

interface

(Optional) Defines the LDP neighbors accessible over this interface.

detail

(Optional) Displays information in long form.

graceful-restart

(Optional) Displays per-neighbor graceful restart information.


Defaults

This command displays information about LDP neighbors for the default routing domain if an optional vrf keyword is not specified.

Command Modes

User EXEC
Privileged EXEC

Command History

Release
Modification

11.1CT

This command was introduced.

12.0(10)ST

This command was integrated into Cisco IOS Release 12.0(10)ST. The command was modified to reflect Multiprotocol Label Switching (MPLS) Internet Engineering Task Force (IETF) command syntax and terminology.

12.0(14)ST

This command was modified to reflect MPLS VPN support for LDP. The vrf and all keywords were added.

12.1(8a)E

This command was integrated into Cisco IOS Release 12.1(8a)E.

12.2(2)T

This command was integrated into Cisco IOS Release 12.2(2)T.

12.2(8)T

This command was modified to reflect MPLS VPN support for LDP. The vrf and all keywords were added.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.

12.2(13)T

This command was integrated into Cisco IOS Release 12.2(13)T.

12.2(14)S

This command was integrated into Cisco IOS Release 12.2(14)S.

12.0(26)S

The detail keyword was updated to display information about inbound filtering.

12.2(25)S

The graceful-restart keyword was added.

12.3(14)T

The command output was updated so that the detail keyword displays information about MPLS LDP Session Protection.

12.2(18)SXE

This command was integrated into the Cisco IOS Release 12.2(18)SXE.

12.2(28)SB

The detail keyword was updated to include Message Digest 5 (MD5) password information and the command was implemented on the Cisco 10000 series routers for Cisco IOS Release 12.2(28)SB.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.


Usage Guidelines

The show mpls ldp neighbor command can provide information about all LDP neighbors, or the information can be limited to the following:

Neighbor with specific IP address

LDP neighbors known to be accessible over a specific interface


Note This command displays information about LDP and Tag Distribution Protocol (TDP) neighbor sessions.


Examples

The following is sample output from the show mpls ldp neighbor command:

Router# show mpls ldp neighbor

Peer LDP Ident: 10.0.7.7:2; Local LDP Ident 10.1.1.1:1
        TCP connection: 10.0.7.7.11032 - 10.1.1.1.646
        State: Oper; Msgs sent/rcvd: 5855/6371; Downstream on demand
        Up time: 13:15:09
        LDP discovery sources:
          ATM3/0.1
Peer LDP Ident: 10.1.1.1:0; Local LDP Ident 10.1.1.1:0
        TCP connection: 10.1.1.1.646 - 10.1.1.1.11006
        State: Oper; Msgs sent/rcvd: 4/411; Downstream
        Up time: 00:00:52
        LDP discovery sources:
          Ethernet1/0/0
        Addresses bound to peer LDP Ident:
          10.0.0.29        10.1.1.1         10.0.0.199      10.10.1.1
          10.205.0.9      

The following is sample output from the show mpls ldp neighbor vrf vpn10 command, which displays the LDP neighbor information for the specified VPN routing and forwarding instance named vpn10:

Router# show mpls ldp neighbor vrf vpn10

Peer LDP Ident:10.14.14.14:0; Local LDP Ident 10.29.0.2:0
        TCP connection:10.14.14.14.646 - 10.29.0.2.11384
        State:Oper; Msgs sent/rcvd:1423/800; Downstream
        Up time:02:38:11
        LDP discovery sources:
          ATM3/0/0.10
        Addresses bound to peer LDP Ident:
          10.3.36.9       10.7.0.1        10.14.14.14     10.13.0.1       
          10.15.0.1       10.17.0.1       10.19.0.1       10.21.0.1       
          10.23.0.1       10.25.0.1       10.27.0.1       10.29.0.1       
          10.31.0.1       10.33.0.1       10.35.0.1       10.37.0.1       
          10.39.0.1       10.41.0.1       10.43.0.1       10.45.0.1       
          10.47.0.1       10.49.0.1       10.51.0.1       10.53.0.1       
          10.55.0.1       10.57.0.1       10.59.0.1       10.61.0.1       
          10.63.0.1       10.65.0.1       10.67.0.1       10.69.0.1       
          10.71.0.1       10.73.0.1       10.75.0.1       10.77.0.1       
          10.79.0.1       10.81.0.1       10.83.0.1       10.85.0.1       
          10.87.0.1       10.89.0.1       10.91.0.1       10.93.0.1       
          10.95.0.1       10.97.0.1       10.99.0.1       10.101.0.1      
          10.103.0.1      10.105.0.1      10.107.0.1      10.109.0.1      
          10.4.0.2        10.3.0.2        
Router#

The following is sample output from the show mpls ldp neighbor all command, which displays the LDP neighbor information for all VPN routing and forwarding instances, including those in the default routing domain. In this example, note that the same neighbor LDP ID (10.14.14.14) appears in all the listed VRF interfaces, highlighting the fact that the same IP address can coexist in different VPN routing and forwarding instances.

Router# show mpls ldp neighbor all 

Peer TDP Ident:10.11.11.11:0; Local TDP Ident 10.12.12.12:0
        TCP connection:10.11.11.11.711 - 10.12.12.12.11003
        State:Oper; PIEs sent/rcvd:185/187; Downstream
        Up time:02:40:02
        TDP discovery sources:
          ATM1/1/0.1
        Addresses bound to peer TDP Ident:
          10.3.38.3        10.1.0.2        10.11.11.11     
VRF vpn1:
    Peer LDP Ident:10.14.14.14:0; Local LDP Ident 10.7.0.2:0
        TCP connection:10.14.14.14.646 - 10.7.0.2.11359
        State:Oper; Msgs sent/rcvd:952/801; Downstream
        Up time:02:38:49
        LDP discovery sources:
          ATM3/0/0.1
        Addresses bound to peer LDP Ident:
          10.3.36.9       10.7.0.1        10.14.14.14     10.13.0.1       
          10.15.0.1       10.17.0.1       10.19.0.1       10.21.0.1       
          10.23.0.1       10.25.0.1       10.27.0.1       10.29.0.1       
          10.31.0.1       10.33.0.1       10.35.0.1       10.37.0.1       
          10.39.0.1       10.41.0.1       10.43.0.1       10.45.0.1       
          10.47.0.1       10.49.0.1       10.51.0.1       10.53.0.1       
          10.55.0.1       10.57.0.1       10.59.0.1       10.61.0.1       
          10.63.0.1       10.65.0.1       10.67.0.1       10.69.0.1       
          10.71.0.1       10.73.0.1       10.75.0.1       10.77.0.1       
          10.79.0.1       10.81.0.1       10.83.0.1       10.85.0.1       
          10.87.0.1       10.89.0.1       10.91.0.1       10.93.0.1       
          10.95.0.1       10.97.0.1       10.99.0.1       10.101.0.1      
          10.103.0.1      10.105.0.1      10.107.0.1      10.109.0.1      
          10.4.0.2        10.3.0.2        
VRF vpn2:
    Peer LDP Ident:10.14.14.14:0; Local LDP Ident 10.13.0.2:0
        TCP connection:10.14.14.14.646 - 10.13.0.2.11361
        State:Oper; Msgs sent/rcvd:964/803; Downstream
        Up time:02:38:50
        LDP discovery sources:
          ATM3/0/0.2
        Addresses bound to peer LDP Ident:
          10.3.36.9       10.7.0.1        10.14.14.14     10.13.0.1       
          10.15.0.1       10.17.0.1       10.19.0.1       10.21.0.1       
          10.23.0.1       10.25.0.1       10.27.0.1       10.29.0.1       
          10.31.0.1       10.33.0.1       10.35.0.1       10.37.0.1       
          10.39.0.1       10.41.0.1       10.43.0.1       10.45.0.1       
          10.47.0.1       10.49.0.1       10.51.0.1       10.53.0.1       
          10.55.0.1       10.57.0.1       10.59.0.1       10.61.0.1       
          10.63.0.1       10.65.0.1       10.67.0.1       10.69.0.1       
          10.71.0.1       10.73.0.1       10.75.0.1       10.77.0.1       
          10.79.0.1       10.81.0.1       10.83.0.1       10.85.0.1       
          10.87.0.1       10.89.0.1       10.91.0.1       10.93.0.1       
          10.95.0.1       10.97.0.1       10.99.0.1       10.101.0.1      
          10.103.0.1      10.105.0.1      10.107.0.1      10.109.0.1      
          10.4.0.2        10.3.0.2        
VRF vpn3:
    Peer LDP Ident:10.14.14.14:0; Local LDP Ident 10.15.0.2:0
        TCP connection:10.14.14.14.646 - 10.15.0.2.11364
        State:Oper; Msgs sent/rcvd:1069/800; Downstream
        Up time:02:38:52
        LDP discovery sources:
          ATM3/0/0.3
        Addresses bound to peer LDP Ident:
          10.3.36.9       10.17.0.1       10.14.14.14     10.13.0.1       
          10.15.0.1       10.17.0.1       10.19.0.1       10.21.0.1       
          10.23.0.1       10.25.0.1       10.27.0.1       10.29.0.1       
          10.31.0.1       10.33.0.1       10.35.0.1       10.37.0.1       
          10.39.0.1       10.41.0.1       10.43.0.1       10.45.0.1       
          10.47.0.1       10.49.0.1       10.51.0.1       10.53.0.1       
          10.55.0.1       10.57.0.1       10.59.0.1       10.61.0.1       
          10.63.0.1       10.65.0.1       10.67.0.1       10.69.0.1       
          10.71.0.1       10.73.0.1       10.75.0.1       10.77.0.1       
          10.79.0.1       10.81.0.1       10.83.0.1       10.85.0.1       
          10.87.0.1       10.89.0.1       10.91.0.1       10.93.0.1       
          10.95.0.1       10.97.0.1       10.99.0.1       10.101.0.1      
          10.103.0.1      10.105.0.1      10.107.0.1      10.109.0.1      
          10.4.0.2        10.3.0.2 
VRF vpn4:
    Peer LDP Ident:10.14.14.14:0; Local LDP Ident 10.17.0.2:0
        TCP connection:10.14.14.14.646 - 10.17.0.2.11366
        State:Oper; Msgs sent/rcvd:1199/802; Downstream
          
Router#

The following example shows the Graceful Restart status of the LDP neighbors:

Router# show mpls ldp neighbor graceful-restart

Peer LDP Ident: 10.20.20.20:0; Local LDP Ident 10.17.17.17:0
   TCP connection: 10.20.20.20.16510 - 10.17.17.17.646
    State: Oper; Msgs sent/rcvd: 8/18; Downstream
    Up time: 00:04:39
    Graceful Restart enabled; Peer reconnect time (msecs): 120000
Peer LDP Ident: 10.19.19.19:0; Local LDP Ident 10.17.17.17:0
    TCP connection: 10.19.19.19.11007 - 10.17.17.17.646
    State: Oper; Msgs sent/rcvd: 8/38; Downstream
    Up time: 00:04:30
    Graceful Restart enabled; Peer reconnect time (msecs): 120000

The following sample output from the show mpls ldp neighbor detail command displays information about the MD5 password configuration:

Router# show mpls ldp neighbor detail

    Peer LDP Ident: 10.3.3:0; Local LDP Ident 10.1.1.1:0
        TCP connection: 10.3.3.3.11018 - 10.1.1.1.646
        Password: required, neighbor, in use
        State: Oper; Msgs sent/rcvd: 167/167; Downstream; Last TIB rev sent 9
        Up time: 02:24:02; UID: 5; Peer Id 3;
        LDP discovery sources:
          Targeted Hello 10.1.1.1 -> 10.3.3.3, passive;
            holdtime: 90000 ms, hello interval: 10000 ms
        Addresses bound to peer LDP Ident:
          10.3.3.3         10.0.30.3       
        Peer holdtime: 180000 ms; KA interval: 60000 ms; Peer state: estab
    Peer LDP Ident: 10.4.4.4:0; Local LDP Ident 10.1.1.1:0
        TCP connection: 10.4.4.4.11017 - 10.1.1.1.646
        Password: not required, none, stale
        State: Oper; Msgs sent/rcvd: 9/9; Downstream; Last TIB rev sent 9
        Up time: 00:05:35; UID: 6; Peer Id 1;
        LDP discovery sources:
          Ethernet1/0; Src IP addr: 10.0.20.4 
            holdtime: 15000 ms, hello interval: 5000 ms
        Addresses bound to peer LDP Ident:
          10.0.40.4       10.4.4.4         10.0.20.4       
        Peer holdtime: 180000 ms; KA interval: 60000 ms; Peer state: estab

Table 8 describes the significant fields shown in the displays.

Table 8 show mpls ldp neighbor Field Descriptions 

Field
Description

Peer LDP Ident

LDP identifier of the neighbor (peer) for this session.

Local LDP Ident

LDP identifier for the local label switch router (LSR) for this session.

TCP connection

TCP connection used to support the LDP session, shown in the following format:

peer IP address.peer port

local IP address.local port

State

State of the LDP session. Generally this is Oper (operational), but transient is another possible state.

Msgs sent/rcvd

Number of LDP messages sent to and received from the session peer. The count includes the transmission and receipt of periodic keepalive messages, which are required for maintenance of the LDP session.

Downstream on demand

Indicates that the Downstream on Demand method of label distribution is being used for this LDP session. When the Downstream on Demand method is used, an LSR advertises its locally assigned (incoming) labels to its LDP peer only when the peer requests them.

Downstream

Indicates that the downstream method of label distribution is being used for this LDP session. When the downstream method is used, an LSR advertises all of its locally assigned (incoming) labels to its LDP peer (subject to any configured access list restrictions).

Up time

Length of time (in hours, minutes, seconds) the LDP session has existed.

LDP discovery sources

Sources of LDP discovery activity that led to the establishment of this LDP session.

Addresses bound to peer LDP Ident

Known interface addresses of the LDP session peer. These are addresses that might appear as "next hop" addresses in the local routing table. They are used to maintain the Label Forwarding Information Base (LFIB).


Related Commands

Command
Description

show mpls ldp discovery

Displays the status of the LDP discovery process.