Guest

Cisco IOS Software Releases 12.0 S

MPLS VPN—Carrier Supporting Carrier

  • Viewing Options

  • PDF (637.7 KB)
  • Feedback
MPLS VPN—Carrier Supporting Carrier

Table Of Contents

MPLS VPN—Carrier Supporting Carrier

Feature Overview

Providing a Backbone Network to an ISP Customer Carrier

Establishing a Route Between the Backbone Carrier and the Customer Carrier Who Is an ISP

Transporting a Packet Through a Network of a Backbone Carrier and Customer Carrier Who Is an ISP

Providing a Backbone Network to a Customer Carrier Who Is a BGP/MPLS VPN Service Provider

Establishing a Route Between the Backbone Carrier and the Customer Carrier Who Is an MPLS VPN Service Provider

Transporting a Packet Through a Network of a Backbone Carrier and Customer Carrier Who Is an MPLS VPN Service Provider

Benefits

Requirements

Related Features and Technologies

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring the Backbone Carrier PE Router

Configuring the Customer Carrier CE Routers

Verifying the Carrier Supporting Carrier Configuration

Configuration Examples

Configuring a Carrier Supporting Carrier Network with a Customer Who Is an ISP

CSC-CE1 Configuration

CSC-PE1 Configuration

CSC-PE2 Configuration

CSC-CE2 Configuration

Configuring a Carrier Supporting Carrier Network with a Customer Who Is an MPLS VPN Provider

CE1 Configuration

PE1 Configuration

CSC-CE1 Configuration

CSC-PE1 Configuration

CSC-PE2 Configuration

CSC-CE2 Configuration

PE2 Configuration

CE2 Configuration

Configuring a Carrier Supporting Carrier Network That Contains Route Reflectors

Backbone Carrier Configuration

Customer Carrier Site 1 Configuration

Customer Carrier Site 2 Configuration

Configuring a Carrier Supporting Carrier Network with a Customer Who Has VPNs at the Network's Edge

Backbone Carrier Configuration

Customer Carrier Site 1 Configuration

Customer Carrier Site 2 Configuration

Command Reference

Glossary


MPLS VPN—Carrier Supporting Carrier


Feature History

Release
Modification

12.0(14)ST

This feature was introduced in Cisco IOS Release 12.0(14)ST.

12.0(16)ST

Support for the Cisco 12000 series routers (Engine 0) for the Cisco IOS 12.0 ST release was added.

12.2(8)T

This feature was integrated into Cisco IOS Release 12.2(8)T. Support was added for the Cisco 12.2 T release for the following platforms: Cisco 3640 series, Cisco 3660 series, Cisco 4500 series, Cisco uBR7200 series, and the Cisco MGX Route Processor Module.

12.0(21)ST

This feature was integrated into Cisco IOS Release 12.0(21)ST. Support for the Cisco 12000 series routers was added (for specific line cards supported, see Table 5).

12.0(22)S

This feature was integrated into Cisco IOS Release 12.0(22)S. Support for the Cisco 12000 series routers was added (for specific line cards supported, see Table 5).

12.0(23)S

This feature was integrated into Cisco IOS Release 12.0(23)S. Support was added for the Cisco 12000 Series Eight-Port OC-3c/STM-1c ATM Line Card (8-Port OC-3 ATM) and the Cisco 12000 Series Three-Port Gigabit Ethernet Line Card (3-Port GbE).

12.0(24)S

This feature was integrated into Cisco IOS Release 12.0(24)S. Support was added for the Cisco 10720 Internet Router and the Cisco 12000 Series Line Cards—1-Port 10-Gigabit Ethernet Line Card (1-Port 10-GbE) and the Modular Gigabit Ethernet/ Fast Ethernet Line Card (Modular GbE/FE).

12.0(25)S

This feature was integrated into Cisco IOS Release 12.0(25)S. Support was added for the Cisco 12000 Series 4-Port Gigabit Ethernet ISE Line Card (4-Port GE ISE).

12.0(31)S

Support for the MPLS VPN—Carrier Supporting Carrier feature on customer-facing interfaces configured for the MPLS VPNs over IP Tunnels feature has been added to IP Services Engine (ISE) line cards on the Cisco 12000 Series Internet Router.


The Carrier Supporting Carrier feature enables one MPLS VPN-based service provider to allow other service providers to use a segment of its backbone network. This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuration Examples

Command Reference

Glossary

Feature Overview

Carrier supporting carrier is a term used to describe a situation in which one service provider allows another service provider to use a segment of its backbone network. The service provider that provides the segment of the backbone network to the other provider is called the backbone carrier. The service provider that uses the segment of the backbone network is called the customer carrier.

This feature module focuses on a backbone carrier that offers Border Gateway Protocol and Multiprotocol Label Switching (BGP/MPLS) VPN services. The customer carrier can be either

An Internet service provider (ISP)

A BGP/MPLS VPN service provider

This feature module describes both types of customer carrier.

Providing a Backbone Network to an ISP Customer Carrier

This section explains how a BGP/MPLS VPN service provider (backbone carrier) can provide a segment of its backbone network to a customer who is an ISP.

Consider the following example:

An ISP has two sites: one in California, the other in Maine. Each site is a point of presence (POP). The ISP wants to connect these sites using a VPN service provided by a backbone carrier. Figure 1 illustrates this situation.

Figure 1 Sample BGP/MPLS Backbone Carrier Supporting an ISP


Note The CE routers in the figures in this feature module are CE routers to the backbone carrier. However, they are PE routers to the customer carrier.



Note This document uses the following abbreviations:

CE router:
A customer edge router is part of a customer network and interfaces to a provider edge (PE) router. In this document, the CE router sits on the edge of the customer carrier network.

PE router: A provider edge router is part of a service provider's network connected to a customer edge (CE) router. In this document, the PE routers sits on the edge of the backbone carrier network.

ASBR: In this document, an autonomous system boundary router connects one autonomous system to another.


In this example, only the backbone carrier uses MPLS. The customer carrier (ISP) uses only IP. As a result, the backbone carrier must carry all the Internet routes of the customer carrier, which could be as many as 100,000 routes. This poses a scalability problem for the backbone carrier. To solve the scalability problem, the backbone carrier is configured as follows:

The backbone carrier allows only internal routes of the customer carrier (IGP routes) to be exchanged between the CE routers of the customer carrier and the PE routers of the backbone carrier.

MPLS is enabled on the interface between the CE router of the customer carrier and the PE router of the backbone carrier.

Internal and external routes are differentiated this way:

Internal routes go to any of the routers within the ISP.

External routes go to the Internet.

The number of internal routes is much smaller than the number of external routes. Restricting the routes between the CE routers of the customer carrier and the PE routers of the backbone carrier significantly reduces the number of routes that the PE router needs to maintain.

Since the PE routers do not have to carry external routes in the VRF routing table, they can use the incoming label in the packet to forward the customer carrier Internet traffic. Adding MPLS to the routers provides a consistent method of transporting packets from the customer carrier to the backbone carrier. MPLS allows the exchange of an MPLS label between the PE and the CE routers for every internal customer carrier route. The routers in the customer carrier have all the external routes either through IBGP or route redistribution to provide Internet connectivity. Figure 2 shows how information is exchanged when the network is configured in this manner.

Figure 2 Backbone Carrier Exchanging Routing Information with a Customer Carrier Who Is an ISP

Establishing a Route Between the Backbone Carrier and the Customer Carrier Who Is an ISP

In the example shown in Figure 3, routes are created between the backbone carrier and the customer carrier sites. ASBR2 receives an Internet route that originated outside the network. All routers in the ISP sites have all the external routes through IBGP connections among them.

Figure 3 Establishing a Route Between a Backbone Carrier and a Customer Carrier Who Is an ISP

Table 1 describes the process of establishing the route, which can be divided into two distinct steps:

The backbone carrier propagates the IGP information of the customer carrier, which enables the customer carrier routers to reach all the customer carrier routers in the remote sites.

Once the routers of the customer carriers in different sites are reachable, external routes can be propagated in the customer carrier sites, using IBGP without using the backbone carrier routers.

Table 1 Establishing a Route Between the Backbone Carrier and the Customer Carrier ISP

Step
Description

1

CSC-CE2 sends the internal routes within site 2 to CSC-PE2. The routes include the route to ASBR2.

2

CSC-PE2 sends the routing information for site 2 to CSC-PE1, using MPLS VPN processes. CSC-PE1 gets one label (called L3), which is associated with the route to the VPN-IP address for ASBR2. CSC-PE1 gets another label (called L2), which is associated with the route to CSC-PE2.

3

CSC-PE1 sends the routing information associated with internal routes from site 2 to CSC-CE1. CSC-PE1 also sends the label binding information. As a result, CSC-CE1 gets the route to ASBR2 with CSC-PE1 as the next hop. The label associated with that route is called L1.

4

CSC-CE1 distributes the routing information through site 1. Every router in site 1 gets a route for every internal destination in site 2. Therefore, every router in site 1 can reach routers in site 2 and learn external routes through IBGP.

5

ASBR2 receives an Internet route.

6

The IBGP sessions exchange the external routing information of the ISP, including a route to the Internet. Every router in site 1 knows a route to the Internet, with ASBR2 as the next hop of that route.


Transporting a Packet Through a Network of a Backbone Carrier and Customer Carrier Who Is an ISP

Table 2 explains each step in the process of transporting a packet. The following conventions are used in Table 2:

The D in the Label Stack and Destination Address column represents an address that is outside the network, such as an Internet address.

The notation X(Y) means "the label distributed by Y, which represents the route to X."

In the Label Stack and Destination Address column, when a label stack is present, the top label is listed first; the destination address is listed last.

Table 2 Transporting Packets From a Customer Carrier Who is an ISP Through a BGP/MPLS Backbone Carrier

Step
The Packet Is Received By
Label Stack and Destination Address
Label Stack Operation
How the Label Was Learned
Next Hop

1

ASBR1

D

None

C1

2

C1

D

None

CSC-CE1

3

CSC-CE1

D

Move ASBR2(CSC-PE1) onto the stack

LDP

CSC-PE1

4

PE1

ASBR2(CSC-PE1)
D

Replace the top label with ASBR2(CSC-PE2)
Push the IGP label for CSC-PE2
CSC-PE2(P1)

BGP

P1

5

P1

CSC-PE2(P1)
ASBR2(CSC-PE2)
D

Replace the top label with CSC-PE2(P2)

LDP

P2

6

P2

CSC-PE2(P2)
ASBR2(CSC-PE2)
D

Remove a label from the stack

LDP

CSC-PE2

7

CSC-PE2

ASBR2(CSC-CE2)
D

Replace the top label from the stack

LDP

CSC-CE2

9

CSC-CE2

D

Remove a label from the stack

C2

9

C2

D

None

ASBR2

10

ASBR2

D

     

Providing a Backbone Network to a Customer Carrier Who Is a BGP/MPLS VPN Service Provider

When a backbone carrier and the customer carrier both provide BGP/MPLS VPN services, the method of transporting data is different from when a customer carrier provides only ISP services. The following list highlights those differences.

When a customer carrier provides BGP/MPLS VPN services, its external routes are VPN-IPv4 routes. When a customer carrier is an ISP, its external routes are IP routes.

When a customer carrier provides BGP/MPLS VPN services, every site within the customer carrier must use MPLS. When a customer carrier is an ISP, the sites do not need to use MPLS.

Figure 4 shows how information is exchanged when MPLS VPN services reside on all customer carrier sites and on the backbone carrier.

Figure 4 Backbone Carrier Exchanging Information with a Customer Carrier Who Is an MPLS VPN Service Provider

Establishing a Route Between the Backbone Carrier and the Customer Carrier Who Is an MPLS VPN Service Provider

In the example shown in Figure 5, routes are created between the backbone carrier and the customer carrier sites.

Figure 5 Establishing a Route Between a Backbone Carrier and a Customer Carrier Who Is an MPLS VPN Service Provider

Table 3 describes the process of establishing the route.

Table 3 Establishing a Route Between the Backbone Carrier and Customer Carrier Site

Step
Description

1

CE2 sends all the internal routes within site 2 to CSC-PE2.

2

CSC-PE2 sends the routing information for site 2 to CSC-PE1, using MPLS VPN processes. CSC-PE1 gets one label (called L3), which is associated with the route to the VPN-IP address for PE2. CSC-PE1 gets another label (called L2), which is associated with the route to CSC-PE2.

3

CSC-PE1 sends the routing information associated with internal routes from site 2 to CSC-CE1. CSC-PE1 also sends the label binding information. As a result, CSC-CE1 gets the route to PE2 with CSC-PE1 as the next hop. The label associated with that route is called L1.

4

CE1 distributes the routing and labeling information through site 1. Every router in site 1 gets a route for every internal destination in site 2. Therefore, PE1 can establish an MP-IBGP session with PE2.

5

CE2 advertises the internal routes of MPLS VPN site 2 to PE2.

6

PE2 allocates labels for all the VPN routes (regular MPLS VPN functionality) and advertises it to PE1, using MP-IBGP.

7

PE1 can forward traffic from VPN site 1 that is destined for VPN site 2.


Transporting a Packet Through a Network of a Backbone Carrier and Customer Carrier Who Is an MPLS VPN Service Provider

Table 4 explains each step in the process of transporting the packet. The following conventions are used in Table 4:

The D in the Label Stack and Destination Address column represents an address that is outside the network, such as an Internet address.

The notation X(Y) means "the label distributed by Y, which represents the route to X."

In the Label Stack and Destination Address column, when a label stack is present, the top label is listed first; the destination address is listed last.

Table 4 Transporting Packets From a Customer Carrier Running BGP/MPLS VPN Service Through a BGP/MPLS Backbone Carrier  

Step
The Packet Is Received By
Label Stack and Destination Address
Label Stack Operation
How the Label Was Learned
Next Hop

1

PE1

D

Move D(PE2) onto the stack
Move PE2(C1)onto the stack

BGP
LDP

C1

2

C1

PE2(C1)
D(PE2)
D

Replace the top label with PE2(CSC-CE1)

LDP

CSC-CE1

3

CSC-CE1

PE2(CSC-CE1)
D(PE2)
D

Replace the top label with PE2(CSC-PE1)

LDP

CSC-PE1

4

CSC-PE1

PE2(CSC-PE1)
D(PE2)
D

Replace the top label with PE2(CSC-PE2)
Move CSC-PE2(P1) onto the stack

BGP

P1

5

P1

CSC-PE2(P1)
PE2(CSC-PE2)
D(PE2)
D

Replace the top label with CSC-PE2(P2)

LDP

P2

6

P2

CSC-PE2(P2)
PE2(P2)
D(PE2)
D

Remove a label from the stack

LDP

CSC-PE2

7

CSC-PE2

PE2(CSC-PE2)
D(PE2)
D

Replace the top label with PE2(CSC-CE2)

BGP

CSC-CE2

8

CSC-CE2

PE2(CSC-CE2)
D(PE2)
D

Replace the top label with PE2(C2)

LDP

C2

9

C2

PE2(C2)
D(PE2)
D

Remove a label from the stack

LDP

PE2

10

PE2

D(PE2)
D

     

Benefits

The MPLS VPN carrier supporting carrier feature provides the benefits listed in the following paragraphs to service providers who are backbone carriers and customer carriers.

Benefits to the Backbone Carrier

Implementing the MPLS VPN carrier supporting carrier feature enables the backbone carrier to realize the following benefits:

The backbone carrier can accommodate many customer carriers and give them access to its backbone. The backbone carrier does not need to create and maintain separate backbones for its customer carriers. Using one backbone network to support multiple customer carriers simplifies the backbone carrier's VPN operations. The backbone carrier uses a consistent method for managing and maintaining the backbone network. This is also cheaper and more efficient than maintaining separate backbones.

The MPLS VPN carrier supporting carrier feature is scalable. Carrier supporting carrier can change the VPN to meet changing bandwidth and connectivity needs. The feature can accommodate unplanned growth and changes. The carrier supporting carrier feature enables tens of thousands of VPNs to be set up over the same network, and it allows a service provider to offer both VPN and Internet services.

The MPLS VPN carrier supporting carrier feature is a flexible solution. The backbone carrier can accommodate many types of customer carriers. The backbone carrier can accept customer carriers who are ISPs or VPN service providers or both. The backbone carrier can accommodate customer carriers that require security and various bandwidths.

Benefits to the Customer Carrier

Implementing the MPLS VPN carrier supporting carrier feature enables the customer carrier to realize the following benefits:

The MPLS VPN carrier supporting carrier feature removes from the customer carrier the burden of configuring, operating, and maintaining its own backbone. The customer carrier uses the backbone network of a backbone carrier, but the backbone carrier is responsible for network maintenance and operation.

Customer carriers who use the VPN services provided by the backbone carrier receive the same level of security that Frame Relay or ATM-based VPNs provide. Customer carriers can also use IPSec in their VPNs for a higher level of security; it is completely transparent to the backbone carrier.

Customer carriers can use any link layer technology (SONET, DSL, Frame Relay, and so on) to connect the CE routers to the PE routers and the PE routers to the P routers. The MPLS VPN carrier supporting carrier feature is link layer independent. The CE routers and PE routers use IP to communicate, and the backbone carrier uses MPLS.

The customer carrier can use any addressing scheme and still be supported by a backbone carrier. The customer address space and routing information are independent of the address space and routing information of other customer carriers or the backbone provider.

Requirements

The carrier supporting carrier feature includes the following requirements:

The PE routers of the backbone carrier require 128 MB of memory.

The backbone carrier must enable the PE router to check that the packets it receives from the CE router contain only the labels that the PE router advertised to the CE router. This prevents data spoofing, which occurs when a packet from an unrecognized IP address is sent to a router.

A routing protocol is required between the PE and CE routers that connect the backbone carrier to the customer carrier. The routing protocol enables the customer carrier to exchange IGP routing information with the backbone carrier. Use the same routing protocol that the customer carrier uses. You can choose RIP, OSPF, or static routing as the routing protocol. BGP is not supported.

Label distribution protocol (LDP) is required between the PE and CE routers that connect the backbone carrier to the customer carrier. LDP is also required on the PE to CE interface for VPN routing/forwarding (VRF). LDP is available on Cisco IOS Release 12.0(10)ST or later.

All PE routers that link the backbone carrier to the customer carrier must run this IOS software image. Other PE routers, CE routers, and P routers do not need to run this software image, but, they must run a version of Cisco IOS software that supports MPLS VPNs (Cisco IOS Release 12.0(5)T or later).

Every packet that crosses the backbone carrier must be encapsulated, so that the packet includes MPLS labels. To ensure that the packets are encapsulated, issue the following command on the PE routers that connect to CE routers:

(config-if)# mpls ip 

For more information, see the IOS Command Reference Guide.

The following features are not supported in the carrier supporting carrier feature:

ATM MPLS

Carrier supporting carrier traffic engineering

Carrier supporting carrier class of service (CoS)

RSVP aggregation

VPN Multicast between the customer carrier and the backbone carrier network

Related Features and Technologies

The carrier supporting carrier feature is used with the VPN capabilities of MPLS. (MPLS VPNs were introduced in Cisco IOS Release 12.0(5)T.)

Related Documents

MPLS Virtual Private Networks (VPNs)

MPLS Virtual Private Network Enhancements

Cisco IOS Release 12.0 Network Protocols Configuration Guide, Part I

Cisco IOS Release 12.0 Network Protocols Command Reference, Part I

Supported Platforms

The following router platforms are supported on the edge:

Cisco 7200 series

Cisco 7500 series

Cisco 10720 Internet Routers

Cisco 12000 series

See Table 5 for Cisco 12000 series line card support added for Cisco IOS Releases.

Table 5 Cisco I2000 Series Line Card Support Added for Cisco IOS Releases

Type
Line Cards
Cisco IOS Release Added

Packet Over SONET (POS)

4-Port OC-3 POS
1-Port OC-12 POS
8-Port OC-3 POS
16-Port OC-3 POS
4-Port OC-12 POS
1-Port OC-48 POS
4-Port OC-3 POS ISE
8-Port OC-3 POS ISE
16-Port OC-3 POS ISE
4-Port OC-12 POS ISE
1-Port OC-48 POS ISE

12.0(16)ST

12.0(21)ST



12.0(22)S

Electrical Interface

6- Port DS3
12- Port DS3
6-Port E3
12-Port E3

12.0(16)ST

12.0(21)ST
12.0(23)S

Ethernet

3-Port GbE
1-Port 10-GbE
Modular GbE/FE
4-Port GE ISE

12.0(23)S
12.0(24)S

12.0(25)S

Asynchronous Transfer Mode (ATM)

4-Port OC-3 ATM
1-Port OC12 ATM
4-Port OC-12 ATM
8-Port OC-3 ATM

12.0(22)S


12.0(23)S

Channelized Interface

2-Port CHOC-3
6-Port Ch T3 (DS1)
1-Port CHOC-12 (DS3)
1-Port CHOC-12 (OC-3)
4-Port CHOC-12 ISE
1-Port CHOC-48 ISE
1-Port CHOC-12 (DS1) ISE
2.5G ISE SPA Interface Processor:
- 2-port Channelized T3 SPA
- 4-Port Channelized T3 Serial SPA

12.0(22)S





12.0(27)S
12.0(31)S


MPLS VPN Carrier Supporting Carrier over IP Tunnels

Starting in IOS Release 12.0(31)S, you can configure the MPLS VPN Carrier Supporting Carrier feature on supported IP Services Engine (ISE) line cards in a Cisco 12000 Series Internet Router, which have already been configured for the MPLS VPNs over IP Tunnels feature. The router must be deployed as a PE router in a service-provider core network.

The MPLS VPNs over IP Tunnels feature introduces the capability to deploy layer 3 VPN services over an IP core network using L2TPv3 multipoint tunnelling instead of MPLS. For more information, refer to MPLS VPNs over IP Tunnels.

The MPLS VPN Carrier Supporting Carrier over IP Tunnels feature is supported only on customer-facing interfaces. The Cisco 12000 Series ISE line cards that support MPLS VPN Carrier Supporting Carrier over IP Tunnels are as follows:

4-port OC-3 POS ISE

8-port OC-3 POS ISE

16-port OC-3 POS ISE

4-port OC-12 POS ISE

1-port OC-48 POS ISE

1-port Channelized OC-12 (DS1) POS ISE

2.5G ISE SPA Interface Processor:

2-port Channelized T3 SPA

4-Port Channelized T3 Serial SPA

4-port OC-12 ATM ISE

4-port OC3 ATM ISE

4-port GE ISE

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that are supported on specific platforms. To obtain updated information about platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. In the release section, you can compare releases side by side to display both the features unique to each software release and the features that releases have in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

RFCs

RFC 1171, A Border Gateway Protocol 4

RFC 1164, Application of the Border Gateway Protocol in the Internet

RFC 2283, Multiprotocol Extensions for BGP-4

RFC 2547, BGP/MPLS VPNs

Prerequisites

The backbone carrier must be properly configured for MPLS VPN operation before the customer carriers can access the backbone network. Refer to the MPLS Virtual Private Networks (VPNs) and the MPLS Virtual Private Network Enhancements feature modules.

Configuration Tasks

See the following sections to enable a backbone carrier to share its backbone network with a customer carrier. Each task entry in the list indicates if the task is optional or required.

Configuring the Backbone Carrier PE Router (required)

Configuring the Customer Carrier CE Routers (required)

Verifying the Carrier Supporting Carrier Configuration (optional)

Configuring the Backbone Carrier PE Router

To configure the backbone carrier PE route that links to the edge router of the customer carrier, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# mpls label protocol ldp

Sets the default label distribution protocol for all interfaces to be LDP.

Step 2 

Router(config-if)# mpls ip

Enables MPLS on the VRF interface.

Configuring the Customer Carrier CE Routers

To configure the CE router on the customer carrier that links to the edge router of the backbone carrier, use the following commands in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# mpls label protocol ldp

Sets the default label distribution protocol for all interfaces to LDP.

Step 2 

Router(config-if)# mpls ip 

Enables MPLS on the VRF interface.

Verifying the Carrier Supporting Carrier Configuration

The following commands helps to verify the status of LDP sessions that were configured between the backbone carrier and customer carrier. Now the customer carrier ISP sites appear as a VPN customer to the backbone carrier.

This command shows the LDP sessions in VRF VPN1 of the PE router of the backbone carrier.

Router# show mpls ldp discovery vrf vpn1 

Local LDP Identifier:
    139.0.0.0:0
Discovery Sources:
    Interfaces:
        Ethernet1/0 (ldp): xmit/recv
            LDP Id: 55.0.0.1:0
POS6/0 (ldp): xmit

This command list all LDP sessions in a router.

Router# show mpls ldp discovery all

Local LDP Identifier:
    141.141.141.141:0
Discovery Sources:
    Interfaces:
        Ethernet1/5 (ldp): xmit/recv
            LDP Id: 5.5.5.5:0
VRF vpn1: Local LDP Identifier:
    139.0.0.1:0
Discovery Sources:
    Interfaces:
        Ethernet1/0 (ldp): xmit/recv
            LDP Id: 55.0.0.1:0
POS6/0 (ldp): xmit

The Local LDP Identifier field shows the LDP identifier for the local label switching router for this session. The Interfaces field displays the interfaces engaging in LDP discovery activity:

xmit indicates that the interface is transmitting LDP discovery hello packets.

recv indicates that the interface is receiving LDP discovery hello packets.

Configuration Examples

This section provides the following configuration examples:

Configuring a Carrier Supporting Carrier Network with a Customer Who Is an ISP

Configuring a Carrier Supporting Carrier Network with a Customer Who Is an MPLS VPN Provider

Configuring a Carrier Supporting Carrier Network That Contains Route Reflectors

Configuring a Carrier Supporting Carrier Network with a Customer Who Has VPNs at the Network's Edge

Configuring a Carrier Supporting Carrier Network with a Customer Who Is an ISP

Figure 6 shows a carrier supporting carrier network configuration where the customer carrier is an ISP. The customer carrier has two sites, each of which is a point of presence (POP). The customer carrier connects these sites using a VPN service provided by the backbone carrier. The backbone carrier uses MPLS. The ISP sites use IP. To enable packet transfer between the ISP sites and the backbone carrier, the CE routers that connect the ISPs to the backbone carrier run MPLS.

Figure 6 Carrier Supporting Carrier Network with a Customer Carrier Who Is an ISP

The following configuration examples show the configuration of each router in the carrier supporting carrier network. OSPF is the protocol used to connect the customer carrier to the backbone carrier.

CSC-CE1 Configuration

mpls label protocol ldp
!
interface Loopback0
 ip address 10.127.14.14 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
 ip address 192.168.0.46 255.0.0.0
 no ip directed-broadcast
 atm pvc 101 0 51 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
 ip address 192.168.0.38 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 200
 log-adjacency-changes
 redistribute connected subnets
 network 10.127.14.14 0.0.0.0 area 200
 network 192.168.38.0 0.255.255.255 area 200
 network 192.168.46.0 0.255.255.255 area 200

CSC-PE1 Configuration

ip cef distributed
!
ip vrf vpn1
 rd 100:0
 route-target export 100:0
 route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
 ip address 10.127.11.11 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Loopback100
 ip vrf forwarding vpn1
 ip address 10.127.19.19 255.255.255.255
 no ip directed-broadcast
!
interface ATM1/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/1/0.1 point-to-point
 ip address 192.168.0.33 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.46 255.0.0.0
 no ip directed-broadcast
 atm pvc 101 0 51 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 100
 log-adjacency-changes
 passive-interface ATM3/0/0.1
 passive-interface Loopback100
 network 10.127.11.11 0.0.0.0 area 100
 network 192.168.33.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
 log-adjacency-changes
 redistribute bgp 100 metric-type 1 subnets
 network 10.127.19.19 0.0.0.0 area 200
 network 192.168.46.0 0.255.255.255 area 200
!
router bgp 100
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.127.12.12 remote-as 100
 neighbor 10.127.12.12 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.127.12.12 activate
 neighbor 10.127.12.12 send-community extended
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.127.12.12 activate
 neighbor 10.127.12.12 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 200 match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family

CSC-PE2 Configuration

ip cef distributed
!
ip vrf vpn1
 rd 100:0
 route-target export 100:0
 route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
 ip address 10.127.12.12 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Loopback100
 ip vrf forwarding vpn1
 ip address 10.127.20.20 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
 ip address 192.168.0.33 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.47 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 100
 log-adjacency-changes
 passive-interface ATM3/0/0.1
 passive-interface Loopback100
 network 10.127.12.12 0.0.0.0 area 100
 network 192.168.33.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
 log-adjacency-changes
 redistribute bgp 100 metric-type 1 subnets
 network 10.127.20.20 0.0.0.0 area 200
 network 192.168.47.0 0.255.255.255 area 200
!
router bgp 100
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.127.11.11 remote-as 100
 neighbor 10.127.11.11 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.127.11.11 activate
 neighbor 10.127.11.11 send-community extended
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.127.11.11 activate
 neighbor 10.127.11.11 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 200 match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family

CSC-CE2 Configuration

ip cef
!         
mpls label protocol ldp
!
interface Loopback0
 ip address 10.127.16.16 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
 ip address 192.168.0.47 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM5/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
 ip address 192.168.0.43 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 200
 log-adjacency-changes
 redistribute connected subnets
 network 10.127.16.16 0.0.0.0 area 200
 network 192.168.43.0 0.255.255.255 area 200
 network 192.168.47.0 0.255.255.255 area 200

Configuring a Carrier Supporting Carrier Network with a Customer Who Is an MPLS VPN Provider

Figure 7 shows a carrier supporting carrier network configuration where the customer carrier is an MPLS VPN provider. The customer carrier has two sites. The backbone carrier and the customer carrier use MPLS. The IBGP sessions exchange the external routing information of the ISP.

Figure 7 Carrier Supporting Carrier Network with a Customer Carrier Who Is an MPLS VPN Provider

The following configuration examples show the configuration of each router in the carrier supporting carrier network. OSPF is the protocol used to connect the customer carrier to the backbone carrier.

CE1 Configuration

ip cef
!
interface Loopback0
 ip address 10.127.17.17 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 192.168.0.37 255.0.0.0
 no ip directed-broadcast
!
router ospf 300
 log-adjacency-changes
 redistribute bgp 300 subnets
 passive-interface Ethernet0/1
 network 10.127.17.17 0.0.0.0 area 300
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 timers bgp 10 30
 redistribute connected
 redistribute ospf 300 match internal external 1 external 2
 neighbor 192.168.0.37 remote-as 200
 neighbor 192.168.0.37 advertisement-interval 5
 no auto-summary

PE1 Configuration

ip cef
!         
ip vrf vpn2
 rd 200:1
 route-target export 200:1
 route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
 ip address 10.127.13.13 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
 ip address 192.168.0.38 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface Ethernet3/0
 ip vrf forwarding vpn2
 ip address 192.168.0.37 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
!
router ospf 200
 log-adjacency-changes
 redistribute connected subnets
 passive-interface Ethernet3/0
 network 10.127.13.13 0.0.0.0 area 200
 network 192.168.38.0 0.255.255.255 area 200
!
router bgp 200
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.127.15.15 remote-as 200
 neighbor 10.127.15.15 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.127.15.15 activate
 neighbor 10.127.15.15 send-community extended
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.127.15.15 activate
 neighbor 10.127.15.15 send-community extended
 exit-address-family
 !        
 address-family ipv4 vrf vpn2
 neighbor 192.168.0.37 remote-as 300
 neighbor 192.168.0.37 activate
 neighbor 192.168.0.37 as-override
 neighbor 192.168.0.37 advertisement-interval 5
 no auto-summary
 no synchronization
 exit-address-family

CSC-CE1 Configuration

mpls label protocol ldp
!
interface Loopback0
 ip address 10.127.14.14 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
 ip address 192.168.0.2 255.0.0.0
 no ip directed-broadcast
 atm pvc 101 0 51 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
 ip address 192.168.0.38 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 200
 log-adjacency-changes
 redistribute connected subnets
 network 10.127.14.14 0.0.0.0 area 200
 network 192.168.38.0 0.255.255.255 area 200
 network 192.168.46.0 0.255.255.255 area 200

CSC-PE1 Configuration

ip cef distributed
!
ip vrf vpn1
 rd 100:0
 route-target export 100:0
 route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
 ip address 10.127.11.11 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Loopback100
 ip vrf forwarding vpn1
 ip address 10.127.19.19 255.255.255.255
 no ip directed-broadcast
!
interface ATM1/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/1/0.1 point-to-point
 ip address 192.168.0.33 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.46 255.0.0.0
 no ip directed-broadcast
 atm pvc 101 0 51 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 100
 log-adjacency-changes
 passive-interface ATM3/0/0.1
 passive-interface Loopback100
 network 10.127.11.11 0.0.0.0 area 100
 network 192.168.33.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
 log-adjacency-changes
 redistribute bgp 100 metric-type 1 subnets
 network 10.127.19.19 0.0.0.0 area 200
 network 192.168.46.0 0.255.255.255 area 200
!
router bgp 100
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.127.12.12 remote-as 100
 neighbor 10.127.12.12 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.127.12.12 activate
 neighbor 10.127.12.12 send-community extended
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.127.12.12 activate
 neighbor 10.127.12.12 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 200 match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family

CSC-PE2 Configuration

ip cef distributed
!
ip vrf vpn1
 rd 100:0
 route-target export 100:0
 route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
 ip address 10.127.12.12 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface Loopback100
 ip vrf forwarding vpn1
 ip address 10.127.20.20 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
 ip address 192.168.0.33 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.47 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 100
 log-adjacency-changes
 passive-interface ATM3/0/0.1
 passive-interface Loopback100
 network 10.127.12.12 0.0.0.0 area 100
 network 192.168.33.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
 log-adjacency-changes
 redistribute bgp 100 metric-type 1 subnets
 network 10.127.20.20 0.0.0.0 area 200
 network 192.168.47.0 0.255.255.255 area 200
!
router bgp 100
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.127.11.11 remote-as 100
 neighbor 10.127.11.11 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.127.11.11 activate
 neighbor 10.127.11.11 send-community extended
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.127.11.11 activate
 neighbor 10.127.11.11 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 200 match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family

CSC-CE2 Configuration

ip cef
!         
mpls label protocol ldp
!
interface Loopback0
 ip address 10.127.16.16 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
 ip address 192.168.0.47 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
interface ATM5/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
 ip address 192.168.0.43 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 200
 log-adjacency-changes
 redistribute connected subnets
 network 10.127.16.16 0.0.0.0 area 200
 network 192.168.43.0.0.255.255.255 area 200
 network 192.168.47.0.0.255.255.255 area 200

PE2 Configuration

ip cef
ip cef accounting non-recursive 
!         
ip vrf vpn2
 rd 200:1
 route-target export 200:1
 route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
 ip address 10.127.15.15 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet3/0
 ip vrf forwarding vpn2
 ip address 192.168.0.42 255.0.0.0
 no ip directed-broadcast
!
interface ATM5/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
 ip address 192.168.0.43 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!
router ospf 200
 log-adjacency-changes
 redistribute connected subnets
 passive-interface Ethernet3/0
 network 10.127.15.15 0.0.0.0 area 200
 network 192.168.43.0 0.255.255.255 area 200
!
router bgp 200
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 timers bgp 10 30
 neighbor 10.127.13.13 remote-as 200
 neighbor 10.127.13.13 update-source Loopback0
 !
 address-family ipv4
 neighbor 10.127.13.13 activate
 neighbor 10.127.13.13 send-community extended
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 10.127.13.13 activate
 neighbor 10.127.13.13 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf vpn2
 neighbor 192.168.0.42 remote-as 300
 neighbor 192.168.0.42 activate
 neighbor 192.168.0.42 as-override
 neighbor 192.168.0.42 advertisement-interval 5
 no auto-summary
 no synchronization
 exit-address-family

CE2 Configuration

ip cef
!
interface Loopback0
 ip address 10.127.18.18 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 192.168.0.42 255.0.0.0
 no ip directed-broadcast
!
router ospf 300
 log-adjacency-changes
 redistribute bgp 300 subnets
 passive-interface Ethernet0/1
 network 10.127.18.18 0.0.0.0 area 300
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 timers bgp 10 30
 redistribute connected
 redistribute ospf 300 match internal external 1 external 2
 neighbor 192.168.0.42 remote-as 200
 neighbor 192.168.0.42 advertisement-interval 5
 no auto-summary

Configuring a Carrier Supporting Carrier Network That Contains Route Reflectors

Figure 8 shows a carrier supporting carrier network configuration that contains route reflectors. The customer carrier has two sites.

Figure 8 Carrier Supporting Carrier Network that Contains Route Reflectors


Note A connection between route reflectors (RR) is not necessary.


The following configuration examples show the configuration of each router in the carrier supporting carrier network. Note the following:

The router IP addresses are abbreviated for ease of reading. For example, the loopback address for PE 1 is 25, which is equivalent to 10.127.25.25.

The following list shows the loopback addresses for the CSC-PE routers:

CSC-PE1 (75K-37-3): loopback 0 = 10.127.15.15, loopback 1 = 10.127.18.18

CSC-PE2 (75K-38-3): loopback 0 = 10.127.16.16, loopback 1 = 10.127.20.20

Backbone Carrier Configuration

Route Reflector 1 (72K-37-1) Configuration

interface Loopback0
 ip address 10.127.13.13 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!         
interface ATM1/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM1/0.1 mpls
ip address 192.168.0.51 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
interface ATM1/1
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM1/1.1 mpls
 ip address 192.168.0.52 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
router ospf 100
 auto-cost reference-bandwidth 10000
 network 10.127.13.0.0.255.255.255 area 100
 network 192.168.51.0 0.255.255.255 area 100
 network 192.168.52.0 0.255.255.255 area 100
!         
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp cluster-id 1
 redistribute static
 neighbor 10.127.15.15 remote-as 100
 neighbor 10.127.15.15 update-source Loopback0
 neighbor 10.127.16.16 remote-as 100
 neighbor 10.127.16.16 update-source Loopback0
 !        
 address-family ipv4 vrf vpn1
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.15.15 activate
 neighbor 10.127.15.15 route-reflector-client
 neighbor 10.127.15.15 send-community extended
 neighbor 10.127.16.16 activate
 neighbor 10.127.16.16 route-reflector-client
 neighbor 10.127.16.16 send-community extended
 bgp scan-time import 5
 exit-address-family

Route Reflector 2 (72K-38-1) Configuration

interface Loopback0
 ip address 10.127.14.14 255.255.255.255
 no ip directed-broadcast
 no ip mroute-cache
!         
interface ATM1/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM1/0.1 mpls
 ip address 192.168.0.53 255.0.0.0
no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
interface ATM1/1
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM1/1.1 mpls
 ip address 192.168.0.52 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
router ospf 100
 auto-cost reference-bandwidth 10000
 network 10.127.14.0 0.255.255.255 area 100
 network 192.168.52.0 0.255.255.255 area 100
 network 192.168.53.0 0.255.255.255 area 100
!         
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp cluster-id 1
 redistribute static
 neighbor 10.127.15.15 remote-as 100
 neighbor 10.127.15.15 update-source Loopback0
 neighbor 10.127.16.16 remote-as 100
 neighbor 10.127.16.16 update-source Loopback0
 !        
 address-family ipv4 vrf vpn1
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.15.15 activate
 neighbor 10.127.15.15 route-reflector-client
 neighbor 10.127.15.15 send-community extended
 neighbor 10.127.16.16 activate
 neighbor 10.127.16.16 route-reflector-client
 neighbor 10.127.16.16 send-community extended
 bgp scan-time import 5
 exit-address-family

CSC-PE1 (75K-37-3) Configuration

ip cef distributed
!         
ip vrf vpn1
 rd 100:1 
 route-target export 100:1
 route-target import 100:1
!         
interface Loopback0
 ip address 10.127.15.15 255.255.255.255
 no ip directed-broadcast
!         
interface Loopback1
 ip vrf forwarding vpn1
 ip address 10.127.18.18 255.255.255.255
 no ip directed-broadcast
!         
interface Ethernet0/0/1
 ip vrf forwarding vpn1
 ip address 192.168.0.55 255.0.0.0
 no ip directed-broadcast
 no ip route-cache distributed
 mpls label protocol ldp
 mpls ip
!         
interface ATM1/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM1/1/0.1 mpls
 ip address 192.168.0.56 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM3/0/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.50 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 6 32 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!         
interface ATM3/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM3/1/0.1 mpls
 ip address 192.168.0.51 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
router ospf 100
 auto-cost reference-bandwidth 10000
 network 10.127.15.0 0.255.255.255 area 100
 network 192.168.50.0 0.255.255.255 area 100
 network 192.168.51.0 0.255.255.255 area 100
 network 192.168.55.0 0.255.255.255 area 100
 network 192.168.56.0 0.255.255.255 area 100
!         
router ospf 1 vrf vpn1
 redistribute bgp 100 metric-type 1 subnets
 network 10.127.17.0 0.255.255.255 area 101
 network 10.127.18.0 0.255.255.255 area 101
 network 192.168.50.0 0.255.255.255 area 101
 network 192.168.55.0 0.255.255.255 area 101
!         
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.127.13.13 remote-as 100
 neighbor 10.127.13.13 update-source Loopback0
 neighbor 10.127.14.14 remote-as 100
 neighbor 10.127.14.14 update-source Loopback0
 !        
 address-family ipv4
 redistribute static
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.13.13 activate
 neighbor 10.127.13.13 send-community extended
 neighbor 10.127.14.14 activate
 neighbor 10.127.14.14 send-community extended
 exit-address-family
 !        
 address-family ipv4 vrf vpn1
 redistribute ospf 1 match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family

CSC-PE2 (75K-38-3) Configuration

ip cef distributed
!         
ip vrf vpn1
 rd 100:1 
 route-target export 100:1
 route-target import 100:1
!         
interface Loopback0
 ip address 10.127.16.16 255.255.255.255
 no ip directed-broadcast
!         
interface Loopback1
 ip vrf forwarding vpn1
 ip address 10.127.20.20 255.255.255.255
 no ip directed-broadcast
!         
interface ATM0/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM0/1/0.1 mpls
 ip address 192.168.0.56 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
interface ATM2/1/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM2/1/0.1 mpls
 ip address 192.168.0.53 255.0.0.0
 no ip directed-broadcast
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls atm vpi 2-5
 mpls ip
!         
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
 no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM3/0/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.54 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 6 32 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!         
interface ATM3/1/0
 no ip address
 no ip directed-broadcast
no ip route-cache distributed
 atm clock INTERNAL
 atm sonet stm-1
 no atm enable-ilmi-trap
 no atm ilmi-keepalive
!         
interface ATM3/1/0.1 point-to-point
 ip vrf forwarding vpn1
 ip address 192.168.0.57 255.0.0.0
 no ip directed-broadcast
 atm pvc 101 6 33 aal5snap
 no atm enable-ilmi-trap
 mpls label protocol ldp
 mpls ip
!         
router ospf 100
 auto-cost reference-bandwidth 10000
 network 10.127.16.0 0.255.255.255 area 100
 network 192.168.53.0 0.255.255.255 area 100
 network 192.168.54.0 0.255.255.255 area 100
 network 192.168.56.0 0.255.255.255 area 100
 network 192.168.57.0 0.255.255.255 area 100
!         
router ospf 1 vrf vpn1
 redistribute bgp 100 metric-type 1 subnets
 network 10.127.19.0 0.255.255.255 area 101
 network 10.127.20.0 0.255.255.255 area 101
 network 192.168.54.0 0.255.255.255 area 101
 network 192.168.57.0 0.255.255.255 area 101
!         
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 10.127.13.13 remote-as 100
 neighbor 10.127.13.13 update-source Loopback0
 neighbor 10.127.14.14 remote-as 100
 neighbor 10.127.14.14 update-source Loopback0
 !        
 address-family ipv4
 redistribute static
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.13.13 activate
 neighbor 10.127.13.13 send-community extended
 neighbor 10.127.14.14 activate
 neighbor 10.127.14.14 send-community extended
 exit-address-family
 !        
 address-family ipv4 vrf vpn1
 redistribute ospf 1 match internal external 1 external 2
 no auto-summary
 no synchronization
 exit-address-family

Customer Carrier Site 1 Configuration

PE1 (72K-36-8) Configuration

ip cef
!
ip vrf vpn2
 rd 200:1 
 route-target export 200:1
 route-target import 200:1
no mpls ip propagate-ttl
!         
interface Loopback0
 ip address 10.127.25.25 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!         
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM1/0.1 point-to-point
 ip address 192.168.0.66 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
 mpls label protocol ldp
 mpls ip
!         
interface Ethernet3/0
 ip vrf forwarding vpn2
 ip address 192.168.0.70 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
!         
interface Ethernet3/1
 ip address 192.168.0.67 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
 mpls label protocol ldp
 mpls ip
!         
interface Ethernet3/2
 ip address 192.168.0.64 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
mpls label protocol ldp
mpls ip
!         
router ospf 1
 network 10.127.25.0 0.255.255.255 area 101
 network 192.168.64.0.0.255.255.255 area 101
 network 192.168.66.0.0.255.255.255 area 101
 network 192.168.67.0.0.255.255.255 area 101
!         
router bgp 200
 neighbor 10.127.22.22 remote-as 200
 neighbor 10.27.22.22 update-source Loopback0
 neighbor 10.27.23.23 remote-as 200
 neighbor 10.27.23.23 update-source Loopback0
 !        
 address-family ipv4 vrf vpn2
 redistribute connected
 neighbor 192.168.70.2 remote-as 300
 neighbor 192.168.70.2 activate
 neighbor 192.168.70.2 as-override
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.22.22 activate
 neighbor 10.127.22.22 send-community extended
 neighbor 10.127.23.23 activate
 neighbor 10.127.23.23 send-community extended
 exit-address-family

CSC-CE1 (72K-36-9) Configuration

ip cef
no ip domain-lookup
!         
interface Loopback0
 ip address 10.127.11.11 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!         
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM1/0.1 point-to-point
 ip address 192.168.0.50 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 6 32 aal5snap
mpls label protocol ldp
mpls ip
!         
interface ATM2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM2/0.1 point-to-point
 ip address 192.168.0.66 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 50 aal5snap
mpls label protocol ldp
mpls ip
!         
interface Ethernet3/0
 ip address 192.168.0.65 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
mpls label protocol ldp
mpls ip
!         
interface Ethernet3/1
 ip address 192.168.0.55 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
mpls label protocol ldp
mpls ip
!         
router ospf 1
 network 10.127.11.0 0.255.255.255 area 101
 network 192.168.50.0.0.255.255.255 area 101
 network 192.168.55.0 0.255.255.255 area 101
 network 192.168.65.0 0.255.255.255 area 101
 network 192.168.66.0 0.255.255.255 area 101

PE2 (72K-36-7) Configuration

ip cef
!
ip vrf vpn2
 rd 200:1 
 route-target export 200:1
 route-target import 200:1
no mpls ip propagate-ttl
!         
interface Loopback0
 ip address 10.127.24.24 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!         
interface Ethernet3/0
 ip address 192.168.0.65 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
mpls label protocol ldp
mpls ip
!         
interface Ethernet3/1
 ip vrf forwarding vpn2
 ip address 192.168.0.71 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
!         
interface Ethernet3/2
 ip address 192.168.0.67 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
mpls label protocol ldp
mpls ip
!         
interface Ethernet3/3
 ip address 192.168.0.63 255.0.0.0
 no ip directed-broadcast
 no ip mroute-cache
mpls label protocol ldp
mpls ip
!         
router ospf 1
 network 10.127.24.0 0.255.255.255 area 101
 network 192.168.63.0 0.255.255.255 area 101
 network 192.168.65.0 0.255.255.255 area 101
 network 192.168.67.0 0.255.255.255 area 101
!         
router bgp 200
 neighbor 10.127.22.22 remote-as 200
 neighbor 10.127.22.22 update-source Loopback0
 neighbor 10.127.23.23 remote-as 200
 neighbor 10.127.23.23 update-source Loopback0
 !        
 address-family ipv4 vrf vpn2
 neighbor 192.168.71.2 remote-as 300
 neighbor 192.168.71.2 activate
 neighbor 192.168.71.2 as-override
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.22.22 activate
 neighbor 10.127.22.22 send-community extended
 neighbor 10.127.23.23 activate
 neighbor 10.127.23.23 send-community extended
 exit-address-family

Route Reflector 3 (36K-38-4) Configuration

ip cef    
!         
interface Loopback0
 ip address 10.127.23.23 255.255.255.255
!         
interface Ethernet1/1
 ip address 192.168.0.64 255.0.0.0
 mpls label protocol ldp
 mpls ip
!         
interface Ethernet1/2
 ip address 192.168.0.63 255.0.0.0
 mpls label protocol ldp
 mpls ip
!         
interface ATM3/0
 no ip address
 no ip mroute-cache
 atm clock INTERNAL
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!         
interface ATM3/0.1 point-to-point
 ip address 192.168.0.62 255.0.0.0
 atm pvc 100 0 55 aal5snap
 mpls label protocol ldp
 mpls ip
!         
router ospf 1
 log-adjacency-changes
 network 10.127.23.0 0.255.255.255 area 101
 network 192.168.62.0 0.255.255.255 area 101
 network 192.168.63.0 0.255.255.255 area 101
 network 192.168.64.0 0.255.255.255 area 101
!         
router bgp 200
 no synchronization
 no bgp default ipv4-unicast
 bgp cluster-id 2
 redistribute static
 neighbor 10.127.21.21.21 remote-as 200
 neighbor 10.127.21.21 update-source Loopback0
 neighbor 10.127.24.24 remote-as 200
 neighbor 10.127.24.24 update-source Loopback0
 neighbor 10.127.25.25 remote-as 200
 neighbor 10.127.25.25 update-source Loopback0
 !        
 address-family ipv4 vrf vpn2
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.21.21 activate
 neighbor 10.127.21.21 route-reflector-client
 neighbor 10.127.21.21 send-community extended
 neighbor 10.127.24.24 activate
 neighbor 10.127.24.24 route-reflector-client
 neighbor 10.127.24.24 send-community extended
 neighbor 10.127.25.25 activate
 neighbor 10.127.25.25 route-reflector-client
 neighbor 10.127.25.25 send-community extended
 exit-address-family

CE1 (36K-36-1) Configuration

ip cef
!         
interface Loopback0
 ip address 10.127.28.28 255.255.255.255
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 192.168.0.70 255.0.0.0
 no ip directed-broadcast
!         
interface Ethernet0/2
 ip address 192.168.0.71 255.0.0.0
 no ip directed-broadcast
!         
router bgp 300
 network 10.127.28.0
 network 192.168.70.0
 network 192.168.71.0
 neighbor 192.168.70.1 remote-as 200
 neighbor 192.168.71.1 remote-as 200

Customer Carrier Site 2 Configuration

CSC-CE3 (72K-36-6) Configuration

ip cef
!         
interface Loopback0
 ip address 10.127.12.12 255.255.255.255
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!         
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM1/0.1 point-to-point
 ip address 192.168.0.54 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 6 32 aal5snap
mpls label protocol ldp

 mpls ip
!         
interface POS2/0
 ip address 192.168.0.58 255.0.0.0
 no ip directed-broadcast
 encapsulation ppp
mpls label protocol ldp
mpls ip
!         
interface ATM5/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM5/0.1 point-to-point
 ip address 192.168.0.59 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 40 aal5snap
 mpls ip
!         
router ospf 1
 network 10.127.12.0 0.255.255.255 area 101
 network 192.168.54.0 0.255.255.255 area 101
 network 192.168.58.0 0.255.255.255 area 101
 network 192.168.59.0 0.255.255.255 area 101

PE3 (72K-36-4) Configuration

ip cef
!         
ip vrf vpn2
 rd 200:1 
 route-target export 200:1
 route-target import 200:1
!         
! 
interface Loopback0
 ip address 10.127.21.21 255.255.255.255
 no ip directed-broadcast
!         
interface Ethernet3/0
 ip vrf forwarding vpn2
 ip address 192.168.0.80 255.0.0.0
 no ip directed-broadcast
!         
interface Ethernet3/1
 ip vrf forwarding vpn2
 ip address 192.168.0.81 255.0.0.0
 no ip directed-broadcast
!         
interface Ethernet3/2
 ip address 192.168.0.61 255.0.0.0
 no ip directed-broadcast
mpls label protocol ldp
mpls ip
!         
interface ATM5/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM5/0.1 point-to-point
 ip address 192.168.0.59 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 40 aal5snap
mpls label protocol ldp
mpls ip
!         
interface ATM6/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM6/0.1 point-to-point
 ip address 192.168.0.60 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 20 aal5snap
mpls label protocol ldp
mpls ip
!         
router ospf 1
 network 10.127.21.0.0.255.255.255 area 101
 network 192.168.59.0.0.255.255.255 area 101
 network 192.168.60.0.0.255.255.255 area 101
 network 192.168.61.0.0.255.255.255 area 101
!         
router bgp 200
 neighbor 10.127.22.22 remote-as 200
 neighbor 10.127.22.22 update-source Loopback0
 neighbor 10.127.23.23 remote-as 200
 neighbor 10.127.23.23 update-source Loopback0
 !        
 address-family ipv4 vrf vpn2
 redistribute connected
 neighbor 192.168.0.80 remote-as 300
 neighbor 192.168.0.80 activate
 neighbor 192.168.0.80 as-override
 neighbor 192.168.0.81 remote-as 300
 neighbor 192.168.0.81 activate
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.22.22 activate
 neighbor 10.127.22.22 send-community extended
 neighbor 10.127.23.23 activate
 neighbor 10.127.23.23 send-community extended
 exit-address-family

CSC-CE4 (72K-36-5) Configuration

ip cef
!         
interface Loopback0
 ip address 10.127.10.10 255.255.255.255
 no ip directed-broadcast
!         
interface POS4/0
 ip address 192.168.0.58 255.0.0.0
 no ip directed-broadcast
 encapsulation ppp
mpls label protocol ldp
mpls ip
 clock source internal
!         
interface ATM5/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM5/0.1 point-to-point
 ip address 192.168.0.60 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 0 20 aal5snap
mpls label protocol ldp
mpls ip
!         
interface ATM6/0
 no ip address
 no ip directed-broadcast
 atm clock INTERNAL
 no atm ilmi-keepalive
!         
interface ATM6/0.1 point-to-point
 ip address 192.168.0.57 255.0.0.0
 no ip directed-broadcast
 atm pvc 100 6 33 aal5snap
mpls label protocol ldp
mpls ip
!         
router ospf 1
 network 10.127.10.0 0.255.255.255 area 101
 network 192.168.57.0 0.255.255.255 area 101
 network 192.168.58.0 0.255.255.255 area 101
 network 192.168.60.0 0.255.255.255 area 101

Route Reflector 4 (36K-38-5) Configuration

ip cef
!         
interface Loopback0
 ip address 10.127.22.22 255.255.255.255
!         
interface Ethernet0/1
 ip address 192.168.0.61 255.0.0.0
 mpls label protocol ldp
 mpls ip
!         
interface ATM2/0
 no ip address
 no ip mroute-cache
 atm clock INTERNAL
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!         
interface ATM2/0.1 point-to-point
 ip address 192.168.0.62 255.0.0.0
 atm pvc 100 0 55 aal5snap
 mpls label protocol ldp
 mpls ip
!         
router ospf 1
 log-adjacency-changes
 network 10.127.22.0 0.255.255.255 area 101
 network 192.168.61.0 0.255.255.255 area 101
 network 192.168.62.0 0.255.255.255 area 101
!         
router bgp 200
 no synchronization
 no bgp default ipv4-unicast
 bgp cluster-id 2
 redistribute static
 neighbor 10.127.21.21 remote-as 200
 neighbor 10.127.21.21 update-source Loopback0
 neighbor 10.127.24.24 remote-as 200
 neighbor 10.127.24.24 update-source Loopback0
 neighbor 10.127.25.25 remote-as 200
 neighbor 10.127.25.25 update-source Loopback0
 !        
 address-family ipv4 vrf vpn2
 no auto-summary
 no synchronization
 exit-address-family
 !        
 address-family vpnv4
 neighbor 10.127.21.21 activate
 neighbor 10.127.21.21 route-reflector-client
 neighbor 10.127.21.21 send-community extended
 neighbor 10.127.24.24 activate
 neighbor 10.127.24.24 route-reflector-client
 neighbor 10.127.24.24 send-community extended
 neighbor 10.127.25.25 activate
 neighbor 10.127.25.25 route-reflector-client
 neighbor 10.127.25.25 send-community extended
 exit-address-family

CE2 (36K-36-2) Configuration

ip cef
!
interface Loopback0
 ip address 10.127.26.26.26 255.255.255.255
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 192.168.0.80 255.0.0.0
 no ip directed-broadcast
!         
interface Ethernet0/2
 ip address 192.168.0.82 255.0.0.0
 no ip directed-broadcast
!         
router ospf 300
 redistribute bgp 300
 network 10.127.26.0 0.255.255.255 area 300
 network 192.168.82.0.0.0 0.255.255.255 area 300
!         
router bgp 300
 network 10.127.26.0
 network 192.168.80.0
 network 192.168.82.0
 neighbor 192.168.80.1 remote-as 200

CE3 (36K-36-3) Configuration

ip cef
!         
interface Loopback0
 ip address 10.127.27.27 255.255.255.255
 no ip directed-broadcast
!         
interface Ethernet1/1
 ip address 192.168.0.81 255.0.0.0
 no ip directed-broadcast
!         
interface Ethernet1/2
 ip address 192.168.0.82 255.0.0.0
 no ip directed-broadcast
!         
router ospf 300
 redistribute bgp 300
 network 10.127.27.0 0.255.255.255 area 300
 network 192.168.82.0 0.255.255.255 area 300
!         
router bgp 300
 network 10.127.27.0
 network 192.168.0.0
 network 192.168.82.0
 neighbor 192.168.81.1 remote-as 200

Configuring a Carrier Supporting Carrier Network with a Customer Who Has VPNs at the Network's Edge

Figure 9 shows a carrier supporting carrier network configuration where the customer carrier has VPNs at the network's edge.

Figure 9 Carrier Supporting Carrier Network

Backbone Carrier Configuration

CSC-PE1 (72K-36-9) Configuration

ip cef 
! 
ip vrf vpn1 
rd 100:0 
route-target export 100:0 
route-target import 100:0 
mpls label protocol ldp 
! 
! 
interface Loopback0 
ip address 10.127.14.14 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface Loopback100 
ip vrf forwarding vpn1 
ip address 10.127.22.22 255.255.255.255 
no ip directed-broadcast 
! 
interface ATM1/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
atm clock INTERNAL 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM1/0.1 point-to-point 
ip address 192.168.0.30 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM1/0.2 point-to-point 
ip address 192.168.0.31 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM1/0.3 point-to-point 
ip address 192.168.0.2 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM2/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
atm clock INTERNAL 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM2/0.1 point-to-point 
ip vrf forwarding vpn1 
ip address 192.168.0.15 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM2/0.2 point-to-point 
ip vrf forwarding vpn1 
ip address 192.168.0.16 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM2/0.3 point-to-point 
ip vrf forwarding vpn1 
ip address 192.168.0.17 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 100 
log-adjacency-changes 
redistribute connected subnets 
passive-interface ATM2/0.1 
passive-interface ATM2/0.2 
passive-interface ATM2/0.3 
passive-interface Loopback100 
network 10.127.14.14 0.0.0.0 area 100 
network 192.168.30.1 0.0.255.255 area 100 
network 192.168.30.2 0.0.255.255 area 100 
network 192.168.30.3 0.0.255.255 area 100 
! 
router ospf 200 vrf vpn1 
log-adjacency-changes 
redistribute connected subnets 
redistribute bgp 100 metric-type 1 subnets 
network 10.127.22.22 0.0.0.0 area 200 
network 192.168.30.15 0.0.255.255 area 200 
network 192.168.30.16 0.0.255.255 area 200 
network 192.168.30.17 0.0.255.255 area 200 
! 
router bgp 100 
bgp log-neighbor-changes 
timers bgp 10 30 
neighbor 10.127.11.11 remote-as 100 
neighbor 10.127.11.11 update-source Loopback0 
! 
address-family ipv4 
neighbor 10.127.11.11 activate 
neighbor 10.127.11.11 send-community extended 
no synchronization 
exit-address-family 
! 
address-family vpnv4 
neighbor 10.127.11.11 activate 
neighbor 10.127.11.11 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf vpn1 
redistribute ospf 200 match internal external 1 external 2 
no auto-summary 
no synchronization 
exit-address-family 

P1 (75K-37-3) Configuration

ip cef distributed 
! 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 10.127.12.12 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface ATM1/1/0 
no ip address 
no ip directed-broadcast 
ip route-cache distributed 
atm clock INTERNAL 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM1/1/0.1 point-to-point 
ip address 192.168.0.7 255.255.0.0 
no ip directed-broadcast 
atm pvc 103 0 53 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM1/1/0.2 point-to-point 
ip address 192.168.0.8 255.255.0.0 
no ip directed-broadcast 
atm pvc 104 0 54 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM1/1/0.3 point-to-point 
ip address 192.168.0.9 255.255.0.0 
no ip directed-broadcast 
atm pvc 105 0 55 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM3/0/0 
no ip address 
no ip directed-broadcast 
ip route-cache distributed 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM3/0/0.1 point-to-point 
ip address 192.168.0.1 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
mpls accounting experimental input 
tag-switching ip 
! 
interface ATM3/0/0.2 point-to-point 
ip address 192.168.0.2 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM3/0/0.3 point-to-point 
ip address 192.168.0.3 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 100 
log-adjacency-changes 
redistribute connected subnets 
network 10.127.12.12 0.0.0.0 area 100 
network 192.168.30.1 0.0.255.255 area 100 
network 192.168.30.2 0.0.255.255 area 100 
network 192.168.30.3 0.0.255.255 area 100 
network 192.168.30.7 0.0.255.255 area 100 
network 192.168.30.8 0.0.255.255 area 100 
network 192.168.30.9 0.0.255.255 area 100 

P2 (75K-38-3) Configuration

ip cef distributed 
! 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 10.127.13.13 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface ATM0/1/0 
no ip address 
no ip directed-broadcast 
ip route-cache distributed 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM0/1/0.1 point-to-point 
ip address 192.168.0.7 255.255.0.0 
no ip directed-broadcast 
atm pvc 103 0 53 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM0/1/0.2 point-to-point 
ip address 192.168.0.8 255.255.0.0 
no ip directed-broadcast 
atm pvc 104 0 54 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM0/1/0.3 point-to-point 
ip address 192.168.0.9 255.255.0.0 
no ip directed-broadcast 
atm pvc 105 0 55 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM3/1/0 
no ip address 
no ip directed-broadcast 
ip route-cache distributed 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM3/1/0.1 point-to-point 
ip address 192.168.0.42 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM3/1/0.2 point-to-point 
ip address 192.168.0.5 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM3/1/0.3 point-to-point 
ip address 192.168.0.6 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 100 
log-adjacency-changes 
redistribute connected subnets 
network 10.127.13.13 0.0.0.0 area 100 
network 192.168.30.4 0.0.255.255 area 100 
network 192.168.30.5 0.0.255.255 area 100 
network 192.168.30.6 0.0.255.255 area 100 
network 192.168.30.7 0.0.255.255 area 100 
network 192.168.30.8 0.0.255.255 area 100 
network 192.168.30.9 0.0.255.255 area 100 
! 

CSC-PE2 (72K-36-5) Configuration

ip cef 
! 
ip vrf vpn1 
rd 100:0 
route-target export 100:0 
route-target import 100:0 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 10.127.11.11 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface Loopback100 
ip vrf forwarding vpn1 
ip address 10.127.23.23 255.255.255.255 
no ip directed-broadcast 
! 
interface ATM5/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM5/0.1 point-to-point 
ip vrf forwarding vpn1 
ip address 192.168.0.18 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM5/0.2 point-to-point 
ip vrf forwarding vpn1 
ip address 192.168.0.19 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM5/0.3 point-to-point 
ip vrf forwarding vpn1 
ip address 192.168.0.20 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM6/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM6/0.1 point-to-point 
ip address 192.168.0.4 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM6/0.2 point-to-point 
ip address 192.168.0.5 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM6/0.3 point-to-point 
ip address 192.168.0.6 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 100 
log-adjacency-changes 
redistribute connected subnets 
passive-interface ATM5/0.1 
passive-interface ATM5/0.2 
passive-interface ATM5/0.3 
passive-interface Loopback100 
network 10.127.11.11 0.0.0.0 area 100 
network 192.168.30.4 0.0.255.255 area 100 
network 192.168.30.5 0.0.255.255 area 100 
network 192.168.30.6 0.0.255.255 area 100 
! 
router ospf 200 vrf vpn1 
log-adjacency-changes 
redistribute connected subnets 
redistribute bgp 100 metric-type 1 subnets 
network 10.127.23.23 0.0.0.0 area 200 
network 192.168.30.18 0.0.255.255 area 200 
network 192.168.30.19 0.0.255.255 area 200 
network 192.168.30.20 0.0.255.255 area 200 
! 
router bgp 100 
bgp log-neighbor-changes 
timers bgp 10 30 
neighbor 10.127.14.14 remote-as 100 
neighbor 10.127.14.14 update-source Loopback0 
! 
address-family ipv4 
neighbor 10.127.14.14 activate 
neighbor 10.127.14.14 send-community extended 
no synchronization 
exit-address-family 
! 
address-family vpnv4 
neighbor 10.127.14.14 activate 
neighbor 10.127.14.14 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf vpn1 
redistribute ospf 200 match internal external 1 external 2 
no auto-summary 
no synchronization 
exit-address-family 

Customer Carrier Site 1 Configuration

CSC-CE1 (72K-36-8) Configuration

ip cef 
! 
mpls label protocol ldp 
!
interface Loopback0 
ip address 10.127.15.15 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface ATM1/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM1/0.1 point-to-point 
ip address 192.168.0.15 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM1/0.2 point-to-point 
ip address 192.168.0.16 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM1/0.3 point-to-point 
ip address 192.168.0.17 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface Ethernet3/1 
ip address 192.168.0.10 255.255.0.0 
no ip directed-broadcast 
no ip mroute-cache 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 200 
log-adjacency-changes 
redistribute connected subnets 
network 10.127.15.15 0.0.0.0 area 200 
network 192.168.30.10 0.0.255.255 area 200 
network 192.168.30.15 0.0.255.255 area 200 
network 192.168.30.16 0.0.255.255 area 200 
network 192.168.30.17 0.0.255.255 area 200 

PE1 (72K-36-7) Configuration

ip cef 
! 
ip vrf customersite 
rd 200:1 
route-target export 200:1 
route-target import 200:1 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 10.127.16.16 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface Ethernet3/1 
ip vrf forwarding customersite 
ip address 192.168.0.35 255.255.0.0 
no ip directed-broadcast 
no ip mroute-cache 
! 
interface Ethernet3/2 
ip address 192.168.0.30 255.255.0.0 
no ip directed-broadcast 
no ip mroute-cache 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 200 
log-adjacency-changes 
redistribute connected subnets 
passive-interface Ethernet3/1 
network 10.127.16.16 0.0.0.0 area 200 
network 192.168.30.10 0.0.255.255 area 200 
! 
router bgp 200 
no bgp default ipv4-unicast 
bgp log-neighbor-changes 
timers bgp 10 30 
neighbor 10.127.18.18 remote-as 200 
neighbor 10.127.18.18 update-source Loopback0 
! 
address-family ipv4 
neighbor 10.127.18.18 activate 
neighbor 10.127.18.18 send-community extended 
no synchronization 
exit-address-family 
! 
address-family vpnv4 
neighbor 10.127.18.18 activate 
neighbor 10.127.18.18 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf customersite 
neighbor 192.168.35.01 remote-as 300 
neighbor 192.168.35.01 activate 
neighbor 192.168.35.01 as-override 
neighbor 192.168.35.01 advertisement-interval 5 
no auto-summary 
no synchronization 
exit-address-family 

CE1 (36K-36-1) Configuration

ip cef 
! 
interface Loopback0 
ip address 10.127.19.19 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0/2 
ip address 192.168.0.30 255.255.0.0 
no ip directed-broadcast 
! 
router ospf 300 
log-adjacency-changes 
redistribute connected subnets 
redistribute bgp 300 subnets 
passive-interface Ethernet0/2 
network 10.127.19.19 0.0.0.0 area 300 
! 
router bgp 300 
no synchronization 
bgp log-neighbor-changes 
timers bgp 10 30 
redistribute connected 
redistribute ospf 300 match internal external 1 external 2 
neighbor 192.168.35.2 remote-as 200 
neighbor 192.168.35.2 advertisement-interval 5 
no auto-summary 

Customer Carrier Site 2 Configuration

CSC-CE2 (72K-36-4) Configuration

ip cef 
! 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 10.127.17.17 255.255.255.255 
no ip directed-broadcast 
! 
interface ATM5/0 
no ip address 
no ip directed-broadcast 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM5/0.1 point-to-point 
ip address 192.168.0.11 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM5/0.2 point-to-point 
ip address 192.168.0.12 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM5/0.3 point-to-point 
ip address 192.168.0.13 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM6/0 
no ip address 
no ip directed-broadcast 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM6/0.1 point-to-point 
ip address 192.168.0.18 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM6/0.2 point-to-point 
ip address 192.168.0.19 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM6/0.3 point-to-point 
ip address 192.168.0.20 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 200 
log-adjacency-changes 
redistribute connected subnets 
network 10.127.17.17 0.0.0.0 area 200 
network 192.168.30.11 0.0.255.255 area 200 
network 192.168.30.12 0.0.255.255 area 200 
network 192.168.30.13 0.0.255.255 area 200 
network 192.168.30.18 0.0.255.255 area 200 
network 192.168.30.19 0.0.255.255 area 200 
network 192.168.30.20 0.0.255.255 area 200 

PE2 (72K-36-6) Configuration

ip cef 
! 
ip vrf customersite 
rd 200:1 
route-target export 200:1 
route-target import 200:1 
mpls label protocol ldp 
! 
interface Loopback0 
ip address 10.127.18.18 255.255.255.255 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
! 
interface Ethernet3/0 
ip vrf forwarding customersite 
ip address 192.168.0.29 255.255.0.0 
no ip directed-broadcast 
! 
interface Ethernet3/1 
ip vrf forwarding customersite 
ip address 192.168.0.30 255.255.0.0 
no ip directed-broadcast 
! 
interface ATM5/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
atm clock INTERNAL 
atm sonet stm-1 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 
! 
interface ATM5/0.1 point-to-point 
ip address 192.168.0.11 255.255.0.0 
no ip directed-broadcast 
atm pvc 100 0 50 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM5/0.2 point-to-point 
ip address 192.168.0.12 255.255.0.0 
no ip directed-broadcast 
atm pvc 101 0 51 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
interface ATM5/0.3 point-to-point 
ip address 192.168.0.13 255.255.0.0 
no ip directed-broadcast 
atm pvc 102 0 52 aal5snap 
no atm enable-ilmi-trap 
mpls label protocol ldp 
tag-switching ip 
! 
router ospf 200 
log-adjacency-changes 
redistribute connected subnets 
passive-interface Ethernet3/0 
passive-interface Ethernet3/1 
network 10.127.18.18 0.0.0.0 area 200 
network 192.168.30.11 0.0.255.255 area 200 
network 192.168.30.12 0.0.255.255 area 200 
network 192.168.30.13 0.0.255.255 area 200 
! 
router bgp 200 
no bgp default ipv4-unicast 
bgp log-neighbor-changes 
timers bgp 10 30 
neighbor 10.127.16.16 remote-as 200 
neighbor 10.127.16.16 update-source Loopback0 
! 
address-family ipv4 
neighbor 10.127.16.16 activate 
neighbor 10.127.16.16 send-community extended 
no synchronization 
exit-address-family 
! 
address-family vpnv4 
neighbor 10.127.16.16 activate 
neighbor 10.127.16.16 send-community extended 
exit-address-family 
! 
address-family ipv4 vrf customersite 
neighbor 192.168.29.1 remote-as 300 
neighbor 192.168.29.1 activate 
neighbor 192.168.29.1 as-override 
neighbor 192.168.29.1 advertisement-interval 5 
neighbor 192.168.30.1 remote-as 300 
neighbor 192.168.30.1 activate 
neighbor 192.168.30.1 as-override 
neighbor 192.168.30.1 advertisement-interval 5 
no auto-summary 
no synchronization 
exit-address-family 

CE2 (36K-38-4) Configuration

ip cef 
! 
interface Loopback0 
ip address 10.127.21.21 255.255.255.255 
! 
interface Ethernet1/3 
ip address 192.168.0.29 255.255.0.0 
! 
interface Ethernet5/0 
ip address 192.168.0.14 255.255.0.0 
! 
router ospf 300 
log-adjacency-changes 
redistribute connected subnets 
redistribute bgp 300 subnets 
passive-interface Ethernet1/3 
network 10.127.21.21 0.0.0.0 area 300 
network 192.168.30.14.0.0.255.255 area 300 
! 
router bgp 300 
no synchronization 
timers bgp 10 30 
redistribute connected 
redistribute ospf 300 match internal external 1 external 2 
neighbor 192.168.29.2 remote-as 200 
neighbor 192.168.29.2 advertisement-interval 5 
no auto-summary 

CE3 (36K-38-5) Configuration

ip cef 
! 
interface Loopback0 
ip address 10.127.20.20 255.255.255.255 
no ip directed-broadcast 
! 
interface Ethernet0/2 
ip address 192.168.0.30 255.255.0.0 
no ip directed-broadcast 
! 
interface Ethernet0/3 
ip address 192.168.0.14 255.255.0.0 
no ip directed-broadcast 
! 
router ospf 300 
log-adjacency-changes 
redistribute connected subnets 
redistribute bgp 300 subnets 
passive-interface Ethernet0/2 
network 10.127.20.20 0.0.0.0 area 300 
network 192.168.30.14 0.0.255.255 area 300 
! 
router bgp 300 
no synchronization 
bgp log-neighbor-changes 
timers bgp 10 30 
redistribute connected 
redistribute ospf 300 match internal external 1 external 2 
neighbor 192.168.30.2 remote-as 200 
neighbor 192.168.30.2 advertisement-interval 5 
no auto-summary 

Command Reference

The feature requires no new or modified commands. All commands used with this feature are documented in the Cisco IOS Release 12.2 command reference publications.

Glossary

AS—autonomous system. A collection of networks under a common administration sharing a common routing strategy.

ASBR—autonomous system boundary router. An edge router located between an Open Shortest Path First (OSPF) autonomous system and a non-OSPF network. ASBRs run both OSPF and another routing protocol, such as RIP.

BGP—Border Gateway Protocol. A routing protocol that exchanges network reachability information with other BGP systems, which may be within the same autonomous system or between multiple autonomous systems.

CE router—customer edge router. A router that is part of a customer network and that interfaces to a provider edge (PE) router.

EBGP—External Border Gateway Protocol. A Border Gateway Protocol between routers located in different autonomous systems.

IBGP—Internal Border Gateway Protocol. A Border Gateway Protocol between routers within the same autonomous system.

LDP—label distribution protocol. A standard protocol used by MPLS-enabled routers to assign the labels (addresses) used to forward packets.

LSP—label-switched path. A sequence of hops in which a packet travels from one router to another router by means of label switching mechanisms. A label-switched path can be established dynamically, based on normal routing mechanisms, or through configuration.

LSR—label switching router. An LSR forwards packets in an MPLS network by looking only at the fixed-length label.

MPLS—Multiprotocol Label Switching. MPLS is a method for forwarding packets (frames) through a network. It enables routers at the edge of a network to apply labels to packets (frames). ATM switches or existing routers in the network core can switch packets according to the labels.

Multihop BGP—A Border Gateway Protocol between two routers in different autonomous systems that are more than one hop away from each other.

NLRINetwork Layer Reachability Information. BGP routers exchange network layer reachability information, which includes the full route (BGP AS numbers) to reach the destination network.

PE router—provider edge router. A router that is part of a service provider's network connected to a customer edge (CE) router. All MPLS VPN processing occurs in the PE router.

POP—point of presence. An access point to the Internet. A POP has a unique IP address. The ISP or online service provider (such as AOL) has one or more POPs on the Internet. ISP users dial into the POP to connect to the Internet. A POP can reside in rented space owned by the telecommunications carrier (such as Sprint) to which the ISP is connected. A POP usually includes routers, digital/analog call aggregators, servers, and frequently frame relay or ATM switches.

RD—route distinguisher. An 8-byte value that is concatenated with an IPv4 prefix to create a unique VPN-IPv4 prefix.

RIP—Routing Information Protocol. An internal gateway protocol used to exchange routing information within an autonomous system. RIP uses hop count as a routing metric.

VPN—Virtual Private Network. VPNs connect branch offices and remote users through a shared or public network, such as the Internet, and provide the same security and availability as a private network. Because VPNs use an existing shared WAN infrastructure, costs are lower and deployment is faster than is the case with traditional private networks. A VPN can consist of sites (or systems) that are all from the same enterprise (intranet) or from different enterprises (extranet); it can consist of sites (or systems) that all attach to the same service provider backbone or to different service provider backbones.

VPN-IPv4—A prefix that consists of a customer VPN address that has been made unique by the addition of an 8-byte route distinguisher.

VRF table—VPN routing/forwarding table. A VRF table includes the routing information that defines a customer VPN site that is attached to a PE router. A VRF table consists of the following elements:

An IP routing table

A derived forwarding table

A set of interfaces that use the forwarding table

A set of rules and routing protocols that determine what goes into the forwarding table

Copyright © 2005 Cisco Systems, Inc. All rights reserved