Guest

Cisco IOS Software Releases 12.0 S

MPLS Scalability Enhancements for the ATM LSR

  • Viewing Options

  • PDF (250.8 KB)
  • Feedback
MPLS Scalability Enhancements for the ATM LSR

Table Of Contents

MPLS Scalability Enhancements for the ATM LSR

Feature Overview

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Sample MPLS ATM Network

Configuring the MPLS ATM Network

Configuring the PE Routers

Verifying the Configuration

Configuration Examples

Disabling the Creation of LSPs

Efficiently Using LVC space for Cisco 12000 Series Routers

LSC1 Configuration

BPX1 Configuration

Routing Protocol Configuration

GSR1 Configuration

GSR2 Configuration

Command Reference

Command Conventions

mpls ldp request-tags for


MPLS Scalability Enhancements for the ATM LSR


Feature History

Release
Modification

12.0(14)ST

This feature was introduced.

12.0(22)S

This feature was integrated to Cisco IOS Release 12.0(22)S.


This document describes how to prevent label-switched paths (LSPs) from being created in an MPLS network. This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuration Tasks

Verifying the Configuration

Command Reference

Feature Overview

Some LSPs are often unnecessary between some label-switched edge routers (LERs) in an MPLS network. Every time a new destination is created, LSPs are created from all LERs in the MPLS network to the new destination. You can use the mpls ldp request-tags for command with an access list at an LER to restrict the destinations for which a downstream-on-demand request is issued. You specify the destination IP addresses that you want to enable/disable from creating LSPs.

Benefits

This command allows you to permit/deny creation of some LSPs, while preventing the creation of others. Using this command reduces the number of LSPs in an MPLS network, which reduces the VC usage in the network.

Restrictions

This section details some of the restrictions of this feature.

Do not use the mpls disable headend-vc command.

When using access lists to prevent the creation of LSPs, do not disable the router from acting as an edge router with the mpls disable headend-vc command, which prevents all LSPs from being established.

Cisco 12000 routers need special LVC configuration for efficient use of VCs.

A Cisco 12000 router (GSR) ATM interface used for MPLS cannot use the entire virtual path identifier (VPI) range configured on the subinterface. Attempts to create label switched controlled virtual circuits (LVCs) within the configured range may be rejected by the line card drivers. This can occur when you use the GSR ATM OC-3 or OC-12 interfaces running MPLS.

The following paragraphs show the commands for efficiently using LVC space. For a configuration example, see "Efficiently Using LVC space for Cisco 12000 Series Routers".

For the Quad OC-3 or Quad OC-12

On the main interface, use 512 VCs per VPI. Enter the following command:

atm vc-per-vp 512

On the MPLS subinterface, match the hardware limit of 7 VPIs and set the control-vc to within that range by entering the following commands:

mpls atm control-vc 2 32
mpls atm vpi 2-8 

For the Single-Port OC-12

On the main interface, use 1024 VCs per VPI . Enter the following command:

atm vc-per-vp 1024 

On the MPLS subinterface, match the hardware limit of 15 VPIs and set the control-vc to fall within that range by entering the following commands:

mpls atm control-vc 2 32
mpls atm vpi 2-16

You must configure the control-vc of the LDP neighbor so that it uses the same VPI and VCI.

Related Documents

For more information about standard and extended access lists, see the following documents:

Cisco IOS IP Configuration Guide, Release 12.2, Configuring IP Services

Cisco IOS Security Configuration Guide, Release 12.2, Access Control Lists: Overview and Guidelines

Supported Platforms

This feature is supported on the following platforms:

Cisco 7200 series

Cisco 7500 series

Cisco 12000 series (engine 0)

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that are supported on specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

The MPLS LSC supports no new or modified standards.

MIBs

The MPLS LSC supports no new or modified MIBs.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

RFCs

The MPLS LSC supports no new or modified RFCs.

Configuration Tasks

The following sections explain how to configure the network to prevent the creation of LSPs from specified IP addresses:

Sample MPLS ATM Network

Configuring the MPLS ATM Network

Configuring the PE Routers

Sample MPLS ATM Network

Figure 1 is an MPLS ATM network that consists of the following elements:

The PE routers in the virtual private network require LSPs to communicate with each other.

All the PE routers are in network 1 (198.x.x.x).

All the IGP IP addresses are in network 2 (192.x.x.x).

If numbered interfaces are required (for network management or other purposes), they are placed in network 2 (192.x.x.x).

Figure 1 Sample MPLS ATM Network

The following configuration tasks use mpls ldp request-tags for commands to accomplish the following:

Allow the PE routers in network 1 to create LSPs and communicate with each other, but prevent creation of LSPs from the PE routers to the MPLS ATM network,

Prevent LSPs from being created in the MPLS ATM network (network 2) and prevent from the MPLS ATM network to the PE routers.

Performing these tasks reduces the number of LSPs in the MPLS ATM network, which reduces the VC usage in the network.

Configuring the MPLS ATM Network

In the configuration file of the routers in the MPLS ATM network, enter the following commands:

 
Command
Purpose

Step 1 

mpls ldp request-tags for acl_1

Initiates the request to prevent the creation of LSPs and specifies the access list name (acl_1).

Step 2 

ip access-list standard acl_1

Creates a standard IP access list.

Step 3 

deny   192.0.0.0 0.255.255.255

Denies access to all routers with an IP address of 192.x.x.x. This prevents LSPs from being created in the MPLS ATM network.

Step 4 

deny   198.0.0.0 0.255.255.255

Denies access to all routers with an IP address of 198.x.x.x. This prevents LSPs from being created between the MPLS ATM network and the PE routers.

Step 5 

permit any

Permits all other IP addresses.

Configuring the PE Routers

In the configuration file of the PE routers, enter the following commands:

 
Command
Purpose

Step 1 

mpls ldp request-tags for acl_2

Initiates the request to prevent the creation of LSPs and specifies the access list name (acl_2).

Step 2 

ip access-list standard acl_2

Creates a standard IP access list.

Step 3 

deny   192.0.0.0 0.255.255.255

Denies access to all routers with an IP address of 192.x.x.x. This prevents LSPs from being created between the PE routers and MPLS ATM network.

Step 4 

permit any

Permits all other IP addresses.

Verifying the Configuration

Use the following commands to verify the configuration:

show mpls atm-ldp bindings

Displays the current headend, tailend, and transit dynamic tag bindings for the destinations.

show ip route

Displays IP routing table entries.

show mpls forwarding-table

Displays the contents of the label forwarding information base (LFIB).


Configuration Examples

This section contains the following configuration examples:

Disabling the Creation of LSPs

Efficiently Using LVC space for Cisco 12000 Series Routers

Disabling the Creation of LSPs

The following examples of the mpls ldp request-tags for command use Figure 2 as a basis. The examples show different ways to disable the creation of LSPs from the LSC to the edge GSR, and from the edge GSRs to the LSC.


Note In this example, the LSCs are running 12.1(5)T software. Cisco IOS Release 12.0(14ST) does not support LSCs.


Figure 2 Sample Configuration

Using a Numbered Access List

The following examples use a numbered access list to restrict creation of LSPs.


Note With LSCs, you disable the LSC from acting as an edge router with the mpls disable headend-vc command, which prevents all LSPs from being established. The following examples use the mpls ldp request-tags for command on the LSC. However, it is recommended that you use the mpls disable headend-vc command.


Preventing LSPs from the LSC to the Edge LSRs

The following example prevents LSPs from being established from the LSC to all 198.x.x.x destinations. However, transit LSPs are allowed between 198.x.x.x destinations. Add the following commands to the LSC configuration:

mpls ldp request-tags for 1
access-list 1 deny 198.0.0.0 0.255.255.255
access-list 1 permit any

Preventing LSPs from the Edge LSRs to the LSC

The following example prevents headend LVCs from being established from edge LSR 1 and edge GSR 2 to the LSC (192.x.x.x). However, transit LSPs are allowed between 198.x.x.x destinations. Add the following commands to the edge GSR 1 and 2 configurations:

mpls ldp request-tags for 1
access-list 1 deny 192.0.0.0 0.255.255.255
access-list 1 permit any

Using a Named Access List

The following examples use a named access list to perform the same tasks as the previous examples.

mpls ldp request-tags for nolervcs
ip access-list standard nolervcs
deny   198.0.0.0 0.255.255.255
permit any

mpls ldp request-tags for nolervcs
ip access-list standard nolervcs
deny 192.0.0.0 0.255.255.255
permit any

Specifying Exact Match IP Addresses with an Access List

The following examples use exact IP addresses to perform the same tasks as the previous examples.

mpls ldp request-tags for 1
access-list 1 deny 198.5.0.1 0.0.0.0
access-list 1 deny 198.5.0.2 0.0.0.0
access-list 1 permit any

mpls ldp request-tags for 1
access-list 1 deny 192.6.53.1 0.0.0.0
access-list 1 permit any

Efficiently Using LVC space for Cisco 12000 Series Routers

The following configuration shows how to set up the ATM interfaces so that LVC space is optimized on a Cisco 12000 series router.

Figure 3 Cisco 12000 Series Router Configuration Example

LSC1 Configuration

ip routing
ip cef
mpls ip
!
int loopback0
ip address 12.12.12.12.255.255.255.255
!
int atm1/0
tag-control-protocol vsi slaves 18
!
interface XTagATM101
ip unnumbered Loopback0
extended-port ATM2/0 vsi 0x000A0100
mpls atm control-vc 2 32
mpls atm vpi 2-8
mpls ip
!
interface XTagATM103
ip unnumbered Loopback0
extended-port ATM2/0 vsi 0x000A0300
mpls atm control-vc 2 32
mpls atm vpi 2-8
mpls ip

BPX1 Configuration

Port 9.1

uptrk 9.1
cnfrscr 9.1 256 248207 N y 1 e 512 5000 2 15 26000 100000
addshelf 9.1 V

Port 10.1

uptrk 10.1
cnfrscr 10.1 256 248207 N y 1 e 512 5000 2 15 26000 100000

Port 10.3

uptrk 10.3
cnfrscr 10.3 256 248207 N y 1 e 512 5000 2 15 26000 100000

Routing Protocol Configuration

router ospf 100
network 12.0.0.0.0.255.255.255.255 area 100

GSR1 Configuration

ip routing
ip cef
mpls ip
!
int loopback0
ip address 10.10.10.10.255.255.255.255
int atm5/0
atm vc-per-vp 512
!
interface ATM5/0.1 tag-switching
ip unnumbered Loopback0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls atm control-vc 2 32
mpls atm vpi 2-8
mpls ip
!
router ospf 100
network 10.0.0.0.0.255.255.255.255 area 100

GSR2 Configuration

ip routing
ip cef
mpls ip
!
int loopback0
ip address 11.11.11.11.255.255.255.255
!
int atm5/0
atm vc-per-vp 512
interface ATM5/0.1 tag-switching
ip unnumbered Loopback0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls atm control-vc 2 32
mpls atm vpi 2-8
mpls ip
!
router ospf 100
router (config-router)# network 11.0.0.0.0.255.255.255.255 area 100

Command Reference

This section describes the CLI commands that you can use to disable the creation of LSPs:

mpls ldp request-tags for

All other commands used with this feature are documented in the Cisco IOS command reference publications.

Command Conventions

boldface font

Commands and keywords are in boldface type.

italic font

Arguments for which you supply values are in italics. In a context that does not allow italics, arguments are enclosed in angle brackets < >.

[ ]

Elements in square brackets are optional.

{ x | y | z }

Alternative keywords are grouped in braces and separated by vertical bars.

[ x | y | z ]

Optional keywords are grouped in brackets and separated by vertical bars.


mpls ldp request-tags for

To restrict the creation of LVCs through the use of access lists on the label edge router, use the mpls ldp request-tags for global configuration command. Use the no form of this command to disable this feature.

mpls ldp request-tags for access list

no mpls ldp request-tags for access list

Syntax Description

access list

A named or numbered standard IP access list.


Defaults

No default behavior or values

Command Modes

Global configuration

Command History

Release
Modification

12.1(5)T

This command was introduced as tag-switching request-tags for.

12.0(14)ST

This command was changed to reflect MPLS terminology.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Usage Guidelines

The command includes the following usage guidelines:

You can specify either an access list number or name.

When creating an access list, the end of the access list contains an implicit deny statement for everything if it did not find a match before reaching the end.

If you omit the mask from an IP host address access list specification, 0.0.0.0 is assumed to be the mask.

Examples

In the following example, headend LVCs are prevented from being established from the core router to all 198.x.x.x destinations. The following commands are added to the core router configuration:

mpls ldp request-tags for 1
access-list 1 deny 198.0.0.0 0.255.255.255
access-list 1 permit any

Related Commands

Command
Description

access list

Creates access lists.