Guest

Cisco IOS Software Releases 12.0 S

Any Transport over MPLS (AToM) Sequencing Support

  • Viewing Options

  • PDF (291.0 KB)
  • Feedback
Any Transport over MPLS Sequencing Support

Table Of Contents

Any Transport over MPLS Sequencing Support

Contents

Restrictions for AToM Sequencing Support

Information About AToM Sequencing Support

How AToM Sequencing Works

Circumstances That Can Reset AToM Sequencing

Resetting Sequence Numbering When the Disposition PE Router Receives too Many Out-of-Order Packets

How to Configure AToM Sequencing

Configuring AToM Sequencing

Prerequisites

Resetting Sequence Numbering When the Disposition PE Router Receives too Many Out-of-Order Packets

Verifying the AToM Sequencing Configuration

Configuration Examples for AToM Sequencing

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

clear mpls counters

sequencing

Feature Information for AToM Sequencing Support


Any Transport over MPLS Sequencing Support


First Published: August 9, 2004
Last Updated: February 28, 2006

The Any Transport over MPLS (AToM) Sequencing Support feature enables the sequencing of packets in an AToM network. When you enable AToM sequencing, each packet entering the imposition provider edge (PE) router is assigned a sequence number. The disposition PE router checks the sequence number of the packet. If the packet is out of order, the packet is dropped. The number of dropped out-of-order packets is recorded. You have the option of resetting the packet sequencing if the number of out-of-order packets exceeds the specified limit.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for AToM Sequencing Support" section.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Restrictions for AToM Sequencing Support

Information About AToM Sequencing Support

How to Configure AToM Sequencing

Configuration Examples for AToM Sequencing

Additional References

Command Reference

Feature Information for AToM Sequencing Support

Restrictions for AToM Sequencing Support

The sequence number is encapsulated in the control word. The PE routers agree on the use of the control word during Label Distribution Protocol (LDP) label binding. If the control word is disabled, AToM sequencing does not work, even if the feature is enabled.

Sequencing is not supported with L2VPN Interworking.

On Cisco 12000 series Engine 3 line cards, AToM Sequencing is supported only without caching.

This feature is not supported on Cisco 12000 Series Four-Port Gigabit Ethernet line cards.

When the Cisco 12000 series Engine 5 line card reads the sequence number of a packet arriving in one of its four pipelines , the line card momentarily halts traffic on its other three pipelines in order not to have any outgoing packets be out of sequence. Therefore, all information carried by the three other pipelines is momentarily halted. This reduces the line rate.

Information About AToM Sequencing Support

To configure AToM Sequencing, you need to understand the following concepts:

How AToM Sequencing Works

Circumstances That Can Reset AToM Sequencing

Resetting Sequence Numbering When the Disposition PE Router Receives too Many Out-of-Order Packets

How AToM Sequencing Works

This feature enables the sequencing of packets in an AToM network. When you enable AToM sequencing, each packet entering the imposition PE router is assigned a sequence number, from 1 to 65535. The disposition PE router checks the sequence number of the packet. If the packet is out of order, the packet is dropped. The number of out-of-order packets that are dropped is recorded. You can reset the packet sequencing if the number of out-of-order packets exceeds the specified limit. For example, you can enable a reset of packet sequencing after 1000 out-of-order packets have been received.

On Cisco 12000 series Engine 3 and Engine 5 line cards, sequencing processing is performed only on the hardware switching path. Any sequenced packets punted to the line card exception switching path or to router processing switching paths are processed as non-sequenced packets.

Circumstances That Can Reset AToM Sequencing

The following conditions can cause AToM sequencing to be reset:

The imposition PE router receives and accepts a new remote VC label.

The disposition PE router allocates and advertises a new local VC label to its peer. Note however, that AToM sequencing is not reset when a router readvertises the same VC label to update information, such as interface parameters.

An AToM VC is unprovisioned through the no xconnect command.

The clear mpls counters command is entered.

The line card on which an AToM VC is configured is removed or reset.

The configuration changes from Cisco Express Forwarding to Distributed Cisco Express Forwarding or from Distributed Cisco Express Forwarding to Cisco Express Forwarding.

When a local router withdraws a VC label or when a remote router releases a VC label, AToM allocates a new VC label. This prevents confusion that could occur if AToM readvertised the same label.

Resetting Sequence Numbering When the Disposition PE Router Receives too Many Out-of-Order Packets

If the disposition PE router receives too many out-of-order packets, it might mean that the imposition and disposition PE routers are hopelessly out of sync. You can use the clear mpls counters command to clear the packets. You can also customize the disposition PE router so that it resets sequencing after it receives more than the specified number of out-of-order packets.

How to Configure AToM Sequencing

This section contains the following procedures:

Configuring AToM Sequencing

Verifying the AToM Sequencing Configuration

Configuring AToM Sequencing

This section explains how to enable AToM to sequence packets. You enable sequencing on both the imposition and the disposition PE routers. The command keywords you use depend on which of those routers you are configuring.


Note You can enable AToM sequencing as part of the pseudowire class configuration or as part of the xconnect command. The following configuration steps explain how to configure AToM sequencing as part of the pseudowire class, which is the preferred method.


Prerequisites

Before configuring AToM Sequencing, make sure that all AToM VCs and features have been configured. See the Any Transport over MPLS documentation for information about configuring AToM.

SUMMARY STEPS

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation mpls

5. sequencing {transmit | receive | both | resync number}

6. sequencing resync {number}

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

pseudowire-class name

Example:

Router(config)# pseudowire-class atom

Establishes a pseudowire class with a name that you specify. Enters pseudowire configuration mode.

Step 4 

encapsulation mpls

Example:

Router(config-pw)# encapsulation mpls

Specifies the tunneling encapsulation. For AToM, the encapsulation type is mpls.

Step 5 

sequencing {transmit | receive | both | resync number}

Example:

Router(config-pw)# sequencing transmit

Specifies that sequencing should be enabled on the router. For the imposition PE router, use the transmit or both keyword. For the disposition PE router, use the receive or both keyword.

Step 6 

sequencing resync number

Example:

Router(config-pw)# sequencing resync 1000

(Optional) To resync sequencing with the peering PE router after the disposition router receives more than a specified number of out-of-order packets, use the resync keyword.

Resetting Sequence Numbering When the Disposition PE Router Receives too Many Out-of-Order Packets

If the disposition PE router receives too many out-of-order packets, it might mean that the imposition and disposition PE routers are hopelessly out of sync. You can specify the sequencing resync command on the disposition PE router so that it resets sequencing after it receives more than the specified number of out-of-order packets.

You can also use the clear mpls counters command to clear the packets.

The following example shows how the clear mpls counters command works. The show mpls l2 vc detail command shows that 15 packets were received and sent, 1656 bytes were received, and 1986 bytes were sent. The clear mpls counters command clears the counters. The second show mpls l2 transport vc detail command shows that no bytes or packets were received or sent.

Router# show mpls l2 vc detail 

Local interface: Et0/0.10 up, line protocol up, Eth VLAN 10 up
    MPLS VC type is Eth VLAN, interworking type is Ethernet
    Destination address: 10.0.0.2, VC ID: 10, VC status: up
        Output interface: Et1/0, imposed label stack {16}
        Preferred path: not configured
        Default path: active
        Next hop: 10.0.0.2
    Create time: 00:19:35, last status change time: 00:19:09
    Signaling protocol: LDP, peer 10.0.0.2:0 up
        MPLS VC labels: local 16, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description:
    Sequencing: receive enabled, send enabled
    VC statistics:
        packet totals: receive 15, send 15 <---- packet totals
        byte totals:   receive 1656, send 1986 <---- byte totals
        packet drops:  receive 0, seq error 0, send 0
 
Router# clear mpls counters 

Clear "show mpls forwarding-table" counters [confirm] mpls forward 
counters cleared
 
Router# show mpls l2 vc detail 

Local interface: Et0/0.10 up, line protocol up, Eth VLAN 10 up
    MPLS VC type is Eth VLAN, interworking type is Ethernet
    Destination address: 10.0.0.2, VC ID: 10, VC status: up
        Output interface: Et1/0, imposed label stack {16}
        Preferred path: not configured
        Default path: active
        Next hop: 10.0.0.2
    Create time: 00:22:55, last status change time: 00:22:29
    Signaling protocol: LDP, peer 10.0.0.2:0 up
        MPLS VC labels: local 16, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description:
    Sequencing: receive enabled, send enabled
    VC statistics:
        packet totals: receive 0, send 0 <---- packet totals
        byte totals:   receive 0, send 0 <---- byte totals
        packet drops:  receive 0, seq error 0, send 0

Verifying the AToM Sequencing Configuration

To verify that the PE routers are correctly set up to perform AToM sequencing, issue the show mpls l2transport vc detail command. The output shows:

Sequencing is enabled in both the imposition and disposition directions.

The transmit and expected receive sequence numbers.

The number of out-of-order packets (seq error).

Router# show mpls l2transport vc 200101110 detail 

Local interface: AT2/0 up, line protocol up, ATM AAL5 101/110 up
  Destination address: 10.1.1.1, VC ID: 200101110, VC status: up
    Preferred path: not configured  
    Default path: active
    Next hop: point2point
    Output interface: AT1/7.1, imposed label stack {22}
  Create time: 00:01:12, last status change time: 00:01:12
  Signaling protocol: LDP, peer 10.1.1.1:0 up
    MPLS VC labels: local 21, remote 22 
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description: 
  Sequencing: receive enabled, send enabled
  VC statistics:
    packet totals: receive 8290, send 3797
    byte totals:   receive 961416, send 470828
    packet drops:  receive 0, seq error 0, send 0

Configuration Examples for AToM Sequencing

The following example shows two PE routers set up for AToM sequencing. PE1 is the imposition router and is enabled to transmit sequenced packets. PE2 is the disposition router and is enabled to receive sequenced packets. PE2 is also enabled to reset sequencing if it receives more than 200 out-of-order packets.

PE1
PE2

ip cef

!

mpls ip

mpls label protocol ldp

tag-switching tdp router-id Loopback0

!

pseudowire-class atom

encapsulation mpls

sequencing transmit

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface ATM5/0

no ip address

pvc 0/100 l2transport

xconnect 10.9.9.9 6 pw-class atom

!

! IGP for MPLS

router ospf 10

log-adjacency-changes

auto-cost reference-bandwidth 1000

network 10.8.8.8 0.0.0.0 area 0

network 10.17.1.10 0.0.0.255 area 0

ip cef

!

mpls ip

mpls label protocol ldp

tag-switching tdp router-id Loopback0

!

pseudowire-class atom

encapsulation mpls

sequencing receive

sequencing resync 200

!

interface Loopback0

ip address 10.9.9.9 255.255.255.255

!

interface ATM2/0

no ip address

pvc 0/100 l2transport

xconnect 10.8.8.8 6 pw-class atom


! IGP for MPLS

router ospf 10

log-adjacency-changes

auto-cost reference-bandwidth 1000

network 10.9.9.9 0.0.0.0 area 0

network 10.18.1.10 0.0.0.255 area 0


Additional References

The following sections provide references related to this feature.

Related Documents


Standards

Standards
Title

draft-martini-l2circuit-trans-mpls-10.txt

Transport of Layer 2 Frames Over MPLS

draft-martini-l2circuit-encap-mpls-01.txt

Encapsulation Methods for Transport of Layer 2 Frames Over MPLS


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

RFC 3032

MPLS Label Stack Encoding

RFC 3036

LDP Specification


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents modified commands.

clear mpls counters

sequencing

clear mpls counters

To clear the Multiprotocol Label Switching (MPLS) forwarding table disposition counters and the Any Transport over MPLS (AToM) imposition and disposition virtual circuit (VC) counters, use the clear mpls counters command in privileged EXEC mode.

clear mpls counters

Syntax Description

This command has no arguments or keywords.

Defaults

Checkpoint information resides on the active and standby Route Processor.

Command Modes

Privileged EXEC

Command History

Release
Modification

12.2(25)S

This command was introduced.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB and implemented on the Cisco 10000 series routers. This command was updated to clear AToM VC counters.


Examples

In the following example, the first show mpls forwarding-table command shows that 590 label-switched bytes exist in the forwarding table. The clear mpls counters command clears the counters. The second show mpls forwarding-table command shows that the number of label-switched bytes is 0.

Router# show mpls forwarding-table

Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop
Label  Label or VC   or Tunnel Id      Switched      interface
20     30            10.17.17.17       590           Et3/0      172.16.0.2

Router# clear mpls counters

Clear "show mpls forwarding-table" counters [confirm]
mpls forward counters cleared

Router# show mpls forwarding-table

Local  Outgoing      Prefix            Bytes Label   Outgoing   Next Hop
Label  Label or VC   or Tunnel Id      Switched      interface
20     30            10.17.17.17       0             Et3/0       172.16.0.2

In the following example, the first show mpls l2 vc detail command shows that 15 packets were received and sent, 1656 bytes were received, and 1986 bytes were sent. The clear mpls counters command clears the counters. The second show mpls l2 transport vc detail command shows that no bytes or packets were received or sent.

Router# show mpls l2 vc detail 

Local interface: Et0/0.10 up, line protocol up, Eth VLAN 10 up
    MPLS VC type is Eth VLAN, interworking type is Ethernet
    Destination address: 10.0.0.2, VC ID: 10, VC status: up
        Output interface: Et1/0, imposed label stack {16}
        Preferred path: not configured
        Default path: active
        Next hop: 10.0.0.2
    Create time: 00:19:35, last status change time: 00:19:09
    Signaling protocol: LDP, peer 10.0.0.2:0 up
        MPLS VC labels: local 16, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description:
    Sequencing: receive enabled, send enabled
    VC statistics:
        packet totals: receive 15, send 15 <---- packet totals
        byte totals:   receive 1656, send 1986 <---- byte totals
        packet drops:  receive 0, seq error 0, send 0
 
Router# clear mpls counters 

Clear "show mpls forwarding-table" counters [confirm] mpls forward 
counters cleared
 
Router# show mpls l2 vc detail 

Local interface: Et0/0.10 up, line protocol up, Eth VLAN 10 up
    MPLS VC type is Eth VLAN, interworking type is Ethernet
    Destination address: 10.0.0.2, VC ID: 10, VC status: up
        Output interface: Et1/0, imposed label stack {16}
        Preferred path: not configured
        Default path: active
        Next hop: 10.0.0.2
    Create time: 00:22:55, last status change time: 00:22:29
    Signaling protocol: LDP, peer 10.0.0.2:0 up
        MPLS VC labels: local 16, remote 16
        Group ID: local 0, remote 0
        MTU: local 1500, remote 1500
        Remote interface description:
    Sequencing: receive enabled, send enabled
    VC statistics:
        packet totals: receive 0, send 0 <---- packet totals
        byte totals:   receive 0, send 0 <---- byte totals
        packet drops:  receive 0, seq error 0, send 0

Related Commands

Command
Description

show mpls forwarding-table

Displays the contents of the MPLS forwarding information base.


sequencing

To configure the direction in which sequencing is enabled for data packets in a Layer 2 pseudowire, use the sequencing command in pseudowire class configuration mode. To remove the sequencing configuration from the pseudowire class, use the no form of this command.

sequencing {transmit | receive | both | resync number}

no sequencing {transmit | receive | both | resync number}

Syntax Description

transmit

Updates the Sequence Number field in the headers of data packets sent over the pseudowire according to the data encapsulation method that is used.

receive

Keeps the value in the Sequence Number field in the headers of data packets received over the pseudowire. Out-of-order packets are dropped.

both

Enables both the transmit and receive options.

resync

Enables the reset of packet sequencing after the disposition router receives a specified number of out-of-order packets.

number

The number of out-of-order packets that cause a reset of packet sequencing. The range is 5 to 65535.


Command Default

Sequencing is disabled.

Command Modes

Pseudowire class configuration

Command History

Release
Modification

12.0(23)S

This command was introduced for Layer 2 Tunnel Protocol Version 3 (L2TPv3).

12.3(2)T

This command was integrated into Cisco IOS Release 12.3(2)T.

12.0(29)S

This command was updated to support Any Transport over MPLS (AToM).

12.0(30)S

The resync keyword was added.

12.2(25)S

This command was integrated into Cisco IOS Release 12.2(25)S.

12.2(27)SBC

L2TPv3 support for this command was integrated into Cisco IOS Release 12.2(27)SBC.

12.2(28)SB

AToM support for this command was integrated into Cisco IOS Release 12.2(28)SB.


Usage Guidelines

When you enable sequencing using any of the available options, the sending of sequence numbers is automatically enabled and the remote provider edge (PE) peer is requested to send sequence numbers. Out-of-order packets received on the pseudowire are dropped only if you use the sequencing receive or sequencing both command.

If you enable sequencing for Layer 2 pseudowires on the Cisco 7500 series routers and you issue the ip cef distributed command, all traffic on the pseudowires is switched through the line cards.

It is useful to specify the resync keyword for situations when the disposition router receives many out-of-order packets. It allows the router to recover from situations where too many out-of-order packets are dropped.

Examples

The following example shows how to enable sequencing in data packets in Layer 2 pseudowires that were created from the pseudowire class named "ether-pw" so that the Sequence Number field is updated in tunneled packet headers for data packets that are both sent and received over the pseudowire:

Router(config)# pseudowire-class ether-pw
Router(config-pw)# encapsulation mpls
Router(config-pw)# sequencing both

The following example shows how to enable the disposition router to reset packet sequencing after it receives 1000 out-of-order packets:

Router(config)# pseudowire-class ether-pw 
Router(config-pw)# encapsulation mpls 
Router(config-pw)# sequencing both 
Router(config-pw)# sequencing resync 1000 

Related Commands

Command
Description

ip cef

Enables Cisco Express Forwarding on the Route Processor card.

pseudowire-class

Specifies the name of an L2TP pseudowire class and enters pseudowire class configuration mode.


Feature Information for AToM Sequencing Support

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for AToM Sequencing Support

Feature Name
Releases
Feature Information

AToM Sequencing Support

12.0(29)S
12.0(30)S
12.0(32)S
12.2(28)SB

In 12.0(29)S, this feature was introduced on the Cisco 7200 and 7500 series routers.

In 12.0(30)S, this feature added support for the Cisco 12000 series routers and Engine 3 customer-facing line cards (except for Cisco 12000 Series Four-Port Gigabit Ethernet line cards).

In 12.0(32)S, this feature added support for Engine 5 line cards on Cisco 12000 series routers.

This feature was integrated into Cisco IOS Release 12.2(28)S for the Cisco 10000 series routers.

The following sections provide information about this feature:

Information About AToM Sequencing Support

How to Configure AToM Sequencing

Configuration Examples for AToM Sequencing