Guest

Cisco IOS Software Releases 12.0 S

MPLS AToM—ATM AAL5 over MPLS

  • Viewing Options

  • PDF (302.3 KB)
  • Feedback
MPLS AToM—ATM AAL5 over MPLS

Table Of Contents

MPLS AToM—ATM AAL5 over MPLS

Feature Overview

Label Stacking

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring a Dynamic MPLS Tunnel

Configuring ATM PVCs Over a Dynamic MPLS Tunnel

Configuring a CoS Map Matrix

Configuring a Point-to-Point ATM Link on the Customer CE Routers

Verifying AAL5 Over MPLS Tunnel Configuration

Configuration Examples

Configuring a Dynamic MPLS Tunnel and the ATM PVC Over the Tunnel

Configuring the Customer's ATM Subinterfaces in the PVC

Command Reference

atm route interface

debug mpls atm-transport control

debug mpls atm-transport distributed

debug mpls atm-transport switching

mpls atm-transport

mpls atm-transport cos-map

show atm route

show mpls atm-transport cos-map

show mpls atm-transport disposition

show mpls atm-transport imposition

show mpls forwarding-table

tunnel mode mpls dynamic


MPLS AToM—ATM AAL5 over MPLS


Feature History

Release
Modification

12.0(10)ST

This feature was introduced to support the Cisco 12000 Series router.

12.0(21)ST

This feature was updated to support an additional line card.

12.0(22)S

This feature was integrated into Cisco IOS Release 12.0(22)S.


This feature module describes the ATM adaptation layer 5 (AAL5) over Multiprotocol Label Switching (MPLS) feature for transporting AAL5 service data units (SDUs) across an IP/MPLS backbone. This document contains information about the benefits of AAL5 over MPLS and lists supported platforms. It also provides configuration tasks, examples and related commands.

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuration Examples

Command Reference

Feature Overview

The AAL5 over MPLS feature provides an ATM permanent virtual circuit (PVC) for transporting AAL5 SDUs across an IP/MPLS backbone with rate-limit policing and configurable PVC priority value. A dynamic MPLS tunnel is configured to enable label imposition and disposition of encapsulated ATM SDUs transported between two edge routers having a Label Distribution Protocol (LDP) neighbor relationship.

Label Stacking

Each routed PVC label stack has two levels of labels prepended to each ATM SDU:

An Interior Gateway Protocol (IGP) stack consisting of zero or more labels

A PVC-based label

Routers at the edge of the MPLS backbone perform label imposition and disposition. The imposition router encapsulates the ATM SDU into an MPLS SDU to transport it to the correct disposition router. The disposition router takes the MPLS SDU, de-encapsulates the ATM SDU, and delivers it to the correct ATM interface and virtual path identifier/virtual circuit identifier (VPI/VCI).

Benefits

As Internet service providers (ISPs) begin to deploy IP/MPLS backbones, services including ATM frame switching must be supported. The AAL5 over MPLS feature allows an ISP to transport AAL5 frames over an IP/MPLS backbone consisting of Cisco 12000 Series router platforms with Packet over SONET (POS) links.

Restrictions

The following restriction apply to AAL5 over MPLS:

The AAL5 over MPLS feature supports only AAL5 SDU switching.

The following services are not supported with the AAL5 over MPLS feature:

ATM switched virtual circuits (SVCs)

ATM signaling

Fragmentation and reassembly

Traffic shaping of packets in the MPLS-to-ATM path

The instructions for configuring AAL5 over MPLS in this feature module apply only to the Cisco 12000 series router for 12.0(21)ST. Avoid using these instructions for any other platform or release.

Related Documents

Refer to the following documents for more information:

MPLS Label Distribution Protocol

MPLS Traffic Engineering and Enhancements

MPLS Class of Service

Supported Platforms

The AAL5 over MPLS feature is supported on the Cisco 12000 Series router. For information on which engines and line cards are supported, see the Release Notes for Cisco IOS Release 12.0 ST.

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page.

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

None.

MIBs

None.

RFCs

RFC 3036, LDP Specification

RFC 3032, MPLS Label Stack Encoding

Prerequisites

Maximum Transmission Unit Size Restriction

Because AAL5 over MPLS does not support fragmentation and reassembly, ensure that the maximum transmission unit (MTU) of all intermediate links between endpoints is sufficient to carry the largest ATM AAL5 SDU received.

Dynamic IP Labeling

You must enable LDP label distribution for the dynamic MPLS tunnels used for AAL5 over MPLS.

Configuration Tasks

See the following sections for configuration tasks to enable AAL5 over MPLS:

Configuring a Dynamic MPLS Tunnel (required)

Configuring ATM PVCs Over a Dynamic MPLS Tunnel (required)

Configuring a CoS Map Matrix (optional)

Configuring a Point-to-Point ATM Link on the Customer CE Routers (required)


Note Make sure dynamic MPLS switching is enabled on all interfaces in your core, including traffic engineering tunnels.


Configuring a Dynamic MPLS Tunnel

To configure a dynamic MPLS tunnel to transport ATM SDUs between two endpoints, perform the following steps on the routers that are endpoints of the tunnel.


Note The commands used to create an MPLS tunnel are supported only on Cisco IOS Releases 12.0(10)ST to 12.0(21)ST.


 
Command
Purpose

Step 1 

Router(config)# interface tunnel tunnel_number

Configures a tunnel interface and enters the interface configuration mode. Specify the number of the tunnel interface that you want to create and configure.

Step 2 

Router(config-if)# tunnel mode mpls dynamic

Sets the encapsulation mode for an MPLS tunnel on all interfaces in the core.

Step 3 

Router(config-if)# tunnel destination ip-address

Specifies the destination for the tunnel interface. We recommend that you use the loopback address as the tunnel destination address. Make sure the backbone network does not perform summarization of this destination address. The IP address of the host destination is expressed in decimal in four-part, dotted notation.

Step 4 

Router(config-if)# tunnel key key-number 

Enables an ID key for a tunnel interface. The key number ranges from 0 to 4,294,96,295 and identifies the tunnel key. The tunnel key must be the same at both ends of the tunnel.

Step 5 

Router(config-if)# mpls atm-transport

Enables the transport of ATM frames across an MPLS tunnel.

Alternatively, you can use the global mpls label protocol ldp command to configure LDP for all interfaces.

Configuring ATM PVCs Over a Dynamic MPLS Tunnel

To configure an ATM PVC over a dynamic MPLS tunnel, perform the following steps:

 
Command
Purpose

Step 1 

Router(config)# interface atm interface

Configures an ATM interface and enters the interface configuration mode.

Step 2 

Router(config-if)# pvc 
input_vpi/input_vci

Creates an ATM input VPI/VCI to route.

Step 3 

Router(config-if-atm)# atm route 
interface tunnel-interface output_vci 
[priority number][rate-limit CIR Bc]


Specifies the dynamic MPLS tunnel enabled for ATM transport for routing the PVC.

The tunnel-interface specifies the dynamic MPLS tunnel.

The output_vci is the VCI value to use over dynamic MPLS tunnels.

The priority is optional; the value of number must be between 0 and 3 inclusive.

The rate-limit is optional. CIR specifies the value of the committed information rate, in bits per second. The value of CIR must be between 8,000 and 2,000,000,000 inclusive. Bc specifies burst, in bytes per millisecond. The value of Bc must be between 8,000 and 2,000,000 inclusive.

Configuring a CoS Map Matrix

A CoS map matrix can be used to route SDUs to ATM PVCs over a dynamic MPLS tunnel. This procedure is optional. To create a CoS map matrix, perform the following steps:

 
Command
Purpose

Step 1 

Router(config)# interface tunnel tunnel_number

Configures a tunnel interface and enters the interface configuration mode. Specify the number of the tunnel interface that you want to create and configure.

Step 2 

Router(config-if)# mpls atm-transport cos-map 0 1 
2 3 4 5 6 7

Specifies a CoS map number from 0 to 7 and the associated committed information rate (CIR) for the packet. The meaning of each number is described below.

0: CIR = 0, priority = 0
1: CIR = 0, priority = 1
2: CIR = 0, priority = 2
3: CIR = 0, priority = 3
4: CIR = 1, priority = 0
5: CIR = 2, priority = 1
6: CIR = 3, priority = 2
7: CIR = 4, priority = 3

Configuring a Point-to-Point ATM Link on the Customer CE Routers

To configure a point-to-point ATM link with PVCs and encapsulated AAL5 SNAP, perform the following steps on the customer's CE routers:

 
Command
Purpose

Step 1 

Router(config)# interface ATMcard/port

Enters configuration mode for the ATM subinterface.

Step 2 

Router(config-if)# no shut

Enables the ATM interface and the configuration changes just made to it.

Step 3 

Router(config-if)# interface 
ATMcard/port.subinterfacenum  point-to-point

Configures the specified subinterface at the designated card and port.

Step 4 

Router(config-subif)# ip address address 
subnet-mask

Specifies the IP address for the ATM interface. The address is the Internet address for the interface. The subnet-mask is the mask of address bits that specifies the network portion of the address.

Step 5 

Router(config-subif)# pvc vpi/vci

Creates an ATM PVC for each end node with which the router communicates. The virtual path identifier (VPI) can be any value. The VCI range is 34 to 1025.

Step 6 

Router(config-subif)# broadcast

Sends duplicate broadcast packets for all protocols configured on a PVC.

Step 7 

Router(config-subif)# encapsulation aal5snap

Configures the ATM adaptation layer 5 encapsulation type.

Verifying AAL5 Over MPLS Tunnel Configuration

To verify and display the configuration of AAL5 over MPLS tunnels, perform the following steps:


Step 1 To determine the state of the dynamic tunnel interface, use the show ip interface brief command:

Router# show ip interface brief
Interface     IP-Address     OK?    Method    Status                    Protocol
Ethernet0     1.0.46.10      YES    manual    administratively down     down
PCbus0        198.135.1.43   YES    manual    administratively down     down
Serial0       198.135.2.49   YES    manual    administratively down     down
Tunnel1       unassigned     YES    manual    up                        up
Loopback0     12.12.12.12    YES    manual    up                        up

Step 2 To make sure the tunnel endpoints have discovered each other, use the show mpls ldp discovery command:

Router# show mpls ldp discovery
Local LDP Identifier:
    12.12.12.12:0
Discovery Sources:
    Interfaces:
        POS0/3 (ldp): xmit/recv
            LDP Id: 11.11.11.11:0
        POS5/0 (ldp): xmit/recv
            LDP Id: 14.14.14.14:0
        Tunnel1 (ldp): -> 11.11.11.11
    Targeted Hellos:
        12.12.12.12 -> 11.11.11.11 (ldp): active, xmit/recv
            LDP Id: 11.11.11.11:0

The LDP targeted hello is for the AAL5 over MPLS tunnel interface whose tunnel destination is 11.11.11.11.


Step 3 To make sure the label distribution session has been established, use the show mpls ldp neighbors command:

Router# show mpls ldp neighbors
Peer LDP Ident: 14.14.14.14:0; Local LDP Ident 12.12.12.12:0
        TCP connection: 14.14.14.14.11021 - 12.12.12.12.646
        State: Oper; Msgs sent/rcvd: 6081/6073; Downstream
        Up time: 3d16h
        LDP discovery sources:
          POS5/0
        Addresses bound to peer LDP Ident:
          14.14.14.14     180.0.0.2       181.0.0.1       185.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 12.12.12.12:0
        TCP connection: 11.11.11.11.646 - 12.12.12.12.12700
        State: Oper; Msgs sent/rcvd: 5864/8340; Downstream
        Up time: 3d13h
        LDP discovery sources:
          POS0/3
          Targeted Hello 12.12.12.12 -> 11.11.11.11, active
        Addresses bound to peer LDP Ident:
          11.11.11.11     183.0.0.2       188.0.0.2       3.3.48.1

Step 4 To view the currently routed ATM PVCs, use the show atm route command:

Router# show atm route  
Input Intf   Input VC     Output Intf    Output VC   Status
ATM0/0       1            Tunnel8        555         UP
Tunnel8      555          ATM0/0         1           UP

Step 5 To view a summary of the ATM PVCs and PVCs configured over dynamic MPLS tunnels, use the show atm pvc command. To view specific information about a PVC, include a VPI/VCI parameter with this command.

Router# show atm pvc 
Interface    VCD/Name  VPI  VCI  Type  Encaps  Peak Kbps  Avg/Min kbps Burst Cells   Sts
0/0          1         0    888  PVC   SNAP    62200      0                          UP
Tunnel 8     N/A       0    555  PVC   N/A     0          0                          UP

Step 6 To view the local labels that are assigned to PVCs over dynamic MPLS tunnels, use the show mpls forwarding command.

Router# show mpls forwarding 
Local tag   Outgoing tag   Prefix        Bytes/tag  Outgoing    Next Hop
            or VC          or Tunnel ID  switched   interface   
127         Untagged       ATM(Tu8:555)  66856      AT0/0       point2point

Step 7 To view the current AAL5 over MPLS CoS map, use the show mpls atm-transport cos-map command. The values used in this example are the default settings.

Router# show mpls atm-transport cos-map 0 1 2 3 4 5 6 7

                        Pri=0   Pri=1   Pri=2   Pri=3
In CIR                      1       3       5       7
Out CIR                     0       2       4       6

Step 8 To view the imposition information about a line card, use the show mpls atm-transport imposition command.

Router# attach 2
Router-lc2# execute-on all show mpls atm-transport imposition detail
Interface ATM0:
ATM vcd: 1-> Tunnel2 mpls_vci: 42 label: 21
 input pkts: 0 output pkts: 0 impose_seq_num:0x8279
 priority: 0 rate limit: unlimited active: yes
 MPLS Detailed info:
  Impose Rewrite:
   22    ATM/MPLS   impose 0    PO6/0    point2point
   MAC/Encaps=4/12, MTU=4466, Tag Stack{22 21}
   04019110 0001600000015001
GSR-LC Detailed ATM vcd info:
 vcd:1 pcr:25801 scr:25801 mbs:94 cid:9672
 pvc output_info:0x4019130
GSR-LC Detailed Output MPLS intf. info:
 local_outputq:0x9800 output:0x4000 output_info:0x4019110
Router-lc2# exit

Step 9 To view the disposition information about a line card, use the show mpls atm-transport disposition command.

Router# attach 3
Router-lc3# execute-on all show mpls atm-transport disposition detail
Tunnel2 MPLS vci:42 -> ATM3/0 ATM vcd:1
 Local Label: 16 dispose_seq_num:0x68C9 atm output_info: 0x4019130
 input pkts:0 output pkts:0
Router-lc3# exit

Configuration Examples

This section provides the following configuration examples:

Configuring a Dynamic MPLS Tunnel and the ATM PVC Over the Tunnel

Configuring the Customer's ATM Subinterfaces in the PVC

Figure 1 illustrates the network configuration that the configuration commands reference.

Figure 1 Configuring AAL5 Over MPLS

Configuring a Dynamic MPLS Tunnel and the ATM PVC Over the Tunnel

The configuration commands for router 2 and router 3 accomplish the following for this example network:

Configuration of dynamic MPLS tunnels between router 2 and router 3.

Routing of PVC 0/203 across the dynamic MPLS tunnels between routers 2 and 3.

Use of LDP for label distribution between router 2 and router 3 in support of the AAL5 over MPLS feature.

Use of dynamic MPLS switching between router 2 and router 3. It is assumed that dynamic MPLS switching is enabled throughout the MPLS core.

Configuration of routing on router 2 and router 3. The sample configurations assume OSPF is used within the MPLS core. The sample configurations illustrate the OSPF configuration to ensure that routers 2 and 3 have routes to the tunnel endpoints.

The following configuration commands configure the transport for PVC 0/203 between router 2 and router 3 across the MPLS core.


Note The mpls label protocol ldp command is a global configuration command. When you use this command from the Router# prompt, it forces all label distribution sessions to use LDP. See the MPLS Label Distribution Protocol Feature Module for more information on this command.


Router 2 Configuration


interface Loopback0                        !Configure loopback interface
ip address 22.22.22.22 255.255.255.255

interface Tunnel33                         !Configure dynamic tunnel to Router 3.
mpls atm-transport                         !Enable transport of ATM across tunnel.
mpls label protocol ldp                    !Use LDP label distribution for tunnel.
tunnel destination 33.33.33.33             !Specify tunnel destination as
                                           !Router 3 loopback.
tunnel source Loopback0
tunnel mode mpls dynamic                   !Make it a dynamic MPLS tunnel.
tunnel key 2233                            !Specify ID for tunnel.

interface ATM2/0
pvc 0/203
atm route interface tunnel33 333           !Route pvc 0/203 on Tunnel33 with
                                           !vci 333 across the MPLS core.

interface POS1/0                           !Configure interface to MPLS core.
ip address 139.1.1.2 255.255.255.0
mpls ip                                    !Enable dynamic MPLS switching.
mpls label protocol ldp                    !Use LDP label distribution. Assumes the
                                           !core router on the interface uses LDP.

router ospf 10                             !Configure OSPF routing.
passive-interface Loopback0
network 22.22.22.22 0.0.0.0 area 0
network 139.1.1.0  0.0.0.255 area 0

Router 3 Configuration


interface Loopback0                       !Configure loopback interface
ip address 33.33.33.33 255.255.255.255

interface Tunnel22                        !Configure dynamic tunnel to Router 2.
mpls atm-transport                        !Enable transport of ATM across tunnel.
mpls label protocol ldp                   !Use LDP label distribution for tunnel.
tunnel destination 22.22.22.22            !Specify tunnel destination as
                                          !Router 2 loopback.
tunnel source Loopback0
tunnel mode mpls dynamic                  !Make it a dynamic MPLS tunnel.
tunnel key 2233                           !Specify ID for tunnel.

interface ATM1/0
pvc 0/203
atm route interface tunnel22 333          !Route PVC 0/203 on Tunnel22 with
                                          !vci 333 across the MPLS core 333.

interface POS2/0                          !Configure interface to MPLS core.
ip address 139.1.7.3 255.255.255.0
mpls ip                                   !Enable dynamic MPLS switching
mpls label protocol ldp                   !Use LDP label distribution. Assumes the
                                          !core router on the interface uses LDP.

router ospf 10                            !Configure OSPF routing.
passive-interface Loopback0
network 33.33.33.33 0.0.0.0 area 0
network 139.1.7.0  0.0.0.255 area 0

Configuring the Customer's ATM Subinterfaces in the PVC

Router 1

interface ATM2/0
no ip address 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
no shut 
no atm enable-ilmi-trap 
no atm ilmi-keepalive 

interface ATM2/0.100 point-to-point 
ip address 1.0.0.2 255.255.255.224 
no ip directed-broadcast 
no ip route-cache 
no ip mroute-cache 
no shut 
no atm enable-ilmi-trap 
pvc 0/203 
broadcast 

Command Reference

This section describes the following commands:

atm route interface

debug mpls atm-transport control

debug mpls atm-transport distributed

debug mpls atm-transport switching

mpls atm-transport

mpls atm-transport cos-map

show atm route

show mpls atm-transport cos-map

show mpls atm-transport disposition

show mpls atm-transport imposition

show mpls forwarding-table

tunnel mode mpls dynamic

atm route interface

To configure a dynamic MPLS tunnel with MPLS ATM transport to route a PVC on a main interface, use the atm route interface command in interface configuration mode. To disable the configuration of a dynamic MPLS tunnel, use the no form of this command.

atm route interface tunnel_interface output_vci [priority number] [rate-limit CIR Bc]

no atm route interface tunnel_interface output_vci [priority number] [rate-limit CIR Bc]

Syntax Description

tunnel_interface

Specifies the dynamic MPLS tunnel enabled for ATM transport to route the PVC.

output_vci

Specifies the VCI value to use over the dynamic MPLS tunnel. The value must be the same at both ends of the tunnel.

priority number

(Optional) Specifies the priority; the value of number must be between 0 and 3 inclusive.

rate-limit CIR Bc

(Optional) Specifies the value of the committed information rate (CIR), expressed in bits per second. The value must be between 8,000 and 2,000,000,000 inclusive. Bc is expressed in bytes per millisecond. The value must be between 8,000 and 2,000,000 inclusive.


Defaults

No default behavior or values.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Usage Guidelines

After a dynamic MPLS tunnel with MPLS transport is configured, you can use it as an outgoing interface by issuing the atm route interface command. Specify AAL5 for the encapsulation of the input PVC; the default encapsulation is AAL5SNAP. This ATM forwarding service does not look at the SDU being transmitted, it simply forwards the AAL5SNAP or AAL5MUX packet.

Routed PVCs are supported on main interfaces, not subinterfaces.

Examples

The following example shows an MPLS tunnel interface enabled for routing an ATM PVC:

Router(config)# interface atm 1/0
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# atm clock internal
Router(config-if)# no atm ilmi-keepalive
Router(config-if)# pvc 0/534
Router(config-if-atm)# atm route interface tunnel2 534

debug mpls atm-transport control

To enable debug messages about the control of traffic transported between ATM and MPLS, use the debug mpls atm-transport control command in EXEC mode. To disable the debug messages about MPLS ATM transport control, use the no form of this command.

debug mpls atm-transport control

no debug mpls atm-transport control

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example enables debugging of AAL5 over MPLS control:

Router# debug mpls atm-transport control
ATM transport over MPLS, Control interactions debugging is on
Router#
ATM_TRANS:GOT ATOM_EVENT_TDP_UP on Tunnel88
ATM_TRANS: Advertising all pvcs on Tunnel88
ATM_TRANS: sending bind for pvc 170 on Tunnel88 label 19
ATM_TRANS: Requesting all pvcs on Tunnel88
ATM_TRANS: sending request_bind for pvc 0 on Tunnel88
ATM_TRANS: received BIND mpls_vci: 170 on Tunnel88 label 16
ATM_TRANS: Done setting imp.rewrite for vc 170 parent dest 88.88.88.88

debug mpls atm-transport distributed

To enable the distribution of debug messages about label imposition and label disposition on line cards, use the debug mpls atm-transport distributed command in EXEC mode. To disable the debug messages about label imposition and label disposition on line cards, use the no form of this command.

debug mpls atm-transport distributed

no debug mpls atm-transport distributed

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example enables debug messages related to the process of label imposition/disposition:

Router# debug mpls atm-transport distributed
ATM transport over MPLS, Distributed switching debugging is on
Router#
ATM_TRANS: removing label disposition info for tun:Tunnel88 vci:0 from all slots
ATM_TRANS: disposition change for tun:Tunnel88 vci:170, (none) -> (all) (queued)
ATM_TRANS: sending  label disposition info for tun:Tunnel88 vci:170 to all slots

debug mpls atm-transport switching

To enable debug messages about the transport of information for ATM to MPLS and MPLS to ATM switching, use the debug mpls atm-transport switching command in EXEC mode. To disable debug messages about ATM to MPLS switching, use the no form of this command.

debug mpls atm-transport switching

no debug mpls atm-transport switching

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example enables debugging of AAL5 over MPLS switching:

Router#  debug mpls atm-transport switching
AAL5 transport over MPLS, switching debugging is on
Router(config)#  int atm3/0
Router(config-if)#  shut
Router(config-if)#  no shut
Router(config-if)#  end
11:46:48: mpls_atm_trans_atm_hwif_up() enter - max_intf_vcs (2048) 
11:46:49: mpls_atm_trans_atm_hwif_up() enter - max_intf_vcs (2048) 
11:46:49: mpls_atm_trans_atm_swif_up(), out_vc(50)
11:46:50: %SYS-5-CONFIG_I: Configured from console by console

SLOT 5:09:18:23: ADJ: Received adjacency update event for 0.0.0.0(connector-id 0)
SLOT 5:09:18:23: ADJ: via ATM3/0, mac-rewrite length 4, output_info
0x1C059220, local_outputq 0x8C00, outputq 16384, enctype 33adj_index 1 mtu 4470
SLOT 5:09:18:23: ADJ: Add AT3/0 index=1 old=0x4127F280 new=0x4127F280
SLOT 5:09:18:23: ADJ: add 0.0.0.0 via ATM3/0

mpls atm-transport

To enable the transport of ATM frames across an MPLS tunnel, use the mpls atm-transport command in interface configuration mode. To disable the configuration of ATM transport, use the no form of this command.

mpls atm-transport

no mpls atm-transport

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example shows a configured MPLS tunnel interface, with the transport of ATM frames enabled, and the destination address of 101.1.1.1:

Router(config)# interface tunnel2
Router(config-if)# no ip address
Router(config-if)# no ip directed-broadcast
Router(config-if)# mpls atm-transport
Router(config-if)# mpls label protocol ldp
Router(config-if)# tunnel destination 101.1.1.1
Router(config-if)# tunnel mode mpls dynamic
Router(config-if)# tunnel key 10111
Router(config-if)# end
!
Router(config)# interface loopback0
Router(config-if)# ip address 102.1.1.1 255.255.255.255
Router(config-if)# no ip directed-broadcast
Router(config-if)# ip ospf interface-retry 0

Related Commands

Command
Description

show mpls atm-transport cos-map

Displays the current ATM transport over MPLS CoS map matrix.

show mpls atm-transport disposition

Displays information about the label disposition on a specified line card.

show mpls atm-transport imposition

Displays information about the label imposition on a specified line card.


mpls atm-transport cos-map

To configure an MPLS CoS map that can be used to specify the priority of each SDU transported across an MPLS backbone, use the mpls atm-transport cos-map command in interface configuration mode.

mpls atm-transport cos-map number0 number1 number2 number3 number4 number5 number6 number7

Syntax Description

number

Specifies the MPLS CoS value associated with a SDU:

0: Committed Information Rate (CIR) = 0, priority = 0

1: CIR = 0, priority = 1

2: CIR = 0, priority = 2

3: CIR = 0, priority = 3

4: CIR = 1, priority = 0

5: CIR = 1, priority = 1

6: CIR = 1, priority = 2

7: CIR = 1, priority = 3


Defaults

The default is 1, 3, 5, 7, 0, 2, 4, 6.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Usage Guidelines

The CoS map is used to set up a policy that is applied to traffic as it enters the MPLS core through ATM transport over MPLS. Class-based weighted fair queuing (CBWFQ) or an MPLS CoS aware scheduling algorithm must be run in the core for the policy to be effective.

Related Commands

Command
Description

show mpls atm-transport cos-map

Displays the current ATM/MPLS CoS map.


show atm route

To display the currently routed ATM PVC, use the show atm route command in EXEC mode.

show atm route

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example shows a currently routed ATM PVC on the input and output interfaces:

Router# show atm route  

Input Intf   Input VC     Output Intf    Output VC   Status
ATM0/0       1            Tunnel8        555         UP
Tunnel8      555          ATM0/0         1           UP

Table 1 describes the fields used in the preceding example.

Table 1 show atm route Field Descriptions

Field
Description

Input Intf

Input interface of the currently routed PVC.

Input VC

Input virtual connection.

Output Intf

Output interface assigned to the PVC.

Output VC

Output virtual connection.

Status

Status of the connection.


show mpls atm-transport cos-map

To show the current ATM/MPLS CoS map, use the show mpls atm-transport cos-map command in EXEC mode.

show mpls atm-transport cos-map

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

In the following example, the current ATM CoS map is shown:

Router# show mpls atm-transport cos-map

                        Pri=0   Pri=1   Pri=2   Pri=3
In CIR                      1       3       5       7
Out CIR                     0       2       4       6

Table 2 describes the fields used in the preceding example.

Table 2 show mpls atm-transport cos-map Field Descriptions

Field
Description

Pri=

Priority assigned to a packet.

In CIR

CIR of the input interface.

Out CIR

CIR of the output interface .


Related Commands

Command
Description

mpls atm-transport cos-map

Configures an MPLS CoS map for a specified PVC.


show mpls atm-transport disposition

To view label disposition information about a line card, use the show mpls atm-transport disposition command in EXEC mode.

show mpls atm-transport disposition {detail | normal | summary}

Syntax Description

detail

Specifies the virtual channel identifier (VCI) range to display in detail mode.

normal

Specifies the VCI range to display in normal mode.

summary

Specifies the VCI range to display in summary mode.


Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example shows detailed disposition information about the ATM line card in slot 3:

Router# attach 3
Router-lc3# execute-on all show mpls atm-transport disposition detail
Tunnel2 MPLS vci:42 -> ATM3/0 ATM vcd:1
 Local Label:16 dispose_seq_num:0x68C9 atm output_info:0x4019130
 Input pkts:0 output pkts:0
Router-lc3# exit
Router# 

Table 3 describes the fields used in the preceding example.

Table 3 show mpls atm-transport disposition Field Descriptions

Field
Description

vci

Number assigned to the VCI.

vcd

Number assigned to the virtual circuit descriptor (VCD).

Input pkts

Number of packets delivered to the input interface.

output pkts

Number of packets delivered to the output interface.


Related Commands

Command
Description

show mpls atm-transport imposition

Displays information about label imposition on a specified line card.


show mpls atm-transport imposition

To view label imposition information about a line card, use the show mpls atm-transport imposition command in exec mode.

show mpls atm-transport imposition {detail | normal | summary}

Syntax Description

detail

Displays the virtual channel identifier (VCI) range in detail mode.

normal

Displays the VCI range to display in normal mode.

summary

Displays the VCI range to display in summary mode.


Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Usage Guidelines

Do not invoke this command while traffic is flowing to the line card.

Examples

The following example shows detailed label imposition information about the line card in slot 2:


Router-lc2# execute-on all show mpls atm-transport imposition detail
Interface ATM0:
ATM vcd: 1-> Tunnel2 mpls_vci: 42 label: 21
 input pkts: 0 output pkts: 0 impose_seq_num:0x8279
 priority: 0 rate limit: unlimited active: yes
 MPLS Detailed info:
  Impose Rewrite:
   22    ATM/MPLS   impose 0    PO6/0    point2point
   MAC/Encaps=4/12, MTU=4466, Tag Stack{22 21}
   04019110 0001600000015001
GSR-LC Detailed ATM vcd info:
 vcd:1 pcr:25801 scr:25801 mbs:94 cid:9672
 pvc output_info:0x4019130
GSR-LC Detailed Output MPLS intf. info:
 local_outputq:0x9800 output:0x4000 output_info:0x4019110
Router-lc2# exit

Related Commands

Command
Description

show mpls atm-transport disposition

Displays label disposition information about a specified line card.


show mpls forwarding-table

To view an MPLS forwarding table, use the show mpls forwarding-table command in EXEC mode. This is also called the show tag-switching forwarding table command.

show mpls forwarding-table

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example shows an MPLS forwarding table:


Router# show mpls forwarding-table  

tag     Outgoing tag   Prefix or     Bytes tag  Outgoing     Next Hop
        or VC          tunnel ID     switched   Interface
128     Pop tag        7.7.7.7/32      0        PO1/0        point2point
129     Pop tag        10.1.3.0/24     0        PO1/0        point2point
130     129            88.88.88.88/32  0        PO1/0        point2point
131     Untagged       ATM(Tu8:555)    0        AT2/0        point2point

Table 4 describes the fields used in the preceding example.

Table 4 show mpls forwarding-table Field Descriptions

Field
Description

Local tag

Tag assigned by this router.

Outgoing tag or VC

Tag assigned by next hop, or VPI/VCI used to get to next hop. Entries in this column include:

Untagged—There is no tag for the destination from the next hop, or tag switching is not enabled on the outgoing interface.

Pop tag—The next hop advertised an implicit NULL tag for the destination, and this router popped the top tag.

[T]—Forwarding through a TSP tunnel.

Prefix or tunnel ID

Address or tunnel to which packets with this tag are going.

Bytes tag-switched

Number of bytes switched with this incoming tag.

Outgoing Interface

Interface through which packets with this tag are sent.

Next Hop

IP address of the neighbor that assigned the outgoing tag.


Related Commands

Command
Description

interface tunnel

Configures a tunnel interface and enters the interface configuration mode.


tunnel mode mpls dynamic

To set the encapsulation mode for an MPLS tunnel interface, use the tunnel mode mpls dynamic command in interface configuration mode. To disable encapsulation mode for an MPLS tunnel interface, use the no form of this command.

tunnel mode mpls dynamic

no tunnel mode mpls dynamic

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

Interface configuration

Command History

Release
Modification

12.0(10)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Examples

The following example enables dynamic MPLS tunneling:

Router# interface tunnel 1
Router (config-if)# tunnel mode mpls dynamic

Related Commands

Command
Description

interface tunnel

Configures a tunnel interface and enters the interface configuration mode.