Guest

Cisco IOS Software Releases 12.0 S

MPLS Traffic Engineering (TE)--Interarea Tunnels

  • Viewing Options

  • PDF (271.9 KB)
  • Feedback
MPLS Traffic Engineering (TE)—Interarea Tunnels

Table Of Contents

MPLS Traffic Engineering (TE)—Interarea Tunnels

Feature Overview

Benefits

Restrictions

Related Features and Technologies

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring a Platform to Support Traffic Engineering Tunnels

Configuring OSPF for Interarea Tunnels

Configuring OSPF for ABRs

Configuring OSPF for Non-ABR Routers

Configuring IS-IS for Interarea Tunnels

Configuring IS-IS for Backbone Routers

Configuring IS-IS for Non-backbone Routers

Configuring IS-IS for Interfaces

Configuring an MPLS Traffic Engineering Interarea Tunnel

Configuring an MPLS Traffic Engineering Interarea Tunnel to Use Explicit Paths

Configuring Explicit Paths

Verifying the Configuration

Configuration Examples

OSPF Configuration Example

IS-IS Configuration Example

MPLS and RSVP Support for Traffic Engineering Configuration Example

Interarea Tunnel Configuration Example

Command Reference

next-address

Glossary


MPLS Traffic Engineering (TE)—Interarea Tunnels


Feature History

Release
Modification

12.0(19)ST1

This feature was introduced.

12.0(21)ST

Support for the Cisco GSR 12000 series platform was added.

12.0(22)S

Support for the Cisco 10000 series edge services routers (ESRs) was added.


This document describes the Multiprotocol Label Switching (MPLS) traffic engineering (TE) Interarea Tunnels feature in Cisco IOS Release 12.0(22)S. The document contains the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuration Examples

Command Reference

Glossary

Feature Overview

The MPLS TE Interarea Tunnels feature allows you to establish MPLS TE tunnels that span multiple Interior Gateway Protocol (IGP) areas and levels, removing the restriction that had required the tunnel head-end and tail-end routers both be in the same area. The IGP can be either Intermediate System-to-Intermediate System (IS-IS) or Open Shortest Path First (OSPF).

To configure an interarea tunnel, you specify on the head-end router a loosely routed explicit path for the tunnel label switched path (LSP) that identifies each area border router (ABR) the LSP should traverse using the next-address loose command. The head-end router and the ABRs along the specified explicit path expand the loose hops, each computing the path segment to the next ABR or tunnel destination.

For example, to configure a TE tunnel from router R1 to router R2 in the simple multiarea network shown in Figure 1, you would specify ABR1 and ABR2 as loose hops in the explicit path for the tunnel. To signal the tunnel LSP, the head-end router (R1) computes the path to ABR1 and sends an RSVP Path message specifying the path from itself to ABR1 as a sequence of strict hops followed by the path from ABR1 to the tail-end as a sequence of loose hops (ABR2, R1). When ABR1 receives the Path message, it expands the path across the backbone area to ABR2 and forwards the Path message specifying the path from itself to ABR2 as a sequence of strict hops followed by the path from ABR2 to the tunnel tail-end (R3) as a loose hop. When ABR2 receives the Path message, it expands the path across the tail-end area to R3 and propagates the Path message specifying the path from itself to R2 as a sequence of strict hops.

Figure 1 Multiarea Network


Note Strictly speaking, IS-IS does not have the notion of an ABR. For the purpose of discussing the TE Interarea Tunnels feature, this document considers an IS-IS level-1-2 router as an ABR as described above.



Note The explicit path for a TE interarea tunnel can contain any number of non-ABR LSRs. Within an area, a combination of loose and strict next-addresses is allowed. For a detailed explanation, see the next-address command.



Note With OSPF, if an area is connected to the backbone through a virtual link, there may be more than two ABRs in the path.


Benefits

When it is desirable for the traffic from one router to another router in a different IGP area to travel over TE LSPs, the MPLS TE Interarea Tunnels feature allows you to configure a tunnel that runs from the source router to the destination router. The alternative would be to configure a sequence of tunnels, each crossing one of the areas between source and destination routers such that the traffic arriving on one such tunnel is forwarded into the next such tunnel.

Restrictions

The dynamic path option feature for TE tunnels (tunnel mpls traffic-eng path-option number dynamic) is not supported for interarea tunnels. An explicit path identifying the ABRs is required. When there are choices for the ABRs to be used, multiple explicit paths are recommended, each of which identifies a different sequence of ABRs.

The MPLS TE AutoRoute feature (tunnel mpls traffic-eng autoroute announce) is not supported for interarea tunnels because you would need to know the network topology behind the tail-end router.

Tunnel affinity (tunnel mpls traffic-eng affinity) is not supported for interarea tunnels.

Tunnel metric (tunnel mpls traffic-eng path-selection metric) is not supported for interarea tunnels.

The reoptimization of tunnel paths is not supported for interarea tunnels.

Related Features and Technologies

The following MPLS traffic engineering features are supported on interarea traffic engineering LSPs:

Automatic bandwidth adjustment

Diff-Serve-aware traffic engineering

Fast reroute link protection

Policy-based routing

Static routing

Related Documents

For IS-IS:

Cisco IOS IP Configuration Guide, Release 12.2

Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2

For link protection:

MPLS Traffic Engineering (TE)—Link and Node Protection, with RSVP Hellos Support, Release 12.0(22)S

For MPLS Traffic Engineering:

Cisco IOS Switching Services Command Reference, Release 12.2

Cisco IOS Switching Services Configuration Guide, Release 12.2

Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2

For OSPF:

Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2

Cisco IOS IP Configuration Guide, Release 12.2

Supported Platforms

Cisco 7200 series (including the Cisco 7202, Cisco 7204, Cisco 7204 VXR, Cisco 7206, and Cisco 7206 VXR)

Cisco 7500 series (including the Cisco 7505, Cisco 7507, Cisco 7513, and Cisco 7576)

Cisco GSR 12000 series (including the Cisco 12008, Cisco 12012, Cisco 12016, Cisco 12404, Cisco 12406, Cisco 12410, and Cisco 12416)

Cisco 10000 series edge services routers (ESRs)

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator home page at the following URL:

http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards are supported by this feature.

MIBs

No new or modified MIBs are supported by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB web site on Cisco.com at the following url: http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml.

RFCs

No new or modified RFCs are supported by this feature.

Prerequisites

Your network must support the following Cisco IOS features:

MPLS

IP Cisco Express Forwarding (CEF)

IS-IS or OSPF

Configuration Tasks

See the following sections for configuration tasks for the Interarea Tunnels feature. Each task in the list is identified as either optional or required.

Configuring a Platform to Support Traffic Engineering Tunnels (required)

Configuring OSPF for Interarea Tunnels (optional)

Configuring IS-IS for Interarea Tunnels (optional)

Configuring an MPLS Traffic Engineering Interarea Tunnel (required)


Note You must configure either OSPF or IS-IS.


Configuring a Platform to Support Traffic Engineering Tunnels

To configure a platform to support traffic engineering tunnels, refer to the Cisco IOS Switching Services Configuration Guide.

Configuring OSPF for Interarea Tunnels

This section describes the following:

Configuring OSPF for ABRs

Configuring OSPF for Non-ABR Routers

For a description of the OSPF commands, see the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols manual.

To view an example, go to "OSPF Configuration Example".

Configuring OSPF for ABRs

For each ABR that is running OSPF, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router ospf process-id

Enables OSPF. You are placed in router configuration mode.

The process-id is an internally used identification parameter for an OSPF routing process. It is locally assigned and can be any positive integer. Assign a unique value for each OSPF routing process.

Step 2 

Router(config-router)# network address mask area area-id

Specifies the interfaces on which OSPF is to run and specifies the area to which the interface is connected. The address is the IP address.

Step 3 

Router(config-router)# mpls traffic-eng router-id Loopback0

Specifies that the traffic engineering router identifier for the node is the IP address associated with interface loopback0. (The router identifier is displayed in the show mpls traffic-eng topology path command output.)

Step 4 

Router(config-router)# mpls traffic-eng area 0

Router(config-router)# mpls traffic-eng area m

Turns on MPLS traffic engineering for OSPF in area 0 and in area m. On an ABR, you must configure traffic engineering on each area you want tunnels in or across.

Configuring OSPF for Non-ABR Routers

For each non-ABR that is running OSPF, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# router ospf process-id

Enables OSPF. You are placed in router configuration mode.

The process-id is an internally used identification parameter for an OSPF routing process. It is locally assigned and can be any positive integer. Assign a unique value for each OSPF routing process.

Step 2 

Router(config-router)# network address mask area area-id

Specifies the interfaces on which OSPF is to run and specifies the area to which the interface is connected. The address is the IP address.

Step 3 

Router(config-router)# mpls traffic-eng router-id Loopback0

Specifies that the traffic engineering router identifier for the node is the IP address associated with interface loopback0. (The router identifier is displayed in the show mpls traffic-eng topology path command output.)

Step 4 

Router(config-router)# mpls traffic-eng area m

Specifies the area that the router is in.

Configuring IS-IS for Interarea Tunnels

This section describes the following:

Configuring IS-IS for Backbone Routers

Configuring IS-IS for Non-backbone Routers

Configuring IS-IS for Interfaces

For a description of the IS-IS commands, see the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Part 1, and Cisco IOS Switching Services Command Reference.

To view an example, go to "IS-IS Configuration Example".

Configuring IS-IS for Backbone Routers

To configure IS-IS for background (level-1-2) routers, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# clns routing

Allows IS-IS to communicate with other IS-IS-configured routers.

Step 2 

Router(config)# router isis

Enables IS-IS routing and specifies an IS-IS process for IP. This command places you in router configuration mode.

Step 3 

Router(config-router)# metric-style wide

Configures a router to generate and accept only new-style type, length, and value objects (TLVs).

Step 4 

Router(config-router)# net nn.nnnn.nnnn.nnnn.nn

Configures the area ID (area address) and the system ID.

Step 5 

Router(config-router)# mpls traffic-eng router-id Loopback0

Specifies that the traffic engineering router identifier for the node is the IP address associated with interface loopback0.

Step 6 

Router(config-router)# mpls traffic-eng level-1

Turns on MPLS traffic engineering for IS-IS at level 1.

Step 7 

Router(config-router)# mpls traffic-eng level-2

Turns on MPLS traffic engineering for IS-IS at level 2.

Step 8 

Router(config)# ip router isis

Enables IS-IS routing. Specify this command on each interface on which you want to run IS-IS.

Configuring IS-IS for Non-backbone Routers

To configure IS-IS for level-1 routers, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# clns routing

Allows IS-IS to communicate with other IS-IS-configured routers.

Step 2 

Router(config)# router isis

Enables IS-IS routing and specifies an IS-IS process for IP. This command places you in router configuration mode.

Step 3 

Router(config-router)# metric-style wide

Configures a router to generate and accept only new-style type, length, and value objects (TLVs).

Step 4 

Router(config-router)# net nn.nnnn.nnnn.nnnn.nn

Configures the area ID (area address) and the system ID.

Step 5 

Router(config-router)# mpls traffic-eng router-id Loopback0

Specifies that the traffic engineering router identifier for the node is the IP address associated with interface loopback0.

Step 6 

Router(config-router)# mpls traffic-eng level-1

Turns on MPLS traffic engineering for IS-IS at level 1.

Configuring IS-IS for Interfaces

To configure IS-IS for interfaces, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# clns routing

Allows IS-IS to communicate with other IS-IS-configured routers.

Step 2 

Router(config)# router isis

Enables IS-IS routing and specifies an IS-IS process for IP. This command places you in router configuration mode.

Step 3 

Router(config-router)# metric-style wide

Configures a router to generate and accept only new-style type, length, and value objects (TLVs).

Step 4 

Router(config-router)# net nn.nnnn.nnnn.nnnn.nn

Configures the area ID (area address) and the system ID.

Step 5 

Router(config-router)# mpls traffic-eng router-id Loopback0

Specifies that the traffic engineering router identifier for the node is the IP address associated with interface loopback0.

Step 6 

Router(config-router)# interface interface

Specifies the interface.

Step 7 

Router(config-if)# ip router isis

Enables IS-IS routing. Specify this command on each interface on which you want to run IS-IS.

Configuring an MPLS Traffic Engineering Interarea Tunnel

This section includes the following:

Configuring an MPLS Traffic Engineering Interarea Tunnel to Use Explicit Paths

Configuring Explicit Paths

For detailed descriptions of the commands and their arguments, see the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols manual.

To view an example, go to "MPLS and RSVP Support for Traffic Engineering Configuration Example".

Configuring an MPLS Traffic Engineering Interarea Tunnel to Use Explicit Paths

To configure an MPLS traffic engineering tunnel, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# interface tunnel-interface

Configures an interface type and enters interface configuration mode.

Step 2 

Router(config)# ip unnumbered loopback0

Gives the tunnel interface an IP address.

An MPLS traffic engineering tunnel interface should be unnumbered because it represents a unidirectional link.

Step 3 

Router(config-if)# tunnel destination A.B.C.D

Specifies the destination for a tunnel. You must enter the MPLS traffic engineering router ID of the destination device.

Step 4 

Router(config-if)# tunnel mode mpls traffic-eng

Sets the tunnel encapsulation mode to MPLS traffic engineering.

Step 5 

Router(config-if)# tunnel mpls traffic-eng bandwidth bandwidth

Configures the bandwidth required for the MPLS traffic engineering tunnel.

Step 6 

Router(config-if)# tunnel mpls traffic-eng path-option number explicit {name path-name | id path-number} [lockdown]

Configures the tunnel to use a named IP explicit path or a path dynamically calculated from the traffic engineering topology database. The path-option must specify the ABRs the tunnel LSP must traverse as "loose" hops via the next-address loose command.

Configuring Explicit Paths

To configure explicit paths, use the following commands beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# ip explicit-path identifier number enable

Enters the subcommand mode for Internet Protocol (IP) explicit paths and creates or modifies the specified path.

Step 2 

Router(cfg-ip-expl-path)# next-address loose A.B.C.D.

Specifies the next loose IP address in the explicit path. Each ABR the path must traverse should be specified in a next-address loose command.

Verifying the Configuration

Use the show mpls traffic-eng topology command at each ABR in the network to verify that the MPLS TE topology database maintained by the ABR includes the topologies of each area to which it is connected for which MPLS TE is enabled.

Configuration Examples

This section shows how to configure MPLS traffic engineering interarea tunnels for the simple router topology illustrated in Figure 2. It includes configuration fragments that illustrate the following configurations:

OSPF to support interarea traffic engineering tunnels

IS-IS to support interarea traffic engineering tunnels

MPLS and RSVP to support traffic engineering on the routers

Interarea traffic engineering tunnel from router R1 to router R2


Note The examples focus on the configuration required to support interarea tunnels. Additional configuration for MPLS traffic engineering is possible. See the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols manual.


Figure 2 Router Topology

OSPF Configuration Example

The following configuration fragments show how to configure OSPF for interarea tunnels assuming that

Routers R1, Rx, and Ra are in OSPF Area 1

Routers Ra, Ry, and Rb are in OSPF Area 0

Routers Rb, Rz, and R2 are in OSPF Area 2

Router Ra is an ABR for Area 0 and Area 1

Router Rb is an ABR for Area 0 and Area 2

Router R1 OSPF Configuration

router ospf 1
 network 10.0.0.10 0.0.0.0 area 1
 network 135.10.0.0 0.0.255.255 area 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 1

Router Rx OSPF Configuration

router ospf 1
 network 200.1.0.1 0.0.0.0 area 1
 network 135.10.0.0 0.0.255.255 area 1
 network 145.10.0.0 0.0.255.255 area 1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 1

Router Ra OSPF Configuration

Ra is an ABR for Area 0 and Area 1. Interface POS2/0 is in Area 1 and interface POS3/0 is in Area 0. The mpls traffic-eng area commands configure Ra for IGP TE updates for both areas.

router ospf 1
 network 200.2.0.2 0.0.0.0 area 0
 network 145.10.0.0 0.0.255.255 area 1
 network 155.10.0.0 0.0.255.255 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 mpls traffic-eng area 1

Router Ry OSPF Configuration

router ospf 1
 network 200.3.0.3 0.0.0.0 area 0
 network 155.10.0.0 0.0.255.255 area 0
 network 165.10.0.0 0.0.255.255 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0

Router Rb OSPF Configuration

Rb is an ABR for Area 0 and Area 2. Interface POS4/0 is in Area 0 and interface POS5/0 is in Area 2. The mpls traffic-eng area commands configure Rb for IGP TE updates for both areas.

network 200.4.0.4 0.0.0.0 area 0
 network 165.10.0.0 0.0.255.255 area 0
 network 175.10.0.0 0.0.255.255 area 2
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
 mpls traffic-eng area 2

Router Rz OSPF Configuration

router ospf 1
 network 200.5.0.5 0.0.0.0 area 2
 network 175.10.0.0 0.0.255.255 area 2
 network 185.10.0.0 0.0.255.255 area 2
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 2

Router R2 OSPF Configuration

router ospf 1
 network 20.0.0.20 0.0.0.0 area 2
 network 185.10.0.0 0.0.255.255 area 2
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 2

IS-IS Configuration Example

The following configuration fragments illustrate how to configure IS-IS for interarea tunnels assuming

R1 and Rx are level-1 routers

Ra, Ry, and Rb are level-1-2 routers

Rz and R2 level-1 routers

Router R1 IS-IS Configuration

clns routing
interface POS1/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.0100.0000.0010
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1

Router Rx IS-IS Configuration

clns routing
interface POS1/0
 ip router isis
interface POS2/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.2000.0100.0001
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1

Router Ra IS-IS Configuration

clns routing
interface POS2/0
 ip router isis
interface POS3/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.2000.0200.0002
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
 mpls traffic-eng level-2

Router Ry IS-IS Configuration

clns routing
interface POS3/0
 ip router isis
interface POS4/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.2000.0300.0003
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
 mpls traffic-eng level-2

Router Rb IS-IS Configuration

clns routing
interface POS4/0
 ip router isis
interface POS5/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.2000.0400.0004
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1
 mpls traffic-eng level-2

Router Rz IS-IS Configuration

clns routing
interface POS5/0
 ip router isis
interface POS6/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.2000.0500.0005
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1

Router R2 IS-IS Configuration

clns routing
interface POS6/0
 ip router isis
router isis
 metric-style wide
 net 49.0000.0200.0000.0020
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-1

MPLS and RSVP Support for Traffic Engineering Configuration Example

The following configuration fragments show how to configure MPLS and RSVP to support traffic engineering on the routers.

Router R1 Traffic Engineering Configuration

ip cef
mpls traffic-eng tunnels
interface Loopback0
 ip address 10.0.0.10 255.255.255.255
interface POS1/0	!Each interface supporting MPLS TE must include the following:
 mpls traffic-eng tunnels
 ip rsvp bandwidth <bandwidth-value>

The configuration of routers Rx, Ra, Ry, Rb, Rz, and R2 for traffic engineering operation is similar to 
that for R1.

Interarea Tunnel Configuration Example

The following configuration fragments show how to configure a traffic engineering interarea tunnel. Router R1 is the head-end for Tunnel1, and Router R2 (20.0.0.20) is the tail-end. Tunnel1 is configured with a path option that is loosely routed through Ra and Rb.

R1 Interarea Tunnel Configuration

interface Tunnel1
 ip unnumbered Loopback0
 tunnel destination 20.0.0.20
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng bandwidth 300
 tunnel mpls traffic-eng path-option 1 explicit name path-tunnel1

ip explicit-path name path-tunnel1
 next-address loose 200.2.0.2
 next-address loose 200.4.0.4
 next-address loose 20.0.0.20	!Specifying the tunnel tail-end in the loosely router
	!path is optional.

Note Generally for an interarea tunnel you should configure multiple loosely routed path options that specify different combinations of ABRs (for OSPF) or level-1-2 boundary routers (for IS-IS) to increase the likelihood that the tunnel will be successfully signaled. In this simple topology there are no other loosely routed paths.


Command Reference

This section documents the following modified command:

next-address

All other commands used with this feature are documented in the Cisco IOS Release 12.2 command reference publications.

next-address

To specify the next IP address in an explicit path, use the next-address command in IP explicit path configuration mode.

next-address [loose | strict] A.B.C.D

To remove an address from an explicit path, use the no index configuration command in IP explicit path configuration mode.

Syntax Description

loose

Specifies that the previous address (if any) in the explicit path need not be directly connected to A.B.C.D, and that the router is free to determine the path from the previous address (if any) to A.B.C.D.

strict

Specifies that the previous address (if any) in the explicit path must be directly connected to A.B.C.D.

A.B.D.C

Next IP address in the explicit path.


Defaults

Strict.

Command Modes

IP explicit path configuration

Command History

Release
Modification

12.0(5)S

This command was introduced.

12.0(19)ST1

The loose keyword was added.

12.0(21)ST

The command is supported on the Cisco GSR 12000 series platform.

12.0(22)S

The command is supported on the Cisco 10000 series edge services routers (ESRs).


Usage Guidelines

To specify an explicit path where the path may include only the addresses specified, specify each address in sequence by using the next-address command with no loose optional keyword.

To configure an interarea TE tunnel, you must configure the tunnel path options as loose explicit paths, for which each ABR traversed by the tunnel LSP is specified as a loose hop by entering the loose option of the next-address command. When there are choices for the ABRs to be used, multiple explicit paths are recommended, each of which identifies a different sequence of ABRs in order to increase the likelihood that a path to the destination will be found.

For explicit paths to be used for TE tunnels within an IGP area, you may specify a combination of both loose and strict hops via next-address commands.

Examples

The following commands configure a loose IP explicit path with ID 60 suitable for use as a path option for an interarea TE tunnel with destination 3.3.29.3 that is to traverse ABRs 3.3.27.3 and 3.3.28.3. The tunnel head-end and the specified ABRs will find a path from the source across Area 1 to ABR1, from ABR1 across Area 0 to ABR2, and from ABR2 across Area 2 to the destination 3.3.29.3.

Router(config)# ip explicit-path identifier 60
Router(cfg-ip-expl-path)# next-address loose 3.3.27.3
Router(cfg-ip-expl-path)# next-address loose 3.3.28.3
Router(cfg-ip-expl-path)# next-address loose 3.3.29.3

Note that the explicit path for an interarea TE tunnel need not specify the destination router because the tunnel configuration specifies it in the tunnel destination command. The following commands configure an exploit path named path-without-tailend that would work equally well for the above interarea tunnel:

Router(config)# ip explicit-path name path-without-tailend
Router(cfg-ip-expl-path)# next-address loose 3.3.27.3
Router(cfg-ip-expl-path)# next-address loose 3.3.28.3

Related Commands

Command
Description

ip explicit-path

Enters the subcommand mode for IP explicit paths and creates or modifies the specified path.

list

Displays all or part of the explicit path(s).

show ip explicit-paths

Displays configured IP explicit paths.


Glossary

ABR—Area border router. Area border routers are routers connecting two areas. In OSPF, ABRs belong to both areas and must maintain separate topological databases for each. When an OSPF router has interfaces in more than one area, it is an area border router.

area—A logical set of network segments (for example, one that is OSPF-based) and their attached devices. Areas usually are connected to other areas by routers, making up a single autonomous system. OSPF and IS-IS define their areas differently. OSPF area borders are marked by routers. Some interfaces are in one area, and other interfaces are in another area. With IS-IS, all the routers are completely within an area, and the area borders are on links, not on routers. The routers that connect the areas are level-2 routers, and routers that have no direct connectivity to another area are level-1 routers.

area border router—See ABR.

area ID—In an IS-IS router, this area address is associated with the entire router rather than an interface. A router can have up to three area addresses. Both the area ID and the system ID are defined on an IS-IS router by a single address, the Network Entry Title (NET).

autonomous system—A collection of networks under a common administration sharing a common routing strategy. Autonomous systems are subdivided by areas.

CEF—Cisco Express Forwarding. An advanced Layer 3 IP switching technology. CEF optimizes network performance and scalability for networks that have large and dynamic traffic patterns, such as the Internet, as well as for networks characterized by intensive Web-based applications or interactive sessions. CEF uses a Forwarding Information Base (FIB) to make IP destination prefix-based switching decisions. The FIB is conceptually similar to a routing table or information base. When routing or topology changes occur in the network, the IP routing table is updated, and those changes are reflected in the FIB. The FIB maintains next-hop address information based on the information in the IP routing table.

Cisco Express Forwarding—See CEF.

head-end—The upstream, transmit end of a tunnel. The router that originates and maintains the traffic engineering LSP.

IGP—Interior Gateway Protocol. Internet protocol used to exchange routing information within an autonomous system. Examples of common IGPs include OSPF and RIP.

interarea TE—Ability for a traffic engineering LSP to span multiple areas.

Interior Gateway Protocol—See IGP.

Intermediate System-to-Intermediate System—See IS-IS.

IS-IS—Intermediate System-to-Intermediate System. OSI link-state hierarchial routing protocol based on DECnet Phase V routing, where intermediate system (IS) routers exchange routing information based on a single metric to determine the network topology.

label-switched path—See LSP.

label-switched path (LSP) tunnel—A configured connection between two routers in which label switching is used to carry the packets.

level-1 routers—Routers that are directly connected to other areas. The routers are not in the backbone. MPLS does not run in the background. These routers are also called internal routers.

level-2 routers—Routers that connect two areas. These routers let you run MPLS in the background.

load balancing—The distribution of traffic among multiple paths to the same destination in order to use bandwidth efficiently. Load balancing increases the use of network segments, thus increasing effective network bandwidth.

LSP—label-switched path. A sequence of hops (R0...Rn) in which a packet travels from R0 to Rn through label switching mechanisms. A label-switched path can be chosen dynamically, based on normal routing mechanisms, or through configuration.

mask—A bit combination used to describe which part of an address refers to the network or the subnet and which part refers to the host.

MPLS—Multiprotocol Label Switching. A method for forwarding packets (frames) through a network. It enables routers at the edge of a network to apply labels to packets. ATM switches or existing routers in the network core can switch packets according to the labels with minimal lookup overhead.

Multiprotocol Label Switching—See MPLS.

Open Shortest Path First—See OSPF.

OSPF—Open Shortest Path First. Link-state, hierarchical IGP routing algorithm proposed as a successor to RIP in the Internet community. OSPF features include least-cost routing, multipath routing, and load balancing.

process ID—Distinguishes one process from another within the device. An OSPF process ID can be any positive integer, and it has no significance outside the router on which it is configured.

router ID—Something by which a router originating a packet can be uniquely distinguished from all other routers. For example, an IP address from one of the router's interfaces.

tail-end—The downstream, receive end of a tunnel. The router that terminates the traffic engineering LSP.

traffic engineering—The techniques and processes that cause routed traffic to travel through the network on a path other than the one that would have been chosen if standard routing methods were used.

tunnel—A secure communication path between two peers, such as two routers. A traffic engineering tunnel is a label-switched tunnel that is used for traffic engineering. Such a tunnel is set up through means other than normal Layer 3 routing; it is used to direct traffic over a path different from the one that Layer 3 routing could cause the tunnel to take.

virtual link—Ordinarily, each area is directly connected to area 0. A virtual link is used for a connection when an area is connected to an area that is one area from area 0.