Guest

Cisco IOS Software Releases 12.0 S

ATM Cell Loss Priority Setting on Cisco 12000 Series 8-Port OC-3 STM-1 ATM Line Cards

  • Viewing Options

  • PDF (245.8 KB)
  • Feedback
ATM Cell Loss Priority Setting on Cisco 12000 Series 8-Port OC-3 STM-1 ATM Line Cards

Table Of Contents

ATM Cell Loss Priority Setting on Cisco 12000 Series 8-Port OC-3 STM-1 ATM Line Cards

Feature Overview

Benefits

Restrictions

Related Features and Technologies

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Prerequisites

Configuration Tasks

Configuring the ATM CLP Bit Setting Feature

Defining a Class Map

Configuring a Policy with ATM CLP Setting in the Policy Map

Attaching the Service Policy and Enabling the ATM CLP Setting Feature

Verifying the ATM CLP Setting Feature

Monitoring and Maintaining ATM CLP Setting

Configuration Examples

CLP Bit Setting on a Per-Experimental Basis Without Per-VC WRED, VC Bundling, or Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Queue Basis with Per-VC WRED and/or Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Experimental Basis with Per-VC WRED and/or Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Experimental Basis with VC Bundling

CLP Bit Setting on a Per-Precedence Basis with Per-VC WRED, VC Bundling, and Per-VC MDRR/LLQ


ATM Cell Loss Priority Setting on Cisco 12000 Series 8-Port OC-3 STM-1 ATM Line Cards


Feature History

Release
Modification

12.0(23)S

This feature was made available on the 8-Port OC-3 STM-1 ATM line card for Cisco 12000 Series Internet Routers.


This feature module describes the ATM Cell Loss Priority (CLP) setting feature. The ATM CLP setting feature allows users to control the ATM CLP bit setting on the 8-Port OC-3 STM-1 ATM line card for Cisco 12000 Series Internet Routers.

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuration Examples

Feature Overview

Before development of the ATM CLP Setting feature, the CLP bit in the ATM header of a cell provided a method of controlling the discarding of cells in a congested ATM environment. A CLP bit contains two settings: 0 or 1. Cells with a CLP bit setting of 1 are discarded before cells with a CLP bit setting of 0. Before the introduction of the ATM CLP Setting feature, the CLP bit was automatically set to 0 when Cisco routers converted packets into ATM cells for ATM networks.

The ATM CLP Setting feature allows users to control the CLP bit setting on Cisco 12000 Series Internet Routers equipped with the 8-Port OC-3 STM-1 ATM line card. The CLP bit is set on each packet individually, and the default CLP bit setting is 0. The application of the ATM CLP Setting feature changes the CLP bit setting to 1. Therefore, users have the option to leave each packet with the default CLP bit setting of 0 or to establish a new CLP bit setting of 1.

Benefits

The ATM CLP Setting feature offers improved bandwidth management by allowing users to extend their IP QoS policies into an ATM network by setting the ATM Cell Loss Priority (CLP) bit in ATM cells in an outgoing AAL5 packet based on the IP precedence or MPLS experimental bits of the incoming packets. A downstream device, such as an ATM switch, can then make congestion-alleviating decisions based on the CLP bit of the ATM cells. As congestion occurs in the ATM network, cells with the CLP bit set are more likely to be dropped, resulting in improved network performance for high priority traffic and applications.

Restrictions

The following qualifications apply when you are configuring the ATM CLP bit setting on an 8-Port OC-3 STM-1 ATM line card:

As implemented, this feature is supported on the 8-Port OC-3 STM-1 ATM line card only.

A policy map containing the set atm-clp command can be attached as an output policy only.

Cisco Express Forwarding (CEF) or distributed Cisco Express Forwarding (dCEF) switching is required.

This feature does not support packets that originate from the router.

This feature does not provide any support for the CLP bit of ATM cells in Rx packets. The CLP bit in cells of Rx packets is currently ignored. It is neither copied into cells of any Tx packets, nor acted upon in any other way on the router.

CLP bit setting is based only on the IP precedence or MPLS experimental bits. This feature does not provide support for ACL-based setting of the CLP bit, or setting based on incoming DSCP bits.

This feature does not perform any action based on the setting of the CLP bit once the bit is set. The segmentation and reassembly (SAR) circuitry on the line card only sets the bit. It does not look at the bit to decide whether to drop a packet. All packet drops on the SAR are due to resource exhaustion, queue-limits, or RED/WRED. All actions based on the CLP bit will occur on a downstream switch or router in the ATM cloud.

This feature supports unicast traffic only. Multicast or broadcast traffic will be put in the same queue and with the same CLP bit marking as IP precedence 0 traffic (except all traffic sourced by the router, including multicast or broadcast traffic, will have CLP=0).

This feature supports PVCs and point-to-point subinterfaces only. It does not support SVCs or multipoint or point-to-multipoint subinterfaces.

It is not configurable on main interfaces. It can be configured on subinterfaces only.

Related Features and Technologies

Multiprotocol Label Switching (MPLS)

Layer 3 quality-of-service (QoS)

Weighted Random Early Detection (WRED)

Modified Deficient Round Robin (MDRR)

Low Latency Queuing (LLQ)

See the "Related Documents" section for documents describing these features and technologies.

Related Documents

The following documents provide additional information about installing and configuring the 8-Port OC-3 STM-1 ATM line card:

8-Port OC-3 STM-1 ATM Line Card Installation and Configuration

Release Notes for Cisco 12000 Series Routers for Cisco IOS Release 12.0 S

Release Notes for Cisco IOS Release 12.0 S

Cisco IOS Release 12.0 Wide-Area Networking Configuration Guide

Weighted Random Early Detection on the Cisco 12000 Series Router

Multiprotocol Label Switching on Cisco Routers

MPLS Virtual Private Networks

Modular Quality of Service Command-Line Interface

You can also find additional information in the installation and configuration guide for your Cisco 12000 Series Internet Router and in the Cisco IOS Release 12.0 documentation set.

Supported Platforms

The 8-Port OC-3 STM-1 ATM line card is compatible with all Cisco 12000 Series Internet Routers and Cisco 12400 Series Internet Routers that are operating with Cisco IOS Release 12.0(23)S or later.

Supported Standards, MIBs, and RFCs

Standards

No new or modified standards apply to this feature.

MIBs

The CISCO-CLASS-BASED-QOS-MIB was modified to add support for the ATM CLP bit setting feature on the 8-Port OC-3 STM-1 ATM line card.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco  MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco  MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

RFCs

No new or modified RFCs apply to this feature.

Prerequisites

The use of this feature is subject to the following conditions:

This implementation of the ATM CLP bit setting feature works only on the 8-Port OC-3 STM-1 ATM line card. The Cisco 12000 Series Internet Router must be equipped with an 8-Port OC-3 STM-1 ATM line card, and must running Cisco IOS software Release 12.0(23)S or a later version of Cisco IOS software Release 12.0S.

Class maps, policy maps, and service policies are required to enable the ATM CLP bit setting feature.

Configuration Tasks

See the following sections for configuration tasks associated with the 8-Port OC-3 STM-1 ATM line card. Each task in the list is identified as either required or optional.

Configuring the ATM CLP Bit Setting Feature (Required)

Verifying the ATM CLP Setting Feature (Optional)

Configuring the ATM CLP Bit Setting Feature

You must perform these tasks before you can enable the ATM CLP Setting feature:

1. Defining a Class Map

2. Configuring a Policy with ATM CLP Setting in the Policy Map

3. Attaching the Service Policy and Enabling the ATM CLP Setting Feature


Defining a Class Map

To create a class map containing match criteria, use the class-map command to specify the class map name, and then use a match command in the class map configuration mode. The "Configuring a Policy with ATM CLP Setting in the Policy Map" section below explains how the ATM CLP Setting feature is applied with this class map.

Command
Purpose

Router(config)# class-map class-name

Specifies the user-defined name of class map.

Router (config-cmap)# match ip precedence number

Specifies up to four IP precedence values used as match criteria.

Router (config-cmap)# match mpls experimental mpls-values

Specifies up to eight Multiprotocol Label Switching (MPLS) experimental bit values to use as match criteria against which packets are checked to whether they belong to the class.


Configuring a Policy with ATM CLP Setting in the Policy Map

Before enabling the ATM CLP Setting feature, you must create and configure a policy map.

To configure a policy map, use the policy-map command to specify the policy map name, and then use the following configuration commands to configure the class and the QoS policy. The ATM CLP Setting feature is configured in the policy map with the set atm-clp command. In this example, all output packets with the match criteria specified by the class map are sent with the CLP bit set to 1. If the set atm-clp command was not issued, the default CLP bit setting of 0 would remain.


Note This feature is expected to be backward compatible with any previous implementations of the CLP bit setting feature that use the MQC set atm-clp command. There is no expected loss of backward compatibility with the command-line interface. However, there will not be counters available of the number of marked and unmarked packets for each class, so these stats will not be available for MIBs or show commands.


 
Command
Purpose

Step 1 

Router(config)# policy-map policy-name

Specifies the name of the policy map to configure.

Step 2 

Router(config-pmap)# class-map class-name

Specifies the name of a predefined class included in the service policy.

Step 3 

Router(config-pmap-c)# set atm-clp

Sets the ATM CLP bit to 1.

Attaching the Service Policy and Enabling the ATM CLP Setting Feature

To attach a service policy to a PVC, use the service-policy output command in PVC configuration mode. Once the service policy is attached to the PVC, the ATM CLP Setting feature is enabled for that PVC, provided the set atm-clp command was issued in the policy map configuration.

Command
Purpose

Router(config-if-atm-vc)# service-policy output policy-name

Enables the ATM CLP Setting feature by attaching the specified service policy map to the PVC.

Verifying the ATM CLP Setting Feature

To verify that the ATM CLP Setting feature has been enabled on the 8-Port OC-3 STM-1 ATM line card, perform the following steps:

 
Command
Purpose

Step 1 

Router# show policy-map

Displays policy map information. Verify that the output list includes the newly configured set atm-clp command entry.

Step 2 

Router# show policy-map interface atm slot/port[.subinterface-number]

Displays the contents of a policy map, including the attached interface.

Step 3 

Router# show atm pvc

Displays information about the ATM interfaces.

Monitoring and Maintaining ATM CLP Setting

To monitor and maintain the ATM CLP Setting feature, use the following commands:

Command
Purpose

Router# show policy-map

Displays the contents of a policy map.

Router# show policy-map interface atm slot/port[.subinterface-number]

Displays the contents of a policy map, including the attached interface.

Router# show atm pvc

Displays general ATM PVC statistics associated with the PVCs on the interface.

Router# show atm pvc pvc-name

Displays in-depth ATM PVC statistics associated with a particular interface.

Configuration Examples

This section provides examples of the use of the CLP bit setting feature by itself or in combination with per-VC WRED, VC bundling, or per-VC MDRR with LLQ (MDRR/LLQ).

This section provides the following configuration examples:

CLP Bit Setting on a Per-Experimental Basis Without Per-VC WRED, VC Bundling, or Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Queue Basis with Per-VC WRED and/or Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Experimental Basis with Per-VC WRED and/or Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Experimental Basis with VC Bundling

CLP Bit Setting on a Per-Precedence Basis with Per-VC WRED, VC Bundling, and Per-VC MDRR/LLQ

CLP Bit Setting on a Per-Experimental Basis Without Per-VC WRED, VC Bundling, or Per-VC MDRR/LLQ

This example configures CLP bit setting using the MPLS experimental bits on a normal VC (1 queue per VC). For this example, the MPLS experimental bit values 0, 2, 4, 6 have the CLP bit turned on, while the other experimental values have the CLP bit turned off. A hierarchical policy is not needed in this case because per-VC MDRR/LLQ is not enabled using either the bandwidth or priority commands. (The set command does not cause a queue to be created.)


Note This example uses matching conditions based on "match mpls experimental." This usage causes CLP bits to be set based on the incoming MPLS experimental bits. You can just as easily use the IP precedence bits to do this matching instead of MPLS experimental bits.


class-map match-any exp0246
  match mpls experimental 0 2 4 6
policy set-clp-0246
  class exp0246
    set atm-clp
interface atm4/0.1 point-to-point
ip address 4.0.1.1 255.255.255.0
  pvc 40/1
    service-policy output set-clp-0246

CLP Bit Setting on a Per-Queue Basis with Per-VC WRED and/or Per-VC MDRR/LLQ

This example configures per-VC MDRR/LLQ and CLP bit setting on a per-queue basis. The example uses 4 queues. Experimental 0 and 1 go to queue 1 with CLP on. Experimental 2 and 3 go to queue 2 with CLP off. Experimental 4 and 5 go to queue 3 with CLP on, and experimental 6 and 7 go to queue 4 with CLP off. This example scheme does not require a hierarchical policy because all experimental values in each queue have the same CLP bit value.


Note This example uses matching conditions based on "match mpls experimental." This usage causes CLP bits to be set based on the incoming MPLS experimental bits. You can just as easily use the IP precedence bits to do this matching instead of MPLS experimental bits.


class-map match-any exp01
  match mpls experimental 0 1
class-map match-any exp23
  match mpls experimental 2 3
class-map match-any exp45
  match mpls experimental 4 5
policy set-clp-0145
  class exp01
    bandwidth percent 25
    set atm-clp
  class exp23
    bandwidth percent 25
  class exp45
    bandwidth percent 25
    set atm-clp
interface atm4/0.1 point-to-point
  ip address 4.0.1.1 255.255.255.0
  pvc 40/1
    service-policy output set-clp-0145
  !
  tag-switching ip

CLP Bit Setting on a Per-Experimental Basis with Per-VC WRED and/or Per-VC MDRR/LLQ

This example configures per-VC MDRR/LLQ and CLP bit setting using the MPLS experimental bits. There are 2 queues, each of which gets 50% of the bandwidth. Experimental 0 and 1 go to queue 1 with CLP on. Experimental 2 and 3 go to queue 1 with CLP off. Experimental 4 and 5 go to queue 2 with CLP on, and experimental 6 and 7 go to queue 2 with CLP off. This example scheme requires a hierarchical policy.


Note This example uses matching conditions based on "match mpls experimental." This usage causes CLP bits to be set based on the incoming MPLS experimental bits. You can just as easily use the IP precedence bits to do this matching instead of MPLS experimental bits.


class-map match-any exp01
  match mpls experimental 0 1
class-map match-any exp45
  match mpls experimental 4 5
class-map match-any exp0123
  match mpls experimental 0 1 2 3
policy child-set-clp-0145
  class exp01
    set atm-clp
  class exp45
    set atm-clp
policy parent-set-clp-0145
  class exp0123
    bandwidth percent 50
    service-policy child-set-clp-0145
  class class-default
    service-policy child-set-clp-0145
interface atm4/0.1 point-to-point
  ip address 4.0.1.1 255.255.255.0
  pvc 40/1
    service-policy output parent-set-clp-0145
  !
  tag-switching ip


Note Configuring CLP bit setting combined with per-VC WRED is similar to this example and is not shown in this publication.


CLP Bit Setting on a Per-Experimental Basis with VC Bundling

CLP bit setting can be combined with VC bundling by configuring VC bundling on a group of VCs as desired, a policy-map with CLP bit setting configured as desired, and then configuring the CLP bit setting.

This example configures VC bundling and CLP bit setting on a per-experimental basis. There are 2 VCs. Experimental 0 and 1 go to VC 1 with CLP on. Experimental 2 and 3 go to VC 1 with CLP off. Experimental 4 and 5 go to VC 2 with CLP on, and experimental 6 and 7 go to VC 2 with CLP off. This does not require a hierarchical policy because there is only one queue per VC.


Note This example uses matching conditions based on "match mpls experimental." This usage causes CLP bits to be set based on the incoming MPLS experimental bits. You can just as easily use the IP precedence bits to do this matching instead of MPLS experimental bits.


class-map match-any exp01
  match mpls experimental 0 1
class-map match-any exp45
  match mpls experimental 4 5
policy set-clp-0145
  class exp01
    set atm-clp
  class exp45
    set atm-clp
interface atm4/0.1 point-to-point
  ip address 4.0.1.1 255.255.255.0
  bundle my-paris2-bundle
    pvc-bundle 40/1
      precedence 0-3
      service-policy output set-clp-0145
    pvc-bundle 40/2
      precedence 4-7
      service-policy output set-clp-0145
  !
  tag-switching ip

CLP Bit Setting on a Per-Precedence Basis with Per-VC WRED, VC Bundling, and Per-VC MDRR/LLQ

CLP bit setting is supported simultaneously by per-VC WRED, VC bundling, and per-VC MDRR/LLQ, where all features are configured on a per-precedence basis. The following example shows how this combination can be configured.

This example configures CLP bit setting with per-VC WRED, VC bundling, and per-VC MDRR/LLQ on a per-precedence basis. Table 1 shows the desired settings for each precedence for each of these features.

Table 1 Desired Settings for Example of CLP Bit Setting with Per-VC WRED, VC Bundling, and Per-VC MDRR/LLQ

Exp Value
VC Number
Queue Number
WRED
CLP

0

1

1, 50%

val1

0

1

1

1, 50%

val2

1

2

1

2, 50%

val3

0

3

1

2, 50%

val4

1

4

2

1, 50%

val5

0

5

2

1, 50%

val6

1

6

2

2, 50%

val7

0

7

2

2, 50%

val8

1


This example requires a hierarchical policy because there are multiple CLP values per queue.

class-map match-any exp0145                           ! Per-VC MDRR
  match ip precedence 0 1 4 5                         
  match mpls experimental 0 1 4 5
class-map match-any exp1357                           ! CLP=1
  match mpls experimental 1 3 5 7
policy child-set-clp-1357
  class exp1357
    set atm-clp
policy parent-set-clp-1357-paris123
  class exp0145
    bandwidth percent 50                              ! Per-VC MDRR/LLQ
    random-detect                                     ! Per-VC WRED
    random-detect exponential-weighting-constant 9
    random-detect precedence 0 288 cells 576 cells 10
    random-detect precedence 1 324 cells 576 cells 10
    random-detect precedence 2 360 cells 576 cells 10
    random-detect precedence 3 396 cells 576 cells 10
    random-detect precedence 4 432 cells 576 cells 10
    random-detect precedence 5 468 cells 576 cells 10
    random-detect precedence 6 504 cells 576 cells 10
    random-detect precedence 7 540 cells 576 cells 10
    service-policy child-set-clp-1357                 ! CLP
  class class-default
    random-detect
    random-detect exponential-weighting-constant 9
    random-detect precedence 0 288 cells 576 cells 10
    random-detect precedence 1 324 cells 576 cells 10
    random-detect precedence 2 360 cells 576 cells 10
    random-detect precedence 3 396 cells 576 cells 10
    random-detect precedence 4 432 cells 576 cells 10
    random-detect precedence 5 468 cells 576 cells 10
    random-detect precedence 6 504 cells 576 cells 10
    random-detect precedence 7 540 cells 576 cells 10
    service-policy child-set-clp-1357
interface atm4/0.1 point-to-point
  ip address 4.0.1.1 255.255.255.0
  bundle my-paris2-bundle                             ! VC bundling
    pvc-bundle 40/1
      precedence 0-3
      service-policy output parent-set-clp-1357-paris123
    pvc-bundle 40/2
      precedence 4-7
      service-policy output parent-set-clp-1357-paris123
  !
  tag-switching ip