Guest

Cisco IOS Software Releases 12.0 S

QoS: Enhancements to Single QoS Policy Definition for a Physical Interface (L3/1C/nD) including Match FR-DLCI

  • Viewing Options

  • PDF (292.1 KB)
  • Feedback
QoS: Enhancements to Single QoS Policy Definition for a Physical Interface (L3/1C/nD) Including Match FR-DLCI

Table Of Contents

QoS: Enhancements to Single QoS Policy Definition for a Physical Interface (L3/1C/nD) Including Match FR-DLCI

Contents

Prerequisites

Information About L3/1C/nD Including Match FR-DLCI

How to Implement L3/1C/nD Including Match FR-DLCI

Configuring Class Maps

Configuring and Attaching Policy Maps to a Main Interface

Restrictions

Configuration Examples for L3/1C/nD Including Match FR-DLCI

L3/1C/nD Service Provider Configuration Example 1

L3/1C/nD Service Provider Configuration Example 2

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

match fr-dlci

show class-map

show policy-map interface


QoS: Enhancements to Single QoS Policy Definition for a Physical Interface (L3/1C/nD) Including Match FR-DLCI


The L3/1C/nD feature allows you to provision multiple Frame Relay DLCI subinterfaces under the same policy map on a physical port. The enhanced match fr-dlci class-map configuration command now permits a range of DLCIs to be specified on a single command line. This feature is intended for service providers.

Feature History

Release
Modification

12.0(28)S

This feature was introduced for select Cisco 12000 Series ISE (E3) line cards.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites

Information About L3/1C/nD Including Match FR-DLCI

How to Implement L3/1C/nD Including Match FR-DLCI

Configuration Examples for L3/1C/nD Including Match FR-DLCI

Additional References

Command Reference

Prerequisites

Knowledge of how to use the Cisco Modular Quality of Service Command line Interface (MQC) is required to create Quality of Service (QoS) class maps, policy maps. See the "Related Documents" section for further information.

The QoS: Enhancements to Single QoS Policy Definition for a Physical Interface (L3/1C/nD) Including Match FR-DLCI is supported on the following Cisco 12000 Series ISE line cards:

Supported Cisco 12000 Series Internet Services Engine (E3) Line Cards

1-Port Channelized OC-12/STM-4 (DS1/E1) ISE Line Card
Product Number: CHOC12/DS1-IR-SC=

1-Port Channelized OC-48/STM-16 (DS3/E3, OC-3c/STM-1c, OC-12c/STM-4c) POS/SDH ISE Line Card
Product Number: CHOC48/DS3-SR-SC=

4-Port Channelized OC-12/STM-4 (DS3/E3, OC-3c/STM-1c) POS/SDH ISE Line Card
Product Number: 4CHOC12/DS3-I-SCB=

16-Port OC-3c/STM-1c POS/SDH ISE Line Card
Product Numbers: 6OC3X/POS-I-LC-B=, 16OC3X/POS-M-MJ-B=

Information About L3/1C/nD Including Match FR-DLCI

The L3/1C/nD feature provides a mechanism whereby a physical interface is provided to a single customer (1C) and multiple Frame Relay DLCIs (nD) are provisioned for that customer. Each DLCI supports a logically separate service at Layer 3 (L3). The aggregate bandwidth of all DLCIs can be a subrate of the physical interface. A single Modular Quality of Service Command line interface (MQC) policy can be applied at the physical interface level rather than at each DLCI level to shape the aggregate rate and enforce the service policy, but still maintain policing or shaping behavior appropriate to the class of traffic. Quality of Service (QoS) features can be applied to the inbound and outbound directions that include an enhanced match fr-dlci class-map configuration command.

How to Implement L3/1C/nD Including Match FR-DLCI

This section contains the following procedures:

"Configuring Class Maps" section (required)

"Configuring and Attaching Policy Maps to a Main Interface" section (required)

Configuring Class Maps

An implementation of the L3/1C/nD feature may require configuring multiple class maps. To configure class maps, complete the following procedure.

SUMMARY STEPS

1. enable

2. configure terminal

3. class-map [match-all | match-any] class-map-name

4. match ip precedence number

5. match fr-dlci dlci-number [- dlci-number]

6. exit

7. Repeat Steps 3 through 5 for each class that you want to create.

8. exit

9. show class-map

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

class-map [match-all | match-any]class-map-name

Example:

Router(config)# class-map match-all prec1

Specifies the name of the class map to be created and enters class-map configuration mode.

Enter the class map name.

If the match-all or match-any keyword is not specified, traffic must match all the match criteria to be classified as part of the traffic class.

Step 4 

match ip precedence number
Example:
Router#(config-cmap)# match ip precedence 1 

Configures the class map created above to match traffic based on the IP precedence number or the packet.

Step 5 

match fr-dlci dlci-number [- dlci-number] 
Example:
Router#(config-cmap)# match fr-dlci 17-19 

Configures the class map created above to match traffic based on the Frame Relay DLCI number associated with the packet.

Enter the DLCI numbers or DLCI ranges. Enter as many DLCI numbers, DLCI ranges, or both as needed.

Step 6 

exit
Example:
Router#(config-cmap)# exit 

(Optional) Exits class-map configuration mode.

Step 7 

Repeat Steps 3 through 5 for each class that you want to create.

 

Step 8 

show class-map


Router# show class-map

Display all class maps and their match criteria.

Configuring and Attaching Policy Maps to a Main Interface

After a policy map is created, the next step is to attach the policy map to an interface. Policy maps can be attached to either the input or output direction of the interface.

To attach the policy map to an interface, perform the following steps:

SUMMARY STEPS

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class class-name

5. shape average 20000000

6. service-policy policy-map-name

7. exit

8. exit

9. interface serial0

10. encapsulation {frame-relay | hdlc | ppp}

11. service-policy {history | input | output} policy-map-name

12. exit

13. show running-config interface serial0

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

policy-map policy-map-name

Example:

Router(config)# policy-map parent

Specifies the name of the policy map to be created or modified. Enters policy-map configuration mode.

Step 4 

class class-map-name

Example:

Router(config-pmap)# class class-default

Specifies a class map name. Enters policy-map class configuration mode.

Step 5 

shape average

Example:

Router(config-pmap-c)# shape average 20000000

Specifes the traffic-shaping method for the class being configured.

Step 6 

service-policy policy-map-name

Example:

Router(config-pmap-c)# service-policy child

Specifies the name of a policy map to be nested within the one being configured.

Step 7 

exit

Example:

Router#(config-pmap-c)# exit

(Optional) Exits policy-map class configuration mode.

Step 8 

exit

Example:

Router#(config-pmap)# exit

(Optional) Exits policy-map configuration mode.

Step 9 

interface serial0

Example:

Router(config)# interface serial0

Configures an interface (or subinterface) type and enters interface configuration mode.

Enter the interface type number.

Step 10 

encapsulation {frame-relay | hdlc | ppp}

Example:

Router(config-inf)# encapsulation frame-relay

Specifies the level 2 encapsulation method.

Step 11 

service-policy {input | output} policy-map-name

Example:

Router(config-inf)# service-policy output parent

Specifies the name of the policy map to be attached to the input or output direction of the interface.

Note Policy maps can be configured on ingress or egress routers. They can also be attached in the input or output direction of an interface. The direction (input or output) and the router (ingress or egress) to which the policy map should be attached varies according your network configuration. When using the service-policy command to attach the policy map to an interface, be sure to choose the router and the interface direction that are appropriate for your network configuration.

Enter the policy map name.

Step 12 

exit

Example:

Router(config-inf)# exit

(Optional) Exits interface configuration mode.

Step 13 

show running-config interface serial0

Example:

Router# show running-config interface serial0

(Optional) Displays parameters and the current policies attached to the specified interface.

Use this command to verify the configuration.

Restrictions

If an L3/1C/nD policy is applied to a main interface, any policies applied to any subinterfaces associated with the main interface are disallowed.

If no policy is configured on the main interface, policies can be applied to subinterfaces.

If a hierarchical policy map is applied to a Frame Relay Main interface, only a single class with portshaping is supported (class-default). No other classes can be configured as part of the hierarchical policy.

The legacy rate-limit interface configuration command cannot be applied to a subinterface if an L3/1C/nD service policy is applied to the main interface.

No match fr-dlci support exists for extended DLCI identifiers.

A policy attached to the main interface is associated (or shared) with all the corresponding subinterfaces.

Policies attached to subinterfaces are not associated or shared with the main interface. No statistics of individual classes under the main interface policy associated to the subinterfaces are provided.

The match protocol class-map configuration command is not supported.

Configuration Examples for L3/1C/nD Including Match FR-DLCI


Note Better performance can be derived by using contiguous DLCI numbers in class maps.


In the following example, a hierarchical policy map named "parent" calls a policy map named "child." The policy map "child" defines three service classes that filter traffic by IP precedence on Frame Relay DLCIs configured on the subinterfaces. The policy map "parent" is applied to the main interface.

Creating the Classes

Router# configure terminal
Router(config)# class-map match-all prec0
Router(config-cmap)# match ip precedence 0
Router(config-cmap)# match fr-dlci 16
Router#(config-cmap)# exit

Router(config)# class-map match-all prec1
Router#(config-cmap)# match ip precedence 1
Router#(config-cmap)# match fr-dlci 17-19 
Router#(config-cmap)# exit

Router(config)# class-map match-all prec2 
Router(config-cmap)# match ip precedence 2 
Router(config-cmap)# match fr-dlci 20
Router#(config-cmap)# exit

Creating the Policy Maps

Router(config)# policy-map parent 
Router(config-pmap)# class class-default 
Router(config-pmap-c)# shape average 20000000 
Router(config-pmap-c)# service-policy child 
Router#(config-pmap-c)# exit 
Router#(config-pmap)# exit 

Router(config)# policy-map child 
Router(config-pmap)# class prec0 
Router(config-pmap-c)# shape average 4000000 
Router(config-pmap-c)# queue-limit 1000 packets 
Router(config-pmap-c)# exit

Router(config-pmap)# class prec1
Router(config-pmap-c)# bandwidth 4000
Router(config-pmap-c)# random-detect
Router(config-pmap-c)# random-detect precedence 1 1000 packets 2000 packets 1
Router(config-pmap-c)# exit 

Router(config-pmap)# class prec2
Router(config-pmap-c)# shape average percent 20
Router(config-pmap-c)# exit 
Router(config-pmap)# exit 

Configuring the Interface and Subinterfaces

Router(config)# interface serial0
Router(config-inf)# encapsulation frame-relay IETF
Router(config-inf)# service-policy output parent
Router(config-inf)# exit

Router(config)# interface Serial0.1 point-to-point
Router(config-inf)# description Intranet Service
Router(config-inf)# frame-relay interface-dlci 16 
Router(config-inf)# exit

Router(config)# interface Serial0.2 point-to-point
Router(config-inf)# description Internet Service
Router(config-inf)# frame-relay interface-dlci 17
Router(config-inf)# exit

Router(config)# interface Serial0.3 point-to-point
Router(config-inf)# description Internet Service
Router(config-inf)# frame-relay interface-dlci 18
Router(config-inf)# exit

Router(config)# interface Serial0.4 point-to-point
Router(config-inf)# description Internet Service
Router(config-inf)# frame-relay interface-dlci 19
Router(config-inf)# exit

Router(config)# interface Serial0.5 point-to-point
Router(config-inf)# description Managed VoIP Service
Router(config-inf)# frame-relay interface-dlci 20
Router(config-inf)# exit
Router(config)# exit 

Verifing the Configuration

Router# show run interface serial0 
Building configuration...
Current configuration : 156 bytes
!
interface serial0
no ip address
no ip directed-broadcast
encapsulation frame-relay
service-policy output parent
end

Router# show running-config interface serial0.1
Building configuration...
Current configuration : 156 bytes
!
interface serial0.1 point-to-point
ip address 192.168.14.1 255.255.255.0
no ip directed-broadcast
frame-relay interface-dlci 16
end
Router# show running-config interface serial0.2
Building configuration...
Current configuration : 140 bytes
!
interface serial0.2 point-to-point
ip address 192.168.18.1 255.255.255.0
no ip directed-broadcast

frame-relay interface-dlci 20
end

L3/1C/nD Service Provider Configuration Example 1

class-map match-all real-time
  match fr-dlci 100
  match ip dscp 46
  match access-group <acl>
class-map match-any bursty-low
  match ip dscp 18 20
  match access-group <acl>
class-map match-any bursty-high
  match ip dscp 26 28
  match access-group <acl> 
class-map match-all best-effort
  match fr-dlci 101
  match ip dscp 0
  match access-group <acl>
policy-map parent-out
class class-default
  shape average percent <%> <ms> ms
  service-policy child
policy-map child
class real-time
 priority
 police cir percent <%> [bc <ms> ms] /* using shaped rate */
class bursty-high
 bandwidth percent <%> /* using shaped rate */
 random-detect [precedence-based | dscp-based | discard-class-based]
 random-detect {precedence | dscp | discard-class} <num> <min_th> ms <max_th> ms [mpd]  
/* using shaped rate */
 police cir percent <%> [bc <ms> ms] /* using shaped rate */
class bursty-low
 bandwidth percent <%>
 random-detect [precedence-based | dscp-based | discard-class-based]
 random-detect {precedence | dscp | discard-class} <num> <min_th> ms <max_th> ms [mpd]  
/* using shaped rate */
 police cir percent <%> [bc <ms> ms]
class class-default    /* best effort */
 bandwidth percent <%>
 random-detect [precedence-based | dscp-based | discard-class-based]
 random-detect {precedence | dscp | discard-class} <num> <min_th> ms <max_th> ms [mpd]  
/* using shaped rate */
 set ip dscp 0

L3/1C/nD Service Provider Configuration Example 2

class-map match-all real-time
  match fr-dlci 100
  match ip dscp 46
  match qos-group <x>
class-map match-any bursty-low
  match ip dscp 18 20
  match qos-group <x>
class-map match-any bursty-high
  match ip dscp 26 28
  match qos-group <x>
class-map match-all best-effort
  match fr-dlci 101
  match ip dscp 0
  match qos-group <x>
policy parent-out
class class-default
  shape average percent <%> <ms> ms
  service-policy child
policy-map child
class real-time
 priority
 police cir percent <%> [bc <ms> ms] /* using shaped rate */
class bursty-high
 bandwidth percent <%>
 random-detect [precedence-based | dscp-based | discard-class-based]
 random-detect {precedence | dscp | discard-class} <num> <min_th> ms <max_th> ms [mpd] /* 
using shaped rate */
class bursty-low
 bandwidth percent <%>
 random-detect [precedence-based | dscp-based | discard-class-based]
 random-detect {precedence | dscp | discard-class} <num> <min_th> ms <max_th> ms [mpd] /* 
using shaped rate */
class class-default    /* best effort */
  bandwidth percent <%>
 random-detect [precedence-based | dscp-based | discard-class-based]
 random-detect {precedence | dscp | discard-class} <num> <min_th> ms <max_th> ms [mpd] /* 
using shaped rate */
interface POS3/0
 encapsulation frame-relay
 service-policy output parent-out
 service-policy input input-policer
end
interface POS3/0.100 point-to-point
 frame-relay interface-dlci 100
 description e.g. VoIP VPN
 ip vrf forwarding voip-vpn
end
interface POS3/0.101 point-to-point
 frame-relay interface-dlci 101
 description e.g. Internet service
end
interface POS3/0.102 point-to-point
 frame-relay interface-dlci 102
 description e.g. Intranet VPN
 ip vrf forwarding intra-vpn
end

Additional References

The following sections provide references related to QoS: Enhancements to Single QoS Policy Definition for a Physical Interface (L3/1C/nD) Including Match FR-DLCI.

Related Documents

Related Topic
Document Title

Information on the extended match fr-dlci command

Packet Classification Using the Frame Relay DLCI Number

Modular QoS Command-Line Interface (CLI) (MQC)

Cisco IOS Quality of Service Solutions Configuration Guide

Information about attaching policy maps to interfaces

Cisco IOS Quality of Service Solutions Configuration Guide

Information about attaching policy maps to Frame Relay DLCIs

Cisco IOS Wide-Area Networking Configuration Guide

Additional match criteria that can be used for packet classification

Cisco IOS Quality of Service Solutions Configuration Guide

Frame Relay configuration information and information about DLCIs

Cisco IOS Wide-Area Networking Configuration Guide

Frame Relay commands: complete command syntax, command modes, command history, defaults, usage guidelines, and examples

Cisco IOS Wide-Area Networking Command Reference, Release 12.3T


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

CISCO-CLASS-BASED-QOS-MIB

CISCO-CLASS-BASED-QOS-CAPABILITY-MIB

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

This section documents modified commands. All other commands used with this feature are documented in the Cisco IOS Release 12.3 command reference publications.

match fr-dlci

show class-map

show policy-map interface

match fr-dlci

To specify the Frame Relay data-link connection identifier (DLCI) number as a match criterion in a class map, use the match fr-dlci command in class-map configuration mode. To remove a previously specified DLCI number as a match criterion, use the no form of this command.

match fr-dlci dlci-number [- dlci-number]

no match fr-dlci dlci-number [- dlci-number]

Syntax Description

dlci-number

DLCI number associated with the packet. DLCI numbers can be in the range of 16 to 1007.

-

(Optional) Indicates that a range of DLCI numbers will be specified.

dlci-number

(Optional) Specifies DLCI number at the end of the specified range.


Defaults

No default behavior or values

Command Modes

Class-map configuration

Command History

Release
Modification

12.2(13)T

This command was introduced.

12.0(26)S

This command was integrated into Cisco IOS Release 12.0(26)S and modified to include support for the Cisco 7200 and 7500 series routers.

12.0(28)S

This command was modified to allow specifying a range of DLCI numbers as match criteria.


Usage Guidelines

This match criterion can be used in main interfaces and point-to-multipoint subinterfaces in Frame Relay networks, and it can also be used in hierarchical policy maps.

Enter as many individual DLCI numbers or DLCI ranges as needed. Individual DLCI and DLCI ranges can be used together when configuring this command.

Examples

In the following example a class map called "class1" has been created; and the Frame Relay DLCI numbers 233, 510 to 516, 600, 612 to 615 and 700 have been specified as match criteria. Packets matching this criteria are placed in class1.

Router# configure terminal
Router(config)# class-map class1
Router(config-cmap)# match fr-dlci 233 510-516 600 612-615 700 
Router(config-cmap)# end

Related Commands

Command
Description

show class-map

Displays all class maps and their matching criteria.

show policy-map interface

Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface.


show class-map

To display all class maps and their matching criteria, use the show class-map command in EXEC mode.

show class-map [class-map-name]

Syntax Description

class-map-name

(Optional) Name of the class map. The class map name can be a maximum of 40 alphanumeric characters.


Defaults

No default behavior or values

Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.2(13)T

This command was modified to display the Frame Relay data-link connection identified (DLCI) number as a criterion for matching traffic inside a class map.

12.0(26)S

This command was integrated into Cisco IOS Release 12.0(26)S and modified to include support for the Cisco 7200 and 7500 Series routers.

12.0(28)S

This command was modified to display a range of Frame Relay DLCI numbers using match criteria.


Usage Guidelines

You can use the show class-map command to display all class maps and their matching criteria. If you enter the optional class-map-name argument, the specified class map and its matching criteria are displayed.

Examples

In the following example, a class map called "c1" has been defined, and Frame Relay DLCI numbers 311, 355, 550 to 570, 600, and 612 to 650 have been specified as match criteria:

Router# show class-map 

class map match-all c1
   match fr-dlci 311 355 550-570 600 612-650

Table 1 describes the significant fields shown in the display.

Table 1 show class-map Field Descriptions 

Field
Description

class-map

Class of traffic being displayed. Output is displayed for each configured class map in the policy. The choice for implementing class matches (for example, match-all or match-any) can also appear next to the traffic class.

match

Match criteria specified for the class map. Choices include criteria such as the Frame Relay DLCI numbers and ranges, Layer 3 packet length, IP precedence, IP differentiated services code point (DSCP) value, Multiprotocol Label Switching (MPLS) experimental value, access groups, and quality of service (QoS) groups.


Related Commands

Command
Description

class-map

Creates a class map to be used for matching packets to a specified class.

match fr-dlci

Specifies the Frame Relay DLCI number as a match criterion in a class map.

show policy-map interface

Displays the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific PVC on the interface.


show policy-map interface

To display the packet statistics of all classes that are configured for all service policies either on the specified interface or subinterface or on a specific permanent virtual circuit (PVC) on the interface, use the show policy-map interface command in EXEC mode.

show policy-map interface interface-name [vc [vpi/] vci] [dlci dlci] [input | output]

Syntax Description

interface-name

Name of the interface or subinterface whose policy configuration is to be displayed.

vc

(Optional) For ATM interfaces only, shows the policy configuration for a specified PVC. The name can be up to 16 characters long.

vpi/

(Optional) ATM network virtual path identifier (VPI) for this PVC. On the Cisco 7200 and 7500 series routers, this value ranges from 0 to 255.

The vpi and vci arguments cannot both be set to 0; if one is 0, the other cannot be 0.

vci

(Optional) ATM network virtual channel identifier (VCI) for this PVC. This value ranges from 0 to 1 less than the maximum value set for this interface by the atm vc-per-vp command. Typically, the lower values 0 to 31 are reserved for specific traffic (F4 Operation, Administration, and Maintenance [OAM], switched virtual circuit [SVC] signaling, Integrated Local Management Interface [ILMI], and so on) and should not be used.

The VCI is a 16-bit field in the header of the ATM cell. The VCI value is unique only on a single link, not throughout the ATM network, because it has local significance only.

The vpi and vci arguments cannot both be set to 0; if one is 0, the other cannot be 0.

dlci

(Optional) Indicates a specific PVC for which policy configuration is displayed.

dlci

(Optional) A specific data-link connection identifier (DLCI) number used on the interface. Policy configuration for the corresponding PVC is displayed when a DLCI is specified.

input

(Optional) Indicates that the statistics for the attached input policy are displayed.

output

(Optional) Indicates that the statistics for the attached output policy are displayed.


Defaults

The absence of both the forward slash (/) and a vpi value causes the vpi value to default to 0. If this value is omitted, information for all virtual circuits (VCs) on the specified ATM interface or subinterface is displayed.

Command Modes

EXEC

Command History

Release
Modification

12.0(5)T

This command was introduced.

12.0(5)XE

This command was integrated into Cisco IOS Release 12.0(5)XE.

12.0(7)S

This command was integrated into Cisco IOS Release 12.0(7)S.

12.1(1)E

This command was integrated into Cisco IOS Release 12.1(1)E.

12.1(2)T

This command was modified to display information about the policy for all Frame Relay PVCs on the interface, or, if a DLCI is specified, the policy for that specific PVC. This command was also modified to display the total number of packets marked by the QoS set action.

12.1(3)T

This command was modified to display per-class accounting statistics.

12.2(4)T

This command was modified for the Two-Rate Policer to display burst parameters and associated actions.

12.2(8)T

The command was modified for the Policer Enhancement — Multiple Actions feature to display the multiple actions configured for packets conforming to, exceeding, or violating a specific rate.

12.2(13)T

This command was modified to display the Frame Relay DLCI number as a criterion for matching traffic inside a class map.

12.0(26)S

This command was modified to include support for the Cisco 7200 and 7500 series routers.

12.0(28)S

This command was modified to display a range of Frame Relay DLCI numbers using match criteria.


Usage Guidelines

The show policy-map interface command displays the configuration for classes on the specified interface or the specified PVC only if a service policy has been attached to the interface or the PVC.

Examples

The following sample output of the show policy-map interface command displays the statistics for the Serial4/0/2 interface, to which a service policy called "p1" is attached. The Frame Relay DLCI numbers 311, 500 to 505, 600, and 610 to 630 have been specified as the match criteria for the traffic in the class called "c1".

Router# show policy-map interface

 Serial4/0/2 

  Service-policy input: p1

    Class-map: c1 (match-all)
      45 packets, 4680 bytes
      5 minute offered rate 0 bps
      Match: fr-dlci  311 500-505 600 610-630

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any 
        0 packets, 0 bytes
        5 minute rate 0 bps

Table 2 describes the significant fields shown in the display.

Table 2 show policy-map interface Field Descriptions 

Field
Description

Service-policy input

Name of the input service policy applied to the specified interface or VC.

Class-map

Class of traffic being displayed. Statistics are displayed for each configured class in the policy. The choice for implementing class matches (for example, match-all or match-any) can also appear next to the traffic class.

packets and bytes

Number of packets (also shown in bytes) identified as belonging to the class of traffic being displayed.

offered rate

Rate, in kbps, of packets coming into the class.

drop rate

Rate, in kbps, at which packets are dropped from the class. The drop rate is calculated by subtracting the number of successfully transmitted packets from the offered rate.

Match

Match criteria specified and packet matching statistics for the class of traffic. Choices include criteria such as the Frame Relay DLCI number or range, Layer 3 packet length, IP precedence, IP differentiated services code point (DSCP) value, Multiprotocol Label Switching (MPLS) experimental (EXP) value, access groups, and quality of service (QoS) groups.


Related Commands

Command
Description

match fr-dlci

Specifies the Frame Relay DLCI number as a match criterion in a class map.

show class-map

Displays all class maps and their matching criteria.

show frame-relay pvc

Displays statistics about PVCs for Frame Relay interfaces.

show policy-map class

Displays the configuration for the specified class of the specified policy map.