Guest

Cisco IOS Software Releases 12.0 S

MPLS AToM—Ethernet over MPLS

  • Viewing Options

  • PDF (302.6 KB)
  • Feedback
MPLS AToM—Ethernet over MPLS

Table Of Contents

MPLS AToM—Ethernet over MPLS

Feature Overview

Label Stacking

Benefits

Restrictions

Related Documents

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Enabling Ethernet Over MPLS on the PE Routers

Configuring the Customer CE Routers

Enabling Quality of Service (Cisco 10720 Internet Router Only)

Setting the Priority of Packets with the Experimental Bits

Enabling Traffic Policing

Displaying the Traffic Policy Assigned to an Interface

Verifying the Configuration

CE Routers

PE Routers

P Router

Configuration Examples

Command Reference

debug lc psa-eompls

debug mpls l2transport vlan

mpls l2transport route

show controllers eompls forwarding-table

show mpls l2transport vc


MPLS AToM—Ethernet over MPLS


Feature History

Release
Modification

12.1(8a)E

This feature was introduced on the Cisco 7600 Series Internet routers. See the Ethernet over MPLS for the Cisco 7600 Internet Router feature module.

12.0(21)ST

This feature was modified to support the Cisco 12000 Series routers.

12.0(22)S

This feature was modified to support the Cisco 10720 Internet router.


This feature module describes the Ethernet over Multiprotocol Label Switching (MPLS) feature, which transports Layer 2 VLAN packets across an MPLS backbone. This feature module is part of the Any Transport over MPLS (AToM) product set. This feature module describes the benefits of Ethernet over MPLS (EoMPLS) and lists supported platforms. It also provides configuration tasks, examples and related commands.

This document includes the following sections:

Feature Overview

Supported Platforms

Supported Standards, MIBs, and RFCs

Configuration Tasks

Configuration Tasks

Configuration Examples

Command Reference

Feature Overview

This feature allows you to connect two VLAN networks that are in different locations, without using expensive bridges, routers, or switches at the VLAN locations. You can enable the MPLS backbone network to accept Layer 2 VLAN traffic by configuring the label edge routers (LERs) at both ends of the MPLS backbone.

Adding a point-to-point virtual circuit (VC) requires you to configure the two VC endpoints at the two PE routers. Only the two PE routers at the ingress/egress points of the MPLS backbone know about the VCs dedicated to transporting Layer 2 VLAN traffic. All other routers do not have table entries for those VCs.

Label Stacking

PE routers connected to the MPLS backbone perform label imposition and disposition. The imposition PE router encapsulates the Layer 2 VLAN packet into an MPLS PDU to transport it across the backbone to the disposition PE router. The disposition PE router takes the MPLS PDU, de-encapsulates the MPLS PDU, and delivers the Layer 2 VLAN packet to the correct interface.

When the imposition PE router encapsulates a Layer 2 VLAN packet to route it across the MPLS backbone, it includes a label stack with two levels of labels:

An Interior Gateway Protocol (IGP) stack, also known as a tunnel label

A VC-based label

The MPLS backbone uses the IGP labels to transport the VLAN packet between the PE routers. The disposition PE router uses the VC-based label to select the outgoing interface for the VLAN packet.

Benefits

The following list explains some of the benefits of enabling the transport of Layer 2 packets over the MPLS network:

The Any Transport over MPLS product set accommodates many types of Layer 2 packets, including Ethernet and AAL5, across multiple Cisco router platforms. This enables the service provider to transport all types of traffic over the backbone and accommodate all types of customers.

AToM adheres to the standards developed for transporting Layer 2 packets over MPLS. (See "Standards and Drafts Upon Which AToM Is Based" for the specific standards that AToM follows.) This benefits the service provider who wants to incorporate industry-standard methodologies in the network.

Upgrading to AToM is transparent to the customer. Because the service provider network is separate from the customer network, the service provider can upgrade to AToM without disruption of service to the customer. The customers assume that they are using a traditional Layer 2 backbone.

Restrictions

The following restrictions pertain to the Ethernet over MPLS feature:

Maximum transmission unit: Because Ethernet over MPLS does not allow packets to be fragmented and reassembled, ensure that the maximum transmission unit (MTU) of all intermediate links between endpoints is sufficient to carry the largest Layer 2 VLAN cell received. The ingress and egress PE routers must have the same MTU value.

Supported platforms: The instructions for configuring Ethernet over MPLS in this feature module apply only Cisco IOS Release 12.0(22)S. Avoid using these instructions for any other release.

Address format: All loopback addresses on PE routers must be configured with 32-bit masks to ensure proper operation of MPLS forwarding between PE routers.

Packet format: Ethernet over MPLS supports VLAN packets that conform to the IEEE's 802.1Q standard. The 802.1Q specification establishes a standard method for inserting VLAN membership information into Ethernet frames. ISL is not supported between the PE and CE routers.

Configuring on subinterfaces: You must enable Ethernet over MPLS by specifying the mpls l2transport route command on an 802.1Q subinterface.

Cisco 12000 Series router line card support: When Ethernet over MPLS is enabled on a Cisco 12000 Series router line card, no other feature can be enabled. The line card is dedicated solely to the transporting Ethernet VLAN packets over an MPLS backbone.

Related Documents

Refer to the following documents for more information:

Multiprotocol Label Switching on Cisco Routers

MPLS Label Distribution Protocol

Supported Platforms

Ethernet over MPLS is supported on the the following platforms:

Cisco 12000 Series router. For information on which engines and line cards are supported, see the Release Notes for Cisco IOS Release 12.0 ST.

Cisco 10720 Internet Router, which provides two line card slots.

The top slot can contain either of the following uplink cards:

DPT uplink card equipped with two physical OC-48c/STM-16c ports with an aggregate bandwidth of 5 Gbps.

Console/Auxiliary card when using the Cisco 10720 Internet Router as an Ethernet-only router.

The bottom slot can contain one of the following access cards:

24-port FX Fast Ethernet access card, available in TX, FX multimode, and FX single-mode

4-port Gigabit Ethernet 8-Port 10/100 Ethernet TX access card

Determining Platform Support Through Cisco Feature Navigator

Cisco IOS software is packaged in feature sets that support specific platforms. To get updated information regarding platform support for this feature, access Cisco Feature Navigator. Cisco Feature Navigator dynamically updates the list of supported platforms as new platform support is added for the feature.

Cisco Feature Navigator is a web-based tool that enables you to quickly determine which Cisco IOS software images support a specific set of features and which features are supported in a specific Cisco IOS image. You can search by feature or release. Under the release section, you can compare releases side by side to display both the features unique to each software release and the features in common.

To access Cisco Feature Navigator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions at http://www.cisco.com/register.

Cisco Feature Navigator is updated regularly when major Cisco IOS software releases and technology releases occur. For the most current information, go to the Cisco Feature Navigator homepage at the following URL:
http://www.cisco.com/go/fn

Availability of Cisco IOS Software Images

Platform support for particular Cisco IOS software releases is dependent on the availability of the software images for those platforms. Software images for some platforms may be deferred, delayed, or changed without prior notice. For updated information about platform support and availability of software images for each Cisco IOS software release, refer to the online release notes or, if supported, Cisco Feature Navigator.

Supported Standards, MIBs, and RFCs

Standards

This feature supports the following IETF draft documents:

Transport of Layer 2 Frames Over MPLS

Encapsulation Methods for Transport of Layer 2 Frames Over MPLS

MIBs

None.

RFCs

RFC 3032: MPLS Label Stack Encoding

RFC 3036: LDP Specification

Configuration Tasks

Perform the following configuration tasks to enable Ethernet over MPLS:

Enabling Ethernet Over MPLS on the PE Routers (required)

Configuring the Customer CE Routers (required)

Enabling Quality of Service (Cisco 10720 Internet Router Only) (optional)

Verifying the Configuration (optional)

Enabling Ethernet Over MPLS on the PE Routers

Figure 1 is a sample topology used in this section.

Figure 1 Sample Topology

Configuration Notes

You must enable dynamic MPLS labeling (through the command mpls ip) on all paths between the imposition and disposition PE routers.

All loopback addresses on PE routers must be configured with 32-bit masks to ensure proper operation of MPLS forwarding between PE routers.

You may assign an LDP router ID to each PE router. The mpls ldp router-id command allows you to specify which interface's IP address to use as the router ID. The force keyword guarantees that the PE routers are correctly targeting the appropriate router ID. If you do not use the force keyword, the router might assign a different router ID, which can prevent the establishment of VCs between PE routers.

Both PE routers require a loopback address that you can use to create a VC between the routers.

The subinterfaces between the CE and PE routers that are running Ethernet over MPLS must have the same VLAN identifier. This requirement does not apply to all other subinterfaces and backbone routers.

To configure MPLS to transport Layer 2 VLAN packets between two PE routers, perform the following steps on the PE routers:

 
Command
Purpose

Step 1 

Router(config)# mpls label protocol ldp

(Optional) Specifies LDP as the label distribution protocol. If you do not specify LDP, TDP is used instead.

Step 2 

Router(config)# interface loopback0

Enters interface configuration mode.

Step 3 

Router(config-if)# ip address x.x.x.x y.y.y.y

Assigns an IP address to the loopback interface. An IP address with a 32-bit subnet mask is necessary for a loopback interface on the PE routers that will transport VLAN packets.

Step 4 

Router(config)# mpls ldp router-id loopback0 force

Forces the IP address of loopback 0 to be used as the router ID.

Step 5 

Router(config)# interface GigabitEthernetx/x.x

Specifies the Gigabit Ethernet subinterface for the imposition interface. Make sure the subinterface on the adjoining CE router is on the same VLAN as this PE router.

Step 6 

Router(config-if)# encapsulation dot1Q vlan-id

Enables the subinterface to accept 802.1q VLAN packets. Make sure the VLAN ID is the same as the VLAN ID on the adjoining CE router.

Step 7 

Router(config-if)# mpls l2transport route destination vc-id

Specifies the VC to use to transport the VLAN packets.

The argument destination specifies the loopback address of the remote PE router at the other end of the VC.

The argument vc-id is a value you supply. It must be unique for each VC. The VC ID is used to connect the endpoints of the VC. Specify the same VC ID on both ends of the VC.

Configuring the Customer CE Routers

The CE routers act as adjacent routers when the PE routers are configured to transport VLAN packets.


Note Make sure the subinterfaces on the CE routers connected to the PE routers have the same VLAN ID.


If the customer CE routers are configured to accept Layer 2 VLAN packets, these steps are not necessary. Otherwise, use the following procedure to transport Layer 2 VLAN packets between the PE router and the CE router:

 
Command
Purpose

Step 1 

Router(config)# interface GigabitEthernetx/x.x

Specifies a Gigabit Ethernet subinterface. Make sure the subinterface on the adjoining PE router shares the same VLAN ID as this router.

Note You must define a subinterface.

Step 2 

Router(config-if)# encapsulation dot1Q vlan-id

Enables the subinterface to accept 802.1q VLAN packets. Make sure the VLAN ID is the same as the VLAN ID on the adjoining PE router.

Step 3 

Router(config-if)# ip address x.x.x.x

Assigns an IP address to the subinterface.

Enabling Quality of Service (Cisco 10720 Internet Router Only)

The following sections detail the Modular QoS CLI commands for enabling QoS on the PE router.

For more information on the commands used to enable Quality of Service, see the following documents:

Modular Quality of Service Command-Line Interface

Cisco IOS Quality of Service Solutions Command Reference, Release 12.2


Note Quality of Service for Ethernet over MPLS is supported only on the Cisco 10720 Internet Router for Cisco IOS Release 12.0(22)S.


Setting the Priority of Packets with the Experimental Bits

Ethernet over MPLS provides Quality of Service (QoS) using the three experimental bits in a label to determine the priority of packets. To support QoS between LERs, set the experimental bits in both the VC and tunnel labels.

Perform the following steps to set the experimental bits:

 
Command
Purpose

Step 1 

Router(config)# class-map 
class-name 

Specifies the user-defined name of the traffic class.

Step 2 

Router(config-cmap)# match 
any 

Specifies that all packets will be matched.

Step 3 

Router(config-cmap)# 
policy-map policy-name 

Specifies the name of the traffic policy to configure.

Step 4 

Router(config-pmap)# class 
class-name 

Specifies the name of a predefined traffic class, which was configured with the class-map command, used to classify traffic to the traffic policy.

Step 5 

Router (config-pmap-c)# set 
mpls experimental value

Designates the value to which the MPLS bits are set if the packets match the specified policy map.

Step 6 

Router(config)# interface 
FastEthernetx/x.x

Enters the subinterface.

Step 7 

Router(config-if)# 
service-policy input 
policy-name 

Attaches a traffic policy to an interface.

Enabling Traffic Policing

Traffic policing allows you to control the maximum rate of traffic sent or received on an interface. Traffic policing is often configured on interfaces at the edge of a network to limit traffic in or out of the network. Traffic that falls within the rate parameters is sent, whereas traffic that exceeds the parameters is dropped or sent with a different priority. To add traffic policing, issue the following commands:

 
Command
Purpose

Step 1 

Router(config)# class-map 
class-name 

Specifies the user-defined name of the traffic class.

Step 2 

Router(config-cmap)# match 
any 

Specifies that any packets be matched.

Step 3 

Router(config-cmap)# 
policy-map policy-name 

Specifies the name of the traffic policy to configure.

Step 4 

Router(config-pmap)# class 
class-name 

Specifies the name of a predefined traffic class, which was configured with the class-map command, used to classify traffic to the traffic policy.

Step 5 

Router (config-pmap-c)# 
police bit-rate

Polices traffic according to the bit rate you specify.

Step 6 

Router(config)# interface 
FastEthernetx/x.x 

Enters the subinterface.

Step 7 

Router(config-if)# 
service-policy input 
policy-name 

Assigns a traffic policy to an interface.

Displaying the Traffic Policy Assigned to an Interface

To display the traffic policy attached to an interface, issue the following command:

Router# show policy-map interface FastEthernet 2/2.1

FastEthernet2/2.1 
Service-policy output: pol (1060)

    Class-map: class-default (match-any) (1061/0)
      7351298 packets, 646914312 bytes
      30 second offered rate 85362000 bps, drop rate 69066000 bps
      Match: any  (1063)
        7351298 packets, 646914312 bytes
        30 second rate 85362000 bps
      police:
        20000000 bps, 10000 limit, 10000 extended limit
        conformed 1403523 packets, 123510024 bytes; action: transmit
        exceeded 5947776 packets, 523404288 bytes; action: drop

Verifying the Configuration

The following steps help to verify the configuration of Layer 2 VLAN transport over MPLS tunnels. Some of the steps help you determine that a targeted LDP session has been initiated between the PE routers and that an LDP session exists between the PE and P routers.

CE Routers

Issue the following command on CE1 and CE2 to ensure that the VC is active:

Use the show ip interface brief command on CE1 and CE2 to make sure the router interfaces are operating.

CE1# show ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet2/1.1          11.11.11.11     YES unset  up                    up
FastEthernet2/1.2           2.12.12.12     YES unset  up                    up
FastEthernet1/1.2          10.10.10.10     YES unset  up                    up

PE Routers

Issue the following commands on each PE router to ensure that the PE routers are working properly.


Step 1 To make sure the PE router endpoints have discovered each other, issue the show mpls ldp discovery command. The command output shows that PE1 established a targeted LDP session with PE2.

PE1# show mpls ldp discovery 

Local LDP Identifier:
    11.11.11.11:0
Discovery Sources:
    Interfaces:
        SRP1/1 (ldp): xmit/recv
            LDP Id: 15.15.15.15:0
    Targeted Hellos:
        11.11.11.11 -> 12.12.12.12 (ldp): active, xmit/recv
            LDP Id: 12.12.12.12:0

Step 2 Issue the show mpls l2transport vc command to check the a VC has been established between the PE routers and that the VC is operational.


PE1#show mpls l2transport vc

VC ID     Client          VC       Local       Remote      Tunnel
          Intf           State   VC Label      VC Label    Label
1        Fa2/2.1          UP       18             20         26 

Step 3 To make sure the label distribution session has been established, issue the show mpls ldp neighbors command. The output shows that:

PE1 and PE2 have established a targeted LDP session.

The LDP session is operational.

Messages are being sent and received.

PE1#show mpls ldp neighbor

Peer LDP Ident: 15.15.15.15:0; Local LDP Ident 11.11.11.11:0
        TCP connection: 15.15.15.15.11072 - 11.11.11.11.646
        State: Oper; Msgs sent/rcvd: 65/73; Downstream
        Up time: 00:43:02
        LDP discovery sources:
          SRP1/1, Src IP addr: 30.5.0.2
        Addresses bound to peer LDP Ident:
          8.0.5.4         180.3.0.3       15.15.15.15     30.5.0.2
          30.5.0.3
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 11.11.11.11:0
        TCP connection: 12.12.12.12.11000 - 11.11.11.11.646
        State: Oper; Msgs sent/rcvd: 26/25; Downstream
        Up time: 00:10:35
        LDP discovery sources:
          Targeted Hello 11.11.11.11 -> 12.12.12.12, active
        Addresses bound to peer LDP Ident:
          8.0.6.3         12.12.12.12     30.5.0.4

P Router

Issue the following commands to ensure that the P router is correctly configured.


Step 1 Issue the show mpls ldp discovery command ensure that an LDP session exists. The command output shows that the P router has regular LDP sessions with the PE routers, not targeted LDP sessions.

P# show mpls ldp discovery 

Local LDP Identifier:
    15.15.15.15:0
    Discovery Sources:
    Interfaces:
        POS3/0 (ldp): xmit/recv
            LDP Id: 11.11.11.11:0
        POS6/0 (ldp): xmit/recv
            LDP Id: 12.12.12.12:0
    Targeted Hellos:
        15.15.15.15 -> 11.11.11.11 (ldp): active, xmit
 

Step 2 To make sure the label distribution session has been established, issue the show mpls ldp neighbors command. The output shows that:

The P routers has LDP sessions with PE1 and PE2.

The LDP session is operational.

Messages are being sent and received.

P# show mpls ldp neighbor 

Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 15.15.15.15:0
        TCP connection: 11.11.11.11.646 - 15.15.15.15.11072
        State: Oper; Msgs sent/rcvd: 80/71; Downstream
        Up time: 00:48:50
        LDP discovery sources:
          POS3/0, Src IP addr: 30.5.0.1
        Addresses bound to peer LDP Ident:
          8.0.5.20        11.11.11.11     180.3.0.2       20.20.20.3
          200.200.200.5   30.5.0.1
    Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 15.15.15.15:0
        TCP connection: 12.12.12.12.646 - 15.15.15.15.11169
        State: Oper; Msgs sent/rcvd: 29/27; Downstream
        Up time: 00:16:28
        LDP discovery sources:
          POS6/0, Src IP addr: 30.5.0.4
        Addresses bound to peer LDP Ident:
          8.0.6.3         12.12.12.12     30.5.0.4

Configuration Examples

The following configuration example lists the commands for enabling MPLS to transport Layer 2 VLAN packets between two endpoints. Figure 2 illustrates the network configuration that the configuration commands reference.

Figure 2 Configuring Ethernet Over MPLS

Notes:

Dynamic MPLS switching is enabled between the PE routers. Dynamic MPLS switching should be enabled throughout the MPLS core.

The sample configurations assume OSPF is used within the MPLS core to ensure that the PE routers have routes to the endpoints.

CE1 Configuration

The subinterface GigabitEthernet2/1.2 is connected to the subinterface on PE1 (GigabitEthernet2/1.2), which was configured to transport VLAN packets. Corresponding subinterfaces on both CE1 and CE2 are in the same VLAN and subnet. In this example configuration, the VLAN ID is 200 and the subnet is 10.1.2.0.

!
interface GigabitEthernet2/1
no ip address
 no ip redirects
 no ip directed-broadcast
 no ip proxy-arp
 no ip mroute-cache
 no keepalive
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet2/1.2
 encapsulation dot1Q 200
 ip address 10.1.2.1 255.255.255.0
 no ip directed-broadcast
 no cdp enable

PE1 Configuration

In this example configuration, note the following:

PE1 requires a loopback address so that it can create a tunnel to PE2. The mpls l2transport route command requires the address of the remote PE router.

The subinterface GigabitEthernet2/1.2 is configured to transport VLAN packets over the MPLS backbone. The VC ID (123) in the mpls l2transport route command is the same VC ID as specified in PE2.

The interface GigabitEthernet2/4 connects to the MPLS backbone through the mpls ip command. This is the disposition interface.

The last section of the configuration example advertises the loopback address and the addresses of the interfaces connecting to the PE routers. These commands help establish LDP and the LSP tunnels.

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 no ip directed-broadcast
!
interface GigabitEthernet2/1
 description "connected to gsr1 2/1"
 no ip address
 no ip redirects
 no shut
 no ip directed-broadcast
 no ip mroute-cache
 no keepalive
 no negotiation auto
 no cdp enable
mpls ip
!
interface GigabitEthernet2/1.2
 encapsulation dot1Q 200
 no shut
no ip directed-broadcast
 mpls l2transport route 4.4.4.4 123 
no cdp enable
!
interface GigabitEthernet2/4
 ip address 11.1.1.2 255.255.255.0
 no ip directed-broadcast
 no negotiation auto
 mpls ip
 no cdp enable
!
router ospf 100
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 11.1.1.0 0.0.0.255 area 0

P Configuration

In this configuration example, note the following:

Interface GigabitEthernet2/1 is connected to PE2. The mpls ip command enables MPLS on this interface.

Interface GigabitEthernet2/4 is connected to PE1. The mpls ip command enables MPLS on this interface.

The last section of the configuration example advertises the loopback address and the addresses of the interfaces connecting to the PE routers. These commands help establish LDP and the LSP tunnels.

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 no ip directed-broadcast
!
interface GigabitEthernet2/1
 ip address 12.1.1.3 255.255.255.0
 no ip directed-broadcast
 no keepalive
 no negotiation auto
 mpls ip 
 no cdp enable
!
interface GigabitEthernet2/4
 ip address 11.1.1.3 255.255.255.0
 no ip directed-broadcast
 no negotiation auto
 mpls ip 
 no cdp enable
!
router ospf 100
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 11.1.1.0 0.0.0.255 area 0 
 network 12.1.1.0 0.0.0.255 area 0 

PE2 Configuration

In this configuration example, note the following:

PE2 requires a loopback address so that it can create a tunnel to PE1. The mpls l2transport route command requires the address of the remote PE router.

The interface SRP1/1 connects to the MPLS backbone through the mpls ip command. This is the disposition interface.

The subinterface GigabitEthernet2/1.2 is configured to transport VLAN packets over the MPLS backbone.

The VC ID (123) in the mpls l2transport route command is the same VC ID as specified in PE1.

The last section of the configuration example advertises the loopback address and the address of the interface connecting to the MPLS backbone. These commands help establish LDP and the LSP tunnel.

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 no ip directed-broadcast
!
interface SRP1/1
 ip address 12.1.1.2 255.255.255.0
 mpls ip
!
interface GigabitEthernet2/1
no ip directed-broadcast
 no keepalive
 no negotiation auto
 mpls ip 
 no cdp enable
!
interface GigabitEthernet2/1.2
 encapsulation dot1Q 200
 no ip directed-broadcast
 mpls l2transport route 2.2.2.2 123 
 no cdp enable
!
router ospf 100
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 12.1.1.0 0.0.0.255 area 0

CE2 Configuration

The subinterface GigabitEthernet2/1.2 is connected to the subinterface on PE2 (GigabitEthernet2/1.2), which was configured to transport VLAN packets. Corresponding subinterfaces on both CE1 and CE2 are in the same VLAN and subnet. In this example configuration, the VLAN ID is 200 and the subnet is 10.1.2.0.

interface GigabitEthernet2/1
 no ip address
 no shut
 no ip redirects
 no ip directed-broadcast
 no ip proxy-arp
 no ip mroute-cache
 no keepalive
 no negotiation auto
 no cdp enable
!
interface GigabitEthernet2/1.2
 encapsulation dot1Q 200
 ip address 10.1.2.5 255.255.255.0
 no ip directed-broadcast
 no cdp enable

Command Reference

This section describes the following commands:

debug lc psa-eompls

debug mpls l2transport vlan

mpls l2transport route

show controllers eompls forwarding-table

show mpls l2transport vc

debug lc psa-eompls

To display debugging information about the Cisco 12000 series router line card, use the debug lc psa-eompls command in EXEC mode. To disable the debugging information, use the no form of the command.

debug lc psa-eompls {event | internal | trace }

no debug lc psa-eompls {event | internal | trace }

Syntax Description

event

Displays line card events.

internal

Displays the internal state of the line card.

trace

Displays any function calls on the line card.


Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(21)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Usage Guidelines

This command is supported only on the Cisco 12000 series router.

Examples

The following example enables all debug messages on the line card:

Router# execute-on slot 1 debug lc psa-eompls event
Router# execute-on slot 1 debug lc psa-eompls internal
Router# execute-on slot 1 debug lc psa-eompls trace
========= Line Card (Slot 1) =======

PSA EoMPLS Trace debugging is on

SLOT 1:2d16h: Requesting eompls ucode load
SLOT 1:2d16h: Trying loading EoMPLS bundle...
SLOT 1:2d16h: Calling the feature-load function
SLOT 1:2d16h: Imposition gather profile# 30 value (0x8800)
SLOT 1:2d16h: Imposition gather profile# 31 value (0x102108)
SLOT 1:2d16h: Imposition gather profile# 32 value (0x8E84C)
SLOT 1:2d16h: Imposition SAP gather profile# 33 value (0x108C00)
SLOT 1:2d16h: Imposition SAP gather profile# 34 value (0x102108)
SLOT 1:2d16h: Imposition SAP gather profile# 35 value (0x18E44E)
SLOT 1:2d16h: Disposition gather profile# 36 value (0x108000)
SLOT 1:2d16h: Disposition gather profile# 37 value (0x189078)
SLOT 1:2d16h: construct_psa_eompls done
SLOT 1:2d16h: load_eompls_ucode: loading complete.
SLOT 1:2d16h: EoMPLS bundle loaded
SLOT 1:2d16h:  VC_label(16) for update, type ETH_TRANS Add case
SLOT 1:2d16h: Having oi=0x10001910, mac_len(0x10)
SLOT 1:2d16h: A VC label: value(16), tag(134217744) TFIB update
SLOT 1:2d16h: oi=0x10001910, mac_len(0x10), mac_str
SLOT 1:2d16h: Disposition label(16) forcing gather profile(0x490)
SLOT 1:2d16h: Got an imposition event(add/delete/update) on LC
SLOT 1:2d16h: ge3_imp_update: remove(0), vcid(123), vlan_id(1), port(0), tunnel_label(16), 
vc_label(16)
SLOT 1:2d16h: ge3_imp_update: out_intf(none)
SLOT 1:2d16h: Tag count in imposition message=2
SLOT 1:2d16h: Rcvd_tag[0]=0x10000, value 16, Modified_tag[0]=0x100FE
SLOT 1:2d16h: Allocated TLU psa_rew at (70075000)
SLOT 1:2d16h: Installing the new tag_rew in the EoMPLS table (D001D400)
SLOT 1:2d16h: FCR Value (0x8E080400)
SLOT 1:2d16h: Lookup table base addr (0x740C8000) installing at (0x740C8004)
SLOT 1:2d16h: Turning ON the EoMPLS vlan flag from (0x80000000) to (0xA0000000)

SLOT 1:2d16h:  VC_label(16) for update, type ETH_TRANS Remove case
SLOT 1:2d16h: Having oi=0x10001910, mac_len(0x10)
SLOT 1:2d16h: Got an imposition event(add/delete/update) on LC
SLOT 1:2d16h: ge3_imp_update: remove(1), vcid(123), vlan_id(1), port(0), tunnel_label(16), 
vc_label(16)
SLOT 1:2d16h: ge3_imp_update: out_intf(none)
SLOT 1:2d16h: Switching off the EoMPLS vlan flag from (0xA0000000) to (0x80000000)
SLOT 1:2d16h: Freeing TLU memory starting 00075000 for 288 bytes

SLOT 1:2d16h: Got an imposition event(add/delete/update) on LC
SLOT 1:2d16h: ge3_imp_update: remove(0), vcid(123), vlan_id(1), port(0), tunnel_label(16), 
vc_label(16)
SLOT 1:2d16h: ge3_imp_update: out_intf(none)
SLOT 1:2d16h: Tag count in imposition message=2
SLOT 1:2d16h: Rcvd_tag[0]=0x10000, value 16, Modified_tag[0]=0x100FE
SLOT 1:2d16h: Allocated TLU psa_rew at (70075000)
SLOT 1:2d16h: Installing the new tag_rew in the EoMPLS table (D001D400)
SLOT 1:2d16h: FCR Value (0x8E080400)
SLOT 1:2d16h: Lookup table base addr (0x740C8000) installing at (0x740C8004)
SLOT 1:2d16h: Turning ON the EoMPLS vlan flag from (0x80000000) to (0xA0000000)

debug mpls l2transport vlan

To enable debug messages about the control of traffic transported between Layer 2 VLAN and MPLS, use the debug mpls l2transport vlan command in EXEC mode. To disable the debug messages about transport control, use the no form of this command.

debug mpls l2transport vlan {control | distributed}

no debug mpls l2transport vlan {control | distributed}

Syntax Description

control

Enables debug messages about the route processor.

distributed

Enables debug messages about line cards.


Note This keyword does not provide any output for the Cisco 10720 Internet router.



Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.1(8a)E

This command was introduced for the Cisco 7600 router.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST for the Cisco 12000 series router.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S for the Cisco 10720 router.


Examples

The following examples show the output of the command with the different keywords.

Router# debug mpls l2transport vlan control 
Ethernet VLAN transport over MPLS, Control interactions debugging is on
Router# config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# int GigabitEthernet2/1 
Router(config-if)# int GigabitEthernet2/1.2
Router(config-if)# shut
Router(config-if)#
*May 25 12:18:33: ATOM_TRANS: atom_if_state_change from GigabitEthernet2/1
*May 25 12:18:33: ATOM_TRANS: Withdrawing all EoMPLS vcs for lgroupid 8
*May 25 12:18:33: ATOM_TRANS: sending extended withdraw_bind for vcid 0
to 12.0.0.1, local groupid 8
*May 25 12:18:33: ATOM_TRANS: holding down local label 21
*May 25 12:18:33: ATOM_TRANS: clearing imp. rewrite for vcid = 2
Router(config-if)#
*May 25 12:18:35: ATOM_TRANS: freeing held label 21
Router(config-if)#
*May 25 12:18:35: %LINK-5-CHANGED: Interface GigabitEthernet2/1, changed state to
administratively down
*May 25 12:18:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/1,
changed state to down
Router(config-if)# no shut
Router(config-if)#
*May 25 12:19:57: ATOM_TRANS: atom_if_state_change from GigabitEthernet2/1
*May 25 12:19:57: ATOM_TRANS: Withdrawing all EoMPLS vcs for lgroupid 8
*May 25 12:19:57: ATOM_TRANS: sending extended withdraw_bind for vcid 0
to 12.0.0.1, local groupid 8
Router(config-if)#
*May 25 12:19:59: %LINK-3-UPDOWN: Interface GigabitEthernet2/1, changed state to up
Router(config-if)#
*May 25 12:19:59: ATOM_TRANS: sending bind for vcid 2 to 12.0.0.1, local
groupid 8
*May 25 12:19:59: ATOM_TRANS: sending request_bind for vcid 2 to
12.0.0.1, local groupid 8
*May 25 12:19:59: ATOM_TRANS: Stale tfib event discarded (12.0.0.1)
*May 25 12:19:59: ATOM_TRANS: Stale tfib event discarded (12.0.0.1)
*May 25 12:19:59: ATOM_TRANS: Stale tfib event discarded (12.0.0.1)
*May 25 12:19:59: ATOM_TRANS: processing tfib event for 12.0.0.1
*May 25 12:19:59: ATOM_TRANS: received BIND from 12.0.0.1:0 remote group id: 8 vc_id: 2 
label: 21
*May 25 12:19:59: ATOM_TRANS: Done setting imp.rewrite for vcid = 2
parent dest 12.0.0.1
*May 25 12:20:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/1,
changed state to up


mpls l2transport route

To enable routing of Layer 2 VLAN packets over a specified VC, use the mpls l2transport route command in interface configuration mode. To disable routing over the specified VC, use the no form of this command.

mpls l2transport route destination vc-id

no mpls l2transport route destination vc-id

Syntax Description

destination

Specifies IP address of the router to which the VC is destined.

vc-id

Assigns a VC ID to a router. The VC ID must be unique to each VC. Specify the same VC ID on both ends of the VC.


Defaults

No default behavior or values.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(8a)E

This command was introduced for the Cisco 7600 router.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST for the Cisco 12000 series router.

12.0(22)S

This command was into Cisco IOS Release 12.0(22)S for the Cisco 10720 router.


Usage Guidelines

An MPLS Layer 2 VLAN VC runs across an MPLS cloud to connect VLAN interfaces on two PE routers.

Use this command on the VLAN interface of each PE router to route Layer 2 VLAN packets across the MPLS cloud to the interface of the other PE router. Specify the IP address of the other PE router for the destination parameter. Do not specify the IP address of the router from which you are issuing the command.

You can choose any number for the VC ID. However, the VC ID must be unique to the VC. Therefore, in large networks, it may be necessary to track the VC ID assignments to ensure that a VC ID does not get assigned twice.

Examples

In the following example, two routers are named PE1 and PE2. The example shows how they establish a VC to transport Layer 2 VLAN packets. PE1 has IP address 172.168.0.1. PE2 has IP address 192.16.0.1. The VC ID is 50.

At PE1, you issue the following commands:

PE1_router (config)# interface GigabitEthernet2/1
PE1_router(config-if) interface gigabitEthernet2/1.1
PE1_router(config-if)# encapsulation dot1q 200
PE1_router(config-if)# mpls l2transport route 192.16.0.1 50 

At PE2, you issue the following commands:

PE2_router (config)# interface GigabitEthernet2/1 
PE2_router(config-if) interface gigabitEthernet2/1.1
PE1_router(config-if)# encapsulation dot1q 200
PE2_router(config-if)# mpls l2transport route 172.168.0.1 50 

show controllers eompls forwarding-table

To display Ethernet over MPLS forwarding table details in the switching engine hardware for the Cisco 12000 Series router, use the show controllers eompls forwarding-table command in EXEC mode.

show controllers eompls forwarding-table interface vlan-id

Syntax Description

interface

The GigabitEthernet interface that has a subinterface configured to transport VLAN packets.

vlan-id

The VLAN ID of the subinterface that is configured to transport VLAN packets.


Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.0(21)ST

This command was introduced.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S.


Usage Guidelines

This command is supported only on the Cisco 12000 Series router.

Examples

The following example shows the status of the VCs on the router.

Router# execute-on slot 0 show controllers eompls forwarding-table 0 1
========= Line Card (Slot 0) =======

Port # 0, VLAN-ID # 1, Table-index 1
EoMPLS configured: 1
tag_rew_ptr             = D001D400
Leaf entry?     = 1
FCR index       = 20
           **tagrew_psa_addr    = 00075000
           **tagrew_vir_addr    = 70075000
           **tagrew_phy_addr    = F0075000

        [0-7] loq 9000 mtu 4470  oq 4000 ai 5 oi 84000002 oacl FFFF (encaps size 4)
        gather 3D0 (bufhdr size 32 unknown profile 30) 2 tags 18 17
        counters 0, 0 reported 0, 0.
Local OutputQ (Unicast):        Slot:4  Port:0  RED queue:0  COS queue:0
Output Q (Unicast):             Channel:0       RED queue:0  COS queue:0

The following fields are significant to Ethernet over MPLS

Table 1

Field

Description

EoMPLS configured

When this field is set to 1, the VLAN ID on the port is configured to transport Layer 2 VLAN packets.

Local OutputQ

The Slot field shows which slot the tunneled packets exit from to enter the MPLS backbone.

The Port field shows the outgoing interface for that slot.

The slot and port displayed should be connected to the MPLS backbone.


show controllers eompls forwarding-table Field Descriptions

show mpls l2transport vc

To display the state of VCs on a router, use the show mpls l2transport vc command in EXEC mode.

show mpls l2transport vc [summary] | [vc-id ] | [vc-id-min vc-id-max] [detail]

Syntax Description

summary

(Optional) Displays a summary of the active VCs on a PE router's MPLS interfaces.

vc-id

(Optional) Displays information about the VC specified.

vc-id-min

and

vc-id-max

(Optional) Displays information about a range of VC IDs that you specify. The range is from 0 to 429,467,295.

detail

(Optional) Displays detailed information about the VCs on a PE router.


Defaults

No default behavior or values.

Command Modes

EXEC

Command History

Release
Modification

12.1(8a)E

This command was introduced for the Cisco 7600 router.

12.0(21)ST

This command was integrated into Cisco IOS Release 12.0(21)ST for the Cisco 12000 series routers.

12.0(22)S

This command was integrated into Cisco IOS Release 12.0(22)S for the Cisco 10720 router.


Examples

The following example shows the status of the VCs on the router.

Router# show mpls l2transport vc

Transport Client     VC       Local       Remote      Tunnel
VC ID     Intf       State    VC Label    VC Label    Label
4         Fa2/1.1     UP       23          21          77        
101       Fa2/1.2     UP       24          22          77 

Table 2 describes the significant fields displayed in the output.

Table 2 show mpls l2transport vc Field Descriptions

Field
Description

Transport VC ID

The virtual circuit identifier assigned to one of the interfaces on the router.

Client Intf

The ingress or egress interface through which the Layer 2 VLAN packet travels.

VC State

The status of the VC. The status can be one of the following:

UP—VC is in a state where it can carry traffic between the two VC end points. A VC is up when both imposition and disposition interfaces are programmed.

The disposition interfaces are programmed if the VC has been configured and the client interface is up.

The imposition interface is programmed if the disposition interface is programmed and we have a remote VC label and an IGP label. The IGP label can be implicit null in a back-to-back configuration. (An IGP label means there is a LSP to the peer.)

DOWN—The VC is not ready to carry traffic between the two VC end points.

Local VC Label

The VC label that a router signals to its peer router, which is used by the peer router during imposition. The local VC label is a disposition label. The local VC label determines the egress interface of an arriving packet from the MPLS backbone.

Remote VC Label

The disposition VC label of the remote peer router.

Tunnel Label

An IGP label used to route the packet over the MPLS backbone to the destination router with the egress interface.


The following example shows the output of the summary keyword. The first part of the example shows VC information for the interfaces on the PE router. The second part of the example shows how many VCs have been configured for destination 13.0.0.1.

Router# show mpls l2transport vc summary 
MPLS interface VC summary:
  interface: Gi2/1, programmed imposition vcs: 1
  interface: Gi2/3, programmed imposition vcs: 1

VC summary (active/non-active) by destination:
  destination: 13.0.0.1, Number of locally configured vc(s): 2

The following example shows detailed information about currently routed VCs on the router interfaces:

Router# show mpls l2transport vc detail 
VC ID: 111, Local Group ID: 5, Remote Group ID: 2 (VC is up)
Client Intf: Gi2/1.1 is up, Destination: 2.2.2.2, Peer LDP Ident: 2.2.2.2:0
Local VC Label: 17, Remote VC Label: 17, Tunnel Label: 16
Outgoing Interface: SRP1/1, Next Hop: 12.1.1.3
Local MTU: 1500, Remote MTU: 1500
Remote interface description: GigabitEthernet2/1.1
Imposition: LC Programmed
Current Imposition/Last Disposition Slot: 1/255
Packet Totals(in/out): 0/0
Byte totals(in/out): 0/0

VC ID: 123, Local Group ID: 6, Remote Group ID: 3 (VC is up)
Client Intf: Gi2/1.2 is up, Destination: 2.2.2.2, Peer LDP Ident: 2.2.2.2:0
Local VC Label: 18, Remote VC Label: 19, Tunnel Label: 16
Outgoing Interface: SRP1/1, Next Hop: 12.1.1.3
Local MTU: 1500, Remote MTU: 1500
Remote interface description: GigabitEthernet2/1.2
Imposition: 
Current Imposition/Last Disposition Slot: 
Packet Totals(in/out): 0/0
Byte totals(in/out): 0/0

The following example shows the detailed VC information for a specified VC:

Router# show mpls l2transport vc 111 detail
VC ID: 111, Local Group ID: 5, Remote Group ID: 2 (VC is up)
Client Intf: Gi2/1.2 is up, Destination: 2.2.2.2, Peer LDP Ident: 2.2.2.2:0
Local VC Label: 17, Remote VC Label: 17, Tunnel Label: 16
Outgoing Interface: SRP1/1, Next Hop: 12.1.1.3
Local MTU: 1500, Remote MTU: 1500
Remote interface description: GigabitEthernet2/1.1
Imposition: 
Current Imposition/Last Disposition Slot: 
Packet Totals(in/out): 0/0
Byte totals(in/out): 0/0

Table 3 describes the significant fields displayed in the output.

Table 3 show mpls l2transport vc detail Field Descriptions

Field
Description

VC ID

The virtual circuit identifier assigned to one of the interfaces on the router.

Local Group ID

The ID used to group VCs locally. Ethernet over MPLS groups VCs by the hardware port, which is unique for each port on a router.

Remote Group ID

The ID used by the peer to group several VCs.

VC is up

or

VC is down

The status of the VC. The status can be one of the following:

UP—VC is in a state where it can carry traffic between the two VC end points. A VC is up when both imposition and disposition interfaces are programmed.

The disposition interfaces is programmed if the VC has been configured and the client interface is up.

The imposition interface is programmed if the disposition interface is programmed and we have a remote VC label and an IGP label. The IGP label can be implicit null in a back-to-back configuration. (An IGP label means there is a LSP to the peer.)

DOWN—The VC is not ready to carry traffic between the two VC end points.

Client

The ingress or egress interface through which the Layer 2 VLAN packet travels.

Destination

The destination specified for this VC. You specify the destination ip address as part of the mpls l2transport route command.

Peer LDP ID

The targeted peer's LDP IP address.

Local VC Label

The VC label that a router signals to its peer router, which is used by the peer router during imposition. The local VC label is a disposition label. The local VC label determines the egress interface of an arriving packet from the MPLS backbone.

Remote VC Label

The disposition VC label of the remote peer router.

Tunnel Label

An IGP label used to route the packet over the MPLS backbone to the destination router with the egress interface.

Outgoing Interface

The egress interface of the VC.

Next Hop

The IP address of the next hop.

Local MTU

The maximum transmission unit specified for the client interface.

Remote MTU

The maximum transmission unit specified for the remote router's client interface.

Imposition

The status of the line card:

LC programmed

LC not programmed


Note This field does not display pertinent output for the Cisco 10720 router.


Current Imposition/Last Disposition Slot

The current imposition is the outgoing interface used for imposition. The last disposition slot is the interface where packets for this VC arrive.


Note This field does not display pertinent output for the Cisco 10720 router.


Packet Totals (in/out)

The total number of packets forwarded in each direction.

Byte Totals (in/out)

The total number of bytes forwarded in each direction