ISDN Voice Configuration Guide, Cisco IOS Release 12.4T
Integrated Voice and Data WAN on T1 E1 Interfaces
Downloads: This chapterpdf (PDF - 258.0KB) The complete bookPDF (PDF - 2.07MB) | Feedback

Integrated Voice and Data WAN on T1 E1 Interfaces

Integrated Voice and Data WAN on T1 E1 Interfaces

Last Updated: December 15, 2011

This chapter describes how to implement the Integrated Voice and Data WAN on T1/E1 Interfaces with the AIM-ATM-VOICE-30 Module feature. This card provides a voice-processing termination solution at a density of 30 VoIP or VoFR voice or fax channels, while not consuming a network-module slot. It provides the following benefits:

  • Integrated voice and serial data WAN functionality on the same T1/E1 interface or on the second port of the voice/WAN interface cards (VWIC)
  • Support for high-complexity codecs

The serial interface supports the following features:

  • Point-to-Point Protocol (PPP), Frame Relay (FR), and high-level data link control (HDLC) encapsulations--Up to 120 channels
  • FR, HDLC, and PPP encapsulation and voice on the same T1/E1 voice interface available in the following two options:
    • Channel associated signaling (CAS) or Primary Rate Interface (PRI) group, plus the channel group are defined on the same T1/E1 interface in the Cisco 2600 WIC slot.
    • The DS0 or PRI, plus the channel groups are configured across two ports of the same T1/E1 VWIC. For example, you can configure a DS0 group or a PRI group on port 0, and a channel group on the same port or another port.
  • HDLC data inversion--Meets the density requirement for T1 links
  • Compression support--Software and hardware compression is supported on the Cisco 3660, Cisco 3725, and Cisco 3745

Note


There is only one advanced integration module (AIM) slot on Cisco 2600 platforms, so hardware compression is not applicable to the Cisco 2600 series.
  • Multilink PPP
  • G.703 (E1 unframed mode)

Feature History for Integrated Voice and Data WAN on T1/E1 Interfaces with the AIM-ATM-VOICE-30 Module

Release

Modification

12.2(15)T

This feature was introduced.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for Configuring Integrated Voice and Data WAN on T1 E1 Interfaces Using the AIM-ATM-VOICE-30 Module

  • Perform the prerequisites that are listed in the "Prerequisites for Configuring an ISDN Voice Interface" section.

Cisco 2600 series and Cisco 2600XM

Cisco 3660, Cisco 3725, and Cisco 3745

Restrictions for Configuring Integrated Voice and Data WAN on T1 E1 Interfaces Using the AIM-ATM-VOICE-30 Module

Restrictions are described in the Restrictions for Configuring ISDN Voice Interfaces section. In addition, the following apply.

Cisco 2600 Series Restrictions

  • This feature does not support Drop and Insert.
  • Voice channels can appear only on a single port of the two T1/E1 interfaces on the VWIC. Data channels can appear on both.

Other Platform Restrictions

  • This feature is not supported on the following platforms: Cisco 1700 series, Cisco MC3810, and Cisco AS5x00.

Hardware Restrictions

  • This feature is not supported on the AIM-VOICE-30 card or the AIM-ATM card.
  • Modem relay is not supported on AIM-ATM-VOICE-30 DSPs.
  • Codec GSM-EFR is not supported.
  • With a high-complexity image set, an AIM-ATM-VOICE-30 DSP card can process up to only 16 voice channels. The 16 associated time slots must be within a contiguous range. Applications and voice interfaces that can be used with the three types of AIM are listed in AIM-ATM, AIM-VOICE-30, and AIM-ATM-VOICE-30 on the Cisco 2600 Series and Cisco 3660.

Information About Integrated Voice and Data WAN on T1 E1 Interfaces Using the AIM-ATM-VOICE-30 Module


Note


General information about ISDN voice interfaces is presented in the "Information About ISDN Voice Interfaces" section.

AIM-ATM-VOICE-30 Module

The AIM-ATM-VOICE-30 module is an advanced integration module capable of supporting up to 30 voice or fax channels when used in a supported platform with one of the T1/E1 voice/WAN interface cards (such as VWIC-1T1). The module includes DSPs that are used for a number of voice-processing tasks such as voice compression and decompression, voice-activity detection or silence suppression, and PBX or PSTN signaling protocols.

The module supports VoIP, VoFR, and VoIP over ATM (VoATM) while leaving the router network-module slot open for other functions such as asynchronous or synchronous serial concentration. For additional information, see AIM-ATM, AIM-VOICE-30, and AIM-ATM-VOICE-30 on the Cisco 2600 Series and Cisco 3660 .

Integrated Voice and Data WAN

This feature adds integrated voice and serial-data WAN service on the same T1 or E1 interface or VWIC on AIM-ATM-VOICE-30 DSP cards. This enhancement enables you to use some DS0 channels for serial-data Frame Relay, high-level data link control (HDLC), and Point-to-Point Protocol (PPP), for example, while the remaining T1 or E1channels can be used for voice channel-associated signaling (CAS) or PRI.

The figure below shows a typical application scenario in which 16 channels of a T1 line are used for voice and 4 channels are used for Frame relay data. Integrating voice and serial data on the same T1 or E1 line minimizes the recurring cost of providing PSTN and data WAN access. In particular, integrated access provides a number of voice DS0s (for PSTN access) and a Frame Relay link on the same T1.

Figure 1 Typical Application Scenario


The figure below shows a typical deployment scenario in which port 0 of the VWIC-MFT module is connected to an integrated voice and data service provider with 20 channels. These 20 channels are used for voice (running CAS or PRI); the remaining four channels are used for serial data (running Frame Relay). Using this type of configuration, you can take advantage of the integrated service offered by a service provider and minimize the cost of leasing and supporting T1 or E1 lines.

Figure 2 Typical Feature Deployment


High-Complexity Voice Compression

This feature adds high-complexity G.723, G.728, and GSM-FR codec support to the AIM-ATM-VOICE-30 module so that the DSP can support both medium- and high-complexity codecs running separately. Each DSP core can process up to two voice channels, so each module can support up to 16 voice channels when running a high-complexity DSP firmware image.

The following high-complexity codecs are supported:

  • G.723.1 5.3K
  • G.723.1 6.3K
  • G.723 1A 5.3K
  • G.723 1A 6.3K
  • G.728
  • G.729
  • G.729B
  • GSM-FR

The following medium-complexity codecs are supported in high-complexity mode:

  • G.711 mu-law
  • G.711 a-law
  • G.726
  • G.729A
  • G.729 AB
  • Clear-channel codec
  • Fax relay

Note


Neither modem-relay nor GSM-EFR is supported.

Network Clock Source and Participation

Packet voice and video are sensitive to time delays. To prevent mismatches and data slips, you must synchronize data flows to a single clock source, known as the network clock . When a network clock is configured on a gateway, the router is externally clocked by one T1 or E1 port and passes that clock signal across the backplane to another T1 or E1 port on another WIC or network module slot. Use of a network clock on a gateway is configured by naming the network modules and interface cards that are participating in network clocking, and then selecting a port to act as the source of timing for the network clock.


Note


You must configure network clock source and participation to use the Integrated Voice and Data WAN on T1/E1 Interfaces Using the AIM-ATM-VOICE-30 Module feature.

The network clock provides timing from the source, through the port to the AIM, and then out to all participating router slots. The number of supported AIM slots is as follows:

  • The Cisco 2600 series and Cisco 2600XM support one internal AIM slot.
  • The Cisco 3660, Cisco 3725, and Cisco 3745 support two internal AIM slots.

The network clock source must be derived from an external source--for example, PSTN, PBX, or ATM network. For digital voice ports, the clock source command in configures the type of timing (internal or from the line) for each port that you designate as a primary source or backup for the network clock.

This command allows maximum flexibility. For example, on a router with a multiflex trunk VWIC connected to an ATM network and a digital T1/E1 packet voice trunk network module connected to a PBX, you can set up network clocking in any of three ways:

  • The multiflex trunk VWIC provides clocking to the AIM, which provides it to the digital T1/E1 packet voice trunk network module (that is, to the PBX).
  • The digital T1/E1 packet voice trunk network module provides clocking to the AIM, which provides it to the multiflex trunk VWIC.
  • The ATM network and the PBX run their own clocks, which are not necessarily synchronized. However, this scenario could result in poor voice quality.

Note


For a detailed discussion of clock sources on individual ports, see the information about clock sources on digital T1/E1 voice ports in the chapter on configuring voice ports in the Cisco IOS Voice, Video, and Fax Configuration Guide.

How to Configure Integrated Voice and Data WAN on T1 E1 Interfaces Using the AIM-ATM-VOICE-30 Module


Note


For detailed configuration tasks for the AIM-ATM, AIM-VOICE-30, see AIM-ATM, AIM-VOICE-30, and AIM-ATM-VOICE-30 on the Cisco 2600 Series and Cisco 3660 .

Configuring Network Clock Source and Participation

Configuring Clock Source Internal

To configure a clock with an internal source, perform the following steps.


Note


You must configure network clock source and participation to use the Integrated Voice and Data WAN on T1/E1 Interfaces Using the AIM-ATM-VOICE-30 Module feature.
Before You Begin

Configure the controller for PRI or DS0 groups and for ATM AIM or CAS before configuring network-clock participation parameters.


SUMMARY STEPS

1.    enable

2.    configure terminal

3.    controller {t1 | e1} slot/port

4.    clock source {line [primary] | internal}

5.    mode atm [aim aim-slot-number]

6.    exit

7.    network-clock-participate [slot slot-number | wic wic-slot | aim aim-slot-number]

8.    exit


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enters privileged EXEC mode. Enter your password when prompted.

 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters configuration mode.

 
Step 3
controller {t1 | e1} slot/port


Example:

Router(config)# controller t1 1/0

 

Enters controller configuration mode on the T1 or E1 controller on the selected slot/port.

 
Step 4
clock source {line [primary] | internal}


Example:

Router(config-controller)# clock source internal

 

Specifies the source from which the phase-locked loop (PLL) on this port derives its clocking and, if the source is line, whether this port is the primary source. Arguments and keywords are as follows:

  • line --Clock recovered from the line's receive data stream. This is the default.
  • primary --External source to which the port is connected. This option also puts a second port, which is generally connected to the PBX, into looped-time mode. Both ports are configured with line, but only the port connected to the external source is configured with primary.
  • internal --T1 or E1 controller internal PLL.
Note    With the default, the clock source does not appear in the show running-config command output. Use the show controllers command to display the current source for a port.
 
Step 5
mode atm [aim aim-slot-number]


Example:

Router(config-controller)# mode atm aim 0

 

Specifies that the configuration on this controller is for ATM, using the AIM in the specified slot for ATM processing, and creates ATM interface 0. Use when you connect the T1 line to an ATM network. The argument is as follows:

  • aim-slot-number --AIM slot number on the router chassis:
    • Cisco 2600 series: 0
    • Cisco 3660 and Cisco 3700 series: 0 or 1
Note    This command without the aim keyword uses software rather than the AIM to perform ATM SAR. This is supported on Cisco 2600 series WIC slots only and not on network module slots.
 
Step 6
exit


Example:

Router(config-controller)# exit

 

Exits the current mode.

 
Step 7
network-clock-participate [slot slot-number | wic wic-slot | aim aim-slot-number]


Example:

Router(config)# network-clock-participate slot 5



Example:

Router(config)# network-clock-participate wic 0



Example:

Router(config)# network-clock-participate aim 0

 

Allows the network module or VWIC in the specified slot to use the network clock for its timing. Keywords depend on platform.

 
Step 8
exit


Example:

Router(config)# exit

 

Exits the current mode.

 

Configuring the Clock-Source Line

To configure the clock-source line, perform the following steps.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    controller {t1 | e1} slot/port

4.    clock source {line [primary] | internal}

5.   Do one of the following:

  • mode atm [aim aim-slot]
  • mode cas
  • ds0-group group-number timeslots timeslot-range type type
  • pri-group timeslots timeslot-range

6.    exit

7.    network-clock-participate [slot slot-number | wic wic-slot| aim aim-slot-number]

8.    network-clock-select priority {t1 | e1} slot/port

9.    exit


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode. Enter your password if prompted.

 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
controller {t1 | e1} slot/port


Example:

Router(config)# controller t1 1/0

 

Enters controller configuration mode on the T1 or E1 controller on the specified slot/port.

 
Step 4
clock source {line [primary] | internal}


Example:

Router(config-controller)# clock source line

 

Specifies the source from which the phase-locked loop (PLL) on this port derives its clocking and, if the source is line, whether this port is the primary source. Keywords are as follows:

  • line --Clock recovered from the line's receive data stream. This is the default.
  • primary --External source to which the port is connected. This option also puts a second port, which is generally connected to the PBX, into looped-time mode. Both ports are configured with line, but only the port connected to the external source is configured with primary.
  • internal --T1 or E1 controller internal PLL.
Note    With the default, the clock source does not appear in the show running-config command output. Use the show controllers command to display the current source for a port.
 
Step 5
Do one of the following:
  • mode atm [aim aim-slot]
  • mode cas
  • ds0-group group-number timeslots timeslot-range type type
  • pri-group timeslots timeslot-range


Example:

Router(config-controller)# mode atm aim 0



Example:



Example:



Example:

Router(config-controller)# mode cas



Example:



Example:



Example:

Router(config-controller)# ds0-group 0 timeslots 1-4,8-23 type fxs-loop-start



Example:



Example:



Example:

Router(config-controller)# pri-group timeslots 1-4,8-23

 

(mode atm command) Sets the controller to ATM mode and creates ATM interface ATM 0. Use for Cisco 2600 series, Cisco 3660, and Cisco 3700 series that use an AIM for ATM processing. Do not use on routers that use an AIM only for DSP resources.

Note    This command without the aim keyword uses software (rather than AIM) to perform ATM segmentation and reassembly. This is supported on Cisco 2600 series WIC slots only and is not supported on network module slots.

or

(mode cas command) Sets the controller to CAS mode (for software images earlier than Cisco IOS Release 12.2(15)T). Use for Cisco 2600 series with WIC slots.

or

(ds0-group timeslots command) Creates a DS0 group that makes up a logical voice port on a T1/E1 controller and specifies the signaling type by which the router connects to the PBX or CO.

or

(pri-group timeslotscommand) Creates a PRI group that makes up a logical voice port on a channelized T1 or E1 controller.

 
Step 6
exit


Example:

Router(config-controller)# exit

 

Exits the current mode.

 
Step 7
network-clock-participate [slot slot-number | wic wic-slot| aim aim-slot-number]


Example:

Router(config)# network-clock-participate wic 0



Example:

Router(config)# network-clock-participate slot 5

 

Allows the network module or VWIC in the specified slot to use the network clock for its timing. Keywords depend on platform.

 
Step 8
network-clock-select priority {t1 | e1} slot/port


Example:

Router(config)# network-clock-select 1 e1 0/1

 

Specifies a slot/port to be used as a timing source for the network clock and the priority level for that port. The source that is given the highest priority is designated the primary source and is used first; if it becomes unavailable, the source with the second-highest priority is used, and so forth. This command is required if the clock source is from the line. The clocking is provided to the AIM, which then provides it to participating slots in the router. Keywords and arguments are as follows:

  • priority --Priority for the clock source (1 is highest priority)
  • t1 or e1--T1 or E1 ports
  • slot/port --Slot and port for the controller clock source. Slots are as follows:
    • Cisco 2600 series and Cisco 2600XM--0 (built-in WIC slot) or 1 (network module slot)
    • Cisco 3660--1 to 6
    • Cisco 3725 and Cisco 3745--1 to 4
 
Step 9
exit


Example:

Router(config)# exit

 

Exits the current mode.

 

Configuring the AIM-ATM-VOICE-30 Card for High-Complexity Codecs and Time Slots

To configure the AIM-ATM-VOICE-30 card for high-complexity codecs and time slots, perform the following steps.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    voice-card slot

4.    codec complexity {high | medium}

5.    dspfarm

6.    exit

7.    controller {t1 | e1} slot/port

8.    ds0-group group-number timeslots timeslot-range type type

9.    exit


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enters privileged EXEC mode. Enter your password when prompted.

 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
voice-card slot


Example:

Router(config)# voice-card 0

 

Enters voice-card configuration mode to configure DSP resources on the specified card. The argument is as follows:

  • slot --AIM slot number on the router chassis:
    • Cisco 2600 series and Cisco 2600XM--0
    • Cisco 3660--7 is AIM slot 0; 8 is AIM slot 1
    • Cisco 3725--3 is AIM slot 0; 4 is AIM slot 1
    • Cisco 3745--5 is AIM slot 0; 6 is AIM slot 1
 
Step 4
codec complexity {high | medium}


Example:

Router(config-voice-card)# codec complexity high

 

Changes the codec complexity to high or medium and matches the DSP complexity packaging to the supported codecs.

When codec complexity changes, the system prompts you to remove all existing DS0 or PRI groups. Then all DSPs are reset, loaded with the specified firmware image, and released.

For switched calls, you can configure a high-complexity codec even when the DSPs are loaded with medium-complexity firmware. However, an error message displays during call setup when a high-complexity codec is detected.

This command affects all DSPs on this voice card. You cannot specify the DSP firmware type based on the DSP chip type.

 
Step 5
dspfarm


Example:

Router(config-voicecard)# dspfarm

 

(Optional) Enters the DSP resources on the AIM specified in the voice-card command into the DSP resource pool.

 
Step 6
exit


Example:

Router(config-voicecard)# exit

 

Exits the current mode.

 
Step 7
controller {t1 | e1} slot/port


Example:

Router(config)# controller e1 1/0

 

Enters controller configuration mode on the T1 or E1 controller on the selected slot/port.

 
Step 8
ds0-group group-number timeslots timeslot-range type type


Example:

Router(config-controller)# ds0-group 0 timeslots 1-16

 

Creates a DS0 group that makes up a logical voice port on a T1/E1 controller. The keyword and argument are as follows:

  • timeslots timeslot-range --Number, range of numbers, or multiple ranges of numbers separated by commas. T1 range: 1 to 24. E1 range: 1 to 31.
  • type type -- Signaling type by which the router communicates with the PBX or PSTN.
Note    High-complexity codecs with the AIM-ATM-VOICE-30 module can process up to 16 voice channels.
 
Step 9
exit


Example:

Router(config-controller)# exit

 

Exits the current mode.

 

Configuring Integrated Voice and Serial Data WAN

To configure integrated voice and serial data WAN, perform the following steps.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    controller {t1 | e1} slot/port

4.    clock source {line [primary] | internal}

5.    channel-group channel-group-number timeslots timeslot-range [speed bit-rate] aim aim-slot-number

6.   Do one of the following:

  • ds0-group ds0-group-number timeslots timeslot-range type type
  • pri-group timeslots timeslot-range | d-channel timeslot| rlm-timeslot timeslot number]

7.    no shutdown

8.    exit


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enters privileged EXEC mode. Enter your password when prompted.

 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
controller {t1 | e1} slot/port


Example:

Router(config)# controller e1 0/1

 

Enters controller configuration mode on the T1 or E1 controller on the specified slot/port. The example shows a VWIC E1 card installed in WIC slot 0.

 
Step 4
clock source {line [primary] | internal}


Example:

Router(config-controller)# clock source internal

 

Specifies the source from which the phase-locked loop (PLL) on this port derives its clocking and, if the source is line, whether this port is the primary source. Arguments and keywords are as follows:

  • line --Clock recovered from the line's receive data stream. This is the default.
  • primary --External source to which the port is connected. This option also puts a second port, which is generally connected to the PBX, into looped-time mode. Both ports are configured with line, but only the port connected to the external source is configured with primary.
  • internal --T1 or E1 controller internal PLL.
Note    With the default, the clock source does not appear in the show running-config command output. To display the current source for a port, use the show controllers command.
 
Step 5
channel-group channel-group-number timeslots timeslot-range [speed bit-rate] aim aim-slot-number


Example:

Router(config-controller)# channel-group 1 timeslots 1-5 aim 0

 

Directs HDLC traffic from the T1/E1 interface to the AIM-ATM-VOICE-30 digital signaling processor (DSP) card. Use to specify T1/E1 timeslots to be used for HDLC/PPP/Frame-relay encapsulated data.

 
Step 6
Do one of the following:
  • ds0-group ds0-group-number timeslots timeslot-range type type
  • pri-group timeslots timeslot-range | d-channel timeslot| rlm-timeslot timeslot number]


Example:

Router(config-controller)# ds0-group 2 timeslots 6-12 type e&m-immediate-start



Example:



Example:



Example:

Router(config-controller)# pri-group timeslots 6-23

 

(DS0 groups) Creates a DS0 group that makes up a logical voice port on a T1/E1 controller. Keywords and arguments are as follows:

  • timeslot timeslot-range --Number, range of numbers, or multiple ranges of numbers separated by commas. T1 range: 1 to 24. E1 range: 1 to 31.
  • type type -- Signaling type by which the router communicates with the PBX or PSTN.
Note    High-complexity codecs with the AIM-ATM-VOICE-30 module can process up to 16 voice channels.

or

(PRI groups) Creates a PRI group that makes up a logical voice port on a channelized T1 or E1 controller. The keyword and argument are as follows:

  • timeslot timeslot-range --Range of numbers. T1 range: 1 to 23. E1 range: 1 to 15.
Note    Only one PRI group can be configured on a controller.
 
Step 7
no shutdown


Example:

Router(config-controller)# no shutdown

 

Reinstates the controller.

 
Step 8
exit


Example:

Router(config-controller)# exit

 

Exits the current mode.

 

Verifying Integrated Voice and Serial Data WAN

To verify integrated voice and serial data WAN, perform the following steps (listed alphabetically).

SUMMARY STEPS

1.    show controllers serial

2.    show interface serial

3.    show isdn status

4.    show network-clocks

5.    show running-config

6.    show voice dsp


DETAILED STEPS
Step 1   show controllers serial

Use this command to display the configuration on the serial interface



Example:
Router# show controllers serial 0/0:3
Interface Serial0/0:3 is up
  Hardware is ATM AIM SERIAL
  hwidb=0x82C1B768, sardb=0x826404A4
  slot 0, unit 0, subunit 0
  Current (mxt5100_t)sardb:
      Ind_Q(0x3D53580), Ind_Q_idx(695), Ind_Q_size(30000)
      Cmd_Q(0x3D4E720), Cmd_Q_idx(359), Cmd_Q_size(20000)
      Inpool(0x3B9E1A0), Inpool_size(4096)
      Outpool(0x3D1B080), Outpool_size(4096)
      Localpool(0x3D20000), Localpool_size(256)
      StorBlk(0x3BA7000), host_blk(0x3BA4840), em_blk(0x3BA4900)
      tx_buf_desc(0x3D476A0), tx_free_desc_idx (1023)
      num_fallback(0)
  MXT5100 Port Info:
      Port Number (4), Port ID (0xE05)
      Interface Number (0), Interface ID (0xF5E0)
      Port Type 2, Port Open Status SUCCESS
 HDLC channels opened(1)
      Port counters:Tx Packets:50686, Rx Packets:42864
      Tx Bytes:0, Rx Bytes:0
      Discards:No Resource:0, Protocol Errors 4
  MXT5100 Channel Info:
    HDLC Channel Info (0):
      Chan_ID (0xF25), Open Status SUCCESS
  tx_limited=0(8)
Step 2   show interface serial

Use this command to display the configuration on the serial interface.



Example:
Router# show interface serial 0/0:3
Serial0/0:3 is up, line protocol is up
  Hardware is ATM AIM SERIAL
  Internet address is 20.0.0.1/16
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  LCP Open
  Open:IPCP, CDPCP
  Last input 00:00:09, output 00:00:09, output hang never
  Last clearing of "show interface" counters 18:36:25
  Input queue:0/75/0/0 (size/max/drops/flushes); Total output drops:0
  Queueing strategy:weighted fair
  Output queue:0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 48 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6696 packets input, 446400 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     6697 packets output, 460924 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
 Timeslot(s) Used:4, Transmitter delay is 0 flags
Step 3   show isdn status

Use this command to display the status of all ISDN interfaces, including active layers, timer information, and switch-type settings.

Step 4   show network-clocks

Use this command to display the current chosen clock and the list of all sources of network clocks according to their priority.



Example:
Router# show network-clocks
  Network Clock Configuration
  ---------------------------
  Priority      Clock Source    Clock State     Clock Type
    3             E1 6/2             GOOD               E1
    5             T1 2/0             GOOD               T1
    9          Backplane             Good               PLL
  Current Primary Clock Source
  ---------------------------
  Priority      Clock Source    Clock State     Clock Type
    3             E1 6/2             GOOD                E1
Step 5   show running-config

Use this command to display the basic router configuration.

Step 6   show voice dsp

Use this command to display the voice DSP configuration.



Example:
Router# show voice dsp
DSP  DSP             DSPWARE CURR  BOOT                         PAK     TX/RX
TYPE NUM CH CODEC    VERSION STATE STATE   RST AI VOICEPORT TS ABORT  PACK COUNT
==== === == ======== ======= ===== ======= === == ========= == ===== ============
C5421000 00 {high}    3.6.14 IDLE  idle      0  0 0/0:0     01     0    5313/1516

Configuration Examples for Integrated Voice and Data WAN on T1 E1 Interfaces Using the AIM-ATM-VOICE-30 Module

Single-Serial-Data WAN Example

This example shows the configuration of a router whose E1 (0/0) controller is used for integrated voice and serial data. Note that E1 timeslots 1 to 11 are configured for serial data and E1 timeslots 12 to 31 are configured for PRI voice. Also note that interface Serial0/0:1 is the logical interface for E1 timeslots 1 to 11 and interface Serial0/0:15 is the logical interface for E1 timeslots 12 to 31.

Router# show running-config
Building configuration...
Current configuration : 1356 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "buick-hc"
!
network-clock-participate wic 0
network-clock-participate aim 0
network-clock-select 1 E1 0/0
voice-card 5
 dspfarm
!
ip subnet-zero
!!
isdn switch-type primary-qsig
no voice hpi capture buffer
no voice hpi capture destination
!
mta receive maximum-recipients 0
!
controller E1 0/0
 channel-group 1 timeslots 1-11 aim 0
 pri-group timeslots 12-31
!
controller E1 0/1
!
controller E1 0/3
controller E1 0/2
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0:1
 ip address 175.0.0.1 255.0.0.0
 encapsulation ppp
!
interface Serial0/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 no cdp enable
!
interface FastEthernet0/1
 ip address 1.10.10.1 255.0.0.0
 speed 100
 full-duplex
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 0/0:15
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 40 pots
 destination-pattern 427....
 direct-inward-dial
 port 0/0:15
 prefix 427
!
dial-peer voice 400 voip
 destination-pattern 525....
 session target ipv4:1.10.10.2
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

Multiple-Serial-Data WAN Example

This example shows the configuration of a router whose E1 (0/0) controller is used voice and serial data traffic and whose E1 (0/1) controller is used completely for data traffic.

Router# show running-config
Building configuration...
Current configuration : 1492 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "buick-hc"
!
network-clock-participate wic 0
network-clock-participate aim 0
network-clock-select 1 E1 0/0
voice-card 5
 dspfarm
!
ip subnet-zero
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination
!
mta receive maximum-recipients 0
!
controller E1 0/0
 channel-group 1 timeslots 1-11 aim 0
 pri-group timeslots 12-31
!
controller E1 0/1
 channel-group 1 timeslots 1-31 aim 0
!
controller E1 0/3
!
controller E1 0/2
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0:1
 ip address 172.0.0.1 255.0.0.0
 encapsulation ppp
!
interface Serial0/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 no cdp enable
!
interface FastEthernet0/1
 ip address 10.10.10.1 255.0.0.0
 speed 100
 full-duplex
!
interface Serial0/1:1
 ip address 175.5.0.1 255.0.0.0
 encapsulation frame-relay
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 0/0:15
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 40 pots
 destination-pattern 427....
 direct-inward-dial
 port 0/0:15
 prefix 427
!
dial-peer voice 400 voip
 destination-pattern 525....
 session target ipv4:10.10.10.2
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

High-Complexity Codecs and Network Clock Example

This example shows the configuration of a router in which the WIC at slot 0 and AIM at slot 0 are configured to received clock from the network (see the lines network-clock-participate). Also note that E1 0/0 controller is the source of the network clock (see the line network-clock-select). This example also shows that the voice card in slot 5 uses a high-complexity codec.

Router# show running-config
Building configuration...
Current configuration : 1276 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "router-hc"
!
network-clock-participate wic 0
network-clock-participate aim 0
network-clock-select 1 E1 0/0
voice-card 5
 codec complexity high
 dspfarm
!
ip subnet-zero
!
isdn switch-type primary-qsig
no voice hpi capture buffer
no voice hpi capture destination
!
mta receive maximum-recipients 0
!
controller E1 0/0
 pri-group timeslots 1-16
!
controller E1 0/1
!
controller E1 0/3
!
controller E1 0/2
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 no cdp enable
!
interface FastEthernet0/1
 ip address 1.10.10.1 255.0.0.0
 speed 100
 full-duplex
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 0/0:15
!
mgcp profile default
!
dial-peer cor custom
!
dial-peer voice 40 pots
 destination-pattern 427....
 direct-inward-dial
 port 0/0:15
 prefix 427
!
dial-peer voice 400 voip
 destination-pattern 525....
 session target ipv4:0.10.10.2
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

Additional References

General ISDN References

  • "Overview of ISDN Voice Interfaces" on page 3 --Describes relevant underlying technology; lists related documents, standards, MIBs, and RFCs; and describes how to obtain technical assistance
  • "Additional References" section on page 64 --Lists additional ISDN references

References Mentioned in This Chapter

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2011 Cisco Systems, Inc. All rights reserved.