Fax, Modem, and Text Support over IP Configuration Guide, Cisco IOS Release 15M&T
Configuring Cisco Modem Relay
Downloads: This chapterpdf (PDF - 203.0KB) The complete bookPDF (PDF - 1.42MB) | The complete bookePub (ePub - 1.09MB) | Feedback

Configuring Cisco Modem Relay

Configuring Cisco Modem Relay

Last Updated: December 4, 2012

This chapter describes the configuration of Cisco modem relay. Cisco modem relay provides support for modem connections across traditional time division multiplexing (TDM) networks. Modem relay demodulates a modem signal at one voice gateway and passes it as packet data to another voice gateway where the signal is remodulated and sent to a receiving modem.

History for the Modem Relay Feature

Release

Modification

12.2(11)T

This feature was introduced on the following platforms: Cisco 2600 series, Cisco 3620, Cisco 3640, Cisco 3660, Cisco 7200 series, and Cisco AS5300.

12.4(4)T

The gw-controlled keyword was added to the modem relay (dial-peer), modem relay (voice-service), and mgcp modem relay voip mode commands.

Finding Support Information for Platforms and Cisco IOS Software Images

Your Cisco IOS software release may not support all of the features documented in this chapter. For the latest feature information and caveats, see the release notes for your platform and software release. Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn . An account on Cisco.com is not required.


Note


For more information about this and related Cisco IOS voice features, see the Cisco IOS Voice Configuration Library ; including library preface and glossary, other feature documents, and troubleshooting documentation.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for Configuring Cisco Modem Relay

Before you configure Cisco modem relay, perform the following steps:

  • Establish a working H.323, SIP, or MGCP network for voice calls.
  • Ensure that you have a Cisco IOS image that supports gateway-controlled modem relay.
  • Determine network suitability to relay modem traffic. The key attributes are packet loss, delay, and jitter. These characteristics of the network can be determined by using the Cisco IOS Service Assurance Agent (SAA) feature.
  • For TI 549 DSPs, you must configure high codec complexity for the originating and terminating gateways.

Restrictions for Configuring Cisco Modem Relay

Restrictions of Cisco modem relay are as follows:

  • This feature does not work with third-party gateways.
  • This feature is supported on TI C5510 and TI C549 DSPs only.
  • Cisco modem relay does not support the V.150.1 signaling standard.
  • Cisco modem relay does not support SCCP.
  • The originating gateway and the terminating gateway must both be configured for Cisco modem relay. If one gateway is configured for modem pass-through, the call occurs using modem pass-through.
  • Both gateways must be configured for a high or flex codec complexity to use Cisco modem relay. If either the originating or terminating gateway is configured for a medium complexity codec, modem passthrough is used.
  • The NSE 199 event signal is sent with triple redundancy once from the terminating gateway. If this signal is lost or not recognized, the call occurs using modem pass-through.
  • Gateway-XID is enabled by default when Cisco modem relay is configured.
  • There is no mechanism to indicate that an upspeed has not taken place because of a CAC failure, regardless of tone detection.
  • Cisco modem relay works only if both modems are high-speed modems (V.34, V.90) that use V.42bis bidirectional compression. For low-speed modems, gateways that carry traffic use modem pass-through.
  • Cisco modem relay works only if both modems use the V.42 error correction protocol and if the error correction layer in both modems is enabled.
  • MGCP, H.323, and SIP can be configured on the same gateway with some restrictions--all calls in a particular T1 or E1 must be handled by MGCP, H.323, or SIP. If your gateway has multiple T1 or E1 facilities, calls on some T1s or E1s can be managed by MGCP and others can be managed by H.323 or SIP.

Information about Cisco Modem Relay

Modem relay demodulates a modem signal at one voice gateway and passes it as packet data to another voice gateway where the signal is remodulated and sent to a receiving modem. On detection of the modem answer tone, the gateways switch into modem passthrough mode and then, if the call menu (CM) signal is detected, the two gateways switch into modem relay mode.

Codec complexity determines the codec types supported on the DSP.

  • The TI 5510 DSP supports medium, high, and flex complexity. The default is flex complexity.
  • The TI 549 DSP supports only high complexity.

If your platform uses the TI 549 DSP, you must configure high codec complexity.

Cisco modem relay using MGCP and H.323 supports the following high complexity codecs:

  • Clear channel: Clear channel at 64000 bps
  • g711alaw: G.711 a-law 64000 bps
  • g711ulaw: G.711 u-law 64000 bps
  • g723ar53: G.723.1 Annex-A 5300 bps
  • g723ar63: G.723.1 Annex-A 6300 bps
  • g723r53: G.723.1 5300 bps
  • g723r63: G.723.1 6300 bps
  • g726r16: G.726 16000 bps
  • g726r24: G.726 24000 bps
  • g726r32: G.726 32000 bps
  • g728: G.728 16000 bps
  • g729br8: G.729 Annex-B 8000 bps
  • g729r8: G.729 8000 bps
  • gsmefr: GSMEFR 12200 bps
  • gsmfr: GSMFR 13200 bps

Cisco modem relay using SIP supports the following high complexity codecs:

  • g711alaw: G.711 a-law 64000 bps
  • g711ulaw: G.711 u-law 64000 bps
  • g723r63: G.723.1 6300 bps
  • g723r16: G.723.1 1600 bps
  • g728: G.728 16000 bps
  • g729r8: G.729 8000 bps

Any MGCP command is applicable to the entire gateway. For MGCP calls, dial peers do not affect call handling because call agent takes care of the call routing. When configured, the following commands affect MGCP calls only and not H.323 calls. H.323 and MGCP commands must be configured separately.

Modes for Modem Transport

There are two ways to transport modem traffic over VoIP networks:

  • With modem passthrough, the modem traffic is carried between the two gateways in RTP packets, using an uncompressed voice codec--G.711 u-law or a-law. Although modem passthrough remains susceptible to packet loss, jitter, and latency in the IP network, packet redundancy may be used to mitigate the effects of packet loss in the IP network.
  • With modem relay, the modem signals are demodulated at one gateway, converted to digital form, and carried in Simple Packet Relay Transport (SPRT) protocol (which is a protocol running over User Datagram Protocol (UDP)) packets to the other gateway, where the modem signal is recreated and remodulated, and passed to the receiving modem.

Modem relay significantly reduces the effects that dropped packets, latency and jitter have on the modem session. Compared to modem passthrough, it also reduces the amount of bandwidth used.

Modem Tone Detection and Signaling

Modem relay supports V.34 modulation and the V.42 error correction and link layer protocol with maximum transfer rates of up to 33.6 kbps. It forces higher-rate modems to train down to the supported rates. Signaling support includes the session initiation protocol (SIP), MGCP/SGCP, and H.323:

  • For MGCP and SIP, during the call setup, the gateways negotiate the following:
    • To use or not use the modem relay mode
    • To use or not use the gateway-xid
    • The value of the payload type for named signaling event (NSE) packets
  • For H.323, the gateways negotiate the following:
    • To use or not use the modem relay mode
    • To use or not use the gateway-xid

Relay Switchover

When the gateways detect a data modem, both the originating gateway and the terminating gateway switch to modem passthrough mode. This includes the following elements:

  • Switching to the G.711 codec
  • Disabling the high pass filter
  • Disabling voice activity detection (VAD)
  • Using special jitter buffer management algorithms
  • On detection of modem phase reversal tone, disabling the echo canceler

At the end of the modem call, the voice ports revert to the previous configuration and the digital signal processors (DSPs) switch back to the state before switchover. You can configure the codec by selecting the g711alaw or g711ulaw option of the codec command.

Payload Redundancy

You can enable payload redundancy so that the modem passthrough over VoIP switchover causes the gateway to send redundant packets. Redundancy can be enabled in one or both of the gateways. When only a single gateway is configured for redundancy, the other gateway receives the packets correctly, but does not produce redundant packets. When redundancy is enabled, 10-ms sample-sized packets are sent. When redundancy is disabled, 20-ms sample-sized packets are sent.


Note


By default, modem relay over VoIP capability and redundancy are disabled.

Dynamic and Static Jitter Buffers

When the gateways detect a data modem, both the originating gateway and the terminating gateway switch from dynamic jitter buffers to static jitter buffers of 200-ms depth. The switch from dynamic to static is designed to compensate for Public Switched Telephone Network (PSTN) clocking differences at the originating and terminating gateways. When the modem call is concluded, the voice ports revert to dynamic jitter buffers.

Gateway-Controlled Modem Relay

Beginning with Cisco IOS Release, 12.4(4)T, Cisco supports gateway-controlled negotiation parameters for modem relay. This new feature is a nonnegotiated, bearer-switched mode for modem transport that does not involve call-agent-assisted negotiation during the call setup. Instead, the negotiation parameters are configured directly on the gateway. These gateway-controlled negotiation parameters use named signaling events (NSEs) to indicate the switchover from voice, to voice-band data (VBD), to modem relay.

Upon detecting 2100-Hz tone, the terminating gateway sends an NSE 192 to the originating gateway and switches over to modem pass-through. The terminating gateway also sends an NSE 199 to indicate modem relay. If this event is recognized by the originating gateway, the call occurs as modem relay. If the event is not recognized, the call occurs as modem pass-through.

Because Cisco modem relay uses configured parameters, it removes the signaling dependency from the call-agent and allows modem relay support independent of call control. Cisco modem relay can be deployed over any call-agent that is capable of setting up a voice connection between gateways, including Cisco CallManager, Cisco CallManager Express, and the BTS/PGW softswitches.

The gateway-controlled modem relay parameters are enabled by default when Cisco modem relay is configured, and when Cisco modem relay is configured, gateway exchange identification (XID) parameter negotiation is always enabled. Gateway XID parameters are negotiated using the Simple Packet Relay Transport (SPRT) protocol.

How to Configure Modem Relay


Note


You must configure modem relay on both the originating and terminating gateways for this feature to operate.

Configuring Codec Complexity for TI 549 DSPs

To configure high codec complexity for the Cisco 2600, Cisco 2800, Cisco 3600, Cisco 3700, and Cisco 3800 series routers on both the originating and terminating gateways, follow these steps:


Note


The VG224 and IAD2430 platforms only support flex complexity.
SUMMARY STEPS

1.    enable

2.    configure terminal

3.    voice-card slot

4.    codec complexity {flex | high | medium} [ecan-extended]

5.    description


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
voice-card slot


Example:

Router(config)# voice-card 0

 

Enters voice-card configuration mode.

  • slot--S pecifies the voice-card slot location.
 
Step 4
codec complexity {flex | high | medium} [ecan-extended]


Example:

Router(config-voice-card)# codec complexity high

 

Specifies call density and codec complexity according to the codec standard that is being used.

  • flex --Each DSP can support up to 16 voice channels, depending on voice traffic.
  • high --each DSP supports six voice channels
  • medium --each DSP supports eight voice channels
  • ecan-extended --Optional) Selects the extended echo canceller.
 
Step 5
description


Example:

Router(config-dspfarm)# description

 

(Optional) Enters a string to include descriptive text about this DSP interface connection. This information is displayed in the output for show commands and does not affect the operation of the interface.

 

Configuring MGCP Modem Relay

Use the following steps to configure MGCP modem relay:

  • To configure MGCP modem relay using PRI, follow steps 1 to 6.
  • To configure MGCP modem relay using CAS, follow steps 1 to 9.
  • To change modem relay parameters from their default values, follow steps 10 to 12.
SUMMARY STEPS

1.    enable

2.    configure terminal

3.    mgcp [port]

4.    mgcp call-agent {dns-name | ip-address} [port] [service-type type] [version protocol-version]

5.    mgcp tse payload value

6.    mgcp modem relay voip mode nse {[codec [g711alaw| g711ulaw]] [redundancy]} gw-controlled

7.    dial-peer voice tag pots

8.    application application-name [out-bound]

9.    port controller number :D

10.    mgcp modem relay voip gateway-xid [compress {backward | both | forward | no}] [dictionary value] [string-length value]

11.    mgcp modem relay voip latency value

12.    mgcp modem relay voip sprt retries value


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
mgcp [port]


Example:

Router(config)# mgcp 4204

 

Allocates resources for MGCP and starts the MGCP daemon.

  • port --(Optional) User Datagram Protocol (UDP) port for the MGCP gateway. Range is from 1025 to 65535. The default is UDP port 2427.
 
Step 4
mgcp call-agent {dns-name | ip-address} [port] [service-type type] [version protocol-version]


Example:

Router(config)# mgcp call-agent 192.168.200.225 service-type mgcp version 1.0

 

Configures the address and protocol of the call agent for MGCP endpoints on a gateway.

  • dns-name --Fully qualified domain name (including host portion) for the call agent; for example, ca123.example.net.
  • ip-address --IP address for the call agent.
  • port --(Optional) UDP port over which the gateway sends messages to the call agent. Range is from 1025 to 65535.
  • service-type type --(Optional) Type of Gateway control service protocol. It can be one of the following values:
    • mgcp--Media Gateway Control Protocol
    • ncs--Network Communication Server
    • sgcp--Simple Gateway Control Protocol
    • tgcp--Trunking Gateway Control Protocol
  • version protocol-version --(Optional) Version of gateway control service protocol. It can be one of the following values:

For service-type mgcp:

    • 0.1 --Version 0.1 of MGCP (Internet Draft)
    • 1.0 --Version 1.0 of MGCP (RFC2705 Version 1.0)
Note    This configuration value is used to allow the router to tailor the MGCP application behavior to be compatible based on the RFC2705 definitions.
    • For service-type ncs: 1.0
    • For service-type sgcp: 1.1, 1.5
    • For service-type tgcp: 1.0
 
Step 5
mgcp tse payload value


Example:

Router(config)# mgcp tse payload 100

 

Enables inband telephony signaling events (TSEs) and specifies the payload value to be used during fax and modem passthrough and network continuity tests.

  • value --TSE payload value. Range is from 98 to 119. The default is 100.
 
Step 6
mgcp modem relay voip mode nse {[codec [g711alaw| g711ulaw]] [redundancy]} gw-controlled


Example:

Router(config)# mgcp modem relay voip mode nse codec g711ulaw redundancy gw-controlled

 

Configures Cisco modem relay parameters for MGCP.

  • nse --Named signaling event.
  • codec --Sets the voice compression selection for speech or audio signals.
    • g711alaw is required for E1.
    • g711ulaw is required for T1.
  • redundancy --(Optional) Sends redundant packets for modem traffic during the pass-through phase. Disabled by default.
  • gw-controlled --Sets the gateway-configured method for establishing modem relay parameters. Enabled by default.
 
Step 7
dial-peer voice tag pots


Example:

Router(config)# dial-peer voice 12 pots

 

(Optional) Creates a data dial peer and enters dial-peer configuration mode.

  • tag --Specifies the dial-peer identifying number. The range is 1 to 2147483647.
  • pots --Specifies an incoming POTS dial peer.
 
Step 8
application application-name [out-bound]


Example:

Router(config-dial-peer)# application MGCPAPP

 

(Optional) Enable a specific application on a dial peer

  • application-name --Name of the predefined application that you wish to enable on the dial peer. Use MGCPAPP to enable the MGCP application on a dial-peer.
  • out-bound --(Optional) Outbound calls are handed off to the named application. This keyword is used for store-and-forward fax applications and VoiceXML applications.
 
Step 9
port controller number :D


Example:

Router(congfig-dial-peer)# port 0:D

 

(Optional) Associates a dial peer with a specific voice port.

  • controller number --T1 or E1 controller.
  • :D --The D channel associated with ISDN PRI.
 
Step 10
mgcp modem relay voip gateway-xid [compress {backward | both | forward | no}] [dictionary value] [string-length value]


Example:

Router(config)# mgcp modem relay voip gateway-xid compress both dictionary 1024 string-length 32

 

(Optional) Enables in-band negotiation of compression parameters between two VoIP gateways using MGCP.

  • compress --(Optional) Direction in which data flow is compressed.
    • backward--Enables compression only in the backward direction.
    • both--Enables compression in both directions. For normal dialup, this is the preferred setting. This is the default.
    • forward--Enables compression only in the forward direction.
    • no--Disables compression in both directions.
  • dictionary value --(Optional) V.42bis parameter that specifies characteristics of the compression algorithm. The range is 512 to 2048. The default is 1024.
  • string-length value --(Optional) V.42bis parameter that specifies characteristics of the compression algorithm. The range is 16 to 32. The default is 32.
 
Step 11
mgcp modem relay voip latency value


Example:

Router(config)# mgcp modem relay voip latency 100

 

(Optional) Optimizes the Modem Relay Transport Protocol and the estimated one-way delay across the IP network MGCP.

  • value --Estimated one-way delay across the IP network, in milliseconds. The range is 100 to 1000. The default is 200.
 
Step 12
mgcp modem relay voip sprt retries value


Example:

Router(config)# mgcp modem relay voip sprt retries 15

 

(Optional) Sets the maximum number of times that the Simple Packet Relay Transport (SPRT) protocol tries to send a packet before disconnecting.

  • value --Maximum number of times that the SPRT protocol tries to send a packet before disconnecting. Range is from 6 to 30. The default is 12.
 

Configuring H.323 and SIP Modem Relay

For H.323 and SIP configurations, Cisco modem relay can be configured at two levels:

The two configuration tasks can be used separately or together. If both are configured, the dial-peer configuration overrides the global configuration.


Note


You must configure Cisco modem relay parameters on originating and terminating gateways. The NSE payload-type number, codec,and negotiation parameter settings must match.

Configuring Cisco Modem Relay Parameters Globally for H.323 and SIP

Use the following steps to configure Cisco modem relay parameters globally.

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    voice service voip

4.    h323

5.    call start slow

6.    modem relay nse payload-type number ] codec {g711ulaw| g711alaw} [redundancy] [maximum-sessions value] gw-controlled


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
voice service voip


Example:

Router(config)# voice service voip

 

Enters voice-service configuration mode.

 
Step 4
h323


Example:

Router(config-voi-serv)# h323

 

Enters H.323 voice service configuration mode.

 
Step 5
call start slow


Example:

Router(config-serv-h323)# call start slow

 

Forces an H.323 gateway to use slow-connect procedures for all VoIP calls.

 
Step 6
modem relay nse payload-type number ] codec {g711ulaw| g711alaw} [redundancy] [maximum-sessions value] gw-controlled


Example:

Router(conf-voi-serv)# modem relay nse payload-type 100 codec g711ulaw redundancy maximum-sessions 1 gw-controlled

 

Configures Cisco modem relay parameters.

  • nse --Named signaling event.
  • payload-type --(Optional) Sets the payload-type for NSE packets. The default number is 100.
  • codec --Sets the upspeed voice compression selection for speech or audio signals.
    • g711ulaw is required for T1.
    • g711alaw is required for E1.
  • redundancy --(Optional) Sends redundant packets for modem traffic during the pass-through phase. Disabled by default.
  • maximum-sessions --(Optional) Maximum number of redundant, simultaneous modem pass-through sessions. The default is 16.
  • gw-controlled --Sets the gateway-configured method for establishing modem relay parameters. Enabled by default.
 

Configuring H.323 and SIP Modem Relay for a Specific Dial Peer

Use the following steps to configure Cisco modem relay for a specific dial peer:


Note


When Cisco modem relay is configured for a specific dial peer, the dial-peer configuration takes precedence over the global configuration.
SUMMARY STEPS

1.    enable

2.    configure terminal

3.    dial-peer voice tag voip

4.    modem relay {system | nse [payload-type number] codec {g711ulaw| g711alaw}[redundancy]} gw-controlled


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
dial-peer voice tag voip


Example:

Router(config)# dial-peer voice 12 voip

 

Enters dial-peer configuration mode for a specific dial peer.

 
Step 4
modem relay {system | nse [payload-type number] codec {g711ulaw| g711alaw}[redundancy]} gw-controlled


Example:

Router(config-dial-peer)# modem relay nse payload-type 100 codec g711ulaw redundancy gw-controlled

 

Configures Cisco modem relay parameters.

  • system --Uses the global configuration parameters set by using the modem relay command in voice-service configuration mode. Enabled by default.
  • nse --Named signaling event.
  • payload-type --(Optional) Sets the payload-type for NSE packets. The default is 100.
  • codec --Sets the upspeed voice compression selection for speech or audio signals.
    • g711ulaw is required for T1.
    • g711alaw is required for E1.
  • redundancy --(Optional) Sends redundant packets for modem traffic during the pass-through phase. Disabled by default.
  • gw-controlled --Uses the gateway-configured method for establishing modem relay parameters. Enabled by default.
 

Troubleshooting Tips

This section provides information and CLI commands for verifying and troubleshooting Cisco modem relay.

Using debug Commands for Troubleshooting

Before using debug commands to troubleshoot Cisco modem relay, be sure that:

  • You can complete a voice call.
  • Cisco modem relay is configured on both the originating and terminating gateways.
  • Both the originating and terminating gateways have the same named signaling event (NSE) payload-type number and codecparameters.

Use the following debug commands to troubleshoot Cisco modem relay:

  • To verify that parameter negotiation has occurred, use these debug commands:
    • debug mgcp packet--Use to check that modem relay parameters are not sent in SDP for MGCP calls.
    • debug h245 asn1--Use to check that modem relay parameters are not sent as part of H.245 messaging.
    • debug ccsip calls--Use to check SIP messages.
  • The following are additional debug commands for troubleshooting:
    • debug voip hpi all--Use to check for event 199.
    • debug voip dsmp all--Use to check for event 199 and check for modem relay parameters.
    • debug voip dsmp session--Use to see if event 199 has been implemented for this session.

Note


See the Cisco IOS Debug Command Reference for additional modem relay debugcommands.
Using the show call active voice brief Command for Verification

To verify that modem relay is configured, you can use the show call active voice briefcommand. The following sample output shows MODEMRELAY in both the POTS and IP call legs and MODEMRELAY in the POTS call leg. Note that MODEMPASS is present for modem relay calls because modem relay calls go into modem passthrough mode before entering modem relay:

11E2 : 3 644890ms.1 +5390 pid:2 Answer 100 active 
dur 00:12:03 tx:7089/139236 rx:112/10110 
Tele 0/0/0 (3) [0/0/0] tx:0/0/0ms modem-relay noise:0 acom:0 i/0:0/0 dBm 
MODEMRELAY info:0/0/0 xid:1/1 total:0/0/0 
speeds(bps): local 28800/31200 remote 28800/31200 phy/ec v34/v42 gateway-controlled 
11E2 : 4 647210ms.1 +3070 pid:1 Originate 200 active 
dur 00:12:03 tx:6956/51275 rx:7089/82524 
IP 1.1.1.2:17692 SRTP: off rtt:0ms pl:0/0ms lost:0/0/0 delay:60/60/60ms modem-relay TextRelay: off 
media inactive detected:n media contrl rcvd:n/a timestamp:n/a 
long duration call detected:n long duration call duration:n/a timestamp:n/a MODEMPASS nse buf:0/0 loss 0% 0/0 last 0s dur:0/0s
DSP Modem Relay Termination Codes

Another troubleshooting method is to view the gateway DSP modem relay termination codes that display when you enter the debug hpi all command. The DSP-to-host messages for the modem relay termination indicate modem relay session termination time, physical or link layer, and other causes for disconnection. On receiving this indication from the DSP, the host can disconnect the call or place the channel in modem pass-through state. The table below lists the modem relay termination cause codes.

Table 1 Modem Relay Termination Cause Codes

Modem Relay Termination Cause Code

Description

0x65

SPRT--Channel 1 max retransmit count exceeded on DSP.

0x66

SPRT--Channel 1 invalid transport frame type in transmit queue.

0x67

SPRT--Channel 2 max retransmit count exceeded on DSP.

0x68

SPRT--Channel 2 invalid transport frame type in transmit queue.

0x69

SPRT--Channel 1 invalid base sequence number received by DSP from remote host.

0x6A

SPRT--Channel 2 invalid base sequence number received by DSP from remote host.

0x6B

SPRT--Received RELEASE request from peer.

0x6C

SPRT--Channel 1 invalid transmit sequence number.

0x6D

SPRT--Channel 2 invalid transmit sequence number.

0x6E

SPRT--Invalid transmit t_frame type.

0x6F

SPRT--Requested to transmit null (zero length) info t_frame.

0x71

V42--Unexpected SABME received.

0x72

V42--Client modem capability appears incompatible with V42bis capability on originating leg gateway.

0x73

V42--Client modem capability appears incompatible with V42bis capability on terminating leg gateway.

0x74

V42--Exceeded max XID retransmit count.

0x77

V42--Exceeded max SABME retransmit count.

0x78

V42--NR sequence exception.

0x79

V42--Invalid acknowledgement received.

0x7A

V42--Exceeded N401 retransmit count.

0x7B

SPRT--Requested to transmit info t_frame that exceeds max allowed size.

0x7C

V42--Received V42 DISC packet from client modem.

0x7D

V42--Received V42 FRMR packet from client modem.

0x82

V42--Failed to add packet to V42 transmit queue.

0x8C

V42--Invalid "VA".

0x8D

PHYSICAL--Modem data pump terminated/failed.

0xC9

SPRT--Channel 1 max retransmit count exceeded on line card.

0xCA

SPRT--Channel 2 max retransmit count exceeded on line card.

0xCD

SPRT--Channel 1 invalid base sequence number received by line card from DSP.

0xCE

SPRT--Channel 2 invalid base sequence number received by line card from DSP.

0xCF

SPRT--Channel 1 invalid base sequence number received by line card from remote host.

0xD0

SPRT--Channel 2 invalid base sequence number received by line card from remote host.

Configuration Examples for Cisco Modem Relay

Cisco Modem Relay Enabled for MGCP Example

The following example shows an MGCP configuration with modem relay voip mode NSE enabled, redundant packets, and by default, modem relay parameters that are configured on the gateway.

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption!
hostname Router
!
boot-start-marker
boot system flash:c2800nm-ipvoice-mz.andante_0224
boot-end-marker
!
card type t1 1 1
logging buffered 10000000 debugging
enable password lab
!
no aaa new-model
!
resource manager
!
clock timezone PST -8
clock summer-time PDT recurring
network-clock-participate slot 1
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
!
ip domain list cisco.com
no ip domain lookup
ip domain name cisco.com
ip host ccm 10.3.102.99
no ftp-server write-enable
isdn switch-type primary-qsig
!
voice-card 0
 codec complexity high
 dspfarm
!
voice-card 1
 dspfarm
!
voice service pots
!
voice service voip
 no fax-relay sg3-to-g3
 h323
 modem relay nse codec g711ulaw gw-controlled
!
voice service voatm
!
controller T1 1/0
 framing esf
 clock source internal
 linecode b8zs
 pri-group timeslots 1-12,16,24
!
controller T1 1/1
 framing esf
 clock source internal
 linecode b8zs
 pri-group timeslots 1-8,16,24 service mgcp
!
interface GigabitEthernet0/0
 ip address 10.2.109.103 255.255.0.0
 duplex auto
 speed auto
 no clns route-cache
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 no cdp enable
!
interface Serial1/1:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip default-gateway 10.2.0.1
ip classless
ip route 10.0.0.0 255.0.0.0 10.2.0.1
ip route 192.168.254.254 255.255.255.255 GigabitEthernet0/0
!
ip http server
!
control-plane
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 1/0:23
 connection plar 2000
!
voice-port 1/1:23
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.3.102.99
!
mgcp
mgcp call-agent ccm service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem relay voip mode nse redundancy gw-controlled
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
no mgcp fax-relay sg3-to-g3
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
dial-peer voice 2000 voip
 destination-pattern 2...
 session target ipv4:10.2.109.104
!
dial-peer voice 3000 voip
 destination-pattern 3...
 modem relay nse codec g711ulaw gw-controlled
 session protocol sipv2
 session target ipv4:10.2.109.104
!
dial-peer voice 2 pots
 incoming called-number 2...
 no digit-strip
 port 1/1:23
!
dial-peer voice 3 pots
 incoming called-number 3...
 no digit-strip
 port 1/0:23
!
dial-peer voice 5000 voip
!
dial-peer voice 10001 pots
!
dial-peer voice 10002 voip
!
dial-peer voice 1000 pots
!
dial-peer voice 6000 pots
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
scheduler allocate 20000 1000
ntp clock-period 17180156
ntp server 10.2.0.1 prefer
!
end

Dial Peer Configured by System Settings Example

In this example, dial peer 2000 is configured to use modem relay NSE mode, the G.711 a-law codec, redundant packets, and modem relay parameters that are configured on the gateway.

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash:c2691-ipvoice-mz.andante_0224
boot-end-marker
!
logging buffered 100000 debugging
enable password lab
!
no aaa new-model
!
resource manager
!
memory-size iomem 25
clock timezone PST -8
clock summer-time PDT recurring
no network-clock-participate slot 1
voice-card 1
 codec complexity high
 dspfarm
!
ip subnet-zero
ip cef
!
no ip dhcp use vrf connected
!
no ip domain lookup
no ftp-server write-enable
!
voice service voip
 fax protocol pass-through g711ulaw
 sip
!
controller T1 1/0
 framing sf
 linecode ami
!
controller T1 1/1
 framing sf
 linecode ami
!
interface FastEthernet0/0
 ip address 10.2.109.104 255.255.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 10.2.0.1
ip classless
ip route 10.0.0.0 255.255.255.255 10.2.0.1
!
no ip http server
!
control-plane
!
dial-peer voice 2000 voip
 modem relay nse codec g711alaw redundancy gw-controlled
 fax rate disable
 fax protocol pass-through g711alaw
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 1
 exec-timeout 0 0
 password lab
 login
line vty 2 4
 login
!
ntp clock-period 17180780
ntp server 192.168.254.253 prefer
!
end

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.