Security Configuration Guide: Access Control Lists, Cisco IOS XE Release 3S (Cisco ASR 1000)
IPv6 Access Control Lists
Downloads: This chapterpdf (PDF - 1.35MB) The complete bookPDF (PDF - 959.0KB) | Feedback

Contents

IPv6 Access Control Lists

Access lists determine what traffic is blocked and what traffic is forwarded at router interfaces and allow filtering of traffic based on source and destination addresses, and inbound and outbound traffic to a specific interface. Standard IPv6 ACL functionality was extended to support traffic filtering based on IPv6 option headers and optional, upper-layer protocol type information for finer granularity of control. Standard IPv6 ACL functionality was extended to support traffic filtering based on IPv6 option headers and optional, upper-layer protocol type information for finer granularity of control.

This module describes how to configure IPv6 traffic filtering and to control access to virtual terminal lines.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About IPv6 Access Control Lists

Access Control Lists for IPv6 Traffic Filtering

The standard ACL functionality in IPv6 is similar to standard ACLs in IPv4. Access lists determine what traffic is blocked and what traffic is forwarded at router interfaces and allow filtering based on source and destination addresses, inbound and outbound to a specific interface. Each access list has an implicit deny statement at the end. IPv6 ACLs are defined and their deny and permit conditions are set using the ipv6 access-listcommand with the deny and permit keywords in global configuration mode.

IPv6 extended ACLs augments standard IPv6 ACL functionality to support traffic filtering based on IPv6 option headers and optional, upper-layer protocol type information for finer granularity of control (functionality similar to extended ACLs in IPv4).

IPv6 Packet Inspection

The following header fields are used for IPv6 inspection: traffic class, flow label, payload length, next header, hop limit, and source or destination IP address. For further information on and descriptions of the IPv6 header fields, see RFC 2474.

Access Class Filtering in IPv6

Filtering incoming and outgoing connections to and from the router based on an IPv6 ACL is performed using the ipv6 access-class command in line configuration mode. The ipv6 access-class command is similar to the access-class command, except the IPv6 ACLs are defined by a name. If the IPv6 ACL is applied to inbound traffic, the source address in the ACL is matched against the incoming connection source address and the destination address in the ACL is matched against the local router address on the interface. If the IPv6 ACL is applied to outbound traffic, the source address in the ACL is matched against the local router address on the interface and the destination address in the ACL is matched against the outgoing connection source address. We recommend that identical restrictions are set on all the virtual terminal lines because a user can attempt to connect to any of them.

Tunneling Support

IPv6 packets tunneled in IPv4 are not inspected. If a tunnel terminates on a device, and the IPv6 traffic exiting the tunnel is nonterminating, then that traffic is inspected.

Virtual Fragment Reassembly

When Virtual Fragment Resassembly (VFR) is enabled, the VFR processing begins after access control list (ACL) input lists are checked against incoming packets. Incoming packets are tagged with the appropriate VFR information.

SSO ISSU Support for Per-User IPv6 ACL for PPP Sessions

The SSO/ISSU Support for per-User IPv6 ACL for PPP Sessions feature reproduces IPv6 ACLs on the active Route Processor to the standby RP and provides a consistent stateful switchover and in-service software upgrade experience for active sessions. The feature also extends the ability to maintain Template ACLs (IPv6 only or dual stack) through ISSU and SSO.

Both named and tagged ACLs can be configured and applied in the following ways:

  • Virtual-template ACL:
    • Virtual-template ACLs (also called interface ACLs) are configured under a virtual-template definition on the ISG router.
    • Only named ACLs can be configured under a virtual-template definition. Named ACLs applied to virtual templates get cloned to all virtual access interfaces created using that virtual-template definition.
  • Per-user ACLs are always applied through RADIUS:
    • User profile--The ACL is configured in the user profile on RADIUS and is applied when the session is up.
    • Change of Authorization (CoA) per-user push--The ACL is applied through a RADIUS CoA push from a subscriber profile.

The table below shows information about support for functionality and SSO for these ACL configurations:

Table 1 SSO Support for Named and Tagged ACLs

ACL Configuration

Functionality Supported

SSO Supported

Named ACL

Virtual-Template

Yes

Yes

User Profile

Yes

Yes

CoA per-User Push

Yes

No

Tagged ACL

Virtual-Template

No

No

User Profile

Yes

Yes

CoA per-User Push

Yes

No

How to Configure IPv6 Access Control Lists

Configuring IPv6 Traffic Filtering

Creating and Configuring an IPv6 ACL for Traffic Filtering


Note


IPv6 ACLs on the Cisco ASR 1000 platform do not contain implicit permit rules. The IPv6 neighbor discovery process uses the IPv6 network-layer service; therefore, to enable IPv6 neighbor discovery, you must add IPv6 ACLs to allow IPv6 neighbor discovery packets to be sent and received on an interface. In IPv4, the Address Resolution Protocol (ARP), which is equivalent to the IPv6 neighbor discovery process, uses a separate data-link-layer protocol; therefore, by default IPv4 ACLs implicitly allow ARP packets to be sent and received on an interface.

>
SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ipv6 access-list access-list-name

    4.    Do one of the following:

    • permit protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator [port-number]] {destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type]] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name]
    • deny protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator port-number]] {destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type] ] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name] [undetermined-transport


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ipv6 access-list access-list-name


    Example:
    Router(config)# ipv6 access-list outbound
     

    Defines an IPv6 ACL, and enters IPv6 access list configuration mode.

    • The access-list nameargument specifies the name of the IPv6 ACL. IPv6 ACL names cannot contain a space or quotation mark, or begin with a numeral.
     
    Step 4 Do one of the following:
    • permit protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator [port-number]] {destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type]] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name]
    • deny protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator port-number]] {destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type] ] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name] [undetermined-transport


    Example:
    Router(config-ipv6-acl)# permit tcp 2001:DB8:0300:0201::/32 eq telnet any 


    Example:
     
              


    Example:
              


    Example:
    Router(config-ipv6-acl)# deny tcp host 2001:DB8:1::1 any log-input
     

    Specifies permit or deny conditions for an IPv6 ACL.

     

    Applying the IPv6 ACL to an Interface

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    ipv6 traffic-filter access-list-name {in| out}


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Router(config)# interface gigabitethernet 0/0/0
       

      Specifies the interface type and number, and enters interface configuration mode.

       
      Step 4 ipv6 traffic-filter access-list-name {in| out}


      Example:
      Router(config-if)# ipv6 traffic-filter outbound out
       

      Applies the specified IPv6 access list to the interface specified in the previous step.

       

      Controlling Access to a vty

      Creating an IPv6 ACL to Provide Access Class Filtering

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    ipv6 access-list access-list-name

        4.    Do one of the following:

        • permit protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator [port-number]] {destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type]] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name
        • deny protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator port-number]] {destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type]] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name] [undetermined-transport


      DETAILED STEPS
          Command or Action Purpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters global configuration mode.

         
        Step 3 ipv6 access-list access-list-name


        Example:
        Router(config)# ipv6 access-list cisco
         

        Defines an IPv6 ACL, and enters IPv6 access list configuration mode.

         
        Step 4 Do one of the following:
        • permit protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator [port-number]] {destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type]] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name
        • deny protocol {source-ipv6-prefix/prefix-length | any | host source-ipv6-address} [operator port-number]] {destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address} [operator [port-number]] [dest-option-type [doh-number | doh-type]] [dscp value] [flow-label value] [fragments] [log] [log-input] [mobility] [mobility-type [mh-number | mh-type]] [routing] [routing-type routing-number] [sequence value] [time-range name] [undetermined-transport


        Example:
        Router(config-ipv6-acl)# permit ipv6 host 2001:DB8:0:4::32 any eq telnet


        Example:
         
                  


        Example:
                  


        Example:
        Router(config-ipv6-acl)# deny ipv6 host 2001:DB8:0:6::6/32 any
         

        Specifies permit or deny conditions for an IPv6 ACL.

         

        Applying an IPv6 ACL to the Virtual Terminal Line

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    line [aux| console| tty| vty] line-number[ending-line-number]

          4.    ipv6 access-class ipv6-access-list-name {in| out}


        DETAILED STEPS
            Command or Action Purpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 line [aux| console| tty| vty] line-number[ending-line-number]


          Example:
          Router(config)# line vty 0 4
           

          Identifies a specific line for configuration and enters line configuration mode.

          • In this example, the vty keyword is used to specify the virtual terminal lines for remote console access.
           
          Step 4 ipv6 access-class ipv6-access-list-name {in| out}


          Example:
          Router(config-line)# ipv6 access-class cisco in
           

          Filters incoming and outgoing connections to and from the router based on an IPv6 ACL.

           

          Configuration Examples for IPv6 Access Control Lists

          Example: Verifying IPv6 ACL Configuration

          In this example, the show ipv6 access-list command is used to verify that IPv6 ACLs are configured correctly:

          Router> show ipv6 access-list
          
          IPv6 access list inbound
              permit tcp any any eq bgp reflect tcptraffic (8 matches) sequence 10
              permit tcp any any eq telnet reflect tcptraffic (15 matches) sequence 20
              permit udp any any reflect udptraffic sequence 30
          
          IPv6 access list tcptraffic (reflexive) (per-user)
              permit tcp host 2001:DB8:1::32 eq bgp host 2001:DB8:2::32 eq 11000 timeout 300 (time left 243) sequence 1
              permit tcp host 2001:DB8:1::32 eq telnet host 2001:DB8:2::32 eq 11001 timeout 300 (time left 296) sequence 2
          
          IPv6 access list outbound
              evaluate udptraffic
              evaluate tcptraffic

          Example: Creating and Applying an IPv6 ACL

          The following example shows how to restrict HTTP access to certain hours during the day and log any activity outside of the permitted hours:

          Device# configure terminal
          Device(config)# time-range lunchtime
          Device(config-time-range)# periodic weekdays 12:00 to 13:00
          Device(config-time-range)# exit
          Device(config)# ipv6 access-list OUTBOUND
          Device(config-ipv6-acl)# permit tcp any any eq www time-range lunchtime
          Device(config-ipv6-acl)# deny tcp any any eq www log-input
          Device(config-ipv6-acl)# permit tcp 2001:DB8::/32 any
          Device(config-ipv6-acl)# permit udp 2001:DB8::/32 any
          Device(config-ipv6-acl)# end

          Example Controlling Access to a vty

          In the following example, incoming connections to the virtual terminal lines 0 to 4 are filtered based on the IPv6 access list named acl1:

          ipv6 access-list acl1
           permit ipv6 host 2001:DB8:0:4::2/32 any
          !
          line vty 0 4
           ipv6 access-class acl1 in

          Additional References

          Related Documents

          Related Topic

          Document Title

          Cisco IOS commands

          Cisco IOS Master Command List, All Releases

          IP access list commands

          Cisco IOS Security Command Reference

          Configuring IP access lists

          “Creating an IP Access List and Applying It to an Interface”

          Technical Assistance

          Description

          Link

          The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          Feature Information for IPv6 Access Control Lists

          The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

          Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

          Table 2 Feature Information for IPv6 Access Control Lists

          Feature Name

          Releases

          Feature Information

          IPv6 Services: Extended Access Control Lists

          Cisco IOS XE Release 2.1

          Standard IPv6 ACL functionality was extended to support traffic filtering based on IPv6 option headers and optional, upper-layer protocol type information for finer granularity of control.

          SSO/ISSU Support for Per-User IPv6 ACL for PPP Sessions

          Cisco IOS XE Release 3.2.1S

          Reproducing IPv6 ACLs on the active RP to the standby RP provides a consistent SSO and ISSU experience for active sessions.