Dynamic Multipoint VPN Configuration Guide, Cisco IOS XE Release 3S (Cisco ASR 1000)
NHRP MIB
Downloads: This chapterpdf (PDF - 120.0KB) The complete bookPDF (PDF - 1.38MB) | The complete bookePub (ePub - 1.12MB) | Feedback

NHRP MIB

NHRP MIB

Last Updated: March 28, 2013

The Cisco NHRP MIB feature introduces support for the NHRP MIB, which helps to manage and monitor the Next Hop Resolution Protocol (NHRP) via Simple Network Management Protocol (SNMP). Statistics can be collected and monitored via standards-based SNMP techniques (get operations) to query objects defined in the NHRP MIB. The NHRP MIB is VPN Routing and Forwarding (VRF) aware and supports VRF-aware queries.


Note


Security threats, as well as the cryptographic technologies to help protect against them, are constantly changing. For more information about the latest Cisco cryptographic recommendations, see the Next Generation Encryption (NGE) white paper.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for NHRP MIB

  • You should be familiar with configuring SNMP.

Restrictions for NHRP MIB

  • Cisco does not support all the MIB variables defined in RFC 2677, Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP). For a list of variables supported and other caveats of this feature, see the Agent Capabilities file. Cisco does not support the set operations defined in RFC 2677.

Information About NHRP MIB

CISCO-NHRP-MIB

CISCO-NHRP-MIB provides NHRP MIB information on managed objects relating to clients only, servers only, and clients and servers.

The NHRP MIB module contains ten tables of objects as follows:

  • NHRP Cache Table
  • NHRP Purge Request Table
  • NHRP Client Table
  • NHRP Client Registration Table
  • NHRP Client NHS Table
  • NHRP Client Statistics Table
  • NHRP Server Table
  • NHRP Server Cache Table
  • NHRP Server NHC Table
  • NHRP Server Statistics Table

The Cisco implementation supports all of the tables except the NHRP Purge Request Table.

RFC-2677

RFC-2677 - Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP), describes managed objects that can be used to remotely monitor NHRP using SNMP and provide management information on the performance of NHRP.

How to Use NHRP MIB

No special configuration is needed to implement the NHRP MIB feature. The SNMP framework can be used to manage NHRP MIB. See the section "Configuration Examples for NHRP MIB" for an example of how to manage a VRF-aware NHRP MIB.

This section contains the following task:

Verifying NHRP MIB Status

Use this task to verify the NHRP MIB status.

SUMMARY STEPS

1.    enable

2.    show snmp mib nhrp status


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Router> enable

 

Enables EXEC mode.

  • Enter your password if prompted.
 
Step 2
show snmp mib nhrp status


Example:

Router# show snmp mib nhrp status

 

Displays the status of the NHRP MIB.

 

Configuration Examples for NHRP MIB

Example Verifying NHRP MIB Status

The following output is from the show snmp mib nhrp status command:

Router# show snmp mib nhrp status 
NHRP-SNMP Agent Feature: Enabled
NHRP-SNMP Tree State: Good
ListEnqueue Count = 0 Node Malloc Counts = 1
Spoke_103#

The "Enabled" status of "NHRP-SNMP Agent Feature:" indicates that the NHRP MIB is enabled. If the NHRP MIB was disabled, it would display "Disabled." "ListEnqueue Count" and "Node Malloc Counts" counts are internal counts. "ListEnqueue Count" indicates how many nodes are queued for freeing. "Node Malloc Counts" displays how many nodes are allocated.

Example VRF-Aware NHRP MIB Configuration

The following is an example of how to configure a VRF table with the name Vrf1, for monitoring by SNMP:

ip vrf Vrf1
 rd 198102
! Name of the SNMP VPN context
 context Vrf1-context
!
crypto isakmp policy 1
 authentication pre-share
crypto isakmp key cisco47 address 0.0.0.0
!
crypto ipsec transform-set trans2 esp-des esp-md5-hmac
!
crypto ipsec profile vpnprof
 set transform-set trans2
!
interface Tunnel0
 bandwidth 1000
! DMVPN tunnel for Vrf1 VPN
 ip vrf forwarding Vrf1
 ip address 10.0.0.1 255.255.255.0
 ip mtu 1400
 ip nhrp authentication sample
 ip nhrp map multicast dynamic
 ip nhrp network-id 99
 ip nhrp holdtime 300
 no ip split-horizon eigrp 1
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source Ethernet0
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile vpnprof
!
interface Ethernet0
 ip address 172.17.0.1 255.255.255.0
!
interface Ethernet1
 ip address 192.168.0.1 255.255.255.0
!
router eigrp 1
address-family ipv4 vrf Vrf1
 network 10.0.0.0 0.0.0.255 
 network 192.168.0.0 0.0.0.255 
 no auto-summary
 autonomous-system 1
exit-address-family
!
! V2C Community ABC for VRF Vrf1
snmp-server group abc v2c context V3red_context read view_V3 
snmp-server view view_V3 iso included 
snmp-server community abc RO 
snmp-server community public RO 
snmp-server context Vrf1_context 
!
!
snmp mib community-map abc context Vrf1-context 
Spoke Configuration for DMVPN Example 
crypto isakmp policy 1
 authentication pre-share
crypto isakmp key cisco47 address 0.0.0.0
!
crypto ipsec transform-set trans2 esp-des esp-md5-hmac
!
crypto ipsec profile vpnprof
 set transform-set trans2
!
interface Tunnel0
 bandwidth 1000
 ip address 10.0.0.2 255.255.255.0
 ip mtu 1400
 ip nhrp authentication sample
 ip nhrp map 10.0.0.1 172.17.0.1
 ip nhrp map multicast 172.17.0.1
 ip nhrp network-id 99 
 ip nhrp holdtime 300
 ip nhrp nhs 10.0.0.1
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source Ethernet0
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile vpnprof
!
interface Ethernet0
 ip address dhcp hostname Spoke1
!
interface Ethernet1
 ip address 192.168.1.1 255.255.255.0
!
router eigrp 1
 network 10.0.0.0 0.0.0.255
 network 192.168.1.0 0.0.0.255

Additional References

Related Documents

Related Topic

Document Title

Cisco IOS commands

Cisco IOS Master Commands List, All Releases

Description of SNMP, SNMP MIBs, and how to configure SNMP on Cisco devices

"Configuring SNMP Support" chapter in the Cisco IOS Network Management Configuration Guide

Security commands

Cisco IOS Security Command Reference

Recommended cryptographic algorithms

Next Generation Encryption

Standards

Standard

Title

None

--

MIBs

MIB

MIBs Link

CISCO-NHRP-MIB

To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs

RFCs

RFC

Title

RFC 2677

Definitions of Managed Objects for the NBMA Next Hop Resolution Protocol (NHRP)

Technical Assistance

Description

Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for NHRP MIB

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for NHRP MIB

Feature Name

Releases

Feature Information

NHRP MIB for DMVPN Networks

Cisco IOS XE Release 2.5

The Cisco NHRP MIB feature introduces support for the NHRP MIB, which helps to manage and monitor Next Hop Resolution Protocol (NHRP) via Simple Network Management Protocol (SNMP). Statistics can be collected and monitored via standards-based SNMP techniques (get operations) to query objects defined in the NHRP MIB.

The following commands were introduced or modified: debug snmp mib nhrp, show snmp mib nhrp status.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2013 Cisco Systems, Inc. All rights reserved.