Multitopology Routing Configuration Guide, Cisco IOS Release 15SY
IS-IS MTR for the Multicast Address Family
Downloads: This chapterpdf (PDF - 149.0KB) The complete bookPDF (PDF - 292.0KB) | The complete bookePub (ePub - 569.0KB) | Feedback

IS-IS MTR for the Multicast Address Family

IS-IS MTR for the Multicast Address Family

Last Updated: October 15, 2012

The IS-IS MTR for the Multicast Address Family feature provides Intermediate System-to-Intermediate System (IS-IS) support for multiple logical topologies over a single physical network. This module describes how to configure IS-IS for Multitopology Routing (MTR) for both unicast and multicast topologies.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for IS-IS MTR for the Multicast Address Family

  • Be familiar with the concepts in the "Routing Protocol Support for MTR" section.

  • Configure and activate a global topology configuration.
  • Configure a multicast topology before activating the Intermediate System-to-Intermediate System (IS-IS) protocol in the multicast topology. For details, see the "MTR support for Multicast" feature module.
  • Activate a Multitopology Routing (MTR) topology on an IS-IS device.
  • Configure the MTR topology to globally configure all interfaces by using the all-interfaces address family topology configuration command, or configure the IS-IS topology in interface configuration mode to configure only IS-IS interfaces. The order in which you perform the two tasks does not matter.

Restrictions for IS-IS MTR for the Multicast Address Family

Only the IPv4 address family (multicast and unicast) and IPv6 address family unicast are supported. For information about configuring Multitopology IS-IS for IPv6, see the IS-IS Configuration Guide.

Information About IS-IS MTR for the Multicast Address Family

Routing Protocol Support for MTR

You must enable IP routing on the device for Multitopology Routing (MTR) to operate. MTR supports static and dynamic routing in Cisco software. You can enable dynamic routing per topology to support interdomain and intradomain routing. Route calculation and forwarding are independent for each topology. MTR support is integrated into Cisco software for the following protocols:

  • Border Gateway Protocol (BGP)
  • Enhanced Interior Gateway Routing Protocol (EIGRP)
  • Integrated Intermediate System-to-Intermediate System (IS-IS)
  • Open Shortest Path First (OSPF)

You apply the per-topology configuration in router address family configuration mode of the global routing process (router configuration mode). The address family and subaddress family are specified when the device enters address family configuration mode. You specify the topology name and topology ID by entering the topology command in address family configuration mode.

You configure each topology with a unique topology ID under the routing protocol. The topology ID is used to identify and group Network Layer Reachability Information (NLRI) for each topology in updates for a given protocol. In OSPF, EIGRP, and IS-IS, you enter the topology ID during the first configuration of the topology command for a class-specific topology. In BGP, you configure the topology ID by entering the bgp tid command under the topology configuration.

You can configure class-specific topologies with different metrics than the base topology. Interface metrics configured on the base topology can be inherited by the class-specific topology. Inheritance occurs if no explicit inheritance metric is configured in the class-specific topology.

You configure BGP support only in router configuration mode. You configure Interior Gateway Protocol (IGP) support in router configuration mode and in interface configuration mode.

By default, interfaces are not included in nonbase topologies. For routing protocol support for EIGRP, IS-IS, and OSPF, you must explicitly configure a nonbase topology on an interface. You can override the default behavior by using the all-interfaces command in address family topology configuration mode. The all-interfaces command causes the nonbase topology to be configured on all interfaces of the device that are part of the default address space or the virtual routing and forwarding (VRF) instance in which the topology is configured.

Interface Configuration Support for MTR

The configuration of a Multitopology Routing (MTR) topology in interface configuration mode allows you to enable or disable MTR on a per-interface basis. By default, a class-specific topology does not include any interfaces.

You can include or exclude individual interfaces by configuring the topology interface configuration command. You specify the address family and the topology (base or class-specific) when entering this command. The subaddress family can be specified. If no subaddress family is specified, the unicast subaddress family is used by default.

You can include globally all interfaces on a device in a topology by entering the all-interfaces command in routing topology configuration mode. Per-interface topology configuration applied with the topology command overrides global interface configuration.

The interface configuration support for MTR has these characteristics:

  • Per-interface routing configuration: Interior Gateway Protocol (IGP) routing and metric configurations can be applied in interface topology configuration mode. Per-interface metrics and routing behaviors can be configured for each IGP.
  • Open Shortest Path First (OSPF) interface topology configuration: Interface mode OSPF configurations for a class-specific topology are applied in interface topology configuration mode. In this mode, you can configure an interface cost or disable OSPF routing without removing the interface from the global topology configuration.
  • Enhanced Interior Gateway Routing Protocol (EIGRP) interface topology configuration: Interface mode EIGRP configurations for a class-specific topology are applied in interface topology configuration mode. In this mode, you can configure various EIGRP features.
  • Intermediate System-to-Intermediate System (IS-IS) interface topology configuration: Interface mode IS-IS configurations for a class-specific topology are applied in interface topology configuration mode. In this mode, you can configure an interface cost or disable IS-IS routing without removing the interface from the global topology configuration.

How to Configure IS-IS MTR for the Multicast Address Family

Activating an MTR Topology by Using IS-IS


Note


Only Multitopology Routing (MTR) commands are shown in this task.
SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router isis [area-tag]

4.    net network-entity-title

5.    metric-style wide [transition] [level-1 | level-2 | level-1-2]

6.    address-family ipv4 [multicast | unicast]

7.    topology topology-name tid number

8.    end

9.    show isis neighbors detail


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
router isis [area-tag]


Example:

Device(config)# router isis

 

Enables the Intermediate System-to-Intermediate System (IS-IS) routing protocol and optionally specifies an IS-IS process.

  • Enters router configuration mode.
 
Step 4
net network-entity-title


Example:

Device(config-router)# net 31.3131.3131.3131.00

 

Configures an IS-IS network entity title (NET) for a Connectionless Network Service (CLNS) routing process.

 
Step 5
metric-style wide [transition] [level-1 | level-2 | level-1-2]


Example:

Device(config-router)# metric-style wide

 

Globally changes the metric value for all IS-IS interfaces.

Note    Wide style metrics are required for prefix tagging.
 
Step 6
address-family ipv4 [multicast | unicast]


Example:

Device(config-router)# address-family ipv4

 

Enters router address family configuration mode.

 
Step 7
topology topology-name tid number


Example:

Device(config-router-af)# topology DATA tid 100

 

Configures IS-IS support for the topology and assigns a Topology Identifier (TID) number for each topology.

  • In this example, IS-IS support for the DATA topology is configured.
 
Step 8
end


Example:

Device(config-router-af)# end

 

Exits router address family configuration mode and returns to privileged EXEC mode.

 
Step 9
show isis neighbors detail


Example:

Device# show isis neighbors detail

 

(Optional) Displays information about IS-IS neighbors, including MTR information for the TID values for the device and its IS-IS neighbors.

 

Activating an MTR Topology in Interface Configuration Mode by Using IS-IS

Before You Begin

Define a topology globally before performing the per-interface topology configuration.


SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    ip address ip-address mask [secondary]

5.    ip router isis [area-tag]

6.    topology ipv4 [multicast | unicast] {topology-name [disable | base]}

7.    isis topology disable

8.    topology ipv4 [multicast | unicast] {topology-name [disable | base]}

9.    end


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Device# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Device(config)# interface Ethernet 2/0

 

Specifies the interface type and number, and enters interface configuration mode.

 
Step 4
ip address ip-address mask [secondary]


Example:

Device(config-if)# ip address 192.168.7.17 255.255.255.0

 

Sets a primary or secondary IP address for an interface.

 
Step 5
ip router isis [area-tag]


Example:

Device(config-if)# ip router isis

 

Configures an Intermediate System-to-Intermediate System (IS-IS) routing process for IP on an interface and attaches an area designator to the routing process.

Note    If a tag is not specified, a null tag is assumed and the process is referenced with a null tag.
 
Step 6
topology ipv4 [multicast | unicast] {topology-name [disable | base]}


Example:

Device(config-if)# topology ipv4 DATA

 

Configures a Multitopology Routing (MTR) topology instance on an interface and enters interface topology configuration mode.

Note    In this example, the topology instance DATA is configured for an MTR network that has a global topology named DATA.
 
Step 7
isis topology disable


Example:

Device(config-if-topology)# isis topology disable

 

(Optional) Prevents an IS-IS process from advertising the interface as part of the topology.

Note    In this example, the topology instance DATA will not advertise the interface as part of the topology.
 
Step 8
topology ipv4 [multicast | unicast] {topology-name [disable | base]}


Example:

Device(config-if-topology)# topology ipv4 VOICE

 

Configures an MTR topology instance on an interface.

Note    In this example, the topology instance VOICE is configured for an MTR network that has a global topology named VOICE.
 
Step 9
end


Example:

Device(config-if-topology)# end

 

Exits interface topology configuration mode and returns to privileged EXEC mode.

 

Monitoring Interface and Topology IP Traffic Statistics for MTR

Use any of the following commands in any order to monitor interface and topology IP traffic statistics for Multitopology Routing (MTR).

SUMMARY STEPS

1.    enable

2.    show ip interface [type number] [topology {name | all | base}] [stats]

3.    show ip traffic [topology {name | all | base}]

4.    clear ip interface type number [topology {name | all | base}] [stats]

5.    clear ip traffic [topology {name | all | base}]


DETAILED STEPS
  Command or Action Purpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
show ip interface [type number] [topology {name | all | base}] [stats]


Example:

Device# show ip interface FastEthernet 1/10 stats

 

(Optional) Displays IP traffic statistics for all interfaces or statistics related to the specified interface.

  • If you specify an interface type and number, information for that specific interface is displayed. If you specify no optional arguments, information for all the interfaces is displayed.
  • If the topology name keyword and argument are used, statistics are limited to the IP traffic for that specific topology.
  • The base keyword displays the IPv4 unicast base topology.
 
Step 3
show ip traffic [topology {name | all | base}]


Example:

Device# show ip traffic topology VOICE

 

(Optional) Displays global IP traffic statistics (an aggregation of all the topologies when MTR is enabled) or statistics related to a particular topology.

  • The base keyword is reserved for the IPv4 unicast base topology.
 
Step 4
clear ip interface type number [topology {name | all | base}] [stats]


Example:

Device# clear ip interface FastEthernet 1/10 topology all

 

(Optional) Resets interface-level IP traffic statistics.

  • If the topology keyword and a related keyword are not used, only the interface-level aggregate statistics are reset.
  • If all topologies need to be reset, use the all keyword as the topology name.
 
Step 5
clear ip traffic [topology {name | all | base}]


Example:

Device# clear ip traffic topology all

 

(Optional) Resets IP traffic statistics.

  • If no topology name is specified, global statistics are cleared.
 

Configuration Examples for IS-IS MTR for the Multicast Address Family

Example: Activating an MTR Topology by Using IS-IS

The following example shows how to configure both the Multitopology Routing (MTR) topologies DATA and VIDEO and Intermediate System-to-Intermediate System (IS-IS) support for MTR. The DATA and VIDEO topologies are enabled on three IS-IS neighbors in a network.

Device 1

global-address-family ipv4
 topology DATA
 topology VOICE
 end
interface Ethernet 0/0
 ip address 192.168.128.2 255.255.255.0
 ip router isis
 topology ipv4 DATA
 isis topology disable
 topology ipv4 VOICE
 end
router isis
 net 33.3333.3333.3333.00
 metric-style wide
 address-family ipv4
  topology DATA tid 100
  topology VOICE tid 200
  end

Device 2

global-address-family ipv4
 topology DATA
 topology VOICE
 all-interfaces
  forward-base
  maximum routes 1000 warning-only
  shutdown
  end
interface Ethernet 0/0
 ip address 192.168.128.1 255.255.255.0
 ip router isis
 topology ipv4 DATA
  isis topology disable
  topology ipv4 VOICE
  end
interface Ethernet 1/0
 ip address 192.168.130.1 255.255.255.0
 ip router isis
 topology ipv4 DATA
  isis topology disable
  topology ipv4 VOICE
  end
router isis
 net 32.3232.3232.3232.00
 metric-style wide
 address-family ipv4
  topology DATA tid 100
  topology VOICE tid 200
  end 

Device 3

global-address-family ipv4
 topology DATA
  topology VOICE
  all-interfaces
  forward-base
  maximum routes 1000 warning-only
  shutdown
  end
interface Ethernet 1/0
 ip address 192.168.131.1 255.255.255.0
 ip router isis
 topology ipv4 DATA
  isis topology disable
  topology ipv4 VOICE
  end
router isis
 net 31.3131.3131.3131.00
 metric-style wide
 address-family ipv4
  topology DATA tid 100
  topology VOICE tid 200
  end

Entering the show isis neighbors detail command verifies topology translation with the IS-IS neighbor Device 1:

Device# show isis neighbors detail

System Id      Type Interface IP Address      State Holdtime Circuit Id
R1             L2   Et0/0     192.168.128.2   UP    28       R5.01              
  Area Address(es): 33
  SNPA: aabb.cc00.1f00      
  State Changed: 00:07:05
  LAN Priority: 64
  Format: Phase V
  Remote TID:  100, 200
  Local TID:   100, 200

Example: MTR IS-IS Topology in Interface Configuration Mode

The following example shows how to prevent the Intermediate System-to-Intermediate System (IS-IS) process from advertising interface Ethernet 1/0 as part of the DATA topology:

interface Ethernet 1/0
 ip address 192.168.130.1 255.255.255.0
 ip router isis
 topology ipv4 DATA
  isis topology disable
  topology ipv4 VOICE
  end

Additional References

Related Documents

Related Topic Document Title

Cisco IOS commands

Cisco IOS Master Command List, All Releases

Multitopology Routing (MTR) commands

Cisco IOS Multitopology Routing Command Reference

Intermediate System-to-Intermediate System (IS-IS) commands

Cisco IOS IP Routing: IS-IS Command Reference

IS-IS concepts and tasks

IP Routing: IS-IS Configuration Guide

Configuring a multicast topology

"MTR Support for Multicast" feature module in the Multitopology Routing Configuration Guide

Configure Multitopology IS-IS for IPv6

IP Routing: IS-IS Configuration Guide

Standards and RFCs

Standard/RFC Title

RFC 5120

M-ISIS: Multitopology (MT) Routing in Intermediate System-to-Intermediate Systems (IS-ISs)

Technical Assistance

Description Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for IS-IS MTR for the Multicast Address Family

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1 Feature Information for IS-IS MTR for the Multicast Address Family
Feature Name Releases Feature Information

IS-IS MTR for the Multicast Address Family

15.1(1)SY

This feature provides Intermediate System-to-Intermediate System (IS-IS) support for multiple logical topologies over a single physical network.

No commands were introduced or modified by this feature.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.