MPLS Traffic Engineering Path Calculation and Setup Configuration Guide, Cisco IOS XE Release 3S
MPLS Traffic Engineering – Bundled Interface Support
Downloads: This chapterpdf (PDF - 1.39MB) The complete bookPDF (PDF - 4.43MB) | The complete bookePub (ePub - 874.0KB) | Feedback

MPLS Traffic Engineering – Bundled Interface Support

Contents

MPLS Traffic Engineering – Bundled Interface Support

The MPLS Traffic Engineering - Bundled Interface Support feature enables Multiprotocol Label Switching (MPLS) traffic engineering (TE) tunnels over the bundled interfaces—EtherChannel, Multilink PPP (MLP), and Gigabit EtherChannel (GEC).

The Resource Reservation Protocol (RSVP) notifies TE about bandwidth changes that occur when member links are added or deleted, or when links become active or inactive. TE notifies other nodes in the network via Interior Gateway Protocol (IGP) flooding. By default, the bandwidth available to TE Label-Switched Paths (LSPs) is 75 percent of the interface bandwidth. You can change the percentage of the global bandwidth available for TE LSPs by using an RSVP command on the bundled interface. Bandwidth reservation and preemption are supported.

The Fast Reroute (FRR) feature is supported on bundled interfaces. FRR is activated when a bundled interface goes down; for example, if you enter the shutdown command to shut down the interface or fewer than the required minimum number of links are operational.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for MPLS TE – Bundled Interface Support

  • Configure Multiprotocol Label Switching (MPLS) traffic engineering (TE) tunnels.
  • Enable Cisco Express Forwarding in global configuration mode.
  • Enable Resource Reservation Protocol (RSVP) feature.
  • Configure EtherChannel.
  • Configure Gigabit EtherChannel.
  • Configure MLP.

Restrictions for MPLS TE – Bundled Interface Support

  • Traffic engineering over switch virtual interfaces (SVIs) is not supported unless the SVI consists of a bundle of links that represent a single point-to-point interface.
  • There must be a valid IP address configuration on the bundled interface and there must not be an IP address configuration on the member links.
  • To ensure that the Fast Reroute (FRR) feature functions correctly in MLP, enter the multilinkmin-links command (to specify the preferred minimum number of links) along with the mandatory keyword (to deactivate the MLP bundle if the minimum number of links is not present).

Information About MPLS TE – Bundled Interface Support

MLP Overview

MLP provides the capability of splitting and recombining packets to a single end system across a logical pipe (also called a bundle) formed by multiple links. MLP provides bandwidth on demand and reduces transmission latency across WAN links.

MLP allows packets to be fragmented and the fragments to be sent at the same time over multiple point-to-point links to the same remote address. The multiple links come up in response to a dialer load threshold that you define. The load can be calculated on inbound traffic, outbound traffic, or on either, as needed for the traffic between the specific sites. MLP provides bandwidth on demand and reduces transmission latency across WAN links.

MLP is designed to work over single or multiple interfaces of the following types that are configured to support both dial-on-demand rotary groups and PPP encapsulation:

  • Asynchronous serial interfaces
  • Basic Rate Interfaces
  • Primary Rate Interfaces

Cisco EtherChannel Overview

Cisco EtherChannel technology builds upon standards-based 802.3 full-duplex Fast Ethernet to provide network managers with a reliable, high-speed solution for the campus network backbone. EtherChannel technology provides bandwidth scalability within the campus by providing up to 800 Mbps, 8 Gbps, or 80 Gbps of aggregate bandwidth for a Fast EtherChannel, Gigabit EtherChannel, or 10 Gigabit EtherChannel connection, respectively. Each of these connection speeds can vary in amounts equal to the speed of the links used (100 Mbps, 1 Gbps, or 10 Gbps). Even in the most bandwidth-demanding situations, EtherChannel technology helps to aggregate traffic, keeps oversubscription to a minimum, and provides effective link-resiliency mechanisms.

Cisco EtherChannel Benefits

Cisco EtherChannel technology allows network managers to provide higher bandwidth among servers, routers, and switches than a single-link Ethernet technology can provide.

Cisco EtherChannel technology provides incremental scalable bandwidth and the following benefits:

  • Standards-based—Cisco EtherChannel technology builds upon IEEE 802.3-compliant Ethernet by grouping multiple, full-duplex point-to-point links. EtherChannel technology uses IEEE 802.3 mechanisms for full-duplex autonegotiation and autosensing, when applicable.
  • Flexible incremental bandwidth—Cisco EtherChannel technology provides bandwidth aggregation in multiples of 100 Mbps, 1 Gbps, or 10 Gbps, depending on the speed of the aggregated links. For example, network managers can deploy EtherChannel technology that consists of pairs of full-duplex Fast Ethernet links to provide more than 400 Mbps between the wiring closet and the data center. In the data center, bandwidths of up to 800 Mbps can be provided between servers and the network backbone to provide large amounts of scalable incremental bandwidth.
  • Load balancing—Cisco EtherChannel technology comprises several Fast Ethernet links and is capable of load balancing traffic across those links. Unicast, broadcast, and multicast traffic is evenly distributed across the links, providing improved performance and redundant parallel paths. When a link fails, traffic is redirected to the remaining links within the channel without user intervention and with minimal packet loss.
  • Resiliency and fast convergence—When a link fails, Cisco EtherChannel technology provides automatic recovery by redistributing the load across the remaining links. When a link fails, Cisco EtherChannel technology redirects traffic from the failed link to the remaining links in less than one second. This convergence is transparent to the end user—no host protocol timers expire and no sessions are dropped.

Cisco Gigabit EtherChannel Overview

Cisco Gigabit EtherChannel (GEC) is a high-performance Ethernet technology that provides transmission rates in Gigabit per second (Gbps). A Gigabit EtherChannel bundles individual ethernet links (Gigabit Ethernet and 10 Gigabit Ethernet) into a single logical link that provides the aggregate bandwidth up to four physical links. All LAN ports in each EtherChannel must be of the same speed and must be configured as either Layer 2 or Layer 3 LAN ports. Inbound broadcast and multicast packets on one link in an EtherChannel are blocked from returning on any other link in the EtherChannel.

Load Balancing and Min-Links in MLP and EtherChannel

Load balancing affects the actual and practical bandwidth that can be used for TE. Multilink load balancing uses a per-packet load balancing method. All of the bundle interface bandwidth is available. EtherChannel load balancing has various load balancing methods, depending on the traffic pattern and the load balancing configuration. The total bandwidth available for TE may be limited to the bandwidth of a single member link.

Min-links affects how FRR works. Multilink PPP (MLP) Minimum Links (min-links) allows you to configure the minimum number of links in an MLP bundle required to keep that bundle active. To configure min-links for MLP, use the multilinkmin-links command. It is recommended that you specify the mandatory keyword. To use FRR, you must specify the mandatory keyword. On EtherChannel, min-links is supported only in the Link Aggregation Control Protocol (LACP). For other EtherChannel protocols, the minimum is one link, by default, and it is not configurable. To configure min-links for EtherChannel, use the port-channel min-links command.

How to Configure MPLS TE – Bundled Interface Support

Configuring MPLS TE on an MLP Interface

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number [name-tag]

    4.    ip address ip-address mask [secondary]

    5.    mpls traffic-eng tunnels

    6.    mpls traffic-eng backup-path tunnel

    7.    ppp multilink [ppp]

    8.    multilink min-links links [mandatory]

    9.    multilink-group group-number

    10.    ip rsvp bandwidth [interface-kbps] [single-flow-kbps]

    11.    keepalive [period [retries]]

    12.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number [name-tag]


    Example:
    Router(config)# interface multilink 1
     

    Creates a multilink bundle, assigns a group number to the bundle, and enters interface configuration mode.

     
    Step 4 ip address ip-address mask [secondary]


    Example:
    Router(config-if)# ip address 10.0.0.7 255.255.255.0
     

    Specifies an IP address for the multilink group.

     
    Step 5 mpls traffic-eng tunnels


    Example:
    Router(config-if)# mpls traffic-eng tunnels 
     

    Enables MPLS traffic engineering tunnel signaling on an interface (assuming that it is enabled on the device).

     
    Step 6 mpls traffic-eng backup-path tunnel


    Example:
    Router(config-if)# mpls traffic-eng backup-path Tunnel50 
     

    (Optional) Enables FRR.

     
    Step 7 ppp multilink [ppp]


    Example:
    Router(config-if)# ppp multilink 
     

    Enables MLP on an interface and, optionally, enables Bandwidth Allocation Control Protocol (BACP) and its Bandwidth Allocation Protocol (BAP) subset for dynamic bandwidth allocation.

     
    Step 8 multilink min-links links [mandatory]


    Example:
    Router(config-if)# multilink min-links 2 mandatory 
     

    Specifies the preferred minimum number of links in an MLP bundle.

    Note   

    To use FRR, you must enter the mandatory keyword.

     
    Step 9 multilink-group group-number


    Example:
    Router(config-if)# multilink-group 1
     

    Restricts a physical link to joining only a designated multilink-group interface.

     
    Step 10 ip rsvp bandwidth [interface-kbps] [single-flow-kbps]


    Example:
    Router(config-if)# ip rsvp bandwidth 100 
     

    Enables RSVP for IP on an interface and specifies a percentage of the total interface bandwidth as available in the RSVP bandwidth pool.

     
    Step 11 keepalive [period [retries]]


    Example:
    Router(config-if)# keepalive 3 
     

    Enables keepalive packets and specifies the number of times that the Cisco IOS software tries to send keepalive packets without a response before bringing down the interface or before bringing the tunnel protocol down for a specific interface.

     
    Step 12 end


    Example:
    Router(config-if)# end 
     

    Returns to global configuration mode.

     

    Configuring MPLS TE on an EtherChannel Interface

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number [name-tag]

      4.    ip address ip-address mask [secondary]

      5.    mpls traffic-eng tunnels

      6.    mpls traffic-eng backup-path tunnel

      7.    port-channel min-links min-num

      8.    ip rsvp bandwidth [interface-kbps] [single-flow-kbps]

      9.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number [name-tag]


      Example:
      Device(config)# interface port-channel 1
       

      Creates an EtherChannel bundle, assigns a group number to the bundle, and enters interface configuration mode.

       
      Step 4 ip address ip-address mask [secondary]


      Example:
      Device(config-if)# ip address 10.0.0.4 255.255.255.0
       

      Specifies an IP address for the EtherChannel group.

       
      Step 5 mpls traffic-eng tunnels


      Example:
      Device(config-if)# mpls traffic-eng tunnels 
       

      Enables MPLS TE tunnel signaling on an interface.

      • MPLS TE tunnel should be enabled on the device before enabling the signaling.
       
      Step 6 mpls traffic-eng backup-path tunnel


      Example:
      Device(config-if)# mpls traffic-eng backup-path Tunnel120 
       

      (Optional) Configures the physical interface to use a backup tunnel in the event of a detected failure on that interface.

       
      Step 7 port-channel min-links min-num


      Example:
      Device(config-if)# port-channel min-links 2 
       

      Specifies that a minimum number of bundled ports in an EtherChannel is required before the channel can be active.

       
      Step 8 ip rsvp bandwidth [interface-kbps] [single-flow-kbps]


      Example:
      Device(config-if)# ip rsvp bandwidth 100 
       

      Enables RSVP for IP on an interface and specifies a percentage of the total interface bandwidth as available in the RSVP bandwidth pool.

       
      Step 9 end


      Example:
      Device(config-if)# end 
       

      Exits interface configuration mode and returns to privileged EXEC mode.

       

      Configuration Examples for MPLS TE Bundled Interface Support

      Example: Configuring MPLS TE on an MLP Interface

      interface multilink 1
      ip address 10.0.0.7 255.255.255.0
      mpls traffic-eng tunnels
      mpls traffic-eng backup-path Tunnel50
      ppp multilink
      multilink min-links 2 mandatory
      multilink-group 1
      ip rsvp bandwidth 100
      keepalive 3

      Example: Configuring MPLS TE on an EtherChannel Interface

      Device> enable
      Device# configure terminal
      Device(config)# interface port-channel 1
      Device(config-if)# ip address 10.0.0.4 255.255.255.0
      Device(config-if)# mpls traffic-eng tunnels
      Device(config-if)# mpls traffic-eng backup-path Tunnel 120
      Device(config-if)# port-channel min-links 2
      Device(config-if)# ip rsvp bandwidth 100
      Device(config-if)# end
      

      Example: Configuring MPLS TE - Bundled Interface Support over Gigabit Etherchannel

      The following example shows how to enable MPLS TE – bundled interface support over GEC on Cisco devices:

      Device> enable
      Device# configure terminal
      
      ! Enable global MPLS TE on routers 
      Device(config)# router ospf 100
      Device(config-router)# network 10.0.0.1 0.0.0.255 area 0
      Device(config-router)# mpls traffic-eng area 0
      Device(config-router)# mpls traffic-eng router-id Loopback 0
      Device(config-router)# exit
      
      ! Configure  GEC  interface and enable MPLS TE and RSVP on interface  
      Device(config)# interface Port-channel 1
      Device(config-if)# ip address 10.0.0.1 255.255.255.0
      Device(config-if)# mpls traffic-eng tunnels 
      Device(config-if)# ip rsvp bandwidth
      Device(config-if)# exit
      
      ! Define explicit path
      Device(config)# ip explicit-path name primary enable
      Device(cfg-ip-expl-path)# next-address 172.12.1.2
      Device(cfg-ip-expl-path)# next-address 172.23.1.2
      Device(cfg-ip-expl-path)# next-address 172.34.1.2
      Device(cfg-ip-expl-path)# next-address 10.4.4.4
      Device(cfg-ip-expl-path)# exit
      
      ! Configure primary tunnel on head-end device
      Device(config)# interface Tunnel 14
      Device(config-if)# ip unnumbered Loopback 0
      Device(config-if)# tunnel mode mpls traffic-eng
      Device(config-if)# tunnel destination 10.10.10.0
      Device(config-if)# tunnel mpls traffic-eng autoroute announce
      Device(config-if)# tunnel mpls traffic-eng path-option 10 explicit name primary
      Device(config-if)# tunnel mpls traffic-eng fast-reroute 
      Device(config-if)# exit 
      
      ! Configure backup tunnel on head-end or mid-point device
      Device(config)# interface Tunnel 23
      Device(config-if)# ip unnumbered Looback 0
      Device(config-if)# tunnel mode mpls traffic-eng
      Device(config-if)# tunnel destination 10.20.10.0
      Device(config-if)# tunnel mpls traffic-eng path-option 10 explicit name backup
      Device(config-if)# exit
      
      ! Configure backup tunnel on protected GEC interface
      Device(config)# interface Port-channel 1
      Device(config-if)# ip address 10.0.0.1 255.255.255.0             
      Device(config-if)# mpls traffic-eng tunnels                            
      Device(config-if)# mpls traffic-eng backup-path Tunnel 23     
      Device(config-if)# ip rsvp bandwidth percent 20    
      Device(config-if)# lacp min-bundle 2
      Device(config-if)# exit
      
      ! Configure GEC interface
      Device(config)# interface GigabitEthernet 0/0/1
      Device(config-if)# no ip address
      Device(config-if)# channel-group 1 mode active
      Device(config-if)# exit
      
      ! Configure GEC interface
      Device(config)# interface GigabitEthernet 0/0/2
      Device(config-if)# no ip address
      Device(config-if)# channel-group 1 mode active
      Device(config-if)# exit
      
      

      The show mpls traffic-eng tunnels command output displays information about a tunnel or one–line information about all tunnels configured on the device:

      Device# show mpls traffic-eng tunnels tunnel 14 
       
      Name: ASR1013_t14                         (Tunnel10) Destination: 10.4.4.4
        Status:
          Admin: up         Oper: up     Path: valid       Signalling: connected
          path option 1, type explicit toR4overR3R3 (Basis for Setup, path weight 3)
       
        Config Parameters:
          Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
          Metric Type: TE (default)
          AutoRoute: enabled  LockDown: disabled Loadshare: 0 [0] bw-based
          auto-bw: disabled
        Active Path Option Parameters:
          State: explicit path option 1 is active
          BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled
       
       
            InLabel  :  -
        OutLabel : Port-channel1, 1608
        Next Hop : 172.16.1.2
        FRR OutLabel : Tunnel23, 4868
        RSVP Signalling Info:
             Src 10.1.1.1, Dst 10.4.4.4, Tun_Id 14, Tun_Instance 35
          RSVP Path Info:
            My Address: 172.12.1.1
            Explicit Route: 172.12.1.2 172.23.1.1 172.23.1.2 172.34.1.1
                            172.34.1.2 10.4.4.4
      
        History:
          Tunnel:
            Time since created: 17 hours
            Time since path change: 18 minutes, 22 seconds
            Number of LSP IDs (Tun_Instances) used: 35
          Current LSP: [ID: 35]
            Uptime: 18 minutes, 22 seconds
            Selection: reoptimization
          Prior LSP: [ID: 32]
            ID: path option unknown
            Removal Trigger: signalling shutdown
      

      Device# show mpls traffic-eng tunnels brief		
      	
      show mpls traffic-eng tunnels brief
      Signalling Summary:
          LSP Tunnels Process:            running
          Passive LSP Listener:           running
          RSVP Process:                   running
          Forwarding:                     enabled
          Periodic reoptimization:        every 3600 seconds, next in 3299 seconds
          Periodic FRR Promotion:         Not Running
          Periodic auto-bw collection:    every 300 seconds, next in 299 seconds
      
      P2P TUNNELS/LSPs:
      TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT^M
      ASR1013_t14                      10.4.1.1                       -         Po12      up/up
      On Mid Router:
      P2P TUNNELS/LSPs:
      TUNNEL NAME                      DESTINATION      UP IF     DOWN IF   STATE/PROT
      ASR1013_t14                       10.4.1.1                   Po12       Po23       up/up
      ASR1002F_t23                      10.2.1.1                   Po25        -         up/up
      

      The show mpls traffic-eng fast-reroute command output displays information about FRR-protected MPLS TE tunnels originating, transmitting, or terminating on this device.

      Device# show mpls traffic-eng fast-reroute database 
      
      P2P Headend FRR information: 
      Protected tunnel               In-label Out intf/label   FRR intf/label   Status 
      ---------------------------    -------- --------------   --------------   ------ 
       
      P2P LSP midpoint frr information: 
      LSP identifier                 In-label Out intf/label   FRR intf/label   Status 
      ---------------------------    -------- --------------   --------------   ------ 
      10.1.1.1 1 [2]                 16        Po23:16          Tu23:16          active 
      

      Additional References for MPLS TE - Bundled Interface Support

      Related Documents

      Related Topic

      Document Title

      Cisco IOS commands

      Cisco IOS Master Command List, All Releases

      MPLS traffic engineering commands

      Cisco IOS Multiprotocol Label Switching Command Reference

      IPv6 commands

      Cisco IOS IPv6 Command Reference

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for MPLS TE - Bundled Interface Support

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for MPLS TE - Bundled Interface Support

      Feature Name

      Releases

      Feature Information

      MPLS TE - Bundled Interface Support

      12.2(33)SRC

      Cisco IOS XE Release 3.6S

      Cisco IOS XE Release 3.8S

      Cisco IOS XE Release 3.12S

      The MPLS TE - Bundled Interface Support feature enables MPLS traffic engineering (TE) tunnels over the bundled interfaces EtherChannel, Multilink PPP (MLP), and Gigabit EtherChannel (GEC).

      In 12.2(33)SRC, this feature was introduced.

      In Cisco IOS XE Release 3.6S, support was added for the Cisco ASR 903 Series Routers.

      In Cisco IOS XE Release 3.8S, support was added for the Cisco ISR 4400 Series Routers.

      In Cisco IOS XE Release 3.12S, support was added for the Cisco ASR 1000 Series Routers.

      Glossary

      bundled interface—Generic terms to represent port-channel, multilink, and VLAN interfaces.

      Cisco express forwarding —A means for accelerating the forwarding of packets within a router, by storing route lookup information in several data structures instead of in a route cache.

      CLNS —Connectionless Network Service. The Open Systems Interconnection (OSI) network layer service that does not require a circuit to be established before data is transmitted. CLNS routes messages to their destination independently of any other messages.

      CSPF —Constrained Shortest Path First. A routing protocol that calculates the shortest path based on a set of constraints, such as a minimum bandwidth requirement, maximum number of nodes, or nodes to include or exclude.

      enterprise network —A large and diverse network connecting most major points in a company or other organization.

      FRR—Fast ReRoute.

      headend —The endpoint of a broadband network. All stations send toward the headend; the headend then sends toward the destination stations.

      IGP —Interior Gateway Protocol. An Internet protocol used to exchange routing information within an autonomous system. Examples of common Internet IGPs include Interior Gateway Routing protocol (IGRP), Open Shortest Path First (OSPF), and Routing Information Protocol (RIP).

      interface —A network connection.

      IS-IS —Intermediate System to Intermediate System. OSI link-state hierarchical routing protocol based on DECnet Phase V routing, where ISs (routers) exchange routing information based on a single metric, to determine the network topology.

      LDN— Link Down Notification.

      LSP —Label-Switched Path. A sequence of hops (R0...Rn) in which a packet travels from R0 to Rn through label switching mechanisms. A label-switched path can be chosen dynamically, based on normal routing mechanisms, or through configuration.

      member links—Individual interfaces that are grouped into a bundled interface.

      message-pacing —The former name of the rate limiting feature.

      MPLS —Formerly known as tag switching, Multiprotocol Label Switching is a method for directing packets primarily through Layer 2 switching rather than Layer 3 routing. In MPLS, packets are assigned short fixed-length labels at the ingress to an MPLS cloud by using the concept of forwarding equivalence classes. Within the MPLS domain, the labels are used to make forwarding decisions mostly without recourse to the original packet headers.

      OSPF —Open Shortest Path First. A link-state, hierarchical Interior Gateway Protocol (IGP) routing protocol. derived from the Intermediate System-Intermediate System (IS-IS) protocol. OSPF features are least-cost routing, multipath routing, and load balancing.

      router —A network layer device that uses one or more metrics to determine the optimal path along which network traffic should be forwarded. Routers forward packets from one network to another based on network layer information.

      RSVP —Resource Reservation Protocol. A protocol that supports the reservation of resources across an IP network.

      scalability —An indicator showing how quickly some measure of resource usage increases as a network gets larger.

      TLV —type, length, value. TLV objects are used in data communication to provide optional information. The type field indicates the type of items in the value field. The length field indicates the length of the value field. The value field is the data portion of the packet.

      topology —The physical arrangement of network nodes and media within an enterprise networking structure.

      TE (traffic engineering) —Techniques and processes that cause routed traffic to travel through the network on a path other than the one that would have been chosen if standard routing methods were used.

      traffic engineering tunnel —A label-switched tunnel that is used for traffic engineering. Such a tunnel is set up through means other than normal Layer 3 routing; it is used to direct traffic over a path different from the one that Layer 3 routing would cause the tunnel to take.