MPLS Label Distribution Protocol Configuration Guide, Cisco IOS XE Release 3S
MPLS LDP Autoconfiguration
Downloads: This chapterpdf (PDF - 1.24MB) The complete bookPDF (PDF - 3.32MB) | The complete bookePub (ePub - 456.0KB) | Feedback

MPLS LDP Autoconfiguration

Contents

MPLS LDP Autoconfiguration

The MPLS LDP Autoconfiguration feature enables you to globally configure Label Distribution Protocol (LDP) on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for MPLS LDP Autoconfiguration

  • In Cisco IOS Release 12.0(32)SY, the mpls ldp autoconfig command is supported only with Open Shortest Path First (OSPF). Other Interior Gateway Protocols (IGPs) are not supported.
  • If the Label Distribution Protocol (LDP) is disabled globally, the mpls ldp autoconfig command fails and generates a console message explaining that LDP must first be enabled globally by using the mpls ip global configuration command.
  • If the mpls ldp autoconfig command is configured for an IGP instance, you cannot enter the no mpls ip global configuration command. To disable LDP, you must first issue the no mpls ldp autoconfig command.
  • For interfaces running Intermediate System-to-Intermediate System (IS-IS) processes, you can enable Multiprotocol Label Switching (MPLS) for each interface, using the router mode command mpls ldp autoconfig or the mpls ldp igp autoconfig interface configuration command.
  • You specify that the default label distribution protocol is LDP for a device or for an interface. Tag Distribution Protocol (TDP) is not supported.
  • The MPLS LDP Autoconfiguration feature is not supported on traffic engineering tunnel interfaces.

Information About MPLS LDP Autoconfiguration

MPLS LDP Autoconfiguration on OSPF and IS-IS Interfaces

The MPLS LDP Autoconfiguration feature enables you to globally enable Label Distribution Protocol (LDP) on every interface associated with an Interior Gateway Protocol (IGP) instance. This feature is supported on Open Shortest Path First (OSPF) and Intermediate System-to-Intermediate System (IS-IS) IGPs. It provides a means to block LDP from being enabled on interfaces that you do not want enabled. The goal of the MPLS LDP Autoconfiguration feature is to make configuration easier, faster, and error free.

You issue the mpls ldp autoconfig command to enable LDP on each interface that is running an OSPF or IS-IS process. If you do not want some of the interfaces to have LDP enabled, you can issue the no mpls ldp igp autoconfig command on those interfaces.

How to Configure MPLS LDP Autoconfiguration

Configuring MPLS LDP Autoconfiguration with OSPF Interfaces

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    mpls ip

    4.    mpls label protocol ldp

    5.    interface type number

    6.    ip address prefix mask

    7.    mpls ip

    8.    exit

    9.    router ospf process-id

    10.    network ip-address wildcard-mask area area-id

    11.    mpls ldp autoconfig [area area-id]

    12.    end


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 mpls ip


    Example:
    Device(config)# mpls ip
     

    Globally enables hop-by-hop forwarding.

     
    Step 4 mpls label protocol ldp


    Example:
    Device(config)# mpls label protocol ldp
     

    Specifies the Label Distribution Protocol (LDP) as the default protocol.

     
    Step 5 interface type number


    Example:
    Device(config)# interface POS 0/3/0
     

    Specifies the interface to configure, and enters interface configuration mode.

     
    Step 6 ip address prefix mask


    Example:
    Device(config-if)# ip address 10.25.0.11 255.255.255.255
     

    Assigns an IP address to the interface.

     
    Step 7 mpls ip


    Example:
    Device(config-if)# mpls ip
     

    Enables hop-by-hop forwarding on the interface.

     
    Step 8 exit


    Example:
    Device(config-if)# exit
     

    Returns to global configuration mode.

     
    Step 9 router ospf process-id


    Example:
    Device(config)# router ospf 1 
     

    Enables Open Shortest Path First (OSPF) routing, and enters router configuration mode.

     
    Step 10 network ip-address wildcard-mask area area-id


    Example:
    Device(config-router)# network 10.0.0.0 0.255.255.255 area 3
     

    Defines an interface on which OSPF runs and defines the area ID for that interface.

     
    Step 11 mpls ldp autoconfig [area area-id]


    Example:
    Device(config-router)# mpls ldp autoconfig area 3 
     

    Enables the MPLS LDP Autoconfiguration feature to enable LDP on interfaces belonging to the OSPF process.

    • If no area is specified, the command applies to all interfaces associated with the OSPF process. If an area ID is specified, then only interfaces associated with that OSPF area are enabled with LDP.
     
    Step 12 end


    Example:
    Device(config-router)# end
     

    Returns to privileged EXEC mode.

     

    Disabling MPLS LDP Autoconfiguration from Selected OSPF Interfaces

    When you issue the mpls ldp autoconfig command, all the interfaces that belong to an Open Shortest Path First (OSPF) area are enabled for the Label Distribution Protocol (LDP). To remove LDP from some interfaces, use the no mpls ldp igp autoconfig command on those interfaces. The following configuration steps show how to disable LDP from some of the interfaces after they were configured with the MPLS LDP Autoconfiguration feature with the mpls ldp autoconfig command.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    no mpls ldp igp autoconfig

      5.    end


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Device(config)# interface POS 3/0
       

      Specifies the interface to configure and enters interface configuration mode.

       
      Step 4 no mpls ldp igp autoconfig


      Example:
      Device(config-if)# no mpls ldp igp autoconfig
       

      Disables LDP for that interface.

       
      Step 5 end


      Example:
      Device(config-if)# end
       

      Returns to privileged EXEC mode.

       

      Verifying MPLS LDP Autoconfiguration with OSPF

      SUMMARY STEPS

        1.    enable

        2.    show mpls interfaces [type number | vrf vpn-name] [all] [detail] [internal]

        3.    show mpls ldp discovery [vrf vpn-name | all] [detail]


      DETAILED STEPS
        Step 1   enable

        Enables privileged EXEC mode. Enter your password if prompted.

        Step 2   show mpls interfaces [type number | vrf vpn-name] [all] [detail] [internal]

        Displays the method used to enable the Label Distribution Protocol (LDP) on an interface:

        • If LDP is enabled by the mpls ldp autoconfig command, the output displays:


        Example:
        IP labeling enabled (ldp):
           IGP config
        
        • If LDP is enabled by the mpls ip command, the output displays:


        Example:
        IP labeling enabled (ldp):
          Interface config
        
        • If LDP is enabled by the mpls ip command and the mpls ldp autoconfig command, the output displays:


        Example:
        IP labeling enabled (ldp):
          Interface config
          IGP config
        

        The following example shows that LDP was enabled on the interface by both the mpls ip and mpls ldp autoconfig commands:



        Example:
        Device# show mpls interfaces Serial 2/0 detail
         
        Interface Serial2/0:
                IP labeling enabled (ldp):
                  Interface config
                  IGP config
                LSP Tunnel labeling enabled
                BGP labeling not enabled
                MPLS operational
                Fast Switching Vectors:
                  IP to MPLS Fast Switching Vector
                  MPLS Turbo Vector
                MTU = 1500
        
        Step 3   show mpls ldp discovery [vrf vpn-name | all] [detail]

        Displays how LDP was enabled on the interface. In the following example, LDP was enabled by both the mpls ip and mpls ldp autoconfig commands:



        Example:
        Device# show mpls ldp discovery detail
        
        Local LDP Identifier:
            10.11.11.11:0
            Discovery Sources:
            Interfaces:
                Serial2/0 (ldp): xmit/recv
                    Enabled: Interface config, IGP config;
                    Hello interval: 5000 ms; Transport IP addr: 10.11.11.11 
                    LDP Id: 10.10.10.10:0
                      Src IP addr: 10.0.0.1; Transport IP addr: 10.10.10.10
                      Hold time: 15 sec; Proposed local/peer: 15/15 sec

        Configuring MPLS LDP Autoconfiguration with IS-IS Interfaces

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    interface type number

          4.    ip address prefix mask

          5.    ip router isis

          6.    exit

          7.    mpls ip

          8.    mpls label protocol ldp

          9.    router isis

          10.    mpls ldp autoconfig [level-1 | level-2]

          11.    end


        DETAILED STEPS
            Command or Action Purpose
          Step 1 enable


          Example:
          Device> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Device# configure terminal
           

          Enters global configuration mode.

           
          Step 3 interface type number


          Example:
          Device(config)# interface POS 0/2
           

          Specifies the interface to configure and enters interface configuration mode.

           
          Step 4 ip address prefix mask


          Example:
          Device(config-if)# ip address 10.50.72.4 255.0.0.0
           

          Assigns an IP address to the interface.

           
          Step 5 ip router isis


          Example:
          Device(config-if)# ip router isis
           

          Enables the Intermediate System-to-Intermediate System (IS-IS) for IP on the interface.

           
          Step 6 exit


          Example:
          Device(config-if)# exit
           

          Returns to global configuration mode.

           
          Step 7 mpls ip


          Example:
          Device(config)# mpls ip
           

          Globally enables hop-by-hop forwarding.

           
          Step 8 mpls label protocol ldp


          Example:
          Device(config)# mpls label protocol ldp
           

          Specifies the Label Distribution Protocol (LDP) as the default protocol.

           
          Step 9 router isis


          Example:
          Device(config)# router isis
           

          Enables an IS-IS process on the device and enters router configuration mode.

           
          Step 10 mpls ldp autoconfig [level-1 | level-2]


          Example:
          Device(config-router)# mpls ldp autoconfig 
           

          Enables the LDP for interfaces that belong to an IS-IS process.

           
          Step 11 end


          Example:
          Device(config-router)# end
           

          Returns to privileged EXEC mode.

           

          Disabling MPLS LDP Autoconfiguration from Selected IS-IS Interfaces

          When you issue the mpls ldp autoconfig command, all the interfaces that belong to an Intermediate System-to-Intermediate System (IS-IS) process are enabled for the Label Distribution Protocol (LDP). To remove LDP from some interfaces, use the no mpls ldp igp autoconfig command on those interfaces. The following configuration steps show how to disable LDP from some of the interfaces after they were configured with the MPLS LDP Autoconfiguration feature with the mpls ldp autoconfig command.

          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    interface type number

            4.    no mpls ldp igp autoconfig

            5.    end


          DETAILED STEPS
              Command or Action Purpose
            Step 1 enable


            Example:
            Device> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.
             
            Step 2 configure terminal


            Example:
            Device# configure terminal
             

            Enters global configuration mode.

             
            Step 3 interface type number


            Example:
            Device(config)# interface POS 3/0
             

            Specifies the interface to configure and enters interface configuration mode.

             
            Step 4 no mpls ldp igp autoconfig


            Example:
            Device(config-if)# no mpls ldp igp autoconfig
             

            Disables LDP for that interface.

             
            Step 5 end


            Example:
            Device(config-if)# end
             

            Returns to privileged EXEC mode.

             

            Verifying MPLS LDP Autoconfiguration with IS-IS

            SUMMARY STEPS

              1.    enable

              2.    show isis mpls ldp


            DETAILED STEPS
              Step 1   enable

              Enables privileged EXEC mode.

              Step 2   show isis mpls ldp

              Shows that the Intermediate System-to-Intermediate System (IS-IS) is configured on the interface and that the Label Distribution Protocol (LDP) is enabled:



              Example:
              Device# show isis mpls ldp
              
              Interface: POS0/2; ISIS tag null enabled
               ISIS is UP on interface
               AUTOCONFIG Information :
                 LDP enabled: YES
               SYNC Information :
                 Required: NO
              

              The output shows:

              • IS-IS is up.
              • LDP is enabled.

              If the MPLS LDP Autoconfiguration feature is not enabled on an interface, the output looks like the following:



              Example:
              Interface: Ethernet0; ISIS tag null enabled
               ISIS is UP on interface
               AUTOCONFIG Information :
                 LDP enabled: NO
               SYNC Information :
                 Required: NO

              Troubleshooting Tips

              You can use the debug mpls ldp autoconfig command to display events that are related to the MPLS LDP Autoconfiguration feature.

              Configuration Examples for MPLS LDP Autoconfiguration

              Example: MPLS LDP Autoconfiguration with OSPF

              The following configuration commands enable the Label Distribution Protocol (LDP) for Open Shortest Path First (OSPF) process 1 area 3. The mpls ldp autoconfig area 3 command and the OSPF network commands enable LDP on POS interfaces 0/0, 0/1, and 1/1. The no mpls ldp igp autoconfig command on POS interface 1/0 prevents LDP from being enabled on POS interface 1/0, even though OSPF is enabled for that interface.

              configure terminal
               interface POS 0/0
                ip address 10.0.0.1 255.0.0.0
              !
               interface POS 0/1
                ip address 10.0.1.1 255.0.0.1
              !
               interface POS 1/1
                ip address 10.1.1.1 255.255.0.0
              !
               interface POS 1/0
                ip address 10.1.0.1 0.1.0.255
                exit
              !
               router ospf 1
                network 10.0.0.0 0.0.255.255 area 3
                network 10.1.0.0 0.0.255.255 area 3
                mpls ldp autoconfig area 3
                end
               interface POS 1/0
                no mpls ldp igp autoconfig

              Example: MPLS LDP Autoconfiguration with IS-IS

              The following example shows the configuration of the MPLS LDP Autoconfiguration feature on POS0/2 and 0/3 interfaces, which are running Intermediate System-to-Intermediate System (IS-IS) processes:

              configure terminal
               interface POS 0/2
                ip address 10.0.0.1 255.0.0.1
                ip router isis
              !
               interface POS 0/3
                ip address 10.1.1.1 255.0.1.0
                ip router isis
                exit
              mpls ip
              mpls label protocol ldp
              router isis
              mpls ldp autoconfig

              Additional References

              Related Documents

              Related Topic

              Document Title

              Cisco IOS commands

              Cisco IOS Master Command List, All Releases

              MPLS commands

              Cisco IOS Multiprotocol Label Switching Command Reference

              MPLS LDP

              “MPLS Label Distribution Protocol” module in the MPLS Label Distribution Protocol Configuration Guide

              The MPLS LDP IGP Synchronization feature

              “MPLS LDP IGP Synchronization” module in the MPLS Label Distribution Protocol Configuration Guide

              The MPLS LDP Session Protection feature

              “MPLS LDP Session Protection” module in the MPLS Label Distribution Protocol Configuration Guide

              Configuring integrated IS-IS

              “Integrated IS-IS Routing Protocol Overview” module in the IP Routing: ISIS Configuration Guide

              MIBs

              MIB

              MIBs Link

              MPLS LDP MIB

              To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

              http:/​/​www.cisco.com/​go/​mib

              RFCs

              RFC

              Title

              RFC 3036

              LDP Specification

              RFC 3037

              LDP Applicability

              Technical Assistance

              Description

              Link

              The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

              http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

              Feature Information for MPLS LDP Autoconfiguration

              The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

              Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

              Table 1 Feature Information for MPLS LDP Autoconfiguration

              Feature Name

              Releases

              Feature Information

              MPLS LDP Autoconfiguration

              12.0(30)S

              12.0(32)SY

              12.2(28)SB

              12.2(33)SRB

              12.2(33)XNE

              12.3(14)T

              15.0(1)M

              15.0(1)S

              Cisco IOS XE Release 2.5

              Cisco IOS XE Release 3.6S

              This feature enables you to globally configure LDP on every interface associated with a specified Interior Gateway Protocol (IGP) instance.

              In Cisco IOS Release 12.0(30)S, this feature was introduced with support for OSPF.

              In Cisco IOS Release 12.0(32)SY, support for IS-IS was added.

              This feature was integrated into Cisco IOS Release 12.2(28)SB with support for OSPF.

              This feature was integrated into Cisco IOS Release 12.2(33)SRB.

              This feature was integrated into Cisco IOS Release 12.2(33)XNE with support for IS-IS on the Cisco 10000 series router.

              This feature was integrated into Cisco IOS Release 12.3(14)T with support for OSPF.

              In Release 15.0(1)M, support for IS-IS was added.

              In Release 15.0(1)S, support for IS-IS was added for the 7600 Series Routers.

              This feature was integrated into Cisco IOS XE Release 2.5 with support for IS-IS on the Cisco ASR 1000 Series Routesr.

              In Cisco IOS XE Release 3.6S, IS-IS support was added for the Cisco ASR 903 Router.

              The following commands were modified: mpls ldp autoconfig, mpls ldp igp autoconfig, show isis mpls ldp, show mpls ldp discovery.