MPLS Label Distribution Protocol Configuration Guide, Cisco IOS XE Release 3S (Cisco ASR 1000)
MPLS LDP IGP Synchronization
Downloads: This chapterpdf (PDF - 1.26MB) The complete bookPDF (PDF - 3.32MB) | The complete bookePub (ePub - 458.0KB) | Feedback

MPLS LDP IGP Synchronization

Contents

MPLS LDP IGP Synchronization

The MPLS LDP IGP Synchronization feature ensures that the Label Distribution Protocol (LDP) is fully established before the Interior Gateway Protocol (IGP) path is used for switching.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for MPLS LDP IGP Synchronization

  • This feature is supported only on interfaces running Open Shortest Path First (OSPF) or Intermediate System-to-System (IS-IS) processes.
  • This feature works when LDP is enabled on interfaces with either the mpls ip or mpls ldp autoconfig command.

Restrictions for MPLS LDP IGP Synchronization

  • This feature is not supported on tunnel interfaces or LC-ATM interfaces.
  • This feature is not supported with interface-local label space or downstream-on-demand (DoD) requests.
  • This feature does not support targeted Label Distribution Protocol (LDP) sessions. Therefore, Any Transport over MPLS (AToM) sessions are not supported.
  • The Tag Distribution Protocol (TDP) is not supported. You must specify that the default label distribution protocol is LDP for a device or for an interface.

Information About MPLS LDP IGP Synchronization

How MPLS LDP IGP Synchronization Works

Packet loss can occur because the actions of the Interior Gateway Protocol (IGP) and the Label Distribution Protocol (LDP) are not synchronized. Packet loss can occur in the following situations:

  • When an IGP adjacency is established, the device begins forwarding packets using the new adjacency before the LDP label exchange completes between the peers on that link.
  • If an LDP session closes, the device continues to forward traffic using the link associated with the LDP peer rather than an alternate pathway with a fully synchronized LDP session.

The MPLS LDP IGP Synchronization feature does the following:

  • Provides a means to synchronize LDP and IGPs to minimize Multiprotocol Label Switching (MPLS) packet loss.
  • Enables you to globally enable LDP IGP synchronization on each interface associated with an IGP Open Shortest Path First (OSPF) or Intermediate System-to-Intermediate System (IS-IS) process.
  • Provides a means to disable LDP IGP synchronization on interfaces that you do not want enabled.
  • Prevents MPLS packet loss due to synchronization conflicts.
  • Works when LDP is enabled on interfaces using either the mpls ip or mpls ldp autoconfig command.

To enable LDP IGP synchronization on each interface that belongs to an OSPF or IS-IS process, enter the mpls ldp sync command. If you do not want some of the interfaces to have LDP IGP synchronization enabled, issue the no mpls ldp igp sync command on those interfaces.

If the LDP peer is reachable, the IGP waits indefinitely (by default) for synchronization to be achieved. To limit the length of time the IGP session must wait, enter the no mpls ldp igp sync holddown command. If the LDP peer is not reachable, the IGP establishes the adjacency to enable the LDP session to be established.

When an IGP adjacency is established on a link but LDP IGP synchronization is not yet achieved or is lost, the IGP advertises the max-metric on that link.

MPLS LDP IGP Synchronization with Peers

When the MPLS LDP IGP Synchronization feature is enabled on an interface, the Label Distribution Protocol (LDP) determines if any peer connected by the interface is reachable by looking up the peer's transport address in the routing table. If a routing entry (including longest match or default routing entry) for the peer exists, LDP assumes that LDP Interior Gateway Protocol (IGP) synchronization is required for the interface and notifies the IGP to wait for LDP convergence.

LDP IGP synchronization with peers requires that the routing table be accurate for the peer's transport address. If the routing table shows there is a route for the peer's transport address, that route must be able to reach the peer's transport address. However, if the route is a summary route, a default route, or a statically configured route, it may not the correct route for the peer. You must verify that the route in the routing table can reach the peer’s transport address.

When the routing table has an inaccurate route for the peer’s transport address, LDP cannot set up a session with the peer, which causes the IGP to wait for LDP convergence unnecessarily for the sync hold-down time.

MPLS LDP IGP Synchronization Delay Timer

The MPLS LDP IGP Synchronization feature provide the option to configure a delay time for Multiprotocol Label Switching (MPLS) Label Distribution Protocol (LDP) and Interior Gateway Protocol (IGP) synchronization on an interface-by-interface basis. If you want to configure a delay time on an interface, use the mpls ldp igp sync delay delay-time command in interface configuration mode. To remove the delay timer from a specified interface, enter the no mpls ldp igp sync delay command. This command sets the delay time to 0 seconds, but leaves MPLS LDP IGP synchronization enabled.

When LDP is fully established and synchronized, LDP checks the delay timer:

  • If you configured a delay time, LDP starts the timer. When the timer expires, LDP checks that synchronization is still valid and notifies the Open Shortest Path First (OSPF) process.
  • If you did not configure a delay time, if synchronization is disabled or down, or if an interface was removed from an IGP process, LDP stops the timer and immediately notifies the OSPF process.

If you configure a new delay time while a timer is running, LDP saves the new delay time but does not reconfigure the running timer.

MPLS LDP IGP Synchronization Incompatibility with IGP Nonstop Forwarding

The MPLS LDP IGP Synchronization feature is not supported during the startup period if the Interior Gateway Protocol (IGP) nonstop forwarding (NSF) is configured. The MPLS LDP IGP Synchronization feature conflicts with IGP NSF when the IGP is performing NSF during startup. After the NSF startup is complete, the MPLS LDP IGP Synchronization feature is supported.

MPLS LDP IGP Synchronization Compatibility with LDP Graceful Restart

LDP Graceful Restart protects traffic when a Label Distribution Protocol (LDP) session is lost. If an interface that supports a Graceful Restart-enabled LDP session fails, MPLS LDP IGP synchronization is still achieved on the interface while it is protected by Graceful Restart. MPLS LDP IGP synchronization is eventually lost under the following circumstances:

  • If LDP fails to restart before the LDP Graceful Restart reconnect timer expires.
  • If an LDP session restarts through other interfaces, but the LDP session on the protected interface fails to recover when the LDP Graceful Restart recovery timer expires.

How to Configure MPLS LDP IGP Synchronization

Configuring MPLS LDP IGP Synchronization with OSPF Interfaces

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    mpls ip

    4.    mpls label protocol ldp

    5.    interface type number

    6.    ip address prefix mask

    7.    mpls ip

    8.    exit

    9.    router ospf process-id

    10.    network ip-address wildcard-mask area area-id

    11.    mpls ldp sync

    12.    end


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 mpls ip


    Example:
    Device(config)# mpls ip
     

    Globally enables hop-by-hop forwarding.

     
    Step 4 mpls label protocol ldp


    Example:
    Device(config)# mpls label protocol ldp
     

    Specifies the Label Distribution Protocol (LDP) as the default protocol.

     
    Step 5 interface type number


    Example:
    Device(config)# interface POS 3/0
     

    Specifies the interface to configure, and enters interface configuration mode.

     
    Step 6 ip address prefix mask


    Example:
    Device(config-if)# ip address 10.0.0.11 255.255.255.255
     

    Assigns an IP address to the interface.

     
    Step 7 mpls ip


    Example:
    Device(config-if)# mpls ip
     

    Enables hop-by-hop forwarding on the interface.

     
    Step 8 exit


    Example:
    Device(config-if)# exit
     

    Returns to global configuration mode.

     
    Step 9 router ospf process-id


    Example:
    Device(config)# router ospf 1 
     

    Enables Open Shortest Path First (OSPF) routing, and enters router configuration mode.

     
    Step 10 network ip-address wildcard-mask area area-id


    Example:
    Device(config-router)# network 10.0.0.0 0.0.255.255 area 3
     

    Specifies the interface on which OSPF runs and defines the area ID for that interface.

     
    Step 11 mpls ldp sync


    Example:
    Device(config-router)# mpls ldp sync
     

    Enables the Multiprotocol Label Switching (MPLS) Interior Gateway Protocol (IGP) synchronization for interfaces belonging for an OSPF or an Intermediate System-to-Intermediate System (IS-IS) process.

     
    Step 12 end


    Example:
    Device(config-router)# end
     

    Returns to privileged EXEC mode.

     

    Disabling MPLS LDP IGP Synchronization from Some OSPF Interfaces

    When you issue the mpls ldp sync command, all of the interfaces that belong to an Open Shortest Path First (OSPF) process are enabled for Label Distribution Protocol (LDP) Interior Gateway Protocol (IGP) synchronization. To remove LDP IGP synchronization from some interfaces, use the no mpls ldp igp sync command on those interfaces.

    Perform the following task to disable LDP IGP synchronization from some OSPF interfaces after they are configured with LDP IGP synchronization through the mpls ldp sync command.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    no mpls ldp igp sync

      5.    end


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type number


      Example:
      Device(config)# interface POS 0/3/0
       

      Specifies the interface to configure, and enters interface configuration mode.

       
      Step 4 no mpls ldp igp sync


      Example:
      Device(config-if)# no mpls ldp igp sync
       

      Disables MPLS LDP IGP synchronization for that interface.

       
      Step 5 end


      Example:
      Device(config-if)# end
       

      Returns to privileged EXEC mode.

       

      Verifying MPLS LDP IGP Synchronization with OSPF

      After you configure the interfaces for the Label Distribution Protocol (LDP), Open Shortest Path First (OSPF), and LDP Interior Gateway Protocol (IGP) synchronization, verify that the configuration is working correctly by using the show mpls ldp igp sync and show ip ospf mpls ldp interface commands.

      SUMMARY STEPS

        1.    enable

        2.    show mpls ldp igp sync

        3.    show ip ospf mpls ldp interface

        4.    exit


      DETAILED STEPS
        Step 1   enable

        Enables privileged EXEC mode. Enter your password if prompted.



        Example:
        Device> enable
        Device#
        
        Step 2   show mpls ldp igp sync

        Shows that the Multiprotocol Label Switching (MPLS) LDP IGP synchronization is configured correctly because LDP is configured and the SYNC status shows that synchronization is enabled.



        Example:
        Device# show mpls ldp igp sync
        
        FastEthernet0/0/0:
         LDP configured;  SYNC enabled.
         SYNC status: sync achieved; peer reachable.
         IGP holddown time: infinite.
         Peer LDP Ident: 10.0.0.1:0
         IGP enabled: OSPF 1
        

        If MPLS LDP IGP synchronization is not enabled on an interface, the output appears as follows:



        Example:
        FastEthernet0/3/1:
         LDP configured; LDP-IGP Synchronization not enabled.
        
        Step 3   show ip ospf mpls ldp interface

        Shows that the interfaces are properly configured.



        Example:
        Device# show ip ospf mpls ldp interface
        
        FastEthernet0/3/1
          Process ID 1, Area 0
          LDP is configured through LDP autoconfig
          LDP-IGP Synchronization: Yes
          Holddown timer is not configured
          Timer is not running
        FastEthernet0/0/2
          Process ID 1, Area 0
          LDP is configured through LDP autoconfig
          LDP-IGP Synchronization: Yes
          Holddown timer is not configured
          Timer is not running 
        
        Step 4   exit

        Returns to user EXEC mode.



        Example:
        Device# exit
        Device>
        

        Configuring MPLS LDP IGP Synchronization with IS-IS Interfaces

        Configuring MPLS LDP IGP Synchronization on All IS-IS Interfaces

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    mpls ip

          4.    mpls label protocol ldp

          5.    router isis process-name

          6.    mpls ldp sync

          7.    interface type number

          8.    ip address prefix mask

          9.    ip router isis process-name

          10.    end


        DETAILED STEPS
            Command or Action Purpose
          Step 1 enable


          Example:
          Device> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Device# configure terminal
           

          Enters global configuration mode.

           
          Step 3 mpls ip


          Example:
          Device(config)# mpls ip
           

          Globally enables hop-by-hop forwarding.

           
          Step 4 mpls label protocol ldp


          Example:
          Device(config)# mpls label protocol ldp
           

          Specifies the Label Distribution Protocol (LDP) as the default label distribution protocol.

           
          Step 5 router isis process-name


          Example:
          Device(config)# router isis ISIS
           

          Enables the Intermediate System-to-Intermediate System (IS-IS) protocol on the device, specifies an IS-IS process, and enters router configuration mode.

           
          Step 6 mpls ldp sync


          Example:
          Device(config-router)# mpls ldp sync
           

          Enables Multiprotocol Label Switching (MPLS) LDP Interior Gateway Protocol (IGP) synchronization on interfaces belonging to an IS-IS process.

           
          Step 7 interface type number


          Example:
          Device(config-router)# interface POS 0/3/0
           

          Specifies the interface to configure, and enters interface configuration mode.

           
          Step 8 ip address prefix mask


          Example:
          Device(config-if)# ip address 10.25.25.11 255.255.255.0
           

          Assigns an IP address to the interface.

           
          Step 9 ip router isis process-name


          Example:
          Device(config-if)# ip router isis ISIS
           

          Enables IS-IS.

           
          Step 10 end


          Example:
          Device(config-if)# end
           

          Returns to privileged EXEC mode.

           

          Configuring MPLS LDP IGP Synchronization on an IS-IS Interface

          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    interface type number

            4.    ip address prefix mask

            5.    ip router isis

            6.    exit

            7.    router isis

            8.    mpls ldp sync

            9.    end


          DETAILED STEPS
              Command or Action Purpose
            Step 1 enable


            Example:
            Device> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.
             
            Step 2 configure terminal


            Example:
            Device# configure terminal
             

            Enters global configuration mode.

             
            Step 3 interface type number


            Example:
            Device(config)# interface POS 0/2/0
             

            Specifies the interface to configure, and enters interface configuration mode.

             
            Step 4 ip address prefix mask


            Example:
            Device(config-if)# ip address 10.50.72.4 255.0.0.0
             

            Assigns an IP address to the interface.

             
            Step 5 ip router isis


            Example:
            Device(config-if)# ip router isis
             

            Enables the Intermediate System-to-Intermediate System (IS-IS) protocol for IP on the interface.

             
            Step 6 exit


            Example:
            Device(config-if)# exit
             

            Returns to global configuration mode.

             
            Step 7 router isis


            Example:
            Device(config)# router isis
             

            Enters router configuration mode, and enables an IS-IS process on the device.

             
            Step 8 mpls ldp sync


            Example:
            Device(config-router)# mpls ldp sync 
             

            Enables Label Distribution Protocol (LDP) Interior Gateway Protocol (IGP) synchronization for interfaces belonging to an IS-IS process.

             
            Step 9 end


            Example:
            Device(config-router)# end
             

            Returns to privileged EXEC mode.

             

            Disabling MPLS LDP IGP Synchronization from Some IS-IS Interfaces

            When you issue the mpls ldp sync command, all of the interfaces that belong to an Intermediate System-to-Intermediate System (IS-IS) process are enabled for Label Distribution Protocol (LDP) Interior Gateway Protocol (IGP) synchronization. To remove LDP IGP synchronization from some interfaces, use the no mpls ldp igp sync command on those interfaces.

            Perform the following task to disable LDP IGP synchronization from some IS-IS interfaces after they are configured with LDP IGP synchronization through the mpls ldp sync command.

            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    interface type number

              4.    no mpls ldp igp sync

              5.    end


            DETAILED STEPS
                Command or Action Purpose
              Step 1 enable


              Example:
              Device> enable
               

              Enables privileged EXEC mode.

              • Enter your password if prompted.
               
              Step 2 configure terminal


              Example:
              Device# configure terminal
               

              Enters global configuration mode.

               
              Step 3 interface type number


              Example:
              Device(config)# interface POS 0/3/0
               

              Specifies the interface to configure, and enters interface configuration mode.

               
              Step 4 no mpls ldp igp sync


              Example:
              Device(config-if)# no mpls ldp igp sync
               

              Disables Multiprotocol Label Switching (MPLS) LDP IGP synchronization for that interface.

               
              Step 5 end


              Example:
              Device(config-if)# end
               

              Returns to privileged EXEC mode.

               

              Troubleshooting Tips

              Use the debug mpls ldp igp sync command to display events related to MPLS LDP IGP synchronization.

              Configuration Examples for MPLS LDP IGP Synchronization

              Example: MPLS LDP IGP Synchronization with OSPF

              The following task shows how to enable the Label Distribution Protocol (LDP) for Open Shortest Path First (OSPF) process 1. The mpls ldp sync and the OSPF network commands enable LDP on interfaces POS0/0/0, POS0/1/0, and POS1/1/0, respectively. The no mpls ldp igp sync command on interface POS1/0/0 prevents LDP from being enabled on interface POS1/0/0, even though OSPF is enabled for that interface.

              Device# configure terminal 
              Device(config)# interface POS0/0/0 
              Device(config-if)# ip address 10.0.0.1 
              Device(config-if)# mpls ip
              !
              Device(config)# interface POS0/1/0 
              Device(config-if)# ip address 10.0.1.1
              Device(config-if)# mpls ip
              !
              Device(config)# interface POS1/1/0
              Device(config-if)# ip address 10.1.1.1
              Device(config-if)# mpls ip
              !
              Device(config)# interface POS1/0/0 
              Device(config-if)# ip address 10.1.0.1
              Device(config-if)# mpls ip
              !
              Device(config)# router ospf 1
              Device(config-router)# network 10.0.0.0 0.0.255.255 area 3
              Device(config-router)# network 10.1.0.0 0.0.255.255 area 3
              Device(config-router)# mpls ldp sync
              Device(config-router)# exit
              Device(config)# interface POS1/0/0 
              Device(config-if)# no mpls ldp igp sync
               

              Example: MPLS LDP IGP Synchronization with IS-IS

              The following examples show the configuration commands you can use to configure MPLS LDP IGP synchronization on interfaces POS0/2 /0 and POS0/3/0, which are running IS-IS processes:

              Device# configure terminal 
              Enter configuration commands, one per line.  End with CNTL/Z.
              Device(config)# interface POS0/2/0 
              Device(config-if)# ip router isis 
              Device(config-if)# exit
              Device(config)# router isis 
              Device(config-router)# mpls ldp sync 
              Device(config-router)# exit
              .
              .
              .
              Device(config)# interface POS0/3/0
              Device(config-if)# ip router isis
              Device(config-if)# exit
              Device(config)# router isis
              Device(config-router)# mpls ldp sync
              Device(config-router)# exit
              Device(config) exit
              Device#

              Additional References

              Related Documents

              Related Topic

              Document Title

              Cisco IOS commands

              Cisco IOS Master Command List, All Releases

              MPLS LDP commands

              Cisco IOS Multiprotocol Label Switching Command Reference

              LDP autoconfiguration

              “MPLS LDP Autoconfiguration” module in the MPLS Label Distribution Protocol Configuration Guide

              Standards and RFCs

              Standard/RFC

              Title

              RFC 3037

              LDP Applicability

              RFC 5036

              LDP Specification

              MIBs

              MIBs

              MIBs Link

              MPLS LDP MIB

              To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

              http:/​/​www.cisco.com/​go/​mibs

              Technical Assistance

              Description

              Link

              The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

              http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

              Feature Information for MPLS LDP IGP Synchronization

              The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

              Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

              Table 1 Feature Information for MPLS LDP IGP Synchronization

              Feature Name

              Releases

              Feature Information

              MPLS LDP IGP Synchronization

              12.0(30)S

              12.0(32)SY

              12.2(33)SB

              12.2(33)SRB

              12.3(14)T

              15.0(1)M

              15.1(1)SY

              Cisco IOS XE Release 2.5

              Cisco IOS XE Release 3.6S

              The MPLS LDP IGP Synchronization feature ensures that LDP is fully established before the IGP path is used for switching.

              In 12.0(30)S, this feature was introduced.

              In 12.0(32)SY, support for enabling synchronization on interfaces running Intermediate System-to-System (IS-IS) processes was added.

              In 12.2(33)SB, the feature was integrated. MPLS LDP IGP synchronization for IS-IS is not supported in this release.

              In 12.2(33)SRB, the feature was integrated. MPLS LDP IGP synchronization for IS-IS is not supported in this release.

              In 12.3(14)T, this feature was integrated. MPLS LDP IGP synchronization for IS-IS is not supported in this release.

              In 15.0(1)M, support for enabling synchronization on interfaces running IS-IS processes was added.

              In 15.1(1)SY, support for configuring MPLS LDP IGP synchronization with OSPF and IS-IS interfaces was enabled.

              In Cisco IOS XE Release 2.5, support for configuring MPLS LDP IGP synchronization with IS-IS interfaces was implemented on Cisco ASR 1000 Series Routers.

              In Cisco IOS XE Release 3.6S, support for configuring MPLS LDP IGP synchronization was added for the Cisco ASR 903 Router.

              The following commands were modified: debug mpls ldp igp sync, mpls ldp igp sync, mpls ldp igp sync holddown, mpls ldp sync, show ip ospf mpls ldp interface, show isis mpls ldp, and show mpls ldp igp sync.